1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Switched from DD-WRT to Tomato, now stunnel not working. Please help.

Discussion in 'Tomato Firmware' started by dontbotherme, Jan 24, 2008.

  1. dontbotherme

    dontbotherme Network Guru Member

    I was forced to replace my Buffalo router (running DD-WRT) with a WRT54G (v4) and decided it would be a good time to try out Tomato. The WRT54G was still running the stock linksys firmware, I flashed it with 1.14 and everything went fine. Except, now I'm having some major issues with stunnel.

    I use stunnel to allow me to run GrabIt (usenet downloader) via SSL. Everything worked fine with DD-WRT, but now no matter what I do I can't seem to connect to my usenet provider. I'm not sure what information is needed to diagnose this, but I figured it probably has something to do with Tomato's firewall and/or NAT Loopback feature...but I've tried all three NAT settings with no luck.

    If someone can help me get this straightened out I would really appreciate it. Otherwise I'll have to go back to DD-WRT. Please let me know what information you need and I'll be glad to provide it.

    This is the main error message I seem to get from stunnel's logs:

    SSL_connect: Peer suddenly disconnected

    Thanks
     
  2. srouquette

    srouquette Network Guru Member

    maybe you need to configure your timeouts : http://192.168.1.1/advanced-ctnf.asp
    Max conn: 2048
    For TCP, I have 1800, 3600, 120, 60, 120, 120, 10, 60, 30, 120.
    And for UDP, I have 10, 300.
     
  3. mstombs

    mstombs Network Guru Member

    I suggest you try enabling the GRE / PPTP firewall Tracking / NAT Helper, under advanced Conntrack/Netfilter.

    The helpers are disabled by default to save memory and not introduce any unnecessary potential security hole.
     
  4. dontbotherme

    dontbotherme Network Guru Member

    Thanks - I'll try both these things when I get home tonight.
     

Share This Page