1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Switchport #1 Problem with WRT54GS 1.1 and Sveasoft Alchemy

Discussion in 'Cisco/Linksys Wireless Routers' started by shapeshifter, May 17, 2005.

  1. shapeshifter

    shapeshifter Network Guru Member


    A friend of mine just bought a Linksys WRT54GS V1.1. He already updated the firmware to some Sveasoft Alchemy release. After configuring the device it worked flawlessly, then he left for the weekend and when he got back there was a problem. A computer connected at port #1 of the switch cannot access the internet or the local lan. If the cable is put on another port everything is fine again. Back on port #1, network interface goes up again in windows but no access to internet or local lan. He has static IP's on his computers, and the computer on port #1 see's MAC addresses of other computers on his lan, but can't ping them. Can this be a hardware defect ??? It seems weird to me because the computer connected to port #1 sees other MAC addresses but can't access them (ping, etc...). I have to admit that he doesn't have a strong computer/networking experience, so he came to my place today and we connected the router to my home network whih has a linux firewall and server. I put the uplink to my network on port #1 of the linksys, and to another port I connected my laptop. The laptop wasn't able to get an IP using DHCP from my firewall until I connected the uplink to my network to another port than port #1. But I also saw MAC addresses of my firewall and another computer. While checking the settings of the router I found a lot of stuff which looked weird, and after asking him if he ever went through the documentation and getting the answer of no I made him leave my place. I don't have a linksys router myself, nor do I know about setting them up.
    Do you think this port #1 problem is a hardware defect or is it just some configuration issue which can be fixed ???

    Thanks for your help.

  2. Guyfromhe

    Guyfromhe Network Guru Member

    i'd revert to linksys firmware and reset to factory defaults and see if the problem goes away if it does then reinstall sveasoft.
  3. shapeshifter

    shapeshifter Network Guru Member

    Yeah, I know this would be somehow the next logical step to test if it's a hardware defect. I guess my friend didn't try up to now, and again he won't until someone tells him.
    When I went through the configuration I have seen that he has given the IP to the Router's ethernet interface, then the mask of and as a standard gateway to the router's interface he also used the Somehow I cannot believe that this is right, but he told me the router worked for some hours or even days before he left for the long weekend.
  4. jagboy

    jagboy Network Guru Member

    maybe it could be a firmware problem becuase i know that some of the new WRT54G routers will stop working with the ethernet chip becuase the firmware does not support it.

Share This Page