1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Talisman wrt54g v4 support

Discussion in 'Sveasoft Firmware' started by tomgrossi, Sep 26, 2005.

  1. tomgrossi

    tomgrossi Network Guru Member

    Any news on when v4 support will be out for Talisman. It seems to be on their development schedule but when I wrote them they never responded.
  2. Toxic

    Toxic Administrator Staff Member

    until a new version of Talisman is released there is no real support for it. afaik v1.05 is the latest. though dont take that for granted.
  3. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Latest updates state Talisman will support the newer hardware versions just released including the v4(v5 units unknown to me). The main issue is the newer units are using an newer BCM5350 chipset that has much more built in.

    Ethernet controller
    MIPS processor
    hardware crypto
    VPN acceleration.

    The fact is the developers will not acknowledge official support until they test and verify the hardware themselves. So until the sveasoft team says it supports it, it is speculation and may or may not work. That asside, they are working on implementing a new driver (which may even be their own developed) into the firmware which will be able to support all chipsets. Bare minimum, the new drivers from the linksys 4.x firmware will be added in, so yes it should work on your hardware.

    1.05 is still the lates Talisman release BTW.
  4. TommyRox

    TommyRox Network Guru Member

    Any updates in the V.4 support?
  5. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Talisman 1.1 supports both the G ans GS v4.0
  6. TommyRox

    TommyRox Network Guru Member

    Thanks !!

Share This Page