1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The WPA2 of Toastman 7633.3 ?

Discussion in 'Tomato Firmware' started by jbcdidgosir, May 25, 2013.

  1. jbcdidgosir

    jbcdidgosir Serious Server Member

    I used to use Toastman 7633.3. Today I upgraded the FW to 7634. After that I found that one notebook(A) couldn't connect to the wireless network. While another notebook(B) with same brand, same type still can connect to the wireless network.

    After comparing the difference between these two notebook, I found that the only difference is: the OS of A is XP SP2. The OS of B is XP SP3. After installing the patch:WindowsXP-KB893357-v2-x86-CHS.exe, problem solved.

    Then I have a question: since XP SP2 doesn't support WPA2. Why A still could connect the wireless network with FW 7633.3? Does it mean 7633.3 is not a TRUE WPA2, still work on WEP?
  2. RMerlin

    RMerlin Network Guru Member

    What is your router settings? For WPA2 to work, you must also have encryption set to AES. TKIP is only supported under WPA.

    Pretty sure your computer wasn't using WEP, since you cannot have both WEP and WPA/WPA2 at the same time. You were most likely connected using WPA instead of WPA2.

  3. jbcdidgosir

    jbcdidgosir Serious Server Member

    The settings on both 7633.3 & 7634 are same:
    Security: WPA2 Personal
    Encryption: TKIP/AES

    I know that router can't work on both WEP and WPA/WPA2. I just guess that 7633.3 was working on WEP. So both A & B can connect to this wireless. After the update, router begins to work on WPA/WPA2, so B can still connect because it's SP3, but A couldn't because it's SP2.
  4. lancethepants

    lancethepants Network Guru Member

    From what RMerlin says, you should probably set it to AES only for WPA2, if you want to force all connections to WPA2.

    Funny that you can set WPA2 Personal, but then essentially bypass this by enabling TKIP/AES. I guess in the cases of devices that do not support WPA2, since you allow TKIP, it must fall back to WPA from the sounds of it. Not like a huge security risk, but maybe a change in the GUI or a notice is in order.

    edit: In my case, I have a roomate with a PSP which apparently does not work with WPA2. I had my settings set to WPA2 and AES only, and he was unable to connect. I then changed it to WPA/WPA2 with AES, and that fixed it for him.

    Your settings in either case, using TKIP/AES, should have allowed for either computer to connect on WPA anyway, not sure what the issues would have been then.

Share This Page