1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Thibor13c is out

Discussion in 'HyperWRT Firmware' started by dirtyclyde, Feb 3, 2006.

  1. dirtyclyde

    dirtyclyde Network Guru Member

    Thibor13c is out

    Changelog from Thibor:
    * Incorporated changes from tofu 13c
    * Upgraded Dropbear to version 0.47
    * Changed SSH remote management behavior and display
     
  2. purephase

    purephase Network Guru Member

    Upgrade from 13a went perfectly, thanks for changing the SSH remote management behaviour!
     
  3. Toxic

    Toxic Administrator Staff Member

    Added to downloads section
     
  4. JohnnyCanuck

    JohnnyCanuck Network Guru Member

    Newbie question ... and it may be dumb

    I have upgraded to 13a without a problem on my GSv4 using the v4 download. To go to 13c, do I use the v4 download, or the general one? Also, if I am going from one Thibor build to another, do I need to go back to factory defaults?

    Thanks
     
  5. purephase

    purephase Network Guru Member

    Use the v4 download if you have a v4 gs router (since you already flashed with that version, I would assume you do). I haven't had to reset to factory defaults in the last 3-4 releases and everything has worked fine.
     
  6. JohnnyCanuck

    JohnnyCanuck Network Guru Member

    Thanks pure
     
  7. bat420

    bat420 Network Guru Member

    running it now
     
  8. dragon67

    dragon67 Network Guru Member

    up and running. Work great so far. Great job Thibor.
     
  9. evil-doer

    evil-doer Network Guru Member

    i havent had my router long, a few weeks, i flashed to dd-wrt the day after i got it, and ive had many problems and really didnt like how the web pages were set up, etc, etc. so i flashed to thibor13c earlier tonight and wow. its everything i used in dd-wrt plus more stuff i like. and its all aranged nicely in the web interface. bravo! thank you so much for doing this thibor and everyone else involved. i hope you keep this up.

    :clap:
     
  10. madhatter

    madhatter Network Guru Member

    I have just flashed my v4 with the Thibor V4 firmware. I originally used the dd wrt method then the Thibor general firmware not v4 and it worked fine, but then thought well since i have a ver 4 might as well use the specific v4 firmware. So upgraded via web interface and done erase nv etc. Seems to work fine and using it now. Why does the firmware version show ver 4.xx instead of 1.x like before. I thought 1.xx was based on ver4 stock firmware.
     
  11. Thibor

    Thibor Super Moderator Staff Member Member

    what's in a name? a rose by any other name would still smell as sweet...
    i used the code headers of the v4 firmware to create the v4 version, that's why it works for v4
     
  12. jason930

    jason930 Network Guru Member

    i am using GS v4 with "v1.05.6 - HyperWRT 2.1b1 + Thibor12" firmware

    can i use the Thibor13c firmware that downloaded from linsysinfo?
     
  13. purephase

    purephase Network Guru Member

    Yes. Just make sure you use the v4 version of the firmware and you'll be fine.
     
  14. Thibor

    Thibor Super Moderator Staff Member Member

    there seems to be some confusion regarding the v4 firmware. Perhaps i am not making myself clear. I have said more than once now...THE V4 FIRMWARE IS FOR UPGRADING V4 ROUTERS FROM STOCK FIRMWARE. IF YOU HAVE AN EARLIER VERSION OF MY FIRMWARE, USE THE NORMAL VERSION
     
  15. darekd

    darekd Network Guru Member

    I would like to upgrade to Thibor 13c but I would like to know if saved configuration backup is portable from version 12 to version 13c.
     
  16. jason930

    jason930 Network Guru Member

    oh i can see there have Thibor's v13c for GS v4 version now
    try it later :clap:
     
  17. Thibor

    Thibor Super Moderator Staff Member Member

    my site is back up now(for the minute), sources and firmware available there
     
  18. purephase

    purephase Network Guru Member

    It might not be a bad idea to update/remove the announcement for release 11 of this firmware in this forum.
     
  19. shentalus

    shentalus Network Guru Member

    Thibor, the problem with the dropdowns in Firefox seems to have returned. I am using 13c, and have tried to reset to factory defaults and clearing the nvram, but that did not fix it.

    I am using a GS v1.0, but it seems that you do too, so I am not sure how you have not noticed this yet. Maybe I am doing something wrong?

    Thanks for the great firmware. Everything else works fine from what I can tell.
     
  20. Thibor

    Thibor Super Moderator Staff Member Member

    reset to defaults, or check nvram variable noffx, it should be 1
     
  21. shentalus

    shentalus Network Guru Member

    Looks like my browser was just caching the old pages. Just needed a press of the Refresh button in Firefox. It's all good now.
     
  22. Thibor

    Thibor Super Moderator Staff Member Member

    "so I am not sure how you have not noticed this yet"
    hmm, that would appear to be because it wasn't there :)
     
  23. zaphod

    zaphod Network Guru Member

    :rofl:
     
  24. shentalus

    shentalus Network Guru Member

    Actually, I am still getting the dropdown problem, even after fully clearing my cache. The refresh button only helps temporarily, meaning if i navagate away from and then back to the page then I will need to press the refresh button on my browser to get the values to show up.
     
  25. Thibor

    Thibor Super Moderator Staff Member Member

    then either reset to defaults or set the nvram variable noffx=1 like i said earlier
     
  26. shentalus

    shentalus Network Guru Member

    I already did this. Didn't help.
     
  27. Thibor

    Thibor Super Moderator Staff Member Member

    i'll check my sources but i use firefox1.5 and i don't see an issue here
     
  28. shentalus

    shentalus Network Guru Member

    I just tested out Firefox 1.0.7 vs. 1.5.0.1, and the problem only occurs in 1.0.7.
     
  29. Thibor

    Thibor Super Moderator Staff Member Member

    i know
     
  30. purephase

    purephase Network Guru Member

    I still think the announcement for Thibor11 in the parent thread for HyperWRT should probably be updated. It was a decent release, but this version is even better.
     
  31. shentalus

    shentalus Network Guru Member

    Thibor, I think I might have finally figured out what is causing the dropdown problem. The common.js file that is included in your sources for 13c does not appear to be ending up in the compiled bin file.

    In fact, the common.js file that can be seen at http://192.168.1.1/common.js when running 13c is the exact same file as the one that is included in the official 4.70.8 firmware.

    I would appreciate if you could verify this for me. I know I'm not crazy, because I've seen a couple other people also have this problem with your v13 releases.
     
  32. Thibor

    Thibor Super Moderator Staff Member Member

    confirmed, 13d available later
     
  33. galileo2000

    galileo2000 Network Guru Member

    Flashed my WRT54GL yesterday, works excellent.

    The only issue I have it doesn't look right from Pocket PC IE.

    I use NetFront and all is cool.

    Is it because PocketPC IE does not have Java/Javascript support?

    Anyway, excellent job Thibor.
     
  34. clone

    clone Network Guru Member

    Works great,
    iptables mangle solved a lot for me.

    Only problem was Access Restrictions didn't work with Firewall Protection disabled.

    But still topnodge.
     
  35. Thibor

    Thibor Super Moderator Staff Member Member

    it's not a bug. the access restrictions are firewall rules matched by time, mac and webstr. they cannot possibly work if the firewall is disabled.
     

Share This Page