1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Thibor15c

Discussion in 'HyperWRT Firmware' started by Thibor, May 10, 2006.

  1. Thibor

    Thibor Super Moderator Staff Member Member

    Now before you get excited, 15c isn't out yet
    I'll update this post as and when to let you know what changes will be implemented in 15c from 15b3.
    Replies in this topic are not required as i will update this post when i see something has has to be changed. Once 15c is released as bug free as possible i'll post the sources on my site and start work on the WRT300N

    so here goes:
    • QoS.asp: Online Games, Mac Address and Ethernet port background will be grey as Application choices are
      DMZ.asp: input boxes will be the correct size.
      Adding Battlefield 2 and BF1942 layer7 matches to Applications
      Adding Counter Strike, CS:Source and MSN File Transfers to App list

    i am NOT going to add any further matches to the Applications menu, it is starting to get very long
     
  2. ndata

    ndata Network Guru Member

    sounds good to me. thanks man
     
  3. JeFFJuH

    JeFFJuH Network Guru Member

    Looks like Thibor15c has been released :thumb:
    Let me install it in a moment..
     
  4. Thibor

    Thibor Super Moderator Staff Member Member

    why? i thought you were going back to stock fw?
     
  5. JeFFJuH

    JeFFJuH Network Guru Member

    Yes, because I had some problems with the HyperWRT fw, but after playing around with some settings, I solved it myself :)

    No need to go back to stock n e more :)
     
  6. prowler1968

    prowler1968 Network Guru Member

    I've got to say - Thibor 15c ROCKS!

    I tested the new DMZ by opening one PC to ip address 4.79.142.206 which is the IP address for ShieldsUP testing. The first 1056 ports that it tests showed up as closed, not stealth. When I put a trusted IP address in there instead of the ShieldsUP, I tested all ports on Stealth.

    Now with this setup, I can fully open ALL ports between home office and work office without having to specify anything in the port forwarding setup.

    Thanks for everything Thibor - I've been using your firmware since 12+WOL and it just keeps getting better with each new build. I hope to get you another donation out soon. I keep thinking about newer routers, but without your firmware, I'd be moving DOWN, not UP. Only the SL would do I suppose!
     
  7. Thibor

    Thibor Super Moderator Staff Member Member

    i have a WRT300N now, i will be working on that, and 15c for the WRTSL now that 15c is out
     
  8. JeFFJuH

    JeFFJuH Network Guru Member

    Good luck! :thumb:
    Same as prowler1968. I haven't been using your firmware a long time, but I am really happy with it. I had a few problems, but playing around with settings fixed it :D

    My donation is coming to you really soon..
     
  9. lwf-

    lwf- Network Guru Member

    Thank you!

    I see that Counter-Strike is now included as a L7-filter. Not really my favourite game, but does it also picks up Half-Life (1)? That would make me a somewhat happier gamer when I feel like swinging the crowbar once in a while. :grin:
     
  10. prowler1968

    prowler1968 Network Guru Member

    The selection box for QOS does have Halflife as a preset.

    You also have the option to add a new game and enter the port usage to optimize for games that are not on the list.
     
  11. myersw

    myersw Network Guru Member

    Interesting. I see folks talking about downloading and installing 15c but when I go to Thibor's site all I see is 15b3.
    Where are you getting the 15c? Or did Thibor send a prerelease copy to folks with QOS problems for testing?
    --bill
     
  12. ofbarea

    ofbarea Network Guru Member

    Thibor, Does the WRT300N really have 4 times the range over the WRT54Gx?
     
  13. prowler1968

    prowler1968 Network Guru Member

    Go to http://www.thibor.co.uk and if it still shows 13b as the download, click refresh to force your browser to update the page. Also, be sure that you are not looking at the section that has Older Versions. There is a table that has the router model that you want to upgrade and then a link to the correct firmware for your model.
     
  14. tstrike2000

    tstrike2000 Network Guru Member

    First I want to again thank Thibor the amount of work he's put into the Hyperwrt project and especially version 15 with all the changes and updates. You trully have a talent and experience that I do not have. I've used Thibor14 on my WRT54GS v4 for the past month and it's been awesome, extremely stable, stable with BitTorrent, and better throughput over my previous router.

    Ok, finally to my question. I did test for a few days the intial Thibor15 and didn't notice any problems with QoS performance although robsonn initially posted about having performance issues in QoS after upgrading to the first Thibor15. Was there any validity to that or has some of the QoS changes in the Thibor15 updates fix that or is there really no QoS performance between Thibor14 and 15? I apologize to keep asking this.
     
  15. JeFFJuH

    JeFFJuH Network Guru Member

    I would like to increase the transmit power of my wireless connection. I've got it on 67% now, is it safe to put it on 83% or even 100%?

    67% already makes a big difference for me, and 83% would be even better, but will it damage my router?
     
  16. jblade

    jblade Network Guru Member

    I don't completely understand the QoS, but let me get this straight, is there a way I can add my VoIP (which is connected to port 1) To have priority on bandwith? Sick of how if I am using bittorrent, no one can understand me.
     
  17. Linkyguy

    Linkyguy Network Guru Member

    Well, what else is there to do in Manchester? :rofl:
     
  18. JeFFJuH

    JeFFJuH Network Guru Member

    As far as I understand, you can prioritize this device by giving highest priority to the port, or by entering the MAC address and giving it highest priority.
     
  19. Thibor

    Thibor Super Moderator Staff Member Member

    JBlade: select "VOIP" in the drop down menu and put in it's mac address. what's hard to understand about that
     
  20. myersw

    myersw Network Guru Member

    Prowler1986. Thanks for the tip. Went to Thibor's site and did a refresh and low and behold there was 15c. Downloaded but will not be able to install this this eve when I get home.
    --bill
     
  21. lwf-

    lwf- Network Guru Member

    Thanks for the reply!

    As I have understood the options under "Applications" are based on L7-filters and those under "Online Games" are port based. It would be unnecessarily to use many options if they do the same thing, so what I am asking for is if Half-Life is included in the application CounterStrike option. Or maybe I got the L7 based, port based thing all wrong, I don’t know.
     
  22. mstombs

    mstombs Network Guru Member

    I'm sure he only works on Firmware when it is raining!
     
  23. mmisnan

    mmisnan Network Guru Member

    Hey, it was pouring here in Manchester .. and what we got? Yes .. 15c!! Yeah .. but heeh, I'm back to 14 for now .. had problem with my HX4700 couldn't get IP address .. Might be problem with the PDA .. no problem when there isn't any security set .. but with WPA TKIP, it couldn't get IP address at all. 14 for now .. but will try again 15c later tonight.
     
  24. prowler1968

    prowler1968 Network Guru Member

    lwf - I think that you are right - the Applications in QOS are the only items that run with the l7 filters. There is an option to add an application, then you only get port based priority.

    This link http://l7-filter.sourceforge.net/protocols was in another post. I'm not familiar enough with this and I don't know if you can add the l7 filters via script or if they have to be compiled into the firmware. Maybe give that a look and someone more knowledgable can advise you on adding these.
     
  25. Thibor

    Thibor Super Moderator Staff Member Member

    nisman, where are you?
     
  26. lwf-

    lwf- Network Guru Member

    I looked at the link you gave me and the only filter that picks up CS is "quake-halflife" so I guess it includes everything based on the Quake engine, and that’s great! :D

    Adding L7-filters myself? That’s a great idea! Of course I don’t have a clue on how to do it and if it includes modifications in the source I better stay out of it or my router will be dead for sure. If it even compiles that is. ;)
     
  27. Thibor

    Thibor Super Moderator Staff Member Member

    are you saying that the counterstrike match doesn't pick up CS? or the cs:source doesn't do it either?
     
  28. prowler1968

    prowler1968 Network Guru Member

    I hear that - I'd have a brick for sure. Maybe I could get an SL :grin:
     
  29. rljo

    rljo Network Guru Member


    COOL. You rock.
     
  30. lwf-

    lwf- Network Guru Member

    No, I say that the quake-halflife.pat filter is supposed to pick up any Quake/Half-Life and its mods (like Counter-Strike). It was the only filter I found on that page that can find CS traffic so I supposed that it’s the one you used, if that is the way it is a better name would probably be “Quake/Half-Life and mods†or something like that. However I don’t know how to actually test if the traffic is found and dealt with correctly so I neither know if it actually works when I play HL but I suppose it do.
     
  31. d00mzday

    d00mzday Network Guru Member

    As always great work Thibor. I always look forward to every release. I havn't had to much time to test it but in response to 'mmisnan' I just tested my ipaq HX4700 with wpa tkip and it seems to be working fine. (note: my HX4700 is flashed to the latest firmware from HP.)
     
  32. Thibor

    Thibor Super Moderator Staff Member Member

    good, glad to hear it mate. :)
    lwf: there are 2 counter-strike specific protocols, one for cs and one for cs:source as well as the quake/half-life protocol
     
  33. TerminatorHTK

    TerminatorHTK LI Guru Member

    I just downloaded 15c and upgraded. It fixes the QoS and Access Restrictions bug! :cheer:

    Thanks for all the help everyone!
     
  34. jblade

    jblade Network Guru Member

    Sorry I think I get it.

    Thibor anyway you can make it so the : (colons) are grayed out. It would make it a lot easier to type MAC ADDRESSES in if you didnt have to worry about overrighting the : inbetween each 00

    thanks for hte help
     
  35. lwf-

    lwf- Network Guru Member

    Sorry, but I this is making me really confused. :???:

    Counter-Strike is a mod for Half-Life with is based on the Quake engine. Both CS, HL and Quake should be found by quake-halflife.pat. CS and HL is using the same protocol and ports last I checked. So what’s the difference between applications Counter Strike, online games Counter Strike and online games Halflife? Sorry, but this is making me really confused.


    Edit: I looked at the source and came to this conclusion. counterstrike.pat probably doesn’t work since CS doesn’t have much to do with "counter-strike.net" anymore since its all driven by Valves Steam technology. The comments in counterstrike-source.pat also confirm this. The quake-halflife.pat should almost certainly work fine however, it says that is should work with all Half-Life variants and mods. So, what do I have to select in the qos options to use quake-halflife.pat?
     
  36. mmisnan

    mmisnan Network Guru Member

    Did another flash this morning, this time, I cleared everything (nvram) and not using my previous config backup that I have. Deleted the wireless config on my HX4700 too .. and everything is hunky-dory now.
     
  37. Toxic

    Toxic Administrator Staff Member

    yeah you'll find sometimes the backup cfg will conflict with new nvram variables and not work correctly.
     
  38. jblade

    jblade Network Guru Member

    What does WMMM do?
     
  39. n3oNx

    n3oNx Network Guru Member

    How do you close all ports? I tested my connection in the http://probe.hackerwatch.org/probe/probe.asp and it tells me that all my ports are secure but still reachble and mthe port 139 NetBIOS is unsecure.

    In the shields up teste it shows that ports: 135, 139 and 445 are open.
     
  40. Toxic

    Toxic Administrator Staff Member

    i found that site to be very dubious in its results. it told me my port 80 was open, i ran the test again it then said it was closed, then secure, same with ftp.

    i alos tried

    http://scan.sygate.com/

    http://www.dslreports.com/scan

    http://www.grc.com/x/ne.dll?rh1dkyd2

    all gave a different reading and more secure than the first.
     
  41. tstrike2000

    tstrike2000 Network Guru Member

    Under your Security tab, Firewall Protection should be enabled if it already isn't with Block Anonymous Internet Requests, Filter Multicast, and Filter IDENT checked by default.
     
  42. lwf-

    lwf- Network Guru Member

    Might have to do with the portscan blocker. Or maybe DMZ. But I am just guessing.
     
  43. Toxic

    Toxic Administrator Staff Member

    WMM is QoS for Wireless.

    i had explained this on a dd-wrt firmware review some time ago, however, your wireless client also needs to support WMM
     
  44. jblade

    jblade Network Guru Member

    Is there any way to figure this out, would this just be located in the firmware section? I have all linksys wireless cards.
     
  45. n3oNx

    n3oNx Network Guru Member

    It's sorted. For some reason I had the DMZ on for my computer when I know for sure that I disabled it. :p
     
  46. lwf-

    lwf- Network Guru Member

    Is WMM common? I got two Linksys WUSB54GS, one Intel 2200BG and no idea if the has this technology. So I guess they haven’t.
     
  47. Toxic

    Toxic Administrator Staff Member

    WMM is failry new and only been introduced in the newer firmwares. some new broadcom drivers for linksys/belkin and byffalo support WMM on their wireless clients.
     
  48. penkert

    penkert Network Guru Member

    Now that we drifted off to WMM... Is there a way to prioritize WDS connections? I'd really like to give let's say Skype traffic a hiqh priority, HTTP packets a medium, and file transfers a low one. But I don't see how this could be accomplished.
     
  49. adam217

    adam217 Network Guru Member

    Has anybody else had any issues with this firmware randomly deciding to not allow net access?

    I have been using the last few releases without any issue, but since upgrading to 15c I have had it disable net access multiple times. I have been browsing the net, closed browser and then re-opened it and not been able to access any sites. I can access the router just fine, reboot it, remove power, nothing will bring it back except restoring defaults. Using either "Clear NVRAM, restore factory defaults" or "Restore factory defaults" will make it function properly again. I then proceed to input all my setting and everything is good until it just randomly does it again. I have tested it with multiple computers with the same result on all of them, so its not just blocking access from one computer.

    I really like everything this release has brought to the table, but no one else around here has knowledge enough to fix the problem if it occurs again.
     
  50. grcore

    grcore Network Guru Member

    Could this be perhaps because you are not supplying enough information? hmmm?

    You say you are losing "net access", which is only at the very most an ambigous symptom of the problem.

    You could start by checking the IP and DNS of your clients, and check the IP and DNS of the WAN interface of your unit, are you on cable or DSL? Can you ping external addresses from the CLI or from any PC? Are any processes dying? zombied?

    What OS are you using? What sort of connection do you have, DSL, Cable? Are you using PPoE? Is your WAN IP static or DHCP? What other equipment do you have?

    Perhaps doing a little more than saying "it dont work" would be helpful. Restoring defaults to fix the problem is like re-installing windows because your mouse does not work.

    So take a little time to find out what is going on, and report back. I also think you may learn something in the process....

    G
     
  51. adam217

    adam217 Network Guru Member

    You may want to hold off on your attacks, I was implying that no one at this residence knows how to fix the problem if it occurs again. You may want to get the whole story or read properly before you attack somebody. Your coming off as a real a*****e(edited, this is a family site - Thibor). I didn't come here and attack anybody or anything, I provided enough info for what I thought others would need if they had seen the issue.

    I'm not some dumbass coming to start any trouble, I have a real issue that I hoped others may have seen and may have some input. I had already had quite a lengthy post and didn't think it was necessary to bore people with all my details, but would have if I had known it would have prevented somebody like you from flaming me or anybody else for asking a simple question. Check your ego at the door.

    Back to the issue at hand.

    Comcast is the provider, the IP is received via DHCP, I can release and renew the lease without any issue while the problem is occurring. All the computer have their IP set via the Static DHCP interface, they are running WinXP Pro SP2. I use the latest version of FireFox for my browsing pleasure.

    I put all the settings into the router starting from the first page, Basic Setup, I change the router name, change the local IP address from a 1.1 to a 123.254, change my time zone to Eastern. I then enter my five Static DHCP entries. Next I change the wireless mode to G-only, change my SSID, change my wireless security settings to WPA2 Personal TKIP+AES and input my shared key. I then enable the wireless mac filter to only allow my one client which isn't even in use at the moment; only when my main computer is moved to the other room to use it on a big screen TV. The next settings that are changed are under "Applications & Gaming, QoS, I enable QoS and set the Upstream Bandwidth to 384, I use three application filters, setting Counter-Strike Source and Battlefield 2 to highest and Bittorent to low. The next setting changed is the password under the Administration page. To finish my setup I input the "nvram set cpu_overdrive=1" via the Run Command interface, check to make sure it set with "nvram get cpu_overdrive" , reboot the router with the reboot button on the administration page and make sure it took by using the "nvram get clkfreq" command. WRT54G v2.2

    Now that everything has checked out, I reboot the router one more time to have a fresh start.

    Now the internet gets used, by me that includes some daily web pages, maybe some online games; by others some basic web browsing and maybe some internet radio. I use FireFox on my 3 computers, and the other 3 people use IE 6.

    One of my computers had its IP and DNS info set statically, not by the router, but by me, it still had the same issue. When the router decided it didn't want to allow access none of my 3 computers had access to a web address or an IP address, hence not a DNS issue, which I had guessed at also, but confirmed by trying to access my hosted game server via HLSW and some ftp sites via CuteFTP 7 Pro.

    If anybody has any questions please ask, but try not to treat me like an idiot. While I may not have a lot of direct knowledge of Linux and or routers I have "worked" in computers for 7+ years and they have been my passion for as far back as I can remember; VIC 20 anyone? The first IBM compatible owned was an 8088, aah the good ole days.

    Now that I've typed a book long post, which I did not think was necessary, has anybody had an experience like mine.
     
  52. mstombs

    mstombs Network Guru Member

    Thibor has quoted elsewhere that you also need a "nvram commit", but would have thought you would notice if this doesn't work - maybe the clk freq is not set after a power cycle?
     
  53. adam217

    adam217 Network Guru Member

    Thats what I though also, asked that very thing in the other thread, but it does stick even after a power cycle.
     
  54. mmisnan

    mmisnan Network Guru Member

    Off topic, but Denton is not that far from my workplace .. at least it shares the same 3 digits of the postcode :)
     
  55. Thibor

    Thibor Super Moderator Staff Member Member

  56. callous

    callous Network Guru Member

    Is it safe to say 15c will be the final for the #15 series, Thibor?

    No more revisions planned? Thanks for the firmware btw :)
     
  57. Thibor

    Thibor Super Moderator Staff Member Member

    no more planned
     
  58. callous

    callous Network Guru Member

    If I were to use the firmware from "upgrade from *stock* firmware" to update my preexisting Thibor14, would it would it brick my router?

    If I were teo use the firmware from "upgrade from HyperWRT" to a router with stock firmware, would it brick my router?
     
  59. RonWessels

    RonWessels Network Guru Member

    No and no.

    The only difference between all the 15c versions that Thibor puts out is the codepattern that is used by existing firmware to check that the new firmware is compatible. If you happen to pick the wrong one, all that will happen is that you will be told that the firmware upgrade failed, without harming your existing firmware.

    Now, you will have to reboot your router to try again with a different firmware, but that's only to clear an internal state of the existing firmware.
     
  60. bleagh

    bleagh Network Guru Member

    Okay, a newbie question, but what does "nvram set cpu_overdrive=1" do?

    Thanks...
     
  61. GhaladReam

    GhaladReam Network Guru Member

    It overclocks the WRT's CPU from 200 to 216 MHz on the WRT54G 2.2 model only I believe.. This was a temporary fix that Linksys put in the stock firmware for this model to fix some large file transfer issues, but it was taken out in the 4.71.1 release. Thibor put this command into Thibor15 to re-enable this fix.
     
  62. callous

    callous Network Guru Member

    Does this mean Linksys/Cisco finally found a solution around the wireless large file transfer problem without havaing to overclock the cpu?
     
  63. mstombs

    mstombs Network Guru Member

    NB The Linksys 4.71.1 firmware was for WRT54GS only. There was a compiler option switch with comment that it was for certain models of WRT54G only.

    My WRT54GS V1.1 had a file transfer file problem which was fixed in Linksys V4 firmware. This was not 'large files' though it was certain files with certain byte sequences and very reproducible.

    It is pretty clear from user comments that the overclock is still needed for certain models of WRT54G, so no they didn't fix it.
     
  64. worm9110

    worm9110 Network Guru Member

    QOS

    Added 2 QoS entries a couple of days ago for bittorrent and CS using the default templates. Today I add one for MAC address and low priority and now the page doesn't show up properly after saving. I have rebooted router via the admin page and rebooted PC and it still doesn't show up properly. The radio buttons for Enabled/Disabled are missing. Is there anything I can do before I reset to factory defaults???? Web site currently is not letting me attach anything.
     
  65. Thibor

    Thibor Super Moderator Staff Member Member

    worm: well spotted. thank you. bug confirmed :)
    **EDIT** reloading the page cured it at this end. a caching issue it would seem
     
  66. worm9110

    worm9110 Network Guru Member

    Thibor, thanks for reply. Unfortunately refreshing page did not fix the problem. Thus I resetted to factory defaults and everything is working again. This time around after adding MAC address everything is working.
     
  67. db1nto

    db1nto LI Guru Member

    Hi,

    i´m new here.
    Sorry for my bad english, but i have some trouble / failure´s with the new 15c firmware.

    1. It is not possible to activate HTTPS remote management
    2. in many dropdown menu´s i see only "Undefined" or likt this "Capture(ddns.custom)undefined"

    Whats wrong?

    I have allready "Clear NVRAM, restore factory defaults" via Factory defaults menu.

    Can anybody help me please?
    My Router is: WRT54GS V1

    many many thanks

    Taner
     
  68. db1nto

    db1nto LI Guru Member

  69. Partizan

    Partizan Network Guru Member

    My "Internet connection" is disabled with this firmware and I can't seem to enable it. I always had both icon in my system tray, now I have only the "Local Area Connection" Upnp is enabled in router. Any ideas?

    Regards, Partizan
     
  70. d00mzday

    d00mzday Network Guru Member

    Crap been busy as hell. I finaly got around to getting some free time and I wanted to say "What a fine peice of work this Hyperwrt has become" great work thibor thanks for all your hard work.
     
  71. Linkyguy

    Linkyguy Network Guru Member

    15c SSID broadcast old name not new name

    Thibber,

    Can't get 15c to change the SSID name from stock linksys to "mynewSSID".........is it me or what?
     
  72. Thibor

    Thibor Super Moderator Staff Member Member

    yes it's you.
     
  73. Linkyguy

    Linkyguy Network Guru Member

    SSID

    can you give me a clue? I have everything else working as a WDS. no matter how many times I change the ssid and save, it never broadcasts newSSIDname, only "linksys".
    And I speak Mancunian also.
     
  74. Thibor

    Thibor Super Moderator Staff Member Member

    aright there, our kid. well your problem is most likely to do with your browser, more than the router. i haven't seen another issue of ssid or another setting refusing to change being caused by anything other than that.
     
  75. Linkyguy

    Linkyguy Network Guru Member

    browser

    so should I ask Bill Gates for my money back for IE V6?
    It works for everything else.....
     
  76. callous

    callous Network Guru Member

    Try another browser, as the new IE which is still in beta has known issues with displaying and modifying router pages for Linksys and D-Link routers.
     
  77. Linkyguy

    Linkyguy Network Guru Member

    beta browser

    I don't have any IE beta browser.
     
  78. Thibor

    Thibor Super Moderator Staff Member Member

    you could always do "nvram set wl0_ssid=<your ssid>; nvram commit"
     
  79. SteelersFANinMA

    SteelersFANinMA Network Guru Member

    I'm using IE 6 and can confirm that it saves new SSID's for me. However, I'm not using WDS.
     
  80. Thibor

    Thibor Super Moderator Staff Member Member

    i am using wds, and i can change ssid at will
     
  81. citizenx

    citizenx Guest

    this is the best firmware.....

    hi Thibor....

    thnx for ur hard work... u solved me allot of probs. im using WRT54GS v4 fresh from th box and it took me like a month to understand that i need ur work....

    now its better on wireless and more solid and stable func.

    thnx!
     
  82. lwf-

    lwf- Network Guru Member

  83. Linkyguy

    Linkyguy Network Guru Member

    browser

    Thanks, but I will re-visit my config and see if it is indeed "me", as Thibor indicated. If no-one else has the problem, maybe it is, although I NEVER make mistakes..... :cry:
     
  84. Thibor

    Thibor Super Moderator Staff Member Member

    although you may be, like me; perfect, i think revisiting your config to check for "machine errors", is a wise decision. these routers are not the worlds most reliable, but seeing as yours is the only occasion i have heard of not storing a new ssid, i think your router is at fault. perhaps it's just confused, maybe try factory resetting it.
     
  85. Linkyguy

    Linkyguy Network Guru Member

    factory reset procedure

    Can anyone state the correct factory reset procedure?
    I have seen many variations: hold reset button with power on, pull plug while holding reset button, put plug in while holding reset button. Hold for 10 -20 -30 secs....? Thanks
     
  86. bleagh

    bleagh Network Guru Member

    Well, Thibor's firmware seems to work good for me. Thanks Thibor.

    Twice now I have tried the DD-WRT v23 final, and both times I have had problems with it. Seems they still have bugs to work out. The second time I messed up the IP address on my second computer (using win98se) and after that, the computer couldn't find the DHCP server on the linksys. After trying several thing I finally just gave up and flashed back to the Thibor15c and everything worked again as it should.

    Personally I have never been able to see my modem (bridged to the router using PPPoE). Then again I've never had any problems with the modem, so have never worried about it.
     
  87. lwf-

    lwf- Network Guru Member

    Is it possible to add Google Talk to QoS? I can’t find it in the list and it seems like GT doesn’t use fixed ports for the calls. Does that mean that a L7-filter is needed or can I do something to fix it myself (besides adding a L7-filter, I am not capable of that).
     
  88. Thibor

    Thibor Super Moderator Staff Member Member

  89. Thibor

    Thibor Super Moderator Staff Member Member

    it looks like google talk uses the "Jabber" protocol which could be added in a custom firmware with 2 minutes work. otherwise i suppose it could be added to Thibor16 when i do it.
     
  90. LawnMowerGuy1

    LawnMowerGuy1 Network Guru Member

    not to be a bother but why not add (virtually) all of the l7 patterns. if you strip out all the comments the patterns are very small.
     
  91. Thibor

    Thibor Super Moderator Staff Member Member

    why don't you add the support for them all then, all you need to do is edit QoS.asp and firewall.c
     
  92. lwf-

    lwf- Network Guru Member

    So you say that it’s easy? If it’s really easy and doesn’t really require any programming skills I could probably add some filters when I get time over. Maybe someone can write how to do it?
     
  93. LawnMowerGuy1

    LawnMowerGuy1 Network Guru Member

    I guess my question should have been, is there a reason why they aren't included?

    currently in helping brainslayer with dd-wrt. Believe me, I know what its like when people constantly want more of you but it just seems ike a no-brainer to me. I guess I could do it if you want.
     
  94. Thibor

    Thibor Super Moderator Staff Member Member

    i included the protocols most people are likely to need, no more no less
     
  95. kulmegil

    kulmegil Network Guru Member

    I can't check my routers CPU load using top command anymore, is there any other way?

    Is there some trick to bost up my WRT54GS (v1.1) performance? I just need to access my ISPs LAN (between I-net getaway and my router) with something higher then ~35Mbps that my router can handle. I already disabled firewall and QoS...
     
  96. Thibor

    Thibor Super Moderator Staff Member Member

    if you need better than 35 mbps, get another router.
     
  97. Linkyguy

    Linkyguy Network Guru Member

    thibor wrt54gx4

    Thibber, see my PM re whether you need the US 120V plug for the wrt54gx4.......it weighs a ton and is not universal voltage......
     
  98. Dirty04

    Dirty04 Network Guru Member

    Thibor, I want to put this under your attention..

    It has been put into the Wishlist.
    ----------------------------------------
    Add the wish hereby as follows:
    - Extend the WOL with a Schedule option !

    Reason:
    We live here in Europe, the WOL is working perfectly. But when you want to schedule a server, which isn't capable of delivering 24/7 hours of duty, you want to schedule the server to go into hybernate after office-hours (for example 18.00 hrs or later 22.00 hrs). But then, of course, you want to schedule then, when the Server has to receive a WOL-packet, early in the morning (for example 07.00 hours when Office-hours begin while I'm in my bed still :).

    That excellent WOL-feature in your firmware, extended with a schedule-option (which IP, and/or which MAC-adress) providing the possibility which piece of hardware should be 'awakened' again, at a certain time, would be a very nice extra feature in your firmware.

    furthermore, it's more secure. If someone is forgetting that, well...

    therefore a good schedule-WOL option would be much appreciated

    Is that possible ? (e-mail option: wwchamp_dirty04@hotmail.com)

    (p.s. excuse my possibly terrible English)
    --------------------------------------

    Putting this into this subject, because it's concerning WOL in Thibor 15c.
     
  99. 0Kool

    0Kool LI Guru Member

    Thibor 15c WOL Issue

    Dirty04,

    You were able to get the WOL to work under Thibor 15c? I just flashed mine from 14 to 15c and cannot get the WOL to work. It worked beautifully under 14.

    Any thoughts/suggestions?


    Thibor,

    I PM'ed you about this. Any thoughts/suggestions?
     
  100. sailorman29

    sailorman29 Guest

    ok so when is the hyperwrt firmware going to be available for the wrt300n?
     

Share This Page