1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Throughput Problem With Tomato

Discussion in 'Tomato Firmware' started by nightemaster, Dec 9, 2008.

  1. nightemaster

    nightemaster Network Guru Member

    Hi, I'm currently having a throughput problem with tomato. I'm using Tomato v1.22.1589 on DHCP. When transferring through the WAN, i get throughput of only round 40mbits/s while on LAN it works at 100mbits. After SSHing into the router, whenever traffic goes up, ksoftirqd_CPU0 runs at 100% CPU. Are there any mods out there that can reduce this or fixes for this? I tested this with a single and multiple connections, so its not a problem with multiple connections. (Nothing like torrents overloading connections on the router)
  2. mstombs

    mstombs Network Guru Member

  3. wolfish

    wolfish Addicted to LI Member

    Nice info. Wonder what the next linux router platform will be...
  4. Kiwi8

    Kiwi8 LI Guru Member

    Yeah u are right. Although that thread is current, this issue has been around for quite some time. Hence those who have ISP services that are more than around 40mbps should really go for another router. Otherwise WRT54G will do fine. :)
  5. nightemaster

    nightemaster Network Guru Member

    I'm wondering, are there any other routers capable of running tomato while having a faster processor than the WRT54G? Would there be a difference with a wrt54gs?
  6. mstombs

    mstombs Network Guru Member

    The S in WRT54GS is a software switch for Speedbooster, but they used to have more memory! Some models can be overclocked up to 250MHz maybe with extra cooling.

    The now obsolete WRTSL54GS can run Tomato (without USB port) - this had decent memory plus 266MHz processor I recall, but had fixed antennae.

    I think the fastest currently available is a specific Buffalo or Asus - but don't have direct knowledge of model Nos.


Share This Page