1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tinyPEAP not working with 3 WRT54G's

Discussion in 'TinyPEAP Firmware' started by jai10, Nov 24, 2004.

  1. jai10

    jai10 Network Guru Member

    I have three WRT54G's, one is setup as the RADIUS server, the other 2 have the IP address of the RADIUS WRT54G in thier radius configuration page, I am using "password" as the shared key. User accounts are also setup on the first access point.

    When I setup a windows xp client, with the profile, it will say , click here to select a cert or other credentials for connection....
    so I put my user name and password in, the same as the radius ones. It will then say validating identitiy, but it will keep saying that forever and never connect.
    Do I need to open any ports on the the first WRT54G to enable the other WRT54G's to send its RADIUS auth packets to it??

    But when I change one of the WRT54G's to be a RADIUS server itself and enter the user name and password it works fine.!...

    Also I cannot use the certificate, when I import it, then choose server certificate and choose internet widgets cert, then put in my user and pass, it will do the same thing just keep saying, validating identity..
    This happens when I point one of the WRT54Gs to the other which is acting as a RADIUS server or even when make it the RADIUS server itself.

    I am using an Intel MiniPCI 2200BG wireless card, it supports 802.1x/WPA etc, I am using Windows XP SP2

    thanks
    Jai
     
  2. nairb2128

    nairb2128 Network Guru Member

    hi, sorry for the quick and dirty answer but im in a hurry. By default, tinypeap is run in "embedded mode" which only allow packets from itself. Ssh'ing into the accesspoint and restarting the server without the -E (embedded) flag will allow you to use it across multiple access points.

    -Brian
     
  3. jai10

    jai10 Network Guru Member

    Ok thanks I'll try that, but how can I make it sustain a restart? Is there a file I need to edit which is read on startup? what commands do I use?, Sorry I'm a bit of a newb to the firmware command line.

    Also what about the certificate issue? If I use a WRT54G on it own, running as the radius server, import the certificate in to winxp, and checking the 'validate server certificate' then choose the "internet widgets" cert. Then putting your radius username and passwrd in the client will keep saying "Validating Identity".. it will never connect.
    It will only connect if I uncheck "validate server certificate"


    EDIT: Ok I just tried this on my ibook running panther, I added a new network, chose WPA enterprise, added a username and password. It then attempted to connect and then prompted that there is no valid certificate, it then showed the internet widgets one and the option to import it, which worked. I guess Mac gets it right again :)

    If I delete the internet widgets cert from WinXP it still allows me to connect, which I guess is not supposed to happen!?
     

Share This Page