1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Toastman release with vlan problems

Discussion in 'Tomato Firmware' started by michse, Nov 27, 2011.

  1. michse

    michse Addicted to LI Member

    Hi,

    I use some WRT54GL and since a few days the last toastman release 76.28.1 vpn. There is a bug in vlan, because "manual_boot_nv" is set to "0", so the router forget all vlan taggings.

    can someone confirm?

    But it's also a good work from all the guys!

    michse
     
  2. kthaddock

    kthaddock Network Guru Member

    I can see in 2490-nocat "manual_boot_nv" is set to ="0"
     
  3. michse

    michse Addicted to LI Member

    Thanks for the replay. The router forget all vlans, when i use the gui. I have to manualy set this variable to "1", then it remember the vlan config. this is a general problem in tomato, i remember.
     
  4. kthaddock

    kthaddock Network Guru Member

    Okey I don't use VLAN at the moment, but I'm sure Toastman fix this in next build.
     
  5. Toastman

    Toastman Super Moderator Staff Member Member

    Teaman, should the nvram variable be set to 1 in defaults.c?
     
  6. teaman

    teaman LI Guru Member

    It is set to '1' on advanced-vlan.asp whenever any 'non-standard' VLAN settings are detected (i.e. vlanXports or vlanXhwname is changed, where X is 0 or 1). Cheers!
     
  7. Toastman

    Toastman Super Moderator Staff Member Member

    OK, thanks, so not really necessary, folks.
     

Share This Page