1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Toastman Releases - up to 1.28.7492

Discussion in 'Tomato Firmware' started by jsmiddleton4, Jun 22, 2011.

Thread Status:
Not open for further replies.
  1. Toink

    Toink Network Guru Member

    Let me re-phrase that my friend, CONFIRMED! Tomato, on E4200 now has 5GHz support! :)

    Toastman, a big THANK YOU! And well done to Fedor, too!!
     
  2. Beast

    Beast Network Guru Member

    Asus RT-N16
    Loaded 7485.2.
    Power light stays OFF after reboot!

    Iptables-restore v1.3.8: error creating chain 'monitor':File exists at line 42. (7485.1 was at line 129).
    Iptables error in the [Port Forwarding Basic] and in [Access Restriction Overview].

    Did not do a nvram clear for this update.
     
  3. kthaddock

    kthaddock Network Guru Member

    This ?
     

    Attached Files:

  4. csm746

    csm746 Network Guru Member

    I do not find 5ghz enabled on my E4200, on the Basic/Network page only 2.4 ghz is available for configuration. What am I missing?
     
  5. Chad Burks

    Chad Burks Networkin' Nut Member

    Make sure that you are downloading the correct build...0485.2
     
  6. Chad Burks

    Chad Burks Networkin' Nut Member

    After 7 hours of uptime, I lost my Internet connection. Reboot fixed the connection. Coincidence?
    E4200--Tomato Firmware v1.28.0485 MIPSR2-Toastman-RT-N-BETA K26 USB VPN-NOCAT
     
  7. Toastman

    Toastman Super Moderator Staff Member Member

    Please disable WEBMON if it isn't working, and everything else will then be OK.

    Chad - possibly, I have had one router up since Friday on PPPOE ADSL.
     
  8. kthaddock

    kthaddock Network Guru Member

    Okey New try with 0485.2-beta-nocat and this time I have all graf... :rolleyes: Seems that " NVRAM-RESET" is very importent to do ALWAYS.
     
    Toastman likes this.
  9. csm746

    csm746 Network Guru Member

    Thanks Chad....that was it.....I missed the "0" 485.....I am testing download speeds and I believe everything is OK WAN to LAN....but, I will continue on that....it has only been up a couple hours, but everything I use seems to work so far....I have to try DDNS from the office today and port forwarding....but, I am running 5 ghz and it is connecting at 270mbs on the Windows network which on the onset appears to be better than stock firmware....and I have an Intel 450mbs card and attennas installed in my Dell Laptop. I will do some across LAN large file transfers this evening.
     
  10. Toastman

    Toastman Super Moderator Staff Member Member

    The bug is with IPV6 builds only. I still haven't spotted the cause, but if I can't find the cause soon, I'll make an interim compile with IPV6 removed so that the majority of people will be able to use it normally.

    From reports I'm getting, the E4200 support is pretty good. A couple of people have been reporting several users bashing it all day at 450Mbps speeds.
     
  11. Pioneer

    Pioneer LI Guru Member

    I get the message "The field "wl_mitigation" is invalid. Please report this problem."

    Is it a known problem?
     
  12. Toastman

    Toastman Super Moderator Staff Member Member

    No, not seen it here - when do you get this message, did you do anything beforehand?
     
  13. Pioneer

    Pioneer LI Guru Member

    Ok, just saw, it's only when I choose the new option "WLAN Auto with Noise Reduction"
     
  14. Toastman

    Toastman Super Moderator Staff Member Member

    OK, I see it now. Hadn't noticed that! Input check hasn't been changed.

    I see a typo / spell error too. (Noice).

    Thank you!
     
  15. leeb

    leeb LI Guru Member

    Re: ASUS RT-N12

    Is v1.28.7483 MIPSR2-Toastman-RT K26 Std the right version for the RT-N12?

    I've had router lockups at 4 days (couldn't ping router on wired connection), and at 14 days. (wireless quit, wireless light was off on router) Previous Buffalo router was rock solid on stock tomatousb 1.28.

    I don't do any p2p, and only have 2 computers and an iPod Touch on this router. Need to get stability back. Thanks for any help. :)
     
  16. Toink

    Toink Network Guru Member

    Yes, that's should be the right firmware. Just make sure you set a STATIC IP to your PC first BEFORE flashing. DHCP is disabled be default in Toastman's builds. You have to enable them upon initial setup.
     
  17. leeb

    leeb LI Guru Member

    Thanks. I've already been using that version (and I used a static IP to install), but since I'm having lockups I thought maybe I should be using a MINI version, since the RT-N12 only has 4MB of flash. Not sure what to try next. Thanks.
     
  18. Toink

    Toink Network Guru Member

    Ah. Silly question, did you clear NVRAM before and after flashing? Hiccups most often happen if this essential step is skipped. If you don't need other features, then you can try the lite version. I only have the WL-520GU - also with 4mb of flash and am using the USB version of the same build number and all is well. I'm not sure what could be causing the lock-ups on your RT-N12
     
  19. Toastman

    Toastman Super Moderator Staff Member Member

    Since I haven't so far found the fix for the webmon/IPtables bug, I am posting interim builds 7485.4-RT and 0485.3-RT-N (E4200 etc) so that the majority of people (who don't use IPV6 anyway) can evaluate the new features and the new updates from Teddy Bear.

    There is no IPV6 support in the menu for these builds.
     
  20. leeb

    leeb LI Guru Member

    The router was new, so I used the Asus rescue utility to install the DD-WRT special image for initial flashing, then I installed generic TomatoUSB, then installed the Toastman build. I did not clear NVRAM prior to installing the Toastman build, but I did clear NVRAM (thorough) afterwards. It seemed successful, as the router runs fine for 4 and 14 days before locking. Nonetheless maybe I should try flashing the router again. Thanks.
     
  21. kthaddock

    kthaddock Network Guru Member

    Thanks for the update builds. Did you forget -NOCAT build this time ?
     
  22. csm746

    csm746 Network Guru Member

    Running 0485-2 Std...My E4200 has been up for only 24 hours, but all is running very well. Windows is reporting generally 270-300 mbs connection speeds 40 feet from the router with two walls between on the 5ghz band. Stock firmware did not do this. This is with output power set at 49mw....setting it at 84 drove down speeds significantly, even 56mw diminished speeds, but 49 seems like a sweet spot here. DDNS worked fine with port forwarding, WPA2-personal with AES, both bands supporting connections simultaneously, I left a Cisco AnyConnect VPN connection to work up for 12 hours and it remained connected with no hiccups, and...I believe it is visibly faster than stock. Thanks for the great work Toastman...I will try 0485-3 shortly.
     
  23. bagu

    bagu Network Guru Member

    Since i use ipv6, i'm waiting for the future stable version ;)
     
  24. Mercjoe

    Mercjoe Network Guru Member

    Great stuff.

    There are a couple of issues I have found:

    1) WDS is broken, I have been using a WRT54gv2.2 runnng 1.28ND for AGES now as a WDS on the other end of the house. I can not connect to it now. Yes, I turned off security, verified SSID name. I tried it in 'auto' as well as 'link with' and it will not connect. The WRT sees the netgear no problem on the wireless survey, I can connect to it as an ethernet client. Try it as a WDS and it will do nothing. I have verified that I can connect to the main router via wirelss with no issues.

    2) Scripts used to allow access to a upstream modem are broken. The routes show up in the Routing tables under the advance menu, but you can not connect to the control panel of the modem.

    I flash back to 7483 and all is well on both issues.

    Yes, I reset NVRAM on each flash and manually reconfigured each time.

    This probably has to do with the VLAN code and some configuration settings, but dang if I can figure it out.

    Late addition:

    I left the router up for most of the day and decided to reboot it. I have both cstat & rstat set to save to CIFS 1 every hour. CIFS1 is a UBS thumbdrive inserted in the routers USB port.

    The bandwidth data was restored upon reboot, however the IP traffic data is not restored on restart. I went and manually restored the data from the admin IP traffic menu. This at least confimed the data being backed up properly.
     
  25. Toastman

    Toastman Super Moderator Staff Member Member

    Thanks for the feedback!

    I am posting a version in which the iptables bug is fixed and Webmon now works. The question is, whether the IPV6 works or not. I have no way to test this, so looking for feedback. Bagu?

    7485.4 and 0485.4 posting today.
     
  26. EpsilonX

    EpsilonX LI Guru Member

    @Toastman
    Hi Toastman...
    Been using 7621 on my WRT54GL...
    Nice work... :)
    If I want to flash a newer version, which route should I go..?
    The newest 7626.1, or the 7628.1..?
    Base on the readme file, I assume the 7628.1 is sort of a BETA..? ;)
    CMIIW...
    Did a quick flash to see both...
    The difference is that 7628.1 got a new "IP Traffic Monitor", but lacks the "BW Limiter"..?
    And if the 7628.1 is the "future", is it possible to have Bluedream back..? ;)
    7628.1 is noticebly smaller than 7626.1, and Bluedream is included in 7626.1...
    Thanx and will wait for future releases...

    P.S : Currently using 7628.1
     
  27. Toastman

    Toastman Super Moderator Staff Member Member

    I may put the BW Limiter back in, but it isn't a priority. Likewise, the reduction of files size achieved by removing themes won't be reversed. You can still use your choice of theme - look on the forum for guidance on this.
     
  28. EpsilonX

    EpsilonX LI Guru Member

    So I assume 7628.1 is the way to go then..?
    Oh and before I forgot...
    If I set the "APSD Mode" to "Disabled", which is the default setting in your build...
    My phone (HTC Desire) will drain its battery like crazy even though it's idling most of the time...
    When I set it to "Enabled" which is the "default" setting based on the asterisk (*) mark, it runs beautifully and consume minimal battery...
    Ever notice something like that..?
     
  29. Toastman

    Toastman Super Moderator Staff Member Member

    Yes. But the APSD mode is also responsible for dropped connections and poor speed with normal (non-phone) useage. So it's disabled in my builds for that reason. If people need it, they can enable it. Which build you like best is up to you :)
     
  30. EpsilonX

    EpsilonX LI Guru Member

    Ow, I see...
    Nice, glad to know that both builds should do just fine...
    And I've enabled Custom theme by using the JFFS...
    No problem at all... :D
    Thanx for these quick replies...
     
  31. kthaddock

    kthaddock Network Guru Member

    Now I have loaded 1.28 0485.4-beta-nocat and It's seem to working.
    Web Usage is working "Recently Visited Web Sites" and "Recent Web Searches", as it should :D.
    Tested my script in GUI-firewall and when loaded Web Usage not working, So conclusion is there is some wrong with that script.
    If someone with linux skills can have a look at that I will appreciate that. ( I can PM )

    And as usually big thanks to Toastman :rolleyes:
     
  32. maple.chick

    maple.chick Networkin' Nut Member

    In my research on UMA, I came across WMM documentation on APSD (Automatic power save delivery) and UAPSD, in a nutshell its designed to conserve power for devices that have it enabled like your cellphone or other VOIP devices. It does that by placing a device in doze state when its not transmitting data. However, if your laptop is in performance mode, APSD is most likely disabled. In my tests, having APSD enabled on router didnt affect throughput too much. However there was a slight difference. We're talking 10.7mbps without APSD and 10.56mbps with APSD. On multiple runs, the average difference is even narrower but there is certainly a slight performance hit.

    I had dropped connection issues and I thought it was APSD but it turned out to be transmit power. Try and experiment using NetStress, it measures your LAN throughput, and share your results.

    Toastman, Can I use MIPSR1 builds on WRT54G-TM?
     
  33. Toastman

    Toastman Super Moderator Staff Member Member

    Yes, either K2.4 or K3.6 providing it's for MIPSR1. K2.4 is smaller and faster.
     
  34. djroby19

    djroby19 Networkin' Nut Member

    :mad: @ Toastman new wireless ethernet works only crash I have to shut down and restart and everything back in place ....
    I want to give it a try if the problem could be the wifi off cron and let you know I try
     
  35. djroby19

    djroby19 Networkin' Nut Member

    I have tested disabling and re-enable the wifi via cron seems ok
    builds on the last beta 4 :)
     
  36. Toastman

    Toastman Super Moderator Staff Member Member

    Anyone tested IPV6 on these builds yet? Or WDS?
     
  37. djroby19

    djroby19 Networkin' Nut Member

    I'm trying to prove ipv6 tunnel with Hurricane
     
  38. tmu1214

    tmu1214 Networkin' Nut Member

  39. djroby19

    djroby19 Networkin' Nut Member

    IPv6 responds to ping but does not open the pages ipv6
     
  40. gutsman7

    gutsman7 Networkin' Nut Member

    Thank you Toastman your work is apreciated.
     
  41. Mercjoe

    Mercjoe Network Guru Member

    No change with regards to any of my prior bugs.

    Sorry.

    I upgraded my old WRT54G to your latest 2.4 (v1.28.7628) to see if it was something in the firmware. No change.

    Nice work BTW. Had that been out I might not have upgraded to the Wnr3500l I have now.
     
  42. tvlz

    tvlz Addicted to LI Member

  43. buckle

    buckle Networkin' Nut Member

    Hey Toastman,

    I haven't rebooted the router ever since and now the IP traffic monitoring is working again (that is, I see the graphs). I didn't make any changes at all. Could this be related to the new month? The only data I see is for 10-01-2011 (in daily).. all September data is not there even though it was enabled. Hope that helps in finding the bug!

    buckle

    EDIT: oops, spoke too soon. It's not working again, as described in the quote (still haven't touched any setting)
     
  44. wittereus

    wittereus Network Guru Member

    I am running a E4200 with 1.28.0485.4-BETA. Everything works for me except ipv6. Can I change the firewall myself? (no experience) or is a new beta comming with upgraded ip6table rules?
     
  45. djroby19

    djroby19 Networkin' Nut Member

    Ipv6 It also does not work for me, also configured tunnels Hurricane :(
     
  46. djroby19

    djroby19 Networkin' Nut Member

    Then, after a few hours Toastman that power to the router and see what happens in theE4200 image
    do so after six or seven hours away I have to redo a reset nvram to return the right values ​​to make me understand I hope, excuse my English school ..
    [​IMG]



    Uploaded with ImageShack.us
     
  47. Toastman

    Toastman Super Moderator Staff Member Member

    Are you saying the router keeps resetting to 133 MHz, and that this cannot be changed using the menu on Advanced/Misc page to set it to 480,240?
     
  48. djroby19

    djroby19 Networkin' Nut Member

    Sure,bring it back to the default values ​​or you need to reset the defaul tsetting sor go through the page and restore overclocking to 480MHz, this happens on average after six, seven hours of operation...and success throughout the 5GHz version with the drivers and changed some thing in the kernel?
     
  49. Toastman

    Toastman Super Moderator Staff Member Member

    All the CPU change does, is to set an nvram variable. Assuming it saves correctly and then rebooted correctly at the new frequency, I don't see why it would revert to 133 after a period of time. Strange.
     
  50. djroby19

    djroby19 Networkin' Nut Member

    Could center the restrictions off the wifi in a certain time?
    for example I've got set from 1 am to 7 am
    Or the CPU goes into saturation and crashes?
    Maybe I'm telling bullshit
     
  51. pharma

    pharma Network Guru Member

    I don't have this problem on my E4200. It displays the correct CPU setting and does not change after days of running. Djroby19, you might want to do a NVRAM clear or re-flash firmware because it sounds like something is messed up or are running some script that might need tested.

    Pharma
     
  52. MPS

    MPS Networkin' Nut Member

    Toastman, you are a genius. The new firmware works perfectly, and has everything I was looking for (as I posted in a different thread). Thank you for your time and effort to compile this.
     
  53. myersw

    myersw Network Guru Member

    Toastman, loaded your 0485.4 on my E4200. Enabled both 2.4 and 5 without any issues. So far looks great. My thanks to you for making this available and to Teddy-Bear for the integration of the drivers and what ever else was required. Glad to see that he is back. Know it has been a tough time for him.
    It looks pretty complete to my eyes. Don't use/need ipv6 and use just the basics. I was glad to see that there are separate ssid's for the two ranges, unlike the Linksys implementation for the e3000. Lots of work with the UI besides just the driver integration. Loving it. :)
    --bill
     
  54. nordberg

    nordberg Networkin' Nut Member

    IPv6 seems to be non-functional. The rest seems ok, although wifi might be a little bit more flaky with this version.
     
  55. Mercjoe

    Mercjoe Network Guru Member

    Thank you, I missed that.

    Added the extra line in the firewall script and now I can access the dsl modem as before. I figured it was a configuration error but I could not find anything when I looked.

    WDS is still broken as after several hours of attempts I can not get it to work.

    I decided to try something different. I flashed over to the older VLAN betas and found that it did not work with those as well. As soon as I go back to a non-vlan GUI firmware WDS works normally. NOTE: Having a VLAN GUI enabled firmware on EITHER router precluded WDS operation. I have one router running 2.4 and one running 2.6. Only when BOTH routers have a older non-VLAN version does WDS work.

    Thus I am convinced it is some kind of config issue. I just can not for the life of me figure it out.

    Here is a strange piece of data for you. While WDS is broken, wireless ethernet client works better. When I get a configuration that WDS works, the wireless ethernet client is so slow as to be unusable.

    The IP traffic monitor save sata still does not reload after a reboot. I have to manually reload the backup data to regain it.

    I am done experimenting for a while as the other half wants her internet back
     
  56. Toastman

    Toastman Super Moderator Staff Member Member

    That bodes well for the router if the configuration for WDS is fixed. Something will have actually improved!

    I have had mails from several people who are confused by the "VLAN-GUI" and by the development work going on. I'll change a few things in the future, announcing a new naming policy shortly.

    I also had a few mails complaining about slow performance using NTFS filesystem on the router. Let me first say, this isn't a NAS box. It's a router, and it makes a really crap NAS. If you don't mind it being slow, that's OK.

    BUT

    ( http://superuser.com/questions/204000/are-there-faster-solutions-for-ntfs-on-linux-than-ntfs-3g ).
     
  57. Toastman

    Toastman Super Moderator Staff Member Member

    IPV6 firewall is now fixed (I hope!) - so:

    Toastman-VLAN-RT-1.28.4406-BETA and Toastman-VLAN-RT-N-1.28.0406 posting shortly.

    Look in the MIPSR2 K2.6 Toastman-VLAN directory.

    Why the change in name/numbers?

    The changes required for the VLAN GUI have impacted several other features which have yet to be resolved. So that we will have a "stable" version of Toastman to rely on (!) I am going to keep Toastman-RT branch for versions without the VLAN-GUI. If you don't need the VLAN-GUI itself (and most people don't) this will be the one to get. Quite a few people pointed out that the interface is less complicated, less daunting, and less likely to be accidentally set up wrongly.

    I will go back to using the older Toastman-VLAN branch for the VLAN-GUI builds. It looks like the VLAN-GUI branched will be the main "development" branch for a while!

    I will continue to add other features from the VLAN-GUI branch back into the RT build, and will try to add the IPT Traffic Monitor etc. back into it ASAP.
     
  58. djroby19

    djroby19 Networkin' Nut Member

    Toastman seems to me that the problem is only one thing ... then do a hard reset 30/30/30 reloading the firmware stock and re-run a hard reset and reload your last version ... you have any other advice? I think should be fine .... it worked well because the stock firmware and also DD-WRT worked never had a problem ... and you probably messed up something in memory .....
     
  59. Mercjoe

    Mercjoe Network Guru Member

    I have just found a major issue with v1.28.7485 MIPSR2-Toastman-RT-BETA K26 USB VPN-NOCAT.

    Access restrictions are broken. In particular the block 'all internet access'. I have all computers currently blocked by MAC address and.. well.. Here I am.

    If you flip the 'all computers' it works, but you can not block individual computers.

    <EDIT>

    Additional info: You CAN block by IP address. It seems that only blocking using a MAC address is bugged at the moment.
     
  60. Mercjoe

    Mercjoe Network Guru Member

    I take it that wireless ethernet client has always been something of a problem?? I played with it a LONG time ago before I figured out how WDS worked. I just know that it was worthless back then and tried it out of desperation this time when WDS had stopped working.
     
  61. Beast

    Beast Network Guru Member

    All this activity with the tomato firmware development, inspired me to load an old computer up with ubuntu v11.04 and clone the tomato git. I have always wanted to try out linux. (Which seems to of become a bit bloty kind of like windows) Its running kind of slow on this computer 1g memory and 1ghz cpu. My goal is to learn to compile the sources on my own. Wish me luck I will need it. I'm still stumbling around in linux just trying figure out how to navigate the cloned tomato git. Much less how to compile the stuff. I assume every thing needed to compile the src code get cloned to the local drive?? I did install flex and bison and other dependences, I hope. My favorite flavor are the Toastman releases they seem to work the best for me.
     
  62. maple.chick

    maple.chick Networkin' Nut Member

    Beast, I'm working on something similar perhaps we can collaborate. However, I'm using VMWare. I was going to ask Toastman what his development environment is and favorite tools. Would be nice to help out Toastman in squashing the bugs :)

    On a different note, I'm using Tomato Firmware v1.28.7628 -Toastman ND USB VPN (kernel 2.4.37.11 and driver 4.150.10.29), though I am pretty sure I flashed 1.28.7628.1 but it comes up as 1.28.7628. In any case, the problem seems to be that Wake-On LAN has all the devices showing Active (In ARP). Here's what I have done so far:
    1. Rebooted the router a few times.
    2. Disconnected all the LAN devices and rebooted.
    3. 'Refresh' the interface and browser after every reboot.
    4. I also tried using different browsers.

    Nothing have worked so far. However, the Wake-ON LAN function works as intended. I was able to wake devices out of sleep.
     

    Attached Files:

    • WOL.png
      WOL.png
      File size:
      5.2 KB
      Views:
      36
  63. Dr Strangelove

    Dr Strangelove Networkin' Nut Member

    BIG 'ups' to Toastman and the crew who provided the 5Ghz WiFi. Thank you.

    Installed the Toastman E4200 1.28.0485.4 Beta VPN firmware and now using 5Ghz WiFi.

    The interesting option I haven't explored is having two 2.4Ghz SSID, as the second 'interface' appears to be able to be configured as either/or (2.4Ghz/5Ghz). Sweet.

    Looking forward to having a release of the firmware with VPN, USB and 5Ghz, but hay, Christmas is still months away yet. :D

    Thank you to all involved.
     
  64. Toastman

    Toastman Super Moderator Staff Member Member


    If Static ARP Binding is enabled for a client, it will always show in the list. That's not a bug :)
     
  65. djroby19

    djroby19 Networkin' Nut Member

    Has anyone tried IPv6 tunnels Hurricane Tomato Firmware v1.28.0406 on latest build MIPSR2 Toastman-VLAN-RT-N-BETA-K26 USB Ext

    I found this error in the log
    Date Time Level Program Host Name Category Posts
    E-4200 03.10.2011 19:30:21 err crond cron time disparity of 21961050 minutes detected
     
  66. Toink

    Toink Network Guru Member

    That time disparity error is normal. Not a bug AFAIK.
     
  67. djroby19

    djroby19 Networkin' Nut Member

    Ok thanks, have you tried IPv6?
     
  68. Toink

    Toink Network Guru Member

    IPv6 isn't supported by my ISP yet so, no point of me tesing it.
     
  69. Beast

    Beast Network Guru Member

    Hi
    I see Toastman already answered the ARP question. I have an older linksys loaded with 1.28.7628.1, and can conferm that the .1 is not reflected in the about page. As far as compiling tomato goes Im a total NOOB, I am using this [ http://tomatousb.org/tut:how-to-build-and-rebuild-tomato-for-total-noobs ] as a starting point. At moment I know just enough to be dangerous. Luckly I have four old linksys routers to play with. I not risking my brand new shiny Asus RT-N16.
     
  70. wittereus

    wittereus Network Guru Member

  71. Beast

    Beast Network Guru Member

    Toastman
    Just relized I have the 60k nvram version loaded on my Asus RT-N16.

    Total / Free NVRAM:60.00 KB / 35.98 KB (59.97%) <------ Reported on the config page.

    Is this a big no no, or just risky?? And btw whats with the secrect code thing in NVRAM. What was it for in the orginal Asus firmware, anyone know???
     
  72. Toastman

    Toastman Super Moderator Staff Member Member

    You don't really have 60K of NVRAM. That version is not suitable for the RT-N16.

    What's that about secret codes?
     
  73. mata7

    mata7 Networkin' Nut Member

    hello guys i just register to this forums great place and great info, i just brought a new linksys E4200 and i want to load the toastman firmware cause the original tomato i read that don't support 5ghz yet, im just confuse witch build firmware i should download, can someone please tell me witch build are more stable that support 2.4 and 5ghz simultaneous wireless

    thanks in advance and sorry about my English
     
  74. Toink

    Toink Network Guru Member

    Welcome to the forum, mata7.

    You can flash your E4200 with E4200USB-NVRAM60K-1.28.0406. You can flash directly from stock firmware. Just make sure you clear the NVRAM after you flash (Admin>Configuration>Restore Default config - Thorough)

    Warning: DHCP is disabled by default in Toastman's latest builds. Make sure you set a STATIC IP to your PC BEFORE flashing the firmware.
     
  75. Beast

    Beast Network Guru Member

    Changed to 4406 none 60k version.

    The secrect code is left over from the orginal firmware, I remmber seeing it on one of the router pages while hunting for the upgrade page.
    Not sure what it was used for. It also can be found in the CFE bin file. While researching the nvram size for the Asus came across this page
    [ http://tomatousb.org/forum/t-284878/increasing-nvram-size ] Near the bottom some one else found the same thing on there router. A snip of my nvram dump file, I changed the numbers around a bit but thats what it looks like in both nvram and cfe.

    sdram_refresh=0x1a5a
    secret_code=85436341
    sesx_b0=1
     
  76. mata7

    mata7 Networkin' Nut Member

    thank you very much
     
  77. wittereus

    wittereus Network Guru Member

    With tomato-E4200USB-NVRAM60K-1.28.0406. When I use B/W limiter, my router reboots and keeps rebooting. Disabled it and made a Qos rule instead.
    I use the E4200.
     
  78. wittereus

    wittereus Network Guru Member

    I,m not good at this either, thats why I asked the question on the other forum. Ik removed everything thats in scripts --- firewall and only pasted the: ip6tables -A FORWARD -i br0 -j ACCEPT
    Save and it should work everytime.
    The lines that are in scripts -- firewall are not executed anyway because there is a #.
     
  79. Beast

    Beast Network Guru Member

    Hi
    Have you tried to compile anything yet. I did and got 2 errors. I think its do to not haveing all the paths correct and maybe missed a dependency. I know there is a log file somewher but where???? BTW do you know where the user.profile and shell.profile files are kept in Linux. Im useing ubuntu on an old computer. And from what I can tell no files are compiled when errores occur. At least I could not find any in the image dir. Im used to using Ztree in windows for my file manager, so im having a hard time getting used to the windows like file manager in Linux. And was unable to find my test compile via search function. I checked out from the git the Toastman 7483.1, this has a minor change of the buffer size to help with vpn. I had been running the 7483 version. So this seems a good choice to experiment with. Im not aware that Toastman compiled this version. Once I get this setup to compile something.... then off to checking out the source code in detail. (And lots of reading about programming). My brain hurts.
     
  80. Beast

    Beast Network Guru Member

    Hmm Asus RT-N16
    Loaded 4406.1 and now my power light turned off again and the wireless toggles between acceptable and severe. Rate stays at 300 mbs.

    No nvram reset from 4406 to 4406.1
     
  81. tenskwatawa

    tenskwatawa Networkin' Nut Member

    Hi,
    I use now v1.28.7485 MIPSR2-Toastman-RT-BETA K26 USB VPN and VPN works perfectly with more then 3 tunnels with full routing between server site and all clients sites.
    Thak you very much for you very good and hard work for us.
     
  82. djroby19

    djroby19 Networkin' Nut Member

    Hello Toastman I wrote a little post but you did not respond even to the one .. or that you are full of work but I would also like an exchange of opinions from you ..
    I wanted to let you know that by not using the feature to disable the wifi-time has notcrashed, I think the problem is to reboot the wifi does not see the exact time in thecrontab (04/10/2011 20:50:20 E-err 4200 crond cron time disparity of 21962570 minutesdetected)
    Could it be that you need to fill two separate and distinct rules for the two drivers wifi?
    What do you think?
     
  83. Toastman

    Toastman Super Moderator Staff Member Member

    djroby - the time discrepancy is normal when the router has started up but has not yet established the correct time.

    How are you trying to turn off your wireless? Are you doing it the easy way with the GUI on the Access Restrictions page?
     
  84. djroby19

    djroby19 Networkin' Nut Member

    Yes.. Access Restrictions page
     
  85. Toastman

    Toastman Super Moderator Staff Member Member

    I have no idea why it would crash. I just tested mine, and it works perfectly with the wireless. Actually I've used timed access restrictions hundreds of times with no problems. Of course, it may be something to do with the E4200...
     
  86. djroby19

    djroby19 Networkin' Nut Member

    If I try with 15 minutes of time also works for me, the problem occurs after one dayas if it reactivates the wifi only works part of the ethernet
     
  87. pokerman123

    pokerman123 Networkin' Nut Member

    Toastman,
    Thanks for all the work you've done. For the E4200 firmware, do any of the tomato firmware's support openvpn? If so which ones?
    Thanks!
     
  88. Solace

    Solace Networkin' Nut Member

    Name toast
    Model Linksys E4200 v1
    Chipset Broadcom BCM4716 chip rev 1 pkg 10
    CPU Freq
    133MHz

    Flash RAM Size 16MB

    Time Thu, 06 Oct 2011 00:12:58 +0200
    Uptime 0 days, 17:03:14
    CPU Load (1 / 5 / 15 mins) 0.04 / 0.02 / 0.00
    Total / Free Memory
    60.05

    it was 480 and randomly changed prior to any reboot or modifications in router settings...

    also the router went into a boot loop when enabling BW limiter.

    EDITED:adjusted the proper bug being reported.

    1.cpu clocks down to 133mhz
    2.BW limiter causes bootloop
    3.E4200 tomato-E4200USB-NVRAM60K-1.28.0406MIPSR2-Toastman-VLAN-RT-N-BETA-Ext
     
  89. Beast

    Beast Network Guru Member

    Thanks Toastman for compiling 7483.1 , for me this version is running nice and stable. Power light stays on and wifi light is steady. Question, is the IPtrafic mointor in the newer builds version 2.0 ??? I saw a post by Teaman somewhere that said to stay tuned he was coming out with version two. I may just buy me another Asus, so I have one to experment with.
     
  90. Toastman

    Toastman Super Moderator Staff Member Member

    v2 is not yet in the compile, because we are having trouble in integrating it into K26 MIPSR2 release. Soon I expect. You can buy your router now, though ;)
     
  91. Toastman

    Toastman Super Moderator Staff Member Member

    .
    Toastman-RT-1.28.7486-RT MIPSR2 K2.6 for RT-N16 etc.
    Toastman-RT-1.28.0486-RT-N MIPSR2 K2.6 for E4200 etc.

    With Teaman Client Monitor (BWclimon)
      • MiniDLNA 1.0.22: cvs 2011-08-25
      • Miniupnpd ver. 1.6 (20110725)
      • Dnsmasq: 2.58 update
      • Busybox 1.18.5 update
      • radvd: 1.8.1 update
      • ebtables: update to 2.0.10-2 (August 11th, 2011)
      • Samba 3: security updates CVE-2011-2522 & CVE-2011-2694
      • ntfs-3g release 2011.4.12
      • IPV6 improvements
      • BCM SDK: 5.10.142.0: wireless driver
      • BCM SDK: 5.100.138.9: wireless driver in RT-N builds
      • PPP: single line MLPPP support
      • Support for Belkin F7D3301/F7D3302/F7D4301/F7D4302/F5D8235v3 routers.
      • Added support for USB led on E3000, WRT610Nv2, DIR-320, H-618B routers.
      • Various optimizations backports and fixes from upstream 2.6 kernel.
    NB - These builds have the normal Setup interface, they do not have the VLAN-GUI feature
    nor the newer IPT Traffic Monitor from Teaman. If you need these look for the Toastman-VLAN builds. The RT-N versions have a newer (and bigger) wireless driver optimized for use with the E4200 and other dual-band routers. It will probably work well enough on earlier routers too, but there may be compatibility problems. It works fine on RT-N16 and E3000 here. Your mileage may vary :cool:

    Includes the above new updates from Tomato-USB/RT by Fedor Kozhevnikov.

    Source code is at http://repo.or.cz/tomato

    Based on Tomato firmware by Jonathon Zarate.
     
  92. Solace

    Solace Networkin' Nut Member

    edit: both show now under newer/different directory.

    will give them a whirl later on

    is there any noted changes for 0406.2?

    or is it the same as 7486 but just includes whats not included in 7486
     
  93. Toastman

    Toastman Super Moderator Staff Member Member

    7486 doesn't have the IPTraffic Monitor or VLAN-GUI. It's in the readme files.
     
  94. Pioneer

    Pioneer LI Guru Member

    I wonder what version is the best for my E2000... 7486 or 0486?​

    Any ideas?​
     
  95. Toastman

    Toastman Super Moderator Staff Member Member

    Try them both and let us know!
     
  96. nick birke

    nick birke Networkin' Nut Member

    Hi toastman thanks for the great job. I have an e3000 and i want to now if for the new versions rt-n for the e3000,will there be one with both usb and vpn for the e3000? for now i use the tomato-E3000-NVRAM60K-1.28.0486MIPSR2-Toastman-RT- N-VPN.bin,n but i would like to have the usb support also.

    Thank you.
     
  97. kthaddock

    kthaddock Network Guru Member

    @toastman
    Have you read this?:
    http://www.linksysinfo.org/index.php?threads/new-victek-releases.33910/page-48#post-173144

     
  98. csm746

    csm746 Network Guru Member

    Good morning Toastman....

    I flashed 0486 std on my E4200 this AM. Seems stable and the functions I utilize appear to be working....DDNS, port forwarding, WPA2 personal with AES, etc. Above you list an updated version of the Broadcom driver, but o486 for the E4200 is still reporting 5.100.138.9. Is the earlier driver retained in this build? Thanks for your great work and I will continue to beat this up.
     
  99. Toastman

    Toastman Super Moderator Staff Member Member

    No, these are merely extracts from Teddy Bear's notes on the new updates.

    Thanks for the feedback :)
     
  100. Solace

    Solace Networkin' Nut Member

    E4200 0406.2

    still getting boot loops when BW limiter is enabled, enabled BW limiter then rebooted router manually and would end up in a boot loop.

    gonna give the other one a whirl now. also i know what the different features of the two builds were, what i was asking previously was that the changelog you posted applied to 0406.2 and not just 0486 i would assume no since the build dates are a day apart.
     
Thread Status:
Not open for further replies.

Share This Page