1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Toastman-RT latest commit (7502.3) troubleshooting Wireless Client + virtual AP

Discussion in 'Tomato Firmware' started by MrPumo, May 15, 2013.

  1. MrPumo

    MrPumo Reformed Router Member

    Hi, I'm troubleshooting "tomato-K26USB-1.28.7502.3MIPSR2Toastman-RT-VLAN-VPN" latest commit (7502.3) on ASUS RT-N16 with a specific config (Wireless Client + Virtual AP):

    - eth1 Wireless Client WPA2 PSK AES with WAN DHCP and bridged on br0 (with all lan ports)
    - wl0.1 Virtual AP WPA2 PSK AES bridged on br1
    - Gateway mode

    1) Configured just eth1 for Wireless Client everything works fine: WAN IP got assigned and routing works fine from lan ports.

    2) Adding wl0.1… waiting for service restart… Default GW from DHCP Response got lost in routing table (ISSUE 1). Adding manually default gw and everything works fine from both lan ports and clients of Virtual AP.

    3) Reboot… WAN DHCP stuck on renewing.. (ISSUE 2)

    wl -i eth1 sta_info reports AUTHENTICATED ASSOCIATED but not AUTHORIZED so I suppose a wpa authentication or a driver issue..

    My question:
    ISSUE 1
    - seem related to default WAN GW acquired through DHCP..

    ISSUE 2
    - Is there a way to troubleshoot manually the problem? can I kill all the running process related to WPA authentication and start manually step-by-step from command line?

    - Anybody can overview router boot startup sequence (scripts & binary) so i can check to see what's happening during startup?

    - Can I compile the firmware with any DEBUG option?

    - I've seen just one "nas" entry in process list: should be two? One nas -S for eth1 and another nas -A for wl0.1 ??

    - What's "eapd" used for?

    - do I need nas_alternate parameter in nvram (I'v read somewhere that's not needed anymore starting from K26..)

    Any other troubleshooting path to follow?

    Thx a lot,

Share This Page