1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tomato 1.25 buffalo whr-hp-g54 tx/rx amps?

Discussion in 'Tomato Firmware' started by doctorp62, Aug 13, 2009.

  1. doctorp62

    doctorp62 Addicted to LI Member

    I recently converted my buffalo whr-hp-g54 from dd-wrt to tomato 1.25.

    Messing with the settings for the tx (HP amplifier) and the rx ( Enhanced recieve sensitivity) in the web interface seemed to be producing strange results.

    I did a little digging by telneting into the router and using nvram get boardflags to verify that the amplifiers were on.

    With the web interface set to HP tx: enabled, and enhanced recieve: enabled (and after hitting save)

    nvram get boardflags returns 0x2758

    from the dd-wrt forum on th buffalo:

    0x0758 - no amp and receive sensitivity normal
    0x1758 - enhanced receive sensitivity
    0x2758 - amp on, normal receive
    0x3758 - both amp and BroadRange enhanced receive sensitivity on

    The above indicates that both tx and rx amps on should be boardflags=0x3758.

    In tomato setting HP tx: enabled, enhanced receive: disabled (then save)
    results in boardflags=0x3758.

    Thus it would appear that the tomato web interface has the enabled/disabled indicator reversed for the enhanced receive sensitivity.
     
  2. darthboy

    darthboy LI Guru Member

    there're old info on ddwrt wiki or forums. Recent info suggests that 3758 is tx-on/rx-off. 2758 is tx-on/rx-on
     
  3. doctorp62

    doctorp62 Addicted to LI Member

    Thanks for clearing that up.

    Do you have a good reference for the boardflags?

    I'm sure the dd-wrt people would be happy to receive a correction, and supporting docs are always reassuring.

    I don't suppose we have anything as straight forward as tech specs from buffalo(?)
     

Share This Page