1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato 1.28 QOS and large file transfers over PPTP VPN

Discussion in 'Tomato Firmware' started by mmakowski, Feb 2, 2011.

  1. mmakowski

    mmakowski Networkin' Nut Member


    Have an interesting problem with QOS.

    When QOS is enabled, transfers of large files over vpn connections cause the PPTP VPN to lock up after the first megabyte or so. I must disconnect the VPN and reconnect it in order to reestablish VPN functionality. Files less than 1MB in size generally do not cause a problem. If I disable QOS entirely in Tomato then file transfers work properly every time no matter their size.

    It's acting like an MTU issue but I can't figure out why simply disabling QOS corrects it every time. I've tried changing all QOS settings and have confirmed that the VPN helper is enabled. Nothing that I alter causes any change in file transfer behavior. The remote network is using an MTU of 1400 on PPTP. I've tried moving that value both up and down with no affect either.

    This certainly seems to be related to Tomato but I'm open to suggestions. FYI I have also done a fresh install after clearing ram. Everything is fine until I turn on QOS. My outbound VPN connection is to a Watchguard X-Core firewall.


Share This Page