1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tomato compiling error

Discussion in 'Tomato Firmware' started by azdps, Jan 21, 2010.

  1. azdps

    azdps LI Guru Member

    i'm getting an error while compiling tomato 1.27. i didnt make any modifications to the firmware. im using ubuntu 9.10 and get the following error when compiling:

    *** No rule to make target `zImage'. Stop.

    is anyone familiar with this particular error at all?
     
  2. ringer004

    ringer004 LI Guru Member

    Since no one has spoken up yet, I can try. :)

    1) What shell are you using? I think I heard Ubuntu does not use 'bash' as the default shell. I also think you need 'bash' to compile Tomato. Someone else can speak up if I'm mistaken here.

    2) Did you follow the directions in the README? Get the original Linksys source, remove the long list of directories, untar tomato.tar on top of the new tree, etc.

    I just tried a 1.27 compile and it worked perfectly (standard build, not ND)
     
  3. roadkill

    roadkill Super Moderator Staff Member Member

    yes you have to replace the link /bin/sh have it pointing to /bin/bash
    try ls -al /bin/bash
     
  4. mstombs

    mstombs Network Guru Member

    and the 'correct' way to do it on Ubuntu is to

    Code:
    sudo dpkg-reconfigure dash
    and answer the prompts. If you manually change the symlink and get it wrong it is tricky to recover, not impossible, you have to manually replace the bash executable before rebooting - BTGTTS.

    You can also select for any bash script which shell it should use by changing the first line in the file away from /sh
     

Share This Page