1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato doesn't see new cable modem

Discussion in 'Tomato Firmware' started by jking, Mar 15, 2009.

  1. jking

    jking Addicted to LI Member

    Hey guys, I have a WRT54GS with Tomato 1.23 installed. I had it working with an old cable modem and today I just got a new cable modem and it no longer works. It doesn't even show up in the device list in Tomato (as a vlan1), I can see my computer as a br0 but not the modem. If I plug my computer straight into the modem it works fine, I can use the internet to post this message. The modem is indeed plugged into the "Internet" port on the router. The cable works because I'm unplugging it from the router into my computer and it works. It's also not a cross over cable. Any ideas?
  2. bripab007

    bripab007 Network Guru Member

    Try plugging the cable modem back into the router, reboot Tomato, THEN power cycle the modem.

    If that doesn't work...does the new cable modem do its own NAT'ing? That is to say, does the new cable modem have a built-in firewall, DHCP server, etc.?
  3. szfong

    szfong Network Guru Member

    Whenever this happens to me, I either hit release/renew, or restart Tomato WHILE CABLES ARE CONNECTED to the Modem.
  4. jking

    jking Addicted to LI Member

    That seemed to work. I don't know why that didn't work before I swear I tried that like 3 times.

    I tried what you said szfong but it didn't do anything. It would always be stuck on renewing it, and restarting didn't change anything.

    Thanks for the help guys!
  5. bripab007

    bripab007 Network Guru Member

    For some reason, my cable modem's always been like that. My cable company doesn't tie their service to a particular MAC address, however, when swapping modems, it does appear that the cable modem has to be power-cycled to register the new device's MAC.
  6. gjcomputer

    gjcomputer Addicted to LI Member

    i have the same problem with my asus router, and my linksys. i dont think i had this issue with past versions of tomato (been using almost 2 years.) but when i make a change on the router, and need to release \ renew, i have to do just that. plug everything in (router) and then reboot modem to get an ip address, otherwise it just sits on "disconnected" or "renewing"
  7. fyellin

    fyellin LI Guru Member

    Same for me. I just swapped routers, and needed to reboot the cable modem to get it to give me an IP address.

    I realize that I could have given my new router the same WAN MAC address as the old one, but I'm all for keeping configurations as simple as possible.
  8. gjcomputer

    gjcomputer Addicted to LI Member

    everyone that is having this issue, are you using the ND version?
  9. bripab007

    bripab007 Network Guru Member

    I am, yes.
  10. gjcomputer

    gjcomputer Addicted to LI Member

    so am i, it looks like it is something with the ND firmware... i bet there are others with this issue.
  11. fyellin

    fyellin LI Guru Member

    Not me. I'm using SgtPepperKSU's non-ND build.

    This issue has also happened to me back when I was using stock firmware. If I got a new router, I'd always have to reboot the cable modem.
  12. RonWessels

    RonWessels Network Guru Member

    When switching routers, I suspect a lot of problems will be avoided if, before disconnecting your old router, you first have it release its DHCP connection. Then disconnect the old router and install the new router. This way, it will be requesting a DHCP allocation without one already having been allocated for that line/account.

Share This Page