1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Firmware for Linksys E1000 v2.1 (will help)

Discussion in 'Tomato Firmware' started by Julzk, Oct 17, 2011.

  1. Julzk

    Julzk Reformed Router Member

    Hello Victek and other Tomato users :)

    First of all, Tomato firmware is brilliant! But I have one problem. I recently purchased two Cisco Linksys E1000 routers version 2.1. Is there any way to get the Tomato RAF firmware working on these routers? If not at the moment, what can I do to help you get it working on these routers? I have noticed there are 3 versions of this router (v1.0 / v2.0 / v2.1). The v2.1 routers I have are almost identical to the new v2.0 E1000’s, except slightly different somewhere in the hardware.

    If you can get a working version of the Tomato RAF Firmware on the Linksys E1000 v2.1 router I would be greatly appreciated! If I can assist you in any way with testing the firmware, getting extra hardware information I’ll be here to help. If you can get a working version of it, I will gladly donate $ to your cause! Please remember, hardware is almost the same between v2.0 and v2.1 versions of this router, but there is something very different between the two.


    · There is a thread on DD-WRT forum where people have bricked their Linksys E1000 v2.1 router when attempting to use DD-WRT firmware for the v2.0 router.

    · For technical specifications, here is the difference between v1, v2 and v2.1 Linksys E1000 routers: http://en.wikipedia.org/wiki/Linksys_routers#E1000

    · Here is the DD-WRT thread where someone named “Eko” did a test build of DD-WRT for testing on the Linksys E1000 v2.1 router -> http://www.dd-wrt.com/phpBB2/viewtopic.php?p=605627

    · Another person then downloaded the test build “Eko” compiled and installed it and returned the CFE file which can be downloaded here -> http://www.dd-wrt.com/phpBB2/download.php?id=19257 (This file may or may not help you as it’s mostly for DD-WRT builds)

    · Shortly afterwards, “Eko” came back with a proper release of the DD-WRT firmware for the Linksys E1000 v2.1 on the same forum thread I linked above for DD-WRT.

    · Here is the latest official Linksys E1000 v2.1 firmware from the cisco.com website (http://homesupport.cisco.com/en-us/wireless/linksys/E1000 be sure to select version 2.1 under downloads) -> http://homedownloads.cisco.com/downloads/firmware/1224659832444/FW_E1000_2.1.02.005_US_20110506.bin



    Some extra information for the Linksys E1000 v2.1 Router:

    Platform

    Serial Num. = CNV2
    FCC ID = Q87-E1000V21
    CPU Type = Broadcom BCM5357B0KFBG (BCM5357B)
    MIPS Rev = ?
    CPU Speed = 300MHz
    Bus = ?
    Flash Type = Serial
    Flash Chip = ?
    Flash Size = 4MB
    Max Firmware Size = 3801088 bytes
    RAM Size = 32MB
    RAM Chip = ?
    nvram Size = 32kb
    Switch = ?
    Port-based vlan = ?
    802.1q vlan = ?
    Ethernet Port Count = 1-10/100-WAN 4-10/100-LAN
    Wired Standard = IEEE 802.3/3u
    boot_wait = ?
    bootloader = CFE
    Flash Card Socket/Type = No
    SD/MMC Mod Support = No
    MiniPCI slots = No
    PoE = No
    Power = 12V/0.5A
    Color of LEDs = ?
    Size = 7.95" x 1.34" x 6.3" (202 x 34 x 160 mm)
    USB = No
    Serial Port = Yes
    JTAG Port = Yes
    Supported by TJTAG/Version = ?
    Supported by dd-wrt as of = 16968
    dd-wrt K2.4 Support = No
    dd-wrt K2.6 Support = Yes
    Special Features = ?

    Radio (wl0)

    Wireless Radio = ?
    WLAN DSP processor = ?
    Antenna Connector Type = Internal
    Wireless Standard = IEEE 802.11b/g/n
    WiFi Operating Frequency = 2.4GHz
    802.11n Draft = up to 300Mbps
    802.11g = 6, 9, 12, 18, 24, 36, 48, 54Mbps
    802.11b = 1, 2, 5.5, 11Mbps
    Radio cor_rev = ?
    Radio Capabilities = ?

    Looking forward to hearing from you soon!


    Kind Regards,

    Julzk
  2. shibby20

    shibby20 LI Guru Member

    please install ddwrt and give me dump of nvram. I will add support for this router.
  3. Julzk

    Julzk Reformed Router Member

    I'll get it for you in 5 minutes :)
  4. shibby20

    shibby20 LI Guru Member

    have you TTL serial cable? I will do build for you but i cant test is before. It is a chance to brick your router! Are you prepare for this?
  5. Julzk

    Julzk Reformed Router Member

    I've done a ...# nvram show > dump_nvram.txt

    I've attached the result here. One last thing, I do not have a TTL serial cable. What do you mean by this change will brick my router?
  6. shibby20

    shibby20 LI Guru Member

    give me also:
    "cat /proc/cpuinfo"

    It will be high experimental firmware. i cant guarantee you it will works.
  7. Julzk

    Julzk Reformed Router Member

    root@DD-WRT:/# cat /proc/cpuinfo
    system type : Broadcom BCM5357 chip rev 1
    processor : 0
    cpu model : MIPS 74K V4.9
    BogoMIPS : 149.91
    wait instruction : no
    microsecond timers : yes
    tlb_entries : 64
    extra interrupt vector : no
    hardware watchpoint : yes
    ASEs implemented : mips16 dsp
    shadow register sets : 1
    VCED exceptions : not available
    VCEI exceptions : not available

    dcache hits : 2147483648
    dcache misses : 4294704894
    icache hits : 2147483648
    icache misses : 3875012094
    instructions : 2147483648
  8. Julzk

    Julzk Reformed Router Member

  9. eahm

    eahm Addicted to LI Member

    Julzk, you can find that router for $24...just sayin'.
  10. Julzk

    Julzk Reformed Router Member

    I'm aware of that, however here in Australia the bastards sell for $60 :(
  11. shibby20

    shibby20 LI Guru Member

    you can buy CA-42 cable for nokia phones. Remember - dont by original nokia cable (will not works) but chinesse product :)

    and a picture
    [​IMG]
  12. Julzk

    Julzk Reformed Router Member

    Hey shibby :)

    How goes the E1000 v2.1 tomato firmware build? Do you need me to get you any other data from the router?
  13. Julzk

    Julzk Reformed Router Member

    Alright, got me the CA-42 cable, stripped it and hooked it up. Mine was the clone version of the CA-42 cable. Had only 3 wires: Orange / Blue / Red..

    On DD-WRT wiki, the serial recovery article mentions Orange is ground, Red is TX and Blue is RX. Well I found difference. Orange was ground but Blue was TX and Red was RX, after swapping them around my serial terminal session began to work.

    I tried your experimental E1000 v2.1 Tomato RAF build shibby and it bricked it. Anyhow I hope this will help you get a little information on what the problem may be. I have attached the terminal boot log of the router. It may of rebooted maybe 1 or 2 times before I killed the router. Check the attached text file.

    Attached Files:

  14. Julzk

    Julzk Reformed Router Member

    Shibby, before I restore the original firmware, I thought I'd get you a second NVRAM dump from terminal after breaking out of the boot sequence. Check attached file

    Attached Files:

  15. Julzk

    Julzk Reformed Router Member

    I restored the original firmware from the cisco website for the E1000 v2.1.

    I have attached the terminal log from the restoration of the firmware and then the original linksys firmware booting up. As a matter of fact, when you open up this log, there's something really funny someone from Cisco put in their firmware. During the bootup it returns the following (LOL):

    dnsmasq use dynamic port
    cmd=[cesmDNS -o /tmp/.mdns_host_info -d ](17)
    olllllllllllllllll
    hahahhhhahhahhahha: Starting in daemon mode
    11111111111111
    br0 192.168.1.100 86400
    cmd=[ip neigh flush to 192.168.1.0/24 dev br0 nud permanent ](17)
  16. Kyle

    Kyle Reformed Router Member

  17. Kyle

    Kyle Reformed Router Member

    I got it installed, will be testing soon
  18. Julzk

    Julzk Reformed Router Member

    Yes I've been running DD-WRT as in my signature, unfortunately DD-WRT blows chunks but it's the best thing at current for v2.1 versions of this router. I am awaiting for Teddy to return as he has experience with porting Tomato to the Linksys Exxxx series already. Shibby has been assisting me too but so far unsuccessful with his experimental builds of Tomato for the E1000 v2.1. Maybe Victek / Teddy or some other kind soul will help again soon to port Tomato over. Can only wait and see :)
  19. louiemiranda

    louiemiranda Reformed Router Member

    Hope there will be a build soon for e1000 v2.1
  20. Julzk

    Julzk Reformed Router Member

    I hope so as well :)

    I got a reply back from Victek (Tomato RAF) via email at the end of last month and Vic mentioned when he returns from his work in China he will continue and build a release version of Tomato for the 2.1 version of this router once he has finished with the 9007 release.

    Meanwhile if Shibby can borrow his friends E1000 router maybe he can do another test build for us or if Teddy Bear returns he too will be able to assist as he has ported Tomato USB version of the firmware to the E1000 v1.0 routers, so either which way I too hope someone will be able to continue with some test builds. I've bricked it a few times trying and attempting different firmwares on the E1000 2.1 and have de-bricked it a good dozen times so far :

    As per my previous responses, hopefully this data will be enough to assist with developing further test builds. I cannot be to much different than say the E1000 v1.0 other than CPU and integrating the new Broadcom Wifi drivers in the build.
  21. Tyrel

    Tyrel Reformed Router Member

    I'm just writing here to show that there is indeed much need of a Tomato build for Linksys E1000 v2.1 routers.

    I badly need a WOL feature for this router, however none of the old workarounds which worked for previous generation Linksys routers work on this device, which could be used to trick it to open a port to the broadcast address of my LAN.
    So, i can't wake my PCs up remotely, because the darn' router does not allow me to send a WOL packet from WAN to my LAN's broadcast address...

    I've been trying DD-WRT, but that thing really pissed me off. It's quite buggy, the browser ends up in a blank white page on my every third click, and there are also a great many of unnecessary things in it. But the biggest problem with DD-WRT is, that the DDNS feature of it is bugged and doesn't work since a couple of versions. However a version which is old enough to have the feature working, does not yet support this router... And the devs of DD-WRT don't give a %^&# about it...

    So, Tomato is my last and only hope, please make a build for this router if you can.

    By the way, is it only me finding it funny, that nowadays in the world of "energy saving" and "mobile devices" i'm completely unable to reach and turn ON my home PC through internet? This feature should be a "must have" in all the new routers, but instead, i have to leave the darn' PC turned on through the whole day, just for the 15mins i would use it remotely... What a joke...

    Any rough ETA about when this build could see daylight?
  22. louiemiranda

    louiemiranda Reformed Router Member

    Any news Julzk? Thanks a lot man!
  23. headlesshorseman

    headlesshorseman Network Newbie Member

    Is this router supported by the latest version of Tomato? Thanks!
  24. lissny

    lissny Connected Client Member

    excuse me sir.. plz any one help me plz....... I have linksys E2500 router ...what version of firmware should I use.. There is no Support for e2500.. but only i can found there E2000; E3000; E4200; but for E2500 what should I use.. PLZ Help me... i need TOMATO,, Firmware.,,, It seems Good...
    Help ME PLZ
  25. Julzk

    Julzk Reformed Router Member

    Nothing new has come of this as yet. My below post is still the most recent.

  26. tvlz

    tvlz Serious Server Member

    In the test build Shibby made do you know if he made any changes in /router/rc/mtd.c, all the other linksys routers seem to require changes in mtd.c, I don't know if the change will make it work, but you never know!:rolleyes:

    EDIT: Looks like 'case 0x30303031: // 1000 E1000v2/v2.1' needs to be added for E1000v2/v2.1 support.
  27. Julzk

    Julzk Reformed Router Member

    Well if Shibby can come back and do a re-build test for me with these changes I'll be happy to try it again on one of my E1000 2.1 routers. Worst case, it'll just brick it and I'll un-brick it again :)
  28. tvlz

    tvlz Serious Server Member

    already done check PM
  29. Julzk

    Julzk Reformed Router Member

    Great, I will test as soon as I get home and report back my findings / news here :)
  30. Tyrel

    Tyrel Reformed Router Member

    Hey guys, sorry for disturbing - i just wanted to express how grateful i am for you to trying to make a Tomato build for E1000 v2.1! :)

    After finding out DD-WRT is a huge letdown and no other firmwares support this router, Tomato (which by the way seems quite awesome, i have huge expectations for it) is my last hope for making this thing useful.

    ...so, just thanks again for spending precious time for this! I really hope it will work, so that it's worth it. :)
  31. Julzk

    Julzk Reformed Router Member

    So I tried the build Shibby made but no luck. It begins the boot then hard resets. I attempted to hold the pin in and do a soft reset and power cycled the router but no go. I've since un-bricked it as well. Shibby, make us another build :)

    case 0x30303031: // 1000 E1000v2/v2.1
  32. Julzk

    Julzk Reformed Router Member

  33. big0bum

    big0bum Network Newbie Member

    Hey I registred just to say thanks for building a future Tomato firmware for this router. I've been using DD-WRT since the day I bought this router and I've been satisfied. I accidentaly seen yesterday a thread on a forum on which a guy benchmarked the same router with different dd-wrt and stock firmwares. I was astonished to see that the DD-WRT performed worse even than the stock firmware.

    I look forward to see a final&working build for E1000V2.1.
  34. big0bum

    big0bum Network Newbie Member

    Hey, I was thinking maybe the bootloader for dd-wrt helps the developer.
    I've uploaded it here as a zip.

    I can help with any other files the developer wants, but I must say it now that I can't test experimental builds since the E1000 is my only router and I don't have the necessary things to unbrick it.

    Attached Files:

    • cfe.zip
      File size:
      129.6 KB
      Views:
      55
  35. Julzk

    Julzk Reformed Router Member

    I can test any builds and de-brick my E1000 v2.1 if need be, done it a few times already in attempts at just sticking various firmwares on it :p
  36. big0bum

    big0bum Network Newbie Member

    Any other updates on this?
  37. tvlz

    tvlz Serious Server Member

    Still being worked on, fix one thing find others that need to be fixed
  38. lissny

    lissny Connected Client Member

    The bins...
    dd-wrt.v24-18625_NEWD-2_K2.6_mini-e2500.bin
    Description: [​IMG]
    Download

    Filename: dd-wrt.v24-18625_NEWD-2_K2.6_mini-e2500.bin
    Filesize: 3.29 MB
    Downloaded: 21 Time(s)

    dd-wrt.v24-18625_NEWD-2_K2.6_mini-nv60k.bin
    Description: [​IMG]
    Download

    Filename: dd-wrt.v24-18625_NEWD-2_K2.6_mini-nv60k.bin
    Filesize: 3.29 MB
    Downloaded: 12 Time(s)




    Enclosed is a screenshot of working bin of E2500


    [​IMG]


    That is linksys e2500 DDWRT ......................
    Can we have toastman build for e2500 ..?????????????
  39. Tyrel

    Tyrel Reformed Router Member

    Any progress or any news?

    I'd like to know if we ever get a working version for E1000 v2.1, or i'd also like to know if this project is dumped, so i won't wait for it anymore. I'd badly need something for this router, the factory firmware is too dumb while DD-WRT is buggy as hell... :(
  40. big0bum

    big0bum Network Newbie Member

    Any more news?
  41. tvlz

    tvlz Serious Server Member

    Try this test build
    I don't have a E1000v2/v2.1 that I can test on, but I made a test build for E1500 that works so I don't think it will brick
    Try at your own risk and post screenshot and report bugs if you flash it.

    Removed -
  42. HWmonkey

    HWmonkey Network Newbie Member

    I have an E1000/V2. I attempted to use the file (E1000v2-v2.1 Test Build), even though I have not made a de-brick serial cable. I tried a firmware upgrade using factory firmware upgrade and it crashed between 3 and 4 percent. It does not brick.

    Next, I tried the firmware (E1000v2-v2.1 Test Build) using dd-wrt. DD-wrt is so buggy that it is difficult to tell what happens (at first). I had a very difficult time getting the dumb dd-wrt to do much of anything through their interface. I tried doing a firmware upgrade (to E1000v2-v2.1 Test Build) through dd-wrt and it failed several times. Then I tried to roll back to the Cisco version without luck (dd-wrt stinks). Somehow, I was able to get dd-wrt into a state where it would accept a firmware change, but I had it revert to the Cisco stuff rather than try E1000v2-v2.1 Test Build.

    Then, I again tried to upgrade to E1000v2-v2.1 Test Build from the Cisco firmware. It failed. I reloaded dd-wrt. It still would not upgrade to E1000v2-v2.1 Test Build in dd-wrt. In fact, I could not even tell the buggy dd-wrt to restore to dd-wrt defaults without failing.

    I decided there was a chance some of this was a browser issue (was using FF). I switched to using Winbloze Internet Exploder for my browser. Now, dd-wrt permitted me to restore defaults of dd-wrt (although the CSS made the pages screwed up slightly), so I thought I was making progress. Did I say dd-wrt was buggy? I tried an upgrade to E1000v2-v2.1 Test Build. This time, after about 5 seconds, dd-wrt gave me a message "Upgrade failed." I re-downloaded this firmware (E1000v2-v2.1 Test Build) to validate it was not my download, and tried again. After 6 seconds of the upgrade process, I get "upgrade failed." Using the Cisco firmware, the "upgrade" from dd-wrt takes about 45 seconds, so it does not get very far before failing..

    My opinion is that I have not found a good way to upload the firmware for testing and that if this firmware does work, it needs a different upload process. The vanilla Cisco interface does not work, and neither does dd-wrt.

    FYI - I messed around with this for 1.5 hours, and I am pretty darn proficient with network administration.

    I am willing to try again.
  43. tvlz

    tvlz Serious Server Member

    New E1000v2/v2.1 Test Build(removed link)
    Wait 5mins after flash, don't forget to erase nvram
  44. The Master

    The Master Addicted to LI Member

    Nice, i hope there is a near final release for Linksys E1000 v2... so i could get rid off ddwrt

    thanks
  45. HWmonkey

    HWmonkey Network Newbie Member

    Wait 5 minutes? You mean that after flashing it, leave the power unplugged for 5 minutes? After a hard reboot, I am not certain why to wait. Can you explain?

    Thanks!
  46. tvlz

    tvlz Serious Server Member

    I meant wait 5 minutes for flash to complete before reboot,

    Saw this on dd-wrt
  47. Toastman

    Toastman Super Moderator Staff Member Member

    Agree with tvlz and the other posters, so many people pull the plug on the router before it's finished doing it's thing. Many strange posts that are resolved by re-flashing are due to this. They just happened to have accidentally waited a bit longer on the subsequent flash... !

    Especially true of the E series like the E3000 which is agonizingly slow to flash anything...
  48. HWmonkey

    HWmonkey Network Newbie Member

    Good points. I always flash, let it do its thing (including a power cycle), and wait a little while. I never timed it. I never pull the plug until I see that it has rebooted and appears functioning. Furthermore, I can confirm that pulling the plug does something completely different that a "click the restart button" in many, many, many situations including commercial hardware costing thousands of dollars.
  49. tvlz

    tvlz Serious Server Member

    New Test Builds to try
    Post screenshot & report bugs if it works
  50. tvlz

    tvlz Serious Server Member

    Important:
    If you have successfully flashed a test build and it works PLEASE post and let us know,
    Shibby wants to include working models in this next build

    Use Shibby's build
  51. flashfart

    flashfart Network Newbie Member

    I have flashed an E900 with tomato-E900-NVRAM64K-1.28.0008MIPSR2Linsys_E-Series_TEST_BUILD-IPv6-VPN.bin

    The router did not brick. I have not tested throughput or any advanced configurations, but the wireless survey tool does function as expected.

    Tomato_E900.jpg

    Attached Files:

  52. Pew

    Pew Network Newbie Member

    Has anyone tried the latest build on E1000 2.1/2.0 yet?
    I've got an E1000 V2.0 and I'd really like a working version of Tomato for it :)
  53. Tyrel

    Tyrel Reformed Router Member

    Gah, we're so close to having a working Tomato for E1000 v2.1 and there's noone to test it... :(

    Where did Julzk and HWmonkey go?
    Wish i had a service cable to do the tests myself, but without it i don't dare bricking mine... Anyways how does this service cable looks like or what's the exact name of it?...
  54. tvlz

    tvlz Serious Server Member

    Look at page 1

    Supported now in Shibby Builds
  55. Pew

    Pew Network Newbie Member

    I think I just bricked my E1000 v2 with the lastest testbuild :p
    I had dd-wrt before, flashed with the new bin from Shibby Builds. It said the update was completed and rebooting but now nothing happens and I cant reach 192.168.1.1 from my web-browser. My computer is not getting an IP from dhcp either, tried setting it manually but I still cant reach the router. So I guess that means I bricked it.
  56. Seal

    Seal LI Guru Member

    Try going via wireless..i have same problem..wired cant reach the router but wireless can.
  57. Pew

    Pew Network Newbie Member

    My wireless aint on so I'm afraid my router is lost unless I get a ca-42 cable and unbrick it. =/
  58. Seal

    Seal LI Guru Member

    Resetting the router through reset should per default turn the wireless on?
  59. Pew

    Pew Network Newbie Member

    Yeah you're right ofcourse, I forgot that, silly me. I can reach the router throu the wireless now like you, thanks for the advice :) I hope they can get it to work for the physical ports aswell now, I'd be really happy :)
  60. tvlz

    tvlz Serious Server Member

    Removed
  61. Pew

    Pew Network Newbie Member

    Tried the commands but it doesnt seem to make a difference.
    I attached a picture of how the vlan assignment looks like, if it helps.

    Attached Files:

  62. tvlz

    tvlz Serious Server Member

    removed

    *edit*
    I've sent the changes to Shibby to include in his next release
  63. Pew

    Pew Network Newbie Member

    The new commands changed the vlan settings, but I still cant reach the router throu cable. I wont get an ip etc.

    The new build is too big it says. (is it supposed to be for ipv6?)

    Thanks for working on a solution btw, appreciate it :)
  64. tvlz

    tvlz Serious Server Member

    IPv6 support was in that build, the new wireless driver that Shibby used must have made that build too big for 4MB flash
    Try this smaller build
  65. Pew

    Pew Network Newbie Member

    This build works! I do now get an ip and I can reach the router throu the physical ports aswell. I've not tried any functionality yet since my sister is using our internet atm and I dont want to mess with her. I'll try it out when I get the chance tho! :)
  66. Pew

    Pew Network Newbie Member

    I'm now surfing throu the E1000 v2 with Tomato :) I've set limits on download/upload for one computer in the network (my sister keeps uploading pictures of her rabbits which fucks up my gameing :p ) and its working like a charm.

    I'm using two router since we got ADSL here and the E1000 is only a router with no built-in modem. Everything seems to be working just fine!

    Thanks again for all the effort you're putting into Tomato and making it accessable for more units :)
  67. big0bum

    big0bum Network Newbie Member

    Maybe i will test the new build by myself if i get more confirmations that it properly works, but tomorrow. I have no time for testing today.
    Any things to know before flashing over DD-WRT?
    Is it ok if I flash over DD-WRT? Should I hard-reset the router before flashing Tomato?
    Is the IPv6 working or should I try the normal build?
  68. Pew

    Pew Network Newbie Member

    I used the latest build tvlz posted, the smaller one. I updated from dd-wrt the first time and it worked just fine.
    I've used it for a day or so now and everything is working.
  69. big0bum

    big0bum Network Newbie Member

    Uh, I'm using for a few hours the build from here. No problems for now, haven't tested much, but the wireless speed is constanly between 3.4-3.5MB/s. With DD-WRT the speed was fluctuating near 3MB/s (2.9-3.2) with a maximum peak of 3.3-3.4 which lasted for about 5-7 seconds. With Tomato it's constant for the whole download time.
    PS: The speed is was tested using "wget ftp://rds:test@ftp.rdsnet.ro/TestDownload100MBytes" downloading the file in RAM (/tmp mounted in ram) so no HDD slowing. Wired speed is about 9MB/s.
    The build
  70. HWmonkey

    HWmonkey Network Newbie Member

    I will also confirm that the release at http://tomato.groov.pl/index.php?dir=K26RT-N/build5x-093-EN/Linksys E-series (experimental) does not work, whilest it appears the firmware at https://www.box.com/s/379098dfc88960e5a06d is functioning. I am having one pc (64-bit win 7) that is seeing two LAN connections when connected (although it connects to many, many, many lan networks without this occurring; somehow it is picking up a gateway of 0.0.0.0 when using a staticly-assigned DHCP) -- a first for this pc. The linux machine and other hardwired are fine. The wireless are fine. More testing ahead.

    Sorry for the delay.
  71. big0bum

    big0bum Network Newbie Member

    Didn't had this problem on WiFi nor on cable, niether in Linux or Windows 7. Maybe it's your PC's fault.

    Oh, any news about IPv6 in another build?
  72. Tyrel

    Tyrel Reformed Router Member

    Anyone tried the E1000 v2.1 test build from here?: http://tomato.groov.pl/download/K26RT-N/build5x-095-EN/Linksys E-series (experimental)/

    I'd really love to use Tomato but i got no de-brickin' cable if something goes wrong...

    P.S.: Ok, I've tried tomato-E1000v2-v21-NVRAM32K-1.28.RT-N5x-MIPSR2-095-Mini myself, but upgrade stops at around 5% progress with an upgrade failed message while upgrading from stock firmware.
    Also the build linked by big0bum (tomato-E1000v2-v21-NVRAM32K-1.28.0010MIPSR2Linksys_E-Series_Test_Build-Mini) does the same. Could it be possible that we can only upgrade from dd-wrt?...
  73. tvlz

    tvlz Serious Server Member

    Tyrel,
    What stock firmware version(it's stopping at a version check in the stock firmware)
    Have you tried flashing to the newest stock firmware first then flashing 095-Mini or 095-MiniIPv6.
  74. Tyrel

    Tyrel Reformed Router Member

    I've had dd-wrt previously on the router, but it sucked so much that i've reinstalled the latest stock firmware available back then... this still seems to be the latest.
    "Firmware Version: 2.1.02 build 5 May 6, 2011"

    I was trying the normal version not the IPv6, does that make a difference? Also i was trying to flash with IE9 as i've had bad experiences flashing with Firefox back when i was trying out dd-wrt.

    I'd say i try and risk flashing some more test builds, but if the router gets bricked i have no way of fixing it... I've already shit myself twice when the "Upgrade Failed" happened and the router wasn't responding for like half a minute afterwards... :( Sorry i can't really afford losing this thing right now...
    Anyways, safe (which might have some bugs but 100% do not brick it) test builds are welcome.

    Thanks for your work by the way!
  75. big0bum

    big0bum Network Newbie Member

    I've upgraded from DD-WRT and I had no problem. I've been running Tomato since then and all if fine.
  76. tvlz

    tvlz Serious Server Member

    Tyrel,
    Try flashing this version 095-mini flash from stock firmware
    I changed the version number that the stock firmware checks for to the one that dd-wrt uses.
    Give it plenty on time to complete after the flash(5 minutes or so) after that all should be good.:)
  77. Tyrel

    Tyrel Reformed Router Member

    No luck, "Firmware upgrade failed" again, right when the progress bar reaches 6%. :(
    Firefox encounters the same issue at 4%.

    Wanna make other test builds or should i try to flash dd-wrt first, then tomato and see how that works out?
  78. tvlz

    tvlz Serious Server Member

    Had to change the revision number also.
    Flash from stock firmware builds
    You could but that wouldn't help fixing this in Tomato!:(
  79. Tyrel

    Tyrel Reformed Router Member

    Man, you fixed it! :)

    Upgrade was a bit weird, first i got an error that i can't upgrade now and i have to restart the router. After restarting i could initiate the upgrade, but it didn't reach 100%... Stopped at 50% instead with an "Upgrade successful" message. Freaked me out at first, though it left half the firmware out...

    Anyways the router booted up just fine, keeping many of my settings from the stock firmware. I've did a configuration reset, but only a normal one, i had no idea what the erasing of the NVRAM could cause or what it is...

    Anyhow the router didn't get bricked, it works pretty nice this far. Internet through PPPoE, WLAN, Bandwidth limiter, some custom DHCP settings... remote admin access through https using dyn-dns to find it, WOL (god i wanted this one so bad)... Unlike dd-wrt, everything seems to work here and every setting seems to have it's desired effect this far.

    I'm amazed by how many features this firmware has! I thought this will be good, but i didn't expect THAT good. Hats-off to you Sir, this thing is incredible!

    Thank you so much!
  80. tvlz

    tvlz Serious Server Member

    Good to Hear:D

    You NEED to go to admin -> configuration -> restore default configuration ->erase all data in nvram(thorough) to get rid of the stock linksys settings and then manually re-add all your settings or you will have problems!
  81. Sequals3

    Sequals3 Network Newbie Member

    Created an account just to say thank you to tvlz for his posts. After reading this entire thread, I decided to go ahead and flash with the firmware you posted in post #78. This was much easier than DD-WRT flashing and quicker too. After looking through the interface, I can't think of anything I need that is missing. Thanks to all who have kept this build at the top of the wish list.
  82. zebus

    zebus Network Newbie Member

    I know next to nothing about Tomato, so I'm hoping someone can help me out. I discovered this thread and am going to install this on my e1000v2.1, but I'm wondering after I do that, what version of Tomato can I upgrade to afterwards. Seems there are like a dozen branches, then each branch has several different versions, so I'm more than a little confused.

    I'd like to run something that can monitor internet traffic per IP (the whole reason I want to switch from dd-wrt), so I'd like to run something like Teaman or Toastman if it was possible since those are the two I've found so far that have this feature.
  83. Toastman

    Toastman Super Moderator Staff Member Member

    RT-N branch

    tomato-E1000v2-v21-NVRAM32K-1.28.0500.2MIPSR2Toastman-RT-N-Mini
  84. Julzk

    Julzk Reformed Router Member

    Hey all! apologies for being away for so long, I have not forgotten! Have been wrapped up in some house moving, car dismantling etc. But I'm back and right now I am currently in the process of plugging in one of my E1000 v2.1 routers currently equipped with DD-WRT and will try one of the experimental builds. Hold tight :)
  85. Julzk

    Julzk Reformed Router Member

    Alright well, first router flashed fine.. From Stock I flashed my E1000 v2.1 to the DD-WRT Build:

    DD-WRT v24-sp2 (05/03/11) mini - build 16968M NEWD-2 K2.6 Eko

    After that, was successful I then completed a Hard Reset (pin in back of router for 8 seconds). I then waited for the router to come back online and logged into the router (DD-WRT console) and processed again to do a hard reset through the software in the console itself. After that was done, I then went to the Upgrade screen within DD-WRT console and upgraded to the following Tomato Build (and yes I selected to do another hard reset after the backup was done):

    tomato-E1000v2-v21-NVRAM32K-1.28.RT-N5x-MIPSR2-101-Mini
    URL -> http://tomato.groov.pl/download/K26...-v21-NVRAM32K-1.28.RT-N5x-MIPSR2-101-Mini.bin

    After a leaving it for 5 minutes odd to make sure it finished doing it's thing, I could log in via 192.168.1.1.. YAY! Tomato on the E1000 v2.1 :)
  86. Julzk

    Julzk Reformed Router Member

    The testing done so far:

    WDS Bridging done between the two E1000 v2.1 Routers (Wireless Network Mode set to "N Only" as 40Mhz, But I seem to get some various speeds jumping up and down so am considering leaving "N Only" but dropping it down to 20Mhz)..

    L1 Router (Located 10ft away from L2 connected to DSL modem)
    Clients:
    - 3 Dell XPS 15 laptops (Wireless)
    - 2 iPhone's (Wireless)
    - 2 iPad's (Wireless)
    - 1 Eee-Pc (Wireless)

    L2 Router (Located in Entertainment Unit)
    Clients:
    - WD TV Live (Ethernet into L2 Router)
    - LG Smart TV (Ethernet into L2 Router)
    - Media PC (Ethernet into L2 Router)

    So far L1 Uptime is 1 hour 47 minutes and L2 is 1 hour 21 minutes.

    As for connectivity / streaming between the devices, I do not seem to have any issue so far. I configured the button on top of the E1000's to act as a reboot option instead of the default "Toggle Wireless", have not had a need to press it however so far. :)

    Will test some more.
  87. louiemiranda

    louiemiranda Reformed Router Member

  88. big0bum

    big0bum Network Newbie Member

  89. sp3ctr3

    sp3ctr3 Network Newbie Member

  90. tvlz

    tvlz Serious Server Member

  91. lsiguy10

    lsiguy10 Networkin' Nut Member

    I just got an E1000 v2.0 and it required me to flash to DD-WRT first then to Shibby Tomato. Going from stock firmware to Shibby Tomato did not work for me. It failed to install. I used "tomato-E1000v2-v21-NVRAM32K-1.28.RT-N5x-MIPSR2-105-Mini.bin".

    Anyways, it's working well.

    There is one slight annoyance though. The WPS (orange) light is always on.
  92. eahm

    eahm Addicted to LI Member

  93. lefty

    lefty Serious Server Member

    yes amber cisco light means you have active wan connection, i know in dd-wrt this can be changed, not sure if tomato supports this.
  94. lsiguy10

    lsiguy10 Networkin' Nut Member

    According to the Linksys manual, the orange WPS light means: "there is an error during the WPS process".

    I don't think there is an error. I think it's just an LED bug in Shibby Tomato. I have a similar issue on my Buffalo WHR-HP-G54 where the wireless light stays on even when I disable wireless.

    There is a separate light for the WAN connection. It looks like a planet icon.
  95. lefty

    lefty Serious Server Member

    If you were using stock firmware, i would go by that manual, but since you are not, i wouldn't. When you flash 3rd party firmware, most times it changes up even the LED arrangement within the router. The planet icon you speak of becomes equiv to a LAN port led, if something is plugged into it, then it lights up, if not, then it won't. From what i have seen with linksys units and 3rd party firmware is that amber WPS led means you have an active WAN connection. I don't believe the led was lit before you established a WAN connection was it? It never lights up for my E2000 or E3000 until i established an active wan connection, before then its off.

    You may consider it a bug because you don't want it to do this but, I don't think this is a bug in shibby tomato, i believe its intended behavior.
  96. Tyrel

    Tyrel Reformed Router Member

    Hello again everyone, 'specially Shibby!

    I still have the original experimental Shibby build (tomato-E1000v2-v21-NVRAM32K-1.28.0095MIPSR2_Flash_From_Stock_Firmware-Mini) on my E1000 V2.1, and even though it works fine 99% of the time, I tought an update - a non-experimental build - couldn't hurt...

    So i was trying to update to tomato-E1000v2-v21-NVRAM32K-1.28.RT-N5x-MIPSR2-108-Mini, but I ran into the same issue the guys above me encountered:
    It's too big, it does not allow to flash.

    According to the first post in this thread, the Max Firmware Size = 3 801 088 bytes.
    This appears to be right, because the 108-Mini build is 3 974 144 bytes and it cannot be flashed.

    The size of the Toastman builds appears to be fine, but I'm a bit reluctant about switching to another build, considering it was you (Shibby) who made the very first one, and I was quite happy with it.

    Is there any chance to have this issue resolved in the near future?
    IF not, then... oh well, are the Toastman builds any good?...
  97. wh7qq

    wh7qq Network Newbie Member

    I must be missing something...can't seem to find any builds for the E1000 v1. I am currently running v1.28.9054 MIPSR2-beta K26 Std and it seems to be working ok but I think it runs hot. If the power goes down, it won't restart right away...all lan leds and the wan led blink continuously...won't reset either. If I stop for lunch and return, it will start again Will the 2.0-2.1 builds work?
  98. Monk E. Boy

    Monk E. Boy Addicted to LI Member

    According to Shibby's model chart the E1000 v1 is only supported by RT not RT-N, while the v2 is the opposite it's only supported by RT-N not RT.

    That being said, 1.28.9054 is a rather old build of Tomato (TomatoUSB hasn't been updated by Teddy in quite a while :( ) but based on some quick reading it sounds like you should be able to flash over to Toastman or Shibby easily. Just be sure to go with a generic RT build, not an RT-N build.

    Obviously you need to settle on a particular firmware that's small enough to fit in 4MB of flash, which is proving more challenging these days. Also, if you go with Toastman, there have been some quirks in his last couple builds, but the one before that - 7501.3 - should work fine.
  99. wh7qq

    wh7qq Network Newbie Member

    @monk e: Thanks...there seemed to be explicit support for everything else and I was missing it.
  100. palica

    palica New Member Member

    Hi all, I would like to post about not being able to flash any Shibby firmware other than

    - Tomato Firmware 1.28.0000 MIPSR2-093 K26 Mini (this one has troubles with wired connections)
    - Tomato Firmware 1.28.0000 MIPSR2-105 K26 Mini (this one works just fine)

    all the other builds 106, 107, 108, 109, 110 and 112 are too big to flash on E1000 v2.1
    Shibby would you be so kind and correct the size of the firmware (since it is label exactly for this model it would be nice if you could actually flash it)

    Thanks for all your hard work.

    Palica

Share This Page