1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato for ARM routers

Discussion in 'Tomato Firmware' started by kthaddock, Feb 28, 2014.

  1. Edrikk

    Edrikk Network Guru Member

    Elfew likes this.
  2. Elfew

    Elfew Network Guru Member

    I hope so. And check all others modulea for new releases...
     
  3. Wenle Zheng

    Wenle Zheng Connected Client Member

    Hi, I am using Shibby's 124 K26ARM USB AIO-64K , on Asus AC68R. Will future builds include NFS server? does any one know an alternative way to set up NFS servers? using optware, there isn't a package called nfs-utils
     
  4. shibby20

    shibby20 Network Guru Member

  5. AndreDVJ

    AndreDVJ Addicted to LI Member

    You can also update dnsmasq as well. Current version is 2.72 unless you want to wait until 2.73 comes out.
     
  6. MrDoh

    MrDoh Networkin' Nut Member

    Shibby, I'm also really hoping to see a build for the Asus RT-AC68P, in addition to the 68U and 68R.

    Thanks!
     
  7. Marc O Alfonso

    Marc O Alfonso Connected Client Member

    Hi Shibby,

    Is there any plans to remove SSLv3 in the router HTTPS administration to address POODLE vulnerability? Even if it is an nvram manual setting, that would be appreciated. Note that SSLv2 is also enabled, but no ciphers are supported. I would try to recompile with NO_SSL2 and NO_SSL3 but (not trying to finger point) sources are not public... Anything you can do for the next build would be appreciated.
     
    MrShimpy likes this.
  8. shibby20

    shibby20 Network Guru Member

    AC68P is the same as U/R. You can install Tomato for U or R using Asus Firmware Restoration Tool. Should works. I it will, then let me know. I can also compile image for you to install tomato via Asus GUI if you want. Just write PM to me for better contact.
     
    MrDoh likes this.
  9. MrDoh

    MrDoh Networkin' Nut Member

    Yes, I tried flashing my RT-AC68P several times with v124 using the Asus Firmware Restoration tool. The flash just didn't work...since I couldn't get in contact with the router after I went through the full flash routine (I've used the firmware restoration tool a lot with my RT-N66U), I couldn't use it. I was hoping for the image that I could flash from the Asus GUI. I'll PM you.

    Thanks very much.
     
    Last edited: Dec 28, 2014
  10. tech128

    tech128 Connected Client Member

    @shibby20

    Here's my latest update for dnsmasq:
    https://github.com/tech128/dnsmasq

    This updates tomato's dnsmasq to 2.72

    Miniupnpd 1.9 looked too scary to merge :x
    (lots and lots of code)

    @lancethepants

    Wow you've got a lot of nice utils compiled there
    I'll have to remember your site for reference :)
     
    pharma likes this.
  11. MrShimpy

    MrShimpy Connected Client Member

    After I successfully built Tomato, I compared the Linux sources in Tomato with the Linux sources in the latest Netgear R7000 sources, and there are many differences. Especially code added by Foxconn is not contained in the Tomato sources.
    Are the kernel sources in Tomato from Asus?

    Out of topic: A workaround in the firmware for a bug in the Windows driver! Usually it's the other way around. Windows...
     
  12. Engineer

    Engineer Network Guru Member

    Don't know about the Netgear R7000 but IIRC, the Asus router's firmware is built upon Tomato (not most current version but originally as a starting point), if that's what you're asking.
     
  13. shibby20

    shibby20 Network Guru Member

    Yes, but not the latest.
     
  14. illiac4

    illiac4 Reformed Router Member

    Will the visualized port state be included in arm platform or. is it still broken?
     
  15. Marc O Alfonso

    Marc O Alfonso Connected Client Member

    ASUS ARM routers work, it is only the R7000 that does not support it. Running the underlying binary that brings back the data, got me this far:
    Code:
       if (phyid == 0xffffffff || phyid == 0x55210022) {
         fprintf(stderr, "No Robo switch in managed mode found\n");
         exit(1);
       }
    
    Shibby can answer definitively, but probably eventually when other features are ironed out. Feel free to take a stab now that sources are released.
     
  16. Engineer

    Engineer Network Guru Member

    Forgive me because I'm not knowledgeable on how firmwares work with memory sizes but will the fact that the latest Asus firmwares are converting the RT-AC68* line to 64MB rootfs sizes have any issue with using Tomato if you try to flash Tomato after the router has been flashed with one of the new 64MB rootfs firmwares (apologize if I'm using the wrong terminology)?

    Just curious more than anything.

    Maybe Merlin can weigh in on this since he knows more about it....
     
  17. Milos

    Milos Networkin' Nut Member

    Hi Shibby,

    I changed from my Asus 500gP to new Asus RT-N18U,which I flashed it with v123 & 124 ARM AIO 64k versions of Tomato.Unfortunately neither version has functional QOS.

    Will you make in near future functional build ? :)

    Thx.
     
  18. LanceMoreland

    LanceMoreland Network Guru Member

    Which is a good thing because the latest Asus kernel locks down channel regulation and WiFi signal strength.
     
  19. hshh

    hshh Network Guru Member

    Hi Shibby,
    R7000 sometimes takes long time to reboot, and there is issue about PPPoE hard to reconnect posted by another man, could you check it?
     
  20. CCRS8

    CCRS8 Reformed Router Member

    Just to confirm - this build is not intended for the RT-AC87U, correct?
     
  21. ghoffman

    ghoffman LI Guru Member

    i think i have figured more of this out.

    burnboardid is only available in netgear original firmware, from the serial terminal or from a telnet session.

    at some point when loading a tomato image on the r6300v2, the boardid (which is written on the 'boarddata' mtd partition) gets overwritten. in my case repeatedly, it gets overwritten with 'HDR0' - the header for a firmware image stripped of the identifying information in a netgear .chk file, which normally starts with U12H240T00_NETGEAR for a r6300v2 image, or U12H270T00_NETGEAR for a R7000 image. then the cfe loader refuses to burn an uploaded .chk file, which does not match the 'HDR0' boardid read from the boardata partition. the trick is to upload a .trx file which has HDR0 as the first bytes. i created one using a hexedit, just taking out the first few bytes up to 'HDR0' from a netgear factory .chk file for the r6300v2. then recovery is easy from the cfe loader when you get ttl=100 ping responses.

    so - make a .trx file from a netgear factory .chk image and then recovery is easy for all you experimentation.

    once back on netgear firmware, you can see the boardid by issuing the command 'burnboardid' from a telnet or serial session. to change it to the correct string for an r6300v2, issue: 'burnboardid U12H240T00_NETGEAR'. then you should be back in business.

    i sincerely hope that Shibby or another dev can make an image for the r6300v2. i hope this makes it easier. i am back on dd-wrt (temporarily i hope)

    let me know if i can help
     
    Last edited: Jan 4, 2015
  22. kisenberg

    kisenberg LI Guru Member

    Is there an issue with pppoe-connections? After a disconnect or reboot, it takes several minutes to get a new pppoe-connection. Sometimes, I have to reboot the R7000 twice to be online again.
     
  23. hshh

    hshh Network Guru Member

    R7000 sometimes need long time to reboot, with pppoe reconnect issue. Build 123.
     
  24. TheFatBoy

    TheFatBoy Network Newbie Member

    I'm running Shibby 124 AIO on R7000. The JFFS size is only 32MB, flashed the other tomato firmware (RAF), still shows only 32MB. Flashed DD-WRT version (v24-K3_AC_ARM_STD), has more than 90MB available. Is there any ways to get more space for the JFFS on tomato? I'm planning to install all optware on the jffs partition, 32MB is small even compressed, but 90MB should be good. Thank you.
     
  25. shibby20

    shibby20 Network Guru Member

    Well i already have a working tomato for R6250/R6300v2 but the only way to install/upgrade tomato is a serial cable. I hope i will fix it.
     
  26. Andreas Mueller

    Andreas Mueller Reformed Router Member

    Hello all,
    yesterday - i had to reset my my ASUS RT-N18U (tomato-RT-N18U-ARM--124-VPN-64K-REFRESH) cause it was stuck in the boot process due to a misconfiguration. Shame on me ...

    After a nvram reset and a complete new configuration i experinced the following issue:

    1. When i configure the wireless filter with all the wireless mac addresses of my devices and i choose the option "Permit only the following clients", the filtering works like a charm.

    2. If i reboot the RT-N18U after that, i am not able to connect with my devices - i have to establish a wired connection and disable and reenable the wireless filtering ...until the next reboot ....


    Can anyone confirm this issue?


    @ Shibby: Is there a alternative way to save the router configuration? (As mentioned before is this thread, you cannot restore config-backups on ARM-devices)
     
  27. Morlok8k

    Morlok8k Connected Client Member

    Just wondering here...

    Have anyone looked into working on the Banana Pi BPI-R1 Open Source Router? Its a beast of a router, except it only has 802.11N.

    Edit: oh its realtek (not broadcom) based, so probably wont be supported here.
     
    Last edited: Jan 8, 2015
  28. shibby20

    shibby20 Network Guru Member

    you cannot restore configuration via GUI but you can via SSH

    nvram restore file.cfg
     
  29. Andreas Mueller

    Andreas Mueller Reformed Router Member


    Sh*t, i should have asked earlier :) Thx a lot ...


    Do i have to do a "nvram commit" afterwards to store the restored config?
     
  30. shibby20

    shibby20 Network Guru Member

    i don`t remember right now. Better do :)
     
  31. kthaddock

    kthaddock Network Guru Member

    Yes
     
  32. ghoffman

    ghoffman LI Guru Member

    shibby - i hope so thank you very much.
     
  33. Andreas Mueller

    Andreas Mueller Reformed Router Member


    Wooha, works like a charm - just did a new flash with nvram erase and then restored the config as you mentioned.

    Great!!!

    BTW: I cannot reproduce the wireless filter issue mentioned above, so i cannot find any really important issues regarding version 124 ...

    Thx for your support!
     
  34. hshh

    hshh Network Guru Member

    Shibby, please check the PPPoE reconnect issue.
     
  35. longshot

    longshot Network Newbie Member

    Hey all,

    I just picked up a Cisco/Linksys EA6300V1 (which is essentially a EA6400), and have been looking for alternative firmwares for it. It is nearly identical to the Asus RT-A56U in terms of chipsets and radios, and I know the dd-wrt builds for the Asus router works nearly out of the box for the Linksys.

    Has anyone had any experience with this router, and would there be anything I can do to get development rolling on it, since it looks to be a pretty solid router for a remarkably low price.

    Thanks for the help!
     
  36. Iceman_jkh

    Iceman_jkh Serious Server Member

    Hi Folks and Shibby.

    I'm currently on Kong - build 23900M, but have been wanting to move over to Shibby's build for quite a while. I know many of you have/do switch back and forth (based on stability, features and speed), so I was wondering if you feel it's a good time to be putting the latest Shibby release on the R7000.

    I've been a long time reader of this thread and even though last year I donated money to Shibby (and Kong and a few others devs who make firmware for the R7000 - simply to say thanks and show support) I never actually installed Shibby's firmware as there were a few bugs in the version of that time (v121).

    I've been hesitant to flash as I don't have the ability to constantly switch between firmwares and it takes me a while to setup all the port-forwarding, etc. (I'm not an expert at setting these up).

    I need the R7000 to (be):
    1. Stable - no/negligible maintenance.
    2. Fast and handle large downloads without 'falling over'
    3. Have fully functional port-forwarding
    4. Excellent signal strength/comms (on 802.11 g/n, 2.4Ghz channels - Australia) (I don't use 5Ghz).
    5. Secure (although admittedly, I'd only know if it wasn't secure by reading dev/user comments in this thread)

    I'm pretty sure my list is not too demanding.
    So is it a good time to join the Shibby team? :)

    I know this thread gets a lot of questions/comments, so thanks in advance.
     
  37. The Master

    The Master Network Guru Member

    Me@R7000 Use Shibby//Advanced Tomato and all of your List is Working.
    Internet 100/10
    R7000 with 2 Block Scripts (Adblock/p2partisan)
    USB and Cifs Shares.
    Port Forwards
    Large Download 50gb Titanfall no Problem
    2,4 and 5ghz ok.
    All OK.

    @5. Secure dont know :(
     
  38. Mr.CTT

    Mr.CTT Serious Server Member

    I can personally guarantee that the Vlans are safe on the R7000 as far as network traffic on the LAN side is concerned. There is 0 crosstalk over VLANs with only 2 exceptions (that i have found after significant amounts of testing)

    *note*
    Device A on 10.10.10.xxx will never beable to see device B on 192.168.0.xxx under any circumstance (unless you edit IP Tables to make it have access).

    Unless you trick the router using ARP by switching from one VLAN to another when they use two different subnets very quickly. Only allows internet access on the other VLAN with the wrong IP address, you will not be able to ping something on the VLAN. However this is an issue that I have seen on 20,000$ network infrastructure (Cisco). ARP remembers your MAC address and remembers your DHCP IP... so when you switch VLANS you keep your previously logged credentials if it is before they are deleted.

    The only other crosstalk is if you have 2 subnets like 10.10.10.xxx and 192.168.0.xxx and the DHCP for both is located on the same router but two different vlans. lets say your router's DHCP server is consistent at xxx.xxx.xxx.254 on all subnets. device on subnet 10.10.10.xxx can reach the router administration page on 192.168.0.254 and vice verso. So if you do not want items on a specific subnet to be able to log into the web GUI, you need to edit your IP Tables accordingly.

    Access point isolation seems to work ok.

    USB access asks for password if you have it set to do that every time.

    if you ask me about something specific, I could tell you more, but off hand, that is all i can think of.
     
    Last edited: Jan 20, 2015
  39. jebise

    jebise Reformed Router Member

    I'm hoping to install Tomato on my R7000, currently using 25580M Kong DD-WRT build and I have everything prefect, expect the rebooting issues which effect all Kong NEWDD builds and do not want to use the OLDD build.

    I would like to know if Tomato will resolve the reboot issue? i.e if it uses older driver or the newer ones from Boardcom. Will also like to know the below things.

    1.) Reboot issue like in DDWRT?
    2.) WiFi VLANs on both 2.4/5GHz (guest network that has no access to the internal network or web interface)
    3.) Good wifi speed and range
    4.) Ability to run SH scripts and some ARM based programs?
    5.) Gigabit LAN to LAN transfer?
    6.) Wifi works on both 2.4 and 5GHz with WPA2 and AES encryption?
    7.) Ability to hide SSID? (yes yes i know not really hidden)
    8 Not needed yet, but would like to know.
    8.) 1gbps WAN, DDWRT max out at 360mbps will Tomato reach the maximum stock supports?

    Never had the chance to use Tomato as DDWRT has always been familiar, but have always head good things and best time to lear new things. Mainly want to fix the reboot issue.

    PS do I just flash the TRX file from the web interface of DDWRT?
     
  40. MrDoh

    MrDoh Networkin' Nut Member

    A couple of answers...no reboot problems. Older ("mature") driver and kernel. CTF is said to work, but couldn't prove it from my download speed. Wireless-AC works, don't know how fast you can get it to go, though.

    I'd suggest giving it a try and seeing what you can do with it. Be sure to save the encrypted admin password from dd-wrt before flashing tomato from dd-wrt, but yes, you can do that
     
  41. hshh

    hshh Network Guru Member

    R7000 with tomato takes long time to reboot sometimes.
     
  42. MrDoh

    MrDoh Networkin' Nut Member

    Funny, I think that I've heard that one before *smile*.
     
    Rovan likes this.
  43. jebise

    jebise Reformed Router Member

    How do I get the encrypted password from DDWRT, I really don't want to try and then revert back if it doesn't support all the things I need in my list above.

    Can anyone confirm the other few items for me please?
     
  44. Siff

    Siff Serious Server Member

    @jebise:
    I would strongly recommend to erase the NVRAM - both before and after you flash Tomato. A lot of stuff might not work as expected or not work at all if you change the firmware and keep the settings in the NVRAM!

    If you absolutely need to do that, to get the text of the encrypted password you have to login to DD-WRT via telnet or SSH and type "nvram get http_passwd". Save the returned encrypted text.

    This is required since DD-WRT keeps the password encrypted in the NVRAM. Since Tomato uses the same NVRAM variable to store the password, but stores it as plain text, when you flash Tomato from the DD-WRT GUI (and you do not erase the NVRAM) you'll need to of type/paste the encrypted text of the password when Tomato asks you to login.

    Hope this helps.
     
  45. ShaRose

    ShaRose Reformed Router Member

    I haven't tried shibby since the previous build, but is usb printer sharing up yet? Everyone is saying how usb sharing works, but nothing on that front (I'm assuming people are still talking about usb file sharing).

    I already can guess that the nvram setb64 isn't in yet (it's easy to check that in the source), but that isn't needed for me at the moment. I'm more or less getting fed up with netgear's default firmware.
     
  46. MrDoh

    MrDoh Networkin' Nut Member

    Found this on the internet, and it works for me:

    "If you're upgrading from the DD-WRT firmware, telnet into the router *before* upgrading and
    type "nvram get http_passwd". The result will be your password in Tomato. This is necessary
    because of a change in DD-WRT's way of using the standard http_passwd variable."

    Update: sorry, this forum is working very slowly here at the moment, and I didn't see the other post about this. Don't see a quick way to delete this post.
     
  47. juggie

    juggie Addicted to LI Member

    Hi Shibby,

    Why does the R6250 require a serial cable to install? I've been able to run DD-WRT and Stock and go back and forth on this device so I am curious why Tomato would be any different?

    Thanks!
     
  48. lepa71

    lepa71 Networkin' Nut Member

    Wondering the same thing. Thanks

     
  49. The Master

    The Master Network Guru Member

    Short Answer:

    1) NO Problem
    2) Yes
    3) Yes
    4) Yes
    5) Yes
    6) Yes
    7) Yes
    8) 9xxMbit with OC maybe 1Gbit

    Use How to Flash from Shibby.
     
  50. Mr.CTT

    Mr.CTT Serious Server Member

    Shibby, do you have this for the R6300v1? I would be more than happy to be a test subject for 124. Could you please post a link or email it to me? ctt08@hotmail.com




    I have seen 60 mbit on AC.... but thats all the faster the connection supported there. they only pay for 50 mbit haha. It is pretty good signal though.
     
    Last edited: Jan 20, 2015
  51. sumo fighter 12

    sumo fighter 12 Network Newbie Member

    I just got the N7000 bad boy and loaded this firmware up:

    Tomato Firmware 1.28.0000 -124 K26ARM USB AIO-64K Linux kernel 2.6.36.4brcmarm and Broadcom Wireless Driver 6.37.14.86 (r456083)

    Great Job!

    However, there is still an issue with bandwidth logging: real time works fine, but I understand there is a long outstanding bug with saving the data - hopefully that can be fixed soon and has not been forgotten about :)
     
  52. sdlink

    sdlink Network Newbie Member

    Hey all,

    I was looking for a place to ask a question about tomato shibby (Tomato v1.28.0000 -123 K26ARM USB AIO-64K) on Asus RT-AC68R/U. I hope this is the right place.

    My issue started when I noticed a lot of disconnects from the 5 GHZ channel, while being only 1 floor away from the router. I went into the UI status page and noticed the intereference level was severe so I started playing with settings like channel width. I'm not sure if the issue is fixed, but now the 2.4ghz channel says the interference level is severe and the 5 Ghz is acceptable. I haven't done much testing yet to see if the diconnects on 5 have gone away nor if now 2.4 gets disconnects.

    But I did look at ifconfig and noticed a lot of "frame" errors. I'm not too familiar with all this, so please let me know if the following shows the problem:
    eth0 Link encap:Ethernet HWaddr 38:2C:4A:99:XX:XX
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:73330494 errors:0 dropped:0 overruns:0 frame:0
    TX packets:57622778 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2233417576 (2.0 GiB) TX bytes:243979946 (232.6 MiB)
    Interrupt:179 Base address:0x4000

    eth1 Link encap:Ethernet HWaddr 38:2C:4A:99:XX:XX
    UP BROADCAST RUNNING ALLMULTI MULTICAST MTU:1500 Metric:1
    RX packets:29801445 errors:0 dropped:0 overruns:0 frame:74260815
    TX packets:24219715 errors:42 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1825604855 (1.7 GiB) TX bytes:2162581261 (2.0 GiB)
    Interrupt:163

    eth2 Link encap:Ethernet HWaddr 38:2C:4A:99:XX:XX
    UP BROADCAST RUNNING ALLMULTI MULTICAST MTU:1500 Metric:1
    RX packets:237890 errors:0 dropped:0 overruns:0 frame:169556
    TX packets:2083777 errors:48 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:50078738 (47.7 MiB) TX bytes:601603687 (573.7 MiB)
    Interrupt:169

    So I guess my biggest question is whether using the "Interference level" in the status page an accurate way to tell if I still have a problem? And if so, what interference level should I look for? Is "acceptable" enough?

    Secondly, what should I do to reduce the number of disconnects from wifi? I just got this router and didn't have any issues with my old router other than that it didn't reach the far corner of the second floor of the house.

    TIA
     
  53. Rovan

    Rovan Network Newbie Member

    I currently have an issue with Tomato 1.28 (Shibby) on my R7000,

    On the Tools > WOL page;
    the MAC addresses should combine but it appears the compare is case-sensitive. Devices with Static IP configuration are listed with their MAC in Uppercase and do not combine with the dynamic list of active MAC's listed in Lowercase.

    MAC Addresses with only numbers combine as normal. Anyone else experiencing this issue?

    Just in case this helps anyone I managed to work around this issue.
    I saved the tomato.cgi post strings using Firefox's network monitor (Press F12 to Activate it)
    From there I unescaped the variables (Unescape tool page: here) then converted the text to lowercase: http://convertcase.net/ make sure the &_http_id variable is the correct case from before. I ended up pasting the text into notepad and capitalizing the hostnames manually after the first test post.

    Post it to the Router http://192.168.1.1/tomato.cgi? <your text goes here :)>

    Problem resolved :D, it seems like a relatively simple fix that could be implemented in the asp source. (tools-wol.asp) I don't know much asp though ^^;

    Are there any updated Tomato firmware releases to try? Sucks how there is no broadcom device driver source. :( OpenWRT would probably release a version too.

    I would log a support request or bug report but I don't think its still in active development (at least by shibby afaik). ^^'
     
    Last edited: Jan 24, 2015
    ipse likes this.
  54. pkdick

    pkdick Addicted to LI Member

    Hello,

    I am posting this message in this thread as I really do not where to put it... I have an ASUS RT-AC56U router with the Tomato Shibby's firmware Tomato Firmware 1.28.0000 -124 K26ARM USB VPN-64K and I live in France.

    I recently bought a TP-Link RE200 AC750 wifi extender: when I tried to adjust this device's configuration, I quickly noticed that I could not set the 5GHz link with the router (the router's SSID was not detected), then after many unsuccessful trials, I eventually found the "Country" parameter had to be set to "EU" instead of "France" in order to be seen by the RE200...
    As this adjustment has only to be done for the 5GHz "part" of the ASUS router (i.e. it works properly with "France" for the 2.4 GHz), I assume that it is a "bug" for the Tomato Shibby firmware... Despite this issue does not have a critical impact, I would be grateful Shibby to have a look on it and to work it out.

    Thank you in advance
     
  55. ilovebytes

    ilovebytes Network Newbie Member


    same for me great work so far, but i also really hopw there is a way to get den bandwith logging to work on R7000
     
  56. HesOnFire

    HesOnFire Network Newbie Member

    I have a R7000 running Shibby Tomato. I've searched around for some answers, but need some guidance.

    I have a R7000 configured to run as a Wireless Ethernet Bridge and wanted to reconfigure it to just a simple access point and didn't bother to reconfigure it in the GUI since I thought I could just hardware reset to default Tomato settings after I disconnected the router and moved it to a new home.

    I tried holding the reset pin down for 20+ seconds (the method I am used to) and noticed it did not work. Now I cannot connect to the router at all. Is it stuck in some kind of recovery mode? I have tried power cycling and still cannot connect. I also believe that the settings for Buttons in Tomato was setup so that the buttons do nothing so I have no way to Telnet into the router either.

    Please let me know if there is an actual way to hardware reset the R7000 to default Tomato settings, or what I should try to do.
     
  57. sumo fighter 12

    sumo fighter 12 Network Newbie Member

    did you try setting a static ip at 192.168.0.x and try to connect to router at 192.168.0.1 ?
     
  58. Engineer

    Engineer Network Guru Member

    I saw over at the DD-WRT forum that they (kong and others) have received a new Broadcom ARM driver that supports old and new units that they hoped fixed some sort of rebooting issue. Could this driver be lifted and used in Tomato?

    I'm assuming binary blob but don't know the details.

    Just curious more than anything?
     
  59. MrDoh

    MrDoh Networkin' Nut Member

    I think that dd-wrt and tomato get their wireless drivers in different ways. That driver should arrive here at some point, but it will be downstream some. On the other hand, I haven't had reboot problems with the tomato ARM wireless drivers, so not so immediate here in my opinion *smile*.
     
  60. Engineer

    Engineer Network Guru Member

    Not sure how old Tomato wireless drivers are to be honest. They are from the Asus side of the equation instead of the Netgear side. Biggest issue that I have is the ping issue and at times, it does slow down page loads and general internet activity (well, I'm assuming that's the cause since I rebooted and got the ping issue back and everything slowed down to one extent or another).
     
  61. RMerlin

    RMerlin Network Guru Member

    BSlayer compiles the driver himself, and it's compiled against his 3.x kernel. So, totally unusable by Tomato.
     
  62. Engineer

    Engineer Network Guru Member

    I had forgotten about them using the 3.x kernel. :(

    Nothing has to be released via GPL?

    What are the odds that the new driver ends up in an Asus release and if so, I'm assuming that one could end up in Tomato?
     
    Last edited: Jan 28, 2015
  63. RMerlin

    RMerlin Network Guru Member

    The driver is not GPL. So all BSlayer has to do is to release the binary blobs that allows the firmware itself (which is GPL) to be compilable. Same way all other manufacturers do.

    I assume he's talking about a newer SDK7 driver (he doesn't specify, but his mention of fixing compatibility with older devices would be in-line with that - recent SDK7 drivers were not compatible with the BCM4630). So far, the RT-AC3200 is an SDK7 device, and Asus had been testing SDK7 builds for the RT-AC87U and RT-AC68U. The early alpha build they sent me a few months ago showed quite promising performance boost for USB disk sharing.

    Now that Broadcom would have fixed backward compatibility, there's a good chance Asus might transition these two models to SDK7, provided they didn't encounter more issues. Only time will tell.

    In any case, it's not just a drop-in replacement, so Tomato won't overnight switch to SDK7. A fair amount of changes are required throughout the firmware architecture for that. And a newer SDK doesn't suddenly mean better performance. Look at how the RT-N66U performance dropped after they transitioned it from SDK5 to SDK6.
     
    The Master likes this.
  64. Engineer

    Engineer Network Guru Member

    Thanks RMerlin!!!

    Always appreciated (and amazed)!!!

    Edit: Well, OT, but kong already has a version of DD-WRT running on the new driver:

    wl ver
    7.14 RC89.21
    wl1: Jan 28 2015 16:52:54 version 7.14.89.21 (r524987)
     
    Last edited: Jan 28, 2015
  65. mito

    mito Network Guru Member

    Yeap...
     
  66. kamaaina

    kamaaina Serious Server Member

    You can over clock the R7000. Kong has stated he stress tested his unit(s) and says 1200 mhz is fine, he does not recommend 1400 as some units might fail or not pass his stress tests if they run.

    For Tomato on the R7000:
    telnet 192.168.0.1 (or whatever IP)
    user/pw (root/password)

    nvram set clkfreq=1200,800 (adjust speed to your desired cpu,mem)
    nvram commit && reboot


    Other useful commands:
    cat /proc/dmu/temperature (cpu temperature check)
    cat /proc/cpuinfo (cpu info)
    nvram get clkfreq (CPU frequency)

    I have mine running at 1400mhz since ARM version 1, I believe 117 or 118, and went through all in between. Now on 124. I need to reboot every once in a while (couple of weeks) as Internet goes but I attribute that to the OpenVPN client I run on the router 24/7. Above stuff is what I found in various posts here and on the net.

    Current CPU temperature : 66?C after 24h after reboot.
    Model Netgear R7000
    Chipset ARMv7 Processor rev 0 (v7l)
    CPU Freq 1400 MHz (dual-core)
    Flash Size 128MB

    Time Wed, 28 Jan 2015 22:17:54 -0800
    Uptime 1 day, 00:00:02
    CPU Usage 4.23%
    CPU Load (1 / 5 / 15 mins) 0.01 / 0.05 / 0.05
    Total / Free Memory 249.60 MB / 210.95 MB (84.51%)
    Total / Free NVRAM 64.00 KB / 21.99 KB (34.36%)
     
    Last edited: Jan 29, 2015
  67. kamaaina

    kamaaina Serious Server Member

    I tried a few months ago and could not get a brother label printer to work on it. I tried it on the USB 2 port in the back. The front USB 3 works fine with a 128GB flash drive. Maybe I should try the printer in the front. Not sure what version I was on when I tried, could have been 123 or before. I gave up quickly as the laser has ethernet and work and it's just an additional label printer I wanted to avoid plugging the USB from one machine into the other. Still plugging the cable at this point.
     
  68. Connor McCaffrey

    Connor McCaffrey Networkin' Nut Member

    is default memory clock 800mhz? how high can it be brought up? if its not default what is default, im on 1200,800 right now debating going to 1400,800
     
  69. shibby20

    shibby20 Network Guru Member

    Printer sharing works on Tomato-ARM. I have connected HP 1018 to my R7000 and works great. But remember that in Tomato-ARM printers are not show in GUI, but works great.
     
  70. mito

    mito Network Guru Member

    I don't know on what router you are, considering R7000 that is which i am on, i used about three months it at 1400,800 and there is no noticeable diference between both, unless you are on an ultra high speed bandwith, but with the risk of frying your router, also you have yo be aware of its temp. Later on i reversed to 1200 Mhz
     
  71. Connor McCaffrey

    Connor McCaffrey Networkin' Nut Member

    well, since i go to 1200,800 i have 3 random failures, and today loosing connection to R7000 intermittently, i switch back to 1000,800 today i hope i fix these problems i never seen before


    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Reply from 192.168.1.35: Destination host unreachable.
    Request timed out.
    Reply from 192.168.1.35: Destination host unreachable.
    Request timed out.
    Request timed out.
    Request timed out.
    Reply from 192.168.1.35: Destination host unreachable.
    Reply from 192.168.1.35: Destination host unreachable.
    Request timed out.
    Request timed out.
    Request timed out.
    Reply from 192.168.1.35: Destination host unreachable.
    Reply from 192.168.1.35: Destination host unreachable.
    Reply from 192.168.1.35: Destination host unreachable.
    Request timed out.
    Request timed out.
    Request timed out.
    Reply from 192.168.1.35: Destination host unreachable.
    Reply from 192.168.1.35: Destination host unreachable.
    Request timed out.
    Request timed out.
    Request timed out.
    Reply from 192.168.1.35: Destination host unreachable.
    Reply from 192.168.1.35: Destination host unreachable.
    Reply from 192.168.1.35: Destination host unreachable.
    Request timed out.
    Request timed out.
    Request timed out.
    Reply from 192.168.1.3: bytes=32 time<1ms TTL=64
    Request timed out.
    Reply from 192.168.1.3: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.3: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.3: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.3: bytes=32 time<1ms TTL=64
    Reply from 192.168.1.3: bytes=32 time<1ms TTL=64
    Reply from 192.168.1.3: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.3: bytes=32 time<1ms TTL=64
    Reply from 192.168.1.3: bytes=32 time<1ms TTL=64
    Reply from 192.168.1.3: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.3: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.3: bytes=32 time<1ms TTL=64
    Reply from 192.168.1.3: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.3: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.3: bytes=32 time=1ms TTL=64
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.

    Ping statistics for 192.168.1.3:
    Packets: Sent = 84, Received = 39, Lost = 45 (53% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 90ms, Average = 4ms
     
  72. my_bey

    my_bey Reformed Router Member

    On my R7000 with Shibby v124, I see the same issue (duplicated entries) on the Tools > WOL page. I could not follow your workaround procedure to fix it (I am not a developer). I may need a more detailed step by step procedure.
    Thanks,
     
  73. Mr.CTT

    Mr.CTT Serious Server Member

    I have noticed this before... but Im pretty sure if you just use the device list to create the static DHCP for you, which is the easiest way to do it anyway, you would bypass needing to do this all together. I cant speak for all devices, but it works for all the ones I have.
     
  74. my_bey

    my_bey Reformed Router Member

    I used the "Device List" page to assign static addresses to each device I have. Device list also shows all capitalized MAC addresses same as on WOL page. I attempted to change the MAC address to a lower case on the "Basic, Static DHCP/ARP/IPT page", but is is not possible.
     
  75. Mr.CTT

    Mr.CTT Serious Server Member

    Hmmm that is interesting. I have multiple RT-N16s (shibby123), a R7000(shibby 123), and a R6300(Hyzoom Shibby121) that do not have this issue when doing it like this. That is very odd. I mean there is supposed to be a difference between upper and lower case alphabetical letters according to my experience with playing with MAC addresses, but I never gave it a ton of thought. I don't know that forcing the WOL page to see them a different way is is necessarily a good idea... hmm I guess I will keep watching if someone would like to comment and clear it up more.

    I mean i guess logically it all calculates out to a number the same so it shouldn't matter upper or lower case i guess... but i have had a few routers that would not let me input it on way, but would accept the other.

    I would assume that this boils down to the character or string representation and how it is interpreted programming wise, but i wounder what that means for what you are are trying to fix/ see fixed.

    My main problem is that my WOL page doesn't display devices at all that i know are on the network at times, but i don't really use it. I was holding off till i updated to 124 to even mention that however so i could see if it was working properly.
     
  76. Mr.CTT

    Mr.CTT Serious Server Member

    BTW, this totally sounds like the ping issue that is happening on Tomato for R7000. Please update if the down clock fixes it.
     
  77. SilentBob999

    SilentBob999 Connected Client Member

    Hi All,
    my first post here, sorry I did not read everything and it probably not the best place to post. I search everywhere on the web without getting good result. My problem is NOT 100% related with tomato (I think). I had an E2500 (v1) and recently decide to upgrade to an R7000. I had different problem but at the moment there is ONE point where I would like your advices.
    My nvram dont know the "export". If I do "nvram export --set" it will just show me the nvram usage. Is this normal?

    I did erase in deep nvram multiple time. Test with [edit]ShibbyTomato121,ShibbyTomato124, AdvancedTomato, DD-WRT, going from stock back and forth... This single problem is driving me nuts because I see nowhere that its a normal behaviour and I notice this issue only after experiencing some problem with my config. My CIFS sudently need the 'nvram set "cifs_opts=noserverino<nounix"' to work, I start to get random issue in many of my script, router reboot start to be longer than before (but not when all settings are reseted). So yeah, I am wondering I after a week something hardware may have fail.

    I dont know if I was suppose to create a new thread. I figure you guys will know more than anybody else and the question could be answer in one post.

    thanks
     
  78. Toastman

    Toastman Super Moderator Staff Member Member

    I think nvram export isn't yet available in the ARM builds. It's something that we should think of adding at some stage.
     
    SilentBob999 likes this.
  79. ipse

    ipse LI Guru Member

    @mito: which Kong load are you running on your R7000 that makes you so happy with range and stability?
    I have to admit I am a Shibby hard-core fan, but I also checked the DD-WRT forum where the posts create more confusion than shed any light regarding R7000 behavior with 2015 drivers.
    Just curious - as I can say I am one of those that do NOT have a ping problem (124...). But I'm not adverse to trying a Kong load.
     
  80. Engineer

    Engineer Network Guru Member

    Not directed at me but I'm running 26135 and it's been pretty flawless. Signal is quite a bit higher on the 2.4GHz band but about the same on the 5GHz band as Shibby Tomato ARM 124. No ping issue (do have ping issue on Shibby 124). Not sure why some do and some don't have ping issue. Sounds exactly like a hardware issue to me.
     
    Last edited: Feb 6, 2015
  81. MrShimpy

    MrShimpy Connected Client Member

    I'm running a slightly modified build of the stock firmware on my R7000, and I'm very happy with it.
     
  82. MrDoh

    MrDoh Networkin' Nut Member

    According to mito's postings on the dd-wrt forum, he likes 23900 for stability:

    http://www.dd-wrt.com/phpBB2/viewtopic.php?p=947131#947131
     
    Last edited: Feb 7, 2015
  83. mito

    mito Network Guru Member

    Hei Ipse & MrDoh & Engineer, i have posted at dd-wrt forum a lot of times about 23900 during the old driver version builds, i always tested for my needs almost every Kong's build, many of them with something new, but always reverted back to 23900, my needs are almost everyone's as VOIP, wifi printer, USB drive, DDNS service with No-Ip, Netflix streaming videos, 2 cameras, 8 clients between iPhones and laptops and also being an AP for a repeater at the condomunium pool side, 23900 was the most stable, i always posted i had a secret to solve the reboots and loss of wifi and it was to make the R7000 to reboot everyday ant 6am just in case :) and it worked fine with no reboots at all.
    But since new driver apeared i also tested since 23065, things changed and there were no more reboots, but started some different troubles like 5Ghz vanishing, Guest wifi desconections, etc so always got back again to 23900.
    Today i loaded new Kong's 26135 that seems to be all fixed, fingers crossed, one thing that firstly noted is that RSSI increased, mesured with Inssider always at the same 20 meters from router, increased a little 5Ghz RSSI from 56 to 52/53 could be the day or whatever, but there it is.
    As said my fingers are crossed, there are 10 hours and everything runs ok, let's see tomorrow :)
    Rgds.
     
    Last edited: Feb 7, 2015
  84. Engineer

    Engineer Network Guru Member

    Kong released a new version today requiring a full reset and manual re-entry. Stated it was a bug that was found to be in all ARM versions of DD-WRT. Tomato really needs this new driver! :(
     
  85. Mr.CTT

    Mr.CTT Serious Server Member

    I upgraded my R7000 from 122 to 124.. I still do not have a ping issue. When I upgraded i went from 1 or 2 ms ping to <1ms... my TX powers also raised significantly... like holy crap... Anyway I wish i know what it is that is going on with this that all these problems are caused by.

    I have 1 really important question. ALL of my 30-30-30's are not working in tomato... I have to use the GUI to erase the NVRAM... Is it safe to do this instead of a 30-30-30? I generally do both to be safe, but it isn't working when i do it manually.
     
  86. Engineer

    Engineer Network Guru Member

    The reset button has been disabled on the R7000 in Tomato, IIRC. You can either use the GUI or Telnet in and run the command to erase NVRAM (don't remember it off the top of my head).
     
  87. Mr.CTT

    Mr.CTT Serious Server Member

    ok good to know. It used to work. I prefer the GUI anyway :)
     
  88. shibby20

    shibby20 Network Guru Member

    mtd-erase2 nvram

    :)
     
    SilentBob999, MrDoh and Engineer like this.
  89. Engineer

    Engineer Network Guru Member

    Thanks Shibby! :)
     
  90. ipse

    ipse LI Guru Member

  91. zatoom

    zatoom Addicted to LI Member

    looks nice but: how is the Kong version doing with IPv6 ?. I have a native IPv6 and I want to use it for my Raspberry Pi Syncthing server.
     
  92. mito

    mito Network Guru Member

    Yes, but that .chk build is the initial/first one that has the headers to receive dd-wrt buils, i don't know what version is that, you can get the last one from today 02/7 for R7000 .chk here: http://www.desipro.de/ddwrt/K3-AC-Arm/ , before upgrading Pls check the Reset to Default Settings box, after firmware Upgrade wait for the router to finish procesing (go have a beer) then follow the indications and after that you are able to download any Kong build from here, http://www.desipro.de/ddwrt/K3-AC-Arm/
    Yes, Kong's build # is no longer on builds listings just only the date, the number apears once upgraded.
    Just in case, revert to Netgear OEM build and start from there, because i dont know if from Shibby's you can jump to dd-wrt, you should check with him.
    After upgrading .chk build watch that final build must be a _STD.bin (the one before last one on list) not .chk nor .bin.md5
    Rgds
     
    Last edited: Feb 7, 2015
    ipse likes this.
  93. Edrikk

    Edrikk Network Guru Member

    Sad to see Tomato appearing to start to shrivel a little. :(
     
  94. The Master

    The Master Network Guru Member

    Why?? What happend?
     
  95. Edrikk

    Edrikk Network Guru Member

    The sense I get is that development has slowed down a lot compared to (say) 1.5 years ago, some users appear to start to transition to dd-wrt, etc.

    This is why I'm happy shibby released the updated code... Hopefully someone will assist Shibby...

    If a move to Kernal 3 / SDK7 is needed for the new AC drivers (similar to dd-wrt) there may be trouble ahead...
     
  96. The Master

    The Master Network Guru Member

    Thats true... but there are no new Devs out there.. (or i dont see them).
    And a move to Kernel 3 would be great because we have not to backport all the drivers to 2.x... But iam no dev so i think it must be very hard to jump from 2.x to 3.x like from XP to win 7 or even to win8.x...(saw this in our company)

    A bit frustrating that i could not help the devs :(
     
  97. shibby20

    shibby20 Network Guru Member

    We (devs) cant switch to kernel 3.x because broadcom drivers are precompiled for exacly 2.6.36 (for arm) kernel version and there is not possible to use those drivers with newer kernel. We said that many times. DD-WRT devs (Brainslayer) has an access to Broadcom`s SDK well he is able to compile his own drivers for any kernel version we want.

    Tomato-ARM is based mostly on AsusWRT (same kernel, same broadcom drivers). Maybe Asus will switch soon to newer version of drivers (now is SDK6, newer SDK7) but propably still without kernel update...
     
  98. The Master

    The Master Network Guru Member

    Ah i thought that sdk 7=kernel 3.x ....so a missunderstanding.

    And i know that DD-WRT has access to the SDK to build his own Driver.

    So the only question i have is why could we not buy the SDK from Broadcom? Is this a monthly fee or what? Sorry if this is a silly question. I dont know it.

    If this is a one time BUY... we could donate all together to buy the SDK... Or are there Problems?
    ----
    And i am happy with tomato @ my R7000/N-16/WRT56g but i want it in the future on the device xy :D... so we have to look into the future and evolve with tomato.


    So happy day to all.

    PS: This is no Tomato or DEV "smashing" or Trolling ....only normal Qestions.
     
    mito likes this.
  99. shibby20

    shibby20 Network Guru Member

    SDK access cost too much. If i good remember this is a few thousand dollars (per month?). Look, even huge company like Asus or Netgear has not an access. We have to wait for new GPL sources :)
     
    The Master likes this.
  100. The Master

    The Master Network Guru Member

    5k/5000 User=:):)....

    THX for the Answer.
     

Share This Page