1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato for ARM routers

Discussion in 'Tomato Firmware' started by kthaddock, Feb 28, 2014.

  1. Engineer

    Engineer Network Guru Member

    Ooooooo....will test as soon as I get a chance. Quick question....why does this only effect the R7000 (and maybe R6250/R6300V2) and not the Asus RT-AC68U (or other ARM routers)?

    Also, why would having the router in AP mode only not have the ping issue (at least on mine) in respect to the commands that you posted?

    Finally, would these changes effect reboot speed? Seemed to take much less time rebooting than normal on my RT-AC68U (maybe just in my head though)?


    Oh, and again, thanks for all you guys do. It is appreciated and amazing!!! :D
     
  2. my_bey

    my_bey Reformed Router Member

    I applied this fix to my R7000 with 126 firmware on it. Ping times are all less than 1 ms except when I measure internet speed when downloading test file temporarily increases ping times to about 23ms max, then ping times settles back to <1ms again.
    Ethernet Ports State showed up as well.
    Thanks.
     
  3. stuffedtiger

    stuffedtiger Reformed Router Member

    My reboot time didn't decrease. The router still took about 2-3 minutes to reboot.
     
  4. Edrikk

    Edrikk Network Guru Member

    Awesome job @tvlz to trigger this!

    @shibby20 will an updated to 126 be released with this?
     
  5. shibby20

    shibby20 Network Guru Member

    of course but it will require erase nvram. If you dont want do this then you can manuall run those command to set corrected variables. Next release will be v127 because i fixed few more things ;)
     
    cybrnook, crusher9 and Edrikk like this.
  6. Edrikk

    Edrikk Network Guru Member

    Absolutely.

    PS: I always recommend to everyone to use iMacros to ease the re-setup of the router (I am always personally a proponent of entering the data via GUI to take advantage of any checks, as oppose to an NVRAM dump and load, which would just load incorrect/changed values back into memory).
     
  7. johaug

    johaug Serious Server Member

    YES. Problem fixed and faster reboot :)
     
  8. tvlz

    tvlz LI Guru Member

    It looks like Netgear changed the numbering on the case compared to earlier versions of the R7000
    Try this fix
    http://www.linksysinfo.org/index.php?threads/can-vlan-gui-port-order-be-corrected.70160/#post-247634
    You should be able to change the MACs - Advanced -> MAC Address
     
    cybrnook likes this.
  9. MrDoh

    MrDoh Addicted to LI Member

    Ran the commands above, and while it didn't cure my psoriasis or just drop off belly fat *smile*, the ping time issue and the issue with Ethernet Ports State are apparently both fixed.

    Really glad to see it, thanks! Now I can use this firmware without worrying about rebooting.
     
  10. Mr.CTT

    Mr.CTT Serious Server Member

    I think this explains my LAN access problems also.

    ---
    Ports state working
    boot time decreased
    wireless problems on the test R7000 I have, appear to be gone.
    IP Traffic is down.... :/ but i dont think it was displaying proper values before... I may need to redo it ill try soon...

    CAUTION!!!
    For some reason, applying this fix changed my VLANs removeding my Lan0 port settings, making all Ethernet
    ports useless!

    Ensure that your "Advanced" -> "VLAN" page does not have a blank spot look like this! Especially if your ports stop working.
    Fix Fallout.jpg

    **Edit** dang Ethernet ports aren't working still. I suggest if you apply this fix, you reset the VLAN settings to stock, reboot, apply fix, reboot, then see what happens... I think i may need to wipe nvram... I cant get my ports to work right.

    **Edit 2**
    Nvram reset and applying the fix worked. the ports are correct with the box unchecked!

    @shibby20
    Is this supposed to be this high? At first i thought I accidentally added numbers to it, but now I can see that it is actually set to 432000 stock... Isn't this kind of high? I have always been setting it at 320
    netfilter.jpg
     
    Last edited: Mar 6, 2015
    SilentBob999 likes this.
  11. ghoffman

    ghoffman LI Guru Member

    regarding the et1macaddr fix - on r6300v2: now there is a mac addr conflict on virtual wireless:

    MAC Address
    WAN Port XX:XX:XX:3A:33:39
    Wireless Interface eth1 XX:XX:XX:3A:33:3A
    Wireless Interface eth2 XX:XX:XX:3A:33:3B
    Wireless Interface wl0.1 XX:XX:XX:3A:33:39 **** same as WAN
    Wireless Interface wl0.1 XX:XX:XX:3A:33:3B **** after hitting "default" button
     
  12. Estevao

    Estevao Network Newbie Member

    After applying the fix I lost contact with my R7000 router (I also had VLAN 10 on Wan to use ONT). The router would come up but no wirelles and no ethernet port. Even after reset I can't ping 192.168.1.1 (manual IP on computer).
    I can only ping on the first seconds the router boots (TTL 100).
    Tryed tftp, but can't get it on upload mode (blinking power).
    Any clue? :(
     
  13. Mr.CTT

    Mr.CTT Serious Server Member

    sorry man i am getting horrible lag spikes and cant figure out why. this website is returning 400ms pings and up

    Dang... its something to do with adblock.sh.... it totally killed my connection.

    So far all i know is shutting it off fixes my problems. so make 100% sure you shut it off it you have it.

    It will not reset nvram for you. So if you use a special IP you need to use that IP to access it. If you cannot get any DHCP on any of the WANs, and cannot figure out a gateway, I don't know what to suggest other than serial.
     
    Last edited: Mar 6, 2015
  14. Engineer

    Engineer Network Guru Member

    You could try this from another forum from Shibby...You need the NVRAM erase command and I don't know what it is (step 4)

    • 1) run router and wait 2-3 minutes
    • 2) push and hold wifi on/off button for 25 secs - this will enable a "backdoor" access to the router.
    • 3) use putty and connect via telnet on port 233 and log in to router without password
    • 4) run NVRAM erase command: I think it's 'mtd-erase2 nvram' without quotes (not 100% though)
    • 5) Reboot router
     
  15. Mr.CTT

    Mr.CTT Serious Server Member

    I dont think this will work. Shibbys fix is disabling br0 and if everything is attached to it, you have a brick because you cannot get DHCP or even a subnet. The only way i can see you getting to it is if you had port forwarding on to manage your router from outside your network.

    it is like setting everything up for use on br0, then telling it to not use anr br at all. restoring config didnt help the router I tried to apply this to remotely, I was fortunate that my wifi still allowed access because all my lan ports were dead

    I don't know if i should tell people to do a NVRAM reset before attempting this or not.

    Is it just people with VLANs that are affected?


    as you can see it does fix the ping issue 99%, but it can brick your router given the right situation, so please use your judgment of the risks until a Guru can comment further.

    Ping statistics for 10.10.7.250:
    Packets: Sent = 1000, Received = 1000, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 10ms, Average = 0ms
     
    Last edited: Mar 6, 2015
  16. Engineer

    Engineer Network Guru Member

    Any chance of throwing a TFTP firmware on there when the ping is alive for those few seconds? I've seen that done in the past but don't remember the circumstances (takes good timing). Would be great to get the RESET button active on this router with Tomato. It's been a worry of mine for some time.

    Are you saying this fix is more of a harm than a fix by the way?
     
  17. Mr.CTT

    Mr.CTT Serious Server Member

    It is 100% a fix for the Ping Issue on ARM,

    Ping statistics for 10.10.7.250:
    Packets: Sent = 1000, Received = 1000, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 10ms, Average = 0ms

    but I can't understand why it is disabling br0 and why it would kill wifi. If you don't know what your doing when you attempt this, wait till shibby or someone else comments about it.

    All of my routers have had the ports disabled with the exception of the wan because they were on br0. The WiFi still had br0 on for them, just not the LAN ports so I suggest waiting it out if you don't have a serial cable just in case it kills your wifi. Otherwise you may end up with a router that doesn't have ping issues, but also doesn't have any access from LAN side, so you cant do squat without a serial cable to stop it from shutting it's self off to you.

    P.S. If you edited your TX power, you can no longer edit it after the fix. It wont work.
     
  18. SilentBob999

    SilentBob999 Connected Client Member

    If it lost network assignment it may still be available to receive an address.
    Try to provide an ip address to your router. Create a dhcp server on your pc or connect another router lan port to one lan port of your R7000.
    Use the device list page or an ip scanner to find out the ip an connect to it.
     
  19. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Trying to follow but getting a little confused.

    If you reset router back to default settings and then update with the ping tweaks does it or does it not leave the router in a proper state?

    Is the problem folks are seeing with the LAN ports for those who are running those commands on an already configured router?
     
  20. SilentBob999

    SilentBob999 Connected Client Member

    I applied the fix on top of my config and got no issues.

    For what I see you can clear the nvram first and apply the fix after and will run fine also.

    Some person got issue mostly if there current config have specific vlan and interface changes. If it's your case you are probably better check everything twice before doing it.
     
  21. Engineer

    Engineer Network Guru Member

    I blindly applied the patch to both my RT-AC68U and R7000 (I know...I know) and everything is fine but I don't have any VLANS or stuff like that running.
     
  22. SilentBob999

    SilentBob999 Connected Client Member

    I just saw that you edited your post a lot. Thanks for all the informations
     
  23. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I'm waiting for Shibby to release 127 but just checking.
     
  24. MrDoh

    MrDoh Addicted to LI Member

    Yes, no additional vlan configuration here, either. Very vanilla. Using the fix posted above worked very well for me on top of pre-configured v126 firmware.

    It appears that if you want to make this work with additional vlan configuration, you should clear your nvram, add the fix, then re-configure your vlan's, etc.
     
  25. Estevao

    Estevao Network Newbie Member

    I tried the DHCP server on WAN to no avail, and as I have no access, no way to enter on the backdoor from ethernet. My only hope from software would be tftp during the first seconds it pings (TTL 100), but it doesn't seem to be looking for an upload.
    Well, what can I say, it comes with the territory, just ordered an USB-ttl, it should arrive on monday. Any tricks to open the R7000 case? Looks like a single screw in the midle.
     
  26. Engineer

    Engineer Network Guru Member

    Instead of TFTP, might try to open a PING window to monitor and another window with the Telnet command typed and ready and as soon as you see the ping, hit it with a Telnet. Probably won't work but if you're willing to try.

    Good luck.
     
  27. ghoffman

    ghoffman LI Guru Member

    i don;t know about the R7000, but the r6300v2 has a crippled cfe that does not actualy flash an uploaded file when it is issuing a ttl=100 response to pings.
    from my serial logs: the device starts the tftp daemon, but does not start a flash after the file is received.
    the way i have been able to recover from the serial port is:
    1. in your terminal program: hit ^C until the boot process breaks and you get the CFE> prompt
    2. set your computer to a fixed IP address in the 192.168.1.X range, where 2<X<254. the router sholdbe 192.168.1.1.
    3. conect computer ethernet to router lan
    4. start tftp server on your computer, at address 192.168.1.X, with firmware to load as 'firmware.trx' in the current directory
    5. in terminal program, issue the following command to router:
    flash -noheader 192.168.1.X:firmware.trx flash1.trx
    6. wait for the flash to complete
    7. issue 'go' to start the bootup form the new burned image.

    the R7000 and R6300/R6250 have a boarddate mtd partiton that has a board id and some init values. it is veyr easy to overwrite this partition wiht bad firmware. if the BOARDID does not match the cfe and firmware version, the router may not boot. i think this is what happens when the cfe will not flash a file uploaded from the ttl=100 state.

    you have to reload netgear factory firmware to use the 'burnboardid' command, and you have to use the serial 'flash -noheader .....' command above

    form the serial terminal (or telnet if you can get in on factory firmware): issue 'burnboardid' without arguments. the correct board id's for netgear ARM boards are:
    R7000 -> U12H270T00_NETGEAR
    R6300v2-> U12H240T00_NETGEAR
    R6250 -> U12H240T99_NETGEAR

    R4500 -> U12H189T90_NETGEAR
    WNDR4500-> U12H189T00_NETGEAR

    mine was totally messed up. i got 'HDR0' for my boardid after a botched firmware flash.
    to fix it, issue the command with correct boardid:
    for example for R6300v2:
    burnboardid U12H240T00_NETGEAR
     
  28. Mr.CTT

    Mr.CTT Serious Server Member

    Tomato has no open ports by default. You can assign the WAN an address all day, but there ain't no way in hell your gettin through that firewall unless you have pre set rules giving you access. Period. End of story. If it did, it would be HORRIBLE!!! Think about it, if you could do it, anyone with your IP could.

    This ^^^^^

    + This ^^^^^

    makes me think you can apply the FIX using an nvram reset prior to applying the fix and you will be ok. I am 80% sure that this was tested on routers that had no custom VLANs. Realistically, all you would be doing with shibby 127 is flashing a stock system with his changes already applied, however I still accept no responibility is you brick your router and need to buy a serial cable. Just wana say that now. It is a 100% chance shibby or someone will comment if if you can wait a few days for a reply as to what you should do and how... I mean you have survived this long.... Earlier I posted ways to help this the ping issue. Explore that and see if it helps using the net filter. You'll still have 1-200 ms ping randomly, but its not that bad if it's all you have.

    99% chance it wont. You will not be able to beat the system easily and I don't see how you can tell it to stop. you may be able to use putty, but I dont think you could write a script that would do what you need fast enough to work with putty. I if we could fix the routers that easily with a timing trick, I feel like someone would have made something special to do it at the exact moment or set up a simple program to do it for you.

    The serial trick allows us access before the router really boots up. we spam the crap out of the stop command through a direct line to the board, where we actually stop it even before it loads the firmware. If there is a window it would probably be a couple ms IMHO because you will have lag time W/O direct access, but im not an expert and I just don't think you can really do it over a lan port. But realistically it should be possible with time, patience, and luck.

    Another thing is the fact the serial take us in to the exact directory the exact way we need to, getting to it from a lan like that, seems like it would be different or require some type of special settings. But I don't know enough to be sure.

    @Estevao
    Have you tried rebooting it a few times? I know that these units have had some problems with the WiFi adapters being recognized and it seemed like rebooting it over and over would eventually make it click and go hey there they are.

    The R7000 to my knowledge doesn't have the problem the R6300 and R6250 have where it doesn't flash all the way then gets stuck until you serial it. AKA This guy's problem
    I have had issues with R7000 flashes/NVRAM commits but rebooting it over and over always fixed it enough serial wasn't needed(because im lazy i attempted this and it worked but diff circumstances i guess)

    When i flash a router, it is in a 100% non screw up able environment. cable I made and Tested. Uninterrupted back up power supplies, I double check file for fragmentation. I shut off all unnecessary stuff and use win enterprise. Fresh reboots. The whole 9 yards. The R6300 and R6250 would still mess up... it is 100% firmware/programming issue if you need to serial. (If shibby hasn't figured out the trick to making it work right yet.)

    In my defense, I was the first victim to notice this and posted almost 1.5hrs before you said you had issues :) but crap happens man. The good news is Serial will 99.9999999999% sure fix this. You have the ping of life. Spend 5$ on the cable it is worth every penny just to have in the event of a bad flash.

    B.T.Dubs consider yourself lucky all of mine took roughly 5 minutes 45 seconds to boot and allocate time before this on a normal reboot. If i changed NVRAM it was more like 7 and sometimes took 10 before it had all 4 WiFi's running and responsive.




    *Edit*
    P.S. with my wifi 1000 ping test I had 4-5 instances where ping would go from 1-4ms to ~50ms for one ping, then jump to 150-180ms for one ping, then drop to 1-4ms till it did it again and repeat. There is still something weird, but it is soooooo much better on my Ebay Test unit that came from a pawn shop through eBay. I tried really hard to get a dud haha. Other than that none of my R7000s suffer ping issues beyond 30ms on wifi. 4ms on cable. Maybe I'm lucky? 99% certain it is my net filter settings that help a lot.
     
    Last edited: Mar 7, 2015
  29. XVortex

    XVortex Networkin' Nut Member

    Try to completely disable usb and reboot. If boot time becomes normal, it is udev. It takes too many time to init. asuswrt uses busybox's mdev instead and it completes instantly.
     
  30. SilentBob999

    SilentBob999 Connected Client Member

    I had LAN in mind not WAN. But I probably misinterpreted something (English isn't my primary langage) , I guess it already been test and it doesn't work. I was thinking that in the current situation he had there the router was not assigning a network to the interface but could maybe accept to receive address anyway. I see now that this isn't the issue.
     
  31. Edrikk

    Edrikk Network Guru Member

    A Google search seems to back up this udev slow boot note.
     
  32. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Can Shibby's use mdev instead of udev?
     
  33. TheSteve

    TheSteve Addicted to LI Member

    I see the 50ms then 150-180ms ping once in a while on wifi as well, both bands, even if no other wifi traffic or devices are present. Not sure why but it happens on all devices.

    btw, it happened before Shibby's ping fix and it still occurs since after it was applied. I also notice that when I reboot my 5 GHz bandwidth gets reset to 20 MHz from 80 MHz. I assume maybe some of the saved settings are no longer valid as the ethernet device names changed with the fix.

    I do use a USB3 device and boot times did not decrease with the fix.
    Also I have one wired LAN connection that goes to a gigabit switch, for some reason it comes up at 100 mbps fdx when the router boots but if I unplug the cable and reconnect it then it switches to gigabit. No idea if it is related to the router, could be my switch or maybe the cable is flakey.

    As always though a big THANK YOU to Shibby for his continued work on this great firmware.
     
  34. alpovs

    alpovs Networkin' Nut Member

    What's the status of QoS in ARM Tomato? As I remember it was broken and now the discussion is always about something else and nobody mentions QoS.
     
  35. Toastman

    Toastman Super Moderator Staff Member Member

    Don't give up, there are several people looking at QOS ... There's just no point in making repeated posts when there is no new news to report (we aren't CNN!) :eek:
     
    homer2320776 and gs44 like this.
  36. KyleS

    KyleS Addicted to LI Member

    The classic Virtual Wireless issue doesn't seem to be resolved in Shibby's tree, if you go to the page and hit "Save" it should successfully set all the networks after you reboot. This is fixed in Victek's, but his builds are unfortunately really dated now.
    I've always had this on the TomatoARM builds, QOS doesn't seem to work at all (and has the conflict with v6). Bandwidth monitoring as well isn't functioning, if you ever wander into there ;)
     
  37. Mr.CTT

    Mr.CTT Serious Server Member

    No, you misunderstand. The ping fix Dropped my boot time from that to normal which is like 2-3 min instead of the 7-10 it was

    I guess i dont understand what you mean. Wan is beyond your firewall and if you hook it up to another router to assign it an address, it may take an address.. but then what? You are outside the firewall with no way in. If Lan ports are dead and WiFi is dead... You are screwed.... do a serial restore is all you can do.

    I am pretty sure that 80 is still broken... It has never worked for me.... but i only need 40 so I don't try it. If speed was a concern i would run a cable. I am glad that your I really feel like USB has little to do with the ping issue...

    **EDIT here3/10/2015**
    I have traced a lag issue I am having to my custom net filter settings i have on the R7000 and have changed my suggestion. My pages were lagging on load and this fixed it. ( I run the previous setting on all routers other than the R7000 with no problmems.)
    @TheSteve Could you try something please?No promises that it will help you, but it helped me. Go to Advanced-> Contrac/NetFilter and write down all of your values. Then replace them with the following and reboot. 15960, 2048, 320, 30, 20, 20, 40, 10, 20, 20, 25, 180, 10, 10, and change TTL to custom :64

    your lan port issue based on my experience with this problem, sounds like it is related to the device rather than the router but i will keep an eye on it as my Obi100 sometimes runs at 10mb/s port speed or no reason.
     
    Last edited: Mar 10, 2015
  38. ilium007

    ilium007 Serious Server Member

    I am needing to buy new hardware very soon and I am tossing up between the Asus RT-AC68U and the Netgear R7000. It seems either would still need to run beta tomato at present. I am in no hurry - so this is not a post whinging about when it will be stable ! I have a WRT54GL running Shibby that runs perfectly fine for what I need here, it just has crappy wireless. I can buy either of this routers above and just use them for the wifi in the meantime so I am not worried about waiting for an ARM version on Tomato.

    I am more interested an any views about buy either of the routers above and the likelihood that at some stage I will be able to run a stable ARM Tomato on them with QoS (main reason I run Tomato). This WRT54GL has been going strong for 6 or so years so far :D

    I also read in the first page of this thread about the router (I assume it was the R7000) writing to the JFFS partition on reboot and shortening the life of the router. Whenever I have used the JFFS partition in the past I write to it very infrequently as I have read about failures with people writing to it excessively. Is this a factor in choosing hardware options above ?

    Advice appreciated.
     
  39. AndreDVJ

    AndreDVJ Addicted to LI Member

    I would drop JFFS and instead take advantage of its two USB ports. You eliminate space constraints, flash wear concerns and have as much space as you can afford to.
     
  40. ipse

    ipse LI Guru Member

    Care to elaborate on what you see indicating that QoS is broken? Are the flows not properly classified, you get weird queue behavior and servicing?
    It looks to me that QoS is OK, but I also have IPv6 disabled...could that be the differentiation?
    I'm not contesting your findings, just trying to make sure I am looking at the right issue.
     
  41. KyleS

    KyleS Addicted to LI Member

    [​IMG]

    When I click on any of them they're empty, except for Unclassified which has a single IGMP entry. Sometimes ipv6 shows up in there (doesn't at all on Victek's unfortunately, even on non-arm and falls under the generic bucket).

    Anyways, yeah, I don't see the connections actually being restricted anymore, maybe it's just because the sensitive traffic is under Unclassified and something triggered it to stop...
     
  42. ipse

    ipse LI Guru Member

    Weird, I just checked mine (I run Shibby 124) and I see the list of connections for that class when I click on distribution. Also this is reflected in traffic volume and rates.
    The only unclassified connections are broadcast and multicast.

    Again...could it be IPv6 making the difference? As I said, mine is 100% disabled.

    PS. I opted for using ONLY outbound QoS.
     
  43. Fab Five Freddy

    Fab Five Freddy Serious Server Member

    I've always been under the impression that outbound QoS is the only thing that makes sense....

    QoS only makes sense in general if you have a backlog of packets, and you get to choose what gets sent next over the wire. If there is no backlog, there is only the current packet to send, so there is no dilemma - send the current one.

    For outbound packets, backlogs do happen if you have multiple computers inside your firewall trying to send out at the same time. (Or just one computer doing a bunch of different connections, voip, torrents, gaming, browsing).

    But for incoming packets, you have no control over when they are sent - the ISP sends them to your router when they are received by the ISP...you have no control until you get it. But your router can generally take them as fast as the modem can hand them to it and there is no queuing at the router, because it can send them off to your internal network immediately, as your internal network is way faster than your internet connection.


    FFF
     
    Elfew likes this.
  44. ilium007

    ilium007 Serious Server Member

    It wasn't JFFS sorry, it was writes to NVRAM as per the comment on the first page of this thread:

    http://www.linksysinfo.org/index.php?threads/tomato-for-arm-routers.69719/#post-242805

    Did this relate to the R7000 or the Tomato for ARM in general ??
     
  45. Nick G Rhodes

    Nick G Rhodes Addicted to LI Member

    Yes you can only directly control outbound, but shaping inbound makes a big difference as it causes upstream inbound traffic in a particular class/overall to never fill its queue, allowing your router allowing to gain control of the inbound traffic in terms of what gets buffered/dropped etc.
     
  46. stuffedtiger

    stuffedtiger Reformed Router Member

    With QoS enabled, for me all ipv4 connections gets lumped into the Unclassified category. I'm not exactly sure if all ipv6 traffic gets classified properly, but they are the only connections I see in any particular class.
     
  47. dskete

    dskete Reformed Router Member

    The ping fix worked and ping times are okay. However my 2.4ghz wireless (eth1) is messed up - an '_2' has been added to my SSID even though 'nvram show' displays the correct ssid. From Basic->Network when I do a wireless scan, it shows up the '_2'. I am also unable to change the wireless channel from the GUI. The wireless scan always shows the '_2' on the other channel.

    I removed all the VLANs and additional Network that I had configured for the virtual wireless and the virtual wireless but the problem persists. I have rebooted the router also.
     
    Last edited: Mar 10, 2015
  48. Mr.CTT

    Mr.CTT Serious Server Member

    My advice on which to buy in your case is a little different in this case. If you buy a brand new router, I suggest you get the R7000 because the ping issue appears to me more prevalent in the older ones. If you do get one that has the issue, the ping fix shibby suggested should reduce it by 95-100% of it. If you get a used or refurb, I suggest the Asus. Both are excellent routers, but the R7000 has a higher clock speed and costs same so that is the route I went.
     
    The Master likes this.
  49. Estevao

    Estevao Network Newbie Member

    Just to update, I used the serial port and with putty, <ctrl>+C, erase nvram, solved my problem. ;)
     
  50. Estevao

    Estevao Network Newbie Member

    Just to update, I used the serial port and with putty, <ctrl>+C, erase nvram, solved my problem. ;)
     
  51. Mr.CTT

    Mr.CTT Serious Server Member

    nice glad to hear.
     
  52. dskete

    dskete Reformed Router Member

    An update on my R7000:

    Looks like in some cases the ping fix does bad things to the 2.4ghz wireless on eth1 (its otherwise on eth2).

    I did a nvram erase -> reboot -> apply ping fix -> reboot -> Configure Wireless -> now on 2.4ghz if the ssid is 'tomatowifi', there were two phantom ssid's tomatowifi_1 and tomatowifi_2, tomatowifi itself was missing. nvram show was not displaying these phantom ssids.

    I had to reinstall the 126 and do a thorough nvram erase from GUI to get things back on track. I had tried nvram erase from telnet and that did not help with the phantom ssids.
     
  53. lancethepants

    lancethepants Network Guru Member

    Had you also called the 5Ghz ssid 'tomatowifi', or something else?
     
  54. dskete

    dskete Reformed Router Member

    both had the same name. I like to run both with the same SSID. I was able to connect to the 5 GHz not the 2.4 ghz.
     
    Last edited: Mar 11, 2015
  55. shibby20

    shibby20 Network Guru Member

    should be fixed in v127.
     
  56. dskete

    dskete Reformed Router Member

    Thanks shibby.
     
  57. shibby20

    shibby20 Network Guru Member

    v127 for ARM available.
     
    IcyTexx, homer2320776, MrDoh and 5 others like this.
  58. Engineer

    Engineer Network Guru Member

    Thanks to @Shibby and the others (@tvlz, @Fab Five Freddy, @xu kai, @Yongqiang Qin ) for helping bring Tomato ARM along!!! Much appreciated!!! :)
     
    cybrnook likes this.
  59. ghoffman

    ghoffman LI Guru Member

    @shibby - thank you for v127. i'm on r6300v2, and cleared nvram, and re-entered by hand. there is still a potential mac address conflict on wl0.1 / wl1.

    here are the mac addresses that show up after configuring first eh1 (wl0), then eth2 (wl1), then wl0.1:

    Advanced \ MAC Address:
    WAN Port 00:65:C2:0B:F9:46
    Wireless Interface eth1 00:65:C2:0B:F9:47
    Wireless Interface eth2 00:65:C2:0B:F9:48
    Wireless Interface wl0.1 02:65:C2:0B:F9:48

    Router's LAN MAC Address: 00:65:C2:0B:F9:45

    but i get all these errors in dmesg:

    br0: received packet on WL0.1 with own addresss as source address
    br0: received packet on WL0.1 with own addresss as source address
    br0: received packet on WL0.1 with own addresss as source address
    br0: received packet on WL0.1 with own addresss as source address
    br0: received packet on WL0.1 with own addresss as source address
    br0: received packet on WL0.1 with own addresss as source address
    br0: received packet on WL0.1 with own addresss as source address

    if i go back to Advanced \MAC Address and hit the 'default' buttons, i get this:

    WAN Port 00:65:C2:0B:F9:46
    Wireless Interface eth1 00:65:C2:0B:F9:47
    Wireless Interface eth2 02:65:C2:0B:F9:48
    Wireless Interface wl0.1 02:65:C2:0B:F9:48

    the mac for eth2 changes to the wl0.1 mac, and saving is not permitted.

    ifconfig does not show a mac address conflict, but i don;t know why else i'm getting the packet address conflicts.



    BW stats work!!
    thank you!!!!
     
    Last edited: Mar 12, 2015
  60. PavelK

    PavelK Network Newbie Member

    E3372 in HiLink mode doesn't work on Asus RT-AC56, v127. What should i do to make it work?
     
  61. LanceMoreland

    LanceMoreland Network Guru Member

    Thanks Shibby. I can report that Comcast IPv6 is working without any work around scripts.

    Edit: I spoke a bit prematurely. Although my devices all receive IPv6 addresses, no IPv6 addresses outside of the network can be communicated with without this firewall script:

    echo 0 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/forwarding
     
    Last edited: Mar 12, 2015
    shibby20 likes this.
  62. blackmack

    blackmack LI Guru Member

    Great, BM finally Works. Any chance to get it working when CTF enabled? Im also interested, if there is anything going on to get higher USB 3.0 speeds out of AC68U (usb 3.0 interference), working USB leds and back button to switch on/off asus logo light?
     
  63. TheSteve

    TheSteve Addicted to LI Member

    What speed are you seeing on USB 3.0 right now? I have an R7000 OC'd to 1200 MHz and get a maximum of 55(average closer to 45) megabytes per second read/write USB 3.0 speed via gigabit wired network. At this speed the main CPU load in the router is 100% so it seems unlikely much more speed can be found.
     
  64. KyleS

    KyleS Addicted to LI Member

    It doesn't look like the vegas kmod was compiled with the ARM builds, can anyone tell if sched was built? Maybe this is why QOS isn't working?
     
  65. Toastman

    Toastman Super Moderator Staff Member Member

    TCP Vegas has absolutely nothing to do with QOS, and it should not really be in that section. Furthermore, it has no effect on anything passing through the router, although it "might" have some effect on stuff sourced from the router itself. It's basically just snake oil as far as the router is concerned.
     
  66. KyleS

    KyleS Addicted to LI Member

    Right but it's a missing module with the GUI component still active, which doesn't seem intended.
     
  67. dskete

    dskete Reformed Router Member

    An observation: I have both the 2.4ghz and 5ghz with the same ssid name. I have a guest wireless network - 2.4ghz and 5ghz on their own vlan, but with the same name. On my android smartphone, I have an app that forces connection to the 5ghz ssid. On my main network, my smartphone is able to connect to 5ghz and remain connected, but with the guest network, it gets disconnected when it tries to connect to 5ghz.
     
  68. blackmack

    blackmack LI Guru Member

    Around 30-35 MB/s. On stock firmware interference disable around 45-50 write 50-60MB/s read, on same as tomato.
     
  69. Toastman

    Toastman Super Moderator Staff Member Member

    @KyleS - Ok, that would have been an oversight, I guess. In my versions I always left the module in but deleted the GUI!
     
  70. MrDoh

    MrDoh Addicted to LI Member

    Wow, big changes in v127 from v126! Lights are working, no random ping times, bandwidth monitoring and IP Traffic view graphs seem to be working, even the 5GHz. wireless signal looks stronger. Mainline functionality looking good.

    Thanks for the great work pulling this together, Shibby!
     
  71. Toastman

    Toastman Super Moderator Staff Member Member

    I'm still finding the QOS is not classifying correctly. Many outgoing connections to ports like 80 are ending up as "unclassified". Hope to get time to look at it next week.
     
  72. LanceMoreland

    LanceMoreland Network Guru Member

    I woke up to a log full of Neighbour table overflow errors this morning running Shibby 127. So both firewall scripts are still necessary if you are on Comcast for IPv6 to work. Depending on your area you may not need the Neighbour table overflow script but I sure do. In case you need them the required scripts are as follows:

    ip6tables -A PREROUTING -t mangle -p icmpv6 --icmpv6-type neighbor-solicitation -i vlan2 -d ff02::1:ff00:0/104 -j DROP

    echo 0 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/forwarding
     
  73. MrDoh

    MrDoh Addicted to LI Member

    Yes, I'm also been given the gift of 10's of thousands of IPv6-related neighbor solicitations per day from Comcast here. Wonderful combination of slow download/upload speeds (25/4) plus a log full of kernel table overflow messages, brought to us by the Comcast "we're upgrading our infrastructure any day now" monopoly people. The interesting thing is that firmware based on later Linux kernels, in the 3.x version range, do not show this problem, so this is apparently fixed in later Linux kernels. I do see this here big time with firmware based on the 2.x Linux kernel.
     
  74. LanceMoreland

    LanceMoreland Network Guru Member

    I am curious to know if IPv6 works properly on your Tomato Arm routers without this firewall script:

    echo 0 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/forwarding
     
  75. MrDoh

    MrDoh Addicted to LI Member

    Couldn't tell you right at the moment. Comcast has screwed up IPv6 at my place for the R7000. Both the Asus RT-AC68P and Linksys WRT1900AC are doing great with IPv6, but I can't get IPv6 started on my R7000 at all, even with firmware where it used to work (like previous versions of tomato or Netgear stock firmware). And now when I connect my desktop PC directly to the modem, it doesn't get IPv6, either, and that always used to work. So even cloning my PC's MAC address isn't helpful. Even though both the other routers mentioned above have no problem using IPv6. So, as another gift from Comcast, there's something in their infrastructure that's stuck, not allowing me to associate the R7000's or my PC's MAC address with the IPv6 /64 prefixes that I always get, or something *smile*. I think that it should always allow the MAC address that I'm currently using, especially since I reset the modem and power-cycle the router when I'm looking at this. Haven't had a problem with this before, this is recent.

    I need to get on the phone with Comcast, but have already spent an hour on the phone with them about this and got nowhere. There must be someone there who has an idea how their IPv6 is implemented and what could be wrong there, but it seems that it would be pure luck to get that particular person *smile*.

    TMI, I guess, but the short answer is that I haven't been able to test that. Sorry, I'm not happy about it, either.
     
  76. LanceMoreland

    LanceMoreland Network Guru Member

    You can reach out to netcool on the DSLreports forum. He is an Engineer for Comcast and has helped me before with IPv6 issues. tvlz on this forum might also be able to help you but believe me, no one that you can reach in Comcast support via phone will have any idea what you are talking about.

    Also, if you haven't tried it yet you might give the above firewall script a shot.
     
  77. MrDoh

    MrDoh Addicted to LI Member

    Thanks for the idea, I'll try DSLreports, didn't know that Comcast folks hung out there.

    Yes, when I get ready to try IPv6 with tomato on the R7000, I always use the two lines you mentioned in the firewall script. Like I said, used to work well *smile*.
     
  78. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Thanks for Shibby's work. Hope folks are supporting him. I'll be making the switch probably this evening while watching NCAA basketball games.
     
  79. Elfew

    Elfew Network Guru Member

    Thank you for a new build!

    Can anybody make a list of features qhich are not working in ARM build (in comparison with nonARM build?) Thank you very much!
     
  80. KyleS

    KyleS Addicted to LI Member

    Ha. Based from your feedback of "it randomly stops working half way down the list", I disabled L7 Filtering, sure enough everything classifies just fine... The qos-detailed.asp still isn't drawing correctly, but atleast it's closer.
     
  81. TomAT

    TomAT Network Newbie Member

    Hello, My first post here.

    Thank you Shibby et all for your great work.

    Running R7000 with 127.

    Not sure this is the place to report bugs.
    Getting "error:unknown" popup when i change or scan for channels in 2.4 section.
    This is a random occurance.
     
  82. Toastman

    Toastman Super Moderator Staff Member Member

    Thanks, KyleS, that will help.

    EDIT - I see also the "bytes transferred" function does not work.
     
    Last edited: Mar 16, 2015
  83. rs232

    rs232 Network Guru Member

    AFAIK only QoS is currently work in progress on ARM considering that BW monitoring and "R7000 ping issue" have been resolved. Anybody else has a better view?
     
  84. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Can't get connected on 2.4ghz channels. No matter what I try it says the interface is down and sure enough the 2.4ghz clients can't connect.

    And no matter what I set the channel to, status always says Channel 1.
     
  85. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I think I tracked it down. The bridge eth1 was not assigned. Said "none". I wasn't 100% sure but since it wasn't working anyway changed it to Lan(br0) and 2.4ghz channel is working. Status information shows correctly.

    I've never had to do that before. Did full nvram reset before install, after, etc. Went from Netgear's OEM but did resets the entire way.
     
  86. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I'd like to say I'm convinced the ping issue is resolved. I am not. When I ran into it I didn't sit here and run endless pings to see what the numbers were and thusly see a "ping issue". I used the Internet. When pages stalled, stuff was jerky, I knew I was having a ping issue.

    I'm still seeing jerky, pages get stuck, etc. Did not see that at all with Netgear's OEM. It was a lot of work to switch over. I was really hoping to see the same smooth quick data flow as I was having with Netgear's. I am not.

    Is there still something not quite right given I had to do the manual LAN assignment for 2.4 ghz?
     
  87. sandspike

    sandspike LI Guru Member

    Guys, I do static DHCP and I have 50 devices. I heard folks mention they use Macros to reinput the settings in the GUI to avoid CFG issues, and allow for NVRAM erasure. What are you guys using?
     
  88. jerrm

    jerrm Network Guru Member

  89. ClearD

    ClearD Reformed Router Member

    First post ever here, and I guess I have a simple feature request. Running v127 and so far so good. I was wondering if you could add in another text box in the bandwidth limiter area so that we can nickname the devices being limited? It'd be nice to be able to tell my nexus player apart from my son's roku, without having to search each device's Mac address. Thank you for all the work you do, shibby. Been running your builds for a couple of years now. Simply amazing.
     
  90. BHTeam

    BHTeam LI Guru Member

    v127 works like a charm on the R7000!
     
  91. FallOut

    FallOut Connected Client Member

    It seems that Victek backported from newer kernels other IPv6 patches and fixes here, I don't know if Shibby implemented them as well, but if he does it should help with Comcast and should remove the need for the echo 0 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/forwarding line in the firewall script.

    I currently am not on Comcast, but I still need that line in my Firewall script to get IPv6 working, otherwise every device will get an IPv6, but won't be able to see any IPv6 traffic. Weirdly enough on my old RT-N16 also running Shibby's Tomato I did not need that line to get IPv6 working.

    I also agree making a list of everything that isn't working 100% and keeping track of what the status of the ARM edition is compared with the MIPS edition.

    Besides that, 127 works great here so far, keep up the good work!
     
  92. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Wish I could figure out why its not working for me. I prefer Tomato interface.
     
  93. stuffedtiger

    stuffedtiger Reformed Router Member

    v127 ARM
    In the Bandwidth tab under Real-Time or Last 24 Hours, every section except WAN displays the RX and TX backward. They should be switched. IP Traffic displays them correctly.
     
  94. The Doctor

    The Doctor LI Guru Member

    I may be mistaken, but I think that's correct. You need to look at the traffic from the point of view of the interface. Someone please correct me if I'm wrong.
     
  95. QQQTJ

    QQQTJ Networkin' Nut Member

    PPTP client doesn't seem to honor MTU setting

    Asus RT-AC68R/U Current Version: 1.28.0000 -127 K26ARM USB VPN-64K

    Have a PPOE connection to ISP via a Zyxel DSL modem in Bridge mode. Hence the tomato router does PPPOE and has a public IP address on ppp0.

    It is then set to connect to a PPTP VPN server and route all traffic through it.

    In the client settings I can set a MTU and MRU value or leave at default. It does not matter if/what I set for the PPTP client MTU, the box will always establish the tunnel and have an MTU of 1400 for ppp1.

    [​IMG]
    Performance is very poor and the log will show kern.debug kernel: mppe_compress[1]: osize too small! (have: 1408 need: 1412)

    Mar 15 18:07:43 bkk1 daemon.notice pptp[3530]: CHAP authentication succeeded
    Mar 15 18:07:43 bkk1 daemon.notice pptp[3530]: MPPE 128-bit stateless compression enabled
    Mar 15 18:07:47 bkk1 daemon.notice pptp[3530]: local IP address 10.242.1.2
    Mar 15 18:07:47 bkk1 daemon.notice pptp[3530]: remote IP address 10.242.1.1
    Mar 15 18:07:47 bkk1 daemon.notice pptp[3530]: primary DNS address 208.67.222.222
    Mar 15 18:07:47 bkk1 daemon.notice pptp[3530]: secondary DNS address 208.67.220.220
    Mar 15 18:07:47 bkk1 daemon.info dnsmasq[7866]: exiting on receipt of SIGTERM
    Mar 15 18:07:47 bkk1 daemon.info dnsmasq[7924]: started, version 2.72+ cachesize 1500
    Mar 15 18:07:47 bkk1 daemon.info dnsmasq[7924]: compile time options: IPv6 GNU-getopt no-RTC no-DBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP no-conntrack ipset Tomato-helper auth DNSSEC loop-detect
    Mar 15 18:07:47 bkk1 daemon.info dnsmasq[7924]: DNSSEC validation enabled
    Mar 15 18:07:47 bkk1 daemon.info dnsmasq[7924]: DNSSEC signature timestamps not checked until first cache reload
    Mar 15 18:07:47 bkk1 daemon.info dnsmasq[7924]: asynchronous logging enabled, queue limit is 5 messages
    Mar 15 18:07:47 bkk1 daemon.info dnsmasq-dhcp[7924]: DHCP, IP range 192.168.2.100 -- 192.168.2.199, lease time 12h
    Mar 15 18:07:47 bkk1 daemon.info dnsmasq[7924]: reading /etc/resolv.dnsmasq
    Mar 15 18:07:47 bkk1 daemon.info dnsmasq[7924]: using nameserver 208.67.222.222#53
    Mar 15 18:07:47 bkk1 daemon.info dnsmasq[7924]: using nameserver 208.67.220.220#53
    Mar 15 18:07:47 bkk1 daemon.info dnsmasq[7924]: using nameserver 208.67.220.220#53
    Mar 15 18:07:47 bkk1 daemon.info dnsmasq[7924]: read /etc/hosts - 2 addresses
    Mar 15 18:07:47 bkk1 daemon.info dnsmasq[7924]: read /etc/dnsmasq/hosts/hosts - 19 addresses
    Mar 15 18:07:47 bkk1 daemon.info dnsmasq-dhcp[7924]: read /etc/dnsmasq/dhcp/dhcp-hosts
    Mar 15 18:07:50 bkk1 kern.debug kernel: mppe_compress[1]: osize too small! (have: 1408 need: 1412)
    Mar 15 18:07:50 bkk1 kern.err kernel: ppp: compressor dropped pkt



    I can ssh into the box or use the GUI and issue "ifconfig ppp1 mtu 1450" and the problem seems to go away until next boot.
     
    Last edited: Mar 15, 2015
  96. Mercjoe

    Mercjoe Network Guru Member

    Thank you Shibby for the hard work. With the recent additions I was able to move my R7000 from a AP to the main router.

    Things are looking good at this time.

    If there was ONE thing that you could bring over from Toastman version it would be the ability to zoom the QOS graphs. It makes it much easier to see what is going on as a percentage of available bandwidth.

    Currently it always adds up to 100% when you view the graphs, even if you are only using 40% of the available bandwidth that you define in QOS.

    When 'zoomed' is shows use what the actual usage is vs max usage. So that 100% is suddenly displayed as 40%.

    It is good because it visually shows you where you have room to work with your classification in QOS.

    Thank you again for all the hard work.
     
  97. TheFatBoy

    TheFatBoy Network Newbie Member

    Advanced --> VLAN, select bridge eth1 to LAN
     
  98. Mercjoe

    Mercjoe Network Guru Member

    After switching the R7000 over to the main router, I am still having problems with IPv6 and U-Verse. The same problems that I was having with Toastmans version.

    I have to add this to the WAN up script to get IPv6 address's out to the machines on the network.

    ebtables -t broute -A BROUTING -i vlan2 -p ! ipv6 -j DROP
    brctl addif br0 vlan2

    Once in there all IPv6 machines on the network get IPv6 connectivity.
     
  99. myersw

    myersw Network Guru Member

    I agree. Also Netflix was slow to load and had a few pauses. Also could not get DLNA to work. Came from DD-WRT and did a nvram reset before flash and reset after Tomato install of 127. Don't do any guestnet just DLNA.
    Have gone back to DD-WRT and everything is back to normal.

    I was excited to see that the bandwidth monitoring was fully working now, something that I like in my tool box as I have used Tomato in the past and like it and the interface over DD-WRT but also need things to work. Will keep watching.

    --bill
     
    Last edited: Mar 16, 2015
  100. TheSteve

    TheSteve Addicted to LI Member

    Just did some testing and found something interesting. Running version 127 on my R7000 however it also occurred on earlier versions.
    If I ping from a wireless device to the router I will see a spike in ping times every 66 to 67 seconds. It varies how much/long the spike is depending on band and device but it is always there(sometimes subtle). I tried this on both bands using 802.11N devices. I believe I saw someone else reference the same problem earlier. This does not occur over the wired interface. So what happens on the router every 66 to 67 seconds?

    Here is one such example:
    Reply from 172.16.16.1: bytes=32 time<1ms TTL=64
    Reply from 172.16.16.1: bytes=32 time<1ms TTL=64
    Reply from 172.16.16.1: bytes=32 time<1ms TTL=64
    Reply from 172.16.16.1: bytes=32 time=143ms TTL=64
    Reply from 172.16.16.1: bytes=32 time=59ms TTL=64
    Reply from 172.16.16.1: bytes=32 time<1ms TTL=64
    Reply from 172.16.16.1: bytes=32 time<1ms TTL=64
    Reply from 172.16.16.1: bytes=32 time<1ms TTL=64
     

Share This Page