1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato for ARM routers

Discussion in 'Tomato Firmware' started by kthaddock, Feb 28, 2014.

  1. olegy

    olegy Reformed Router Member

    Thank you. It worked!
  2. Xenier

    Xenier Network Newbie Member

    I'm having very high pings with tomato (even by ethernet cable). It takes too long to get online too...

    C:\Users\Joao>ping -t

    A fazer ping para com 32 bytes de dados:
    Resposta de bytes=32 tempo=19ms TTL=64
    Resposta de bytes=32 tempo=125ms TTL=64
    Resposta de bytes=32 tempo=1112ms TTL=64
    Resposta de bytes=32 tempo=150ms TTL=64
    Resposta de bytes=32 tempo=135ms TTL=64
    Resposta de bytes=32 tempo=222ms TTL=64
    Resposta de bytes=32 tempo=175ms TTL=64
    Resposta de bytes=32 tempo=51ms TTL=64
    Resposta de bytes=32 tempo=103ms TTL=64
    Resposta de bytes=32 tempo=475ms TTL=64
    Resposta de bytes=32 tempo=150ms TTL=64
    Resposta de bytes=32 tempo=541ms TTL=64
    Resposta de bytes=32 tempo=37ms TTL=64
    Resposta de bytes=32 tempo=16ms TTL=64
    Resposta de bytes=32 tempo=121ms TTL=64

    Estatísticas de ping para
    Pacotes: Enviados = 15, Recebidos = 15,
    Perdidos = 0 (perda: 0%),
    Tempo aproximado de ida e volta em milissegundos:
    Mínimo = 16ms, Máximo = 1112ms, Média = 228ms

    This is not normal. Have I did something wrong?
  3. sandspike

    sandspike LI Guru Member

    Mine are stable at 2ms, just saw 1ms mixed in.

    Sent from my SM-N900V using Tapatalk
  4. MaX PL

    MaX PL Networkin' Nut Member

    I'm so happy with this firmware. 5ghz is finally usable and its so much faster for web browsing. Its like when I went from my wrt54g2 with wireless G to a e3000 with wireless N. very noticeable improvement in browser speeds.
  5. porcusor

    porcusor Network Newbie Member

    Wow, unexpected results! CTF really works. I have a 500d/100u connection and with stock fw I only got max 450mbit with high oscillations - 400-450. DD-WRT maxed out at 320 (as tomato w/out ctf). Now it peaks like a full revved engine - 500-515mbit. I'm waiting for a friend with 1000down/100up to test but I'm sure he will get close to 930down.
    I'm patiently waiting for a stable release to use as a daily driver, I'm back to stock for now.
    Offtopic - Stock fw got updated to which increased max pppoe nat to 480mbit, no matter how high above that your connection is.

    Thank you Shibby!!!
  6. nleyend

    nleyend Reformed Router Member

    Mine did this as well until I went into Advanced|Miscellaneous and enabled CTF. Now consistently 0.1-0.2. Working very well on both bands.
  7. MrDoh

    MrDoh Networkin' Nut Member

    Good to hear that CTF ("hardware acceleration") is working. Thanks for sharing.
  8. Xenier

    Xenier Network Newbie Member

    Thanks! That just solved my ping problems :cool:

    Now I have another problem... very low signal in places where (with genie and DD-WRT) I had good signal. I already set amp power to 150mW and didn't got better.
  9. lancethepants

    lancethepants Network Guru Member

    Got my router recovered with the telnet suggestions, thanks!
    shibby20 and jsmiddleton4 like this.
  10. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I'm going to wait until another release cycle but everything is very encouraging.
  11. Xenier

    Xenier Network Newbie Member

    Well... Since I'm having problems with Wireless (low signal) I'm going back to DD-WRT. I'll be waiting for new releases that fix the problem.

    Yet, congrats to Shibby for the excelent work :)
  12. sandspike

    sandspike LI Guru Member

    Are you considering the wireless range an issue at this point (or an isolated problem)? Something that should be patched in a further release or is what the coverage we are getting now, all we can expect (or an unknown issue, that could be resolved in the future)?
  13. mitoh

    mitoh Network Guru Member

    I can also confirm shorter range with this firmware compared to Genie and DD-WRT. Hopefully this can be fixed, great job for creating this version Shibby! I really appreciate it :)
  14. sandspike

    sandspike LI Guru Member

    Yea, great job for sure, I love having tomato with CTF and support for high speed internet. Got my VPN back, my SSHD server.....it's so great. Thanks Shibby.
  15. yanfox

    yanfox Connected Client Member

    I have searched a lot for my brouting problem... it seems that kernel require a recompilation with theses options (found on openwrt bugtracker) :


    I guess tomato sources are not available atm to try this myself but @shibby20, dou you think it's possible in the future ?

    Thank you again,

    R7000 rox since monday !
    Last edited: May 7, 2014
  16. mitoh

    mitoh Network Guru Member

    I think I may have solved the short range issue. Go to Advanced -> Wireless Settings (2.4 GHz), set the region to UNITED STATES and tx power to 0 on both radios (0=use hw default). The radio will briefly cycle and you should get better range. I'm now at the same range as DD-WRT/Genie (if not better), tested using my mobile wifi analyzer app.

    PS: I don't use the 5GHz radio BTW, I left it disabled.
    Last edited: May 7, 2014
  17. sandspike

    sandspike LI Guru Member

    By George, I think you are right, my survey tool is showing much stronger signal.

    ** Update: I turned off the old access point, and then tested all the devices that were struggling before, and they are good now. ** Thanks mitoh!!!
    Last edited: May 8, 2014
  18. mitoh

    mitoh Network Guru Member

    Cool, glad it worked! Anyway, does port forwarding work for you? It doesn't seem to be working for me.
  19. sandspike

    sandspike LI Guru Member

    Port forwarding is working here. Just tested it.
  20. Aaron

    Aaron Networkin' Nut Member

    I can confirm that setting 2.4GHz and 5GHz radios to UNITED STATES and 0 transmit power produced a dramatic increase in signal according to my tablet running WiFi Analyzer app.

    Now I'm curious if Shibby had it set to Singapore/EU @42 for a reason?
  21. koitsu

    koitsu Network Guru Member

    Re: changing wifi radio settings: report back in 2 weeks and then tell us if the situation remains the same. Any kind of radio adjustment often resets numerous pieces of the wireless driver as well as the underlying chip, which can temporarily improve things. Two weeks is a good test duration; try 1 week if you're impatient. 1 hour, and then later 20 minutes, are not really all that acceptable durations of time to reach a conclusion. At least not with wireless. :/

    I cannot tell you how many times I've seen people (incl. on this forum) say "hey I toggled {some stupid setting that has no relevancy to their problem} and now the issue is gone!" only for them to show back up later with their tail between their legs. Be patient when trying to debug anything related to wireless, and write down all things you do/change/adjust, including any physical actions you take! Troubleshooting 101.

    As for the Singapore TomatoUSB default: Google "tomatousb singapore" and enjoy reading. A lot of it is speculative, but there are some folks who absolutely see an improvement when using Singapore instead of, for example, United States. Nobody (to my knowledge) is completely sure why. I don't use this default however. The biggest improvement I've had to wireless reliability (talking about 2.4GHz here) stems from using 20MHz width and statically choosing a channel that has as few APs on it as possible (the default is Auto). Sadly I live in an urban area with a lot of congestion, and most consumer routers default to Auto (i.e. the channel number will fluctuate/change dynamically), so I change my channel every few months. Use the "Scan" button to see how many APs there are on individual channels (and expect wireless to not function during the scan).
    kIssGlaY likes this.
  22. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Yes. SG to get 80hz channel working correctly for AC speeds.
  23. sandspike

    sandspike LI Guru Member

    Koitsu, You are very correct, in part. You know more about this stuff than most. I've read tons of your postings. We will continue to test. The massive amounts of instability I was getting with the previous EU setting, I couldn't get a phone to maintain connection 30 feet away. Now the signal is strong, and working well. Also the range was greatly impaired in a distant room, now that room is great. Transfer rates are great. I've read and participated in your discussions about 40/20Mhz adjustments, congestion, etc. Great reads and learned alot. Luckily, my area is congested, but everything works without too much trouble. I also measured the signal level with inSSIDer. The signal is stronger, the numbers don't lie. Bottom line, anyone in the US should change their settings to US if they are having trouble. The 2nd bottom line is, we will see if these improvements last, I'm betting on yes.

    Good luck people, I'm super happy. I even implemented a remote WOL feature via Tomato........;-)
  24. mitoh

    mitoh Network Guru Member

    First thing that came to mind is I live in US so I thought the radio may have specific setting for the region so I set it and it's stronger. And then out of curiosity, I verify DD-WRT Kong mod and it is also using US as its region. As far as the TX power change, I just wanted to get a baseline using the hardware default. So that's the story behind the finding :D
    Last edited: May 8, 2014
  25. mitoh

    mitoh Network Guru Member

    I also notice port-forwarding is not working with CTF turned on. Turning it back off makes port-forwarding working again.
    Last edited: May 8, 2014
  26. knight401

    knight401 Serious Server Member

    I also set US region for both radio, yes it stronger than EU
    WAN Bandwidth - Daily don't work ,I will wait for shibby' updates
    Great work and thanks
  27. MrDoh

    MrDoh Networkin' Nut Member

    Yep, all the posts, including the release post by Shibby and succeeding posts, are gone!

    Maybe the site admin can retrieve them...too bad if not. Glad I took some notes from key posts about settings, etc.
  28. mito

    mito LI Guru Member

    Fortunatelly everything is back now:)
  29. MrDoh

    MrDoh Networkin' Nut Member

    Yep, hate to lose messages.
  30. sandspike

    sandspike LI Guru Member

    Still missing several messages, like the one from Shibby and Myself saying Port forwarding and CTF are working....
  31. JAC70

    JAC70 Networkin' Nut Member

    I'm curious as to the 400mW TX limitation. I was using 500mW under DD-WRT quite successfully, and Wifi strength is significantly decreased under Tomato. I did the trick of setting it to 0 and USA.
  32. lancethepants

    lancethepants Network Guru Member

    I noticed the nvram function 'setfile2nvram' isn't available in arm builds. Did Jonathon Zarate end up writing his own version nvram? Will we see this implemented?
  33. boghea

    boghea Reformed Router Member

    Hi all,

    First I would like to thank Shibby for his great work releasing TOmatoUSB for R7000.
    Regarding CTF I have done some tests on speedtest.net and I got the following results:
    - with CTF off during the upload / download test the cpu stayed at 50~%
    - with CTF on during upload /download the cpu stayed at 10~%
    In the meantime under IP traffic, while CTF enabled, the computer reported traffic worth of 10 - 20 Kb (while speed test was running); with CTF disabled IP Traffic reported correct values for the computer during test;

    Computer was connected via gigabit cable.
    Last edited: May 9, 2014
  34. Aaron

    Aaron Networkin' Nut Member

    I know it's only been a day, but it seems setting wireless to USA on the 5GHz side has fixed drop outs.

    While set to Singapore I was getting drop outs on the 5GHz side, but I have not had one since changing it to USA.
  35. JAC70

    JAC70 Networkin' Nut Member

    Was there ever a fix for the whole DNSMASQ being broken issue? I'm trying to set a range of static IPs to use OpenDNS for content filtering, and it won't work like it did under Toastman's e3000 build.

  36. Netwet

    Netwet Reformed Router Member

    I think tomato will not be able to get the same signal strength. I have tried kongs OLDD and NEWD builds and only his OLDD builds allow to boost the signal strength beyond stock firmware. NEWD has the same signal strength as stock, the OLDD builds allow too boost the signal in a way that I have -10dB better signal compared to stock.

    Kong mentioned it somewhere, that only his OLDD with customized driver allows this kind of power boost.

    I have a bridge setup with two R7000 and with his power boost I have ~180mbps throughput on a long distance connection , where stock only managed to do ~100mbps.
  37. btaroli

    btaroli Reformed Router Member

    Happy tomato shibby user coming from an e2500 (117) to this build on R7000. So far so good, though I must admit so far I haven't any AC clients to test. Enjoying enhanced range with external antennas for now. :) I am noticing some oddities with wifi signal reports and throughput depending on region and transmit power. Trying out US & 0 for now, but I guess only real test is over the course of several days.

    Even with defaults on location and transmit power, setting 2.4GHz to 40 and 5.0GHz to 80 resulted in overview displaying only 20 and 40 respectively. Just a display issue, or a symptom suggesting the perhaps the settings weren't honored? Survived a restart as well.

    [Update: Seems when I choose specific channels for each, this behavior stops and I see 40 and 80, respectively.]

    I, too, have noticed that the real-time bandwidth numbers are off, but figure this is an early build so overlooking some of this. :) Overall, things are functional. CTF and port maps (as noted but apparently posts are missing) do indeed appear to be working together.

    Apart from the Wifi and Port status items, are there any other specific configuration issues we should be watching for now?
    Last edited: May 9, 2014
  38. RMerlin

    RMerlin Network Guru Member

    IPTraffic is incompatible with CTF, as it relies on entries in the FORWARD chain.
    koitsu likes this.
  39. boghea

    boghea Reformed Router Member

    I have read in previous posts that there is a way to target the packets in order to fix this and QOS (maybe more things that are passing trough CTF)
  40. RMerlin

    RMerlin Network Guru Member

    Packets that are marked will bypass CTF. However if you were to mark every single packet so you can count the traffic, you would effectively never use CTF at all.
    koitsu likes this.
  41. 00_ren

    00_ren Serious Server Member

    Are the current arm builds compatible with Buffalo's WZR-1750DHPD?

    Sent from my Nexus 4 using Tapatalk
  42. mitoh

    mitoh Network Guru Member

    I also found out virtual wireless wl0.2 and above can't be connected with encryption (WPA/WPA2) enabled. If I disable the encryption then client can connect successfully. It was working with the 117 RTN version with my previous router (RT-N16).
  43. shibby20

    shibby20 Network Guru Member

    not for now.
  44. José Fernández

    José Fernández Serious Server Member

    Shibby, what about Buffalo WZR-1166DHP? It seems to have the same hardware as the Asus RT-AC56U.
  45. shibby20

    shibby20 Network Guru Member

    IMO both buffalo's routers will be supported by tomato but i need to one sample on my desk. Then we can talk.

    Wysłane z mojego IQ4410 przy użyciu Tapatalka
  46. TyShawn

    TyShawn Reformed Router Member

    Just a quick update for the 6300 v2 owners. After a weeks delay I did ship the unit to Shibby so at this point it's a waiting game.
    edgardluz, shibby20 and mito like this.
  47. TC777

    TC777 Networkin' Nut Member

    I'm having a similar problem with Tomato that I do with the stock firmware, on my R7000. It sometimes will lose wireless connections for no reason... its not distance either, because I am even in the same room as the router. The last one was bad because it didn't even seem to want to reboot. Either that or its taking an abnormal amount of time to reboot. I had to reconnect my old router temporarily.
  48. mitoh

    mitoh Network Guru Member

    Hi Shibby, I also notice the config backup file saved from R7000 is not restore-able. I read in the forum the backup file is really a .gz file and I couldn't gunzip it either. I tested the backup file from my other router (E2000) and I can gunzip the file fine so looks like the config backup is borked in R7000?
  49. shibby20

    shibby20 Network Guru Member

    i know that. It`s on TODO list.
    mito likes this.
  50. mito

    mito LI Guru Member

    It is not only Tomato, OEM firm also has it and others too, it is Broadcom driver that makes all the troubles to different devs. Everybody is waiting for a good Broadcom driver update asap.
    Last edited: May 12, 2014
  51. JAC70

    JAC70 Networkin' Nut Member

    My JFFS won't format, nothing in log suggests why. Anyone else?
  52. lancethepants

    lancethepants Network Guru Member

    Is there a way to save an arbitrary file to nvram with arm?
  53. noyp

    noyp LI Guru Member

  54. M0g13r

    M0g13r LI Guru Member

    from conversation with victek :

    Hi !! was you? ... yes.. Thanks a lot.. 10€ more and then I can buy the EA6900 ;).

    Doing last burn in for 1.3e version, running smoothly since today.

    come one guys ...... 10 bucks .... he is doing it for the community ;)
  55. lancethepants

    lancethepants Network Guru Member

  56. tomciopaluch357

    tomciopaluch357 Network Newbie Member

  57. Kev18

    Kev18 Network Newbie Member

    problem solved
    Last edited: May 14, 2014
  58. marekop

    marekop Network Newbie Member

    Can't set virtual WiFi network on my R7000 without disrupting 5G network settings (5G options are dissapear from Wireless Basic settings). I don't see any options for implicit/explicit beam-forming or airtime fairness does they are implemented? Thank You for Your hard work.
  59. JAC70

    JAC70 Networkin' Nut Member

  60. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Just trying to keep track of where we're at and what is on the to do list. NOT being inpatient. Just checking.

    1. The MAC address thing as reported regarding losing 5ghz if WPA2.
    2. The config backup/restore.
    3. Broadcom wireless driver updated.

    Is that right?
  61. boghea

    boghea Reformed Router Member

    Hi shibby,
    Can you reveal to us what is on that TODO list?
  62. The Master

    The Master LI Guru Member

    So after a few Days/Weeks of testing the R7000 Image. Pros/Cons.


    Internet Speed with 100/10 no Problem (20% CPU with 2 Block Scripts)
    Media Server
    USB 2.0 / 3.0 working (sometimes Spindown Problems)


    Wlan Range lower then Stock
    Wlan Speed lower then Stock
    Wlan bit tricky no "free" channel select.
    no Beamform
    CTF must be enable -> if deactivated pingtimes 100ms and more (pc TO router/Internet)
    no Qos
    no bandwith Monitoring.

    i think i forgot a lot but this are the things that i remember.

    But Overall a realy good start. I dont want to go back to Stock or DDWrt (more Problems).

    So Thanks Shibby.
    and the others on Working on tomato for ARM Router.
  63. Victek

    Victek Network Guru Member

    You can modify radio power.. it works fine for this model, set to 100. Ping issue confuses me.. here is my ping with R7000, uncomment blocking scripts for a while an test again. About other comments, known and working on it.

    from PC to Internet.
    vicente@vicente-K53SJ:~/tomato/release/src-rt$ ping google.com
    PING google.com ( 56(84) bytes of data.
    64 bytes from mad01s08-in-f1.1e100.net ( icmp_seq=1 ttl=56 time=11.1 ms
    64 bytes from mad01s08-in-f1.1e100.net ( icmp_seq=2 ttl=56 time=11.1 ms
    64 bytes from mad01s08-in-f1.1e100.net ( icmp_seq=3 ttl=56 time=11.1 ms
    --- google.com ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2002ms
    rtt min/avg/max/mdev = 11.117/11.159/11.183/0.091 ms
    from the router to internet..
    Tomato v1.28.9014 v1.3e K26ARM USB RAF-64K
    root@R7000:/tmp/home/root# ping google.com
    PING google.com ( 56 data bytes
    64 bytes from seq=0 ttl=57 time=10.976 ms
    64 bytes from seq=1 ttl=57 time=10.930 ms
    64 bytes from seq=2 ttl=57 time=10.800 ms
    64 bytes from seq=3 ttl=57 time=10.709 ms
    64 bytes from seq=4 ttl=57 time=10.957 ms
    --- google.com ping statistics ---
    5 packets transmitted, 5 packets received, 0% packet loss
    round-trip min/avg/max = 10.709/10.874/10.976 ms
    from PC to router.
    vicente@vicente-K53SJ:~/tomato/release/src-rt$ ping
    PING ( 56(84) bytes of data.
    64 bytes from icmp_seq=1 ttl=64 time=0.228 ms
    64 bytes from icmp_seq=2 ttl=64 time=0.251 ms
    64 bytes from icmp_seq=3 ttl=64 time=0.219 ms
    64 bytes from icmp_seq=4 ttl=64 time=0.234 ms
    --- ping statistics ---
    4 packets transmitted, 4 received, 0% packet loss, time 2998ms
    rtt min/avg/max/mdev = 0.219/0.233/0.251/0.011 ms
    Check wires ...

    Some add fun.. to light wireless LED's .. gpio disable 13 and gpio disable 12 dunno yet why it's not active at boot ... WAN LED gpio disable 8 (orange) and gpio disable 9 (white)
    Last edited: May 16, 2014
  64. The Master

    The Master LI Guru Member


    All Tests WITH CTF ON.

    Ping from PC:
    Pinging google.com [] with 32 bytes of data:
    Reply from bytes=32 time=43ms TTL=57
    Reply from bytes=32 time=31ms TTL=57
    Reply from bytes=32 time=31ms TTL=57
    Reply from bytes=32 time=38ms TTL=57
    Ping from GUI R7000:
    Seq Address RX Bytes TTL RTT (ms) +/- (ms)
    0 google.com ( 64 58 20.67
    1 google.com ( 64 58 20.59 -0.08
    2 google.com ( 64 58 21.36 0.77
    3 google.com ( 64 58 24.54 3.18
    4 google.com ( 64 58 18.51 -6.03
    Ping from PC to Router:
    Pinging with 32 bytes of data:
    Reply from bytes=32 time=1ms TTL=64
    Reply from bytes=32 time=20ms TTL=64
    Reply from bytes=32 time=18ms TTL=64
    Reply from bytes=32 time=12ms TTL=64
    Test with CTF off. -> Later :D
  65. Victek

    Victek Network Guru Member

    mines are CTF= off ... the test from router to internet was done from router cli but as you can see half of ping delay it's between your PC and Router ... something not usual if you did by cable.. windows OS? I'm getting same results with RT-N16 and tomato mips ...
    Last edited: May 16, 2014
  66. garyn

    garyn Network Newbie Member

    Hi all 1st post here. new member and bought a wrong router.
    i've seen the build for R7000 which i've seen almost similar with EA6700 broadcom chipset ( the wrong router i bought).
    is there any build for EA6700 yet ? sorry if its already ask.


    nvm. found theres a search bar on right top corner. pretty much explain everything.
    Last edited: May 17, 2014
  67. shibby20

    shibby20 Network Guru Member


    got Netgear R6250 ;)
    lepa71, TyShawn, garyn and 2 others like this.
  68. szpunk

    szpunk Networkin' Nut Member

    Similar hardware with R6300 V2 but 2.4G ?( BCM43217 vs BCM4331)
  69. jsmiddleton4

    jsmiddleton4 Network Guru Member

  70. TyShawn

    TyShawn Reformed Router Member

    Did I send you the wrong router?
  71. juggie

    juggie Addicted to LI Member

    Nice! Looking forward to testing.. my R6250 is terrible on DD-WRT so I reverted to stock. Its not my main router though, just setup as an AP. Still running a 3500L (with wireless disabled) as my core router. Tomato is 100% solid on that one.
  72. Netwet

    Netwet Reformed Router Member

    Maybe you installed this bullshit release from myopenrouter, which was no official dd-wrt realease:


    you can read lots about it on dd-wrt forum:)
  73. lilstone87

    lilstone87 Serious Server Member

    Well decided to test shibby's build on my R7000 today, and its running pretty good minus a couple features that are not working for everyone.

    One thing I am disappointed in, and might have switch back over is. The NTFS driver being used is rather poor transferring data to a USB3 drive using the USB3 port. Speed's were between 14-17MB's, even with DD WRT was getting around 27MB's. Also while data was being transferred, it didn't seem very smooth. I have CTF enabled, as not having it enabled caused pings to be all over the place.

    So Shibby, is it gonna be possible to improve NTFS driver speed's for the R7000 on tomato? As I mention above with DDWRT I am able to get around 27MB's using this same drive, and around 34MB's using netgear build.

    EDIT: just transferred a 5GB file to the USB drive, and it avg 13MB's, and the transfer rate was all over the place. I seen it dip as low as 7-8MB's, so again I don't find that acceptable. But I know it's possible your hands may be tied regarding this, and wanna see what your comment regarding the NTFS driver for the R7000 with tomato.

    Also just took the same file from the USB drive connected to the router, and copied it back to the pc and got 32MB's. So writing speed to the drive is piss poor, but reading from drive speed is really good.
    Last edited: May 18, 2014
  74. lilstone87

    lilstone87 Serious Server Member

    Have run tomato for a couple hours now, and even with CTF enabled. I am still seeing pings to the router all over the place. When I first enabled CTF pings were still all over, then I rebooted the router, and things settled down. But now pings are again all over the place, something is odd about this issue.
  75. 00_ren

    00_ren Serious Server Member

    How do I donate towards the purchase of WZR-1750DHPD? DD-WRT is nice an all but I prefer tomato. I've had issues in the past with Asus and Netgear so I'm staying away from both manufacturers

    Sent from my Nexus 4 using Tapatalk
  76. juggie

    juggie Addicted to LI Member

  77. Edrikk

    Edrikk Network Guru Member

    @shibby20 I wanted to share some findings on an R7000, running 118 that haven't been reported yet:

    1). Changing the multicast rate from Auto to something else and saving it, results in the rate returning to Auto when you leave the wireless settings page and come back to it.

    2). Setting up a guest wireless network (vlan), and going to the status page, sometimes the guest wifi shows up in the page, sometimes it doesn't... Haven't been able to figure out any rhyme or reason why...
  78. Aaron

    Aaron Networkin' Nut Member

    Updated to v119

    So far so good
  79. porcusor

    porcusor Network Newbie Member

    is there a changelog? any notable improvements/fixes for R7000?
  80. TyShawn

    TyShawn Reformed Router Member

    E4200v1 just upgraded.
  81. thedak

    thedak Connected Client Member

    Can anyone help with my upgrade? I upgrade from DD-WRT, did an erase nvram first, then upgrade (with reset to default) to the R7000-118 initial flash. Router boots fine but cannot get into the webgui via any combination of password/usernames at all. How can I recover this? Is there some funny dd-wrt encrypted password stuck on it and if so how can this bet reset.

    Any help appreciated!!!!
  82. MrDoh

    MrDoh Networkin' Nut Member

    It would be really great to see release notes for 119...I see the download over on Shibby's site, but don't see what's fixed or added for the R7000?

    I probably just don't know where to look for that.
  83. porcusor

    porcusor Network Newbie Member

    Flashed 119 on my R7000. So far everything I'm interested in works just fine, I'm considering making this my daily driver provided I don't get stability issues in the next days.
    Here's what I've been after and it looks like it's working OK:
    1. CTF on
    2. Port forwarding
    3. PPTP server
    4. DHCP static leases
    5. 5ghz 80mhz (works for US also, no only Singapore)
    6. Remote access over https
    7. DDNS on dydns.org (paid)
    8. UPnP
    9. [not tested] restore saved config - I'm not risking making all the changes again ;)
    Things to note:
    • No settings are altered after a reboot
    • WAN-LAN = 498mbps down / 105 up which is max from my isp- nic using 68% cpu in top

    Waiting for:
    • Greater signal on 2.4. The 5ghz band behaves the same as on stock which is good.
    I'll post if anything goes wrong.

    Thanks a lot Shibby and keep up the great work!!
  84. jsmiddleton4

    jsmiddleton4 Network Guru Member


    Waited for the second release before installing the FW on my R7000. Installed 119 tonight. Was easy. GREAT JOB!
  85. MrDoh

    MrDoh Networkin' Nut Member

    How's the wireless signal strength with 119?

  86. The Master

    The Master LI Guru Member

    [RELEASE] 119
    All version:
    - DDNS – new services: ovh and changeip
    - ovpn client gui: allow to set ip/mask on TAP/TLS
    - zlib update to 1.2.8
    - Add Web server: php/pcre/nginx/spawn-fcgi – thx Victek
    - openvpn update to 2.3.4
    - minidlna – 1.1.2
    - miniupnpd – 1.8 (20140422)
    - dnsmasq: update to 2.70
    - Comcast Fixes: DSCP and buffer overflow with GUI – thx lancethepants
    - dropbear: fix some PATH
    - DNSSEC with GUI – thx lancethepants – AIO builds only
    - dnscrypt: Add dns priority option – thx lancethepants and Victek
    - ethstate: fix when we have network aliases of WAN interface
    - Access Restriction: return to old „web module” style. „String” module is still in image, well user can you it in his own iptables rules
    - libsodium: Update to version 0.5.0

    ARM only
    - new wl driver (r456083)
    - kernel update – thx RMerlin
    - wl blob update
    - add some 3G LTE modules (like cdc) – thx RMerlin
  87. Connor McCaffrey

    Connor McCaffrey Serious Server Member

    dang, u guys are making me want an R7000.

    how is USB2.0 and USB3.0 Performance?

    and also since i have an RT-AC66U im curious if there is anyone out there who also has on running tomato to compare it to the R7000.

    can't think of many areas i need improved other then NAS speed and wifi range and throughput.

    RT-AC66U running Shibby 119 is just great :)
  88. Netwet

    Netwet Reformed Router Member

    The r456083 driver is buggy, with Realtek wireless as in some Lenovo you have to reboot the router everyday in order to be able to connect to 2.4G. With intel you get dropped of from time to time.

    Same problem on asus and dd-wrt with this driver version. Only dd-wrt with older driver (OLDD build)works reliably.
  89. The Master

    The Master LI Guru Member

    Same Problem with Pingtimes at R7000 FW 119..please ignore the "VERLOREN/Lost" Pings... that was the test with or without CTF there is no differenz. (Ping from PC to Router no other Traffic...)

    At N-16 there is no Problem Pingtimes 1ms

    Ping-Statistik für
        Pakete: Gesendet = 13542, Empfangen = 13495, Verloren = 47
        (0% Verlust),
    Bytes=32 Ca. Zeitangaben in Millisek.:
        Minimum = 0ms, Maximum = 1245ms, Mittelwert = 75ms
    Antwort von Bytes=32 Zeit=57ms TTL=64
    Antwort von Bytes=32 Zeit=44ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit=25ms TTL=64
    Antwort von Bytes=32 Zeit=95ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit=100ms TTL=64
    Antwort von Bytes=32 Zeit=71ms TTL=64
    Antwort von Bytes=32 Zeit=22ms TTL=64
    Antwort von Bytes=32 Zeit=17ms TTL=64
    Antwort von Bytes=32 Zeit=70ms TTL=64
    Antwort von Bytes=32 Zeit=4ms TTL=64
    Antwort von Bytes=32 Zeit=2ms TTL=64
    Antwort von Bytes=32 Zeit=48ms TTL=64
    Antwort von Bytes=32 Zeit=2ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit=4ms TTL=64
    Antwort von Bytes=32 Zeit=27ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit=14ms TTL=64
    Antwort von Bytes=32 Zeit=40ms TTL=64
    Antwort von Bytes=32 Zeit=1ms TTL=64
    Antwort von Bytes=32 Zeit=130ms TTL=64
    Antwort von Bytes=32 Zeit=122ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
  90. jsmiddleton4

    jsmiddleton4 Network Guru Member

    "How's the wireless signal strength with 119?"

    When I check the clients signal strength from the clients it is strong and as strong as the Netgear OEM FW. 119's own signal strength meter reads as if the signal is lower. But in use I do not have any connectivity issues anywhere in my 2000 sq foot home nor from the backyard by our pool.

    In fact the 5ghz wireless signal strength meter in Windows 7 had been 4 bars with Netgear's, is 5 bars with 119.

    I do have signal strength set to 80 in 119.
  91. jsmiddleton4

    jsmiddleton4 Network Guru Member


    Just a question to confirm my understanding. The fancy port graphic image thing to show the status of each LAN port is not working?
  92. Victek

    Victek Network Guru Member

    I don't use it for ARM versions .. but for the R7000 will not work by now... or until we can find the right driver.
  93. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Good morning, or evening, Victek. Can it be removed as an option if it isn't working? I'll look again when I post my reply but as I remember it is still an option in the GUI.
  94. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Does not save.

    When I click Save on the DHCP/DNS LAN Advanced config page, I don't need IPV6, nothing saves.
  95. Victek

    Victek Network Guru Member

    To the TODO list, sure.
  96. thedak

    thedak Connected Client Member

    Hi Shibby/Victek! Thanks for the great update!!!

    I upgraded my R7000 / DD-WRT to your 118 R7000 initial load. Did NVRAM Erase and then load with reset to defaults. Can't get into tomato with any username/password combination. I even loaded DD-WRT (Same release) on another router and got all combinations of http_username and http_passwd (default, initial, nvram erase, my combo) and tried to use these encrypted names in all combinations without any luck.

    Any idea how I can get into the admin interface of the tomato R7000 118 initial load? The router works (get internet on the computer), but can't get into the web gui or telnet.

  97. Victek

    Victek Network Guru Member

    As far I know .. tomato can be updated from stock firmware with the released version by shibby ... not? the fast way should be.. use netgear firmware, then reset to defaults and use tomato build initial.... (I don't know in version 118.. but after it you can do directly..).
  98. thedak

    thedak Connected Client Member

    Thanks for the fast reply! Yup - did read instructions. But I went from DD-WRT directly to Tomato. Now I think I have an encrypted DD-WRT password stuck in nvram, but can't get in (despite above). Any ideas how to clear NVRAM with 118 loaded without access to the gui?
  99. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Encrypted password.....

    Probably. Lancethepants can help you.....

    Any of the options on the Advanced/DHCP/DNS page do not save. It is as if the "Save" button is not programmed to write any values to the NVRAM. Clicking on it does nothing.
  100. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Even though it won't save it, do we still need to mess with this in DNSMasq?

    Last edited: May 25, 2014

Share This Page