1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Issues

Discussion in 'Tomato Firmware' started by reem01, Apr 21, 2009.

  1. reem01

    reem01 Addicted to LI Member

    Hello, I did a little searching, but didn't find anything with my issues.

    I just upgraded to Tomato 1.23 from dd-wrt v24 sp1. DD-WRT was working great for a few months when all of a sudden last week my Vista laptops stopped being ablt to browse the internet. I flashed to a newer interim release, but that didn't fix my issue. I installed Tomato 1.23 and it fixed it immediatly.

    My issue is that non of my port forwarding is working. And the firewall doesn't seem to be blocking ping requests, even though I have the check box empty. It seems like non of the settings are doing anything.

    The wireless works great, and bandwidth monitoring is working just fine, but that seems to be about it.

    Does anyone have any ideas?

    When I upgraded it did the 30-30-30 reset, upgraded firmware, and another 30-30-30 reset. I have rebooted the firmware and done power cycles, with no change in performance. Any help would be appreciated.
     
  2. peyton

    peyton LI Guru Member

    Did you try to erase nvram even if you did the 30/30/30 ?
     
  3. reem01

    reem01 Addicted to LI Member

    I thought the 30-30-30 reset did that? I guess I am not sure how to empty the nvram.
     
  4. reem01

    reem01 Addicted to LI Member

    I erased the nvram, but I am having the same issues.

    Does anyone have any other ideas as to why the settings don't seem to be working?

    Thanks
     
  5. Chilling_Silence

    Chilling_Silence Addicted to LI Member

    Is it *just* HTTP traffic, or does HTTPS also work?

    Are you certain that you've plugged in your Router / Modem to the WAN port?
     
  6. reem01

    reem01 Addicted to LI Member

    All outbound traffic is working just fine, including https:. Yes the modem is plugged into the WAN port on the router. It is just inbound traffic that is not working like it should. I have the respond to icmp ping unchecked, and I am responding to external ping requests, when I shouldn't. I have port forwarding setup that is not working at all. I am very confused on this issue.
     
  7. bripab007

    bripab007 Network Guru Member

    Can you do a 30-30-30 reset then re-flash the Tomato firmware, then another 30-30-30 reset?
     
  8. reem01

    reem01 Addicted to LI Member

    I can, and will. Should I erase the nvram sometime during this process?
     
  9. Toastman

    Toastman Super Moderator Staff Member Member

    Seems we all have no problems, so you have a weird situation. Since your old DD-WRT setup suddenly stopped working for no apparent reason, this is a clue that something is different to all of our setups. Although we never really know the answer WHY, it can be that something in the installation went wrong. Hence, firstly, suspect some change in your hardware. Swap power supply, for example. Then try completely reinstalling from scratch, say DD-WRT v24 SSP1 which is stable. Then upgrade to tomato, setting it to erase config while upgrading. Then erase NVRAM too. (Don't forget to consult a priest if necessary). And then reconfigure yet again. This has cured a similar problem I had in the past, one WRT54GL seemed to have busted and I was about to throw it away. Yet it has been fine for 7 months now. As for why it happens, I pass...
     
  10. bripab007

    bripab007 Network Guru Member

    I had an issue on two separate routers, one running Tomato and the other running DD-WRT, wherein a power surge (and both routers were in fact plugged into surge protectors) during a thunderstorm caused them to lose the web GUI's admin username/password.

    Perhaps, as Toastman suggested, you have had some sort of hardware "incident."
     
  11. reem01

    reem01 Addicted to LI Member

    I will go through all of this tonight if I can. Yeah, I was thinking that maybe there is a hardware issue, but since everything is now working outbound, I thought the hardware was fine. I do have another power supply to try, so will swap that out and start from scratch with dd-wrt, then upgrade to tomato again. Definitely an odd issue. I appreciate all the suggestions.
     
  12. reem01

    reem01 Addicted to LI Member

    I have not had good luck tonight.

    I erased the nvram, did a 30-30-30 reset, and flashed the dd-wrt.v24_mini_generic.bin file. But I got distracted, and I don't think I waited long enough before I did another 30-30-30 reset.

    Now dd-wrt is installed, and I can get out to the internet with it, but I cannot do anything with the firmware. I changed the password. Everytime I go to a new page it asks for the password again. If I try and reset to factory defaults, it starts the process for about one second then I get an "Internet Explorer cannot display the webpage" error. I get the same error for trying to upgrade the firmware.

    I tried tftping the firmware up, but that times out everytime. I have tried a few more 30-30-30 resets with no luck.

    Once again, asking for help. :)

    Thanks
     
  13. reem01

    reem01 Addicted to LI Member

    Another strike for IE. Decided to give Firefox a try, and it let me to the factory defaults and upgrade to Tomato. I will now start configuring and testing.
     
  14. reem01

    reem01 Addicted to LI Member

    I am still having these issues. I did not configure dd-wrt and test it. I will do that now.
     
  15. reem01

    reem01 Addicted to LI Member

    Put on DD-WRT v24-sp1 (07/27/08) mini.

    Did all the 30-30-30 resets and erase nvram. Having exact same problem as with the Tomato firmware.

    Very wierd. Initially dd-wrt was not allowing my Vista laptops to browse the internet, but everything else worked fine. Then move to Tomato and all outbound traffic working great, but none of the port forwarding or firewall stuff is working. Now with dd-wrt again, browsing out is no problem, even on Vista, but port forwarding and firewall are not working.

    I am at a complete loss. I fear that I need a new router, like something is wrong with this one.
     
  16. Toastman

    Toastman Super Moderator Staff Member Member

    Are other non-Vista machines suffering the same problem? Oh well, maybe the router has suffered some damage, I would not give up just yet, go back to Linksys original software if necessary and try several times. Did you try the priest?
     
  17. reem01

    reem01 Addicted to LI Member

    All machines browse out to the internet just fine 2003 Server, XP and Vista. But the port forwarding for inbound stuff doesn't work at all. I have port forwarding to go to 2003 Server, XP and Vista machines. It does always seem to hang on to something from previous flashes and resets. Sometimes it remembers the transmit power.

    I will try the Linksys firmware and see if that does anything. I have not consulted a priest, none in the phone book mentioned Linksys hardware blessing, so not sure who to go to.
     

Share This Page