1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato (Latest Shibby) - Ports won't forward - Lots of screen captures included

Discussion in 'Tomato Firmware' started by Rockstead, Sep 29, 2013.

  1. Rockstead

    Rockstead Reformed Router Member

    I've tried everything, so to make things as clear as possible. I'm providing as many screen captures of my Windows Setup and my Tomato screen.
    I'm just trying to simply forward ports, it started off with trying to forward my Utorrent port, but in fact I can't successfully forward any port, but let's start with uTorrent.
    I've never had an issue forwarding a port before, not with my stock Linksys Firmware.
    I'm using the latest version of Tomato Shibby I could find: tomato-E4200USB-NVRAM60K-1.28.RT-MIPSR2-112-AIO
    I also read that when people have this problem they go the Administration Menu and reset their NVRAM, I did that by selecting "Restore all data in NVRAM memory (thorough)" but not difference.
    Here are my screens, I'm trying to forward port 17094.
    I connect wirelessly and from Tomato, I use the mac address to set a static IP of to that wireless connection. I also tried using a LAN connection without wireless and setting a static IP from the network config of Windows, but it made no difference.
    In order to eliminate it being something related to Windows, I've turned off Windows Firewall and that made no difference, and it made no difference if I tried other ports.
    Can someone please show me what I'm doing wrong. Or maybe something is wrong with the latest Shibby? but then I would think I would see more people reporting that issue for such a popular firmware.
    Only thing worth adding is that I'm also using the openVPN client functionality, but right now even that is set to off.

    Windows Firewall Settings off.jpg
    Internet Protocol Version 4 (TCP_IPv4) Properties.jpg
    TomatoUSB Basic_ Network.jpg
    TomatoUSB Basic_ Static DHCP_ARP_IPT.jpg
    TomatoUSB] Forwarding_ UPnP _ NAT-PMP.jpg
    TomatoUSB Forwarding_ Basic.jpg
    TomatoUSB Status_ Device List.jpg
    ĀµTorrent 3.3.1 Setup Guide test results.jpg

    Attached Files:

    Last edited: Sep 29, 2013
  2. koitsu

    koitsu Network Guru Member

    Edit: the port forward isn't relevant most likely because uTorrent is using UPnP to add a port forward dynamically.

    Look under Port Forwarding / UPnP/NAT-PMP, and before you do that, delete the manual port forward you added to Port Forwarding / Basic so that it doesn't conflict.

    Kudos for turning off the Windows Firewall for testing -- very wise/smart.

    And if you want to test a port forwarding entry, use something that's Internet-bound already, not an application that's running on the LAN: http://www.yougetsignal.com/tools/open-ports/

    P.S. -- I can confirm that port forwarding works just fine in general, ditto with the dynamic UPnP method. I use the UPnP method for uTorrent, mIRC, and Skype -- all works fine.
  3. Rockstead

    Rockstead Reformed Router Member

    Thank you for the feedback and so quickly after I posted, I just uploaded the screen cap of the UPnp/NAP-PMP screen and it's not even enabled.

    So I'll enable Enable UPnP (which wasn't enabled) and I'll delete the manual port forward.

    I'll repost the screen capture of the UPNP screen, not sure if NAT-PMP should be enabled as well?

    so with these guys enabled? I never have to do manual port forwarding again? or just for apps that support it?

    For testing, yeah I found a bunch of web links to test open ports, I didn't post the screen caps of those results, I appreciate the link for that...I'm guessing I'm close now.

    Just tried it...now I remember, This is the error message you get when you try to enable this from the uPNP screen. I tried this and I couldn't figure out how to enable this on the Lan Bridge.

    2013-09-29 16_52_42-[TomatoUSB] Forwarding_ UPnP _ NAT-PMP.jpg
  4. Rockstead

    Rockstead Reformed Router Member

    Oh Yes, thank you so much, it finally works. I didn't notice, it was referring to the LAN check box on the same screen.

    I get a green check mark on utorrent now!!

    Does this screen look good now?, should I be enabling NAT-PMP too?

    Thanks again!

    Oh BTW is the reason my manual forward didn't work because uPNP was enabled in uTorrent?

    I guess I can re-enable Windows Firewall now.

    2013-09-29 17_22_41-[TomatoUSB] Forwarding_ UPnP _ NAT-PMP.jpg
  5. koitsu

    koitsu Network Guru Member

    Looks fine.

    I do not use VLANs or separate LAN bridging "stuffs".

    You can enable NAT-PMP if you want; it's functionally the same thing as UPnP in this regard, but different. Like UPnP, programs have to support it to make use of it. It also doesn't appear to support application-based descriptions (i.e. you won't see "uTorrent" in a NAT-PMP entry). It's up to you/your decision/I cannot make the decision for you.

    I have no actual hard evidence that your port forward wasn't working; uTorrent's "test/setup" application means jack squat to me and I never trust local applications to determine that (esp. when they don't explain how they're accomplishing the task; that's why I linked to a website that can actually do the test for you). Chances are it wasn't working because it was trying to use UPnP ("Automatic port mapping" checkbox was checked).

  6. JohnnyG76

    JohnnyG76 Addicted to LI Member

    I have 1.28 by shibby installed on my Linksys WRT54G and port forwarding doesn't work at all.
    Any ideas? I've used dd-wrt in the past on this router and didn't have any issues.
    I'm using shibby-vpn as I need it in order to replace my actiontec tech router from my provider.

    Attached Files:

  7. JohnnyG76

    JohnnyG76 Addicted to LI Member

    I installed the latest version of toastman and now my port forwards work. It must be something specific with the shibby version I was using.

Share This Page