1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato ND 1.25 Thor MOD - SDHC | SNMP | VPN | USB

Discussion in 'Tomato Firmware' started by thor2002ro, Apr 11, 2009.

  1. Thrasher

    Thrasher Network Guru Member

    I'm happy to report wireless works fine on my WRT54GS 1.1

    I have noticed, however, that although the web interface allows me to enable/disable wireless....it has no effect on the WLAN. A cold reboot is required to make the change take effect.
     
  2. x-demon

    x-demon Addicted to LI Member

    BTW, looks like a bug. WRT54GL, latest thor's firmware.
    VPN status page.
    At least 1 client connected via static key. And OpenVPN version not displayed.
     

    Attached Files:

  3. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    I've already made changes (just yesterday, in fact) that correct this in the next TomatoVPN release. The status file format for static-key server is completely different than for TLS server, and the parsing capability was only implemented for TLS previously. I also added a status tab to the client.

    It seems my changes get picked up pretty quickly into this mod, so you should see these features shortly after I release them.
     
  4. thor2002ro

    thor2002ro Addicted to LI Member

    1.23.8515.5 .7 v3 UP with changelog

    still trying to get snmpd smaller..... not much luck pased 860kb if anyone knows how to make it smaller... please share...

    SgtPepperKSU push the source to git when ready :)

    anyone got loop driver working? can't seem to make it work....
     
  5. x-demon

    x-demon Addicted to LI Member

    Looks like i can't get SNMP works. I can snmpwalk, but i can't get traffic usage info.
     
  6. thor2002ro

    thor2002ro Addicted to LI Member

    looks fine to me....
    maybe you are doing something wrong...
     

    Attached Files:

  7. x-demon

    x-demon Addicted to LI Member

    related snmpd. Looks like daemon can't get interfaces info.
    Code:
    Found standard interfaces:
    1: (001) lo,Undefined,0 KBit/s,(not defined),
    2: (002) eth0,Undefined,0 KBit/s,(not defined),
    3: (003) eth1,Undefined,0 KBit/s,(not defined),
    4: (004) vlan0,Undefined,0 KBit/s,(not defined),
    5: (005) vlan1,Undefined,0 KBit/s,(not defined),
    6: (006) br0,Undefined,0 KBit/s,(not defined),
    7: (007) tap21,Undefined,0 KBit/s,(not defined),
    8: (008) ppp0,Undefined,0 KBit/s,(not defined),
    
    Testing standard interfaces...
    Test 1 (1.3.6.1.2.1.2.2.1.10.1,1.3.6.1.2.1.2.2.1.16.1): in=134629  out=
    Test 2 (1.3.6.1.2.1.2.2.1.10.2,1.3.6.1.2.1.2.2.1.16.2): in=1045441701  out=3036926586
    Test 3 (1.3.6.1.2.1.2.2.1.10.3,1.3.6.1.2.1.2.2.1.16.3): in=979112060  out=3258667188
    Test 4 (1.3.6.1.2.1.2.2.1.10.4,1.3.6.1.2.1.2.2.1.16.4): in=3567869711  out=3675583162
    Test 5 (1.3.6.1.2.1.2.2.1.10.5,1.3.6.1.2.1.2.2.1.16.5): in=1492344265  out=3656315949
    Test 6 (1.3.6.1.2.1.2.2.1.10.6,1.3.6.1.2.1.2.2.1.16.6): in=159841735  out=1517324939
    Test 7 (1.3.6.1.2.1.2.2.1.10.7,1.3.6.1.2.1.2.2.1.16.7): in=0  out=10528373
    Test 8 (1.3.6.1.2.1.2.2.1.10.8,1.3.6.1.2.1.2.2.1.16.8): in=1240488669  out=3280461077
     
  8. Thrasher

    Thrasher Network Guru Member

    Update on the wireless bug I mentioned....

    On the "Overview" page, wireless enable/disable buttons work fine

    On the "Basic" page, the tick box "Enable Wireless" seems to have no effect on the WLAN (yes, I do click "Save" after changing the tick box)
     
  9. i1135t

    i1135t Network Guru Member

    There is no wireless loop problem for me.. both locations you specified worked as it should. :) Maybe it's a browser thing. I am using firefox, the latest released build. I am also running your latest revision, v7.3
     
  10. thor2002ro

    thor2002ro Addicted to LI Member

    i see you get interfaces traffic... if you are refering to interface speed ... tomato doesnt report that.....
     
  11. sigma

    sigma Addicted to LI Member

    I found a bug in the latest firmware rev .7 v3 Thor MOD, im trying to attempt a WDS connection and i simply cant do it for some reason. Nothing wrong seems to show'd up when you review the logs and the VLAN setup is succesfuly done, but the problem is serious, because you cant ping from one to another router even when you see the WDS lease and not to mention i cant reach one trough the other neither, and obviously i config both routers fine, i tough the problem was the WL driver wich is updated in the earlier modded version and somehow may be incompatible whit the older Tomato original version i had in one of my routers, but when i upgrade to a RAF victeck mod with the same WL version i found the same problem (obviously i did erase nvram thorough, and even setup the original values just in case...) but the problem persist, and when i downgrade to the older v2 Thor MOD everything works just fine... so, what could it be the issue in the latest one? Thor help us out! Greetings...
     
  12. thor2002ro

    thor2002ro Addicted to LI Member

    Tomato 1.23.8515.5 .7 v4 up
     
  13. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    If you pulled my 1.23vpn3.2 sources off git for inclusion before about two hours ago, there is a minor GUI bug that will give an error if client settings are changed with the client running (will still be able to make the changes, though). The sources currently up have this bug fixed.
     
  14. thor2002ro

    thor2002ro Addicted to LI Member

    i pulled the v4 off download... ill fix it tomorrow
     
  15. sigma

    sigma Addicted to LI Member

    Thanks for the fast response Thor! Greetings...
     
  16. thor2002ro

    thor2002ro Addicted to LI Member

  17. xworm

    xworm LI Guru Member

    will a non-ND version be released?
     
  18. thor2002ro

    thor2002ro Addicted to LI Member

    dont think so....
     
  19. sigma

    sigma Addicted to LI Member

    What a great and stable release, i will give a try later the WDS, but so far is so good, that seems like a dream, thanks for your work Thor, keep it up! Greetings!
     
  20. occamsrazor

    occamsrazor Network Guru Member

    Got a new Asus WL-500GP to replace my WHR-G54S... and the Thor mod (latest v4) is running nicely on it. Don't have the problems of bricking it due to running out of space I had on the old router e.g. when enabling JFFS. The only thing lacking is USB support which would be really nice to have :)

    The only problem I've noticed is the Monthly and Weekly bandwidth stats don't seem to be working, coming up with an error box stating "The rstats program is not responding or is busy. Try reloading after a few seconds."

    EDIT: Hmm.... now I am having the same problems I reported before. This time it isn't bricked fortunately, but now all sorts of settings aren't saving properly and are getting reset right after I save them. When I moved to the Asus router I cleared NVRAM at the start, and then entered all settings manually. I'd assigned my previous problem down to running out of space for the settings, but this new router has plenty of flash. For example the "SSID Broadcast" option is unchecked and every time I check the box then save it "loses" it and reverts back to unchecked, and the wireless won't work.
     
  21. thor2002ro

    thor2002ro Addicted to LI Member

    dono what to say .... my router is running with no problems.... including Monthly and Weekly bandwidth stats. maybe there some problems with other routers... but i cant really test all my friends have WRT54GL 1.1 and running my mod for a while now with no problems...
     
  22. Thrasher

    Thrasher Network Guru Member

    I was away training in London last week, so had my first real go at VPN. This firmware rocks! I connected to 3G then starten OpenVPN and linked back into my home network.
    Sweeeet!! Thanks :)

    Is there anything occamsrazor can do to test if his flashRAM has a fault? A mem check kinda program.
     
  23. thor2002ro

    thor2002ro Addicted to LI Member

  24. psychowood

    psychowood LI Guru Member

    Hi,
    I successfully installed .7 v4 on my WRT54GL, but I'm still having problems with JFFS2.

    Code:
    user.notice kernel: JFFS2 version 2.1. (C) 2001 Red Hat, Inc., designed by Axis Communications AB.
    user.notice kernel: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00008000: 0x4c46 instead
    user.notice kernel: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00008004: 0x3478 instead
    user.notice kernel: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00008008: 0x01f7 instead
    user.notice kernel: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000800c: 0x0062 instead
    user.notice kernel: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00008010: 0x0107 instead
    user.notice kernel: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00008014: 0x7272 instead
    user.notice kernel: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00008018: 0x3065 instead
    user.notice kernel: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000801c: 0x6c77 instead
    user.notice kernel: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00008020: 0x6361 instead
    user.notice kernel: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00008024: 0x6e65 instead
    user.notice kernel: Further such events for this erase block will not be printed
    user.notice kernel: JFFS2: Erase block at 0x00000000 is not formatted. It will be eras
    user.info kernel: ed
    user.notice kernel: Cowardly refusing to erase blocks on filesystem with no valid JFFS2 nodes
    The strange thing is that if I try to force format I lose every router setting... :confused:
     
  25. fyellin

    fyellin LI Guru Member

    I can confirm this. I had not enabled JFFS2, but I got similar error messages when I did. Based on psychowood's warnings, I'm simply turned it off, rather than trying to format the disk.
     
  26. thor2002ro

    thor2002ro Addicted to LI Member

    theres not enough space for the jffs on a 4mb flash it's implemented for 4mb+ flashes
     
  27. fyellin

    fyellin LI Guru Member

    I suspected that that was the problem.

    This is truly one of the worst error messages error. (I realize that this is probably buried deep in the bowels of jffs and not easily fixed.) A simple "Not enough free NVRAM" message would have been nice. :frown:
     
  28. thor2002ro

    thor2002ro Addicted to LI Member

    Tomato 1.23.8515.5 .7 v5 up

    guide here on installing optware now works with ext2/3 formated mmc
     
  29. sigma

    sigma Addicted to LI Member

    Thanks! ... i was wonder is there any chance you could add Double WAN support in a future release? would be great and may be the best adds of all, obviously may not fit in the actual state but hopefully some features may be reduced in the present time.

    Anyway your work is the best mod by far. Congrats!
     
  30. kramed

    kramed LI Guru Member

    I just installed the modded firmware v5 but the SD/MMC page is broken in IE.

    Thanks for the mod! I ordered the things I need to mod my GL. Hoping to next week.
     
  31. thor2002ro

    thor2002ro Addicted to LI Member

    seems to work fine on my win 7 with ie8 if not try firefox...
     
  32. Tolem

    Tolem Addicted to LI Member

    Ok so I just clicked the download link for Tomato 1.23.8515.5 .7 v5 and the file is a .trx? Does this install the same way as .bin on the firmware upgrade page?

    Thanks
     
  33. fyellin

    fyellin LI Guru Member

    If you're already running Tomato, then the .trx file will work fine.

    (You only need to worry about the suffix if you're still running the original Linksys firmware)
     
  34. Tolem

    Tolem Addicted to LI Member

    Ah ok thanks I was just a little cautious as I didnt want to brick my router installing it the wrong way. I got it running just fine, I have two questions:

    1. Under IP/MAC BW Limit, what is the difference between DL Rate and DLCeil? If I want a maximum download limit of 500kbps, what do I set each of these to? If the rate is 500kbps, why would the ceiling be any higher than that I suppose is my question.

    2. -What is the ARP Binding tab under the IP/MAC BW Limiter used for? I know that ARP Binding allows you to take any MAC and force it to use a certain IP address... but what does this have to do with Bandwidth limiting?
      -When a machine is "unlisted" what does that mean? If I check that box does every machine have to be ARP Binded?
    Thanks :p
     
  35. thor2002ro

    thor2002ro Addicted to LI Member

    read HERE
    should clarify IP/MAC BW Limiter and ARP Binding
     
  36. martinqiu

    martinqiu Addicted to LI Member

    I have flashed Tomato 1.23.8515.5 .7 v4 successfully, but OpenVPN settings can not be save. Who can help me ? Thank you.
     
  37. sigma

    sigma Addicted to LI Member

    I already had some troubles myself setting up the conf in IE, just try any other browser (ej. Firefox, Opera, Safari, even Maxthon); that will do the trick for sure. :cool:

    Greetings.
     
  38. martinqiu

    martinqiu Addicted to LI Member

    Yes, it works! Thank you very much!:):thumbup:
     
  39. fyellin

    fyellin LI Guru Member

    Any plans or ETA for 1.25?
     
  40. kabar

    kabar Addicted to LI Member

    it`ll be better if Thor waits for new Victek software - he claims that new version 1.25 will have:
    Passive wireless Scan
    Auto channel wireless
    BusyBox 1.15 (1.14 is unstable release, so, 1.13.4 or 1.15, not 1.14)
    Wan_is_LAN feature
    Traffic monitoring per IP/MAC
    and probably SD card mod.

    then Thor should merge this Vic soft with vpn, and then there it is - the best soft ever! ;)
    cheers!
     
  41. thor2002ro

    thor2002ro Addicted to LI Member

    of course i'm waiting for Victek the mod does have Victek's mod at the core...
     
  42. kabar

    kabar Addicted to LI Member

    yeah, of course, thats what i wanted to say :) Thor, do U also melt the SpeedMod http://touristinparadise.blogspot.com/2008/04/linksys-wrt54gl-routers-improving.html in Your soft, or its not necessary becouse of what Victek changes in conntrack?

    Victek claims:
    IP_Conntrack up to 8192 IP's

    but Rodney (SpeedMod guy) says some more:

    "1. Patched ip_conntrack to increase NAT hashtable size and optimized conntrack hash bucket selection filter from modulo to bitwise AND.

    2. Increased the IP route cache hashtable to speed up routing when there are many connections (>4000).

    3. Updated Jenkins' hash to lookup3.

    With these changes, these little routers should be able to handle around 6000 connections and still remain responsive"

    maybe You could also merge his modifications, if theres a sense in it?
    cheers, great work till now, cant wait for new version :)
     
  43. someguyfromhell

    someguyfromhell Addicted to LI Member

    Nice looking mod so far, but why did you use Keith Moyer's VPN implementation instead of SgtPepperKSU?
     
  44. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    I am one and the same person :wink:
     
  45. someguyfromhell

    someguyfromhell Addicted to LI Member

    Wow, never knew :tongue:
     
  46. sigma

    sigma Addicted to LI Member

    Thor, Victek has already release a test version of his 1.25 RAF Mod, is there any chance you could give us (all fans of your work) a probably date to your own release? Would be great see this new features integrated in your unique mod. Thanks in advanced! Greetings :thumbup:...
     
  47. Victek

    Victek Network Guru Member

    It makes no sense, all these patches are already in RAF version with the update of kernel 2.4.35 files.
     
  48. thor2002ro

    thor2002ro Addicted to LI Member

    i'm still testing but from my first tests i dont think i'm gonna update to 1.25 it feels like we've taken steps back not forward. the UI feels stiff and unresponsive. most of the updates can be implemented in 1.23 with little effort. i'm still testing but thease are my thouths so far
    1.25 seems half baked... not many good points to it.....
     
  49. sigma

    sigma Addicted to LI Member

    Well, so what would it be? i mean, do you will work on the same x.23 branch and make updates from there regulary as you always did, or the x.25 will be tested until came out a consistent release? Im telling you this because we apreciate your fluid work and every update is fully welcome. As you said besides the error i describe before with the writes cicles to the chip i havent found any others so x.23 is fine with me; i hope the excelent work dont die here. Thanks for your replys. Greetings :biggrin:
     
  50. baldrickturnip

    baldrickturnip LI Guru Member

    yes - I like this mod combining the SD and VPN GUI - no real need for the SNMP for me .

    any road map on what you intend to do with it in the future ?
     
  51. thor2002ro

    thor2002ro Addicted to LI Member

    i'm trying to update stuff without going to 1.25
     
  52. thor2002ro

    thor2002ro Addicted to LI Member

    Tomato 1.25.8515 .7 v6 UP

    edit if some MOD can change the name from "Tomato ND 1.23 Thor MOD - SDHC | SNMP | VPN" to "Tomato ND 1.25 Thor MOD - SDHC | SNMP | VPN" i would appreciate it
     
  53. nuetron

    nuetron Addicted to LI Member

    Does the newest build have the option to redirect all internet traffic through the VPN?
     
  54. thor2002ro

    thor2002ro Addicted to LI Member

    you mean "Direct clients to redirect Internet traffic" yes its in there
     
  55. burritoboy9984

    burritoboy9984 Addicted to LI Member

    Thor, is it safe to save my config from 1.23 update to 1.25 and load the config file from 1.23? :) Looked around briefly but didn't see any info...

    Thanks!
    -Erik
     
  56. fyellin

    fyellin LI Guru Member

    If you're just updating, there's really no need to reload the config file. Your 1.23 settings should still be there when you've updated to 1.25
     
  57. sigma

    sigma Addicted to LI Member

    Honestly i dunno what make you to change your mind about the branch you will follow, but im glad you made an upgrade. Your mod x.25 v6 so far so good i may add, however if something happend i let you know :wink:, Thanks for the fantastic job! Greetings! :thumbup:

    P.D. The sticky should be renamed maybe to a x.23-x25 or something, just a suggestion...
     
  58. thor2002ro

    thor2002ro Addicted to LI Member

    DO not use saves from 1.23 , you need to clean nvram and remake all setings ... unless you do this dont post here asking for help

    edit: chant rename it need a MOD to do it...
     
  59. kamatschka

    kamatschka Network Guru Member

    Nice Firmware.. Ive installed it and its working...

    I chose this Firmware because of the propagated SD-Card Support.. Ive Soldered all thigs together ... But the Router is having a Problem find the SD-Cards I tried to get working..

    Here the Thread where I have postet my Issue.. It would be really helpfull if someone can try to solve my Problem..

    HERE the THREAD: KLICK ME
     
  60. thor2002ro

    thor2002ro Addicted to LI Member

  61. kamatschka

    kamatschka Network Guru Member

    YAAAAAAY... ITS WORKING!!! I Love you!! :)


    THANK YOU.... SO I only need to intall optware now? Is this a packetmanager or why should I Install it?!

    ANd to wich Folder is the SD Card mounted?


    Thank you very much...
     
  62. thor2002ro

    thor2002ro Addicted to LI Member

    for opt ware you need ext2 formated sd search on the forum... im trying to do opt the loop way with a single file but cant seem to get the bloody loop driver to mount....
    sd mounted to /mmc
     
  63. kamatschka

    kamatschka Network Guru Member

    I get all things working now.. optware is installed and I can download and install apps with ipkg form the repository...


    Now im stuck at vsftpd..


    I need the folder /usr/share/empty ....

    But I have with root no write permissons there..it says something linke "read only file-system" . Is there any possibility to make this folderstructure?


    Thank you very much for your help...
     
  64. thor2002ro

    thor2002ro Addicted to LI Member

    cant you just make a link?
     
  65. burritoboy9984

    burritoboy9984 Addicted to LI Member

    thx thor! very nice :)

    -Erik
     
  66. fyellin

    fyellin LI Guru Member

    Apologizes. Thanks for correcting me. I actually thought I was answering about a different mod.
     
  67. kamatschka

    kamatschka Network Guru Member

    Linking does not work because I have not the dyrectory-structure

    /usr/share/empty/ ...


    when I try to link the Folder toanother it says "no duch file or directory"..

    the folder "share" in "usr" does not exist and the folder named "empty" in "share" does also not exist... THerefore the linking will not work...


    Reconfiguring the conf file of vsftpd does also not get other results...

    Is there an other way to force the creation of these essential folders?


    Thanks in Advance...


    greetz kama
     
  68. thor2002ro

    thor2002ro Addicted to LI Member

    dude you dont need dir named empty... share.... you need to link share on the mmc with share in usr thats it then do all the creating on the mmc
     
  69. kamatschka

    kamatschka Network Guru Member

    Hi!

    I hve a 2GB big ext2 formatted SD_Card..

    Yes... I tried to link it to my mc with following command:

    ln -s /usr/ /mmc/


    so the usr link is in the mmc folder...

    then I tried to create a folder within the usr-link and it does not work because it links directly to the "original" usr folder wich is in / and there I have nor writing permissions.. Chmod does also not work...

    Can you help me in this case.. I would really get vsftpd working under your firmware...
    Ive tried it 6 hours with configuring vsftpd to another folder but its not working...


    thank you very much in advance...
     
  70. thor2002ro

    thor2002ro Addicted to LI Member

    you cant try to make a direcotry on the mmc usr and copy all /usr them do mount /mmc/usr /usr
     
  71. kamatschka

    kamatschka Network Guru Member

    Yes.. this worked so far... I can now create folders and write to /usr/ ...


    Now I wanted to download vsftpd with ipkg but i dont know how the ipkg.conf deleted itself.. Its missing in /etc/ .. can you post the content of ipkg.conf so i can put it in /etc/ to get it working... I think Im then done with all and could vsftpd get working...



    Thank you very much... you helped me a lot....


    Greetz kama
     
  72. thor2002ro

    thor2002ro Addicted to LI Member

    you need ipkg.conf from somewhere else... it contains repository downlaod urls . it's not included in any tomato...
    cant help you any further because i dont use ipkg... any program i need i just compile it and put it on the mmc .... this is not related to my mod .. any mod will do please open a new thread so more people can help i'm shure there must be someone who uses ipkg in the forum
     
  73. kamatschka

    kamatschka Network Guru Member

    Thank you very much...

    I tried another 5 hours and geht it working... haleluja...

    but after rebooting optware and therefore ipkg and vsftpd and all progs I installed are deleted and I need to run every time I restart the Router all these install and configuration procedures...




    I would apreciate and it would be really nice in the next build of your firmware if you could put a ftpserver like vsftpd and a http-server like lighttpd with GUI in the firmware...


    So I am really thankfull you helped me... Good supporting..


    Thanks in advance

    kamatschka
     
  74. tenkuken

    tenkuken Addicted to LI Member

    can i have your source code (v1.25 ND) please :)
     
  75. thor2002ro

    thor2002ro Addicted to LI Member

    it's on my todo list: for some versions i dont have a clean source
    there certain "tricks" for it to compile
     
  76. thor2002ro

    thor2002ro Addicted to LI Member

    Tomato_RAF_1.25.8515 ND USB .7 v7 OUT

    Have funnnn!!!!!!!!!!!!!!! :p just got my new router and updated the mod to USB
     
  77. sigma

    sigma Addicted to LI Member

    Still Will be regulary updates for a 4MB routers? or just for +4MB?

    Thanks :smile:
     
  78. thor2002ro

    thor2002ro Addicted to LI Member

    depends if i have time and still keep the WRT54GL(might sell it)
     
  79. hapahopi

    hapahopi Addicted to LI Member

    i thought i bricked my router when i flashed this firmware. i later found out that it was winrar unpacking it differently. tried 7Z to unpack and now it works great! thanks for this and can't wait for the bittorent client!

    Asus WL-500gP v2
     
  80. thor2002ro

    thor2002ro Addicted to LI Member

  81. mactogo

    mactogo Addicted to LI Member

    Working great on my WL500gp v1. Running for more than 24hrs with no problems so far. I also noticed an increase in my signal. Not sure if has anything to do with this firmware but seems to be that way at least.
     
  82. thor2002ro

    thor2002ro Addicted to LI Member

    cold be from the updated wireless driver...
    and i have to ask check if you dont have the bad wifi card on the router(it can be identifyed from the first 2 letters/numbers from the serial google it for more info...)
    mine has the bad wifi card and have to change a resistor on it for the card to work properly.its one of the reasons i havent switched to WL-500gP v1 as the primary router ... cant find a 62ohm resistor in my country .... so i ordered a BCM 4318(its the same as the original card that comes with the router , just that the original one is made by asus) from ebay and waiting for it...
     
  83. mactogo

    mactogo Addicted to LI Member

    yes, i know of the problem and my router is one of the units with the bad wifi resistor problem :( That's why an increase in the signal for this firmware is the first thing i noticed. Since i don't want to do any soldering I was also planning on fitting in a new wifi card (still deciding between Atheros and BCM) but for the meantime my unit's still working good - a little crippled maybe, but nothing for me to be too worried about.

    I also noticed you implemented scanner drivers in this firmware. Have you gotten it to work on the network? How do we go about mounting scanners and would you know which models are compatible?
     
  84. thor2002ro

    thor2002ro Addicted to LI Member

    i just implemented it and i dont have a scanner to test .... but need to search for a program somthing like p910 for scanners , p910 is printers only :(
    as for the wifi get BCM 4318(BCM94318MPG) card dont get other cards because we dont have drivers implemented....
     
  85. occamsrazor

    occamsrazor Network Guru Member

    Hi Thor,
    Am using the new "All-in-One" mod (you said you want questions about that mod to be posted here... right?). All is fine except I'm not getting the USB Samba & FTP working... The USB drive says it is mounted, but I am getting password errors when I try to FTP (I've double-checked password is correct) and getting no response to attempts to connect to Samba share. I'm getting a lot of errors in the log like this:

    Code:
    Jul 18 15:05:12 Tomato daemon.err smbd[17112]:   ===============================================================
    Jul 18 15:05:12 Tomato daemon.err smbd[17112]: [2009/07/18 15:05:12, 0] lib/fault.c:fault_report(41)
    Jul 18 15:05:12 Tomato daemon.err smbd[17112]:   INTERNAL ERROR: Signal 10 in pid 17112 (2.0.10-security-rollup)
    Jul 18 15:05:12 Tomato daemon.err smbd[17112]:   Please read the file BUGS.txt in the distribution
    Jul 18 15:05:12 Tomato daemon.err smbd[17112]: [2009/07/18 15:05:12, 0] lib/fault.c:fault_report(43)
    Jul 18 15:05:12 Tomato daemon.err smbd[17112]:   ===============================================================
    Jul 18 15:05:12 Tomato daemon.err smbd[17112]: [2009/07/18 15:05:12, 0] lib/util.c:smb_panic(2381)
    Jul 18 15:05:12 Tomato daemon.err smbd[17112]:   PANIC: internal error
    Jul 18 15:05:12 Tomato daemon.err smbd[17112]: 
    Jul 18 15:05:12 Tomato daemon.err smbd[17113]: [2009/07/18 15:05:12, 0] lib/fault.c:fault_report(40)
    Jul 18 15:05:12 Tomato daemon.err smbd[17113]:   ===============================================================
    Jul 18 15:05:12 Tomato daemon.err smbd[17113]: [2009/07/18 15:05:12, 0] lib/fault.c:fault_report(41)
    Jul 18 15:05:12 Tomato daemon.err smbd[17113]:   INTERNAL ERROR: Signal 10 in pid 17113 (2.0.10-security-rollup)
    Jul 18 15:05:12 Tomato daemon.err smbd[17113]:   Please read the file BUGS.txt in the distribution
    Jul 18 15:05:12 Tomato daemon.err smbd[17113]: [2009/07/18 15:05:12, 0] lib/fault.c:fault_report(43)
    Jul 18 15:05:12 Tomato daemon.err smbd[17113]:   ===============================================================
    Jul 18 15:05:12 Tomato daemon.err smbd[17113]: [2009/07/18 15:05:12, 0] lib/util.c:smb_panic(2381)
    Jul 18 15:05:12 Tomato daemon.err smbd[17113]:   PANIC: internal error
    Jul 18 15:05:12 Tomato daemon.err smbd[17113]: 
    Jul 18 15:05:12 Tomato daemon.err smbd[17114]: [2009/07/18 15:05:12, 0] lib/fault.c:fault_report(40)
    Jul 18 15:05:12 Tomato daemon.err smbd[17114]:   ===============================================================
    Jul 18 15:05:12 Tomato daemon.err smbd[17114]: [2009/07/18 15:05:12, 0] lib/fault.c:fault_report(41)
    Jul 18 15:05:12 Tomato daemon.err smbd[17114]:   INTERNAL ERROR: Signal 10 in pid 17114 (2.0.10-security-rollup)
    Jul 18 15:05:12 Tomato daemon.err smbd[17114]:   Please read the file BUGS.txt in the distribution
    Jul 18 15:05:12 Tomato daemon.err smbd[17114]: [2009/07/18 15:05:12, 0] lib/fault.c:fault_report(43)
    Jul 18 15:05:12 Tomato daemon.err smbd[17114]:   ===============================================================
    
    Thanks again for all your work in getting that mod together :)
     
  86. thor2002ro

    thor2002ro Addicted to LI Member

    working on it ... thanks for the bug report....
     
  87. fyellin

    fyellin LI Guru Member

    The main page says that this upgrade takes a while to download to the router. Would it be safer and or quicker to just download the .trx file onto the device and use
    mtd-write -i file.trx -d linux
    reboot​
    to install the new OS? Has anyone tried this?
     
  88. occamsrazor

    occamsrazor Network Guru Member

    When I flashed the "all-in-one" version of this mod it took about 1min30secs to upload to the router (over ethernet), and then a few minutes for the upgrade to be completed and the router reboot. It seemed a little (but not that much) longer than previous mods, but I didn't have any problems.
     
  89. thor2002ro

    thor2002ro Addicted to LI Member

    found the problem and fixed it forgot to update the kernel thats what is creating all the problems
    i will release an update today or tomorow :)
     
  90. occamsrazor

    occamsrazor Network Guru Member

    Nice, I look forward to it... It's not that I'm really using the USB functionality that much, but it's cool to have nonetheless.

    On a general point, I was wondering.... I know it took you a lot of work and time to get this "all-in-one" 4mb+ mod together, but once the initial work is over will it be relatively easy for you to keep it updated when other authors (Victek, SgtPepper, etc) update their mods?
     
  91. thor2002ro

    thor2002ro Addicted to LI Member

    install it to ipkg..... but theres no space left in my mod for 4mb.....
     
  92. thor2002ro

    thor2002ro Addicted to LI Member

    official or RAF i think....
     
  93. thor2002ro

    thor2002ro Addicted to LI Member

    you need usb or vpn?
    edit:if so go with it
     
  94. Victek

    Victek Network Guru Member

    If you hang it in the git yes, but till now what I saw is that the versión of each mod differs for each of us, for instance, I don't use USB I don't update anything about fs.
     
  95. i1135t

    i1135t Network Guru Member

    Any new releases to fix that bug for the FTP issue for the all-in-one mod?
     
  96. thor2002ro

    thor2002ro Addicted to LI Member

    ya i fixed it just not released it yet.... adding some new stuff...
     
  97. edric25

    edric25 Addicted to LI Member

    will there be an integrated torrent client in the future? it would be greate if there was
     
  98. thor2002ro

    thor2002ro Addicted to LI Member

    im working on integrated optware so you can write ipkg install rtorrent and you have torrent :)
     
  99. occamsrazor

    occamsrazor Network Guru Member

    Integrated Optware? So we can install any packages? :) :) :)
     
  100. thor2002ro

    thor2002ro Addicted to LI Member

    i tested rtorrent thats about it.... havent had time to test alot of them... theoreticly you can install all you what
    and its not openwrt you still need a usb to bind to /opt
    i'm working now on automatic swap enable
     

Share This Page