1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato ND USB Mod with kernel 2.6 (Tomato-RT)

Discussion in 'Tomato Firmware' started by teddy_bear, Jan 8, 2010.

  1. Toastman

    Toastman Super Moderator Staff Member Member

    Quite possibly the new wireless driver may not allow 40MHz wide channel operation the 2.4GHz band. This is actually supposedly a requirement, to avoid unnecessary interference to b/g users, but it seems OEM's are ignoring it. Mode "N" is not really suitable for use on 2.4GHz and if it's allowed to be used then in the future we will all be totally screwed (my opinion as an RF engineer, for what it's worth).

    The 5GHz band is the best place for wide channels...
     
  2. blinkfrog

    blinkfrog Addicted to LI Member

    How can I setup PPTP WAN connection in Tomato? Have tryed beta05 and beta07.

    I have username and password, but I haven't static IP. Internet provider requirement is to use Automatic IP address obtaining from DHCP.

    Next, where can I type ISP's server address? Is it "Gateway" field? I have tryed this but without good results.

    In DD-WRT, all ASUS firmwares and Oleg's firmwares I haven't any problem with PPTP.
     
  3. mschulze

    mschulze Addicted to LI Member

    The router is set to N-only. So all clients (2 laptops) connect in N-mode.
     
  4. prince

    prince Addicted to LI Member

    i cant access my router
    im putting username root
    pass- admin
    not working
    pls help
     
  5. deboyz1014

    deboyz1014 Addicted to LI Member

    Please provide more info, what did you do before that and have you tried resetting the router?
     
  6. TexasFlood

    TexasFlood Network Guru Member

    Did you, for example, just flash from dd-wrt to tomato? In this case, the password gets munged as described in the official Tomato FAQ and you'll have to reset the router to reset the password.

    If it's something else, as was already stated, you'll have to provide some more detail, although in any case, a reset should put the id/pw back to default.
     
  7. Slimey

    Slimey Network Guru Member

    Which one of these would you use to run on a Broadcom BCM4785 chip rev 2 cpu? Is this MIPS r1 or r2?
     
  8. rmccask

    rmccask Network Guru Member

    Safe to try on Buffalo WHR-G54S?

    I am tempted to try this on a Buffalo WHR-G54S. I think I can recover easily enough from bricking this but I figure I will ask if there is any reason I shouldn't try before I start. The /proc/cpuinfo claims:

    system type : Broadcom BCM5352 chip rev 0 pkg 0
    cpu model : BCM3302 V0.8

    I am running the latest USB mod already "Tomato Firmware v1.27.8744 ND USB Std". I should be fine with the "Lite" edition of this due to the limited memory. I am running it in "Wireless Ethernet Bridge" mode if that makes any difference. I would rather wait until it is no longer beta before I put it on my main router but this router I can play with without annoying my wife.

    Thanks,
    -Randy
     
  9. amitava82

    amitava82 Addicted to LI Member

    OK, I don't know if it is a bug or not. After router reboot tasks in Scheduler won't run until I connect to internet. My internet works through a web based login portal. I need to login to be able to browse. Once I login, scheduler starts working. Is there anyway to fix it? I have a custom task to do the login but it won't run until I manually login. :\
     
  10. teddy_bear

    teddy_bear Network Guru Member

    rmccask,
    I believe MIPSR1 builds should work on BCM5352... You can try it - but only if you are sure you can unbrick your router :).

    amitava82,
    The scheduler doesn't work because the router doesn't have a valid date/time before it connects to the internet and obtains the time via NTP.

    Slimey,
    That's MIPSR1 CPU. But I don't know if this firmware will boot up on Linksys N routers - try it at you own risk.
     
  11. prince

    prince Addicted to LI Member

    i reset it twice after that its working ....
    thanks
     
  12. amitava82

    amitava82 Addicted to LI Member

    Thanks teddy_bear for the clarification. Is there any workaround?
     
  13. bogderpirat

    bogderpirat Network Guru Member

    you could try doing the login from the router.
     
  14. amitava82

    amitava82 Addicted to LI Member

    It is not standard PPPoE system. But I put the script in WAN Up section and it did the trick :D
     
  15. dicson

    dicson Addicted to LI Member

    thx .... it is working fine for mine .....and very fast compare to the official one.

    Is there any possibility that including the Media Server function in the next beta ?
     
  16. rmccask

    rmccask Network Guru Member

    I tried it with tomato-1.27-NDUSB-9044MIPSR1-beta07-Lite.trx but all I get is the message "File is too big to fit in MTD". This is trying the upgrade via the Tomato's Administration->Upgrade option. Do you think the tftp method of flashing would be more successful or am I stuck for now?

    -Randy
     
  17. Catalin

    Catalin Addicted to LI Member

    Your question is useless without mentioning what router model you are trying to flash it to...
     
  18. though

    though Network Guru Member

    i browsed over to the DD-WRT forums for #$%^s n giggles and found that a lot of people are *still* complaining about wireless dropouts and slow throughput when transferring larger files. the buzz going around is that they believe it's a result of the router overheating.

    do you guys think they are having these problems as a result of the overheating or did Teddy Bear do something to fix these issues since im not hearing these complaints in this forum anymore????
     
  19. cariyawa

    cariyawa Addicted to LI Member

    I put a heat sink for CPU as well as for switch, but I really don't think that these wireless dropouts happen because of over heating issue. I just did it for fun. But that only didn't solve my wireless dropout issues. Heat sinks **may** help in many ways. I mean they always help... cooler the better.
    I had wireless dropouts when we have first tomato beta version.. then eventually all settled down to none. I played with different channels and widths. Right now I don't have any problem for what I use. I am running a thttpd web server with optware, openvpn server, SSH, samba. My conclusion is that it has something to do with firmware. So T.B. must have done something to fix it. :biggrin:
     
  20. teddy_bear

    teddy_bear Network Guru Member

    Yes, this very particular issue that seemed to be very common initially - the router reboots during N-speed wireless transfers - was addressed in beta05. Several people confirmed it who could reproduce the problem consistently in beta02 and other firmwares.
    However, please note that not all routers were affected - some (including mine) did not have this issue at all from the beginning.
    WHR-G54S? It has 4MB flash, doesn't it? Shoud fit - I was able to flash Asus WL520GU (also 4MB) with this exact build - unless WHR has a non-standard/larger CFE. Maybe try and look for hints on dd-wrt forum - they may have some additional info about restrictions and flashing for this model.
    By the way - I thought WHR-G54S doesn't have USB... If it doesn't - why flash a "Lite" build with USB support? You can try using no-USB build (tomato-1.27-ND-9044MIPSR1-beta07-Std.rar) which is smaller...
     
  21. teddy_bear

    teddy_bear Network Guru Member

    Tomato has rather poor support for PPTP and L2TP connection types compare to Oleg's firmware. I'm trying to address this, and make it more usable for people with these connection types, for example the beta07 already includes the kernel L2TP driver that speeds up L2TP connections a lot.
    What router do you run this mod on? Will you be willing to flash and test some experimental builds with PPTP-related changes?
     
  22. Terror1

    Terror1 Addicted to LI Member

    I just wanted to say thank you for getting Tomato working on the RT-N16, I purchased this especially for Tomato support.

    I have encountered some bugs/features here and there. Is there a special place you would like bug reports?
     
  23. though

    though Network Guru Member

    post your probs in this thread, please...


     
  24. salamaza

    salamaza Network Guru Member

    finally tomato with N wireless router!, thanks teddy for your work, now Iam thinking of replacing my good WRT54GL. I Need a Router that can stream HD video to my HTPC(it has N support).

    I have one qustion, what router would you recommend for your firmware teddy?
    (Asus RT-N16 or WNR3500L..others?)
    maby you should write that in the first post(recommended router)


    Thanks alot for your hardwork!
     
  25. gingernut

    gingernut LI Guru Member

    Teddy Bear has a RT-N16 so he can thouroughly test before a release. Support, as far as I know, for the WNR3500L is test and report by users as he didn't/dosen't have one.


    Would some good samaritan post a how to on compiling Tomato K26 :redface:. I have tried using this guide I found but maybe the process has to be a little different when compiling Teddy Bears mod for the RT-N16.

    Thanks
     
  26. azdps

    azdps LI Guru Member

    HOW TO COMPILE FOR RT-N16 USING UBUNTU 9.10

    DOWNLOAD TEDDY BEARS SOURCE CODE FOR TOMATO AND PLACE FILES IN FOLLOWING DIRECTORY:
    /home/code/tomato

    EXECUTE THE FOLLOWING COMMAND TO INSTALL MISSING STUFF ON UBUNTU:
    sudo apt-get install gcc g++ binutils patch bzip2 flex bison make gettext unzip zlib1g-dev ncurses-dev

    EXECUTE THE FOLLWING IN TERMINAL WINDOW. DON'T CLOSE WINDOW AFTERWARDS.
    sudo ln -s ~/code/tomato/tools/brcm/ /opt/brcm
    PATH=$PATH:/opt/brcm/hndtools-mipsel-uclibc/bin:/opt/brcm/hndtools-mipsel-linux/bin

    IN TERMINAL WINDOW NAVIGATE TO:
    /code/tomato/release/src-rt/

    EXECUTE THE FOLLOWING IN TERMINAL WINDOW TO MAKE FIRMWARE WITH USB AND VPN:
    make MIPS32=r2 e

    OR EXECUTE THE FOLLOWING IN TERMINAL WINDOW TO MAKE FIRMWARE WITH USB WITHOUT VPN:
    make V1=9044 V2=Whatever r2m



    03/14/2010: made change to apt-get command
     
  27. gingernut

    gingernut LI Guru Member

    Thanks :smile:
     
  28. mstombs

    mstombs Network Guru Member

    I assume this is for the 32 bit, but which version? I recall 9.04 needed bash rather than dash, and vice-versa with 9.10. My 64-bit 9.10 now works fine - you also need the 32 bit versions of various libs/utils. Have had trouble using file download with git - but the snapshot seemed fine.
     
  29. azdps

    azdps LI Guru Member

    the above compiling info was in regards to Ubuntu 9.10 32bit. i didn't have to mess with dash to bash. compiles fine with just opening the terminal window and using the instructions i posted in my previous post.

    ok i just tested compiling the newest source and now ncurses-dev needs to be installed for a successful compile. im editing the post above to include it.
     
  30. KyleChen

    KyleChen Addicted to LI Member

    I am using beta07 and build a pre-beta08 with new wl driver from sourse, can't spot a single bug about it.

    Just wonder, I moved my laptop just out of the room where the n16 router is. 5 meters away the speed drop from 144M to 11M, and Ive got no way to speed it up no more. Can anybody with experience tell me is it normal?
     
  31. teddy_bear

    teddy_bear Network Guru Member

    No, I don't believe it is. Try different channels - it may help to avoid possible interference. My N16 provides the wireless coverage throughout the house with no noticeable drop in speed. Granted, it's not a big house, but it's still more than 5 meters in distance, and a couple walls between the router and the clients. The N laptop is able to transfer files at 10 to 13 MB/s no matter where in the house it is.

    Since you built the firmware from the latest git sources, you should see the link speed on the Status->Devices page. Does it show 11? Here it fluctuates between 300 and 243, but doesn't go below that.
     
  32. gingernut

    gingernut LI Guru Member

    These are the errors that I keep getting after following the instructions.

    Code:
    make[4]: mipsel-uclibc-gcc: Command not found
    make[4]: *** [head.o] Error 127
    make[4]: Leaving directory `/home/ginger/tomato/release/src/lzma-loader'
    make[3]: *** [lzma-loader] Error 2
    make[3]: Leaving directory `/home/ginger/tomato/release/src/router'
    make[2]: *** [all] Error 2
    make[2]: Leaving directory `/home/ginger/tomato/release/src-rt'
    make[1]: *** [m] Error 2
    make[1]: Leaving directory `/home/ginger/tomato/release/src-rt'
    make: *** [r2m] Error 2
    
     
  33. azdps

    azdps LI Guru Member

    i noticed you put the tomato folder into the ginger folder. if you didn't change my instructions to reflect the different path, then there will be issues.

    try the exact path that i have for testing purposes. tomato should be in the code folder and not in ginger. /home/code/tomato

    otherwise, at the moment, im not sure why you are getting those errors.
     
  34. rasa

    rasa LI Guru Member

    Hello,

    I have some problems with Tomato K26 (beta07) on Asus WL-520GU and microsd card reader included in Huawei E156G modem.

    After connect modem I get error:
    Code:
    usb 1-1: new high speed USB device using ehci_hcd and address 2
    usb 1-1: configuration #1 chosen from 1 choice
    usb-storage: probe of 1-1:1.0 failed with error -5
    usb-storage: probe of 1-1:1.1 failed with error -5
    usb-storage: probe of 1-1:1.2 failed with error -5
    usb-storage: probe of 1-1:1.3 failed with error -1
    The same error after disable USB 2.0
    Code:
    usb 1-1: new full speed USB device using ohci_hcd and address 2
    usb 1-1: configuration #1 chosen from 1 choice
    usb-storage: probe of 1-1:1.0 failed with error -5
    usb-storage: probe of 1-1:1.1 failed with error -5
    usb-storage: probe of 1-1:1.2 failed with error -5
    usb-storage: probe of 1-1:1.3 failed with error -1
    Is it a problem with usb-storage module?
     
  35. joorge

    joorge Addicted to LI Member

    Thanks teddy bear. Just installed on my new N16 that replaced a WRT54-GL with stock firmware. Life is good. Also, thanks to cariyawa, mstombs and soldier for the excellent instructions. Worked first time for a complete noob.
     
  36. teddy_bear

    teddy_bear Network Guru Member

    rasa,
    The storage device in your Huawei modem may not be supported in the kernel. Please post the complete log when the modem is attached to the router.
    Do you want to use it as a storage, or as a modem? If as a modem, you'll need to use usb_modeswitch utility to switch it to modem mode.
     
  37. Lost_Animal

    Lost_Animal Addicted to LI Member

    teddy BTW the new BETA7 release just ROCKS...:biggrin:

    I don't remember when was the last reboot i've done by my self.
    Access restrictions also working great m8.

    Thank you.
     
  38. Catalin

    Catalin Addicted to LI Member

    Same here, I have 12 days uptime on the WAN PPPoE connection so far, that says it all...:biggrin:
     
  39. dennys

    dennys Addicted to LI Member

    Hello,

    I can use K24 (v8744) in 500gp V1, but I tried to use K26 beta 7 and have following problems.

    1. Enable USB 2.0, it's ok.
    2. Enable IHCI and saw the following log
    Code:
    Dec 31 16:02:25 unknown user.info kernel: usbcore: deregistering interface driver usblp
    Dec 31 16:02:26 unknown user.info kernel: usbcore: registered new interface driver usblp
    Dec 31 16:02:26 unknown user.info kernel: usblp: USB Printer Device Class driver
    
    3. Put the Huawei E169 into USB slot but no log and seems hub cannot detect it.
    4. Enable OHCI and saw the following log
    Code:
    Dec 31 16:03:29 unknown user.info kernel: usbcore: deregistering interface driver usblp
    And after that, I cannot use the hub anymore. I can ping it after reboot, but I cannot use web or telnet. And the original telnet session is crashed after I enable OHCI.

    Is there any suggestion for it? thanks.
     
  40. teddy_bear

    teddy_bear Network Guru Member

    No. The details you provided are incomplete and scrappy. A few lines from the log are ok - they don't show anything being wrong.
    If you can't access your router now - reset it to defaults first using the "reset" button.
     
  41. fier04

    fier04 Guest

    MLPPP

    Pretty sure this has been asked before. Are you planning to add MLPPP support at all?
     
  42. Brandonc

    Brandonc Addicted to LI Member

  43. azdps

    azdps LI Guru Member

    i think what KyleChen was refering to was that he compiled by himself the latest source code from the git repository. there is actually no downloadable build later then beta07 on sourceforge at the moment from my understanding.

    for instance i compiled the latest source code from the git repository and flashed it to my router today. you can do the same. then you can call it pre-beta08.
     
  44. Catalin

    Catalin Addicted to LI Member

    It was there for a short period of time. Probably the proper beta8 version will be released soon. Be pacient. :)
     
  45. gregd72002

    gregd72002 Addicted to LI Member

    What's the hack/trick to create an image that can be used for asus rt n16?
    I've been trying many different ways and it never works... whilst it works well on some other wrt routers!
    On asus n16 it always stuck on booting:
     
  46. humba

    humba Network Guru Member

    What's the meaning of the different builds on SF? MIPSV1/V2 is explained, but what is tomato-1.27-NDUSB-9044MIPSR2-beta07-Ext.rar
    tomato-1.27-NDUSB-9044MIPSR2-beta07-vpn3.6.rar
    tomato-1.27-ND-9044MIPSR2-beta07-vpn3.6.rar
    tomato-1.27-ND-9044MIPSR2-beta07-Std.rar

    and what about extras-K26-MIPSR2.tar.gz?

    I presume that -ND means using the newer drivers, USB means USB support and vpn3.6 means the VPN version 3.6 (thus the same VPN as the regular 3.6 VPN release).

    What do std and ext stand for? Does ext contain all the binaries from extras-K26-MIPSR2.tar.gz? And are those included in the VPN build as well?
     
  47. Toastman

    Toastman Super Moderator Staff Member Member

    Read the first post of this and the USB thread...
     
  48. Edrikk

    Edrikk Network Guru Member


    Hi Slimey... Did you managed to test this out? I'm really wishing to run Tomato on my WRT610nV2, but don't have the means to get back up if things don't go well...

    I hope someone can try it... Keep up the great work teddy_bear!
     
  49. mschulze

    mschulze Addicted to LI Member

    After more experiments, it seems that the connection drops happen with tomato and DD-WRT but not with the Asus firmware (I tried the latest beta).

    Unfortunately the Asus firmware has more severe issues, like WLAN to LAN speeds of 100KB/s when transferring large files. This does not happen with tomato.
     
  50. teddy_bear

    teddy_bear Network Guru Member

    No such plans yet. Actually, you're only the 2nd or 3rd person to ask in the last 15 months, since I started my mod. Not enough demand...
    Search often helps:
    http://www.linksysinfo.org/forums/showthread.php?p=359442#post359442
    http://www.linksysinfo.org/forums/showthread.php?p=360707#post360707
    Please note that WRT610nV2 has 4718 CPU which is MIPS Release2. Supposedly MIPSR2 builds should boot on it. But someone needs to try to make sure. I wouldn't recommend trying though if you are not sure how to unbrick the router if the flash goes bad... And of course, there will be no GUI settings for 2 radios - only a single-band radio is supported by this version of Tomato - and the LEDs/buttons probably won't work.
     
  51. mau108

    mau108 Addicted to LI Member

    hey
    Any word on beta8 release? I am on beta5 right now, debating if I should update to beta7 or wait for beta8 if it's around the corner.

    Does beta7 fix lan speeds?
     
  52. gingernut

    gingernut LI Guru Member

    I know this is not a compiling Tomato thread but I've followed the steps found in those links on a fresh Ubuntu install but still get errors sooner or later in the build process.

    Apart from the instructions posted is there any other things that I'm missing :confused:.
     
  53. 3lackhawk

    3lackhawk Addicted to LI Member

    I use WL500W router with Tomato ND mod based on 2.4 kernel, but my webcam is still not working with it.Is there any difference about webcam support in this firmware compared to 2.4 kernel version?or else is there just same possibility to use 2.6 kernel module driver for webcam like in the 2.4 kernel?
     
  54. rasa

    rasa LI Guru Member

    I want to use my device as modem and storage :)
    I don't have any problems in tomato with kernel 2.4. Storage is also correctly recognized in OpenWrt with kernel 2.6.

    Complete log in attachment.

    It is possible to mount USB CD-ROM in tomato?
     

    Attached Files:

  55. Catalin

    Catalin Addicted to LI Member

    Ok, so after 13 days of uptime, tonight, under heavy p2p traffic (6.5 MB/s download and about 3.2 MB/s upload), when I tried to copy some 700 MB of data using Samba from a memory stick attached to the RT-N16 to a LAN PC, after transfering about 200 MB the router rebooted itself. Unfortunately, the log is gone.

    First Tomato crash for me.:tongue:
     
  56. teddy_bear

    teddy_bear Network Guru Member

    Nope - the SCSI CDROM support is not included, neither is ISO 9660 filesystem support. Looks like that's why your storage is not accessible - it's recognized as a CDROM.
    What's strange however, is that you say you can use the modem's storage in Tomato with kernel 2.4 - but the CDROM driver is not included there either...

    gingernut,
    Unless you post the exact errors you are getting, nobody can advice you. Also, make sure you're building in the clean Tomato tree - re-extract files from the archive, or run "make distclean" after failed builds.

    3lackhawk,
    Nothing for webcam support is included.
     
  57. rasa

    rasa LI Guru Member

    teddy_bear
    After disable CD-ROM in my modem I get the same error:
    Code:
    Initializing USB Mass Storage driver...
    usbcore: registered new interface driver usb-storage
    USB Mass Storage support registered.
    usb 1-1: new high speed USB device using ehci_hcd and address 3
    usb 1-1: configuration #1 chosen from 1 choice
    option 1-1:1.0: GSM modem (1-port) converter detected
    usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
    option 1-1:1.1: GSM modem (1-port) converter detected
    usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
    option 1-1:1.2: GSM modem (1-port) converter detected
    usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2
    usb-storage: probe of 1-1:1.3 failed with error -1
    I think there is problem with usb-storage module...
     
  58. teddy_bear

    teddy_bear Network Guru Member

    Are you saying that even with cd-rom disabled you still can't use it as a modem?

    From your log it looks like the modem is recognized correctly, and you can probably just ignore storage errors unless the log is flooded with them. According to this, the errors are expected, and this thread shows that this is a common issue even with recent kernels. I have not looked deeper to see if solution exists already - please let me know if you find out anything.
     
  59. iroot

    iroot Addicted to LI Member

    Teddy, there is some problem with module cdc-acm.ko in beta07. I have GSM mobile phone (Motorola L6) attached to USB, I use it as modem. When I want to make a call, I send «ATDTsome_number» to /dev/ttyACM0 and router freezes. I've returned to beta06.04 (MIPSR2-beta06u.04 ND USB Ext), with old version my phone works correctly.

    //sorry for my English, hope, that you understand me.
     
  60. gingernut

    gingernut LI Guru Member


    These are the new errors.

    Code:
    make[4]: Entering directory `/home/code/tomato/release/src/router/bridge'
    make[4]: *** No rule to make target `libbridge/if_index.c', needed by `libbridge/libbridge.a'.  Stop.
    make[4]: Leaving directory `/home/code/tomato/release/src/router/bridge'
    make[3]: *** [bridge] Error 2
    make[3]: Leaving directory `/home/code/tomato/release/src/router'
    make[2]: *** [all] Error 2
    make[2]: Leaving directory `/home/code/tomato/release/src-rt'
    make[1]: *** [m] Error 2
    make[1]: Leaving directory `/home/code/tomato/release/src-rt'
    make: *** [r2m] Error 2
    
    Thanks
     
  61. KyleChen

    KyleChen Addicted to LI Member

    I can't downgrade /upgrade tomato anymore. (find out after trying pre-beta08)

    After flash another firmware with asus tool, the nvram mess up.

    I keep trying asus tool, and the DDWRT-MINI successfully flash into RT-N16.

    But, I can't update from it to any other firmware anymore.

    and I can't access "recovery mode", asus tool become useless now.

    I can use the web-gui, can telnet, but just can't upgrade any firmware. strange~~~

    I guess my cfe is half-broken.
     
  62. KyleChen

    KyleChen Addicted to LI Member

    OMG
    I am totally a firmware newbie~~~

    here I fixed cfe, Lucky its only half broken b4:

    cd /tmp
    wget http://192.168.1.129/cfe.bin #my laptop web server
    mtd unlock cfe
    mtd write -f /tmp/cfe.bin cfe
    reboot


    Everything is running now, I can upgrade new firmware now!

    And teddybear, I am not sure its because of the pre-beta08 or not, and i dare not to flash it again~~~~

    and the cfe (bootloader) of RT-N16 was downloaded from here
    http://www.dd-wrt.com/phpBB2/viewtopic.php?t=25971&postdays=0&postorder=asc&start=0

    Thanks god, thanks everyone
     
  63. gingernut

    gingernut LI Guru Member

    I'm not sure so Teddy Bear would have to conferm but it's probably due to the new Broadcom updates included in build 8 that updates among other things the routers cfe to a newer version. So maybe this behaviour is normal.

    As far as I know the cfe is like a computers mainboard bios and some times due to changes in the code it's maybe not possible to go back to older version.
     
  64. jeltok

    jeltok Addicted to LI Member

    MLPPP support

    Hi teddy_bear

    First of all I wanted to thank you for your hard work on the Tomato mod for Asus RT-N16.
    Please count me as #4 person for MLPPP feature. I am using DD-WRT now just because they have incorporated the MLPPP support.
    The real issue that forces me and I believe thousands of other Canadian internet users is p2p throttling by Bell and other telcos.
    The only reliable way to avoid it was Tomato/MLPPP mod (fixppp dot org) running on older hardware (e.g. WRT54GL).
    Recently DD-WRT added support for MLPPP as well.
    It would be very nice to also have this feature in RT-N16 version of Tomato and I am positive it will drive a lot of new users towards your mod.
     
  65. gregd72002

    gregd72002 Addicted to LI Member

    Is there a way to compile rt73 usb module for this firmware? What would be the process of doing it?
    The sources can be obtained from
     
  66. mstombs

    mstombs Network Guru Member

    I am 100% sure build 8 does not upgrade the CFE, it can only possibly be nvram variables, for which the reset button to put the router into management mode should fix. It is very risky change the CFE like that, and likely to be a pain with wrong MAC numbers if successful.
     
  67. Slimey

    Slimey Network Guru Member

    Tried unsuccessfully to run build 7 on WRT350N with patched CFE to run K2.6, suspect router went into a reboot loop but I no longer have serial cable to confirm exactly whats preventing it from fully booting. Also it seems the network on the router was unable to come up as I received no indication of a link once the router restarted; wonder if this is whats causing the problem or is the router just crashing?, the power light did turn steady after a few seconds of flashing and then went back to flashing and repeated the process over and over again.
     
  68. gregd72002

    gregd72002 Addicted to LI Member

    I've just compiled my own version for RT-N16. But there are many problems:
    - missing module auto-load (at least looks like)
    - many kernel panic's ... whenever i try to access www for example...

    Any solution?
     
  69. though

    though Network Guru Member

    solution = use teddy's release :)

     
  70. KyleChen

    KyleChen Addicted to LI Member

    mstombs, When cfe broken, the router can't hold reset button to enter"management mode" anymore, because the "management mode" is provided by cfe itself.

    I am lucky because the cfe was half-working, no "management mode" or "recovery mode", but basic drivers and telnet boot up and work, so i can use mtd.


    And beta08 had a serious issue(i don't know why in the first few days i didn't spot it), under heavy load, the wl-driver will keep on restart. causing wl connection to be on-off-on all the time. but under minor load and no disk operating, It can be stable.

    Another bug possibility is the new NTFS-3G. with latest ntfs-3g update, it happened few times the large files in usb NTFS partition became 0KB suddenly. Including the files I modified through tomato pre08 and the files I didn't touched.Also after that the windows disk check report errors on the partition, fixed, but files just lost into 0KB. (no bad disk blocks report from the full check). It never happened on older build. But because i experienced serious driver crashes, so I can't 100% say its because of ntfs-3g.

    I guess it may be more possible that I damaged the cfe from the driver keeping crashing hundreds of times(i was testing it).

    And anyone know how can I get the source of beta07 from git? I read git documentation but don't have a clue.....off topic :)

    For now i don't think the new driver is a good idea. And I feel everything is updating all the time (miniupnp, busybox, samba......) If we keep chasing the latest modules, we will be in beta version forever :)

    And teddy bear would you please do something about the upnp name showing in windows neighborhood? Because even I un-check the upnp "show in windows network", all windows 7 PC still can detect it and showing "tomato-router" in the network window(win7 is very powerful in detecting network devices). It makes all my housemates(they know nothing about firmwares) laugh at me like"hah hah, Kyle, you really like tomato ah?" And in workplace, it can be dangerous because it expose the router system to public so people can find a method to attack it. That is why every time I build from your code I modify the source, to let it showing only"upnp" instead of"tomato".

    Beyond everything, thanks for your hard work again!
     
  71. teddy_bear

    teddy_bear Network Guru Member

    Don't call it "beta08" because it's not. This is just a custom build you compiled from git sources. Nobody advised you that they are ready - you did it at your own risk...

    That said, I'm very interested in any feedback about the new wi-fi driver. So far I got mixed reports about it - you're the second person who's saying it's unstable and performs a lot worse than the previous one. Although it has been stable for me for , I didn't find any improvements in it either.
     
  72. Papka__

    Papka__ Addicted to LI Member

    May be it's possible to implement speed control by IP? For example as in Vitek's Tomato mode?
     
  73. jnappert

    jnappert LI Guru Member

    @teddbear: Sucessfully compiled 08pre for my RT-N16 which is running without issues using "make r2m". What are the options to build a small version for my WRT54GLs without USB/VPN,... to test the new drivers in WDS-clouds? Is "make MIPS32=r1 d s" correct?

    OC the RT-16N: "nvram get clfkreq" states: 480,240,120. What is the meaning of the 3rd number? lost_animal oced to 532,266 (as in his signature). Is "nvram set clkfreq 532,266" without setting the 3rd value correct? Is some cooling necessary?
     
  74. mstombs

    mstombs Network Guru Member

    The clkfreq settings are cpu, ddr memory bus, axi (I assume some form of pci peipheral bus). The frequency table is in various GPL releases and here

    http://www.dd-wrt.com/wiki/index.php/Overclocking_BCM_47xx_CPU's

    Relevant CFE source in Asus GPL release - the actual frequencies used are set to nearest available clock multipliers by the code, personally I'd manually set all 3 frequencies as per table, but as various reports that 532 is unstable I wouldn't bother until fully stable firmware established. (Overclocking a WRT54G-TM to 250 from 200MHz is a significant 25%, 480 to 500 is only 4%).
     
  75. mstombs

    mstombs Network Guru Member

    I'm sorry I see no mechanism for CFE to be partially broken, that's not the way flash memory and binaries work. The Broadcom/Asus CFE is better than most because the reset button is checked before any nvram variables used, so it doesn't suffer the Linksys WRT54GL problem of duff clkfreq requiring JTAG to recover.

    You do realize that on the RT-N16 there are 2 buttons?

    Security by obscurity is not security! upnp always broadcasts its presence, but XP didn't show the icon if no presentation URL given. What happens if you just enable natpmp?

    But would be good to have a custom miniupnp config box, like dnsmasq - so that names and other custom settings such as restriction of which lan device can use which ports by upnp can be configured by web admin.
     
  76. gregd72002

    gregd72002 Addicted to LI Member

  77. KyleChen

    KyleChen Addicted to LI Member

    mstombs,cfe half working, sounds unbelievable right? but it did happened.
    And I always use reset button to do 30/30/30 for reset....don't know wps button can do reset too :) should save me some time.

    cfe half working i mean, flash in normal ways showing success but old firmware stay still, and can't enter "recovery mode", firmware memory and nvram memory blocks mixed together....all shows the bootloader was broken right? I spent like 5 hours trying to make a successful flash and do lots of memory test, none of them worked.

    But i can still load a buggy linux kernel, so part of cfe was working. and as soon as i flash the new cfe, all the above problems suddenly gone~~~I did opened a bear instead of champagne yestoday :)

    gregd72002: the latest source is a pre-beta08 and very buggy I feel. so far the beta07 is the best.
     
  78. gregd72002

    gregd72002 Addicted to LI Member

    I need sources for beta07. Could you please point me to git rep for beta07 or preferably svn rep with correct revision?

    Thank you,
    G
     
  79. joew333

    joew333 LI Guru Member

    Beta 8 feedback

    The Beta 8 release has some cool features, like transmit/receive speed in the Device List. I guess this is based on the newest drivers from Broadcom.

    As Teddy Bear noted, it does use 1 MB more RAM than the Beta 7 build. When playing with Beta 8, in the Advanced Wireless settings a change of country from United States (to for example Japan) dropped my N speeds from 270 MB/S to 133 MB/S. I also had trouble connecting a VOIP device to the wireline side of the router using static DHCP even after rebooting. The speed of the Tomato interface intuitively seemed slower with Beta 7...although it could just be me. This is the great part about getting early access to a new build.

    Reverted back to Beta 7 for now.
     
  80. cariyawa

    cariyawa Addicted to LI Member

    As T.B. has suggested, please stop this use of term "beta 08". There is still NO official beta 08. Whenever somebody put the term beta 08 and mentioned that it has lot of bugs, it gives the wrong impression to the people, specially for new people who only read the last page of the thread.
     
  81. joew333

    joew333 LI Guru Member

    Test

    You are correct. I should have referred to Beta 8 as "test" as it is not released yet. It is a test build.
     
  82. cariyawa

    cariyawa Addicted to LI Member

    It seems joew333 has reverted back to Beta 07 from newest test build without any problem(Hoping he didn't face problems as KyleChen).

    So that means newest test build doesn't alter the CFE at all. Something else must have affected KyleChen's case.:confused:
     
  83. joew333

    joew333 LI Guru Member

    reverting back

    I had no problems to revert back from Beta 8 test to Beta 7. Just cleared NVRAM.
     
  84. maurer

    maurer LI Guru Member

    it worked the same for me. I recommend erasing NVRAM for each new major build, them reload the back-up file. Worked like a charm :smile:
     
  85. stanikki

    stanikki Guest

    mldonkey

    First at all: Thx Teddy for making Tomato available on such a great router like the Asus RT-N16. Like many other i could finally replace my good old WRT54GL.

    I'm sorry to interrupt your technical chat and i hope it's ok to ask something really different.

    I found a precompiled static binary of good old mldonkey for mipsel (http://mldonkey.sourceforge.net/phpBB2/viewtopic.php?p=27075). I had no problems to install it and get it running on the RT-N16 but the DNS resolution doesn't work. I tried all tips at the forum over there (except the one with "chroot"-environment) but i had no success. The problems are missing and/or different named libraries.

    My question: Is it possible to add some libs into /libs by compiling myself or even better to get write access to this mount and just copying some new libraries in it?

    i'm good in linux but far away from being a professional but i try almost everything if i find/get a proper howto ;).

    Thx,
    stanikki
     
  86. pharma

    pharma Network Guru Member

    Has anyone flashed a Netgear WNR3500v2 (no-USB editions) with this firmware successfully? If so please indicate what steps were taken or if you deviated from the firmware flash guide written for the Asus router.

    Thanks for your help.

    Pharma
     
  87. CHRONOMASTER

    CHRONOMASTER Addicted to LI Member

    I'm having trouble trying to copy a video more than 4GB(4.37GB) from Windows 7 to an usb hdd formatted with ext3 attached to my RT-N16.

    At 4GB mark I receive an "Folder Access Denied" error window. And I receive this error in the syslog.

    -----
    smbd[12438]: reply_write_and_X - large offset (1 << 32) used and we don't support 64 bit offsets.
    -----

    Device: RT-N16
    Firmware: tomato-1.27-NDUSB-9044MIPSR2-beta07-Ext
    USB HDD: WD MyBook 500GB formatted ext3 and inode changed from 256 to 128 for ext2ifs
     
  88. teddy_bear

    teddy_bear Network Guru Member

    MIPS R1 - no USB, no VPN, no JFFS (if compiling for 4MB router):
    make V1=9044 V2=<whatever> NO_JFFS=y s

    Yep, see this post: http://www.linksysinfo.org/forums/showthread.php?p=360284#post360284
    Will be fixed in the next update (fixed in git if you feel adventurous and up to compiling it yourself).
     
  89. orlander

    orlander Guest

    Hi teddy_bear

    First, thank you for your hard work on the Tomato mod for Asus RT-N16.
    Please count me as #5 person for MLPPP feature.
    The reason I ask for MLPPP is to avoid the throttle as well.
    And MLPPP-Single Link is enough to bypass the throttle.
     
  90. CHRONOMASTER

    CHRONOMASTER Addicted to LI Member

    -Split from my orignal post-
    Thanks

    EDIT1: I compiled the firmware with with the help of Post #933 and from the latest git and now it works. Also I got a usb speed boost from 5MB/s to 7MB/s write. :biggrin:

    EDIT2: Darn, The router rebooted three times while running rtorrent without any errors via external syslog then usb crashed with an error log. I will go back to Beta 7 and wait for teddy_bear's release.
    Code:
    Mar 20 06:12:27 RT-N16 user.warn kernel: WARNING: at drivers/usb/host/ehci-mem.c:111 qh_get()
    Mar 20 06:12:27 RT-N16 user.warn kernel: Call Trace:
    Mar 20 06:12:27 RT-N16 user.warn kernel: [<8000de90>] dump_stack+0x8/0x34
    Mar 20 06:12:27 RT-N16 user.warn kernel: [<c007ab44>] ehci_urb_enqueue+0xf58/0xfa0 [ehci_hcd]
    Mar 20 06:12:27 RT-N16 user.warn kernel: [<c008c980>] usb_hcd_submit_urb+0x2c8/0x968 [usbcore]
    Mar 20 06:12:27 RT-N16 user.warn kernel: [<c00c50ac>] usb_stor_msg_common+0xd4/0x1fc [usb_storage]
    Mar 20 06:12:27 RT-N16 user.warn kernel: [<c00c5704>] usb_stor_bulk_transfer_buf+0x60/0xb0 [usb_storage]
    Mar 20 06:12:27 RT-N16 user.warn kernel: [<c00c5aec>] usb_stor_Bulk_transport+0x10c/0x37c [usb_storage]
    Mar 20 06:12:27 RT-N16 user.warn kernel: [<c00c6208>] usb_stor_invoke_transport+0x40/0x408 [usb_storage]
    Mar 20 06:12:27 RT-N16 user.warn kernel: [<c00c6ebc>] usb_stor_control_thread+0x2a4/0x32c [usb_storage]
    Mar 20 06:12:27 RT-N16 user.warn kernel: [<8003e5c4>] kthread+0x58/0x94
     
  91. gregd72002

    gregd72002 Addicted to LI Member

    Also, when having WIRELESS EXTENSIONS enabled in kernel the firmware is not usable:
     
  92. teddy_bear

    teddy_bear Network Guru Member

    Of course. Wireless Extensions are NOT for Broadcom driver - they are for other wireless chips natively supported by the kernel.
     
  93. gregd72002

    gregd72002 Addicted to LI Member

    That's exactly the idea - to plug an wifi dongle to the usb port. The driver for the dongle is fully supported by the kernel and can be easily compiled once Wireless Extensions are on.

    What can we do about them in this firmware?
     
  94. teddy_bear

    teddy_bear Network Guru Member

    To start with you can try to unload the Broadcom wireless driver and related modules - wl, igs, emf, and - if you use the latest version from git with newer 5.10.140.0 driver - ctf.

    It may or may not help. Broadcom patched the kernel all over to make it compatible with their driver, and the code preventing wireless extension to work could be somewhere else, not in the driver itself. But at least the rest is open source - so if you're interested enough, you might be able to find the culprit in the Broadcom kernel patches.
     
  95. humba

    humba Network Guru Member

    @teddy_bear: The latest WRN3500L firmware adds guest networking (multi ssid). Any chance we could see that feature (also available in dd-wrt) in your Tomato build?
     
  96. teddy_bear

    teddy_bear Network Guru Member

    At some point - maybe. Not in the near future though.
    I only have so much time to work on this mod, and unless some other devs join in and start submitting working and tested patches, don't expect any new major features too soon.
     
  97. though

    though Network Guru Member

    just out of curiosity, what is the advantage of having multiple SSID's?
     
  98. humba

    humba Network Guru Member

    There are multiple reasons for it. One being the existence of devices that don't support a decent encryption standard (so no WPA2)... you segment your wireless network, firewall it so that the device(s) on the less secure net can only access whatever services they need while blocking the rest (so e.g. even if somebody cracks your WEP key, they might be able to access the Internet but certainly not the data you have in your network, infect your machines, etc.)

    Another one is to keep untrusted devices in another separate net. E.g. visitors that might bring virus infected machines into your home, or who'd go snooping around your NAS.
     
  99. peyton

    peyton LI Guru Member

  100. Rasky

    Rasky Addicted to LI Member

    I can't help with the kernel (unless I'm given enough support and pointers to get me started), but I can help with pretty much everything in the user-space. Do you have a roadmap / list of tasks that I can help with?
     

Share This Page