1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato ND USB Mod

Discussion in 'Tomato Firmware' started by teddy_bear, Dec 17, 2008.

  1. ghostknife

    ghostknife Addicted to LI Member

    You must have got a bad one mine drifts but not by that much, >30s per day

    Time Updated: Fri, 31 Jul 2009 23:32:26 +0930 [+25.350s]
    Time Updated: Sat, 01 Aug 2009 23:32:22 +0930 [+19.832s]
    Time Updated: Sun, 02 Aug 2009 23:32:17 +0930 [+15.854s]
    Time Updated: Mon, 03 Aug 2009 23:32:23 +0930 [+20.675s]
    Time Updated: Tue, 04 Aug 2009 23:32:29 +0930 [+27.168s]
    Time Updated: Wed, 05 Aug 2009 23:32:32 +0930 [+29.854s]
     
  2. dkoren

    dkoren Addicted to LI Member

    Thanks ray123, that's what I was doing. But I still wonder why the drift is so huge ? Down the thread I have seen there was a fix for this, but apparently it was removed. Up to 60 seconds per hour is fine for me, but I am getting 10 minutes off !

    That's what I am getting:

    Aug 7 00:00:01 tomato syslog.info root: -- MARK --
    Aug 7 00:59:02 tomato user.info ntpc[3802]: Time Updated: Fri, 07 Aug 2009 00:59:02 -0400 [+600.543s]
    Aug 7 01:00:01 tomato syslog.info root: -- MARK --
    Aug 7 01:59:01 tomato user.info ntpc[3826]: Time Updated: Fri, 07 Aug 2009 01:59:01 -0400 [+600.415s]
    Aug 7 02:00:01 tomato syslog.info root: -- MARK --
    Aug 7 02:59:02 tomato user.info ntpc[3850]: Time Updated: Fri, 07 Aug 2009 02:59:02 -0400 [+600.569s]
    Aug 7 03:00:01 tomato syslog.info root: -- MARK --
    Aug 7 03:59:01 tomato user.info ntpc[3874]: Time Updated: Fri, 07 Aug 2009 03:59:01 -0400 [+600.377s]
    Aug 7 04:00:01 tomato syslog.info root: -- MARK --
    Aug 7 04:59:02 tomato user.info ntpc[3902]: Time Updated: Fri, 07 Aug 2009 04:59:02 -0400 [+600.576s]
    Aug 7 05:00:01 tomato syslog.info root: -- MARK --
    Aug 7 05:59:01 tomato user.info ntpc[3926]: Time Updated: Fri, 07 Aug 2009 05:59:01 -0400 [+600.384s]
    Aug 7 06:00:01 tomato syslog.info root: -- MARK --​
     
  3. freddyspam

    freddyspam Addicted to LI Member

    Wow, I'm impressed by how consistent the time adjustments are on your unit. If there was only a way to adjust the number of "router seconds" that count toward real-time seconds, your unit would be dead on.
     
  4. Engineer

    Engineer Network Guru Member

    Curious: Victek's firmware states that my Asus runs at 240MHz but the DD-WRT site states that this unit is limited to 200MHz because of clock problems. Is it possible that the clock still thinks that it's 240MHz while the actual CPU speed is 200MHz.

    240-200 = 40

    40/240 = .1666666666666666....

    3600 * .1666666666666666.... = 600 seconds per hour off.

    Thoughts....?
     
  5. Megaweapon

    Megaweapon Addicted to LI Member

    Does anyone know why dnsmasq is compiled without tftpd support?

    When I installed this firmware I was looking forward to setting up my router to do both the PXE and tftpd parts of network booting (files on a USB flash drive). I was disappointed to find the tftpd feature missing. Is it worth it to try to create my own compile or is the tftpd part of dnsmasq too large and/or breaky?
     
  6. dkoren

    dkoren Addicted to LI Member

    I believe that victek usb mod doesn't have this problem; I have tried my router with it and it worked fine. However it was based on tomato 1.23 and I decided to upgrade to this mod which is based on 1.25 - and only here I get this kind of clock drift.
     
  7. ray123

    ray123 LI Guru Member

    It's only consistent because he only meaured it in one load scenario.

    When my router is idle (no traffic in or out) the drift is 0.5 sec/hr. But when I am running torrents heavily, the drift is quite stable at 2.5 sec/hr. That's a 5-to-1 variation.

    That's equivalent to 138 ppm (high, but not too bad) and 694 ppm (horrible--worse than a poor mechanical wris****ch). The standard advice in the ntpd community for a drift that large is to replace that computer with one that isn't broke. FWIW, the standard kernel cannot correct a clock drift greater than 500 ppm.

    BTW, there *is* a way to tune the kernel timing parameters to offset the clock drift. It's adjtimex. But it's of little use, since the drift is so wildly variable depending on the traffic load. That's why an ntpd-lite is needed.
     
  8. ray123

    ray123 LI Guru Member

    My time results are the same on Tomato-ND-USB v23 as well as V32 which is the latest one. There are no significant changes in the timing code between these two versions. If you are seeing a clock drift of more than a few seconds per hour, something is really really wrong!
     
  9. dkoren

    dkoren Addicted to LI Member

    Interesting. I will try to reflash my router with previous FW version and see what happens.
     
  10. weixing

    weixing Addicted to LI Member

    I only want to use PPTP Server, how can I add the PPTP server to the ND version?
     
  11. kerbdog

    kerbdog Addicted to LI Member

  12. weixing

    weixing Addicted to LI Member

  13. teddy_bear

    teddy_bear Network Guru Member

    weixing,
    The complete source code of the latest build can always be downloaded as a git snapshot in tar format.

    dkoren,
    The info about clock fix for wl-520gu is in the 1st post:
    WayF1nder,
    This mod should work with DIR-320. It will not display the router model properly, but otherwise it should work just fine.

    asterger,
    Although NTFS support is not included into the firmware, there's a separate module for NTFS (with limited write support) that you can store on the router on JFFS (if there's room) or USB partition, and manually load it using insmod command. See this post for some more details, or search this thread for "NTFS".
     
  14. weixing

    weixing Addicted to LI Member


    Teddy, where can I find the source or compiled object for tomato for pptp vpn server?
     
  15. weixing

    weixing Addicted to LI Member

    Teddy,

    DL the repo file already, it's a single big file over 700 megs, how to use that?
     
  16. Megaweapon

    Megaweapon Addicted to LI Member

    In Linux, OS X, BSD, etc.:

    Code:
    tar xvfz tomato-refs-heads-tomato-ND-USBmod.tar.gz
    In Windows you can extract it with WinRAR, WinZip, 7-zip, etc.
     
  17. weixing

    weixing Addicted to LI Member

    which environment is the best to complile the firmware? I need to install one.
     
  18. teddy_bear

    teddy_bear Network Guru Member

    weixing,
    It doesn't really matter, any Linux distribution would do... I'm running Ubuntu, but it all depends on your personal preferences.
     
  19. teddy_bear

    teddy_bear Network Guru Member

    Update - build 34.
    • Added support for QUERY_STRING env variable to httpd.
    • Minor fix for printing support broken in builds 31 and 32 for some printer models.
    • Fixed USB automount not working on startup when WAN mode is set to Static or Disabled.
    • Minor fixes backported from kernel 2.4.37.5.
    • USB driver patched to make hdparm work properly with USB drives.
    • FTP Server vsftpd updated to ver. 2.2.0.
    • Allow multiple MAC addresses per device for static leases (copied over from Tomato VPN mod).
    • Use more precise pattern for L7 FTP match.
    • Added new Web GUI page to execute system shell commands.
    • Added "Bluetooth Coexistence" mode to the Advanced Wireless settings (might be useful with UMA enabled phones).
    • Automatically create empty /etc/fstab file on startup.
    • Busybox updated to ver. 1.14.3.
    • Fixed CSS for Absolon USB themes ("USB Red" and "USB Blue").
    Links to the firmware binaries and the git repository with sources are in the 1st post. The complete source code of this build can also be downloaded as a git snapshot in tar format.

    USB+VPN merged build is also available - based on the SgtPepperKSU' last released VPN mod ver 3.4 and Standard version of the USB mod. USB+VPN build is untested - use at your own risk.
     
  20. ghostknife

    ghostknife Addicted to LI Member

    teddy_bear, thanks for the update and keeping it going.

    Now I have an unrelated question, is there some command I can use via telnet or the gui to disable all or some of the front panel lights?
    Seems weird I know but I recently upgraded from 520gu to 500gpv2 and it is so bright at night now, flashing away as it does it lights up the entire room. I could cover it up but might overheat or something.
     
  21. teddy_bear

    teddy_bear Network Guru Member

    ghostknife,
    Some of the LEDs - but not all of them - can be controlled via the "led" command. Issue the "led" command without parameters, and it should display the list of LEDs that can be turned on and off on your router.
     
  22. borosai

    borosai Addicted to LI Member

    teddy_bear,
    Just another opportunity to thank you for your work and this update. The ability to run shell commands from the web GUI is a nice touch. :)
     
  23. i1135t

    i1135t Network Guru Member

    Thanks Teddy for the hard work, will test it out and see if I run into any issues. Thanks again.
     
  24. ghostknife

    ghostknife Addicted to LI Member

    Assume you mean via telnet, I tried that, I get "not supported".
    This is on v.8632 Ext as I haven't tried new one yet, is it only in 8634?

    root@WL500:/tmp/home/root# led
    Not supported.
     
  25. lancer1991

    lancer1991 Addicted to LI Member

    Tried the latest version in hopes to fix my Dell Photo 720 issues, but no luck. I still can get one document to print, but the document never clears out of the print spooler and shows as Deleting. Anyone with any ideas? I tried to disable bi-directional and that didn't do a thing.

    Thanks.
     
  26. besonen

    besonen LI Guru Member

    what firmware is this mod built upon?

    is this mod built on top of SgtPepperKSU's 'VPN build with Web GUI' firmware? and if not, which firmware is it built upon?


    thanks,
    david
     
  27. teddy_bear

    teddy_bear Network Guru Member

    ghostknife,
    Looks like you're out of luck - Tomato doesn't support controlling LEDs on your router...
    besonen,
    This mod (Std, Ext, Lite and NoCIFS editions) is built on top of vanilla Tomato 1.25. The VPN build includes the Standard edition of this USB mod (see the 1st post for details of what features are included in each edition), and the SgtPepperKSU's 'VPN mod.
    lancer1991,
    As google search reveals, Dell 720 is known to be troublesome with many Linux distros - it usually requires a special driver to work... Since only generic printer driver is included, it most probable will not work properly with the router.
     
  28. ghostknife

    ghostknife Addicted to LI Member

    Blast, the shoe box it is then. Router can't move and my enormous bed can't fit in the dog kennel
     
  29. weixing

    weixing Addicted to LI Member



    Teddy,

    Does the latest build - standard and vpn3.4 FULLY support Asus Wl-500gP v2 (Broadcom 5354 CPU). Pls let me know what will not be supported? Some earlier posted said the LEDs are not functioning.

    Thanks,
     
  30. Megaweapon

    Megaweapon Addicted to LI Member

    teddy_bear: Any chance of the next version having dnsmasq compiled with tftpd feature turned on?

    Thanks
     
  31. jmelan

    jmelan Guest

    I just wanted to post that I was able to install an HP 1022 printer without any special drivers from both Vista and Win 7, following the general directions posted for printer configuration (asus wl-520gu)

    Thanks for the great USB firmware !!!
     
  32. right4you

    right4you Guest

    Teddy,

    I followed linx's guide and tried to install Standard firmware on WL-520GU. Now, when I try to log into the router, it asks the username and password. I tried root/admin and admin/admin combination but they did not work. Looks like it is necessary to telnet to your router and type “nvram get http_passwd†to find out that password. But it is too late now. Is it possible to go back to stock image? Your help is highly appreciated!
     
  33. ghostknife

    ghostknife Addicted to LI Member

    Yay a question I can answer for a change!

    From Tomato FAQ:
    Make sure you're entering the username "admin" or "root". Unlike the Linksys firmware, they are required in Tomato......If nothing else works, push the reset button for a few seconds to reset all of the settings. The default password after resetting is "admin".
    Otherwise use Asus firmware restore utility from CD with the router, you must have used this to get Tomato on there in the first place. You can use it to restore any firmware image you want, including the original.

    EDIT: Maybe if you did not reset the NVRAM default BEFORE you flashed Tomato that the password is still the same as it was before, i.e. what you had in the stock firmware as password, try that?
     
  34. A30N

    A30N Addicted to LI Member


    I just bought a brand new WL-520GU and I am having the same problem. I use the Asus Firmware Restoration Utility to flash the latest build of DD-WRT Mini Generic, which is successful Then, after a hard reset, I log into DD-WRT, change the default username and password (required) and go to the Administration Tab and upgrade to Tomato 1.23 ND USB Mod. After another hard reset, I enter 192.168.1.1, and the prompt says: "The server at DD-WRT is requesting a password". Neither the default DD-WRT username & password, nor my custom username & password, nor the default WL-520GU username and password, or any combination, work. However, if I reflash another Mini or Standard build of DD-WRT, then the custom DD-WRT password I had previously set works just fine.

    I'll use DD-WRT until the issue has been resolved and tested by other users, because so far today I've flashed the router 9 times, and I have no idea what kind of flashrom is used, and how many flash cycles it can handle.
     
  35. ray123

    ray123 LI Guru Member

    DD-WRT encrypts the password. How to handle that when you reflash to Tomato is covered somewhere in the writeups. IIRC, you have to delete the password when you switch from DD-WRT. Try doing a search in this forum, or on the Tomato FAQ.

    BTW, the flash chip information is out there somewhere. I have a specsheet but can't find it right now.
    The chip is good for 300,000+ erase cycles, so you aren't going to have any trouble with that.
     
  36. teddy_bear

    teddy_bear Network Guru Member

    Guys,

    First of all, although the instructions posted by linx are excellent, there's no need for an extra step of installing DD-WRT - you could have just flashed Tomato directly from the stock Asus firmware using Asus Firmware Restoration Utility.

    However, if you have already installed DD-WRT, see these instructions in the official Tomato FAQ to obtain or reset your password.
     
  37. A30N

    A30N Addicted to LI Member

    Thanks for the info, I went back and tried it again....SUCCESS! It turns out that in DD-WRT, on the Firmware Upgrade page, I needed to change the following option:

    After flashing, reset to: "Reset to default settings"

    The default was "Don't reset" and that was probably why the old encrypted password from DD-WRT persisted the flash to Tomato.

    Thanks again for a speedy reply! :biggrin:
     
  38. A30N

    A30N Addicted to LI Member

    For some reason, the Asus Firmware Restoration Utility failed to flash directly with Tomato- I tried that before using the DD-WRT method. However, I used the included Asus CD to install the utility; it might have worked if I had downloaded the updated version from their website.
     
  39. teddy_bear

    teddy_bear Network Guru Member

    Strange... I've heard that from other people as well - they were unable to use Asus utility to flash Tomato directly from the stock firmware. OTOH I used that Asus tool to flash different firmwares, including Tomato (from stock as well as from alternative firmwares), and to unbrick the router a few times, with no problems whatsoever... Well, maybe a couple times it didn't come back up after flashing, but it always worked on the 2nd try.

    Anyway, it's good to know DD-WRT route worked for you, and you have Tomato installed now :).
     
  40. ghostknife

    ghostknife Addicted to LI Member

    I'm certainly no expert but I also had this issue several times and pretty sure I figured out why. I had a lot of trouble when trying to flash several times and the firmware image name was long and located in eg.
    "C:\directory path with long name and spaces" or the desktop.
    This seems to be related also to the different version of the asus tool (or router), the one that came with my 500gp does not have this problem, the one for 520gu does.

    Immediately I moved the file to C:\temp and rename it (eg. firmware.trx) and restart the flash tool it works, even while the router is sitting there in recovery mode waiting

    Or maybe i imagine it, not scientifically tested but worked for me and better than kicking the cat :)
     
  41. ghostknife

    ghostknife Addicted to LI Member

    Not specific to this this mod but does anyone know why it will never let me run e2fsck, I always had this error and have to remove the drive and connect it to another system to run the check which is annoying, runs fine if I check on Mint6/7.
    Also can check another partition on the same drive OK, just not the one with most of the data. It's quite possible i ran the command wrong or did the initial partition in some way it doesn't like, it was done on Mint6 as well
    Thanks if you have any suggestion

    root@WL500:/tmp/home/root# e2fsck /dev/discs/disc0/part1
    e2fsck 1.38 (30-Jun-2005)
    ELEMENTS was not cleanly unmounted, check forced.
    Pass 1: Checking inodes, blocks, and sizes
    Error allocating inode bitmap (6): Communication error on send
    e2fsck:
     
  42. ray123

    ray123 LI Guru Member

    You didn't run it on a partition that is mounted, did you? Because that's a no-no.

    Every time I've tried to run e2fsck on my ASUS 520GU it would roll over and die. I suspect that it's running out of memory and gets into a deadlock. This was without swapping active.
    Soon as it finished with the 8GB torrent I've downloading, I'll do some experimentation. That should be any day now. ;-)
     
  43. ray123

    ray123 LI Guru Member

    USB problems

    Teddy bear, I'm still having some weird USB problems, I wonder if you have any thoughts. Previously I thought it was the old USB1.1 hard drive, but the same things happens with a new USB2 drive, so now I think it's probably the kernel software.

    This failure has been consistent for all the different releases for several months, including V32. Haven't tried V34 yet.

    Here's what happens:
    I'm doing some intensive work in the router that evidently overloads it. Trying to do webcam capture, running a torrent client in the router, while having several telnet sessions into the router, etc. The router locks up and (usually) reboots. FWIW, I have a software watchdog running, so maybe that's what does the reboot. On the USB port I have a 4-port hub, with a USB harddrive and one or two USB sticks.

    Sometimes when it reboots, one of the USB devices won't come up. In the syslog there are messages like "...USB device won't accept new address..." I unplug and replug that device and consistently get the same failure & same messages. The only thing that works is to pull power to the USB device and then re-power it on, and then reboot the router. Sometimes I have to power-cycle the router, too.

    What I'm thinking is that the system is in the middle of a transaction to the USB device when it dies, and that the device is stuck in some intermediate state and therefore won't accept the command(s) that the router issues to it on the hotplug event (boot or plug in). Do you know enought about USB to have any ideas about what might be happening?
     
  44. ghostknife

    ghostknife Addicted to LI Member

    Well I did forget to unmount it once but it warned me anyway and I didn't try till I unmount it so I don't think thats the problem. Don't think it will be a memory issue casue this is on a 500gPv2 and it doesn't download torrents or do anything intensive and usually says it has 20mb free. No torrents running on PC either since I found how to use my ISP news server properly.....whoaaa there, slow down, don't want to max the connection out :)

    FWIW I did Google the error I get and came up with only one complete reference but unfortunately it was in Russian, yeah my skills on that are a bit rusky,lol.
    Drive is a WD Elements 640gb incase it makes some difference.

    Thanks ray.
     
  45. koszpa

    koszpa Addicted to LI Member

    Hi Teddy,

    I have been trying this mod for a while, and I have trouble with my wifi antenna, even though I set everything to a minimal basic configuration (SSID, open network, etc...) I can't connect to the router with any of my clients. Even the wireless survey is not working in the router, and I know there are other wifi networks around here.
    I have an Asus WL-500gP v2. I have this trouble only with this mod of tomato, the original tomato works fine, but it misses the USB and the extra functions.
    I really like this mod, it makes Tomato the best firmware ever, and I would really like to use it, but I can't.
    Is this a known bug for this mod? Is there any solution for this?
    I found out one of the previous "rotten" version, that wifi is working correctly in it, but only in this version: v1.23.8624 a.OND ND USB Ext .
    Is there something special implemented in this version? Can it be ported to the latest modded firmwares please?

    Regards:
    Koszpa
     
  46. ghostknife

    ghostknife Addicted to LI Member

    I also have a 500gPv2, I don't have this problem and never had any wireless issue with this mod so I don't think there is anything wrong with it. Try reset NVRAM, reflash firmware and reset NVRAM again to make sure there is not some setting from other firmware still?

    Tomato ND 1.25 Thor MOD also has USB
    http://www.linksysinfo.org/forums/showthread.php?t=61552

    DD-WRT also has USB, you can test with that one
    http://www.dd-wrt.com/dd-wrtv2/down...2548/dd-wrt.v24-12548_NEWD_std-nokaid_usb.bin
     
  47. ghostknife

    ghostknife Addicted to LI Member

    Here is a screen shot of my wireless settings, i only ever had a problem when I enable WMM, one old wireless B client could not connect until I disable it again.
     

    Attached Files:

  48. koszpa

    koszpa Addicted to LI Member

    I have tried to reflash my WL-500gP v2 with almost every version of this mod when I found that this is the only which makes my wlan work: v1.23.8624 a.OND ND USB Ext . Everytime I cleared my NVRAM, even with the force clear option. I have also tryed Thor's mod, the results are the same: not working wlan.

    Before Tomato I have been using DD-WRT it worked fine with the wifi, but I had my reasons to leave it and to change to Tomato, I like this much better. The original 1.25 works fine, and I was thinking maybe these mods takes some bug in to the mix, but to be honest I am just guessing.

    However it is very strange for me that, this version (v1.23.8624 a.OND ND USB Ext) works fine, but the others not.
     
  49. were55

    were55 Addicted to LI Member

    Web Server

    Hi Everyone,

    I'm really happy with this firmware, previously I was using Oleg modification for my Asus 520gu but this one is more complete, many great features. I followed all instructions to make a webserver (making a /opt partition in external drive in Linux ext3, and installing Optware) but I can only access the "home page" from my Lan, not for Wan...how can I open this for an external access ? I also have access to "web admin" page from external in https, I don't want to lose it.
    Thanks for you help !!
     
  50. ghostknife

    ghostknife Addicted to LI Member

    Thats got to have something wrong with it, nobody else has this problem I know of or have seen here.Still under warranty? Flash back to Asus firmware, test and return it for a new one if it doesn't work.
     
  51. ghostknife

    ghostknife Addicted to LI Member

    Have you Forward ports on your modem/tomato?
    Forward port 80 for webserver and port 8080 for https remote access, make sure you have https (8080) enabled for external admin.
     
  52. were55

    were55 Addicted to LI Member

    Hi Ghostknife, thanks for answer.

    Yes, I tried a port forwarding and I get same result, let explain my configuration:

    "Web Admin"
    - Local Access =http/https
    - HTTP Port = 81
    - HTTPS Port = 8080
    - Remote Access = HTTPS
    Port = 8080

    With this configuration I can Access from LAN y WAN to "web Admin" page.

    In other hand, I'm starting thttpd with next configuration:

    "thttpd.conf"
    dir=/opt/share/www
    port=80
    user=nobody
    nochroot
    nosymlink
    novhost
    logfile=/opt/var/log/thttpd.log
    # Please do not edit pidfile path at it is use to kill thttpd process during ini
    pidfile=/opt/var/run/thttpd.pid

    In /opt/share/www I have a "index.htm" file, then I started the process with:

    /opt/etc/init.d/S80thttpd start

    So far is good, I make a test from LAN and webpage is accessed (http://192.168.1.1).

    So, now I make a port forwading:
    On=On
    Proto=TCP
    Src Address =
    Ext Port = 80
    Int Port = 80
    Int Address = 192.168.1.1

    Then I tried to access from Internet (http://myhome_WAM_ip_address) and nothing is coming...

    What I missing ?

    Regards
     
  53. weixing

    weixing Addicted to LI Member

    I use Restoration Utility to go from oleg to tomato and it bricked the router, need to blow off the flash and rewrite.
     
  54. weixing

    weixing Addicted to LI Member

    Teddy,

    Can you post the scripts to 1) automount the USB drive 2) auto share of the USB drive? I really love these 2 pages but cannot have it with oleg version.

    I got a ntfs-3g compiled for oleg, can you compile a ntfs-3g driver for your mod version also?
     
  55. koszpa

    koszpa Addicted to LI Member

    I have been thinking the same, but if I restore the original ASUS firmwarer and take it back to the shop they will realise that everything is fine, I don't have a reason to complain....

    Meanwhile I have checked the logs of the firmware and one thing I have seen is the modded firmware which works for me contains the original Broadcom Wireless drivers which is in the original 1.25 version of Tomato by default: 4.130.19.0 . So maybe this driver is the reason of my lack of wlan in these mods, but this doesn't explain why the newer driver (4.158.4.0) works for everyone who has Asus WL500-gP v2, but for me not...

    I am thinking about rebuilding Teddy's mod, with the original Broadcom Wireless drivers, could you please help me in that?
     
  56. KyleChen

    KyleChen Addicted to LI Member

    Hey mate who said nobody? and how can you let other return a good router? i've got same problem here and i think most 500gp v2 users are having the same problem. you just dont know it i think.

    Here are two asus wl-500gp v2 routers, got them from different places. tried heaps of roms(tomato, dd, open....) ,including many "only for asus" roms and many usb roms. BUT as Koszpa said, nearly all of them wont work because the router got no wlan signal after flash, no matter how to set them. only roms works on it are: tomatoV1.23.8624 (as koszpa said), and few of DD-wrt version like sp1 stable or 12060M NEWD, and of course the asus official roms. Only these three roms after flashing, the computer can see the signal and ssid name. Other roms, including this teddy_bear super functional one, will just make a 500gp v2 into a non-wireless router.

    It is not the hardware problem (because the official roms and few other roms simply work perfect)
    Not a flashing mistake ( some version will work, some version won't, same flash and clear process, tried hundred times by good hands)

    My opinion is, ppl cooked a rom working on 500gp v1 or other asus routers, simply thought it will work on 500gpv2 (which actually doesn't work) so publish it and saying it support 500gpv2. But not many 500gpv2 users find out it is a common wireless problem, plus most of them just flash the 500gpv2 recommanded dd-wrt stable(this works fine) and some of them even not sure they are using a v1 or v2........ For years many roms are marked "support 500gp v2" but they are totally not.

    Few times i saw some ppl like "Koszpa" was saying :"Hey this rom doesn't work on my 500gpv2~~" after that very soon some one like "Ghostknife" will say "hey that is your individual problem, return your router to the shop~~~~" something like that, same pattern i saw too many times.

    But hey, Koszpa, dont return your router to shop, it is not your router's problem, it is a problem with the rom/driver. Just roll back to your tomato 1.23.8624 or if you insist to use usb, try ddwrt 12060 eko plus a little script job. dont need to try other ddwrt versions most of them wont work. we 500gpv2 users are forgotten already so take it easy...
     
  57. koszpa

    koszpa Addicted to LI Member

    My problem with wlan is not that serious you mention above, I have tried so many firmwares so far and most of them works like charm, even wlan works fine. The original Tomato 1.25 is working also, and so does the most of the DD-WRT versions and X-WRT, Gargoyle, etc...
    I have only troubles Teddybear and/or Thor mods on Tomato, and I believe it's because of the Broadcom Wireless Driver version update, but I don't know the exact reasons. However the v1.23.8624 a.OND ND USB Ext Teddybear version has the original Broadcom Wireless Drivers released in all original Tomato versions, and only this USB modded version is working for me.

    So I am really interested in to build the newest Teddybear version with the original Broadcom Driver to see if it works for me. That would be so great, because I like Tomato really much, but without USB support I would lose a lot of great potential of my router... :(
     
  58. Engineer

    Engineer Network Guru Member

    It would be interesting to see your iptables listing

    (Telnet into router, login / password - root / "login password" and then issue the command

    iptables -L

    )

    I'm thinking that you need to add something to your iptables such as

    Code:
    iptables -I INPUT -p tcp -d `nvram get wan_ipaddr` --dport 80 -j ACCEPT
    
    or

    Code:
    iptables -I FORWARD -p tcp -d `nvram get wan_ipaddr` --dport 80 -j ACCEPT
    
    but I'm new to this stuff and I might be wrong! :p
     
  59. ghostknife

    ghostknife Addicted to LI Member

    Yep Ok then whatever you say must be true then "mate".
    I have 3 WL-500gPv2 and they are all working fine. If people had such a big problem and they tell Teddy about it then he would surely fix it.
    The only way what you say could be true is if there are different hardware revision of the 500gPv2, do you know for sure this is the case?
    Do broadcom/asus make the same model with different chip version?
    Maybe there are I don't know since mine all work fine, can you provide the different hardware specs from the logs then?
     
  60. hapahopi

    hapahopi Addicted to LI Member

    i have a wl-5oogpv2 bought last june. tried with teddy bear's build 32 and currently using thor's latest mod; no wireless problems encountered on both builds.
     
  61. koszpa

    koszpa Addicted to LI Member

    I found these lines in the logs containing revision information:
    CPU revision is: 00029029
    CPU: BCM5354 rev 2 at 240 MHz
    Calibrating delay loop... 237.56 BogoMIPS
     
  62. Mastec

    Mastec Network Guru Member


    I have been playing catchup on all the posts and ran across this statement.

    I, like many others is not have any issues with wlan on my 500gP v2. I started using TB's firmware from the beginning and update as they are released. I have a Buffalo router located in my boys room connected via WDS. And a neighbor is connected wirelessly with a desktop and laptop to my Asus so they can access the internet.
     
  63. ghostknife

    ghostknife Addicted to LI Member

    OK, this is not going to help you because I have the exact same on the one I'm using the most, so it would appear we have the same hardware:
    CPU revision is: 00029029
    CPU: BCM5354 rev 2 at 240 MHz
    Calibrating delay loop... 237.56 BogoMIPS

    AND just for reference i went out and bought another new one, which gets slightly different revision, same first line and different alternates so I am really confused about those numbers (same but different?). However this wireless works as well although it has only been running tomato for last 30 mins, was able to check email on PDA thats only wireless I've connected so far.

    CPU revision is: 00029029
    CPU: BCM5354 rev 3 at 240 MHz
    Calibrating delay loop... 238.38 BogoMIPS

    Can do more (speed, device) test later, so far it ran OK on:
    Gargoyle 1.08
    DD-WRT EKO v24-12548_NEWD_mega
    tomato-1.25-ND-USB-8634-Ext
     
  64. shibby20

    shibby20 Network Guru Member

    why in wds mode i cant select wpa2? wpa2 is supported only in AP mode... this is fault broadcoma or tomato?

    can i use wds with wpa2 on ddwrt?
     
  65. danny_8

    danny_8 Addicted to LI Member

    This is fantastic

    I've owned my WL-520GU for about a year. I've been using DD-WRT or Tomato firmware for most of that time. I also tried Oleg's firmware mods for a while.

    This is fantastic! Everything I've tried works perfectly. Thank you very much!
     
  66. koszpa

    koszpa Addicted to LI Member

    As I can see the logs don't show us any major difference in the hardware, I tried raising the log level to 8 but it did not show any more details about this. So maybe we should find a way to determine what might cause all of this. I also think that my hardware is not faulty, or at least I try to believe in this. So we should find something to debug this drive by commands via ssh or telnet. I know the wl command is responsible for almost anything about the wlan. I am not so familiar with this command, could someone give us a hand with creating something like a test case to see what might cause this trouble?
    Thanks in advance.
     
  67. ghostknife

    ghostknife Addicted to LI Member

    Also I checked my older 520gu which I gave to a friend, it is also CPU revision 3.
    I don't think the hardware revision is the cause of the fault, they all us the same wireless so if one didn't work neither would any of them.

    So, do you have any special configuration set up?
    What options do you have enabled for USB support, maybe this is conflict somehow?
     

    Attached Files:

  68. koszpa

    koszpa Addicted to LI Member

    I have set the following options to USB which are visible on the screenshot, but I don't think if there is any configuration problem with this, because in the very moment after I upgrade the TeddyBear or Thor moded Tomato firmware with the system default / nvram erased state the wlan is not reachable however from the router side it seems working, but it's not.
     

    Attached Files:

    • USB.jpg
      USB.jpg
      File size:
      17.9 KB
      Views:
      46
  69. tomato-rocks

    tomato-rocks Addicted to LI Member

    Large file transfer

    Hi,

    I've been a fan of DD-wrt on linksys router and recently I bought wl520gu to replace one of my linksys routers, which was bricked during firmware upgrade. And I loaded teddy's build 34 standard to my 520gu, formated 120GB usb portable hard drive with ext3 and connected to 520gu without ac adapter. So now I have problem copying large file over to portable drive, it breaks internet connection. I have to reboot the router to get WAN connection back. It is ok to copy up to 5MB file but when I copy 50MB file, it says "Network path no longer exist". Should I use ac adapter for my usb hard drive?
     
  70. KyleChen

    KyleChen Addicted to LI Member

    Well, seems do have some ppl run the mod on 500gpv2 without problems.
    But my routers have the exactly same problems with these roms like yours.
    From the router side everything looks just fine, but from computer just can't see the wlan. Feels like sth screw the antenna.
    the chips are both rev2 as yours.

    and after read all post above, i start to believe the 500gpv2 have different hardware.

    is there any tips for using the source files? i am thinking build a mod with latest function but older drivers. where should i start with?
     
  71. baker99

    baker99 Addicted to LI Member

    Hi Teddy, love the mod, sorry if this has been asked already but does your build include SD card support? I'm thinking of adding an SD card to my Buffalo, but there isn't much point if your mod doesn't support it ;)
     
  72. KyleChen

    KyleChen Addicted to LI Member

    i find out some more info:

    the OND rom was built on 11th april, and teddy wrote that day:

    I definitely don't want to go back to the original driver, since for may the newer driver improved the stability of wireless connection. However, I made another build - v24a-OND ("older" or "original" "new" driver) - tomato-1.23-ND-USB-v24a-OND-Ext.rar. It contains the original Tomato WL driver, and is available for download from the links in the 1st post. If you experience wireless speed drop with USB mod, and if you try that build - please report the results here. Although less probable, it's still possible that the speed issue is caused by some other changes in USB mod, and not by the WL driver itself...

    So i think the wl500gpv2 in my hand hates the new drivers, the original tomato driver (at least in version 1.23) can make it work.

    I just start to learn the UnpackTomato things, help i can make out a rom with old driver soon.
     
  73. weixing

    weixing Addicted to LI Member

    I need the file libpthread.so.0 for installation of the twonkymedia, can anyone compile a version for me for either 8632 or 8634 built?

    mant thanks!
     
  74. ghostknife

    ghostknife Addicted to LI Member

    I think the hardware is so close to same it makes no difference, these WL driver work on many different versions of hardware. DD-WRT EKO NEWD has wireless driver from Linksys WRT610, that works on mine. There is some other basic problem going wrong.
    But out of interest, telnet and run command "nvram get wl0_corerev" what number does it report, I get 13. Expect it will be the same, but check anyway

    It would be interesting to know what version WL driver is included with the (latest) Asus default firmwares, I google and search and I can't find any information. I tried to download the source code to look, bit it keeps failing half way through (very annoying)
     
  75. koszpa

    koszpa Addicted to LI Member

    I am also pretty sure that the new Broadcom Driver is the cause all of the trouble we have with WL500gPv2, the original driver provided by the original Tomatos work fine, just like 1.23 OND.
    Please keep us posted about the newest results you have building Teddy's mods with the original old driver, I am interested in that too! Thanks
     
  76. ghostknife

    ghostknife Addicted to LI Member

    Here is Oleg guide to build custom firmware, you can adapt that for your purpose
    http://code.google.com/p/wl500g/wiki/CompilingCustomFirmware
     
  77. TexasFlood

    TexasFlood Network Guru Member

    Thought I saw this discussed previously, so searched and found this thread. In summary, tape it up, :)
     
  78. weixing

    weixing Addicted to LI Member

    no one can help?
     
  79. baker99

    baker99 Addicted to LI Member

    OK I have read a bit more and it seems there is no SD support in this mod, is there any way I can add it using the firmware mod kit? I know DD-WRT is supposed to support Buffalo routers with an SD card, can I merge stuff from that? I'm also a total linux n00b so could someone tell me exactly how to do this if it is possible, I have downloaded VMWare player and the ubuntu iso ready.
     
  80. danny_8

    danny_8 Addicted to LI Member

    Unable to mount 4GB USB stick

    Yesterday I used my old 128MB USB stick as a network share with my ASUS WL-520GU router running the advanced Tomato firmware. I got excited about having a larger shared folder. Today I purchased a 4GB memory stick. I am unable to mount the drive.

    The volume is formatted with FAT32. Upon clicking the mount button I receive a message "Failed to mount. Verify the device is plugged in and try again." I've looked at the log file, but I'm unsure what to look for.

    I'm using the version: Tomato Firmware v1.25.8634 ND USB Ext

    I was thinking I might be trying to use too large of a memory stick, or perhaps I should use a smaller Tomato version in order to allow more free RAM in the router.

    ———————

    Update: I attempted to partition my USB memory stick, but I was unable to. I tried reformatting the stick using variants of FAT/FAT32/NTFS and trying various allocation sizes, but nothing came of that.

    Using setup information in a file USB_LocalDisk and instructions from this page I updated my Windows driver for the new pen drive, making it appear as a fixed HD. I then used diskmgmt.msc and partitioned the drive into a 1 GB slice and a 3 GB slice. Now both of these mount automatically under Tomato. I went back and deleted the two slices and formatted the whole drive as a four GB primary partition. The single large volume also mounts under Tomato.

    I was aiming to solve my problem by partitioning, but simply making the pen drive appear as a fixed drive seems to have corrected the problem.

    If I were totally Linux-oriented I would probably use the tools to make the stick into an EXT2 or EXT3 partition.
     
  81. ghostknife

    ghostknife Addicted to LI Member

  82. thor2002ro

    thor2002ro Addicted to LI Member

    theres no sd support in my usb mod .... but the non usb version does have sd support(1.25.8515 .7 v6)
     
  83. teddy_bear

    teddy_bear Network Guru Member

    Sorry for a long silence guys... Unfortunately I didn't have much time lately to help out or even read the forum.

    No, I am definitely not a device driver developer, so I can only guess here like you do. What you say sounds reasonable, but the same thing never happened to me. I don't think I overload my router much though - it never rebooted by itself either. Sometimes it kills some processes and restarts them, but that's about it. I'll try to read more on USB internals - but the research probably will require more time than I have ((...

    Yep, it looks like that, and you, koszpa and a few others are probably unlucky ones who got the "wrong" hardware. Could you check the wireless chip version in your logs (not the CPU version), and compare it to others who have it working? You need to look for line that look like:
    Code:
    Dec 31 19:00:12 router user.warn kernel: eth1: Broadcom BCM4318 802.11 Wireless Controller 4.158.4.0
    - the BCM4318 is the WL chip model. I've heard that Broadcom stopped supporting 4312/4318 chips in the driver version 4.174.X.X and newer - so who knows, maybe 4.158.4.0 also doesn't support some of the older chips. All recent Asus official firmware releases for G routers have WL driver 4.150.10.29, and the version I'm using now came from one of the Linksys N routers (wgr610n IIRC) - it's possible that the only improvements in 4.158.X.X driver are for N routers. Maybe what I'll do is I'll release my next build with 4.150.10.29, and we'll see then if it solves your issues, and if it works any worse than 4.158.4.0 for someone else.

    The compiled libpthread-0.9.19.so and libpthread.a can be downloaded from Tomato GIT from this folder.
     
  84. ghostknife

    ghostknife Addicted to LI Member

    Ah yes, right you are, my bad. I didn't look at it close enough, I read it briefly and assumed it did. I am an ass then :)
     
  85. weixing

    weixing Addicted to LI Member

    Thanks, teddy for the dl location, I've downloaded the file, I've uploaded the file to jffs and try "ln -sf /jffs/libpthread.so.0 /lib/libpthread.so.0", the system report that "Read-only file system", I think it's becoz it's in the firmware not writable section, how can I get around this if this file is not included in the orginal firmware?

    Help is highly appreciated!
     
  86. thor2002ro

    thor2002ro Addicted to LI Member

    put it in /opt/lib
     
  87. ray123

    ray123 LI Guru Member

    Yes, put it in /opt/lib. Except that you can't because /opt is in the rom and is read-only just like /lib. :frown:

    What you have to do is what I had to do to get ipkg & torrent client working.

    Put it in some directory somewhere and remount that directory. Example:
    Put it in /jffs/whatever/lib and execute "mount -o bind /jffs/whatever /opt"
     
  88. ray123

    ray123 LI Guru Member

    Teddy Bear:
    It seems that the USB "not accepting address" is a ubiquitous problem in all Linux'es, even the latest 2.6 kernels on PCs. Everybody just has to live with it; nobody seems to know what the problem is or how to fix it. sigh....

    ============
    I've been playing with getting more utilities running on Tomato, primarily a torrent client. I have a few small enhancements to make this easier. Will submit them soon, after I get another problem resolved. Which is:

    ============
    [Tomato ND USB version 34]
    I have 3 drives connected via a 4-port hub. A USB2 160GB external hard drive (ext3), and a 64MB USB1.1 flash stick (fat32), and a USB1.1 48MB CF card (ext2) in a CF-to-USB adapter.
    When I copy a large directory (500+ files & sub-directories) from the HD to the CF ("cp -a /mnt/ext_160/opt /mnt/CF48") the router almost always locks up before the copy is finished. Not every time, just most times.
    When it boots up the next time, the ext3 disk undergoes a journal recovery when it gets mounted. All fine. But after much puzzlement and investigation, I discovered that the mount takes 5+ minutes (!!!!) because that's how long the journal recovery was taking. BTW, a normal mount after a clean unmount on the ext3 is taking about 4-5 seconds.

    Now, the problem. I see that there is now an alarm timeout of 8 seconds in the usb_lock function, which gets called to serialize the hotplug add function when there are multiple USB drives. What was your intention here?

    Because there are problems in this code. There is no SIGALRM handler, so if the lock isn't acquired in 8 seconds the process gets killed. This is why all the drives that are after my ext3 drive weren't getting mounted at reboot after a crash. When the ext3 drive finally competes the mount (5 minutes later) and releases the lock, the hotplug-mount processes for the othere drives are long gone, so they don't get mounted.

    I tried putting in an alarm handler and have it force the lock to return with EINTR and then proceed even without the lock. But that generally doesn't work. It generally fails just as if there was no lock, and the router will seize up later on in the hotplug process. I even extended the timeout to 30 seconds, but that doesn;t reliably work, either.

    The only thing that I could get to reliably work was to remove the timeout and just let the lock take however long it takes. Which means that if the ext3 drives takes 5 minutes to get mounted (due to the journal recovery taking 5 minutes), the later drives will wait that long, too. This is an annoying situation, but I can't find any way around it. It is a fact that the ext3 mount has to do journal recovery during its mount, and therefore it will take 5 minutes--or whatever--for it to mount. So I don't see any significant downside to having the later drives delay their mounting. In fact, now that I think of it, there really is no parallelism that can take place when mounting or accessing more than one USB drive. The USB interface is the bottleneck. If the 3 drives take, respectively, 600 seconds, 10 seconds and 2 seconds to mount, then it will take 612 seconds to get all 3 mounted. Depending on the ordering, the last one may get mounted 2 seconds, 12 seconds, or 612 seconds after startup. But the last mount won't finish until 612 seconds after startup.
    And you can more-or-less control the ordering by changing the ports that the drives are plugged in to.

    So, what do you think? What was the purpose for alarm timeout? As it works now, the later drives will not mount at all, since their hotplug process aborts after the timeout. I figure it's better for them to eventually mount--even if it takes 5+ minutes. For sure the ext3 drive that's the one taking 5 minutes will, er, take 5 minutes.
    Putting a timeout on the lock doesn't really work----there is still something somewhere in the kernel that locks up if 2 drives are being mounted at the same time.

    I've been doing more experimentation with moving the lock around and unlocking/relocking at various places in the hotplug code. So far, no joy.

    ====================
    Taking out the lock timeout is pretty trivial. I'll include that in the other small patches I have and shoot it to you.

    Regards,
    ray
     
  89. weixing

    weixing Addicted to LI Member

    /opt/lib is read-only also. Tried "mount -o bind /jffs/lib /opt/lib". Twonky still reports libpthread.so not found! What else can I do?
     
  90. ray123

    ray123 LI Guru Member

    Oh, bye the way, USB 1.1 is really slow. I have a 8GB torrent that I was downloading. When the the router crashed and the torrent client has to do a recheck, it takes over 5 hours on the USB 1.1 hard drive, but only about 1 hour on the USB 2.0 hard drive.
     
  91. ray123

    ray123 LI Guru Member

    You didn't do what I said. It has to be done exactly right.
    If your lib directory is /jffs/lib, then you need to do "mount -o bind /jffs /opt "

    After you do this correctly, then "ll /opt" will show the exact same things as "ll /jffs".

    Preferably, what you should do is have a directory /jffs/opt and then lib, bin, etc. directories under that. So you'd do ""mount -o bind /jffs/opt /opt". That's what I have, except that I have /mnt/ext_160/opt instead of /jffs/opt. (/mnt/ext_160 is my USB hard drive).
     
  92. koszpa

    koszpa Addicted to LI Member

    I have checked the wireless hardware, and found the BCM4318 which you suspect to have no more support in the newest drivers.

    Code:
    Jan  1 01:00:08 router user.warn kernel: eth1: Broadcom BCM4318 802.11 Wireless Controller 4.130.19.0
     
  93. baker99

    baker99 Addicted to LI Member

    The main reason I didn't swap is I just got used to Teddy's mod, plus it says to erase nvram, I really didn't want to have to re-enter all my settings, it does look like it has most of what I want though.
     
  94. TexasFlood

    TexasFlood Network Guru Member

    FYI, I just bought a WL-500gP v2 and everything seems to be working fine.
    For comparison to those having issues, my logs show:
    Code:
    CPU revision is: 00029029
    CPU: BCM5354 rev 2 at 240 MHz
    Calibrating delay loop... 237.56 BogoMIPS
    eth1: Broadcom BCM4318 802.11 Wireless Controller 4.158.4.0
     
  95. ghostknife

    ghostknife Addicted to LI Member

    Mine shows exactly the same and as we know is working
    WL500 eth0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller 4.158.4.0
    WL500 eth1: Broadcom BCM4318 802.11 Wireless Controller 4.158.4.0

    I wrote a big post yesterday of the various wireless driver being used in here and in DD-WRT versions, then i went to submit, page crashed and I lost it all. Had already closed all the pages and links I had referenced...!!!

    Not going to redo everything I had from yesterday but main point was that even the *newest* DD-WRT with updated WL is not even close to 4.158 and they are having issue with some hardware, but only when the same chips are in different box. Eg. BCM5354 / BCM4318 in slightly different linksys router model do not work the same, some wireless work, some wireless fail, some router brick.

    Without knowing all these devices it appears there is some other piece of hardware/circuit difference between them so maybe we have the same problem. Some slight difference in the board design, different RAM/Flash or other electronic part is also affecting the WL driver function as it appears all the CPU and WL chip are the same.

    Wireless discussion in this thread
    http://www.dd-wrt.com/phpBB2/viewtopic.php?t=54711&postdays=0&postorder=asc&start=0

    You could try this DD-WRT for test, think it is using 4.150.66.6 although I have not loaded it.
    http://www.dd-wrt.com/dd-wrtv2/down...n12548/dd-wrt.v24-12548_NEWD-2_std-nokaid.bin
     
  96. teddy_bear

    teddy_bear Network Guru Member

    Thanks for pointing this out! I added this timeout while troubleshooting some issue... Don't even remeber what it was exactly - but I believe the issue has been resolved later by other means, and I simply forgot to remove the timeout which never worked as intended anyway. You're right, it's trivial to get rid of it - done already -).
     
  97. ray123

    ray123 LI Guru Member

    For anybody who wants to try the older wireless drivers, I have created a tarball with 3 different versions (current and two old ones). Instructions are included.
    It's not a full TRX, and you don't have to re-flash the firmware. It's just the driver module that you would install on your current running firmware.

    Download it at:
    http://www.mediafire.com/file/awjnerojzky/old_wireless_drivers.tgz

    Let us know if you had any useful results with these older drivers.
     
  98. teddy_bear

    teddy_bear Network Guru Member

  99. mitek76

    mitek76 Addicted to LI Member

    Samba issue with some binary files

    I have issue with uploading t1.zip (this is not real zip file) to samba server (when using total commander "disk full" message appears, when using explorer - "the network name is no longer available").
    Could someone check if uploading this file to his samba cause the same issue?
     

    Attached Files:

    • t1.zip
      File size:
      4 KB
      Views:
      16
  100. shibby20

    shibby20 Network Guru Member

    what i cant use WPA2 with WDS on tomato? on ddwrt i can....
     

Share This Page