1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato problems. Loss of port 80 traffic?? Enter if you want a challenge!

Discussion in 'Tomato Firmware' started by terintamel, May 6, 2009.

  1. terintamel

    terintamel Addicted to LI Member

    UPDATE: Tomato problems. Loss of port 80 traffic?? Enter if you want a challenge!

    I am running a 4 router (WRT54GL 1.1) WDS system w/Tomato Vicktek 1.23.8025 on each router. The main AP is at one house while I have a WDS node at my location. My Wii, PS3, and PCs are connected wirelessly to the router in my house. My issue it that while I am browsing the web at random times webpages will not respond or downloads in progress will stop. I will click on a weblink or enter an url and the browser will just sit there like it is trying to connect.

    While this is going on I can ping any website and all the routers on my subnet. I can send and receive email. I can telnet to each router, but I can only access the web interface of the router I am directly connected to. Sometimes if I wait long enough it will finally work again, but usually I have to either disconnect/reconnect to the network(does not always work) or reboot the router(always works).

    At first I believed it was my pc's issue, so I updated the wireless drivers on my nic, but still no joy. It has also happened to my PS3 a few times and once to my wii. No one else (each connected by ethernet to separate routers) on the network is having this issue. If I uplug my router my pc can pick up the signal from another WDS node, while connected to this node I have no issue. (UPDATE: Upon futher testing this does happen when connected to that node)

    I checked and rechecked the settings on each router and besides the main AP all the nodes have the same settings. I was using Upnp for my PS3 and thought that may be the issue so I have disabled that service and it still happens.

    Each device on the network is assigned a static DHCP for the IP/Mac bandwidth settings, and I am using QOS w/TCP vegas. I have disabled that and still have the issue. I have flashed and reflashed and cleared NVRam and still have the issue. I have even replaced the router and still have the issue. I have removed myself from the static DHCP list and pulled a new IP and still have problems. There is no IP conflict with another device on my network to my knowledge.

    I do not believe I am doing anything odd on my routers. I left everything at defaults for 1.23.8025 except the settings necessary for WDS (from polarclouds FAQ) and the router password and wireless power level. I also am using WPA Personal AES wireless encryption.

    Side note this happens on 2 pcs and also in my Vista and Xp partitions, so I do not believe it is a pc issue, but I could be wrong.

    I am at my wits end because this has been progessively getting worse and I cannot find any issues with my configuration or pc.

    UPDATE #1:
    Do not know if this helps, but both pcs have RaLink wireless cards.

    UPDATE #2:
    Upon futher testing this does not seem to happen when connected via Ethernet to router but only when connecting wirelessly.
  2. terintamel

    terintamel Addicted to LI Member

    It seems this only happens when I am connected wirelessly to one of the nodes. This does not happen when connected via ethernet cable. All the other houses are connected physically to their nodes, while I have all my devices connected wirelessly to my node.
  3. mikester

    mikester Network Guru Member

    it's your pc - disable any pc firewall, check for viruses/trojans,...
  4. terintamel

    terintamel Addicted to LI Member

    Already deep scanned my Vista and Xp partitions with Malwarebytes Anti-malware and Avira Antivir. Both came back negative.

    This does not happen when I am connected via Ethernet to WDS Client node. This only happens when connected wirelessly to any WDS Client node. This happens on my main PC and an old recently reformatted and installed XP machine with very little installed on it.

    On a further note, when I setup this WDS network I had one house connected to the Host WDS node with a wireless card(Ralink chip) and they similar issues. I thought they just did not have a strong enought wireless link, so I had them buy a WRT54GL that i then setup as a Wireless Client. They had this issue. I troubleshot it and could not come up with a solution, so I just setup the router as an AP+WDS client node (w/them connected via ethernet) and they have not had a problem since.

    I am going to setup a my router as a Wireless Client and see if I have the same issues. If I do not have the issue then it could be the RAlink chips on my wireless nics. I am also borrowing a friends laptop so I can test w/a wireless card by a different manufacturer. If the laptop has no issues then it is definitely my wireless nics. If I do then there is something wrong w/tomato or some setting I have wrong causing the issue.

    If any one has any other suggestions on how to troubleshoot this issue please let me know.
  5. Toastman

    Toastman Super Moderator Staff Member Member

    terintamel, you've no doubt noticed that some very strange things happen that eventually turn out to be due to the wirless adapter/card in the client. I've seen weird issues with RALINK cards in the past, and several others too. I have many problems with client's D-Link DWA110 USB adapters (Ralink RT73). See this thread, where you can see that some problems seem to be due to USB port differences and sometimes the USB adaper's "cradle" or "base".


    Sometimes the problem is due to windows Wireless Zero Configuration utility, sometimes due to the card driver. Sometimes the problem goes away if you use WEP. Sometimes the problem is intermittent, and a reboot of the client works for a short time. However, often the only cure is a different wireless card, which is a bit of a problem if the offending client is a laptop !

    Without me looking back to see if 8025 had the mod - do you have "Regulatory mode" set to "off" ? This cures a lot of problems.

    You might find some useful pointers in this thread - I'm trying to keep it updated with connection issues.

  6. terintamel

    terintamel Addicted to LI Member

    Toastman thanks for the info, but if the problem is the Ralink cards why did I have the issue when I had a WRT54GL setup as a wireless client(going to retest this when I get off work today)? Is it because I am not using the ND version of tomato? My corerev is 9. Also I did flash just my WDS client node to Vickteks latest ND version and has the issue. Do I need to update all the WDS nodes to the ND version?

    What wireless cards would you recommend?
  7. Toastman

    Toastman Super Moderator Staff Member Member

    That was quick ! Well, unfortunately I don't have any reliable solutions for you. The wifi technology is a bit of a mess, and some things are a complete mystery. The NON-ND driver versions were usually quite good, but some cards, notably Intel 2200B/G and later Intel cards, would cause the router to reboot, we don't actually know why. We do know the ND drivers stopped this happening but then some cards couldn't associate. What actually goes on in the driver we do not know, because the source code has not been released. Now we have solved the problem of non - association with most cards but just a few problems remain.

    I'd also go back to basics. See if you get the problem with that client on a straightforward router/AP setup with no WDS and no encryption (fetch the router across from the other house and try it). After that try encryption, start with WEP. See if it works. Then add the WDS and repeat the experiment with no encryption to the house. Then add WEP, and so on. In the early days I used WDS but found it was slow and troublesome, with similar problems to what you are having. WEP always seems 100% rock solid, but newer encryption schemes have given me problems. Luckily for me, I can use cable, but you don't have the luxury.

    It's always worth a shot changing to ND driver, which you've done? You might find that WDS works better with all routers using the same firmware. You would need to set regulatory mode to off (if it's not already done in Advanced/Wireless). Perhaps a search of the forum for WDS connectivity problems might give some help.

    Failing that, it's also worth trying another adapter in your client, though if you are having the same trouble already with 2 different clients with different wireless, that reduces the chances of success. One USB adapter that has never given any trouble here is the SMC SMCWUSB-G which is pretty cheap.

    Can't think of anything else, you've already done most of the obvious things !

    Keep us posted with any news!
  8. terintamel

    terintamel Addicted to LI Member

    Unfortunately, I cannot test in a pure router/ap mode. I live in the country and could not get internet at my house. I setup a 4 house WDS system that shares the internet connection from house 1(not my house) to the other 3 houses (mine is one of the 3). I have to use WDS otherwise I have no need for the router. I have tried WEP encryption and that did not help.

    The WDS does not seem to be broken in the fact that the Client Nodes all communicate fine, and pc's or routers connected via ethernet to the Client Nodes operate fine. Maybe the issue is with wireless client communication to a WDS Node operating in AP+WDS mode. If so it seems my only solution is to use a double router setup. One router as the WDS client node (a backhaul) and another router (connected via ethernet to the WDS client node) to act as my AP for my wireless devices in my house. The farthest house in my WDS system has this setup(they needed a directional antenna to connect to the host WDS node), and they have had no issues.

    I would still like to rectify this problem without the need for a second router, but I will just have to do whatever works.

    Thanks for the help. I guess this is the price you pay for using custom firmware in non standard ways.
  9. Toastman

    Toastman Super Moderator Staff Member Member

    Understood. Don't give up. What happens if you use someone's laptop in your house, does it suffer the same fate? If you can get any machine to work it would point to those wireless cards. If none work, it points to something on the WDS system not allowing access. It's such a long time since I used WDS I can't remember much about it, but there are people on here using WDS without trouble - perhaps someone will come forward with a clue.

    Seems like every week or two there is a post like this one, that's what makes me think it may be WDS http://www.linksysinfo.org/forums/showpost.php?p=345241&postcount=1

    Do read though the connection thread http://www.linksysinfo.org/forums/showthread.php?t=60509 for pointers if you haven't already. Particularly the bits about the RALINK USB problems, near the end of the thread.

    In the meantime, if one starts with the assumption that WDS is not working correctly, then you might start from scratch and rebuild it, flashing new firmware, erasing NVRAM , reconfigure from scratch, start with no encryption even, see if that works. etc. (but perhaps you've already done this all and got nowhere). When you get home try search the forums for WDS problems and info, then do the same on google and trawl through the DD-WRT and OPN WRT forums. You may not find anything but it's worth a shot. Then you fall back on the desperate measures (the priest, etc).
  10. terintamel

    terintamel Addicted to LI Member

    Planning on using my friends laptop to test and see if it is those Ralink cards. Beyond that I might try the start from scratch on all method, though it will be a hassle I would love to avoid.
  11. mikester

    mikester Network Guru Member

    Likely a vista problem - try resolving on an xp box before trying to fix the vista issues

    If you have no problems using a wired connection then it's most likely to do with your wireless software.

    These wouldn't be Acer laptops would they?

    Ditch the Acer and windows wireless zero config and use the hardware vendor software i.e. use Intel wireless software. Windows wireless zero config is a dog at best and will give you never ending grief.
  12. terintamel

    terintamel Addicted to LI Member

    My main pc is a dual boot Vista and Xp. Happens just as frequently in both OS's on the same machine.
  13. Toastman

    Toastman Super Moderator Staff Member Member

    mikester - a few guys with Acer laptops here found that ND driver and router "Regulatory mode" set to "off" fixed their problems. (Ignore if you've tried it already)
  14. terintamel

    terintamel Addicted to LI Member

    Is there a problem will all Acer laptops and Tomato non-ND version? Because I just bought my wife an Acer laptop and want to know if I will have problems if I do not upgrade all the routers to an ND version firmware.
  15. sardaukar

    sardaukar Addicted to LI Member

    I have an Acer Aspire 6930G with an Intel 5100 wireless NIC and have _zero_ issues with Tomato 1.23 (non-ND) and Vista's default wireless management software.
  16. Toastman

    Toastman Super Moderator Staff Member Member

    terintamel, not all Acer laptops have a problem. Even the same laptops sometimes connect and sometimes don't. The same thing happened with the old Intel 2200B/G. Not everyone had a problem! As you can see, sardaukar has no problems with his Intel 5100 card, yet many other people do, some on this forum, many others post asking for help on the web forums. Statistically, people with problems are probably a minority, but we don't know for sure.
  17. terintamel

    terintamel Addicted to LI Member

    Well back to my original issue.

    After work I went to the main Host WDS node (house 1) and cleared nvram, flashed with 1.23.8025, cleared nvram again, setup everything from scratch. I then went home to test on my pc. It took a little while but the same problem occurred. So I found new drivers for my wireless nic (ralink rt61) and installed them this time using the ralink wireless config software. Still not working right.

    I am currently using a second WRT54GL(from work) w/Tomato in Client mode (basically as a big NIC) connected to the client WDS node in my house. So far I have not had any issues, in fact internet speeds have improved slightly on my pc.

    If this continues to work (I'll give it a few days), my options are to flash all my routers with an ND version of Tomato and see if that solves the issue, get another wireless nic (any recommendations), or get another WRT54GL and use it in client mode. Which do you think would be the better choice?
  18. Toastman

    Toastman Super Moderator Staff Member Member

    Given what you've done already I would be tempted to use what you have found to work! But maybe someone else with more experience will come to offer some insight as to why the original setup is giving you a problem.

  19. baldrickturnip

    baldrickturnip LI Guru Member

    when the problem occurs can you go into the advanced conntrack filter page - count current - I am wondering if you have too many idle connections
  20. terintamel

    terintamel Addicted to LI Member

    I have checked conntrack on the client WDS node I connect to, which happens to be the only thing I can connect to in my webbrowser when I am having problems, and I only have between 15 to 40 at most connections when I have the issues.
  21. terintamel

    terintamel Addicted to LI Member

    True, I am tired of trying to fix the issue, and am tempted to stay with this 2nd router setup. However, this is added expense as well as another point of failure if I start to have internet issues(wired NIC to router to WDS node). I would like to try another wireless nic, but I am afraid to spend money on another card just to possibly have the same issue. To top it off most of the cards I find online seem to be ralink chipsets. Does anyone know of a good, low cost (cheaper than WRT54GL) nic that is not a ralink chipset?
  22. Toastman

    Toastman Super Moderator Staff Member Member

    The SMC USB adapter that I mentioned doesn't use RALINK. I seem to remember it was Atheros. Nobody has had any trouble with it so far. In Thailand these USB adapters are quite cheap, and always quite useful to have around. The great thing about USB adapters is that you can put them in a good spot to get the best signal.
  23. terintamel

    terintamel Addicted to LI Member

    Thanks, I'll look into that one.
  24. mikester

    mikester Network Guru Member

    I've had a LOT of trouble from Acer laptops and Windows Wireless Zero Config in general and not just with Tomato.

    My recommendation is to get rid of all the automatic stuff (i.e. make sure that the wireless isn't set to power conservation mode, make sure the laptop power settings are set to "full power" etc.), under computer management DISABLE the "Wireless Zero Config Service" (this one is always installed whether you have wireless or not) and use only the wireless hardware vendor software i.e. I use the "Intel Proset Wireless" utility on my Acer laptop.

    In fact I created a partition on my Acer and dual boot into a brand new OEM install of XP and only install the drivers and utilities I want and need. This laptop works 100x better than the Acer XP version, doesn't have weird wireless and software problems, and is now way faster.

    If you have Vista then you mind as well re-format the hard drive right now unless you have 32GB RAM and quad core cpu. A what the heck reformat it anyways and install XP.
  25. sardaukar

    sardaukar Addicted to LI Member

    I use Vista Ultimate x64 SP1 on an Acer and have *zero* problems, connectivity- and speed- (with Aero on) wise. With Vista's default wireless config tools.I was actually disappointed, since I hated Vista by proxy with all the the beta reports on Slashdot and so on :smile:. It's actually snappier than XP (and Acer has no x64 drivers for some of the hardware) on my laptop.

    Point is - if your hardware is "Vista-ready" (quality drivers and so on), you should have no problems with Vista and I myself recommend it over XP. To prove my point, to this day there are NO IE exploits for Vista SP1 due to Vista's ASLR not having been hacked around yet.

    Of course, some people just hate Vista by default now :cool:
  26. terintamel

    terintamel Addicted to LI Member

    I have tested this setup further, It has happened again, but not as often. It even has happened a few times on my wife new laptop w/Atheros wifi chipset. It seems to me that Tomato WDS nodes (haven't tried it in plain router mode) do not like wireless communications from wireless devices that are not other nodes. It only works 100% from client WDS node to host WDS node (when devices are hooked up via ethernet).
  27. terintamel

    terintamel Addicted to LI Member

    I am still trying to track down the problem, but I have not been able to narrow it down. I will restate the issue again for clarity. I (Ralink card or Tomato in client mode)and my wife's laptop (Atheros) are connected wirelessly to a Tomato (WRT54GL) router in AP+WDS mode relaying to another WRT54GL acting in AP+WDS mode (this hosts the internet 2 houses down). With some regularity http traffic past the WDS node I wirelessly connect to will seem to just stop. I can logon to the web interface of my WDS node, but not any other node (including host node) on my small network. If anyone is physically connected to a WDS node with ethernet the issue never happens.

    Upon further investigating, it now seems (I maybe wrong) that http traffic past my client WDS node is not stopped, but is drastically slowed down. I am talking like 1-5kbs. (It also seems the heavier the bandwidth usage the faster I can duplicate the error) That is why I can still get the logon prompt for the host WDS node and do not get a "page cannot be displayed error" the page (or any new page) just keeps loading, but because it is so slow it seems like no traffic is moving. If I wait long enough sometimes a minute or more speed will ramp up and the page will finish loading.

    During this time I can nslookup, ping, telnet, and SMTP with no problems. But I have now found that when this issue is going on some pings fail. When the everything is working fine the following pings work: ping www.example.com -t -l 150and ping www.example.com -t -l 1500. But when http traffic appears slowed down the ping www.example.com -t -l 1500 fails and www.example.com -t -l 150 works.

    I am using QOS, TCP vegas, and IP/MAC bandwidth filtering. These settings are only used on the Tomato WDS node that hosts the internet connection. I have turned all of these off and I still have problems.

    Am I doing anything wrong, or does Tomato just not like wireless clients in AP+WDS mode?

    In case this is needed my node connects to the main node at -68 to -81dbm.
  28. terintamel

    terintamel Addicted to LI Member

    SOLVED: Tomato problems. Loss of port 80 traffic?? Enter if you want a challenge!

    I think I have finally solved my issue. I know what is happening, but I do not know why Tomato functions this way. The problem is the trees between my house and the host WDS house have been filling in. This is causing my rssi to fluctuate anywhere between -68 to -82dbm. These fluctuations happen are sudden and when it happens all large packets (1500byte pings, and web packets) stop transmitting or get lost, I don't know which. If I wait sometimes a few minutes after the signal returns to normal eventually the large packets will start flowing again.

    To solve this I am putting an ubiquiti NS2L on my roof to act as a wireless backhaul to my internal router. This will stabilize the wireless signal. My question is why Tomato causes large packets to seize up when the signal fluctuates alot? On dd-wrt and most other wireless firmware I have used, when signal fluctuates all packets (large and small) start dropping and immediatley start flowing again when signal level returns to normal.

    Oh well, I found a fix but still wonder why it happens like this.
  29. Toastman

    Toastman Super Moderator Staff Member Member

    If the signal to noise ratio is not good enough to support a connection at the higher speeds, then the router has to renegotiate speed with the distant wireless. That would screw up the connection. Before the renegotiation of speed, the bigger packets would suffer first. But the same would happen with DD-WRT.

    A big drop in signal such as this would actually be a bit odd for a bunch of trees, I mean, the foliage does not drop off suddenly and then jump back onto the branches shortly afterwards. Perhaps there's something else ? If you have access to both ends of the network, does the signal drop at both ends, as it should if the attenuation were causing the problem?
  30. terintamel

    terintamel Addicted to LI Member

    The big fluctuations is on the receiving end of my router. The host router shows a better dbm and stabler dbm than my router shows. Moving my router outside my house seems stabilize the signal. This would make me think there is localized interference in my house, but when I setup the link in Dec '08 I did not have this issue. Nothing has changed inside my house. No new equipment or such. Also my nearest neighbor is over 200' from my house and I know they have not added any new equipment either.
  31. Toastman

    Toastman Super Moderator Staff Member Member

    When I was testing the wireless power levels of Tomato, I found that the received signal jumped around by several dB. Later, I tested DD-WRT to see if their drivers displayed the same behaviour with transmit power. To my surprise, the received signal was rock steady, and changing power levels was quick and precise. I wonder if it's related? I posted the graphs here:

  32. terintamel

    terintamel Addicted to LI Member

    Well I have stabilized my wireless link by mounting a Ubiquiti Nanostation Loco2 (Atheros based) on my roof and using it as a wireless bridge to the wireless router in my house. That router is setup as a wireless switch. The Nanostation gives me a stable wireless link to the host WDS node, and I have had no further issues.

    Would love to know why Tomato seems to behave this way, but since I have found a relatively cheap ($49 USD) fix, I am no longer going to fret over the issue. Thanks for all the ideas/or help I received.

Share This Page