1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato RAF Releases

Discussion in 'Tomato Firmware' started by Victek, Dec 28, 2012.

  1. Victek

    Victek Network Guru Member

    I did not compiled but yes, it's possible.
     
  2. RonV

    RonV Network Guru Member

    Victek,

    Going on 11 days and no issues with Version 1.28.9013 release 1.2. Beating the heck out of QOS rules, NGINX web server, 75 concurrent devices and 2 VPN server session. Customized the DNS cache to 8192 entries, poisoned the cache to block ads and route to the NGINX web server. 53 QOS rules including some really cool DSCP to handle some funky settings in a remote backup utility. Also running multiple 2.4 GHZ networks one visible one hidden to see how two streaming IP cameras work wirelessly.

    Memory and CPU look great:
    Model Asus RT-N66U
    Chipset Broadcom BCM5300 chip rev 1 pkg 0
    CPU Clock 600 MHz
    CPU Load 2.29%
    CPU Load (1 / 5 / 15 mins) 0.00 / 0.00 / 0.00

    Flash RAM Size 32 MB
    RAM Size / Free 249.96 MB / 229.61 MB (91.86%)
    NVRAM Size / Free 64.00 KB / 36.06 KB (56.34%)

    Starting to work on prototyping the build for a field test subject in a low volume location. Thanks again for all you and all the project providers hard work on this firmware.
     
  3. Victek

    Victek Network Guru Member

    Amazing, you're welcome and I thank you to push the pulse of my firmware, I hope it will improve with changes doing now during other models addition... it's a great oporttunity to clean code and discover hide bugs ;), one of them will definitively kill the sirq conflict with new initialization process and monitoring. I discover it understanding and reading wl500g guys and ASUS code.

    Thanks!
     
    Elfew likes this.
  4. iRiii

    iRiii Reformed Router Member

    Would you kindly help me compile or give me the direction how to compile your latest version. Thank you for your help.
     
  5. Victek

    Victek Network Guru Member

    I'll do today and include in the v.1.2 model list...
     
  6. Darius510

    Darius510 Reformed Router Member

    Hey Victek,

    I've got both an RT-N56U, and a RT-AC66U. My main concern is WAN-LAN throughput and low CPU usage with QoS enabled. Bought the rt-56u because it was cheap and had good throughput, thought I could deal with the stock firmware, but I just cant. I figured RT-AC66U was faster in every way, but it sounds like what you're saying is that the rt-56u actually has more potential?

    Neither seem fully supported yet by any version of Tomato, but I'm going to return one before the end of the week.

    Which should I keep?
     
  7. alexlau

    alexlau LI Guru Member

    Report back on the status (all running fine)

    my own: 1 E4200 & 1 WNR3500Lv2, both running v1.2, in total about 12-15 devices, no problem.

    my neighbours: 1 E3200, 3 Asus N-16, all running v1.2, no problem(at least they didn't complain to me, haha)

    I have successfully "converted" my neighbours' to Tomato and setup their DDNS. Appearently they all love the "Access restriction" function for controlling their kids' late night activity. The "parental control" function with the default firmware are not as intuitive to setup.

    Left with 2 E3000 in my drawer now. maybe can wait for the v1.2a or "speedtest" version later. (Not in service anyway :D)

    Thanks Vic!
     
  8. M0g13r

    M0g13r LI Guru Member

    hi victek
    i have a wish :)
    can u add an <BR> between NGINX is currently stopped/started and the start/stop now button ?
    i think it looks better :)

    thx

    btw. 1.2 runs realy fine :)
     
  9. mrQQ

    mrQQ Addicted to LI Member

    hi,

    running 1.2 here on E4200. After ~7 days of uptime, my wireless networks just died. They are still visible, but devices can't connect to them. All 3 are like that (G, N and Guest). If it helps, when I went to logging configuration, changed something, clicked save, and when "some services restarted", i was able to connect again..
     
  10. M_ars

    M_ars LI Guru Member

    Hi Victek,

    is commit 867c81831c714cd42d7c973c519ff4dabf22e118 (VLAN: Correct mapping Netgear 3500L V2 allowing tagging now) really ok? because in file "init.c" we do the following:

    Code:
     404 #ifdef CONFIG_BCMWL5
    405        case MODEL_WNR3500L:
    406        case MODEL_WRT320N:
    407        case MODEL_WNR3500LV2:
    408        case MODEL_RTN16:
    409        case MODEL_RTN66U:
    410                dirty |= check_nv("vlan1ports", "4 3 2 1 8*"); // Lan1 Lan2 Lan3 Lan4 and CPU
    411                dirty |= check_nv("vlan2ports", "0 8"); // WAN and CPU
    412                break;
    I checked then netgear code and they do (almost) the same initialization ("vlan1ports", "1 2 3 4 8*" and "vlan2ports", "0 8") --> Lan 1 to Lan4 turned around in tomato-git or netgear-code... i didnt check that.

    ==> but i think the old setting (COL_P4N = 0) was right at "advanced-vlan.asp"?

    Code:
    @@ -180,7 +180,7 @@ switch(nvram['boardtype']) {
        COL_P1N = '3';
        COL_P2N = '2';
        COL_P3N = '1';
    -    COL_P4N = '0';
    +    COL_P4N = '8';
        break;
        }
        if (nvram['boardrev'] == '0x1204') { //rt-n15u
    best regards
     
  11. Victek

    Victek Network Guru Member

    By wireless specs.. RT-AC66U.
    I got reports of WAN-LAN RT-AC66U running Tomato, dd-wrt with dramatic WAN-LAN throughput, dd-wrt hangs at 80MBps, Tomato hangs at 200Mbps, the main problem is the proprietary hardware NAT module shared with third party firmwares. RMerlin version I think is bug free.
    I was talking about RT-AC56U don't confuse with RT-N56U ... and technologically (wireless besides) the CPU 'should' perform much better than RT-AC66U. Then I expect that hardware NAT bottleneck will give a breath to added features, VPN, QoS ... but these are my thoughts without any evidence until Tomato will be available for RT-AC56U (again, not RT-N56U)

    Final answer.. which one to keep? RT-AC66U ...
     
  12. Victek

    Victek Network Guru Member

    Thanks alexlau, probably the parental option in Tomato is more 'understood' and easy per average user. Happy to ear it.
    Thanks!
     
  13. Victek

    Victek Network Guru Member

    Do you like the button down?... I'll check .. didn't try so I can't say if I like it. The most valuable was your last phrase, happy to read it.

    Thanks!
     
  14. Victek

    Victek Network Guru Member

    I hope feedback, in fact the change was done cause the VLAN tag was not posible, do you have this unit to test?

    Thanks!
     
  15. Victek

    Victek Network Guru Member

    You're the second person (the other sent e.mail) talking about this bug, question: Are you using USB devices connected?, if yes then I know the problem and solution, if not... I need more information in the router log, any message?..
     
  16. Darius510

    Darius510 Reformed Router Member

    Gotcha, thanks. Hadn't realized there was a CPU difference between the n56 and the ac56, figured it was just the wireless radio.

    Any ETA on a stable build of Tomato RAF for the ac66u? Shibby's tomato had pings all over the place. I'm using RMerlin right now, but it's user interface is still meh, and it's QoS is completely useless.
     
  17. iRiii

    iRiii Reformed Router Member

    Victek, Thank you very much and appreciate it!
     
  18. Victek

    Victek Network Guru Member

    You have one Tomato RAF beta in RT-AC folder in my site, you can try but now I'm working in next beta that will ready on Wednesday (holiday in my region).
     
  19. iRiii

    iRiii Reformed Router Member

    Hi Victek,
    Thank you very much for your hard work and I hope, you have a wonderful holiday! I may have confused you somehow. I was requesting that if you can help me compile your latest firmware for Belkin F7D8031/4031.


    Enjoy your holiday,

    iRiii
     
  20. Victek

    Victek Network Guru Member

    Yes, I'll do tomorrow ;)
     
  21. vlads

    vlads Serious Server Member

    @Victek - any chance of a 1.2 build for the Netgear WNR3500L v1?
     
  22. Victek

    Victek Network Guru Member

    I think this model had some issues with Tomato, not?... please help me with related information..
     
  23. vlads

    vlads Serious Server Member

    I can't speak for others, but I've used a WNR3500Lv1 with tomato-K26USB-1.28.9013MIPSR2-R1.0--RAF-VPN-NOCAT for a remote PBX connected to 45/4 cable service without any issues. Before that I've used it with tomato-K26-1.28.9006MIPSR2_RAF-VPN-NOCAT and some of Shibby's builds. Again, no issues.

    Granted, my feature use was limited (ie no VLANs, no WiFi, no QoS, no DHCP - just basic NAT, OpenVPN server, JFFS, DDNS and port forwarding).

    As far as I can remember the only issue I've experienced with it was that during the initial setup I had to manually set the correct mac addresses in NVRAM (wan_hwaddr/et1macaddr = lan_hwaddr/et0macaddr + 1 and wl0_hwaddr = lan_hwaddr/et0macaddr + 2).
     
  24. zavar

    zavar Networkin' Nut Member

    Victek, thanks for all of your hard work with the new version. I'm just getting ready to install 1.2 on my RT-N16.

    I'm a little confused with some the issues that have been posted. Are they mainly related to the RT-N/AC-66?
     
  25. zapoqx

    zapoqx Networkin' Nut Member

    I don't know how many are just to what router, but he did say for me to wait for his next version and an earlier response was that he was gonna drop the new version on Wednesday. So if anything, maybe its best to wait another 24 hrs..
     
    zavar likes this.
  26. zavar

    zavar Networkin' Nut Member

    Thanks zapoqx, I can definitely wait.
     
  27. Victek

    Victek Network Guru Member

    Issues was for RT-AC66U .. but wait for next Tomato RAF version cause I'm including some new patches for dnsmasq (dhcp-relay) and modifying bandwidth limiting with 'priority prefecthing' .. in few words.. sorting problems with WAN-LAN bandwidth
     
    Last edited: Sep 11, 2013
  28. zavar

    zavar Networkin' Nut Member

    Thanks Victek. I'll wait for the new version goodness!
     
  29. Victek

    Victek Network Guru Member

    Tomato RAF RT-AC66U version with LAN ping solved.
     
  30. Darius510

    Darius510 Reformed Router Member

    Sweet! I'll be more than happy to be your guinea pig once it's ready for DL.
     
  31. Darius510

    Darius510 Reformed Router Member

    So I tried out the version dated Sept 12th in your beta folder, tomato-RT-AC66U_9013-RAF-V1.2a-VLAN-VPN-NOCAT-NGINX.trx

    First thing I noticed is that the "save" button doesn't need to work under basic->network, I'm unable to change any wireless properties, so my Wifi is sitting wide open unsecured. DHCP also seems to work fine, but I'm seeing a lot of options I'm not used to seeing, like "pin code", "modem init string", "pptp gateway", etc. Perhaps this page is bugged? Any way to force a save in another way?

    I also gave a speedtest a run, and on my 110/35 connection with qos on but all limits set to 100% and bandwidth to 9999999, it maxes out at 75/35, and CPU usage spikes to 80%+ and the router becomes unresponsive. With QoS off, it runs at full speed. Anything I can do to reduce the CPU load and get QoS working with the full speed of the connection?

    pings seem good though!
     
  32. ksergey2012

    ksergey2012 Serious Server Member

    I confirm to the extreme firmware from 09/12/13, again changes are not saved in the Basic / Network. Wired ping less than 1ms.
     
  33. Victek

    Victek Network Guru Member

    Perfect, I'll built again with missed options ;), I haven't an RT-AC66U to test all functions but the main problem is off.. nice ;) .. @Darius510 forget to reduce load with QoS and/or achieve good bandwidth because the interruptions of the settings in QoS squeezes CPU, if you want lower CPU load then you must use a lite QoS as ASUS implements in the stock firmware... or we need to change the forward rules used by Tomato QoS. Step by step, meanwhile you have to choice ..

    Go to build new test version. Edit: Ready, V.1.2b
     
    Last edited: Sep 12, 2013
  34. Darius510

    Darius510 Reformed Router Member

    I'll be sure to test out the new version when I get home.

    But you're basically saying there's nothing I can do on my end to get higher performance with QoS on? Maybe the "bandwidth limiter" is lighter on the CPU than full QoS?
     
  35. mahi2003

    mahi2003 Reformed Router Member

    Victek: Currently running 1.2b on my RT-AC66U. Saving settings on the Basic / Network page (or any other page) works correctly and, as already mentioned by others, the ping issue is finally resolved! Thanks for the great job!
     
  36. Victek

    Victek Network Guru Member

    I'm so happy to read it... let's go to fine tune the firmware, please tell me what's wrong (besides the QoS softirq load).
    Thanks for testing.
     
  37. Victek

    Victek Network Guru Member

    Yes!, you can help developers testing the firmware.
     
  38. ksergey2012

    ksergey2012 Serious Server Member

    Dear Victek, a new beta firmware for the Asus RT-AC66U just super! Thank you for your work!
     
  39. Victek

    Victek Network Guru Member

    @ksergey2012 thanks for the feedback, test and write anything wrong, as I said I don't have this unit to test. I follow with RT-AC56U Tomato version..
     
  40. Darius510

    Darius510 Reformed Router Member

    Basic settings seems to work now.

    On both 1.2a and 1.2b, enabling the bandwidth limiter crashes the router. I need to reset it by holding the reset button, just powering off and on again doesn't help. When it happened with 1.2a I figured it was random, but it happened exactly the same way on 1.2b.
     
  41. Victek

    Victek Network Guru Member

    Thanks @Darius510 .. Go to check. I think traffic shape it's not enabled in the kernel then..
     
  42. Darius510

    Darius510 Reformed Router Member

    I also noticed IP traffic doesnt seem to show anything, maybe I dont have it configured correctly? I set a few devices to static IP, enabled IP traffic for each of them...the graph is still blank.

    I did some testing with QoS to see what would effect speed, and this is what I found:
    QoS Off - 115mbps
    QoS on, default settings - 75mbps
    Disable inbound layer 7 - 80mbps
    +Disable ingress UDP - 84mbps
    +Change scheduler to pfifo - 86mbps
    +Delete all L7 rules - 100mbps
    +Delete all rules - 103mbps

    Disabled pretty much everything on the router that I could think find, and those were the only settings that had any effect. Seems like there really is no way to get QoS working at full speed on my connection. Hopefully bandwidth limiter in place of QoS can run at full speed!
     
  43. RonV

    RonV Network Guru Member

    Never mind....figured it out myself....
     
  44. Victek

    Victek Network Guru Member

    You're helping ;), in fact the ASUS kernel for this router it's configured for ASUS firmware as it should be, then you know what it means? I need to reconfigure all iptables, ebtables, iptraffic, webmon .... for Tomato... a big fun ... but also a good opportunity to enable ctf (bandwidth >70MB) and shift forward rules to mangle... good moment. Sorry but I hadn't opportunity to test in the unit so, thanks for your comments. Don't wait next release in few hours :)

    @RonV ... Thanks ;)
     
    Last edited: Sep 13, 2013
  45. Darius510

    Darius510 Reformed Router Member

    Just want to give you an update to make sure you don't go through any unnecessary work....I rebooted the router, and IPtraffic seems to be working fine.

    Also tried BW Limiter again...and crashed as expected.
     
    Last edited: Sep 13, 2013
  46. Victek

    Victek Network Guru Member

    It should work fine at first power ON or might be we have a race condition.... nevertheless If I have to update to sdk6 then I need to run these modifications. Thanks for the hands up. If you have a chance please test VPN and wireless streams.
     
  47. Darius510

    Darius510 Reformed Router Member

    Hmmm....well I gave DD-WRT a go, but that's even slower than tomato, so I'm about to revert back. I can tell you for sure that the 5ghz radio wasnt enabled on the first boot either. Let me reinstall 1.2b and I'll let you know what I see.

    Also noticed the wireless rate numbers were kind of crazy. Most were normal like 65/65, 72/6 etc...but a few were like 12/4233463, something impossibly high.
     
  48. Darius510

    Darius510 Reformed Router Member

    Ok, just reinstalled. On first boot, IP traffic is working, 5ghz radio doesnt appear. 2.4ghz works fine. No way for me to test VPN, I don't really know anything about it.

    Rebooted, both wireless radios are working, as is IP traffic...no idea why it wasnt working that one time, although I believe I've seen the same thing happen with a shibby build.

    Anything else I can test?
     
  49. Victek

    Victek Network Guru Member

    Ok, I'll upgrade to latest ASUS kernel and check, the startup phase seems not stable, not bad for the first try ;)
     
  50. kyrios

    kyrios Serious Server Member

    Not bad considered you do not have real AC-66U.
    Anyone who have AC-66U, shall buy Vic 1 unit?

    Ever gave donation to Vic (small), but my routers are N16 and E4200v1.
    Not have plan to replace with AC-66U shortly. Maybe 2-3 years.
    Afterall still have N53 as back-up.
     
  51. kyrios

    kyrios Serious Server Member

    Hi Vic, you have promoted / potential bugs.
    When Basic => IPv6 is disabled, DHCP/DNS => Announce IPv6 on LAN shall be grayed and disabled.

    Reason? This lead to problem with LAG.
    My OSKAM client have fluctuate replied from server.
    I mean lag will happen every 5-6 sec and this lead to glitch on my TVs.

    2013/09/13 : found (322 ms)
    2013/09/13 : found (422 ms)
    2013/09/13 : found (322 ms)
    2013/09/13 : found (722 ms)
    2013/09/13 : found (1022 ms) <<== will cause glitch on TVs
    2013/09/13 : found (522 ms)
    2013/09/13 : found (422 ms)
    2013/09/13 : found (422 ms)
    2013/09/13 : found (322 ms)
    2013/09/13 : found (222 ms)
    2013/09/13 : found (522 ms)
    2013/09/13 : found (422 ms)
    2013/09/13 : found (522 ms)
    2013/09/13 : found (822 ms)
    2013/09/13 : found (1132 ms) <<== will cause glitch on TVs
    2013/09/13 : found (422 ms)
    2013/09/13 : found (322 ms)
    2013/09/13 : found (222 ms)
    2013/09/13 : found (222 ms)
    2013/09/13 : found (422 ms)

    This bug is introduced since ver.y if I remembered correctly.
    I also note that my d/l speed is fluctuate as well.
    I use IDM and noticed my d/l speed will vary from 170 kbps- 400 kbps pretty fast.
    This is weird.
    I bet, online game users will also be affected by this feature.
    They need very short time in order still connected to game server.

    Unthick Announce IPv6 on LAN cure my problem.
    steady repliy from OSKAM server and steady d/l speed as well.

    Please consider to gray and disable Announce IPv6 on LAN
    when Basic => IPv6 is disabled, Vic
     
    lmartinez7641 likes this.
  52. Victek

    Victek Network Guru Member

    Last edited: Sep 14, 2013
    kyrios and Elfew like this.
  53. kyrios

    kyrios Serious Server Member

    Ah.. cool :)
    You the best
     
  54. Sandalwood

    Sandalwood Reformed Router Member

    Hi!

    I just flashed my E4200 with "tomato-E4200-1.28.9013MIPSR2-RAF-V1.2" image and was wondering if the "low" wan to lan throughput i'm getting is normal - some pages ago i read someone saying, that he doesn't need the speedmod version since he "only" has 150 mbit down at the moment, so i was thinking "hey that sounds right for me", since i also got 150/15, but i guess he was talking about another router because what i'm getting is 110mbit - at that point the cpu is totally maxed and the web interface becomes quite unresponsive.
    when connecting the pc directly to the modem i get 137 mbit down and in actual applications the difference is even bigger: when test downloading a CentOS-6.4-x86_64 torrent (with literally thousands of seeders) in qbittorrent i only get 11 MiB/s down when connected to the router but 17.5 MiB/s when connected directly.

    i disabled pretty much everything i could find, and was mentioned on the earlier pages: qos, bw limiter, traffic and bandwidth monitoring, usb, etc ... the only thing active are ddns and upnp.
    jumbo frames don't seem to influence the performance, which doesn't surpise me, since i don't think my isp supports them

    is this the normal performance for an E4200? if not - any idea what could be wrong? of course i did a 30/30/30 reset after flashing.
     
  55. Victek

    Victek Network Guru Member

    The bandwidth is directly dependant of router model and CPU equipped.
    As you may think the figures downloading torrent are out of bounds since as you said your connection is 150Mbps download, so, I think the indication given is wrong in this case. Jumbo frames has no relation in this subject. You can try now the Speedmod version, less features but if your target is to squeeze line capacity then it's the right path. Thanks for your comments.
     
  56. mahi2003

    mahi2003 Reformed Router Member

    Victek: So far version 1.2b for the RT-AC66U seems to be stable although I have not experimented with QoS or any fancy filtering yet.

    I noticed your firmware provides an NTPD service (not available in Shibby's) but I can't get it to work... When I enable "Provide NTPD Service" ("Basic" > "Time") nothing happens. No "ntpd" process appears in the process list and nothing listens on port 123. A reboot does not change this. The binaries however are present and when I manually launch "ntpd" it works and other computers in my LAN can synchronize against it.
    Code:
    ntpd -l -p 0.be.pool.ntp.org -p 1.be.pool.ntp.org -p 2.be.pool.ntp.org

    PS: Would it be possible to add another checkbox, "Intercept NTP port", below "Provide NTPD Service" (it should be unticked and disabled when "Provide NTPD Service" is not checked). The new checkbox should add following iptables rules when checked:
    Code:
    iptables -t nat -I PREROUTING -i br0 -s 192.168.1.0/24 -d ! 192.168.1.0/24 -p tcp --dport 123 -j DNAT --to 192.168.1.1
    iptables -t nat -I PREROUTING -i br0 -s 192.168.1.0/24 -d ! 192.168.1.0/24 -p udp --dport 123 -j DNAT --to 192.168.1.1
    (where br0, 192.168.1.0/24 and 192.168.1.1 should be replaced by the appropriate values of course)

    This is very similar to the "Intercept DNS port" feature ("Advanced" > "DHCP/DNS") and will redirect all NTP requests from the local LAN to the NTP daemon on the router.


    PS2: What does checkbox "Push to Connect On Demand" ("Basic" > "Time") do?
     
  57. Sandalwood

    Sandalwood Reformed Router Member

    I'd be extermely happy if i could try out the speedmod version. didn't know there was one for the E4200 - where can i find it?

    EDIT: i found this post which seemed to have linked the speedtest mods
    but the links are dead :_(
     
    Last edited: Sep 17, 2013
  58. lmartinez7641

    lmartinez7641 Serious Server Member

    You can get it from http://victek.is-a-geek.com/speedtest.html
     
  59. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    @Sandalwood
    There are several people in the forum who overclock their E4200 with good result. Even with the speedtest version it may be required to reach maximum speeds.
    I'm sure you already know this, but UPnP does raise CPU load. Manually forwarding ports is lighter on the CPU, though not always practical.
    Have fun!
     
  60. JAC70

    JAC70 Networkin' Nut Member

    Cool, here's hoping for a Speedtest version for the e3000. I can confirm this router is capable of 160 down without overclocking, since I achieved that on previous generations of firmware, so the E4200 should have no problem.
     
  61. Victek

    Victek Network Guru Member

    I'm sorting all Tomato RAF firmwares in one page for easy download ...yes, it's a mess of versions and non eficient descriptions.

    You can download E3000 version, it's fine for your model too.
    Thanks
     
  62. Victek

    Victek Network Guru Member

    I'm doing changes in Busybox since RT-AC66U broke many features ... but yes, as you saw it can be initiated manually..

    Push Connect on Demand waits until one device in your network needs Internet access and then activates the WAN. Time is the period in seconds that conection will be alive after request.

    Intercept NTP Port is a good idea... just need to replace IP's by lan_ip ... I wrote in my TODO list if I'm bored .. some day .. ;)

    Release for ASUS RT-N12B1 available in the list
     
    Last edited: Sep 17, 2013
  63. nurofen

    nurofen Serious Server Member

    where you can download?
    TOMATO RAF Firmware 2013 r.1.3

     
  64. zavar

    zavar Networkin' Nut Member

    Hi Victek, any timeline for the updated 1.2 for RT-N16 with the DNSMasq and BW Limiter changes? Not pushing, just hoping. :)
     
  65. Sandalwood

    Sandalwood Reformed Router Member

    WOW!
    i just flashed the speedtest mod aaaaand ...

    [​IMG]

    I did a factory reset and did not change any settings.

    Thanks a lot Victek for your wonderful work i had pretty much given up on the full150 mbit ^^ i will go play around a little with it now
     
  66. mrQQ

    mrQQ Addicted to LI Member

    Hello,

    this problem happened again. Yes, I have USB flash drive plugged in, but I don't use it at all.

    No messages, just can't connect to wireless, that's it. Log shows nothing..
     
  67. asammar

    asammar Network Guru Member

    Victek,

    The download page shows the load for E3000 and F7D4301 to be the same. I was under the impression that the E3000 has 60K of nvram which would brick the 4301 as it has only 32K. Am I missing something?

    I have an F7D4301 and just wanted to confirm the correct load before flashing.

    Thank you.
     
  68. Victek

    Victek Network Guru Member

    Wait then .. try the version for RT-16, it's the same but restricted to 32KB nvram. Opss.. but you need less than 8MB size by the flash ... ok, go to compile a 'solo' version for the unit.

    The problem is the USB conflict.. ok, I patched the usb-hci .... it triggers the issue.

    Hi zavar, are you working for NSA? :) ... Right now I'm doing test with dnsmasq, the test14 version runs very well but it delays a lot the presentation of devices in "Devices List" feature. Since Tomato have it's own calls to scan it I'm thinking how to merge and sort it. I have to recognize the great job done by dnsmaq author, a lot of comments and information in his code.
     
  69. asammar

    asammar Network Guru Member

    Thanks for the quick reply Vic. Which Makefile target should I use to generate the correct build for the 4301 please?

    Also, I have a few WRT54GS units (with 8M flash) that I am using as wireless bridges. Which target should I use to generate a load for those? Or are they not supported?

    Thank you.
     
  70. Victek

    Victek Network Guru Member

    I'm changing something for new builds in ../src-rt/makefile, but you can 'touch' the 'nc' switch like I modified today...

    Code:
    nc:
    ifeq ($(CONFIG_LINUX26),y)
        @$(MAKE) bin OPENVPN=y USERPPTP=y PPTPD=y NTFS=y BBEXTRAS=y USBEXTRAS=y EBTABLES=y NO_LIBOPT=y MEDIASRV=y IPV6SUPP=y DNSCRYPT=y B=NC USB="USB" SNMP=y VLAN=y NOCAT=y TCPDUMP="$(TCPDUMP)"
    else
        @$(MAKE) bin OPENVPN=y USERPPTP=y PPTPD=y NTFS=y DNSCRYPT=y B=NC BUILD_DESC="$(VPN)" USB="USB" VLAN="$(VLAN)" NOCAT=y TCPDUMP="$(TCPDUMP)" BUILD_DESC+=" $(NC)"
    endif
    But .. I posted the build two minutes ago ...

    About WRT54GS ... look at the other versions firmware selecting language tab on top..
     
    Last edited: Sep 17, 2013
  71. Victek

    Victek Network Guru Member

    I don't need to download .. you need if you like.. ;) .. These features are available in release 1.2 already ... http://victek.is-a-geek.com/9013.html
     
    nurofen likes this.
  72. nurofen

    nurofen Serious Server Member

  73. zapoqx

    zapoqx Networkin' Nut Member

    Hmm. Curiousity here, Is 1.2a coming out today for E3000?
     
  74. Victek

    Victek Network Guru Member

  75. Victek

    Victek Network Guru Member

    No ..
     
  76. zavar

    zavar Networkin' Nut Member

    No comment Victek... someone is always watching. ;)

    Glad to hear the test version is coming along. Thank you for all of the time and hard work that you put into continuing Tomato's development. I'm excited to see what the future holds!
     
  77. Daky

    Daky Network Guru Member

    Hello guys,

    I just flashed my RT-N66U with: Tomato RAF Firmware v1.28.9013 MIPSR2-RAF-V1.2 K26 USB VLAN-NGINX-64K

    is this what i am suppose to be running?

    Thanks all, and thanks Victek.

    Is there a way to enable stealthmode on this firmware?

    Regards
     
  78. Victek

    Victek Network Guru Member

    Did you downloaded from this link? http://victek.is-a-geek.com/Repositorios/Beta_RAF/tomato-RT-N66-1.28.9013MIPSR2-RAF-V1.2.trx .. if yes then is correct. No, no stealthmode, always shinning ;)
     
  79. Elfew

    Elfew Addicted to LI Member

    Of course, you can - just use script for turn on/off leds in scheduler... I use it in my rt-16n... Or just take script from shibby
     
  80. Daky

    Daky Network Guru Member

    Thanks Victek, that was it (correct link)

    Elfew, mind explaining how to do this? (if its not allowed in this thread), can i msg you?

    Thanks !
     
  81. fubdap

    fubdap Addicted to LI Member

  82. Daky

    Daky Network Guru Member

    Thanks, but, i need to find the script or install something? I already tried these commands when i flashed my router, but, didnt work :)

    root@home:/tmp/home/root# /usr/sbin/stealthMode on
    -sh: /usr/sbin/stealthMode: not found
    root@home:/tmp/home/root#

    root@home:/usr/sbin# ls -la stealthMode
    ls: stealthMode: No such file or directory
    root@home:/usr/sbin#


    Thanks
     
  83. Victek

    Victek Network Guru Member

    @Daky you can't because the stealhtmodule is not in Tomato RAF firmware... ;)
     
  84. Daky

    Daky Network Guru Member

    Victek, i understand.

    I apologize for writing about this in your thread.

    Your firmware is perfect, great work, and thank you for this.

    Is it okay if i open up another thread and ask about this? as, ppl say there is a way.

    I have router in my living room, on the wall, close to TV, at night, while watching tv\movies, etc. those lights are just killing eyes :)

    Thanks
     
  85. Victek

    Victek Network Guru Member

    LOL ... the solution is simple but instead of doing in 'hard way' (disabling GPIO pin from the prompt) stealthmode do it with a simple script identifying the model and then applying for a cron process or directly. I'll test the code look for some improvement and include it in next release, meanwhile you can use shibby's version or stick a sheet of paper at the router top... ;)
     
    Last edited: Sep 18, 2013
  86. Daky

    Daky Network Guru Member

    :) :) you the man! Thank you.

    i will try to do some re-search for that script as well, so, i can do it without a paper :p

    Thanks again
     
  87. Victek

    Victek Network Guru Member

    Just wait two hours.. I'm doing it now..
     
  88. Daky

    Daky Network Guru Member

    I can wait few days, as well, don't rush your self sir, if you have other important things to do. :)

    Thank you VERY much!

    Regards
     
  89. Victek

    Victek Network Guru Member

    Ok, I'm working in some dnsmasq issues and I built one version for RT-N16/RT-N66/RT-AC66 with stealthmode included, you have a lot of options to include it, from the simple on|off till option to synchronize it with your city local time (look codes at Yahoo Weather Service, and then leave a Sunset mode), it's very complete. To know the options simply type from the command line; cat /usr/sbin/stealthMode , and you will read all possibilities, there are many options and modes. To test if it works:
    Code:
    root@unknown:/usr/sbin# stealthMode on
    stealthMode: Activated
    root@unknown:/usr/sbin# stealthMode off
    stealthMode: Disactivated
    root@unknown:/usr/sbin#
    
    To set steathMode to your city...
    Code:
    root@unknown:/usr/sbin# stealthMode sun 753692
    stealthMode: Sunset Enabled
    stealthMode: Scheduler Tasks Deleted
    stealthMode: Sunset city code: 753692, sunset: 19:55, sunrise: 7:33
    stealthMode: The time now is 18:52, so StealthMode will be activated at next sun set
    root@unknown:/usr/sbin#
    
    Link for RT-N66U: Ready ... Beta v1.3
    Link for RT-N16U: Ready ... Beta v1.3
    Link for RT-AC66U: Ready ... Beta v1.3
     
    Last edited: Sep 18, 2013
  90. Daky

    Daky Network Guru Member

    Perfect ! :)

    Will i have to flash my router again with new version? Is it going to be safe to save current config (if this has to be done) and just restore it? (as i believe only this was added in this release).

    Thank you Victek.
     
  91. mrQQ

    mrQQ Addicted to LI Member

    Hi,

    will you release a fix? Shoud unplugging usb help?

    also, should WPS work? pressing WPS on RAF just kills the wireless networks..
     
  92. Victek

    Victek Network Guru Member

    Just flash over actual version, in this case no need to restore or erase nvram .. yet ;) .. version for RT-N66 ready, go to downloads v.1.2 and scroll down to download v1.3 betas.
     
  93. Victek

    Victek Network Guru Member

    Unplug USB helps a lot... then you can confirm that the problem is gone before I release the patched version.
    WPS will not work in Tomato. We never used ... but if it kills wireless then you discover the Wireless OFF switch ;) it restores wireless when pushed again or simply cut wireless radio?
     
    Last edited: Sep 18, 2013
  94. Daky

    Daky Network Guru Member

    THANK YOU !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! YOU THE MAN!
     
  95. Daky

    Daky Network Guru Member

    Victek,

    This is correct file ( tomato-K26USB-1.28.9013MIPSR2-RAF-V1.2c ) ?

    As i don't see 1.3 in file name, i just wasn't sure, it says , 1.2c.

    Thank you sir.
     
  96. Victek

    Victek Network Guru Member

    Yes, it's the beta branch to reach final version v1.3 .. starts from v1.2 stable
     
  97. Sp0wn971

    Sp0wn971 Reformed Router Member

    Hello Victek, does your last Asus RT-AC66U firmware include AC support ?
     
  98. Daky

    Daky Network Guru Member

    Everything works perfect !!! Thank you sir.
     
  99. Daky

    Daky Network Guru Member

    I have @ Wan up (Scripts: /usr/sbin/stealthMode on and in scheduler, to check it every hour.

    Man, i am so glad you are this helpful :)
     
  100. Victek

    Victek Network Guru Member

    I used the sunset mode.. it works perfect too.. now I can sleep at the desk...:)
    Code:
    Sep 18 19:16:44 unknown user.info stealthMode: Sunset Enabled
    Sep 18 19:16:44 unknown user.info stealthMode: Scheduler Tasks Deleted
    Sep 18 19:16:44 unknown user.info stealthMode: Sunset city code: 753692, sunset: 19:55, sunrise: 7:33
    Sep 18 19:16:45 unknown user.info stealthMode: The time now is 19:16, so StealthMode will be activated at next sun set
    Sep 18 19:55:02 unknown user.info stealthMode: Activated
    Please observ dnsmasq messages and log... it's the real change in this version, includes dhcp-relay.
     
    Last edited: Sep 18, 2013

Share This Page