1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato RAF Releases

Discussion in 'Tomato Firmware' started by Victek, Dec 28, 2012.

  1. szpunk

    szpunk Networkin' Nut Member

    @Vicrek, i try WNR3700v3-1.28.9013MIPSR2-RAF-V1.2f1, all issue stay(from 1.2f) but DHCP for LAN working now~~USB function is fine, i test it by install optware on a 8G U disk.

    POWER LED, WAN LED, LAN LED almost working, it's means, it's light but color it's not like stock or DD-WRT firmware. For normal status, these LEDs should be green color, but all orange on raf firmware~ When LAN connection is 100M, LAN LED should be green and if connection is 1000M LED should be orange. 2.4G and 5G LED NOT working, USB LED NOT working, Wireless switch LED,WPS LED NOT working.

    5G signal still terrible....
  2. Victek

    Victek Network Guru Member

    Good ... one step more ;) go to upgrade to f2 then... 20 or 30 versions more and it should work (LOL)...now you will understand how it motivates?

    @jilebi , @szpunk version f2 ready.. I hope it will be much better but I can't test in my E4200 due to nvram size...
    Last edited: Sep 22, 2013
  3. szpunk

    szpunk Networkin' Nut Member

    @Victek,WNR3700v3-1.28.9013MIPSR2-RAF-V1.2f2, one thing i can see it's WAN/LAN LED now smarter than ever, when 1000M is green color,100M is orange.
  4. Victek

    Victek Network Guru Member

    and ?.. ;) I mean .. I like LED color but what about connection and operations?. Thanks and appreciate your feedback.
  5. szpunk

    szpunk Networkin' Nut Member

    @Victek, after i flash this firmware, i still need use wireless connect to router, then reset VLAN, then use DHCP for LAN and WAN. (no PPPoE WAN test because i dont have this line in my office)

    Router Model still not WNDR3700.

    Basic wireless setting still no N for select, both 2.4G and 5G, 5G signal still weak. 2.4G working fine when i use all "Auto" setting.

    BTW: I flashed another AC66U unit with you 1.2e version of firmware, i erase all data in NVRAM, reboot 3-5 times, but the 5G/eth2 never show on Basic Seting page... Finally, i input next commands in ssh console:

    nvram set lan_ifnames='vlan1 eth1 eth2'
    nvram set landevs='vlan1 wl0 wl1'
    nvram commit
    and i got my 5G back.. I dump CTF from tomato, this unit's CFE include:

    Do you remember the two CFE i send to you last time? It's CN and EU;

    So i set "UNITED STATES" in Advance/Wireless Setting/Country / Region, I got 1300Mbps soon...

    After all, i dont think it is must set Country / Region =EU then we will get 1300Mbps, for me, i follow CFE's regulation_domain set is always working.
  6. Victek

    Victek Network Guru Member

    @szpunk ... weird cause the values are in router/rc/init.c file already (line 1226)... go to check again.

    These things happen when we have no router to test new model add to Tomato.. but at least we have nice people helping us with tests ..

    Ah!.. the problem could be that you have a Chinese unit and ... could be that boardrevision or id is different from EU version model... just a thought..

    Edit: Just modified it...

    //force USA country for eth2
                nvram_set("pci/2/1/ccode", "US");
    settings for WNDR3700 are from code line 1480... a Babel Tower.. don't understand why it assign WAN to vlan1 when wan_ifnamesX is vlan2... but if Model not appear is suspicious..
    Last edited: Sep 22, 2013
  7. ilkevinli

    ilkevinli Network Guru Member

    I installed Shibbys version from the Asus firmware using the Asus recovery tool and I had both wireless bands. I then upgraded to your version 1.2e and lost the 5 ghz band again. Suggestions ? Could it be because I have hardware version A2 ?

  8. RonV

    RonV Network Guru Member

    Hey Victek, just wanted to give you an update on the stability of Tomato RAF Firmware v1.28.9013 MIPSR2-RAF-V1.2 K26 USB VLAN-NGINX-64K on my n66u:

    Date & Time Sun, 22 Sep 2013 13:45:44 -0500
    Uptime 25 days, 17:38:06
    Flash RAM Size 32 MB
    RAM Size / Free 249.96 MB / 226.30 MB (90.54%)
    NVRAM Size / Free 64.00 KB / 36.09 KB (56.39%)

    Logs are clean only seeing DCHP lease information or access vpn. As you can see memory is holding up great, no memory leaks that I can identify and I even doubled the amount of traffic and the DNS cache size. Yesterday did a huge stress test by streaming TV through it at 12 mbps for over 10 hours and not a hiccup.

    I'll have another testing session next Friday when my internet bandwidth doubles from 15 mbps to 32 mbps.
    Last edited: Sep 22, 2013
  9. Victek

    Victek Network Guru Member

    Now you can update to Tomato RAF from the gui with the previous version you downloaded, it's a bug in initialization of 5GHz when router had Asus firmware, later is no problem when update is done. it seems that bug is also in shibby version, so I have to look asus code.. http://www.linksysinfo.org/index.ph...ds-for-asus-rt-ac66u.68055/page-2#post-233963

    Amazing ... I can't hold versions in my router for more than 1-2 days testing new features so I thank you very much all patient people giving the figures I saw.. wow.. 25 days.
    If I were you... update to v1.2f .. and test vpn (it solves TLS cypher bug from previous 2.3.0 ran in V1.2) and dnsmasq (it works smooth and you can shout up log messages if you like. Feedback till now is very positive.
    Last edited: Sep 22, 2013
  10. Elfew

    Elfew Addicted to LI Member

    I am waiting for nodog splash :) Now I flashed latest beta, good work
  11. Victek

    Victek Network Guru Member

    Hi Elfew, thanks for posting, as you saw have been sorting many threads, now I'm reading code for the remote http/https stuck... It's a longtime bug as I read and .. well.. I would like to clean these bugs.

    Elfew likes this.
  12. jilebi

    jilebi Reformed Router Member

    Hi Victek,

    For WNDR3700v3, I downloaded ver.f2. My WNDR3700v3 is currently on dd-wrt, since you needed a NVRAM and CFE dump from dd-wrt earlier. Hence I attempted to upgade to test ver.f2 from dd-wrt.

    The upgrade does not get completed. After 5 seconds, the upload webpage goes blank (instead of counting down from 300 sec to 1 sec, it stops at 295sec and then goes blank). 10 seconds after that, the unit reboots and I am back in dd-wrt. I did this twice and both times with same results. FYI, I upgraded the firmware in dd-wrt with 'Reset Default Values' option. After rebooting, dd-wrt starts with default options on login/password/SSID/etc.

    Since the firmware upgrade is failing from within dd-wrt, what do I need to do different to test it?

  13. Victek

    Victek Network Guru Member

    Weird.. @szpunk is using same version and reporting findings, let's wait him to know what firmware base version uses for the upgrade to Tomato RAF?
  14. szpunk

    szpunk Networkin' Nut Member

    @jilebi , @Victek , i had failed upgrade raf's firmware from dd-wrt too, this unit is very special. We can not let it into recover mode by holding the reset button and power on like other unit(3700 v1 or v2), but i found a trick on dd-wrt forum: set your pc a static ip, like, then telnet into dd-wrt's console:

    mtd erase linux
    after reboot, the unit will into recover mode, if you ping you will get TTL=100, you can flash raf firmware by tftp or netgear's recover tools now.

    For user who has stock firmware on WNDR3700V3, i suggest flash shibby's firmware for 3700v3 first, then raf.

    shibby's firmware for v3:

  15. Victek

    Victek Network Guru Member

    Perfect ...;), good method
  16. Planiwa

    Planiwa LI Guru Member

    May I ask a question?
    Are you making *actual* use of BW Limiter?
    I say *actual* use, since merely *enabling* the BW Limiter without *actually* *limiting* any traffic does not cause frequent reboots.

    I have reviewed Victek's Beta-testing of the "Random Reboot" problem with the BW Limiter.
    It is clear to me that there is a problem, that Victek is aware of the problem, that Victek had specifically asked Beta-testers to examine this problem, and that nobody has reported *actually* using the BW limiter to limit BW, without incurring Random Reboots.

    In particular, no one has said: "I have used the BW limiter, using the following parameters, with X LAN hosts, moving Y GB of Data, and my uptime is Z days, where Z is significantly greater than 0.

    Victek has said:
    "I can't hold versions in my router for more than 1-2 days testing new features".
    "I have BW limiter enabled in my router 24/24 .. no problem".
    "_ Please use the Bandwidth limiter to check that no random reboots are present [it occurs after browsing many url or download big amount of data]".
    "_ Please check BW limiter. It should limit < 200+400KB (for a ceiling of 5MB/sec) under the selected value due to unwanted TCP header".

    Also, the sorts of things that are almost guaranteed to trigger Router Reboot, such as waking a Mac OS X host from several hours of sleep, may not be experienced by people who power down their hosts rather than sleeping them, or who don't run Mac hosts.

    Still, if this 25 day uptime is with BW Limiter not only enabled, but actually applied to reduce BW below demand, that would be most interesting.
  17. jilebi

    jilebi Reformed Router Member

    I agree with Victek. Nice workaround for the WNDR3700v3 RAF firmware upgrade, @szpunk! I will try it out.

  18. MatteoV

    MatteoV Serious Server Member

    Hi Victek, hi all.
    I'm kinda of a noob with TomatoRAF but I would like to do a little question, because I liked and like the firmware a lot and I want to stay with this, I'm testing 1.2 since a month, coming from dd-wrt, with an E4200, and I find it really better behaving!
    Now, presentations apart, I think I have done something not really advised. I upgraded 1.2 to latest beta 1.2f, precisely:
    tomato-E4200-1.28.9013MIPSR2-RAF-V1.2.bin >> tomato-E4200-1.28.9013MIPSR2-60K-RAF-V1.2f.bin
    without a nvram erase of course :oops:
    Now I'm stuck with everything working except the web GUI. It does not answer at all. Well, and I have a Tomato.RAF 5ghz network now too, what I wanted to reach with the upgrade, but would like to change its settings lol. I managed to put it down in the while with sshd (I had set a remote access and keys for login). I could not by telnet because it is refusing admin/mypassword. Don't know why.
    I'm seeking how to fix webif, I found a similar report:
    in another post, Peter, you were saying one could fix changing nvram value for this. Would you/someone please tell me which one is it? I know the nvram show and nvram set commands so I would like to fix without re-setting everything.
    p.s. in the logs I see:
    Sep 23 10:45:54 ROUTER daemon.info httpd[980]: Generating SSL certificate...
    Sep 23 10:45:56 ROUTER daemon.warn httpd[980]: Unable to start SSL
    Sep 23 10:45:56 ROUTER daemon.info httpd[980]: Generating SSL certificate...
    Sep 23 10:45:58 ROUTER daemon.err httpd[980]: Unable to start SSL
    This could be the problem? Not sure if httpd is the webif or nginx honestly, hope I'm not saying bullshit so :)

    Thanks guys for your work and help.
  19. MatteoV

    MatteoV Serious Server Member

    Ok, found it out,
    nvram set https_enable=1
    nvram commit
    Worked ;)
  20. Victek

    Victek Network Guru Member

    That's a valuable information for me to fix the remote access problem, obviously ssl cert is not working. httpd in tomato is not nginx (added module)

    MatteoV likes this.
  21. Victek

    Victek Network Guru Member

    And this workaround may solve other router head checking for non original firmware or allow to revert to older firmware versions... ;)
  22. MatteoV

    MatteoV Serious Server Member

  23. Victek

    Victek Network Guru Member

    I'm only adding updated modules if newer features or bugs from previous versions are solved, is it in this case? I'm always working with sources and compile in the build... and always trust in others work .. it's a personal decission ;)
  24. MatteoV

    MatteoV Serious Server Member

    I think it is. There are 2 main differences (imho) and upgrading is highly recommended from authors:
    1 )
    I am testing if this will fix my log full of these strange messages when changing dns server to others from OpenDNS' ones:
    Sep 23 14:48:30 ROUTER daemon.debug dnscrypt-proxy[1497]: resolver timeout (UDP)
    Sep 23 14:49:42 ROUTER daemon.debug dnscrypt-proxy[1497]: Received a reply that doesn't match any active query
    Sep 23 14:49:42 ROUTER daemon.debug dnscrypt-proxy[1497]: Received a reply that doesn't match any active query
    Sep 23 14:49:44 ROUTER daemon.debug dnscrypt-proxy[1497]: Received a reply that doesn't match any active query
    Sep 23 14:49:52 ROUTER daemon.debug dnscrypt-proxy[1497]: resolver timeout (UDP)
    Sep 23 14:49:52 ROUTER daemon.debug dnscrypt-proxy[1497]: resolver timeout (UDP)
    Sep 23 14:49:54 ROUTER daemon.debug dnscrypt-proxy[1497]: resolver timeout (UDP)
    Sep 23 14:50:40 ROUTER daemon.debug dnscrypt-proxy[1497]: Received a reply that doesn't match any active query
    Sep 23 14:50:49 ROUTER daemon.debug dnscrypt-proxy[1497]: resolver timeout (UDP)
    Sep 23 14:50:50 ROUTER daemon.debug dnscrypt-proxy[1497]: Received a reply that doesn't match any active query
    Sep 23 14:51:00 ROUTER daemon.debug dnscrypt-proxy[1497]: resolver timeout (UDP)
    2 )
    and minor others (still, imho!). You can find the full changelog from the authors here: https://github.com/opendns/dnscrypt-proxy/blob/master/NEWS

    Thanks ;)
  25. Victek

    Victek Network Guru Member

    Same log as 1.3.2 .. libsodium detached in dnscrypt-proxy .. not important since we compile both of them independent.. but 1.3.3 makes sense to update, the issue is we need to build a new Makefile for the module.
    In fact log seems normal since dnscrypt-proxy was built to work with opendns http://www.opendns.com/technology/dnscrypt/ ,go to solve SSL integration..
    Last edited: Sep 23, 2013
    Elfew likes this.
  26. MatteoV

    MatteoV Serious Server Member

    After a pair of hours of testing I find 1.3.3 completely stops flooding the log with errors even with other servers active. In the meantime, in fact, I managed to use it uploading the downloaded compiled binary to an external usb stick and using a wan up script in the gui that kills integrated 1.3.0 and wakes 4 instances of 1.3.3 ;)
    I'm not sure if OpenDNS has thinked/sponsored dnscrypt-proxy or if they have just firstly used it, but there's http://dnscrypt.org/ that is suggesting the latter, and some lines of commit in the github page, like "oops, seems like opendns changed ipv6 address" :) ...not sure anyway but I am just using the servers listed on that official page of the project.

    Thanks for your help Victek, I'll watch out for news ;)
  27. Victek

    Victek Network Guru Member

    @Planiwa , since you're one of the 'hard' users for BW Limiter... I review the code again and found some 'holes' in the integration of new models routers 'AC' and 'N', so, I wrote new code trying to workaround 'forward' using 'mangle', would you like to test the build I did few minutes ago? Are you using RT-N66U right? please confirm and I'll indicate the link to download. Thanks

    @MatteoV .. found the bug in the integration of the new Openssl 1.0.1e ... will be back in this issue after I finish BW limiter bug... thanks a lot!
    Last edited: Sep 23, 2013
    MatteoV and Elfew like this.
  28. Elfew

    Elfew Addicted to LI Member

    I know Victek and keep good work...

    Anyway I dont have any issues with BW limiter but I use it on my RT-16n and I have less clients connected... so maybe there is an issue but I dont know about it
  29. Victek

    Victek Network Guru Member

    I have been able to reproduce with the MacBook Air of my friend.. it's the kiss of the dead.. amazing ;) love Apple...:p
    Last edited: Sep 23, 2013
  30. Planiwa

    Planiwa LI Guru Member

    YES!!! Please Victek.
  31. eahm

    eahm LI Guru Member

    No, it doesn't work. "IP address outside of LAN" when I try to limit 10.0.0.x (br1) when br0 is 192.168.1.x. Shibby mod has a separate brx limiters, Toastman VLAN's as well IIRC.

    I am talking about this btw:
    Last edited: Sep 23, 2013
  32. Elfew

    Elfew Addicted to LI Member

    You are wrong.... or I dont understand you.

    set IP range in br1 - for example:

    go to the BW limiter GUI and add there - so all clients which are connected to the br1 will have your limit for DWL and UPL... you can set also priority (something like QoS but for clients)
  33. eahm

    eahm LI Guru Member

  34. Elfew

    Elfew Addicted to LI Member

    @eahm - check this, I just check my config twice https://www.dropbox.com/sh/qbcx7yx9gjh1wku/W2EtSMdDbi - everything is working fine

    @Victek - same notification window - IP address is outsite of LAN - but I think it is normal, not? It shows only for br1/br2/br3 etc networks

    @Victek - second thing - please could you check VLAN? I think my settings doesnt save... and last thing - my router is rebooting everytime with BW limiter enabled my wifi and all clients reconnect automatically every minute - but I have only test values so maybe it is because of them... I will post you a log or more info tommorow, I am going to sleep
  35. eahm

    eahm LI Guru Member

    @Elfew, that only tells me that yours works and mine doesn't. It gives me "IP address outside of LAN" even with 192.168.2.x btw.

    Using 1.2f beta on N66U.

    Does it work without setting up a port for the VLAN here ?
    Last edited: Sep 23, 2013
  36. Elfew

    Elfew Addicted to LI Member

    Ok, but I use rt-16n. I solved issue with disconnecting maybe, I will provide more info tommorow.

    I can add every IP range but only for IPs in br1/2/3 etx it shows the notification window but when you click on OK it is added -> save it -> no problem, working
  37. Elfew

    Elfew Addicted to LI Member

    PS - I dont know, I will try it in the morning, it is 1Am here and I go to work in the morning ;) you can test it with vlan and tell us
  38. eahm

    eahm LI Guru Member

    Please don't waste time for me, I can't right now but I will try every configuration later this evening.


    Nothing. It doesn't work even after the setup of a VLAN port.
    Last edited: Sep 24, 2013
  39. CowMix

    CowMix Addicted to LI Member

    Hey Victek,

    I have your latest build running on my ac66u and I think I found a bug. If I enable qos and then try to modify any of my wifi settings from the Basic > Network page the entire router will crash and I have so a hard reset using the wps button.

    Also does the 80mhz band work for 5ghz in your build or is it only shibby?

    Everything else seems to work really well and the Wifi range seems to be pretty much on par with the asus firmware so far, I'm going to keep messing with the wifi settings to see if I can get faster speeds (I'm getting wifi rates below 25Mbps on 2.4 and 5ghz but it could be because my neighborhood is noisy). Thanks for your hard work!
    Last edited: Sep 24, 2013
  40. Victek

    Victek Network Guru Member

    To :
    @eahm , @Planiwa @Elfew after 58GB downlaod with BW limiter in a E4200 (the weakest unit due to low RAM) it seems that problem is solved, I build one version for RT-N66U with capacity to control separated lan's also, please test and if report is OK then I'll clone same patch (1.800 lines and 12 files) to other builds.. I hope to close this issue in the TODO list..

    @CowMix, you're right the QoS is not working in RT-AC66U version at the moment... also some other features can be buggy, network and wireless is OK, please read posts in this thread how to fix 5GHz 80MHz bandwidth, I don't have router to test.

    Thanks to all.
    eahm and Elfew like this.
  41. Elfew

    Elfew Addicted to LI Member

    Excellent! You are great! :D

    Does the new patch for separated control affect speed or no?
  42. Victek

    Victek Network Guru Member

    As far I tested the bandwidth is keept.. 196Mbps in V.1.2 and 290Mbps in Speedtest version... I'll build another version for RT-N16U now (1.2f2), please tell me your opinion about the gui. I'm stuck in revision 1.2f until the subject will be solved. Thanks

    I changed the method for traffic control... here it's some information about... http://www.cisco.com/en/US/tech/tk543/tk545/technologies_tech_note09186a00800a3a25.shtml

    Nest I'll try to sort the local/remote access with https after this subject will be closed.
    Last edited: Sep 24, 2013
    Elfew likes this.
  43. Planiwa

    Planiwa LI Guru Member

    Victek likes this.
  44. Elfew

    Elfew Addicted to LI Member

    I cannot believe that speedtest version has 290Mbps throughput! Final speedtest version will be really huge step for Tomato

    @Planiwa - no it is not this version... check date and time
    Last edited: Sep 24, 2013
  45. Victek

    Victek Network Guru Member

  46. CowMix

    CowMix Addicted to LI Member

    Does qos not work at all? I can enable it and I stat to getting classification graphs and details that are correctly mapping like its working. But when I tried twice to change a wifi setting after enabling qos and the router blew up. Is it just classifying packets but not actually prioritizing them?

    I got the 80mhz working by changing my wifi country to untied states but the signal seems worse than 20 and 40. Hmm, I'll keep playing around with options.
  47. Victek

    Victek Network Guru Member

    right, this is the bug... when something is not working 100% I simply say 'not work' ;)
  48. CowMix

    CowMix Addicted to LI Member

    haha okay, I should probably keep it disabled for now until that bug is fixed anyway, thanks again!
  49. Victek

    Victek Network Guru Member

    @eahm @Elfew @Planiwa .. forgot to write... NVRAM ERASE and new configuration, many values (18) in nvram are deleted and new values entered.
    eahm and Elfew like this.
  50. Planiwa

    Planiwa LI Guru Member

    Thanks. (SOP)
  51. eahm

    eahm LI Guru Member

    I always reconfigure form scratch. Thanks, testing in a bit.

    I like this limiter Victek thanks. What is the difference from yours to Shibby's?
    Last edited: Sep 25, 2013
  52. Darius510

    Darius510 Reformed Router Member

    Will the speedtest version eventually be able for other models, such as the e3000?
  53. barkmann

    barkmann Network Guru Member

    yes, I'd lurve to see a speedtest version for the n66u please :)
  54. Victek

    Victek Network Guru Member

    You can use the same version as available for E4200 ... I renamed the file..

    Do you have bandwidth problem with RT-N66U ?
  55. CowMix

    CowMix Addicted to LI Member

    What is the normal ping response time for wifi? Lan is always less than 1ms but wifi seems all over the place.

    --- IP (wlan0)
    PING ( 56(84) bytes of data.
    64 bytes from icmp_seq=1 ttl=64 time=0.885 ms
    64 bytes from icmp_seq=2 ttl=64 time=6.40 ms
    64 bytes from icmp_seq=3 ttl=64 time=6.25 ms
    64 bytes from icmp_seq=1 ttl=64 time=1.09 ms
    64 bytes from icmp_seq=2 ttl=64 time=6.92 ms
    64 bytes from icmp_seq=3 ttl=64 time=0.977 ms

    AC66U, 1 meter away from the router and full bars.
  56. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    The variability and range of ping times are normal behavior for wireless. If you care about latency, use wired connections.
    koitsu likes this.
  57. CowMix

    CowMix Addicted to LI Member

    Ya I figured as much just wanted to verify. Thanks :)
  58. Lorenceo

    Lorenceo Networkin' Nut Member

    I've just flashed tomato-K26USB-1.28.9013MIPSR2-64K-RAF-V1.2f to my N66U B1, and IPv6 via DHCP-PD doesn't work. The router obtains its v6 address on the WAN, but when trying to ping or traceroute to v6 hosts on the router it reports:
    traceroute: can't connect to remote host: Network is unreachable

    There are no router advertisements sent to the LAN either.

    If anyone has suggestions on what to try to get it working, or needs more information for troubleshooting let me know. I'm keen to get it working as soon as possible. :)
    Last edited: Sep 25, 2013
  59. eahm

    eahm LI Guru Member

    That's not the latest beta. Don't know if anything related to your problem changes though.
    Last edited: Sep 25, 2013
  60. Lorenceo

    Lorenceo Networkin' Nut Member

    What is the latest one? I'll try it.

    At the moment I'm comparing the ip6tables and ifconfig between an older working version (with radvd, not perfect but better than no v6) on an N16 and they seem very similar. The biggest difference is probably br0 on them.
    On the N66U it has a /48 on br0, where on the N16 it has a /64. The /48 should be correct, as that is the size of the subnets my ISP hands out.
  61. eahm

    eahm LI Guru Member

  62. nurofen

    nurofen Serious Server Member

    eahm, And what are the changes?

    I'm waiting for the fix errors with IPTV :)
  63. eahm

    eahm LI Guru Member

    Other than the new BW Limiter I am not sure.
  64. ksergey2012

    ksergey2012 Serious Server Member

    Good day to all! Dear Victek, I understand that a new version of firmware for the v1.2f2 RT-AC66U still based on the old driver? Because of the choice of channels only auto or 40 and also connected 877.5 Mbps. I tried to install the Country - United States, appears in the settings to choose 48 channels, but it is not stored (after you save is automatically - auto). For the rest, the firmware is stable, I really do not use QoS, VPN, USB (I have a NAS). Another would be to deal with speed PC connection and all would be fine! Dear Victek, do you have any plans to do light firmware for this router? Thank you for the great work!
  65. Victek

    Victek Network Guru Member

    Good morning all!, Betas 1.2f2 fix BW limiter as eahm said and I did some changes in AC-66U wireless settings (fixed US as default country.. but it can be overwritten by the CFE countrycode). I expect BW limiter reports and if it works as expected (no reboots and fine control) we'll go to fix other, roadmap:

    *- Local/remote https access. (solved) 09/26/2103
    *- Update for dnsmasq v2.67test16 version. (done) 09/26/2013
    *- Update to SDK6 for wireless RT-N66U/AC-66U. (don't have routers to test)
    *- WNDR3700 v3 integration. (don't have routers to test)
    *- IPv6 (good information @Lorenceo ) I will hire IPv6 service...
    *- IPTV. (don't have IPTV to test)
    *- Can't initialize Sierra 330 LTE modem when it hangs, need to unplug-plug again. (don't have units to test)
    *- Captive Portal broken. (solved) 09/26/2013
    *- First beta for RT-AC56U. (I have the unit)
    *- ... and 23 more wishes in the queue...

    You can see that almost of items requires the device or service and it's the reason why testing and good feedback from users is needed.

    Thanks! ;)
    Last edited: Sep 26, 2013
    Elfew likes this.
  66. Elfew

    Elfew Addicted to LI Member

    Your day has 48hours and week 14days, not?! :)
  67. Victek

    Victek Network Guru Member

    Last edited: Sep 25, 2013
    Elfew likes this.
  68. CowMix

    CowMix Addicted to LI Member

    Hey Victek should the new build fix the qos crash bug? Will flash soon. Is nvram erase required? Thanks!
  69. Lorenceo

    Lorenceo Networkin' Nut Member

  70. nurofen

    nurofen Serious Server Member

    Victek, One can try? Working or not? IPTV :) Tonight put the new firmware.

    I'll try to help you a little bit of money.

    And if you look at the source code of the official firmware how it works IPTV.

    thank you
    Last edited: Sep 25, 2013
  71. Victek

    Victek Network Guru Member

    No, for RT-AC66U I need more work. Item nº 3 in the list.
    As expected, I didn't touch anything about IPv6. Item nº5 in the list.
    Don't try because as I said I in my post I go by order. Item nº6 in the list.

  72. Elfew

    Elfew Addicted to LI Member

    @Lorenceo - are you sure that it is working in stock firmware? Is there any special settings in original firmare for it?

    @Victek - how many units do you have in your bedroom? :D I am going to flash new beta
  73. RonV

    RonV Network Guru Member

    I don't have the BW Limiter enabled but I do use QOS and have about 25 rules. I always follow what I have read here in the board and enableing QOS and BW Limiter is a bad idea. I did try BW Limiter with Toasman's release and it didn't cause any reboots but I was getting very random respnses from devices in he area of thoughput and a lot of aborted file transfers.

    What is it you are attemping to do with BW Limiter that would not work with QOS?
  74. Victek

    Victek Network Guru Member

    As far I know ASUS maintain radvd, Openwrt is maintaning, dd-wrt is maintaining too, Oleg WL500g is doing porting now based on Tomato information ...

    Some.. but now I work with RT-N16U and E4200, RT-N66U die two months ago.
  75. Victek

    Victek Network Guru Member

    RonV , give a try now to BW Limiter and QoS together... it should work with latest changes I did, both are separated, don't share kernel modules.
  76. Elfew

    Elfew Addicted to LI Member

    @Victek - radvd - new version 24/9/2013 1.9.4 RC4

    September 24, 2013 - Version 1.9.4-rc2 updates:

    • IPv6 forwarding setting should be 1 or 2
    • Performance fix in netlink message processing
    • fix for kernels with no NETLINK_NO_ENOBUFS defined
    • distributing gz, bz2 and xz tarballs
    • also distributing md5, sha1, sha256 and gpg signatures
    Maybe update would fix the problem with IPTV
  77. Victek

    Victek Network Guru Member

  78. Elfew

    Elfew Addicted to LI Member

    Srry I didnt mention this... I am on smartphone.

    My mistake - RADVD was replaced by DNSmasq - srry
    Last edited: Sep 25, 2013
  79. Lorenceo

    Lorenceo Networkin' Nut Member

    Yes, IPv6 works on the stock Asus firmware without issue. No, no special settings. Set it to DHCP-PD and it works. However I don't want to use the stock firmware. I far prefer using Tomato. :)

    I'm currently using an older Toastman version (v1.28.7501) on an N16 that the N66U was meant to replace. (My N66U is sitting doing nothing until I can find a version of Tomato on which v6 works.) The older version uses radvd for router advertisements.
    On its stock settings v6 works, but it announces the incorrect MTU, which breaks some websites and services. I've got it starting radvd manually with a custom radvd.conf, and a script repeating every few minutes to test whether radvd is still running, as it crashes at random.

    As long as dnsmasq can announce the correct MTU with its router advertisements, hopefully it'll all work. When the other issues are solved first, though.
  80. Elfew

    Elfew Addicted to LI Member

    Maybe *- Update for dnsmasq v2.67test16 version. could solve it...
  81. Lorenceo

    Lorenceo Networkin' Nut Member

    You'd have to ask Victek. I tried to download the source code and have a look myself but failed miserably, so can only report on the symptoms.
  82. Victek

    Victek Network Guru Member

    Well, tomorrow new beta, it will be v1.2g. Changelog:

    *- dnsmasq updated to date 25sep2013. @Lorenceo test IPv6.
    *- BW limiter working as far I know..
    *- Captive Portal working, when BW limiter was solved Captive Portal restored...

    Last edited: Sep 25, 2013
    radionerd, Elfew and ilkevinli like this.
  83. ilkevinli

    ilkevinli Network Guru Member

    Man Vic you are a work-a-holic .... LOL :D :D

  84. Darius510

    Darius510 Reformed Router Member

    Hey Vic, I've got a feature request. It'd be great to save basic configuration options like your static IP designations, your SSIDs, etc. It's super annoying to have to re-enter all that stuff manually every time you erase the NVRAM. I understand why the low level configuration stuff needs to be wiped, but there's has to be a way to at least save some of it.
  85. fubdap

    fubdap Addicted to LI Member

    Great idea!!!
  86. Darius510

    Darius510 Reformed Router Member

    So I tried out the speedtest version on my E3000....good news and bad news.

    The good news is that bandwidth limiter works...sort of. On non-speedtest versions, just enabling it limited my bandwidth to 75mbps or so. On the speedtest version, I could get my full 110mbps with it enabled, and it hardly seemed to slow down the router at all.

    The first problem I encountered, is that I tried to limit the bandwidth of one IP just to test it.... It popped up with a message that the IP was out of the LAN, which obviously isn't right. I tried it by mac address and it works, but it only limits the download bandwidth properly, not the upload.

    I also gave QoS a shot, and it seems like I can hit about 100mbps with it on, which is a HUGE improvement over the 60mbps that the non-speedtest version gave me on the e3000.

    All this time I've been trying router after router to find something that can do QoS/BW Limiting on my 115/35 connection, and none of them even came close until I tried the speedtest version. So whatever you're doing to speed everything up, it's totally working, I'm super impressed!

    Are you likely to port this version to the AC56u? I figure between the optimizations and the increased CPU power of the dual core AC56u, it should easily be able to handle 115mbps.
  87. Darius510

    Darius510 Reformed Router Member

    So I did a little more testing. Disabled inbound layer 7 (what does that do anyway?), and I can get full speed with QoS on!

    I'm running a constant ping to a nearby server, and then downloading at full speed to test the effect it has on latency. Normally it pings around 10ms.
    Without QoS, it downloads at 110mbps, and pings jump to around 40.
    On non-speedtest builds, it downloads at 60mbps, the router becomes non-responsive, and pings jump to 80ms.
    On speedtest build, I limited the IP to 80% inbound, it downloads at 88mbps, and pings only jump to 15ms.

  88. Lorenceo

    Lorenceo Networkin' Nut Member

    Tried v1.2g. Still shows: traceroute: can't connect to remote host: Network is unreachable
    The router picks up its IPv6 prefix but shows the above when trying to connect to v6 hosts.

    A bit of progress though. Router advertisements are sent out, but clients report the following:
    Also the MTU in the router advertisements is still 1500. Dnsmasq isn't getting the MTU option from nvram get wan_mtu, I think.
    Also in the router advertisements it is announced that I have a /64 prefix, when I in fact have a /48. I've set this, along with DNS IPs on the IPv6 options, and neither are showing up in the router advertisements.
  89. koitsu

    koitsu Network Guru Member

    Do you have a default route for your IPv6 network? netstat -r -n should show such.

    There used to be a problem with a "spurious default IPv6 route" being added (this is back when dhcp6c was used), as documented here but be sure to read my follow-up -- but all that was supposed to be addressed by now. (I haven't used IPv6 myself since that whole debacle)

    If you think the issue really is with MTU and is based on the NVRAM variable wan_mtu, then why not kill dnsmasq (make note of what its flags/options are via ps first), then nvram set wan_mtu=xxxx ; nvram commit, then start dnsmasq manually, then nvram set wan_mtu={previousvalue} ; nvram commit and see if the issue resolves itself.
  90. Lorenceo

    Lorenceo Networkin' Nut Member

    No, I don't think the issue is with MTU. I'm saying that the MTU (and values entered in the IPv6 GUI being ignored) is an issue in addition to all v6 hosts being reported as unreachable. I discussed the MTU problem with Victec via PM a while ago now.
    netstat -r -n doesn't show any v6 information on my N16 with an old Toastman version. v6 works on this router (with radvd being run manually with a custom config), are you sure that's the correct command?
  91. koitsu

    koitsu Network Guru Member

    Ah, right... sigh, Linux and Busybox... Try route -A inet6 -n as well as ip -6 route (these will output two related yet different things).
  92. Lorenceo

    Lorenceo Networkin' Nut Member

    I ran:
    I've PM'd you the results @koitsu. If you're interested @Victek I can send them to you as well.
    Last edited: Sep 26, 2013
  93. Victek

    Victek Network Guru Member

    Thanks for your complete test, the E3000 is a poor platform and I agree that some of these jobs overload the hardware.
    The comparison made between two Tomato RAF versions, the current branch and the Speedtest branch; can't be compared now because last changes are not ported to Speedtest version yet. The current branch it's updated with latest patches, the Speedtest version is a basic and naked branch oriented only to max. bandwidth.

    About RT-AC56U.. it will share Tomato features but the kernel and almost of functions run in another environment (ARM) and also the code it's slightly different.

    About QoS, I read it and behaviour is as expected, it loads a bunch of rules to netfilter, so, it's normal what you mention.

    In any case I keep your test because is one guide for next changes in Speedtest version ;)

    @Lorenceo , thanks I'm seeing it now... and found the bug, it's not in dnsmasq module! :)
  94. Elfew

    Elfew Addicted to LI Member

    @ Victek - so you found issue in code? IPv6 and maybe IPTV would work in next release?

    anyway, I flashed new beta - BW limiter enabled - no problem and no disconnetions.
  95. mahi2003

    mahi2003 Reformed Router Member

    I too got a bit fed up of manually entering all information over and over again after erasing the nvram. It is not recommended to save the entire nvram to a file and restore it after erasing the nvram and/or updating the firmware - the nvram contains a lot of settings that might change/interfere between firmware versions. However, most of the information entered by the user in the web interface does never or rarely change. So why not isolate these lines from the nvram?

    Here's what I did: I dumped the nvram configuration of a cleared (and rebooted) router and a fully configured router. Each has over a thousand nvram entries. I then compared both dumps and generated a differences file. I had somewhat hoped this differences file would contain just the settings I manually entered in the web interface, but it still contained several hundreds of nvram settings I never touched. It seems when you save a page in the web interface it will not only save the changed fields, but every field on that page. So if you change, for example, "Transmit Power" on the "Advanced > Wireless" page and save it, the nvram will be updated with all settings on that page. Even though you did not change other settings on that page like "Fragmentation Threshold" of the 5 GHz radio, the nvram will be updated with their entries like wl1_frag="2346". I don't think that is necessary because those are the default values.

    After a bit of experimenting I managed to isolate the entries from the differences file that I manually changed in the web interface. Well, there are still a few entries like "wl0_nbw_cap" and "wl0_lazywds" I'm not entirely sure about, but the rest should be mine. The result for my configuration is about 30 nvram entries. These are all quite elementary settings and I don't think they will change any time soon in Tomato, so it should be safe to take these nvram entries with me every time I upgrade the firmware and/or erase the nvram.

    After the router has rebooted I simply open a telnet session to it and paste following block of settings (you could probably also use "Tools > System" and paste the block in the "Command" field):
    nvram set cstats_path="/mnt/usb/stats/"
    nvram set cstats_stime="1"
    nvram set dhcpd_static="### list of static hosts ###"
    nvram set http_passwd="### webadmin password ###"
    nvram set ipv6_radvd="0"
    nvram set lan_hostname="### host name ###"
    nvram set pci/1/1/ccode="EU"
    nvram set pci/2/1/ccode="EU"
    nvram set portforward="### list of forwarded ports ###"
    nvram set router_name="### router name ###"
    nvram set rstats_path="/mnt/usb/stats/"
    nvram set rstats_stime="1"
    nvram set sshd_dsskey="### key ###"
    nvram set sshd_eas="1"
    nvram set sshd_forwarding="0"
    nvram set sshd_hostkey="## key ###"
    nvram set sshd_port="### ssh port ###"
    nvram set trigforward=""
    nvram set upnp_enable="0"
    nvram set upnp_lan="0"
    nvram set wan_hostname="### host name ###"
    nvram set wl0_akm="psk2"
    nvram set wl0_channel="11"
    nvram set wl0_chanspec="11"
    nvram set wl0_country="EU"
    nvram set wl0_country_code="EU"
    nvram set wl0_lazywds="0"
    nvram set wl0_nbw="20"
    nvram set wl0_nbw_cap="0"
    nvram set wl0_net_mode="n-only"
    nvram set wl0_security_mode="wpa2_personal"
    nvram set wl0_ssid="### ssid ###"
    nvram set wl0_wpa_psk="### shared key ###"
    nvram set wl1_radio="0"
    nvram set wl_country_code="EU"
    nvram commit
    The last two lines save the changes to the nvram and reboot the router. After that the device is configured as if I had done it manually but it took me only a few seconds of work.
    zavar likes this.
  96. Victek

    Victek Network Guru Member

    ;) .. it's what I do in the inside tools router menu .. but in my case a little different cause I have to configure vlan's,pppoe,web server, so, in resume.. what I do is:
    Default nvram in txt file
    Configured nvram in txt file

    Make a diff and add 'nvram set' to all different values.. and that's all, paste into tools/command window.. commit and reboot.

    zavar likes this.
  97. Darius510

    Darius510 Reformed Router Member

    The speedtest version seems stable and fast though. Is there any reason I shouldn't continue to use it?

    I'm hoping that future speedtest versions would get faster, not slower. I really don't need a lot of the fancy features, just a ast stable router with good qos.
  98. Victek

    Victek Network Guru Member

    Of course not!, Speedtest version is growing now, I just started, my intention is to become the future Tomato base platform.
    By the way .... and I'm happy to announce it.. local/remote access bug solved ... one item less in the TODO list... 'unfortunately' ;) I'll release another beta version soon. The origin? Openssl 1.0.1e switches change.

    Sep 26 14:56:43 unknown daemon.notice miniupnpd[866]: version 1.8 started
    Sep 26 14:56:43 unknown daemon.notice miniupnpd[866]: HTTP listening on port 34832
    Sep 26 14:56:43 unknown daemon.notice miniupnpd[866]: Listening for NAT-PMP traffic on port 5351
    Sep 26 14:57:23 unknown daemon.info httpd[991]: Generating SSL certificate...
    Last edited: Sep 26, 2013
  99. zavar

    zavar Networkin' Nut Member

    Thanks mahi2003 and Victek for this, it looks like a great way for easy router configuration. What utility do you folks use to do the diff?

    Will this work if I do a dump of my current config, upgrade to a new version and dump the defaults and then do a diff between these two dumps?
  100. RonV

    RonV Network Guru Member

    I am going to hold off until th weekend to do any update on the N66U. I have AT&T upping my internet from 18 mbps to 45 mbps and doing native IPv6. Once this settles down I will give it a shot.

    Also I have to get a new N16, the board in my prototyping router seems to have given out. All the lights come on and never turn off. I have seen this happen in my old Buffalo's when a capacitor has given out and I think the same may have happend here. All my N16's in the field are spoken for so I am waiting for Amazon to deliver a new one on Friday.

Share This Page