1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato RAF with Captive Portal (NocatSplash)

Discussion in 'Tomato Firmware' started by Victek, May 12, 2011.

  1. Victek

    Victek Network Guru Member

    Hi all,

    Tomato RAF with NocatSplash (Captive Portal) available, no more words needed, not? ... well, yes, User Manual for new function is included in the menu. Please relax, don't get nervous and search each version for your router before download, upload to your unit and enjoy. Yes, nvram erase is needed during flashing or after first start.

    I will include a Changelog .. or not .. cause in few days you will have new features and new version... :eek:

    Version for WRT54GL solved problems with bandwidth using kernel 2.6, >50mb/BW.

    As always you can download in my site, Tomato RAF section. My Thanks to all the people helped me in this integration with special mention to Roadkill. :wink:
     
  2. ddd1

    ddd1 Networkin' Nut Member

    Thanks Victek! Is this release with Transmission or not?
     
  3. Victek

    Victek Network Guru Member

    No, I separate BT for other releases. With the adequate git combination you can build a 'Mega' version.
     
  4. molnart

    molnart Networkin' Nut Member

    I hope shibby will soon release new builds combining Victek's latest features and Transmission (and maybe the client monitor from Toastman) :)
     
  5. shibby20

    shibby20 Network Guru Member

    yes i will. Client monitor you can add yourself. This is 4 lines of code :) And you can add grafs for every users, not for only one.
     
  6. CBR900

    CBR900 LI Guru Member

    Or may be Victek can include the client monitor.
     
  7. shibby20

    shibby20 Network Guru Member

    @Victek - great work!! Gratz. But do you know, that BW limiter doesnt work?
    I tested Tomato RAF 1.28.9001 USB+VPN+Captive Portal on wl 500gp v1.

    More info: http://tomatousb.org/forum/t-358163/module-xt-mark-is-broken

    @CBR900 - if you have my tomato you can add client monitor yourself:
    - advanced -> firewall -> numdevs set 4 (imq0,1,2,3, but imq0 and imq1 are reserved for bw limiter), save and reboot.
    - in firewall script add:
    where 192.168.1.*** is a client ip.

    Do you want monitor for more client? No problem
    ingrees numdevs +2 and add to firewall another rules for other ip client etc. With this solution you can add max 7 client.
     
  8. occamsrazor

    occamsrazor Network Guru Member

    That would be awesome... Or Toastman could make a build from Victek's including both.
    I have to say the variety of builds these days gets quite daunting.....
     
  9. occamsrazor

    occamsrazor Network Guru Member

    This is maybe a dumb question, but can NoCatSplash restrict access for clients to only the WAN, and prevent access to the LAN?
     
  10. Azuse

    Azuse LI Guru Member

    I assume the xbox nat-pmp problem is fixed?
     
  11. CBR900

    CBR900 LI Guru Member

    Hi...

    I have Tomato Firmware 1.28.0905 MIPSR1-047 K26 USB VPN-BT installed in wl 500gp v1.

    Lan IPs range from 192.168.1.3 to 192.168.1.9

    could you list the steps to get it working.

    10x
     
  12. shibby20

    shibby20 Network Guru Member

    advanced -> firewall -> numdevs set 16, save and reboot

    to firewall script add:
    set only USER name.

    After reboot you should see graphs in bw realtime and last 24h :)
     
  13. Victek

    Victek Network Guru Member

    Nocat as it's configured shows the banner to LAN and WLAN clients, it's a information (publicity-promotion) notice only.

    Regards!
     
  14. Toastman

    Toastman Super Moderator Staff Member Member

    Nice work Vic!
     
  15. Victek

    Victek Network Guru Member

    Thank you dear :biggrin: I'll post code in git today. Do you remember when we talk about 1 year ago? ... we are older, but with the same illusion as teenagers... :rolleyes:
     
  16. bogderpirat

    bogderpirat Network Guru Member

    i sometimes consider using my <ERASED> as an avatar - not to make people jealous, but to make them feel compassion for me so they'll help me better.
     
  17. Azuse

    Azuse LI Guru Member

    Well the GUI OC option is missing, but despite the 50mhz drop in speed this k2.6 build is smoother than the k2.4 it replaced and the xbox issue has been fixed :)

    Couple things, first, now that there's a default class for unlisted ip in the mac limiter must I select just it or limit unlisted machines also and what is the difference? Why is the RTSP NAT Helper disabled by default?

    Second, bug. Qos > Class. double click on a number in the # column and the class editing will open but you're unable to edit or move the class (or any other). You have to leave the page to fix it.

    Also I suspect the BW Limiter isn't working, will check when I have a chance.

    N.B. this build really doesn't like large numbers of connections. With UDP time-outs at 10 sec updating steam server list takes a lot longer than it did on k2.4 with cpu load hitting 0.7/8 with spikes of 1.9.
     
  18. Victek

    Victek Network Guru Member

    1. As I said time ago, OC don't affect to router performance, GUI flights .. but nothing more.
    2. Yes, select unlisted machines, fix down/up speed and that's all. Difference is that previously unlisted machines was not locked by BW limiter.
    3. I don't know, no interested in QoS (this is the reason for BW limiter feature).
    4. BW limiter is working fine in my case, bring more information.
    5. Please run iperf or jperf and check number of wires and BW. I'm able to run 780 connection with a BW of 35mb, 500 conn. with 65mb BW, and 100 conn. with 80mb BW.

    Thank you for xbox info, good for reference to other.
     
  19. Azuse

    Azuse LI Guru Member

    1. If you say so it's good :)
    2. So you mean enable both?
    4. Having done so prodding it's working, odd glitch I guess. (WRT54GL)
    5. I have no clue what either of those are :biggrin: but this line is only 11mb and I don't currently have access to a second pc or router to check. Refreshing steam sever lists basically simulates a connection storm. Even with udp time-outs at 10sec it climbs to ~1900 after 5 seconds with cpu at .9/.95. If I were to guess I'd say it's just the limit of an old cpu, not your coding :drinking:
     
  20. shibby20

    shibby20 Network Guru Member

  21. Victek

    Victek Network Guru Member

    shibby, ;) I read you earlier post .. sorry.. but I tested in WRT54GL, WL500gP V1, RT-N16, E3000 .. and it works in my case. Did you erase nvram?
     
  22. shibby20

    shibby20 Network Guru Member

    many times :/
     
  23. DAVIZINHO

    DAVIZINHO Networkin' Nut Member

    devife mesionsi

    hello victek,
    Great release, i will try it.
    i what to use asus RT-N16 with tomato with FTTH of movistar (spain).
    In previous version i configure it manually throught telnet.
    In this version exist other method more easy?

    thanks a lot
    -Davizinho-
     
  24. Victek

    Victek Network Guru Member

  25. Azuse

    Azuse LI Guru Member

    This is interesting. Eve has been constantly dropping. Checked the f8lure graphs (server pinging the router) and got this.

    Normal f8lure graph (k2.4)
    [​IMG]

    k2.6 graph
    [​IMG]

    Lan was inactive between 02:00 & 10:00, but the router isn't responding correctly to pings in either case :(

    Edit: reverted to k2.4 (1.28.8525) at 17:00;

    [​IMG]
     
  26. Victek

    Victek Network Guru Member

    If Nocat was active and Eve was in the net ... that's normal :), you should push AGREE ....
     
  27. virgil

    virgil Network Guru Member

    RT-N12 BW limiter not working

    I am running on RT-N12 with RAF1.28.9001 MIPSR2_RAF_NOCAT K26 Std. Seems like BW limiter isnt working for me either.

    Am also puzzled by the CPU load which jumps from normal (<0.1) to close to 1.0 and stays there consistently.

    Yes - I had reset the Flash NVRam after updating FW (from Asus original) and reloaded settings manually. Have also reboot the RT-N12 manually. Why? - even the Reboot via the GUI doesn't seem to work...
     
  28. Victek

    Victek Network Guru Member

    Then and since I have no chance to test this router I recommend you to try another build. This CPU load is unacceptable, change firmware please.
     
  29. Azuse

    Azuse LI Guru Member

    Nocat is not active, the router is either not responding correctly, response is delayed or failing to respond to icmp pings on the wan. I've reverted to k2.4 for a couple of days. I'll trying k2.6 again in a few days, redoing everything from scratch.

    If you have a WRT54GL it would be easy to test no? :)
     
  30. Victek

    Victek Network Guru Member

    Azuse, Unfortunately no WRT54GL is available, sold one month ago to get more space :)
     
  31. valerima

    valerima LI Guru Member

    last toastman files cannot be downloaded

    Hi, Toastman,

    Tried it some hours ago and just now. It cannot be downloaded from 4shared...
     
  32. altdel

    altdel Networkin' Nut Member

    Does latest E4200 firmware support 5GHz ?

    Hi Victek,

    Does your latest firmware for Linksys E4200 (tomato-E4200USB-NVRAM60K-1.28.9001MIPSR2_RAF_NOCAT-VPN.bin) support 5GHz radio? (i.e., uses the Broadcom driver blob for BCM4331 supplied in the Netgear WNDR4000 GPL release).

    I'm currently running my E4200 on a beta version of TomatoUSB, can I just flash your firmware file from my current firmware?

    Thanks,

    altdel
     
  33. valerima

    valerima LI Guru Member

    download still not possible

    Hi, Toastman,

    I see the changes in uploaded files, but still cannot download though.
    1st post I made was from home , now from working place- different conditions, IT providers, etc. ...But result still the same.
     
  34. virgil

    virgil Network Guru Member

    Thanks Toastman.
    But I am not sure if K2.4 is supported on RT-N12. As per Victek's page:


    What release should I use? Can I install this firmware in my router?

    Router | CPU Architecture | Kernel 2.6 | Kernel 2.4 | Kernel 2.6 Editions
    Asus RT-N12 | R2 _ _ _ _ | _ _ Yes _ _| _ _ No _ _| _ No USB
    Asus RT-N16 | R2 _ _ _ _ | _ _ Yes _ _| _ _ No _ _| _ All

    Has anyone tried K2.4 on RT-N12?
     
  35. shibby20

    shibby20 Network Guru Member

    ONLY K2.6 MIPS2. RTN10/12/16 are not supported by k2.4
     
  36. Victek

    Victek Network Guru Member

    Would you (all of you) post about NocatSplash feature in Tomato-RAF, thank you :biggrin: This is the post subject.
     
  37. vincom

    vincom LI Guru Member

    shibby20s ip bandwidth monitor not accurate

    followed the steps outlined by shibby20, but the bandwidth rate is low for which the actual ip is using, if im downloading lets say 400kbytes of data, monitor is only seeing 5kbytes, same problem with the upload rates, using Tomato Firmware 1.28.0905 MIPSR1-053 K26 Std on a WRT54G-tm router, i enabled imq and set it to 4, rebooted, code i put in the scripts/firewall section is

    ip link set imq2 name vince_IN up txqueuelen 100
    iptables -t mangle -A POSTROUTING -d 192.168.1.133 -j IMQ --todev 2
    ip link set imq3 name vince_OUT up txqueuelen 100
    iptables -t mangle -A PREROUTING -s 192.168.1.133 -j IMQ --todev 3

    rebooted again, i do see the vince up and vince out in the bwmonitor, but the rates are really low.
    any help would be appreciated shibby20
     
  38. isulistiawan

    isulistiawan Networkin' Nut Member

    I have done flashing my WRT54GL v1.1 with Tomato RAF 1.28.9001 Captive Portal . but not only BW Limiter not work but IP range for BW Limiter not work to . . . .:frown:
     
  39. shibby20

    shibby20 Network Guru Member

    @vincom do you use qos? I tested this method on my wl500gp and i see correct rates.

    btw im working now on client monitor:
    http://update.groov.pl/cmon.png

    i have to fix few problems but looks and works nice ;)

    @isulistiawan - if i good remember in this build Victek didnt revert MARK module. This is a reason why bwlimiter wont works. You can try my build. Its based on Tomato-RAF and bwlimiter works correct. When Victek fix this problem you will go back to his builds :)
     
  40. Victek

    Victek Network Guru Member

    New release 9006 in my site, changelog; clean start of nocat and BW limiter hicks solved.
     
  41. vincom

    vincom LI Guru Member

    no qos, im using WRT54G-tm, was on your build and it wasnt working correctly, will try vics 9006 release, btw i like your client monitor shibby, cant wait 4 final release
     
  42. vincom

    vincom LI Guru Member

    not using qos, imq seems to work but bandwidth reading does not, used victeks 9006 and urs shibby, tried victeks bw limiter it also doesnt work, i cleared nvram and rebooted , cant seem to get either client ip bw monitoring or bwlimiter to work
     
  43. shibby20

    shibby20 Network Guru Member

    check my build5x-055 version ;)
     
  44. Rudi1

    Rudi1 Network Guru Member

    Did you made this new build for Linksys wrt160n v3 too ?

    thx!
     
  45. vincom

    vincom LI Guru Member

    tried shibbys client monitor version 55 (Tomato Firmware 1.28.0905 MIPSR1-055 K26 Std) on WRT54G-tm, but bandwidth is almost nil(less than 2 kbyte when im actually downloading at 400 kbytes) on the ip i choose to monitor, i enabled imq, set it to 2, saved and rebooted, then i enabled client monitoring, input the ip and name for ip.
    even on previous mods like victeks, i did it manually, and the bandwidth for the ip client is really low, just as above with client monitor, not using qos or bw limiter, any ideas shibby
     
  46. jeff_tay

    jeff_tay Networkin' Nut Member

    hey guys, this may be the wrong place for this question, and I apologize for that, however I don't know where else to ask this question. ok, i have an E4200 running tomato-E4200USB-NVRAM60K-1.28.9006MIPSR2_RAF-VPN-NOCAT firmware. When I update the captive portal to my own, and save, it works. but if i restart the router it vanishes. what is happening here? is the default location /tmp/splashd/splash.html the cause? does my custom portal page have to be named "splash.html"? because i have been naming it that. I couldn't get the router to show a page hosted on my site, only the custom page uploaded to the router, and never after router reboot. so, I guess what I'm asking is, can I change the location of the custom portal splash.html to make it stay after reboot? or how do I enter the address for my page hosted on my website. because http://www.website.com/spash.html isn't working. that is my main problem and I can't seem to figure it out. If anyone else works with tomato and uses the captive portal please provide any input you might have.
     
  47. ntest7

    ntest7 Network Guru Member

    The /tmp directory is a ram-based filesystem and is lost at power-off.
    Either enable JFFS or add a usb drive for your spash page.
     
  48. jeff_tay

    jeff_tay Networkin' Nut Member

    Thank you very much, that's what I was wondering! I will give that a try tomorrow! This is going to sound really novice but I'm new to tomato/custom firmware, what would the location be if my splash.html is on a flash drive then attached to my E4200?
     
  49. ntest7

    ntest7 Network Guru Member

    by default the USB will show up in /mnt/NAME where NAME is the volume name of the usb drive.
     
  50. jeff_tay

    jeff_tay Networkin' Nut Member

    Thank you very much! I have not seen any information regarding custom splash pages with Tomato on any of the sites I've been looking at.
     
  51. Victek

    Victek Network Guru Member

    Simply copy the html of the splash page and then modify at your style, mount in your USB and point the location on the Nocatsplash menu.
     
  52. jeff_tay

    jeff_tay Networkin' Nut Member

    I updated the location of my captive portal splash.html to be stored on the USB drive, and that seems to be staying up after router reboot. However, after a day, when I come in and check the connection, the captive portal seems to not be working properly. I obtain an IP from the router, can connect to the router, but the captive portal doesn't show up until I go in to tomato, disable and re-enable the captive portal, then it works again. Does anyone know why it could be stopping like that? It's happened overnight twice. I did have a rule in place to disable wifi from midnight to 3am, I don't think that would do it right? Somehow it's just deciding to not show up, blocking guests when it does. If anyone has experienced this or has any clue what setting might be my cause I would greatly appreciate it. A few of my settings are, 24 hr dhcp lease time, 2 hour window with no captive portal after agreement, 100 addresses for guests with bandwidth limitations. All seem to be working minus the disappearing captive portal. On a side note, I also opted to use OpenDNS, which works fine when the captive portal is disabled, but once I enable it OpenDNS does not block anything. Does anyone know why? is it because the captive portal is using another port than OpenDNS does? is that even possible? either way I've tested that numerous times and they don't work together... any advice guys???
     
  53. jeff_tay

    jeff_tay Networkin' Nut Member

    update:
    Since I disabled the rule to turn of internet during the night, the captive portal stays on now. that must have had something to do with it. also, OpenDNS seems to work just fine with it now and i didn't change anything, maybe it is just buggy. however i did notice when I save some changes and "some services are being restarted" this can also knock the captive portal offline again. so i disable and re-enable it then it works. i just wanted to post this info in case it helps with future updates/fixes.
     
  54. jeff_tay

    jeff_tay Networkin' Nut Member

    I'm storing my splash.html on a usb drive, with the location like you guys said, but as of today the captive portal still went off. I thought I had it fixed because it worked for a whole day but something else is wrong. has anyone seen this before???
     
  55. zckorpio_

    zckorpio_ Reformed Router Member

    Hello, my name is ivan writing from Chile, a pleasure to participate in its web. :)

    I have the WRT54GL with Tomato RAF 1.28.9006 Captive Portal. I can not configure the Captive Portal. :(

    Someone can give me the instructions to do so?:rolleyes:

    I'm a newbie


    Greetings and thank you very much
     
  56. Victek

    Victek Network Guru Member

    Instructions are in the User guide below the User Interface, where are you stacked?
     
  57. zckorpio_

    zckorpio_ Reformed Router Member

    Hello Victek

    The problem is I do not understand much, I find the panel where you add users and assign passwords for my wifi connections.

    Have any tutorials that teach you to do step by step?


    You speak Spanish?

    regards
     
  58. Victek

    Victek Network Guru Member

    ;) Yes, I'm Spanish, send me e.mail, you can find my e.mail visiting the web site and click in 'contact' tab, top page at right.

    Thanks!
     
  59. zckorpio_

    zckorpio_ Reformed Router Member

    Thankz, gracias, no sabes como apreciaré tu ayuda ;)
     
  60. Brandon

    Brandon New Member Member

    @Victek - is there a reason that you excluded --with-remote-splash and --with-ghttpd from the NoCatSplash build, and SplashURL from the interface?
     

Share This Page