1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tomato shibby v140 systemd/sd-daemon.h: No such file or directory

Discussion in 'Tomato Firmware' started by oglops, Jul 10, 2017.

Tags:
  1. oglops

    oglops New Member Member

    Hi I was trying to build v140 with default toolchain, but I am getting

    Code:
    make[5]: Entering directory '/home/oglop/tomato/release/src/router/tor'
    make  all-am
    make[6]: Entering directory '/home/oglop/tomato/release/src/router/tor'
      CC       src/or/config.o
      CC       src/or/confparse.o
      CC       src/or/connection.o
      CC       src/or/connection_edge.o
    src/or/config.c:66:31: error: systemd/sd-daemon.h: No such file or directory
    src/or/config.c: In function 'options_act_reversible':
    src/or/config.c:1172: warning: implicit declaration of function 'sd_notifyf'
    src/or/config.c:1172: warning: nested extern declaration of 'sd_notifyf'
    Makefile:3589: recipe for target 'src/or/config.o' failed
    make[6]: *** [src/or/config.o] Error 1
    make[6]: *** Waiting for unfinished jobs....
    make[6]: Leaving directory '/home/oglop/tomato/release/src/router/tor'
    Makefile:2090: recipe for target 'all' failed
    make[5]: *** [all] Error 2
    make[5]: Leaving directory '/home/oglop/tomato/release/src/router/tor'
    Makefile:2556: recipe for target 'tor' failed
    make[4]: *** [tor] Error 2
    make[4]: Leaving directory '/home/oglop/tomato/release/src/router'
    Makefile:118: recipe for target 'all' failed
    make[3]: *** [all] Error 2
    make[3]: Leaving directory '/home/oglop/tomato/release/src-rt'
    Makefile:1023: recipe for target 'bin' failed
    make[2]: *** [bin] Error 2
    make[2]: Leaving directory '/home/oglop/tomato/release/src-rt'
    Makefile:1140: recipe for target 'm' failed
    make[1]: *** [m] Error 2
    make[1]: Leaving directory '/home/oglop/tomato/release/src-rt'
    Makefile:1207: recipe for target 'r2m' failed
    make: *** [r2m] Error 2
    
    I have my custom build which works fine in v138, but with v140, it has the above error. So I tried default max build with
    Code:
    make r2m
    
    But it still fails. I am on fedora 25.

    toolchain is in PATH
    Code:
    sudo ln -s ~/tomato/tools/brcm /opt/brcm
    export PATH=$PATH:/opt/brcm/hndtools-mipsel-linux/bin:/opt/brcm/hndtools-mipsel-uclibc/bin
    
     
    Last edited: Jul 10, 2017
  2. oglops

    oglops New Member Member

  3. oglops

    oglops New Member Member

    problem solved by disabling systemd in dnscrypt and tor configure command(I thought on tomato there is no systemd), and removed systemd detection code in dnscrypt configure.ac
     

Share This Page