1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Shibby's Releases

Discussion in 'Tomato Firmware' started by shibby20, Feb 26, 2011.

  1. Elfew

    Elfew Addicted to LI Member

    confirmed...
     
  2. nick ant0ny

    nick ant0ny Networkin' Nut Member

    Hi,
    i have noticed that in the 092 v there is no ipv6 routing in other vlans i create. Only in the br0. is this an issue anyone else has noticed?

    thanks
     
  3. anpak

    anpak Networkin' Nut Member

    Hi shibby...have you resolved the issues with DLNA&PS3 with new release??? thanks a lot
     
  4. shibby20

    shibby20 Network Guru Member

    no, i haven`t PS3.
     
  5. CBR900

    CBR900 LI Guru Member

    Will tor be added?

    Sent from my U8860 using Tapatalk 2
     
  6. shibby20

    shibby20 Network Guru Member

    I have already compiled tomato with tor but im thinking about the GUI :) well TOR will be in tomato but i don`t know when i finish GUI.
     
    CBR900 likes this.
  7. CBR900

    CBR900 LI Guru Member

    I hope it will fit in my router
     
  8. nick ant0ny

    nick ant0ny Networkin' Nut Member

    Hi shibby!
    have you checked the problem with the ipv6 working on other vlans except only br0 in v092?

    thanks
     
  9. shibby20

    shibby20 Network Guru Member

    i havent ipv6 yet :) well i cant test it but will look into sources. Maybe i will find solution.
    can you send me your /etc/iptables and ip6tables?
     
  10. molnart

    molnart Networkin' Nut Member

    i have a problem with Bandwidth and IP monitoring in build 92 on Linksys E3000. i have set the path /opt/tomato/BandwidthUsage/ for the rstats file location, but when i browse to that directory its empty. i am using the same config on RT-N16 with build 88 and it works flawlessly. any idea what could be wrong?

    edit: Nevermind, it seems i had to manually create the BandwidthMonitor and IPMonitor subdirectories. It seemed to be that these directories where created automaticly in earlier builds...
     
  11. CBR900

    CBR900 LI Guru Member

    is it possible to have one directory for all monitoring and logging?
     
  12. occamsrazor

    occamsrazor Network Guru Member

    Could you clarify what exactly you did please to get it working? Thanks
     
  13. molnart

    molnart Networkin' Nut Member

    i have manually created a /opt/tomato/BandwidthUsage/ directory on my sd card. now the logs are saved as they should
     
  14. nick ant0ny

    nick ant0ny Networkin' Nut Member

    Hi everyone, are there any updates on schedule?

    thanks
     
  15. distantcoder

    distantcoder Network Guru Member

    I was courious if there was any updates on WNDR4000 Port?
     
  16. Elfew

    Elfew Addicted to LI Member

    Any news about update or new features? Thank you!
     
  17. shibby20

    shibby20 Network Guru Member

    it the moment i`m trying to fix Tomato for RT-N66U. I want to release new build when i repair shell problem.
     
  18. Elfew

    Elfew Addicted to LI Member

    OK, good to know! Any new feature or suprise for us? :)
     
  19. BHTeam

    BHTeam LI Guru Member

    Hello.
    Today i got my second 3500L v2 from Netgear. I flashed it with V092 AIO. The flash was good. I can access the router. Internet works fine, etc, etc.
    I found two things that doesn't work on by box/
    1/ Transmission - I tried with both optware and internal options selected, set up the download directory, and when I hit the Save button i get:
    Error setting "global_peer_maximum_limit". Please report this.
    2/ IP monitor can't be enabled. I enable it. All goes well. And when I go to the IP Monitor page it is still not enabled.
    There is nothing logged in to messages about both issues.

    Is there something else i have to do, to get transmission to work? Install it manually or what? Can't seem to find someone else in the forum with those issues.


    EDIT: Please disregard the above. Issue is fixed after a 30-30-30. :) Everything works like a charm now.
     
  20. distantcoder

    distantcoder Network Guru Member

    Will the WNDR4000 run the WNDR4500 Firmware?
     
  21. BHTeam

    BHTeam LI Guru Member

    No, it will not!
     
  22. distantcoder

    distantcoder Network Guru Member

    Drag, I keep hoping, I have had this thing since like Feb, it just sits. Factory firmware is SO BAD. Drag....
     
  23. kenworth

    kenworth Networkin' Nut Member

    Hi All / Shibby,

    I am using K24 1.28.0005 087V ND USB BTgui build. I do not see any option of 3g under USB and NAS.

    I tried searching online and found a couple of shibby's post that 3G option is there on 87V onwards and this build is recommended for 3G WAN users.

    However I do not see any 3G option under 'USB' or 'WAN' options...Do the smaller K24 builds have this feature removed?

    TIA everyone.
     
  24. shibby20

    shibby20 Network Guru Member

    3G support is only in K26. In K24 this feature was never implemented.
     
  25. kenworth

    kenworth Networkin' Nut Member

    Thanks for the confirmation Shibby. Too bad MISRP 1 CPU routers do not run well on K26.
    Would you recommend K26 on Asus 520 Gu?
     
  26. maurer

    maurer LI Guru Member

  27. Mirko Baila

    Mirko Baila Networkin' Nut Member

    Hi shibby!News about the new firmware?
    Tnk's
     
  28. shibby20

    shibby20 Network Guru Member

    i have finished and ready to publish new 093 ;) but we have to wait to 1 june because i nearly reach my monthly transfer limit (120GB) on my serwer (i have now 116GB).
    Well new version will be publish on friday.
     
  29. nick ant0ny

    nick ant0ny Networkin' Nut Member

    :) wow really excited, so what's new on v93 shibby?

    were you able to take a look at the ipv6 problem i had sent you some routing tables time ago.

    Thank you for your hard work man, relly appreciate it!
    Have a nice day.
     
  30. kthaddock

    kthaddock Network Guru Member

    @Shibby
    Which version of Samba is in your 088 and 092/3 build ?

    kthaddock
     
  31. shibby20

    shibby20 Network Guru Member

    @kthaddock - 3.0.37

    @nick_ant0ny - patience ;) did you send me as conversation? I didnt see this thread. Can you send me ne more time?
     
  32. nick ant0ny

    nick ant0ny Networkin' Nut Member

    Hi again! yes i had sent you an inbox. I will send you again so you can take a look before compiling. This is the original post
     
  33. GhaladReam

    GhaladReam Network Guru Member

    Hey shibby, why not post your releases on mediafire or 4shared, that way when users download it, it won't use your bandwidth?
     
  34. shibby20

    shibby20 Network Guru Member

    @kthaddock - 3.0.37
     
  35. kthaddock

    kthaddock Network Guru Member

    Thanks !
     
  36. Badders44

    Badders44 LI Guru Member

    New version? Excellent news! 092 has been rock solid and I'm looking forward to playing with a new version :)
     
  37. Mirko Baila

    Mirko Baila Networkin' Nut Member

    Confirm!The new firmware have the new driver for wireless?
     
  38. BHTeam

    BHTeam LI Guru Member

    Shibby, can you please tell us what's new/updated/changed/fixed in the v93 :)
    Just can't wait till Friday.
     
    Elfew likes this.
  39. Elfew

    Elfew Addicted to LI Member

    Please changelog :)))
     
  40. kthaddock

    kthaddock Network Guru Member

    Why do try to push it when Shibby have stated this???
     
    eahm likes this.
  41. Elfew

    Elfew Addicted to LI Member

  42. shibby20

    shibby20 Network Guru Member

    [RELEASE] 093

    Changelog:
    - Busybox: add WHOIS tool
    - Busybox: fix ash repetear bug
    - Dropbear: 2012.55 update
    - Dnsmasq: 2.61 update
    - Captive Portal: lot of fixes and improvements
    * new style of splash.html
    * selectable interface (br0/1/2/3)
    * fixed PATH in shell files (Thx for @baranek from openlinksys.info)
    * some of patched from dd-wrt
    * add to autostart
    - Add SNMP configuration options for custom port and remote access
    - Remove "CPU % usage" on Status Overview page
    - Transmission: update 2.52
    - New theme for "Dark Knight" RT-N66U ( by Dark_Shadow)
    - Fix menu highlights (Captive Portal and BW Limiter)
    - lot of changes in buildtypes (some removed, add new)

    RT-N builds only:
    - WL 5.100.138.20 SDK: wl binaries, et/bcm57xx drivers, dnsmq module
    - Asus RT-N10U: fix USB led
    - Asus RT-N15U: fix USB led
    - Support Asus RT-N53 (no 5GHz support, 2,4GHz only)
    - WNR3500Lv2 - Fixed display Free NVRAM on Admin->Configuration page (thx @krisan)
    - Add new Linksys E-series routers support (thx @tvlz). More info:
    http://www.linksysinfo.org/index.php?threads/adding-linksys-e-series-support.37444/#post-183837

    Best Regards!
    Have Fun :)
     
    Elfew likes this.
  43. Elfew

    Elfew Addicted to LI Member

    Goooood job!
     
  44. kthaddock

    kthaddock Network Guru Member

    @Shibby
    Asus RT-N xx works to load on RT-N16U ? want to test new driver, experimental.

    kthaddock
     
  45. shibby20

    shibby20 Network Guru Member

    it should. Try :)
     
  46. kthaddock

    kthaddock Network Guru Member

    Thanks !
     
  47. Ed50547

    Ed50547 Network Guru Member

    Awesome work, shibby! E3000 and E4200 just flashed and working fine so far. Anyone tried the E3200 build yet?
     
  48. BHTeam

    BHTeam LI Guru Member

    IS there going to be an update for the WNR3500Lv2? Or may be I am just not seeing it on the website??
     
  49. kthaddock

    kthaddock Network Guru Member

    BHTeam likes this.
  50. BHTeam

    BHTeam LI Guru Member

    hehe I need glasses . Thank you.
     
  51. Elfew

    Elfew Addicted to LI Member

    I miss this feature - I need to schedule turning off/on my virtual wireless network (for example - turn on from 8:00 - 19:00, turn off from 19:00-8:00)... now I can only schedule my home wireless network... I need to schedule both of them. Can you add this feature into your next build? Thank you!
     
  52. kthaddock

    kthaddock Network Guru Member

    @Shibby
    I have loaded 093V-AIO RT-N on my RT-N16 and I have so far discivered two issues:

    -- Interference Mitigation and "WLAN Auto with Noice Reduction" doesent fit with mode 4.
    I can't set that then I get: The field "wl_mitigation" is invald. Please Report this problem. (tnx M_ars)
    "wl -i eth1 interference" shows, se code, when "Wlan Auto" is enabled:
    Code:
    (Auto Wireless LAN Interference mitigation is enabled and active, and noise reduction is enabled. (mode 4)
    -- "Show In My Network Places" If not clicked that should not show up on Network UpnP Router in Win 7

    If something is unclear don't hesitate to ask.

    kthaddock
     
  53. se7six

    se7six Networkin' Nut Member

    Thanks for the new update shibby!

    I upgraded using the tomato-K26-1.28.RT-MIPSR2-093-Mini file and noticed that DNSCrypt is missing in that build. Did you remove it? I've been running tomato-K26-1.28.RT-MIPSR2-092-MiniIPv6 which has DNSCrypt and has worked very well.
     
  54. kthaddock

    kthaddock Network Guru Member

    Look at this chart: http://tomato.groov.pl/K26RT-N/build5x-093-EN/builds.png
     
  55. se7six

    se7six Networkin' Nut Member

    The chart shows DNSCrypt should be in that build but it's missing. See the image below. The red rectangle is where it was located in 092 and I don't see it anywhere in 093 Mini. I've looked through every menu option for it.

    [​IMG]
     
  56. kthaddock

    kthaddock Network Guru Member

    Have you done NVRAM reset and cleared your cookies and browser cash also ?
    And don't use backup file to restore ?
     
  57. se7six

    se7six Networkin' Nut Member

    I don't use backups and always reset everything when upgrading. I checked the IPv6 Mini and it's missing from that one also. Browser cache clearing didn't change anything.
     
  58. Elfew

    Elfew Addicted to LI Member

    I have this option on AIO v93
     
  59. Aaron

    Aaron Networkin' Nut Member

    This is back for the E3000 Mega-VPN build, but E4200 RT-N AIO correctly defaults to 'None *'
     
  60. Elfew

    Elfew Addicted to LI Member

    In AIO v093 build on ASUS RT-16N there is Advanced>>Wireless; Interference Mitigation selected 'WLAN Auto' as default (same like in v92)
     
  61. nick ant0ny

    nick ant0ny Networkin' Nut Member

    Hi to all!
    Great build shibby, but the problem with no ipv6 on other vlans (br1,br2 ecc.) persists.
    Did you take a look at the iptables i had sent you?

    thanks.
     
  62. M_ars

    M_ars LI Guru Member

    thx for the new build :)
    My RT-N16 is running with the RT-N-Version V093 and the new driver looks like very stable. No problems so far. Wireless speed is no difference.
     
  63. M_ars

    M_ars LI Guru Member

    hi Shibby, can confirm that problem of kthaddock

    [​IMG]
     
  64. burmite

    burmite Serious Server Member

    Thanks for the updated firmware Shibby. It is working well on a Netgear WNR3500LV2 so far. :)
     
  65. shibby20

    shibby20 Network Guru Member

    Finally i resolved problem with minidlna and PS3 (error 2014). I`m testing now new build on 3500Lv2 and dlna on PS3 works very well.
     
    Elfew likes this.
  66. GhaladReam

    GhaladReam Network Guru Member

    Oh great joy! What was the problem??

    Also, are you going to be releasing an interim bugfix release fixing the bugs listed by users above. or wait till the next release? (will the PS3 DLNA fix be in the interim release?)

    Thanks shibby!
     
  67. shibby20

    shibby20 Network Guru Member

    propably release a bugfix version for few days :)
     
    Elfew likes this.
  68. Elfew

    Elfew Addicted to LI Member

    What about MAC adresses bug or IPv6 bug? Is it difficult to fix?
     
  69. shibby20

    shibby20 Network Guru Member

    i`m working on ipv6 bug. About Wireless MAC address we have to wait when Teaman will update code in repo. Btw WAN MAC address i can change.
     
  70. Elfew

    Elfew Addicted to LI Member

  71. nick ant0ny

    nick ant0ny Networkin' Nut Member

    Hi everyone! Shibby thank you for all the time you're spending on our requests.
    Just for the recond, since everyone here asks for new features and reports bugs to resolve etc., we must also say that all these guys in here spend time and all these stuff in order to give us the product named "tomato firmware". So, putting myself too within the list, apart from asking only for features we must also try to help them with even a minimal donation. Saying this, for people who have the posibility to do it since i know times are a bit difficult.
    Thank you all shibby,toastman,teaman and all the other guys doing a great work in here.

    Have a nice day all.
     
  72. kthaddock

    kthaddock Network Guru Member

    @Shibby

    Can you check if L7-filter and ebtables realy working. Is these module loaded ?? 093V-AIO RT-N-build
    And if this working: -m string --string "word" --algo -kmp

    EDIT: ebtables is working ! Not sure about string algo thougt?

    Thanks
    kthaddock
     
  73. Mirko Baila

    Mirko Baila Networkin' Nut Member

    Hi,Acces Restriction it's bugged?
    In my case is not active every day as set
     
  74. Badders44

    Badders44 LI Guru Member

    Hi Shibby. 093 is running fine here but I have a query regarding the Samba File Sharing page.

    If I 'Enable File Sharing' with 'Yes, No Authentication and have both 'Master Browser' and 'WINS Server' unticked, I'm getting this in the log:
    Code:
    Router daemon.err nmbd[605]: Samba name server ROUTER is now a local master browser for workgroup WORKGROUP on subnet 192.168.1.1
    If I tick just 'WINS Server' I get:
    Code:
    Router daemon.err nmbd[604]: Samba name server ROUTER is now a local master browser for workgroup WORKGROUP on subnet 192.168.1.1
    Router daemon.err nmbd[604]: find_domain_master_name_query_fail:
    Router daemon.err nmbd[604]: Unable to find the Domain Master Browser name WORKGROUP<1b> for the workgroup WORKGROUP.
    Router daemon.err nmbd[604]: Unable to sync browse lists in this workgroup.
    
    If I tick just 'Master Browser' I get:
    Code:
    Router daemon.err nmbd[1244]: Samba server ROUTER is now a domain master browser for workgroup WORKGROUP on subnet 192.168.1.1
    Router daemon.err nmbd[1244]: Samba name server ROUTER is now a local master browser for workgroup WORKGROUP on subnet 192.168.1.1
    
    ..so am I right in thinking that by enabling Samba it automatically enables a "local" master browser..or was it doing so previously, but without the log message?

    Thanks for another great release!
     
  75. housenation

    housenation Serious Server Member

    hi everyone;

    i flashed the latest build, 93, on my Asus RT-N66U and for some reason the showing rate on 2.4GHz is very low 5.5Mbps. It starts at 450Mbps and keep going down. I tried AIO and Mega. Any hints on way I am seeing this low rate?

    cheers.
     
  76. Narkhelek

    Narkhelek Serious Server Member

    Making any progress on the WNDR4500 build? Let me know if you need anyone to help test.
     
  77. M_ars

    M_ars LI Guru Member

    Hi shibby,
    for the last 4 days the 2.4 Ghz wirless network of my RT-N16 does not work like expected. I am using your latest RT-N AIO build with the new driver. The GUI says, wifi is ON, while the 2.4 GHz LED says clearly OFF (see pic) - this happend every day so far (mostly in the morning time), but i can not find the root cause. After the problem happens, wireless network keeps off until i save/change some wireless setting or reboot --> then it starts working again. Mabye it has something to do with "Access Restriction" because i turn off my wireless by night using "Disable Wireless". However my "Test-Access Restriction" works like expected...I have also not found a problem/error in the syslog or somewhere else. Any ideas?

    Maybe you can have a look at Access Restriction. thx :)

    Edit: for now i will remove the wlan-off-rule and see how it works out.

    [​IMG]
     
  78. Elfew

    Elfew Addicted to LI Member

    use RT firmware
     
  79. kthaddock

    kthaddock Network Guru Member

    Band witdh link under Device List is broken. 500 Unknown 093V-AIO RT-N
    old path: new-qoslimit.asp new path: bwlimit.asp
     

    Attached Files:

  80. M_ars

    M_ars LI Guru Member

    Removing the wlan-off-rule from Access Restriction solved the problem. There has to be a problem, at least at the new RT-N 093V AOI. With RT 092V AOI i didnt have that problem.
    I made a few tests and i can reproduce it most of the time, but not always. Test 1 to 3 failed (see pic) --> i had to save/change some wireless settings to get the wlan back to work. To start a wlan-survey (unders tools) helped also. Test 4 succeded... so it happens not always. Can someone please confirm that? thx

    [​IMG]
     
  81. Elfew

    Elfew Addicted to LI Member

    confirmed
     
  82. Florid

    Florid Serious Server Member

    I am using Tomato Firmware 1.28.0000 MIPSR2-093 K26 USB BT-VPN for E4200v1.
    I met one issue when using BitTorrent function. The built in transmission client cannot connect SSL https tracker, always saying "could not connect to the tracker". But the http normal trackers work fine.
    I searched and there's a topic on transmission support address this. https://forum.transmissionbt.com/viewtopic.php?f=2&t=12708
    Any chance we can fix this in tomato firmware? Detail guide would be good as I am not an expert in Linux.
    Thanks.
     
  83. Dark_Shadow

    Dark_Shadow Addicted to LI Member

    Also broken in the 94.1 test build for the RT-N66U
     
  84. shibby20

    shibby20 Network Guru Member

    i know :) it`1s already fixed in my local git.
     
    Elfew likes this.
  85. 56kb

    56kb Addicted to LI Member

    94.1 test build for the RT-N66U can't access files in NFS Server
     
  86. shibby20

    shibby20 Network Guru Member

    need more info
     
  87. Elfew

    Elfew Addicted to LI Member

    IPv6 issue or probelm with auto wlan migitation is fixed in your test build? Thanks
     
  88. shibby20

    shibby20 Network Guru Member

    not yet, but will be
     
  89. Elfew

    Elfew Addicted to LI Member

    Thank you for your hard work! ;)

    Have you any info about Teaman release - when or what it contains?
     
  90. zong

    zong Serious Server Member

    hai - I have had shibby RT version 92 running on my RT N16 and was not happy with wireless RX/TX rate as well as ftp speed (internal via usb). So I tried RAF version 11(beta) with better ftp/usb speed.
    @shibby: may have a look here. (USB Speed improved. Old schema detection enabled. Thanks to tvlz. 60KB NVRAM Free RT-N16 or WNR3500L (32KB in origin, no need CFE update).

    Still I am not 100% happy with WLAN (RX/TX). I have best results with
    a)preamble short & frame burst
    b)increased transmit power to 43 mW
    c)interferance mit: auto wlan +noice reduc

    however still 108/162 (changing around) to 40MHz channel (300MBit)

    SO WONDERING if the NEW 5.100.138.20 can improve - however want to wait for a stable version :)
    Are you planning (Victek/Shibby) to release a version for N16 (meaningRT) with this new driver -or we need to try the RT-N version. I saw still problems with 93 RT-N version on N16 router.
    Can we expect a fix for 94 ???
     
  91. Dark_Shadow

    Dark_Shadow Addicted to LI Member

    and soon after you exceed 32 kb it is likely to brick. The RT-N16 is NOT capable of 60kb nvram without a CFE update.
     
  92. zong

    zong Serious Server Member

    Thx Dark Shadow. Victek may answer :)) however this build is running since weeks stable ! I am not sure if the 60k is really active for this router or what exactly he did. Where can I check this in the settings ??? ...
    Not to get me wrong. This was not my topic/problem - I would hope to see some improvements on WLAN (RX/TX) and wonder if the new driver will help. If YES- would be good to see in which version it will be implemented and working for N16.
     
  93. Dark_Shadow

    Dark_Shadow Addicted to LI Member

  94. M_ars

    M_ars LI Guru Member

    Hi Shibby,
    in the file "wan.c" there is the line "CONNECT \c\n" . Is that right or did you mean "CONNECT \\c\n"?
    Right now there is a warning in the buildprocess...

    Code:
            fprintf(cfp,
                "OK \"AT&FE0V1X1&D2&C1S0=0\"\n"
                "OK \"AT\"\n"
                "OK \"ATS0=0\"\n"
                "OK \"AT\"\n"
                "OK \"AT&FE0V1X1&D2&C1S0=0\"\n"
                "OK \"AT\"\n"
                "OK 'AT+CGDCONT=1,\"IP\",\"%s\"'\n"
                "OK \"ATDT%s\"\n"
                "CONNECT \c\n",
                nvram_safe_get("modem_apn"),
                nvram_safe_get("modem_init")
                );
            fclose(cfp);
     
  95. Elfew

    Elfew Addicted to LI Member

    Any progress with IPv6 bug? Teaman released new version with cool features and bug fixes
     
  96. shibby20

    shibby20 Network Guru Member

    for RT-N16 an WNR3500L (v1) better use K26-RT builds.

    it`s warning but not error :) And it`s work. But ok, i will check this.

    not yet.

    I know and i`m merging now :)
     
    Elfew likes this.
  97. Elfew

    Elfew Addicted to LI Member

    Thank you... I am looking forward to your new release ;) Good job!
     
  98. shibby20

    shibby20 Network Guru Member

    [RELEASE] 095

    changelog available on my page tomato.groov.pl

    Best Regards!
     
    NeutralGold, eahm and Gitsum like this.
  99. Mirko Baila

    Mirko Baila Networkin' Nut Member

    Thank'you!!!
     
  100. GhaladReam

    GhaladReam Network Guru Member

    Thanks shibby!!

    I'm curious however, what was involved in fixing minidlna for PS3?
     

Share This Page