1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Shibby's Releases

Discussion in 'Tomato Firmware' started by shibby20, Feb 26, 2011.

  1. nick ant0ny

    nick ant0ny Networkin' Nut Member

    Hi all!

    I get this error on port forward basic
    Any news about the ipv6 fix?

    Thanks
     
  2. kthaddock

    kthaddock Network Guru Member

    Seems that you have wrote some wrong in iptables.
    Sometimes when you make a new ruleset that can be displayed before you reboot router.
     
  3. maurer

    maurer LI Guru Member

    no automatic migration possible. just copy the files downloaded by torrent on your external drive in the download folder of transmission and start adding torrent 1 by 1 - it will take alot of time for big torrents >1GB until all files hashes are checked.
    just leave this hashing running over night
     
  4. shibby20

    shibby20 Network Guru Member

    yes i do. But i haven`t this router. I will think about buy it and then will try to add support.
     
  5. luckydog2006

    luckydog2006 LI Guru Member

    Flashed to tomato-K26USB-1.28.RT-N5x-MIPSR2-097-AIO-64K.trx since I had odd behaviour with the first non-64k load, and everything seems smooth and very stable. Thanks Shibby for a quality build. Ported my settings over and everything is working great as well.
     
  6. Dark_Shadow

    Dark_Shadow Addicted to LI Member

    Ditto, I am not having any issues with what I need out of v097-AIO-64K. I try to test other parts of it when I know how and can. Only other problems have been Guest WiFi, which has it's own thread and is being discuses in the Multi-BSSID thread. Dunno if Teaman has had a chance to take a look.
     
  7. eahm

    eahm LI Guru Member

    RT-N66U, definitely best router I've ever had. Slightly better than the E4200v1.

    Now, is it safe to leave Transmit Power to 100 like the E4200v1 had?

    I'll keep doing more test but it seems the original firmware performs better (download/upload speed).
     
  8. piotrpiano

    piotrpiano Serious Server Member

    [quote="eahm, post: 186333, member: 42178"

    I'll keep doing more test but it seems the original firmware performs better (download/upload speed).[/quote]

    If you mean the wireless performance, try tweaking some of Advanced settings:
    Frame Burst -> Enable
    802.11n Preamble -> Green Field
    ASPD Mode -> Disable

    After changing these I got the performance on par with Asus fm (if not slightly better).
     
  9. eahm

    eahm LI Guru Member

    What do you use for Transmit Power? I have 0 right now and testing.
     
  10. rhester72

    rhester72 Network Guru Member

    May be old news to you, but applies to clients as well as servers, in case you're not using it:

    AvoidDiskWrites 0|1
    If non-zero, try to write to disk less frequently than we would otherwise. This is useful when running on flash memory or other media that support only a limited number of writes. (Default: 0)

    Rodney
     
    windozer likes this.
  11. piotrpiano

    piotrpiano Serious Server Member

    I am using default 42 for both bands.
    Tried to play with it a while ago on 5 ghz band but changing it didn't seem to have any meaningful difference to the signal strength, so I don't bother...
     
  12. GhaladReam

    GhaladReam Network Guru Member

    I'm not entirely sure what is causing issues for you guys with regard to the virtual (guest) wireless. Running 097-AIO-64K on my RT-N66U, uptime now over 10 days, and I can still reliably connect to my wl0.1 and wl1.1 guest SSID's. I'm running both 2.4 and 5 Ghz bands, and can connect to all 4 (main 2.4 and 5, guest 2.4 and 5). Could it be a setting somewhere that I don't have set that is causing issues?

    Is anyone else but me NOT having issues with their Guest Wi-fi?
     
  13. Dark_Shadow

    Dark_Shadow Addicted to LI Member

  14. windozer

    windozer Networkin' Nut Member

    Hi Shibby, I discovered your site with openwrt builds for my tp-link 1043 in the past year. (Tp-link at my office and Asus at home) I really want to throw away the TP-link and get the RT-66 : D

    Wow TOR is the most awesomest thing to have on the router. You read my mind. It works very good.
    I had some issues though - the Time doesn't update even after 15 minutes after connecting. Tor requires time to work. I had to manually set the time using "date 072616202012".

    A 60k nvram version for tomato-K26USB-1.28.RT-MIPSR2-097-AIO would be nice please. I use fstab, adblock script, openvpn echo 'key file, vpnroute.sh file - so it would be nice to have space in nvram.

    Don't mind helping the TOR community if there was a gateway option in addition to client (not sure how it works...i use advtor in windows). Btw is it possible to configure an app like IE to use tor via 192.168.1.1:9050, without being in IP allowed list?

    Keep up the super work. Much appreciated.
     
  15. shibby20

    shibby20 Network Guru Member

  16. awer1967

    awer1967 Addicted to LI Member

    Shibby , sorry for a dumb questions, but now I want to install Your Tomato on my WRT320N and there is misty moments on me in that process :)

    1. My provider gets static IPv4 address for me .I need not use IPv6 ,VPN and other things anymore.

    It seems that two firmwares are good for me -

    tomato-K26-1.28.RT-MIPSR2-097-Max.trx or
    tomato-K26-1.28.RT-MIPSR2-097-Mini.trx

    Which one may I choice to install ?

    2 .Now I have latest stock firmware from Linksys. Can I upgrade to Your firmware directly from Linksys firmware ?

    I was try to use TomatoUSB , but there was issue with low speed on wifi connection (72Mb/sec on TomatoUSB, but 150Mb/sec on original software) That problem was not resolved and I return to stock firmware. Now I want to try Your release , because I like Tomato (it used on second router - Linksys WRT54GL).

    Do zobaczenia, życzę wszystkiego najlepszego :):)
     
  17. Nitro

    Nitro Networkin' Nut Member

    Hi shibby I was trying out your latest build *AIO* and I can't find the overclock section for the RT-N16 cpu for 480MHz to 532MHz? did this get removed? and why?
     
  18. shibby20

    shibby20 Network Guru Member

    @Nitro - i was never include O/C feature :) you can overclock cpu via nvram. This is only 3 commands and done.
    http://tomatousb.org/tut:over-clocking-asus-rt-n16

    @awer1967 - this router has 8MB flash memory well you can install MAX build. MAX has all my features! This is the same as AIO but only for router without USB port :) I haven`t linksys routers well i don`t want to make mistake and tell you a wrong way to flash tomato into wrt320n :/ Should be all good via GUI but better if someone who has Linksys router will confirm this.

    Best Regards.
     
  19. awer1967

    awer1967 Addicted to LI Member

    Thank You for good answer , it is nice for me ! Now I know which software I can use .

    And I mean about my linksys flashing - there is two ways. One is to change software through from GUI and if router will not work correctly I always can restore it by the 30-30-30 procedure (I have such experience with linksys :) ) Second way is flash with TomatoUSB first and re-flash with Your Tomato. This way is more long but it seems more safely . Well , I will try this and write here about results :D - bad or good , no matter.

    Do zobaczenia, życzę wszystkiego najlepszego :):)
     
  20. awer1967

    awer1967 Addicted to LI Member

    IT works !:):)

    I flash my WRT320N directly from GUI of native CISCO software.
    The version of flash was

    tomato-K26-1.28.RT-MIPSR2-097-Max

    It works nice.

    But there is one bug I seen on TomatoUSB previously.

    This is wireless speed.

    Let me explain this situation.

    I have notebook with embedded Wifi -N adapter Atheros AR9285 (with last native drivers from Atheros). It connect to Inet through the my WRT320N . When it flash with native CISCO software speed WiFi connection is 150 Mb/sec, but on Tomato it falls to 72,2 Mbit/sec. I read a lot of forum messages and dig the packets and could not found WHY IT SHIT HAPPENS.

    Anywhere , I stay on Tomato, because I need IPTV (native soft cannot works right with multicast).
    But there is a hope that I will find decision.

    Thanks a lot Shibby !:):)
     
  21. mokey

    mokey Serious Server Member

    JugsteR, Shibby or anyone else, do you run transmission as optware or not? Some people claim it's more stable as optware.
     
  22. JugsteR

    JugsteR Serious Server Member

    Built-in 093, flawless. I'd expect 097 to be the same.

    Signature? Signature!
     
  23. shibby20

    shibby20 Network Guru Member

    from optware is more stable, i agree. I`m using build-in transmission but i dont download to much (more for tests).
     
  24. ady_k4e

    ady_k4e Serious Server Member

    Hello, shibby. Thank you again for a beautiful build of tomato. I have a question / request. I noticed that in start_transmission.sh you have this line:
    rm /opt/.settings/blocklists/*
    prezent even if in the GUI blocklist option si not checked. I am using a personal script to merge more blocklists and use with transmission. Is it possible to remove this line from the start-up script or to have a GUI option to manually edit the start-up script of transmission please? Thank you.
     
  25. shibby20

    shibby20 Network Guru Member

    well i have to remove all blocklist files because if you already have bloclist and now you don`t want use it, then you can uncheck box and press save. Then i have to be sure there is no any of files in blocklists directory before i will sart transmission again. Right?

    I will add more fields to add more blocklist links.
     
  26. zong

    zong Serious Server Member

    dear shibby,
    is there still an table existing to compare the features of different builds.
    If I do not use "transmission" - is BIG-VPN or MEGA VPN still the one with all other features ?

    Any plans to further devellop the "openVPN" client - to be activated/deactivated via "internal IP request" inside the LAN for temporary usage of the VPN.
    br zong
     
  27. dadaniel

    dadaniel Network Guru Member

    Hi,

    After clearing NVRAM on RT-N12 running tomato-K26-1.28.RT-N5x-MIPSR2-097-Max the WLAN LED and WAN LED are swapped.
    Plug in something to WAN port --> WLAN LED on.
    Turn WLAN off --> WAN LED off

    Is it possible to fix that?
     
  28. dlawley

    dlawley LI Guru Member

    I just obtained a Linksys E1550. So far the only firmware that I have found that works is ddwrt. I have tried your latest (tomato-E1550USB-NVRAM60K-1.28.RT-N5x-MIPSR2-095-AIO is one version I have tried) with no luck getting it to run.

    I have recovered via serial port access and flashed back to ddwrt via the stopping of cfe and using upgrade command.

    Both yours and toastmans 1550 builds don't seem get to to a point where I'm able to regain network access.

    What can I do to help? dmesg first I suppose. ddwrt and yours to compare? and where to post?

    I have done the usual resets, nvram erase etc..
     
  29. maurer

    maurer LI Guru Member

  30. ady_k4e

    ady_k4e Serious Server Member

    Hello, Shibby.

    I managed to find a workaround for transmission blocklist and load the blocklists that I am interested in via my script. But I have a new request if it is not to hard and you have time. I am interested in a field present in Administration -> admin access where the user will be able to add extra options for dropbear. For instance I am interested in :
    -w Disallow root logins
    -g Disable password logins for root
    -W <receive_window_buffer> (default 12288, larger may be faster, max 1MB)

    Thank you once again for tomato and for your help.
     
  31. Gitsum

    Gitsum LI Guru Member

    Hi, I was wondering if you could add the number of connections to the system overview page?
    Something like "Active Connections 435/16384"
     
  32. Nitro

    Nitro Networkin' Nut Member

    +1 I like this Idea very much, when your checking status of a router the connections it has currently made seem more relevant than cpu usage or uptime.
     
  33. shibby20

    shibby20 Network Guru Member

    eahm likes this.
  34. ghoffman

    ghoffman Addicted to LI Member

    great work again shibby. thank you
     
  35. CBR900

    CBR900 LI Guru Member

    Thank you shibby...will install it later
     
  36. Aaron

    Aaron Networkin' Nut Member

    When I enable dnscrypt-proxy my CPU load stays above 1.00. When I disable it goes down to 0.

    Also, with dnscrypt-proxy on welcome.opendns.com reports that I'm not using OpenDNS
     
  37. mokey

    mokey Serious Server Member

    Shibby, I remember you said you're not a programmer. I installed you AiO for my new RT-N16, I I'd like to thank you for a well put-together firmware. I thought I'd have to do a lot of configuring transmission (my linux is weak), but It is easily configured from the web interface. No problems with the firmware, although transmission does crash periodically (I guess that's transmission's fault) (and it gets auto-restarted). I think you have at least a bit of programming experience to do this all.
     
  38. eahm

    eahm LI Guru Member

    099V is better/faster than 097V IMO but when dnscrypt-proxy is enabled the anti-ads script won't download/work.
     
  39. Engineer

    Engineer Network Guru Member

    Edit: Well, after many, many, many 30-30-30 resets and other "tinkering", I've managed to get into my Belkin Sharemax 300N and reset the NVRAM. Seems to be working now. Have to set it up again though.

    Bricked my Belkin Sharemax 300N, which was running version Big 097. Was running Big 095 before that. Will try to figure it out later. Strange light patterns on the power on/status light.

    Regardless, thanks Shibby.
     
  40. shibby20

    shibby20 Network Guru Member

    issue of dnscrypt-proxy confirmed. I`ll be fixed in next release soon.
     
    Cyberian75 and eahm like this.
  41. dadaniel

    dadaniel Network Guru Member

    It's the same in 099.
     
  42. shibby20

    shibby20 Network Guru Member

  43. Cyberian75

    Cyberian75 Network Guru Member

    It also breaks DDNS.
     
  44. leandroong

    leandroong Addicted to LI Member

    dnsscrypt-proxy has problem also with 3G modem. When checked, very hard to establish connection and if connected, slowly killing web access.Kindly verify this matter also
     
  45. shibby20

    shibby20 Network Guru Member

    ok will check
     
  46. shibby20

    shibby20 Network Guru Member

    hmm Netgear 3500Lv2 + RT-N build100 + huawei 173 + T-mobile + dnscrypt-proxy = no issue

    connected in the first time, dnscrypt works correct, internet speed is ok.

    make a router reboot and all stay up without problem.

    On build099 i will not test because dnscrypt has confirmed issue with 100% cpu usage
    On 097 i will also not test because there is older 0.9.3 version of dnscrypt.
     
  47. leandroong

    leandroong Addicted to LI Member

    Using different sim provider, allows me to connect easily to 3g modem and surf successfully except for 1 url, http://repo.or.cz/w/tomato.git/shortlog/refs/heads/tomato-RT, it says gateway timeout.

    Common problem for both sim card are having problem connecting using putty or winscp whenever dnscrypt-proxy is checked.
     
  48. shibby20

    shibby20 Network Guru Member

    repo.or.cz was down yesterday :)
     
  49. shibby20

    shibby20 Network Guru Member

    [RELEASE] build 100!!
     
    eahm likes this.
  50. Aaron

    Aaron Networkin' Nut Member

    tomato-E3000USB-NVRAM60K-1.28.RT-MIPSR2-100-Mega-VPN.bin - 8.2MB

    E3000 only has 8MB flash
     
  51. shibby20

    shibby20 Network Guru Member

    from build 088, mega-vpn is only for router with 16MB or more.
     
  52. GhaladReam

    GhaladReam Network Guru Member

    Seems Asuswrt-Merlin now has DualWAN support.

    Shibby, I know you said before you don't know a whole lot about how to add DualWAN to your build, but perhaps his sources would help? I would LOVE to see this feature in your branch :)

    Something else I would love to see would be the ability to set "Wireless" as one of the options under WAN/Internet on the Basic-->Network page as part of both single and DualWAN. Effectively making your WAN/Internet connection recieve internet wirelessely.
     
  53. Aaron

    Aaron Networkin' Nut Member

    Thanks for your hard work shibby.

    v100 running perfect on my E3000 and E4200. I really like the new Linksys Red color scheme.

    One small tiny bug that I found. In Transmission web interface my torrent has "&darr" and "&uarr"
    I believe this is for down arrow and up arrow? I first noticed this in 099. My torrents download fine.
     
  54. Cyberian75

    Cyberian75 Network Guru Member

    Thanks, Shibby!
     
  55. mbreslin

    mbreslin Networkin' Nut Member

    I had been using 87 for quite a while on my RT-N66U, a couple days ago decided to see what was new, first tomato-K26USB-1.28.RT-N5x-MIPSR2-099-AIO-64K and now tomato-K26USB-1.28.RT-N5x-MIPSR2-100-AIO-64K randomly reboot my router. Will have to go back to 87 I guess for stability.
     
  56. Cyberian75

    Cyberian75 Network Guru Member

    mbrestin, 097 is fine.
     
  57. mbreslin

    mbreslin Networkin' Nut Member

    Thanks will run 97 for awhile and check it out.
     
  58. Cyberian75

    Cyberian75 Network Guru Member

    Is it possible to change the logging path of webmon?
     
  59. GhaladReam

    GhaladReam Network Guru Member

    Looks like there was a new miniDLNA (1.0.25) back on July 13. Has this been updated on your builds Shibby? The last time I see a miniDLNA update (v1.0.24) was build 87.
     
  60. CBR900

    CBR900 LI Guru Member

    Guys...help please

    I need to configure swap on my flash memory in order to use Tor.

    I just installed Tomato Firmware 1.28.0000 MIPSR1-100 K26 USB Tor-VPN
     
  61. shibby20

    shibby20 Network Guru Member

    ATTENTION!!

    i found 2 big problems in tomato`s 099, 099.1 and 100

    1) ipv6 doesn`t work. In all buildtype without AIO and Mega-VPN, ipv6 will not work. The problem is with ipsec support. sit.ko module needs xfrm modules as depends. Temporaty solutions are:
    a) download extras modules package and load manually four modules:
    insmod tunnel4.ko
    insmod tunnel6.ko
    insmod xfrm6_tunnel.ko
    insmod xfrm4_tunnel.ko
    b) dont use ipv6 for a while :)
    c) return to 097.

    2) Transmission doesn`t work. Transmission 2.61 needs libiconv library :/ Version 2.60 didn`t need this library. I have this library installed from optware well this was confuse me because build-in transmission works on my router :/ Temporary solution: install gettext package from optware.

    I will fix those issues as soon as possible.

    Best Regards.
     
    eahm and Gitsum like this.
  62. Cyberian75

    Cyberian75 Network Guru Member

    There's also a memory leak causing random reboots in 099 and 100.
     
  63. GhaladReam

    GhaladReam Network Guru Member

    Thanks for the heads up shibby! I assume by what you say in item 1) that ipv6 WILL work if we are using AIO or Mega-VPN?
     
  64. Cyberian75

    Cyberian75 Network Guru Member

    I can confirm IPv6 works in AIO.
     
  65. GhaladReam

    GhaladReam Network Guru Member

    I'm not getting these random reboots or any memory leak. From the other thread about the memory leak, I can confirm the services I don't use which the others are reporting having used. I currently DO NOT use: DNSCrypt. IPv6. OpenVPN. If you disable any or all of these, does it change anything?
     
  66. Cyberian75

    Cyberian75 Network Guru Member

    I've tried turning DNSCrypt off, but it didn't help. I'd have tried IPv6, but I downgraded to 097 already which is very stable and has no memory fluctuations.
     
  67. zong

    zong Serious Server Member

    running version100 with DNSCrypt (on AsusN16) and have no access to this forum link (linksysinfo.org). Needed to go via my OpenVPN / will also check the normal DNS function.
    Not sure if problem is with the new DNSCrypt implementation or with opendns itself.
     
  68. Cyberian75

    Cyberian75 Network Guru Member

    I think OpenDNS is malfunctioning... their filter is apparently down.
     
  69. kthaddock

    kthaddock Network Guru Member

    Do you get this in logg from OPENDNS?
    Code:
    Aug 15 22:48:41 HOSTNAME daemon.info dnscrypt-proxy[5217]: Refetching server certificates
    Aug 15 22:48:41 HOSTNAME daemon.info dnscrypt-proxy[5217]: Server certificate #1234567890 received
    Aug 15 22:48:41 HOSTNAME daemon.info dnscrypt-proxy[5217]: This certificate looks valid
    Aug 15 22:48:41 HOSTNAME daemon.info dnscrypt-proxy[5217]: Server key fingerprint is KEY REMOVED
    I'm using it and it's working
     
  70. Cyberian75

    Cyberian75 Network Guru Member

    Yup, but it's not blocking any sites on my "always block" list.
     
  71. kthaddock

    kthaddock Network Guru Member

    Okey
    Then I suggest to reset router and add one options at the time and narrow what's problem.

    I have used it for years with no trouble. I have one router with 100V-aio working right now.
    Make sure you have assign IP-number and setup STATS in OpenDns.
    Dnscrypt is only a secure tunnel to opendns nothing else.
     
  72. zong

    zong Serious Server Member

    thx for feedback. Need to correct my statement !!!!
    Also without opendns (dynscript) - using my preferred university DNS, I have no access to "linksysyinfo.org".
    I am using a view "filters" in access restriction , which should not the cause this problem. However I disabled those!
    I also changed some small adaption to QoS in BasicSettings.
    Independent - I can only access this forum via my tunnel (openVPN client.)
    I think it is within "iptables". However I cleared the Ram before updating !
    So will go back to 97 BigVPN. will let you know...
    -----
    Now running 97BigVPN and used my "config file" from the "100 Version"./ I wanted to know...:)
    Works fine - however still no access to this forum pages /only via tunnel.
    Are they maybe blocking "german" IPadresses ?
    I not jet see any other problems /url not running. So will do noting for a while -and then maybe a new config per hand.... //
    To note: I was running version 95 and have had access to this url a week before :)
    -----
    1) could an "error" in iptables" been "transferred" with the config file??) what you guess.
    V100 to V97 ???

    2) An other question to experts :) In all tomato builds the LAN (in UpnP or IGMO config)
    ask to "activate" LAN and LAN1 by counting to LAN3.
    My AsusN16 has 4 LAN ports (LAN1 , ... LAN4)
    So how is LAN counting in tomato config (LAN = LAN4 // LAN1 = LAN1) ??
    What is the preferred LAN port ( 1 or 4) for IPTV or video streaming ?

    br thx
     
  73. Cyberian75

    Cyberian75 Network Guru Member

    It was IPv6. Apparently, they don't do filtering over IPv6 yet.
     
  74. kthaddock

    kthaddock Network Guru Member

    Okey you find your issue. I didn't mention when you make rules to IPV6 then you have to do like this:
    This is only example rules:
    Code:
    ip6tables -I FORWARD 1 -p icmpv6 -j DROP
    ip6tables -I FORWARD 1 -p tcpv6 -j DROP
    ip6tables -I FORWARD 1 -p udpv6 -j DROP
     
  75. Cyberian75

    Cyberian75 Network Guru Member

    I just took out ipv6 dns entries.
     
  76. zong

    zong Serious Server Member

    sorry - I cleaned RAM / did reset and configured manually. Everything is unchanged ! Could not access THIS forumpage. Your answer with regard to ipv6. Do you maybe think that they are only available with ipv6 ? (which I not have activated). Not sure if I understood "Cyberian" correctly !
    What is about the 6in4 via tunnelbroker. (my ISP not jet having nativ ipv6) Is this really a good idea and give me benefits in speed (compared to ipv4). Do we have experience here in the forum ?
     
  77. Cyberian75

    Cyberian75 Network Guru Member

    Sorry, zong, I wasn't taking about your problem.
     
  78. Mirko Baila

    Mirko Baila Networkin' Nut Member

    Tnk's shibby!! :)
     
  79. Nitro

    Nitro Networkin' Nut Member

    wow thanks for including the themes! now I can just select them :D <3 you shibby
     
  80. spookyneo

    spookyneo Networkin' Nut Member

    I'm running on 095 and my miniDLNA does not start automatically when the router (RT-N16) restarts/starts. The web interface shows it at stopped because the button is written "Start now" and my X360 cannot pick up my router's video. The miniDLNA processes are running after the router restarts; doing a "top" will show me 3 "minidlna -f /etc/minidlna.conf" processes. However, I must manually type "minidlna -f /etc/minidlna.conf" to start the service or go into the web interface and hit "Start now".

    As a workaround, I have added "minidlna -f /etc/minidlna.conf" into the init script and now it starts succesfuly automatically. Could this be a bug ? I have not updated to latest version (100), because of the memory leak issue reported by many people in the latest versions.

    Thank you.
     
  81. taiwops

    taiwops Networkin' Nut Member

    @Shibby

    I lovely tomato your mod very much. Now i working upcountry instead of normal ppoe connection via modem I don't have any more line. I buy 3G modem from ZTE MF190S (have micro-sd also) on Router H/W: Tomato Firmware 1.28.0000 MIPSR2-083V K26 USB Mega-VPN on RT-N10U. I try to read about 3G/WAN usb_switch but i can't fixed it by myself and here below my console logging. thank in advance for your help.

    Code:
    basic->wan->3G Modem
     
    modem device->dev/ttyusb0
     
    pin->nil
     
    modem init->*99***1#
     
    apn->etlnet
     
    user->nil
     
    password->nil
     
    connection mode->keep alive
     
    check interval->10
     
    lsusb
     
    Bus 001 Device 003: ID 19d2:2003
     
    Bus 002 Device 001: ID 1d6b:0001
     
    Bus 001 Device 001: ID 1d6b:0002
     
    dmesg
     
    Tomato v1.28.0000 MIPSR2-083V K26 USB Mega-VPN
     
    root@JoJetta:/tmp/home/root# dmesg
     
    Linux version 2.6.22.19 (root@tomato) (gcc version 4.2.4) #31 Mon Dec 5 16:34:55 CET 2011
     
    CPU revision is: 00019749
     
    Found an ST compatible serial flash with 128 64KB blocks; total size 8MB
     
    Determined physical RAM map:
     
    memory: 02000000 @ 00000000 (usable)
     
    Entering add_active_range(0, 0, 8192) 0 entries of 256 used
     
    Zone PFN ranges:
     
    Normal 0 -> 8192
     
    HighMem 8192 -> 8192
     
    early_node_map[1] active PFN ranges
     
    0: 0 -> 8192
     
    On node 0 totalpages: 8192
     
    Normal zone: 0 pages used for memmap
     
    Normal zone: 0 pages reserved
     
    Normal zone: 8192 pages, LIFO batch:1
     
    HighMem zone: 0 pages used for memmap
     
    Built 1 zonelists. Total pages: 8192
     
    Kernel command line: root=/dev/mtdblock2 noinitrd console=ttyS0,115200
     
    Primary instruction cache 32kB, physically tagged, 4-way, linesize 32 bytes.
     
    Primary data cache 32kB, 4-way, linesize 32 bytes.
     
    Synthesized TLB refill handler (20 instructions).
     
    Synthesized TLB load handler fastpath (32 instructions).
     
    Synthesized TLB store handler fastpath (32 instructions).
     
    Synthesized TLB modify handler fastpath (31 instructions).
     
    PID hash table entries: 256 (order: 8, 1024 bytes)
     
    CPU: BCM5357 rev 1 pkg 8 at 300 MHz
     
    Using 150.000 MHz high precision timer.
     
    console [ttyS0] enabled
     
    Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
     
    Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
     
    Memory: 28632k/32768k available (33k kernel code, 4120k reserved, 2701k data, 124k init, 0k highmem)
     
    Calibrating delay loop... 149.91 BogoMIPS (lpj=749568)
     
    Mount-cache hash table entries: 512
     
    NET: Registered protocol family 16
     
    PCI: no core
     
    PCI: no core
     
    PCI: Fixing up bus 0
     
    NET: Registered protocol family 2
     
    Time: MIPS clocksource has been installed.
     
    IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
     
    TCP established hash table entries: 1024 (order: 1, 8192 bytes)
     
    TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
     
    TCP: Hash tables configured (established 1024 bind 1024)
     
    TCP reno registered
     
    squashfs: version 3.0 (2006/03/15) Phillip Lougher
     
    io scheduler noop registered (default)
     
    HDLC line discipline: version $Revision: 4.8 $, maxframe=4096
     
    N_HDLC line discipline registered.
     
    Serial: 8250/16550 driver $Revision: 1.90 $ 2 ports, IRQ sharing disabled
     
    serial8250: ttyS0 at MMIO 0xb8000300 (irq = 8) is a 16550A
     
    PPP generic driver version 2.4.2
     
    MPPE/MPPC encryption/compression module registered
     
    NET: Registered protocol family 24
     
    PPPoL2TP kernel driver, V0.18.3
     
    PPTP driver version 0.8.5
     
    pflash: found no supported devices
     
    Creating 5 MTD partitions on "sflash":
     
    0x00000000-0x00020000 : "pmon"
     
    0x00020000-0x007f0000 : "linux"
     
    0x00106c00-0x007a0000 : "rootfs"
     
    0x007a0000-0x007f0000 : "jffs2"
     
    0x007f0000-0x00800000 : "nvram"
     
    u32 classifier
     
    OLD policer on
     
    Netfilter messages via NETLINK v0.30.
     
    nf_conntrack version 0.5.0 (512 buckets, 4096 max)
     
    ip_tables: (C) 2000-2006 Netfilter Core Team
     
    ipt_account 0.1.21 : Piotr Gasidlo <quaker@barbara.eu.org>, http://www.barbara.eu.org/~quaker/ipt_account/
     
    net/ipv4/netfilter/tomato_ct.c [Dec 3 2011 17:07:50]
     
    NET: Registered protocol family 1
     
    NET: Registered protocol family 10
     
    ip6_tables: (C) 2000-2006 Netfilter Core Team
     
    NET: Registered protocol family 17
     
    802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
     
    All bugs added by David S. Miller <davem@redhat.com>
     
    VFS: Mounted root (squashfs filesystem) readonly.
     
    Freeing unused kernel memory: 124k freed
     
    Warning: unable to open an initial console.
     
    emf: module license 'Proprietary' taints kernel.
     
    PCI: Setting latency timer of device 0000:00:02.0 to 64
     
    eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 5.100.138.9
     
    wl_module_init: passivemode set to 0x0
     
    PCI: Setting latency timer of device 0000:00:01.0 to 64
     
    eth1: Broadcom BCM4329 802.11 Wireless Controller 5.100.138.9
     
    Algorithmics/MIPS FPU Emulator v1.5
     
    usbcore: registered new interface driver usbfs
     
    usbcore: registered new interface driver hub
     
    usbcore: registered new device driver usb
     
    SCSI subsystem initialized
     
    Initializing USB Mass Storage driver...
     
    usbcore: registered new interface driver usb-storage
     
    USB Mass Storage support registered.
     
    ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
     
    PCI: Setting latency timer of device 0000:00:04.1 to 64
     
    ehci_hcd 0000:00:04.1: EHCI Host Controller
     
    ehci_hcd 0000:00:04.1: new USB bus registered, assigned bus number 1
     
    ehci_hcd 0000:00:04.1: irq 5, io mem 0x18004000
     
    ehci_hcd 0000:00:04.1: USB 0.0 started, EHCI 1.00
     
    usb usb1: configuration #1 chosen from 1 choice
     
    hub 1-0:1.0: USB hub found
     
    hub 1-0:1.0: 2 ports detected
     
    ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
     
    PCI: Setting latency timer of device 0000:00:04.0 to 64
     
    ohci_hcd 0000:00:04.0: OHCI Host Controller
     
    ohci_hcd 0000:00:04.0: new USB bus registered, assigned bus number 2
     
    ohci_hcd 0000:00:04.0: irq 5, io mem 0x18009000
     
    usb usb2: configuration #1 chosen from 1 choice
     
    hub 2-0:1.0: USB hub found
     
    hub 2-0:1.0: 2 ports detected
     
    usb 1-1: new high speed USB device using ehci_hcd and address 2
     
    usb 1-1: configuration #1 chosen from 1 choice
     
    scsi0 : SCSI emulation for USB Mass Storage devices
     
    usbcore: registered new interface driver usblp
     
    usblp: USB Printer Device Class driver
     
    Registered led device: 1-1
     
    vlan0: add 33:33:00:00:00:01 mcast address to master interface
     
    vlan0: add 01:00:5e:00:00:01 mcast address to master interface
     
    vlan0: dev_set_allmulti(master, 1)
     
    vlan0: dev_set_promiscuity(master, 1)
     
    device eth0 entered promiscuous mode
     
    device vlan0 entered promiscuous mode
     
    device eth1 entered promiscuous mode
     
    br0: port 2(eth1) entering forwarding state
     
    br0: port 1(vlan0) entering forwarding state
     
    vlan1: Setting MAC address to 54 04 a6 5a a3 01.
     
    scsi 0:0:0:0: CD-ROM ZTE USB SCSI CD-ROM 2.31 PQ: 0 ANSI: 2
     
    scsi 0:0:0:1: Direct-Access ZTE MMC Storage 2.31 PQ: 0 ANSI: 2
     
    sd 0:0:0:1: [sda] 498176 512-byte hardware sectors (255 MB)
     
    sd 0:0:0:1: [sda] Write Protect is off
     
    sd 0:0:0:1: [sda] Mode Sense: 0f 0e 00 00
     
    sd 0:0:0:1: [sda] Assuming drive cache: write through
     
    sd 0:0:0:1: [sda] Assuming drive cache: write through
     
    sd 0:0:0:1: [sda] Attached SCSI removable disk
     
  82. kthaddock

    kthaddock Network Guru Member

    Pls put your logs in CODE tag it's easyier to read too people.
     
  83. sorance2000

    sorance2000 Networkin' Nut Member

    Hello!
    I ask you a question about Qos Classification: I `d like to make rules for these dst. ips : 192.168.1.2, 192.168.1.3 ...4,5 and so on.
    I want make the same rule for these ips. Should I make a row rule for every ip, or is there another way to type them in, eg: 192.168.1.2/5 or 192.168.1.2,3,4,5 or 192.168.1.2-5 ?

    Thanks!
     
  84. dadaniel

    dadaniel Network Guru Member

  85. Elfew

    Elfew Addicted to LI Member

    I have a problem with multiSSID - I configured my router according to the teaman manual.

    I see network, but I cannot connect to it

    I have asus rt-16n, build 100AIO

    thank you

    btw - in wl0.1 i have a message - this MAC adress is ....
     
  86. eahm

    eahm LI Guru Member

    083V from a customer:

    [​IMG]

    Also Shibby, the red Xs on Port Forwarding are messed up:

    [​IMG]
     
  87. Nitro

    Nitro Networkin' Nut Member

    This is theme related, I will fix this and update the theme pack for Linksys/Asus Red for shibby :)
     
  88. Nitro

    Nitro Networkin' Nut Member

    update: fixed, will pm new css to shibby which will hopefully be inlcuded in the next release :)
     
    eahm likes this.
  89. eahm

    eahm LI Guru Member

    Awesome theme, thank you!
     
  90. zong

    zong Serious Server Member

    having Asus N16 and running first time AIO builds now with version100.
    After installation, I have had 32% free NVRAM, now with all changes and the "openVPN client" config with keys, I have 6% ..... Is this ok ???
    Total / Free Memory 123.87 MB / 112.79 MB (91.06%)
    Total / Free NVRAM: 32.00 KB / 1936 (5.91%)
     
  91. maurer

    maurer LI Guru Member

    yes, it's ok - i have the same ~5.38% free NVRAM
     
  92. zbeyuz

    zbeyuz Serious Server Member

    I also have a problem with DNS-Crypt. The upload and download speed were slow when I turned DNS-Crypt on.

    Btw, The wireless scheduler also didn't work in access point mode with DHCP disabled.

    Unlike DD-Wrt firmware, it works every time even in access point mode, as it is based on uptime of the router not the time of the day.

    Hope the next build can fix that problem. Thank you very much for your works, Shibby.
     
  93. shibby20

    shibby20 Network Guru Member

  94. Elfew

    Elfew Addicted to LI Member

    Great news!
     
  95. Engineer

    Engineer Network Guru Member

    Just upgraded my 4 routers to 101. All is well although I admit that I don't do much with them.

    One thing I noticed is the transfer speed between my E2000 Wireless Ethernet Bridge to my Belkin N600 router (5GHz) is faster and more steady (up to nearly 21MB (MBytes) per seconds). Also, the transfer is now steady in both directions whereas with 095, it was fast from the Belkin to the E2000 but very slow between the E2000 and the Belkin. Will monitor that over the days to see how it goes.

    Thanks Shibby, jyavenard and all of the rest for your great contributions to the best router firmwares available.
     
  96. Mirko Baila

    Mirko Baila Networkin' Nut Member

  97. GhaladReam

    GhaladReam Network Guru Member

    101-AIO-64K working great :) Thanks again shibby!
     
  98. GhaladReam

    GhaladReam Network Guru Member

    Are DualWAN sources not in the tomato git?
     
  99. Badders44

    Badders44 LI Guru Member

    +1 for 101 - another great version. Thanks Shibby :)
     
  100. Dark_Shadow

    Dark_Shadow Addicted to LI Member

    Agreed, Thanks, jyavenard and shibby
     

Share This Page