1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Shibby's Releases

Discussion in 'Tomato Firmware' started by shibby20, Feb 26, 2011.

  1. shibby20

    shibby20 Network Guru Member

    when you choise with version of minidlna will be in final realase i will release all buildtypes :)
     
  2. molnart

    molnart Networkin' Nut Member

    shibby, do your current test builds already include the changes from Victek's latest build (9006)?
     
  3. baluvee

    baluvee Network Guru Member

    minidlna 1.0.20
     
  4. GhaladReam

    GhaladReam Network Guru Member

    +1 for 1.0.20
     
  5. Badders44

    Badders44 LI Guru Member

    +1 for 1.0.20 also
     
  6. shibby20

    shibby20 Network Guru Member

  7. Victek

    Victek Network Guru Member

    But I want to fix something important in this topic. Shibby included some other features in his version that are independent of Tomato RAF. Any unstable behaviour in shibby's build does'nt mean that Tomato RAF is unstable too. Thank you!
     
  8. 56kb

    56kb Addicted to LI Member

    Feedback tomato-K26USB-1.28.905xRAF-EN-MIPSR2-055-Ext
    I have been using since released 12 Jun 11 very stable recommended.

    Thanks shibby20
     
  9. bluesky

    bluesky Networkin' Nut Member

    Shibby20,
    I found a new bug on the firmware. When remote control windows XP machine by using remote desktop over the internet, router will force machine in to standby mode once idle 3-5 minutes. But remote control it in internal network, it does not have this issue. I have try 2 different Windows XP machine. I have flashed new one Tomato Firmware 1.28.0905 MIPSR2-055 K26 USB Mega-VPN to the RT-N16. They are having the same problem. If the XP machine connect to Linksys router (not tomato firmware), it does not have this problem. But Windows 7 machine does not have any remote desktop issue when connect to RT-16.
     
  10. GhaladReam

    GhaladReam Network Guru Member

    shibby, could you include Victek's newest additions to filesystem support in your next release? His newest release seems to now support HFS and HFS+ formatted drives. Thanks!
     
  11. Victek

    Victek Network Guru Member

    GhaladReam , beta version built for some custom request .. already posted to the git.
     
  12. shibby20

    shibby20 Network Guru Member

    [release] build5x-060
    - minidlna 1.0.20
    - transmission 2.31
    - few fixed for clients monitor
    - Victek`s fixes for captive portal
    - builds for Linksys E4200 (radio 5Ghz not work)
    - NFS server removed from Mega-VPN build. Revert JFFS to Mega-VPN build
    - transmission-create only in AIO builds
     
  13. bkmo

    bkmo LI Guru Member

    I have been having zero problems with transmission using build 55. I just updated to version 60 and transmission died 10 minutes into a torrent download.
     
  14. GhaladReam

    GhaladReam Network Guru Member

    clear NVRAM. I was using build 056 since it came out, first test version with Transmission 2.31, and I find it to be worlds more stable than 2.22. Would crash left and right for me before. Not anymore (this includes build 060). Since 2.31 was used, it's been rock solid on my end.
     
  15. bkmo

    bkmo LI Guru Member

    Since I restarted Transmission it has been running stable again ever since.
     
  16. were55

    were55 Addicted to LI Member

    I had some toubles with "1.28.0905 MIPSR2-060 K26 USB Mega" , my routes access was denied a coupple of times (after nvram and reconfiguration perfomed) and I lost internet also, so I decided back to 1.28.0905 MIPSR2-057 K26 USB Mega and now my router (RT-N16) is working fine, anyone else?
     
  17. gogubeb

    gogubeb Addicted to LI Member

    @were55, I use Tomato Firmware 1.28.0905 MIPSR2-060 K26 USB AIO on an RT-N16 without problems (my connection is PPPOE).
    @shibby, You change the penguin with an ugly picture :((. It was more nice the penguin then the actual picture in about section.
     
  18. molnart

    molnart Networkin' Nut Member

    although i didn't update to build 60 yet, i really love(d) the penguin and would be very disappointed to see it gone...
     
  19. shibby20

    shibby20 Network Guru Member

    its only a pictute ;P Its openlinksys.info url in QT code (very useful if you have phone with android os)

    @were55 - i use pppoe on my rtn16 and works correct. Difference between version 057 and 060 is only minidlna (1.0.18.2 and 1.0.20).

    No need to clear nvram after flash from 057 to 060.
     
  20. CBR900

    CBR900 LI Guru Member

    Is it possible to have NFS server back in Mega-VPN build for asus wl500gp

    10x for the great work
     
  21. GhaladReam

    GhaladReam Network Guru Member

    I noticed this as well :D

    Now it's a QR Code linking to openlinksys.org
     
  22. shibby20

    shibby20 Network Guru Member

    i`ll try.
     
  23. GhaladReam

    GhaladReam Network Guru Member

    There is definitely still something wrong with minidlna 1.0.20. I only recently started using it with my XBOX360 and PS3 after reading about other people's issues, which prompted me to try it. Before that, I'd never used it before... No matter what I do, PS3 always gets the 2104 error, and I can't play anything at all. My 360 works for a few minutes (plays a few songs), but when I go to switch a song or change album, miniDLNA crashes altogether ("Restart Now" changes to "Start Now" in the gui, indicating it's no longer running).

    I read this whole thread, and people reported rebooting the router & miniDLNA itself, and rescanning the database works, but I've had no luck with these solutions.

    Here's my setup and what I've tried:

    ASUS RT-N16 running shibby's AIO build 060.
    120GB USB-powered laptop HDD in an enclosure formatted NTFS (browsing via samba, copying files, Transimission all work perfect on it)

    PS3 is wireless G, XBOX360 is wired (but I've tried ps3 wired, same problem)

    -Tried clearing NVRAM (thorough)
    -Tried putting DLNA database both on USB HDD and in router RAM, no difference
    -Tried shortening the folder structure (i.e placing mp3's on the root), as some of my media is buried in 3-4 folder levels, but that didn't make a difference
    -Tried setting to strictly adgere to standards and TivO support which don't help
    -I can faithfully reproduce the crashing problem by playing a song or 2 on xbox, then switching, which immediately causes minidlna to crash.
    -I can SOMETIMES get as far as seeing artist/album names on PS3, but when i go into the folder that will have the songs, it just gets DLNA 2104 every time.
    -I have rebooted the router 6-7 times, hit "restart now" many times in DLNA gui, rescanned DB...

    Anyone else still getting these problems?

    EDIT: Also wanted to point out that I tried physically unplugging the hole router for 10 minutes then plugging back in to see if it was power related. No change. Also, everything else, and Transmission 2.31 are working flawlessly, so it can't be a hardware issue... I also wanted to point out that I had posted previously that it wwas orking fine for me on both PS3 and 360, and it was! The only difference this time is that I put my entire music collection on it (2000+ songs) instead of 2-3 songs I had on there for testing (which worked perfectly at the time)

    It seems to have issues with large collections possibly?
     
  24. shibby20

    shibby20 Network Guru Member

  25. shibby20

    shibby20 Network Guru Member

    @GhaladReam - its definitely minidlna fault. Please check 057 from testing directory. This version has BT2.31 and minidlna 1.18.0.2 from build52. Should works with PS3.
     
  26. were55

    were55 Addicted to LI Member

    Shibby, I updated again to 060 without clear nvram and now I have 24 hours running flawlessly.

    thanks !!
     
  27. virginlulu

    virginlulu Networkin' Nut Member

    Mipsr1 aio needed

    thanks a lot to shibby, could you compile an AIO for MIPSR1 ? zte h618b has 16m flash.......:):):)
     
  28. virginlulu

    virginlulu Networkin' Nut Member

    Mipsr1 aio

    thanks shibby ,will you compile an AIO for MIPSR1?
     
  29. GhaladReam

    GhaladReam Network Guru Member

    Are there MIPSR1 routers with more than 8MB flash that can handle AIO? I wasn't aware of any...
     
  30. stuntsy99

    stuntsy99 Networkin' Nut Member

    Oops... are AIO builds only meant for more than 8mb flash? I thought I read somewhere that you can use them on 8mb flashes too...

    I have been loading them on to my WRT610Nv2... :biggrin: and working fine too.
     
  31. shibby20

    shibby20 Network Guru Member

    yes i can.
     
  32. virginlulu

    virginlulu Networkin' Nut Member

    AIO

    Thanks very much:):):)
     
  33. shibby20

    shibby20 Network Guru Member

  34. virginlulu

    virginlulu Networkin' Nut Member

    got it , thanks again!!!!
     
  35. shadowken

    shadowken Networkin' Nut Member

    Hi guys,

    I'm new to Tomato firmware if can i ask you how to install tomato-E3000USB-NVRAM60K-1.28.905xRAF-EN-MIPSR2-060-Ext.bin on Linksys E3000 ?
    And how can i downgrade it to stock firmware if something went wrong ?
     
  36. GhaladReam

    GhaladReam Network Guru Member

    I just got around to testing this, and unfortunately it didn't help one bit. It did however fix the problem of miniDLNA crashing when using the 360 (seems to work perfect on xbox 360 now with minidlna 1.18.0.2, but it still will absolutely not work on my PS3. Still get the 2104 DLNA error 100% of the time. I also tried switching my PS3 from wireless to wired, which didn't fix it. Cleared NVRAM, rebooted router several times.

    To those who claimed to get this working with the PS3 (especially miniDLNA 1.0.20), I ask, HOW??? :p
     
  37. molnart

    molnart Networkin' Nut Member

    hi shibby, i finally had some time to upgrade to build 60. i really love the new additions, and i have two small suggestions for the next release:
    - move the clientmon configuration to the Administration\Bandwidth monitoring page. I think its a more logical place and one line in the menus is saved :)
    - PLEASE put back the linux penguin logo to the About page, i really loved it (the QR code is quite pointless since there is already a direct link on the page to openlinksys.info, not to mention that the average tomato user is probably not extremely interested in a bulletin board in polish (although containing lot of valuable information)
     
  38. shibby20

    shibby20 Network Guru Member

    [release] build5x-062

    Changelog:
    - transmission update to version 2.32
    - SNMP integration and GUI
    - HFS/HFS+ Mac OS x read support
    - increase custom schedulers to 5
    - new buildtypes! Check builds.png

    Feedback welcome!
     
  39. shibby20

    shibby20 Network Guru Member

    good point, can do that

    my openlinksys page has lot of valuable information. You can use google translate. I think you will find many of useful information on forum -> tutoriale and will be most understandable for you. Openlinksys is my website and i want to promote it. I use often from QRcode when i`m using my android`s phone. I think it`s better and more useful than the logo of the penguin.
    I use tomato for 3 years and before I started to compile own builds, never looked to the About page. Why is it so important to you?
     
  40. kthaddock

    kthaddock Network Guru Member

  41. molnart

    molnart Networkin' Nut Member

    somehow i always found qr-codes as an useless thing in general. if i want to go to a website i can simply remember enter its url, taking out my mobile to take a photo of some image is quite awkward for me... anyways, i am not wanting to you actually remove the qr-code, just put back the penguin logo somewhere on the about page (there is enough space for that...).

    the about page is kinda my fetish, i can stare at about pages of several programs for minutes. its like a business card of an application...
     
  42. GhaladReam

    GhaladReam Network Guru Member

    Since build 057 didn't help me at all miniDLNA-wise, I decided to update to build 062, which I presume uses miniDLNA 1.0.20. Thanks for the great work shibby!
     
  43. kthaddock

    kthaddock Network Guru Member

    EDIT
    I have tested -062 AIO first look user3 UL there but after awhile it's disappear.
     
  44. GhaladReam

    GhaladReam Network Guru Member

    shibby

    I was wondering if it would be possible to compile a speical AIO build with alternate DLNA/media server software? I was reading about optware packages like Twonky, but I prefer not to use optware if I can get away with it.

    Since I and many others have been having issues with miniDLNA and PS3's (and other devices) are there alternatives which still fit in a 16MB or 32MB flash router that would provide the same, if not better functionality than miniDLNA?
     
  45. ntamas26

    ntamas26 Networkin' Nut Member

    Netgear 3500L flash size?

    Hi guys,

    I would like to fresh install Shibby's Tomato version into a Netgear 3500L router, but now I'm a bit confused.

    I would like to install this version:
    tomato-K26USB-1.28.905xRAF-EN-MIPSR2-062-BT.trx which has a size of 7 696 384 byte -->> 7516K

    This router has 8MB flash, but I found the following post on this forum:

    Does this version will fit into Netgear 3500L or it's too large?
    I would like to have the full integrated Transmission client, and this is the smallest firmware which contains it.

    Thanks for your answers
     
  46. iviux

    iviux Networkin' Nut Member

    A question to shibby

    Hi shibby!

    I use your Tomato Firmware 1.28.0905 MIPSR1-062 K26 USB Big-VPN on an ASUS WL-500gP v2. I like it very much plus i regulary use Transmission from the Optware packages. But now I'am thinking to change this firmware to other that has built-in Transmission (Mega, BT). So I have a question :confused:.
    Did you modify the Transmission source code and built your Queue torrent system into your new (062) firmware?
    [​IMG]
    I am only asking it because it will be very useful to me and I missed this feature from the original Transmission.

    PS: sorry my poor English :frown:
     
  47. GhaladReam

    GhaladReam Network Guru Member

    Hey shibby, just wondering what's coming / on the horizon for your branch?
     
  48. shibby20

    shibby20 Network Guru Member

    @iviux - No, i didnt modify transmission sources. Queue is a bash script, running every 15 min. Its not including into transmission and will works with transmission installed from optware if you use my BT gui and simply change binary path from internal to optware.

    @GhaladReam - at the moment, nothing. Maybe i will try merge vlan-gui into my branch :) Maybe i will continue multilanguage features. I dont have too much free time... :/
     
  49. shibby20

    shibby20 Network Guru Member

    need a betatester ;) I compiled new version:
    - VLAN-GUI support
    - minidlna update to 1.0.21
    - transmission update to 2.33
    - interval options for keep alive and queuing

    someone want test? please PM.
    BR!
     
  50. 56kb

    56kb Addicted to LI Member

    Please help to config nfs server
    Thanks
     
  51. shibby20

    shibby20 Network Guru Member

    what kind of problem have you?
     
  52. 56kb

    56kb Addicted to LI Member

    I got it working now. thanks
     
  53. GhaladReam

    GhaladReam Network Guru Member

    I understand the delay for this is a bug is a WLAN bug in the VLAN-GUI support. I was wondering if you could, in the mean time, compile a new build (including AIO) with newer miniDLNA & Transmission,but leave VLAN-GUI out for now while we wait for this fix? I for one am itching to see if miniDLNA 1.0.21 fixes my PS3 issues, as I noticed it fixes a few crash-related bugs...
     
  54. shibby20

    shibby20 Network Guru Member

    @teaman pushed fix to git. I will test it tomorrow. If will wlan works i will release new version with VLAN-GUI integration. If will not ill revert vlan-gui and release new version witout them.
     
  55. Toastman

    Toastman Super Moderator Staff Member Member

    wireless is working here now shibby
     
  56. shibby20

    shibby20 Network Guru Member

    GREAT! compiling and testing :)
     
  57. shibby20

    shibby20 Network Guru Member

    [release] 065V

    Changelog:
    - transmission 2.33
    - minidlna 2.0.21
    - transmission: allow set interval for keep alive and queuing
    - VLAN-GUI integration
    - fix save button on nas-usb.asp page for K24
    - transmission: more ratio options
    Best Regards!
     
  58. GhaladReam

    GhaladReam Network Guru Member

    Thanks shibby! Do you plan to release an AIO build as well? I didn't see one..
     
  59. shibby20

    shibby20 Network Guru Member

    indeed, compiling at the moment :)

    Preview: my new features - multilanguage.
    I hope will be finished soon :)
     

    Attached Files:

    • en.png
      en.png
      File size:
      42.5 KB
      Views:
      92
    • pl.png
      pl.png
      File size:
      33.1 KB
      Views:
      70
  60. CBR900

    CBR900 LI Guru Member

    Thx shibby20 for the effort...


    I think there is a problem in your site:

    Code:
    Error in ./count on line 778.
    ./K26/build5x-065V/tomato-K26USB-1.28.905xRAF-EN-MIPSR2-065V-Big.trx is already defined.
     
  61. shibby20

    shibby20 Network Guru Member

    thx, fixed.
     
  62. GhaladReam

    GhaladReam Network Guru Member

    Flashed build 065V AIO this morning, everything seems to be running smoothly. Several parts of the GUI do appear to be changed :) I like how simple it is to set up VLANs now! One thing I noticed if you're moving to this build from a previous build, and didn't clear your NVRAM: If you use uPnP / NAT-PMP, make sure you check the new "LAN" checkbox(s) otherwise uPnP won't work for your primary LAN, or any VLANs you create. I'm not sure if clearing your NVRAM before flashing would have this issue.

    Unfortunately miniDLNA 1.0.21 still does not work on the PS3. I still get the dreaded 2104 DLNA error, while my 360 remains error-free. I'm 100% convinced at this point that it's a problem on Sony's end with the PS3's software.

    Keep up the great work shibby!
     
  63. ginson

    ginson Addicted to LI Member

    @Shibby20,

    Tried downloading the 1.28.0905 MIPSR2-065V K26 USB AIO file but got garbled webpage

    Can someone point me to an alternae link?

    Thanks

    Nate
     
  64. gutsman7

    gutsman7 Networkin' Nut Member

    Dude just right click and save file as.
     
  65. CBR900

    CBR900 LI Guru Member

    I just flashed my router with 065V...and can not access my modem webpage.

    I have this:
    Code:
    sleep 5
    ip addr add 10.0.0.10/24 dev $(nvram get wan_ifname) brd +
    iptables -I POSTROUTING -t nat -o $(nvram get wan_ifname) -d 10.0.0.0/24 -j MASQUERADE
    under firewall tab in scripts.

    and it was working with firemware 60.

    Is there any setting I should set?

    please help
     
  66. GhaladReam

    GhaladReam Network Guru Member

    Hey shibby,

    Would there be any way to integrate Toastman's QoS class labels and QoS presets into a future build? I remember seeing them before, and they're much better than the default Tomato QoS labels/presets. They technically don't change functionality, but they are a good guide when it comes to properly setting up QoS.
     
  67. shibby20

    shibby20 Network Guru Member

    @GhaladReam - i will think about this

    @CBR900 - instead of $(nvram get wan_ifname) try vlan1
     
    GhaladReam likes this.
  68. CBR900

    CBR900 LI Guru Member

    can show me the complete script please
     
  69. CBR900

    CBR900 LI Guru Member

    After replacing with vlan1...still canot access the modem
    help pls
     
  70. teaman

    teaman LI Guru Member

    By default, Tomato allows most things on the LAN side to reach out other interfaces (except for LAN <-> WAN traffic). As sugested/requested by other users/testers, that behaviour was changed on VLAN-GUI so any/all interfaces are isolated from each other by default:
    http://repo.or.cz/w/tomato.git/commit/e425061d5d5e85165c8fa72b8622191d0cf5d95f

    Therefore, from now on you'll need a new/extra rule on your firewall to allow network traffic to be forwarded from your LAN to your 'raw' WAN interface (last/3rd command below):

    Code:
    sleep 5
    ip addr add 10.0.0.10/24 dev $(nvram get wan_ifname) brd +
    iptables -I POSTROUTING -t nat -o $(nvram get wan_ifname) -d 10.0.0.0/24 -j MASQUERADE
    iptables -A FORWARD -i $(nvram get lan_ifname) -o $(nvram get wan_ifname) -j ACCEPT
    
    Cheers!
     
  71. CBR900

    CBR900 LI Guru Member

    10x alot
    working
     
  72. shibby20

    shibby20 Network Guru Member

    good to know :) THX @teaman.
     
  73. Goggy

    Goggy Network Guru Member

    Hmm - is it possible that this the 065V - Release breaks the VPN - Functionality?
     
  74. shibby20

    shibby20 Network Guru Member

    possible is always. Can someone confirm the problem?
     
  75. Goggy

    Goggy Network Guru Member

    Downgraded to v62 and VPN works again (for me). Possible that this has something to do with that new behaviour on VLAN-GUI (any/all interfaces are isolated from each other by default)?.
     
  76. teaman

    teaman LI Guru Member

    Hi there - at first, I wasn't quite sure what could be causing problems... so I spent a few minutes looking onto rc/vpn.c and at first sight, it looks like it's handling properly adding/creating any new/required iptables rules... Then, I've reconfigured my routers and ran some tests (I have two gateways here). Four devices involved:
    A) my linux machine (OpenVPN client), default gateway=B
    B) WRT54G v2, my gateway via provider1
    C) WRT54GL v1.1, another gateway (provider2), OpenVPN server
    D) WRT54GL v1.1, test/dev box, on its own network, default gateway=C

    Fired up OpenVPN client on A, accessing the internet thru B, reaching the OpenVPN (via internet) on C. So far, so good.
    Connections from A to D (thru the VPN, around the internet): success.
    Connections from D to A (thru the VPN, around the internet): timeout.

    What was missing? One iptables/forward rule like this one (on C, the OpenVPN server):
    Code:
    iptables -A FORWARD -i LAN_DEV -o OVPN_DEV -j ACCEPT
    In my particular case, the actual command/rule was:
    Code:
    iptables -A FORWARD -i br1 -o tun21 -j ACCEPT
    Would you be able to check if such solution solves your problem?
    Please notice your router might be using different brX or tunX devices... so change them accordingly when/if you're able to test/validate this (and let us know how it goes).

    Thanks!
     
  77. shibby20

    shibby20 Network Guru Member

    [release] 070V-ML

    Changelog:
    - first multilanguage implementation. Available languages: English, Polish, Chinese
    - some fixes of VLAN
    - patch for minidlna to support Samsung TV C550/C650

    If someone want create translation for your language, please let me know.

    Best Regards!
     
  78. GhaladReam

    GhaladReam Network Guru Member

    Just flashed the new 070V multilingual build remotely from work, seems to be working fine. I will have to test miniDLNA when I get home. Is it possible this "Samsung TV" fix for miniDLNA may have silently fixed the PS3 issues as well? I'll know more when I get home, but I'm not holding my breath.
     
  79. Goggy

    Goggy Network Guru Member

    @teaman: thx for your reply and sorry for the delay :oops:

    Not really - i'm a Linux - Noob :(
    Now that Shibby releases a new Version it comes to my Mind that there was something - yes - the VPN - Problem :cool:. Currently i use a WRT54GS with one of Toastmans latest Releases as Server. The RT-N16 with Shibby's Build acts as Client. So i adapted your suggested Rule to my Needs:
    Code:
    iptables -A FORWARD -i br1 -o tun21 -j ACCEPT
    Throwed it on the RT-N16 (Client) and voila - VPN is back online and it seems to work as expected :).

    Thx for your Help!
     
  80. GhaladReam

    GhaladReam Network Guru Member

    Nope, still doesn't work. Not surprised. :( Silly Sony...
     
  81. linsj

    linsj Networkin' Nut Member

    If update 065V to 070V, should I clear NVRAM of RT-N16?
    Thanks a lot.

     
  82. shibby20

    shibby20 Network Guru Member

    i think, you dont.
     
  83. GhaladReam

    GhaladReam Network Guru Member

    One thing I noticed in 070V build is that the miniDLNA server no longer shows up in My Network Places in Windows 7. In 065V and lower, it would show up as a media server on the network. Mind you my XBOX360 sees it and it works fine, but Win7 doesn't see it anymore for some reason...
     
  84. Goggy

    Goggy Network Guru Member

    Is "Language: Custom" currently a Placeholder or is it possible to "test" a Translation-File? If yes where to put and under what Name?
     
  85. pupie

    pupie Networkin' Nut Member

    Hi, I tried to complie tomat-shibby branch for AIO by using the option:make z but I got errors and not image had been found in /release/src-rt/image directory.

    latest portion of make logs:

    Creating little endian 3.0 filesystem on /home/tester/tomato/release/src-rt/router/mipsel-uclibc/target.image, block size 65536.

    Little endian filesystem, data block size 65536, compressed data, compressed metadata, compressed fragments
    Filesystem size 6982.11 Kbytes (6.82 Mbytes)
    31.15% of uncompressed filesystem size (22413.55 Kbytes)
    Inode table size 8148 bytes (7.96 Kbytes)
    24.10% of uncompressed inode table size (33804 bytes)
    Directory table size 9082 bytes (8.87 Kbytes)
    55.31% of uncompressed directory table size (16419 bytes)
    Number of duplicate files found 0
    Number of inodes 1041
    Number of files 800
    Number of fragments 76
    Number of symbolic links 180
    Number of device nodes 0
    Number of fifo nodes 0
    Number of socket nodes 0
    Number of directories 61
    Number of uids 1
    root (0)
    Number of gids 0
    make[3]: Leaving directory `/home/tester/tomato/release/src/router'
    make[3]: Entering directory `/home/tester/tomato/release/src/btools'
    make[3]: Nothing to be done for `all'.
    make[3]: Leaving directory `/home/tester/tomato/release/src/btools'
    # Create generic TRX image
    Total size 8093808 (7904.1 KB) is too big. Maximum is 7995392 (7808.0 KB).

    -----------------
    1.28.0001 MIPSR1 K26 USB AIO ready
    -----------------
    make[2]: Leaving directory `/home/tester/tomato/release/src-rt'
    make[1]: Leaving directory `/home/tester/tomato/release/src-rt'
    is there anything i did wrong when making it? thanks alot.
     
  86. shibby20

    shibby20 Network Guru Member

    @Goggy - put custom.txt file to /tmp/lang/

    @pupie - in file btools/fpkg.c change line
    #define TRX_MAX_LEN<---><------>((8 * 1024 * 1024) - ((256 + 128) * 1024))<---><------>// 8MB - (256K cfe + 128K cfg)
    to
    #define TRX_MAX_LEN<---><------>((16 * 1024 * 1024) - ((256 + 128) * 1024))<---><------>// 16MB - (256K cfe + 128K cfg)

    and try again.
     
  87. Badders44

    Badders44 LI Guru Member

    Shibby, I'm running an RT-N16 with the version in my sig and its running fine as a WPA2-AES G-Only Access Point - many thanks btw. My only issue is that if I choose a channel less than 10 then all my three wireless devices become disconnected - channels 1-9 fail, 10-13 succeed. Advanced/Wireless are set to defaults apart from region which is set to UK but I've tried with US and Singapore and the results are the same. I clear NVRAM before each flash.

    Any ideas what could be causing this?
     
  88. shibby20

    shibby20 Network Guru Member

    i have now installed 071v on my RT-N16 and wireless on channel 7 works great. I havent any problems with wireless.
     

    Attached Files:

  89. Badders44

    Badders44 LI Guru Member

  90. GhaladReam

    GhaladReam Network Guru Member

  91. shibby20

    shibby20 Network Guru Member

    071 is wasnt release jet. It is the same as 070 but with new clients monitor. Thats all.
     
  92. Jas

    Jas Networkin' Nut Member

    shibby20 Is there any way to speedup Transmission download speeds?? I'm getting nothing greater than 25KiB/S .
     
  93. linsj

    linsj Networkin' Nut Member

    updated to 070V-ML of NT-N16, but it's seem lack some graph of Qos.
    Is the setting of RT-N16 wrong? or should update Firefox?
    Thanks a lot!

    [​IMG]
     
  94. Badders44

    Badders44 LI Guru Member

    There is something strange with the QOS graphs. I can't see your image but I'm only getting one segment of the "Connections" graph. The "Bandwidth" graph is showing no graph at all. This is with Firefox 6.
     
  95. shibby20

    shibby20 Network Guru Member

    true, i know about this bug and will fix this in next release.

    @Jas - i havent this problem. Transmission on my rtn16 download with speed 300-400kbit (speed limit dl).
     
    Jas likes this.
  96. Jas

    Jas Networkin' Nut Member

  97. GhaladReam

    GhaladReam Network Guru Member

    I can answer that one for you... the BTgui build only contains the bittorrent GUI and not the actual binaries. If you use that build you have to tell the GUI where to look for the Transmission binaries (such as on a USB HDD) because they aren't built-in.
     
    Jas likes this.
  98. Jas

    Jas Networkin' Nut Member

    I'm new to tomato firmware, so I wanted to know if I can access HDD connected to RT-N16 via NFS ? If yes then please someone tell me step by step how ?? I'll really appreciate that .
     
  99. 56kb

    56kb Addicted to LI Member

  100. pupie

    pupie Networkin' Nut Member

    this is a good mod, if you can merge toastman's QOS class/default rules into your mod, that's perfect.
     

Share This Page