1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Shibby's Releases

Discussion in 'Tomato Firmware' started by shibby20, Feb 26, 2011.

  1. 56kb

    56kb Addicted to LI Member

  2. HeadShot

    HeadShot Networkin' Nut Member

    Because you are using the bash or shell relative to the router and not relative to your own system. Your trying to mount a share on itself essentially.

    First never use Telnet. Unless you want the Zombie hackers of the 1990's to roll over in the graves and bitch slap you; use SSH.

    It will look like this if you are using a Mac or Linux
    xxxxxxxxxxxxxx:~ maxr$ sudo mount -t nfs -o rw /Users/maxr/mnt/
    Host Name~user$ <command>
    sudo is execute as root
    You don't have to type mount -t nfs, it already knows, but I type it anyway to look smart
    The IP address of the NFS share & path
    Where you would like to mount locally
  3. koji

    koji Networkin' Nut Member

    Can anybody tell me if (tomato-K26USB-1.28.RT5x-MIPSR2-082V-AIO.trx) is the last version for RT-N16? I noticed that previous version had RAF inside.
  4. Mysteron

    Mysteron Networkin' Nut Member

    I'm a little confused by the new naming convention as well :( hence my earlier question:

    Please advise on the most appropriate build .

    Many thanks :)
  5. Badders44

    Badders44 LI Guru Member

    Well I've had it running successfully on my RT-N16 for the past few days without any probs :)
  6. shibby20

    shibby20 Network Guru Member

    mount.nfs /mnt/nfs
  7. shibby20

    shibby20 Network Guru Member

    @Mysteron - i removed only 905xRAF-EN and added RT5x, thats all :) You selected correct image.
  8. ntamas26

    ntamas26 Networkin' Nut Member

    Just a short feedback.

    USB 3G modem support works perfectly with a ZTE MF190 HSUPA USB stick.
    Tomato Firmware 1.28.0905 MIPSR2-076V K26 USB AIO
  9. maurer

    maurer LI Guru Member

    shibby, can you build some images with the new wifi driver - in the TEST section :) ?
  10. occamsrazor

    occamsrazor Network Guru Member

    I am running Tomato Firmware 1.28.0000 MIPSR2-082V K26 USB BT-VPN on an E3000 and it seems my 5Ghz network is not working.
    It appears to be running, but am unable to see it from my laptop. I upgraded from Mega-VPN 079, I had too many settings to clear NVRAM, so did a straight upgrade. Actually it might have been not working in 079, but certainly was working previously at some point.
    Any ideas?
  11. Jas

    Jas Networkin' Nut Member

    I'm using windows7, I tried it again the way shibby20 mentioned but, still getting same meassage mount point doesn't exist. I'm not clear about the method you mentioned, please mention how can I use SSH on Win7 ?? Then what command should I use there ??
  12. ppsun

    ppsun Networkin' Nut Member

    I think not clearing NVRAM could be your main culprit for the issues you are facing. When I upgraded from 062 to V7x without clearing NVRAM, it was terrible. It felt like using an early beta firmware. But when I re-flashed it again and zapping the NVRAM, it was back to smooth running. I screen-copied all my settings and manually input it into V7x. My settings are only half-hours worth of manual key-in. For more complex settings, I think I have seen instructions here somewhere to batch transfer the settings across.
  13. ntamas26

    ntamas26 Networkin' Nut Member

    Tomato configuration can be saved and restored here:
    Administration/Configuration/Backup Configuration - Restore Configuration
  14. ntamas26

    ntamas26 Networkin' Nut Member

    I found a small problem:
    -Tomato Firmware 1.28.0905 MIPSR2-076V K26 USB AIO
    -Transmission installed through Optware into the /Opt directory, configured through the firmware's BitTorrent Client menu

    When I have a power outage or power loss, the router reboots, everything working perfectly, except Transmission which says to configure the Transmission.json file and edit the allowed IP adresses.

    If I uncheck the Enable torrent client checkbox, click save, then enable again Transmission can be reached again.
  15. occamsrazor

    occamsrazor Network Guru Member

    Yes, but if you use that to backup and restore it negates the point of clearing nvram, as any "bad" nvram entries would get saved and restored too...
  16. CBR900

    CBR900 LI Guru Member

    I am having problem with iptraffic, I get the messege: The cstats program is not responding or is busy. Try reloading after a few seconds.

    Can you help
  17. anpak

    anpak Networkin' Nut Member

    Hi everybody...i'm a new user in this forum!!!
    I have a big problem with this release of Tomato RAF:

    i've installed it on my E3000...works great well with pc or tablet but there are some problems with Media Server and PS3...i can't browse the directories in media server, error 2140...there is a solution to this problem???
    thanks in advance...
  18. Toastman

    Toastman Super Moderator Staff Member Member

  19. anpak

    anpak Networkin' Nut Member

    i've already read other posts...i understand that now there isn't a solution for this problem...is right?
    now i've found another bug...after some minutes turned on, wireless lan doesn't work well...i find the name of the network but i can't connect...so i need to restart the router...anyone have this problem?
  20. anpak

    anpak Networkin' Nut Member

    there is also an important thing...with TomatoUSB firmware the problem between ps3 and DLNA doesn't not exists...it's very strange!!!
  21. maximus

    maximus Networkin' Nut Member

    Strange, tomatousb build 54 dated 11/30/2010 has absolutely no issues with PS3 using the media server. Works perfectly.

  22. anpak

    anpak Networkin' Nut Member

    Great, can you give me a link to download this version???
    thanks in advance...
  23. eahm

    eahm LI Guru Member

  24. anpak

    anpak Networkin' Nut Member

    i've already tested this version...is a beta version, i want a stable version! this is the reason I installed tomato RAF. Moreover this version doesn't include BitTorrent client!!!:(
  25. maurer

    maurer LI Guru Member

    any news porting the new wireless driver (5.100... RT-N) to the AIO builds ?
  26. shibby20

    shibby20 Network Guru Member

    @anpak - tomato.groov.pl -> k26

    @maurer - For E4200 or RT-N16? For E4200 will be today.
  27. maurer

    maurer LI Guru Member

    RT-N16 please,
    i noticed your E4200 builds already
  28. shibby20

    shibby20 Network Guru Member

    if you really want i can send you test build, but i tried install once RT-N on asus N16 (079V if i good remember) and i quickly go back to RT-K26. Was very unstable.
  29. shibby20

    shibby20 Network Guru Member

    [Release] 083V

    - IPTraffic: fix column sorting on ipt-daily.asp, ipt-monthly.asp and ipt-details.asp
    - IPTraffic: option to show hostnames and/or IPs on IPTraffic graphics
    - IPTraffic: conn/BW ratios graphs
    - Added CPU % usage to Status Overview page
    - Added "Route Modem IP" option (basic -> network). This option allow access to adsl modem in bridge mode.
    - Ovislink 1600GL: Turn on/off "Connected" led when WAN connection is up/down
    - VLAN-GUI: include E4200 and WHR-G54S port mapping

    In K26RT-N directory are also available images with new broadcom driver for E4200, RT-N10U and RT-N12B1

    Best Regards!
  30. maurer

    maurer LI Guru Member

    i tested toastman's rt-n builds and were stable - only usb stick mounted as opt and transmission installed there rebooted it very often
    i switched to your build above with ald drivers and using internal transmission client and is stable for last hours
  31. anpak

    anpak Networkin' Nut Member

    thanks for support shibby...i've tested now this version: tomato-E3000USB-NVRAM60K-1.28.RT5x-MIPSR2-083V-BT-VPN...unfortunatly the problems with ps3 are still present (error 2104)!:(
    somewhere exist a guide to customize a firmware? thanks
  32. eahm

    eahm LI Guru Member

    tomato-E4200USB-NVRAM60K-1.28.RT-N5x-MIPSR2-083V-AIO.bin flashed. So far so good.

    Thanks Shibby.
  33. gijs73

    gijs73 LI Guru Member

    Has anyone encounted Device List missing Wired LAN interfaces? When I check Device List only eth1 devices are showing, none of my Wired devices can be seen although connected. I just flashed tomato-NDUSB-1.28.5x-083V-BTgui in my Asus WL-520GU.
  34. GhaladReam

    GhaladReam Network Guru Member

    I have completely given up on this. The only build that works for me for this is Teddy Bear's build 54, and maybe a few others. Shibby's has never worked for me. I do however still use Shibby's build because absolutely everything else seems to work for me other than this one thing.
  35. shibby20

    shibby20 Network Guru Member

    on k26usb-mipsr2 i see users from both interfaces: eth1 and br0.

    tomorow i can check k24-NDUSB on Asus wl500gp.
  36. shibby20

    shibby20 Network Guru Member

    and this is very strange, because i was revert minidlna to version from build54, but people still reported problem with PS3. I dont know why, now minidlna doesnt work on PS3 :/ i havent PS3 well i cant firuge out this problem, have only x360 :/
  37. GhaladReam

    GhaladReam Network Guru Member

    I agree that it's strange.. I also did try your build a while back that reverted miniDLNA to the same version in as build 54, which didn't work. The only thing I can think of is that there's something in your builds that is not in Teddy Bear's build54 that is causing some kind of conflict with miniDLNA, since the SAME version of miniDLNA works in build54, but not your builds. But as you said, because you don't own a PS3, it makes it hard for you to experiment with this. It boggles my mind since it works 100% all the time on X360.
  38. shibby20

    shibby20 Network Guru Member

    not only in my builds, because in Tomastman`s and Victek`s builds PS3 also wont work. Build54 was released in december 2010, but i (and others developers) based on teddy`s current git souces. I mean chances pushed by Teddy between dec 2010 and april 2011.

    can you (or did you) try this one:

    this is pre55 build compiled only from tomato-RT (teddy`s) branch without any changes. I am very interesting will minidlna works or not.
  39. anpak

    anpak Networkin' Nut Member

    i'm testing this version tomato-E3000USB-NVRAM60K-1.28.9055MIPSR2-git-13042011-Ext ... wait a minute!!!
  40. molnart

    molnart Networkin' Nut Member

  41. anpak

    anpak Networkin' Nut Member

    shibby the problem is still present!!!:(
  42. anpak

    anpak Networkin' Nut Member

    I just tried this:

    - with this firmware tomato-E3000USB-1.28.9054MIPSR2-beta-Ext there aren't problems with PS3 and MediaServer
    - with all of the following firmware the problems with PS3 are present:
  43. shibby20

    shibby20 Network Guru Member

    @anpak - thx for testing. Now i know where i have to search.

    @molnart - indeed. You dont need those scripts. Only set IP of your modem :)
  44. anpak

    anpak Networkin' Nut Member

    de nada shibby!!! i want to resolve this problem as soon as possible !!!;)
  45. dadaniel

    dadaniel Network Guru Member

    Hi shibby,

    When using WAN type 'PPTP', Routing mode 'router' and official IP on LAN interface it is not possible to reach the routers webinterface (pinging works). The routing works fine, but as said above - no webinterface(I also tried Remote Access using port 8080 but it didn't work).
  46. shibby20

    shibby20 Network Guru Member

    @dadaniel - i think you have a modem ip in the same subnet like router. If your modem ip is, you have to change subnet of router`s LAN to ex Subnets have to be different.

    @anpak - i will try figure out which one of changes broken minidlna/ps3 and will give you a test build.
  47. anpak

    anpak Networkin' Nut Member

    ok shibby I will test all your beta versions!!:D
  48. hond_x

    hond_x Networkin' Nut Member

    shibby20, any chance to implement a client eMule (aMule) on this wonderful firmware?

    I ask this because I already got used to using the torrent on the router, no more leaving my PC on 24x7 ...

    But I miss eMule in some situations, and did not want to reinstall it again on the PC ... (believe it or not, there are things you only find in eMule)

    But anyway, thank you for your incredible dedication to this project.


    "ASUS RT-N16 + tomato-K26USB 1.28.RT5x-082V-AIO-MIPSR2"
  49. shibby20

    shibby20 Network Guru Member

    for now you can install amule from optware. I`m thinking about implement TOR into tomato ;)
    maurer likes this.
  50. dadaniel

    dadaniel Network Guru Member

    Hi shibby,

    no, the setup here (default setup for ADSL PPTP with routed subnet here in Austria) is more complicated.
    I have to set the following:

    Type: PPTP
    Username: adsl.1234567@isp.at
    Password: 1234567
    Use DHCP: no
    IP Adress:
    Subnet Mask:
    Gateway: (=Modem IP)
    PPTP Gateway: (=Modem IP)

    After successful dial-in, the router gets an official IP 62.99.xxx.97 Subnetmask My subnet gets routed on this address, so I have to set the LAN settings of my router to IP 62.99.xxx.98 Subnetmask, DHCP server off, Advanced - Routing - Mode 'Router'.

    Currently there are two routers with your firmware in Gateway mode 'behind' this router(their WAN port connected to LAN of this router), their webinterface is reachable, and also tracert and internet connectivity looks ok. (they are set to static ip 62.99.xxx.99 and 62.99.xxx.100, Subnetmask, Gateway 62.99.xxx.98)

    This is a example log of a successful PPTP dial-in(not from this router):
    Dec  6 00:44:35 E3000 user.info redial[14574]: Started. Time: 30
    Dec  6 00:44:37 E3000 daemon.info pptp[14572]: Using interface ppp0
    Dec  6 00:44:37 E3000 daemon.notice pptp[14572]: Connect: ppp0 <--> pptp (
    Dec  6 00:44:40 E3000 daemon.info pptp[14572]: CHAP authentication succeeded: CHAP authentication success
    Dec  6 00:44:40 E3000 daemon.notice pptp[14572]: CHAP authentication succeeded
    Dec  6 00:44:40 E3000 daemon.err pptp[14572]: not replacing existing default route via
    Dec  6 00:44:40 E3000 daemon.notice pptp[14572]: local  IP address
    Dec  6 00:44:40 E3000 daemon.notice pptp[14572]: remote IP address
    Dec  6 00:44:40 E3000 daemon.notice pptp[14572]: primary  DNS address
    Dec  6 00:44:40 E3000 daemon.notice pptp[14572]: secondary DNS address
    Dec  6 00:44:40 E3000 daemon.info dnsmasq[14527]: reading /etc/resolv.dnsmasq
    Dec  6 00:44:40 E3000 daemon.info dnsmasq[14527]: using nameserver
    Dec  6 00:44:40 E3000 daemon.info dnsmasq[14527]: using nameserver
    Dec  6 00:44:50 E3000 daemon.info dnsmasq[14527]: reading /etc/resolv.dnsmasq
    Dec  6 00:44:50 E3000 daemon.info dnsmasq[14527]: using nameserver
    Dec  6 00:44:50 E3000 daemon.info dnsmasq[14527]: using nameserver
    Dec  6 00:44:50 E3000 daemon.info dnsmasq[14527]: exiting on receipt of SIGTERM
    Dec  6 00:44:50 E3000 daemon.info dnsmasq[14582]: started, version 2.57 cachesize 1500
    Dec  6 00:44:50 E3000 daemon.info dnsmasq[14582]: compile time options: IPv6 GNU-getopt no-RTC no-DBus no-I18N DHCP TFTP no-IDN
    Dec  6 00:44:50 E3000 daemon.info dnsmasq[14582]: asynchronous logging enabled, queue limit is 5 messages
    Dec  6 00:44:50 E3000 daemon.info dnsmasq-dhcp[14582]: DHCP, IP range --, lease time 1d
    Dec  6 00:44:50 E3000 daemon.info dnsmasq[14582]: reading /etc/resolv.dnsmasq
    Dec  6 00:44:50 E3000 daemon.info dnsmasq[14582]: using nameserver
    Dec  6 00:44:50 E3000 daemon.info dnsmasq[14582]: using nameserver
    Dec  6 00:44:50 E3000 daemon.info dnsmasq[14582]: read /etc/hosts - 2 addresses
    Dec  6 00:44:50 E3000 daemon.info dnsmasq[14582]: read /etc/dnsmasq/hosts/hosts - 3 addresses
    Dec  6 00:44:50 E3000 daemon.info dnsmasq-dhcp[14582]: read /etc/dnsmasq/dhcp/dhcp-hosts
    Dec  6 00:44:54 E3000 user.info syslog: SNet version started
  51. ForumLuker

    ForumLuker Networkin' Nut Member

    I'm using shibby's build on my Asus RT N16.. 082v bt vpn..
    Tested print server, transmission(download 4mb file), file sharing and media server and is working good..
    No internet disconnection for almost a week now..
    Media server is having dlna protocol error 2104 at first but changing my wifi to g only fixed it..
    Qos and others not mentioned above is untested..
    Thank you shibby.. :)
  52. GhaladReam

    GhaladReam Network Guru Member

    I will try this when I get home from work and report back my results with miniDLNA and PS3.
  53. GhaladReam

    GhaladReam Network Guru Member

    I would also like to help you test this.
  54. GhaladReam

    GhaladReam Network Guru Member

    Changing to Wifi G only did NOT fix the problem for me., just letting you guys know.
  55. anpak

    anpak Networkin' Nut Member

    it's very strange...shibby is possible to install the miniDLNA server that is present in Tomato USB in yours version??
  56. shibby20

    shibby20 Network Guru Member

    yes, but it`s not fault of minidlna. Version of minidlna in build54 is the same as in pre55, but on pre55 minidlna wont work on PS3. Well the problem has to be somewhere else.
  57. GhaladReam

    GhaladReam Network Guru Member

    I can confirm shibby's above statement. A while back he released a test build containing the same miniDLNA build as is present in build54, yet it still gave me the 2104 error on the PS3. Then I flashed to build54 and BOOM, it started working right away. There's definitely something else causing the problem. I also do not believe it is miniDLNA's fault.
  58. nick coero

    nick coero Networkin' Nut Member

    Hi, this is my first post, as i am new on flashing routers with custom firmware. i must admit till now, the most complete tomato firmware is the shibby one and i am really happy with the stability! i posted for something different than the discussion on the dlna, just to propose/ask if there are any plans/possibilities on implementing the https://github.com/opendns/dnscrypt-proxy ,the new opendns encryption way for dns queries.
    Just a question :)

    Keep up the great job!
    eahm and occamsrazor like this.
  59. anpak

    anpak Networkin' Nut Member

    it's very strange!!!what else can causing this problem??
    another question...is possibile install in this firmware the protocol AFP (Apple Filing Protocol)??
  60. dr.gazza

    dr.gazza Networkin' Nut Member

  61. eahm

    eahm LI Guru Member

  62. lancethepants

    lancethepants Network Guru Member

    That would be a nifty feature. I'll put in a request @ tomatousb.org
  63. eahm

    eahm LI Guru Member

    Absolutely! I was about to ask the same thing.
  64. shibby20

    shibby20 Network Guru Member

  65. maurer

    maurer LI Guru Member

    +1 for TOR - client + relay (optional) :)
  66. fubdap

    fubdap Addicted to LI Member

    Hi Shibby,
    It looks like this feature "Ignore DHCP requests from unknown devices" is found in two sections of my 79v and 83v. They are found in:
    Basic -->static DHCP/ARP/IPT
    Advance -->DHCP/DNS
    When I enble one, the other is also enabled. I am not sure whether having two of them was done on purpose or an oversight. Thanks for all your hard work.
  67. teaman

    teaman LI Guru Member

    Hi there! Actually... I wrote that piece of code back in September ;)

    Back then, it sorta made sense in having that particular setting in the Basic: Static DHCP/ARP page... but it was also added to the Advanced -> DHCP/DNS settings page (since it definitively 'deserves' to be on this one).

    So... thanks for bringing that up (i.e. we might eventually do something about that) ;)

  68. eahm

    eahm LI Guru Member

    shibby20, to make it a little safer or even for people to know the file they download is the 100% of the file you've uploaded, could you please post the MD5/SHA1 of each .bin on your site? It's not even important for older files if it takes too much time but I'm just asking for 083V+.

  69. ddd1

    ddd1 Networkin' Nut Member

    +1 for TOR - client + relay (optional)
  70. GhaladReam

    GhaladReam Network Guru Member

    Shibby, just wanted to say that build 083v seems to be one of your most stable so far! In previous builds, Transmission would crash occasionally and when that happened the Keep Alive daemon wouldn't work either, and the load would jump to 3.00/3.00/3.00. Been up for 10 days so far (since you released 083v) and smooth sailing so far, with 0.00/0.00/0.00 load. :) Great work! I'm not sure if this is your doing, or the fact that Transmission 2.42 is more stable than previous versions, but nonetheless keep it up! Thanks!
  71. Jas

    Jas Networkin' Nut Member

    GhaladReam I've the same build on RT-N16 but, I'm getting more crashes of transmission as oppose to previous builds. That's completely weird , maybe I need to re flash !!
  72. Badders44

    Badders44 LI Guru Member

    The only issue I've found with 083V is a generic issue where the default Transmit Power for the Buffalo WHR-G54-HP is set to 42. This is correct for the WHR-G54S but wrong for the HP. Strangely, the text does say the default is 10 on the on the Wireless webpage.

    The USB support is now starting before minidlna which fixes having a custom path for the dlna server on a USB drive. This is good :)

    Also, thinking about the "PS3 errors with the media server" issue, seeing that the code hasn't changed could it be something to do with the boot order of the processes? Maybe something is taking longer to boot up or initialise in later versions - just a thought...

    Thanks again Shibby for a wonderful release :)
  73. GhaladReam

    GhaladReam Network Guru Member

    Looks like I spoke too soon too. Woke up this morning, Transmission had crashed and a CPU load of 2.13/2.40/2.22... Usually I don't get 10 days of uptime before that happens though. I wonder what causes Transmission to crash like that? All other functions seem to work when it crashes though. Rebooted router and everything seems back to normal. NVRAM reset doesn't help.
  74. djroby19

    djroby19 Networkin' Nut Member

    HelloI installedyour versionShibby20o83tutorand I must sayis very goodstable and fast..I have notencountered the problemofoff-timeofWi-Fiand onthis build works perfectly.
    You couldsolve theproblem ofnon-functionalLEDsull'E4200?
    InDD-WRThavesolved..thank you for alltheworkyou carry......;)
  75. ntamas26

    ntamas26 Networkin' Nut Member

    The integrated bittorrent client was never worked stable for me. I installed several RT-N16 and 3500L routers with 60/25Mbit/sec cable connections as a sample at my friends (Tomato 062/076/083).

    On the Asus RT-N16 the best way to use Transmission is the following:
    -format JFFS2 on the admininstration/jffs page
    -ssh into your router and run the following commands (with putty)
    ~ # mkdir /jffs/opt
    ~ # mkdir /jffs/tmp
    ~ # mkdir /jffs/tmp/ipkg

    ~ # mount -o bind /jffs/opt /opt (also copy this row into the init script section on the routers admin, to mount jffs/opt as /opt everytime when the router starts)

    Optware installation:
    ~ # wget http://tomatousb.org/local--files/tut:optware-installation/optware-install.sh -O - | tr -d '\r' > /tmp/optware-install.sh
    ~ # chmod +x /tmp/optware-install.sh
    ~ # sh /tmp/optware-install.sh
    ~ # sleep 5
    ~ # ipkg update
    ~ # sleep 5
    Transmission installation:
    ~ # ipkg install transmission
    ~ # sleep 5

    Then just enter into Tomato webadmin usb and nas/bittorrent client change the Transmission binary path to optware (/opt/bin), and config your Transmission as you like.

    With this config I had more than 800GB traffic in 30 days without any kind of stability issue.
    boondoggle likes this.
  76. GhaladReam

    GhaladReam Network Guru Member

    I will have to test this when I have time. My question is, why is Transmission more stable when installed to JFFS as an Optware package vs. being integrated? There has to be something causing it to crash if this is the case.
  77. ntamas26

    ntamas26 Networkin' Nut Member

    Transmission is more stable when installed as an Optware package.

    -I just mentioned JFFS because it's a convenient solution for the RT-N16. You don't have to install Transmission into the hard drive etc.
    -All I know, everytime I used the integrated client on my friends router, I always got complaints about stability, crash problems.
    This is a Netgear 3500L installation with Shibby's Tomato 076, Transmission 2.42 installed as an Optware package, configured through the bittorrent client settings page (transmission binary path set to optware):


    My experiences with the integrated Transmission client:
    -it's very sensitive against paralell downloads, crashes more often when I download simultaneously
    -when the client crashes the keep alive function does not work, I need to uncheck then recheck the enable torrent client on the webadmin, to get the client working again
    -if the netspeed is low ( adsl around 5-10mbit/sec) there are less complaints about crashes, but with hight speed cablenet (above 25mbit/sec) the client becomes more unstable
  78. StickMonster

    StickMonster Networkin' Nut Member

    Shibby, you are awesome. I've been reading your threads, and I find your skills, your dedication, and especially your helpfulness amazing.

    I just recently switched from the regular 54 tomatousb build to Shibby's tomato-K26USB-1.28.RT5x-MIPSR2-083V-AIO.trx on my RT-N16. On build 54, minidlna was working with the PS3, and on build 83 it was not. I've now read the various threads and see that it's a known problem.

    I've done some experiments, trying differenent combination of firmware and minidlna, and can confirm what others are saying.

    On firmware build 54, minidlna version works AND version 1.0.22 works.
    On firmware build 83, minidlna version works AND version 1.0.22 DOES NOT work.

    My conclusion, like others, is that the problem with minidlna and the PS3 is firmware dependent and not minidlna dependent. Furthermore, minidlna does work with the PS3 with certain versions of firmware, so the problem should be fixable in the firmware, without focusing too much on the version of minidlna or the PS3.

    I see that here that it looks like someone narrowed down the problem to a pretty small window. I haven't confirmed because those builds aren't compatible with my RT-N16 (I think).

    I can try out different firmwares or other combinations to help narrow down the problem. Any suggestions? Anything else I can do to help?

  79. anpak

    anpak Networkin' Nut Member

    Great StickMonster!!!;) i hope that shibby could resolve this problem with ps3!!!!!!!
  80. shibby20

    shibby20 Network Guru Member

    First i need to borrow PS3 console from my friend :)
  81. GhaladReam

    GhaladReam Network Guru Member

    Tell your friend hundreds (and possibly even thousands) of people will be forever in his (and your) debt if he lends it to you ;)
  82. StickMonster

    StickMonster Networkin' Nut Member

    @Shibby, I understand. It is easier to fix something when you can replicate the problem! However, if you want to just want to create a dozen test builds, I'd be happy to spin through them and tell you which ones work.

    I'm happy to help, and others are too, in whatever way we can. It's the least we can do.
    anpak likes this.
  83. anpak

    anpak Networkin' Nut Member

    @Shibby the new version of your firmware will be the best Xmas gift!!!:D:D
  84. shibby20

    shibby20 Network Guru Member

    indeed. I dont know which one of teddy`s commit broke comunication between minidlna and PS3. I need to make revert some parts of commit i test, revert next part and test again ... :/
  85. zergelo

    zergelo Networkin' Nut Member

    Hi There,

    First of all i have been using your fw on my RT-N16 and it is far far better than any which i saw so far, so thanks Shibby. 2 things which i still looking for...the 1st is the same PS3 streaming issue which i also have with your latest build. (i saw it is already being discussed) The 2nd is more question, i've been reading through the topic and googled a lot but i have not found any solution to enable external subtitle (mainly .srt) in the stream. I am now watching over a Philips smartTV but it is showing the subtitle if i stream from a PC but would be lot better if i can use this option from my router. Can you let me know if there is any option to enable it. I saw that in miniDLNA running on linux desktop has this option so i hope it is existing in your Tomato rom as well so it is me who is noob enough to not to find it :)

  86. djroby19

    djroby19 Networkin' Nut Member

    Shibby AIO-083 is very good you could also add PPPoA onthe router?
    It would be pleasant to make the LEDs running on E4200..Thanks again...Positive feedback :D
  87. hond_x

    hond_x Networkin' Nut Member

    I'm also getting exactly the same conclusion.

    The only thing missing is learn how to install / use Optware :)

    But I can not forget to give a big thanks to Shibby by the effort and dedication to this project.

    Thanks Shibby

    ps: I'm still going to test other releases, for sure ...
  88. shibby20

    shibby20 Network Guru Member

    you dont need PPPoA (PPP over ATM). Because your WAN is Ethernet, you need PPPoE (PPP over Ethernet). PPPoA you should using when you will have Router with ADSL modem

    which of leds doesn`t work?
  89. pazos

    pazos Networkin' Nut Member

    shibby20, your work seems awesome! I have an Asus 520gU running tomato raf, which version of your firmware is recommended for my device? Maybe k24-btgui? Have anybody tested this router with shibby's firmware?

    Thanks in advance
  90. GhaladReam

    GhaladReam Network Guru Member

    I have tried this and have since had 100% stability. In light of this, shibby, would there be any way you could update your "BTgui" build to include everything AIO has minus the Transmission binaries, so that we can have a little more space in JFFS? Currently, BTGui build seems to be missing OpenVPN, NFS Server and Captive Portal. Oh and obvousely keep the Bittorrent gui :)

  91. shibby20

    shibby20 Network Guru Member

    hmm Big-VPN? :)
  92. Toastman

    Toastman Super Moderator Staff Member Member

    Happy New Year, Shibby!
  93. GhaladReam

    GhaladReam Network Guru Member

    Does Big-VPN include the bittorrent UI? According to your builds.png, it does not.

    EDIT: Nevermind, yes it does. My mistake! I didn't notice this build. Thanks shibby!
  94. eahm

    eahm LI Guru Member

    shibby20, yesterday I configured a WDS for a customer and the main router was restarting every time a change was applied. I ended up choosing not to use a WDS for different reasons but just wanted to let you know.

    The main router was a Cisco Linksys E2000 and the second one was the same, E2000. The firmware was this one: tomato-E2000-NVRAM60K-1.28.RT5x-MIPSR2-083V-IPv6-VPN.bin, same firmware on both routers.
  95. scorpeeon

    scorpeeon Networkin' Nut Member

    Hi! This might be a bit off, I just don't know where to ask:

    I have an E4200 since about a month, I used it with stock fw, there are 4 computers connected to it on LAN, and a laptop and a few phones connected on WiFi. Until a few days ago it worked OK, achieving 80-150 Mbps real speeds on 5GHz WiFi, but recently when watching a movie on a LAN connected computer from the laptop connected on WiFi, (it was only mid-quality 720p) in the middle of the movie it suddenly started to struggle, the movie got stuck several times. I restarted both computers, but it wasn't fixed. Then restarted the router too, but that didn't help either. Ever since, the WiFi speed is just miserable, i usually get 20-40 Mbps, but sometimes it even goes as low as 10 Mbps. I checked in inSSIDer that there's not a single other router on 5 GHz near me, no I wouldn't think it's an interference related problem. I tried playing around with wireless settings, for a moment when I disabled all encryption for wireless (no WPA/WEP or anything) and for a few minutes it reached 150 Mbps but then when i switched back to normal WPA encryption it dropped down to the miserable level.
    So it delivered nice performance for weeks and now it's just miserable. Since it seemed to have a nice performance when encryption was disabled, I think it must have something to do with the router's firmware. I haven't tried 30/30/30 resetting yet but i think i should.

    Anyway the real reason i'm here is because I want to take a look at other firmwares, my previous Linksys router was shit too when using stock firmware (it got disconnected always) and when I used it with DDWRT, it was rock stable. Most people recommend Tomato for this router, mostly Toastman's or Shibby's build. Is there a guide how to flash them on E4200? DDWRT had a guide, like doing a 30/30/30 reset before and after the upgrade, and sometimes you had to use mini build first and only after could you use bigger, mega builds, and stuff like that. So is there a guide of how to flash Tomato? Or should i just 30/30/30 before and after and it should be fine?
    Also which build should I use? 5 GHz WiFi is a must for me, so I guess i have to use an RT-N version right? Let's say i want a Shibby build.
    So should tomato-E4200USB-NVRAM60K-1.28.RT-N5x-MIPSR2-083V-AIO.bin work well?
    Also can I go back to stock fw if something goes wrong/i don't like it? Also if i go back to stock would i still have warranty on the router so they can't tell that it was running 3rd party fw before so the warranty is void? It wasn't a cheap router, so i'll try hard not to get it bricked, I flashed several DDWRT builds on my previous router without problems, it would be just nice to know for sure...

    Thanks in advance for your help!

    Edit: just thought of something, and deleted the known wireless connection on my laptop, connected to it, re-entered password and my hyper-fast WiFi is back delivering 160-170 Mbps contantly. Looks like the problem was on the laptop side (khm.. Windows... khm...) the whole time, i just didn't think of that because i haven't touched it while i first encountered the error.
    Anyway, i'm still willing to try a Tomato build and see how it performs :)
  96. StickMonster

    StickMonster Networkin' Nut Member


    I tried disabling a bunch of stuff to see if I could zero in on the problem component that might be interfering with dlna and the ps3. I wasn't successful, but for the record, this is what I tried.
    • disabling wireless (used a wired connection)
    • disabling NTFS and FAT support
    • disabling file sharing
    • running minidlna from jffs
    • disabling usb support (copied media to jffs)
    None of those helped. I tried a bunch of firewall, network and NAT settings too, but I didn't keep good track of what all I tried.
  97. koji

    koji Networkin' Nut Member

    Hi everyone,
    I'm using a dual-stack native IPv4, IPv6 with prefix delegation from my ISP, and every 2 or 3 days, I have to disconnect from WAN or restart the router, (by the way, it's a Asus RT-N16) cause I can't access any IPv6 site, of course, I have no issue on IPv4... I'm currently use tomato-K26USB-1.28.RT5x-MIPSR2-083V-AIO.trx. Can anybody tell me what's happen?
    Thank's anyway for your answers.
  98. tipunch

    tipunch Networkin' Nut Member

    Hello Shibby,

    Would it be possible to include the program forked-daapd (iTunes Server) or somebody could made a package for tomatoUSB? There already exists for OpenWRT…

    Thanks and Happy New Year !
  99. shibby20

    shibby20 Network Guru Member

    i can try make ikpg package.

    BTW, i`ve got PS3 ;) tests begin.
  100. scorpeeon

    scorpeeon Networkin' Nut Member

    Meanwhile i installed Tomato (RT-N, AIO version) to my E4200 and i can say it seems to be working much stable, much better than the stock fw did.

    There only one thing might worth mentioning: The status LEDs don't seem to work the way they did with stock fw. They're not blinking when there's traffic on them and out of 2 LEDs on each port only one is turned on (randomly either the left or right one) and is illuminating constantly. It's not a real problem for me, just thought worth mentioning.
    Apart from this, it's really perfect, thanks for this great firmware!

Share This Page