1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Shibby's Releases

Discussion in 'Tomato Firmware' started by shibby20, Feb 26, 2011.

  1. RichtigFalsch

    RichtigFalsch Networkin' Nut Member

    As long there's no solution found I think it's worth discussing.
    For example, well, we could even try crowdfunding to pay brainslayer for fixing some of the most important well known problems. Of course this could throw him the question, if it would do harm to his own business. But I also think, he might be induced by the challenge.

    Regarding the requirements this idea seems like the pulled out of the hat solution to me, I find the thought funny - at least.
     
    Last edited: Jan 6, 2017
  2. Tim Sudall

    Tim Sudall Connected Client Member

    Seems like there's a pattern here. I want to stay on tomato, I love tomato but can I really put up with the limited channel selection? Going back to DDWRT appeals as they don't have bugs like this but it means you miss out on the nice UI and various features become more complicated to use.

    Then of course if you don't use QOS AsusWRT supports hardware acceleration and also doesn't have these limits.
     
  3. comego

    comego Network Newbie Member

    I flashed a R6400 with advancedtomato (shibby base) and it looks good, except for QOS. I enabled it and classifications seems to be there, however the limits on upload/download on the WAN (wan1) are not respected. I have a 100MBit/20Mbit (download/upload) VDSL and If I try to limit the WAN to say 50/10Mbit (i.e. 50000/10000kbit in the gui) I can still reach the full 100/20MBit of the uplink.

    I'm not sure if this is a problem with advancedtomato or if it's a shibby thing too, or is it me alone with this issue ?

    All I did was enable QOS, leaving default values everywhere, except filled up the speed for upload and download on wan1.
     
  4. AndreDVJ

    AndreDVJ Addicted to LI Member

    As far as I know, enabling bandwidth limiter is a pre-requisite. Did you enable it? It works fine at my end.
     
  5. comego

    comego Network Newbie Member

    Well, QOS deals with saturation on the uplink (WAN), while the BW limiter's job is to limit certain clients or whole lan segments to a lower limit than the one available on WAN. They *should* be independent and there's no mention on the limiter in shibby/toastman tutorials.

    The simple usage scenario would be for having full speed between lan segments (br0<->br1) but QOS for WAN connections.

    EDIT(2) removed wrong info.
     
    Last edited: Jan 7, 2017
  6. comego

    comego Network Newbie Member

    So, I enabled BW limiter, and left all lan unchecked. There was a new script (qoslimit) in /tmp/etc which added some limits directly to the physical interfaces (br0 and vlan2 in my case). The QOS script instead uses an intermediate device (ifb0).

    The qdisc/classes/filters seem there. So does the limiter. However, both dslreports speed test and the ookla speed test show my full line speed and not the limited speed I need to achieve.

    I'm running with all default settings. Just enabled QOS/Limiter and put numbers in the upload/download limits.
    I'm quite sure the qos scripts are broken (at least regarding the U/D limits).

    I tried a few other variants (toastman, shibby and advancedtomato) do the same. I also tried different queue disciplines with the same results.

    Perhaps, some traffic escapes classification and goes directly to the WAN, which is not limited, as limits are done only on the intermediate device (ifb0) ?
     
  7. vr33595

    vr33595 New Member Member

    Hi,

    I created guest network, by adding another bridge and another virtual wireless interface.

    But I have file sharing and DLNA media server enabled. How to make them available only to the first, non-guest network, but not to the guest one?
     
  8. RichtigFalsch

    RichtigFalsch Networkin' Nut Member

    Hello!

    You can tell samba (File Sharign) to use one of your bridges only, using Samba Custom configuration, like this:
    Code:
    [global]
        interfaces = br0 lo
        bind interfaces only = yes
    Edit the adapter name (br0) to what your private VLAN bridge name is.

    I don't use DLNA, but when I just had a look at it, it was set to use br0 (that's the private VLAN at least oyn my router) for default, in it's config file at /etc/minidlna.conf:
    If you where using another bridge or pysical network adapter for your private VLAN, I you could achieve this by adding some commands to the end of Tomato's scripts (Init section) (using sed, awk or egrep), for removing this line, adding a modified one using your favorite adapter, and restart miniDLNA.
    For example would try it alike this:
    Code:
    sed -i '/^network_interface=/d' /etc/minidlna.conf
    echo 'network_interface=br1' >> /etc/minidlna.conf
    killall minidlna
    minidlna -f /etc/minidlna.conf
    
    I now tested the script, and it's working, but I didn't test, if miniDLNA really only responds on br1 after the change. Also you should know, that stopping and starting the Media Server through the WebUI would undo the change, until the script is run again, by rebooting the router. For improving on this you could create a checking script that would monitor /etc/minidlna.conf for changes and execute those commands when triggered.
     
    Last edited: Jan 8, 2017
  9. Sean B.

    Sean B. Networkin' Nut Member

    Didn't fully read through so this may have been noted already. I was able to change the country codes, regrevs, and PA max limitations by modifying the CFE for my RT-AC68P. Specifically, setting them to a test mode so to speak that removes all restriction for power and channel availability. The wireless driver uses these values in the CFE to impose limitations on transmit power and channel use. Allowing one chipset to be used for all regions, as it's much cheaper to taylor the software per region than multiple runs of IC's.
     
    Last edited: Jan 8, 2017
  10. TTROUT

    TTROUT Network Newbie Member

    Well these test codes and the possibility or the necessity (due to broken implementation - tomato) are the reasons why some manufacturers already had to lock down their firmware.

    If you advertise this as the tomato way, then you ask for more lockdowns.
     
    RichtigFalsch likes this.
  11. Sean B.

    Sean B. Networkin' Nut Member

    I did not advocate the abuse of such modifications nor promote reckless "power jockey" abandon. I was providing knowledge I've gained that pertains to the replied quote. The modifications I've made for my personal use added just enough tx power to reach a clear 5ghz signal to my garage, done so in a neighborhood with no competing 5ghz wi-fi signals and at a level which shows no change 10ft outside of my house. Even though it gains me the ability to stomp the entire neighborhood in both 2.4 and 5ghz bands if I so choose. While I understand what you're saying, preaching in a holier-than-thou fashion without any idea what's been done is unnecessary.

    And to add, reverse engineering is what Tomato and most 3rd party firmware is based on, save the very few which have formed relationships with the manufacturers themselves. A lack of self-control and basic common sense are what turns this into an issue.
     
    RichtigFalsch likes this.
  12. comego

    comego Network Newbie Member

    People should understand that regulations and limits are there to ensure fair use and availability of the radio spectrum which is a limited resource. Jacking up power and removing limitations might have disruptive effects on other's ability to comunicate or use other vital equipment. Think about radars for civil, or worse, military use. You don't want a military knocking on your door and taking you in custody for disrupting national security and interfering with who knows what operation.

    Sorry, but I'm a licensed ham operator and feel a little offended by other people ignorance in the matter.
     
  13. Sean B.

    Sean B. Networkin' Nut Member

    I completely agree. But I must say I get a kick out of how people jump all over the concept, as if they "must" know more than someone that has modified their power levels or channels.. and that the modification "must" be causing interference elsewhere, and that the "modifier" is guaranteed to have no knowledge of what they're doing and has certainly not performed any checks an balances of their output or range of any kind. Yes, regulations are in place as not everyone does give a crap about what else they interfere with or have a concept of what they're doing. Same as regulations for crossing a street outside of a crosswalk, as people may get hurt doing so. Yet I wonder how many people are "guilty" of that. If anything about my post implied "Hey if you do this you can crank out so much power you'll microwave a burger from across the room, everyone should do it" then the finger wagging would have some valid reason. Nothing of the sort was stated.

    Bonus factor: Those who really do know what they're talking about, and aren't just on a holy crusade when txpower is mentioned, would probably think to ask " are you running stock antennas? ". Sense PA power (mV) is only half the equation in FCC RF regulation. Regulation governs Equivalent Isotropically Radiated Power, a factor of effective transmission power and antenna gain. Yet everyone just thinks about the txpower as an end all doomsday number.
     
    Last edited: Jan 8, 2017
    Mr9v9 likes this.
  14. comego

    comego Network Newbie Member

    Sean, I see your point and I did not want to step on your toes.

    Discussing radiation patterns, EIRP etc might be too much for this forum, but suffice to say that one of the issues with 5G is that some channels *do* interfere with radars both military and civil and in some countries ppl might find that the hard way when police knocks on their door. The reason for a country setting in the drivers is so that ppl are less likely to shoot them in their foot by accident.

    With that said, I agree with what you say, specially the silly regulations for crossing "public soil" with your "pirate" signal.

    O too hate it when mfg are forced to put protections in their gear to prevent tampering.
     
    Sean B. and koitsu like this.
  15. Azuse

    Azuse LI Guru Member

    Quick question, I realise the AC68U Version C1 is incompatible, but is there any firmware difference between versions A1, A2 & B1? I.e. will all firmwares work on them? I'm also curious about the AC66U B1. Will current firmwares run on it's new cpu?
     
    Last edited: Jan 8, 2017
  16. RMerlin

    RMerlin Network Guru Member

    No, the firmware is identical between these three revisions.

    No, because just like the RT-AC68U HW rev C1, it uses a newer CPU.
     
  17. noparking247

    noparking247 Serious Server Member

    Happy New Year folks,

    I was recently gifted a PS4 and noticed a bug in "Tomato Firmware 1.28.0000 -138 K26ARM USB AIO-64K" on my R7000.

    When I added the PS4's IP address to the DMZ, external SSH access broke. The settings I have are as follows:

    Administration > Admin Access > SSH Daemon
    Remote Access: Checked
    Remote Port: 8080
    Remote Forwarding: Checked
    Port: 22
    Allow Password Login: Checked

    I was wondering if anyone else could validate my findings -- or if I'm still just hung over from New Years.

    Thanks!

    EDIT: Once I removed anything from the DMZ, everything worked perfectly fine.

    EDIT #2: Within "DMZ" I tried having "Leave Remote Access" both toggled and not toggled -- this did not make a difference.
     
  18. comego

    comego Network Newbie Member

    William Clark likes this.
  19. Jose C

    Jose C Connected Client Member

    can somebody please confrm how stable (or not) is shibby 138 on a R7000? also how about wifi stability, range and if there are some known issues.

    PD. I know dual wan and QoS is not working very well but im not really interested on any of these two features.

    thanks
     
  20. koitsu

    koitsu Network Guru Member

    AFAIK Shibby 138 "works well" except for the following things:

    - QoS complexities
    - VLAN (and possibly Wireless VIFs, but definitely VLANs) problems
    - MultiWAN bugs that manifest themselves in bad ways
    - The above bugs may impact single-WAN usage for bandwidth monitoring graphs/data

    In general if you want to use Shibby, the go-to release right now for most is 132. Some are using 136.
     
  21. Jose C

    Jose C Connected Client Member

    Thanks for the info! I will go now with the 132 for now


    Sent from my iPhone using Tapatalk
     
  22. xips_

    xips_ Serious Server Member

    Ummm, sampling the data @ R7000 TomatoAnon database indicates approx 10% of users running 132 vs approx 62% on 138.

    My R7000 single WAN with 138 runs rock solid.
     
    TRIUMF likes this.
  23. Grimson

    Grimson Networkin' Nut Member

    Some notes about acquiring an SDK from a hardware producer:
    I have some experience with the terms of getting an SDK from hardware producers, not with Broadcom specifically but I don't think they handle it that much different than the other companies.

    I can't go into exact details as I'm obviously not allowed to spill company internals on the internet, but I can provide some notes on the basic requirements:

    First an foremost, you don't simply buy an SDK and can do whatever you want with it, you license it. This means you make a contract that allows you to use an SDK for a specified amount of time (often 3, 5 or 10 years) for an annual payment. During that time you are allowed to create and distribute products (software and/or hardware) based on the SDK. When the contract ends you have to cease creation and distribution of all products related to the SDK, so you have to renew the contract.

    The annual cost of an SDK depends on whether you also pay an additional fee per sold product, as this won't be possible for Tomato expect the cost to be somewhere in the 5 digit range per year.

    As this is a business contract it's very unlikely that Broadcom will even start negotiations with a private person. Even if they do and let's say Shibby will be able to buy SDK access for 3 years, it would mean that he cannot simply share any of the code, created with the SDK, with for example Toastman.
    In all likelihood the developers would have to come together and form at least an association with legal capacity, that holds the rights to the Tomato specific code, to be considered for business negotiations. This would create additional costs, and might not be possible at all given that some of the original creators went silent.
    If this would at all be possible, I would also highly recommend to get the help of an actual business lawyer for the contract negotiations and they don't come cheap either.

    So this is not a matter of "Let's raise 2000 bucks to buy the SDK and we are done", but rather a huge undertaking.

    I doubt his contract with Broadcom would even allow him to provide code based on the SDK to projects outside the business he has licensed it to.
     
    koitsu, AndreDVJ and Toastman like this.
  24. Jose C

    Jose C Connected Client Member

    Thanks for that info, just out of curiosity, what kind of WAN connection do you have? I have ADSL2+ with PPPoE and read some post behind an user was having issues with that.
     
  25. koitsu

    koitsu Network Guru Member

    "Ummm," and your point is what exactly? Did you even read what I wrote? What percentage of people are using 132 vs. 138 has zero relevancy. The fact is that several features in 138 are broken; it is sometimes specific certain models, but in other cases it's universal. So, if you don't use those features, or are using an unaffected model, then 138 works great. So again: what's your point? Do you really think I'm trying to spread FUD about this when there's sufficient evidence in this thread and spread across several other threads all discussing said problems? Get real.
     
  26. xips_

    xips_ Serious Server Member

    Running DHCP with cable. I used to run PPPoE with pre multiWan.
     
  27. xips_

    xips_ Serious Server Member

    I quoted what your wrote. Own it and stop rationalizing.

     
  28. koitsu

    koitsu Network Guru Member

    Cool, then I look forward to you digging through all the posts (including those in this thread), and other threads, demonstrating where 138 is broken and how rolling back to either 132 (for most), 136 (for some), or 137 (for an even smaller few) works around one or more of the issues I mentioned. Looking forward to those replies!
     
  29. Tim Sudall

    Tim Sudall Connected Client Member

    In this post in the R7000 Asuswrt @RMerlin states:

    So can tomato copy this?
     
    RichtigFalsch likes this.
  30. Mercjoe

    Mercjoe Network Guru Member

    Why in the world would WANT to copy this?
     
  31. Tim Sudall

    Tim Sudall Connected Client Member

    Because then the problem can be solved by running a modified CFE and you don't need to edit anything to the nvram each time. Of course setting the nvram correctly would be a better option but it doesn't look like this is possible without access to the ins and outs of the broadcom WiFi driver.

    Anyway, does anyone know how to alter the nvram to show all available UK channels or where I can look for this info?

    I've tried

    nvram set wl0_country_code=gb
    nvram set wl0_country_rev=0
    nvram set wl_country_code=gb
    nvram set wl1_country_rev=13
    nvram set wl0_country=gb
    nvram set wl_country_rev=0
    nvram set wl1_country=gb
    nvram set wl1_country_code=gb

    But all it does is change the country code in advance it doesn't open anymore channels. ​
     
  32. Sean B.

    Sean B. Networkin' Nut Member

    nvram show | grep ccode

    These variables need to be changes as well. Use " wl country list " to see all supported country codes and their matching region, use " wl channels_in_country " for a list of channels available for the specified country code.
     
    RichtigFalsch and Tim Sudall like this.
  33. Tim Sudall

    Tim Sudall Connected Client Member

    Code:
    root@R7000:/tmp/home/root# wl -i eth2 channels_in_country GB a
    36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140
    Code:
    root@R7000:/tmp/home/root# wl -i eth2 channels
    36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140

    That's correct yet in the UI doesn't give these options with GB as country.

    Code:
    root@R7000:/tmp/home/root# nvram set wl -i eth2 channel 100
    root@R7000:/tmp/home/root# nvram commit
    root@R7000:/tmp/home/root# reboot
    
    Didn't change anything

    Also tried to find county_rev as mentioned previously with Asus routers but does it not apply to netgear ones?
    Code:
    root@R7000:/tmp/home/root# wl -i eth2 country_rev
    wl: Buffer too short
     
    RichtigFalsch likes this.
  34. Sean B.

    Sean B. Networkin' Nut Member

    I believe the format for country revision for wl directly is an addition to the country code, not a country_rev command specificly.

    " Where <built-in> is a country country code followed by '/' and regulatory revision number. "

    This is a very invalid concept of how nvram variables are set/work. I use Toastman builds, and nvram variables can differ across firmware flavors but shibby's is usually very close. First do " nvram get wl1_channel " and make sure it returns with a value confirming it's existence and use.. I'm rather sure it will be. Then once confirmed, do " nvram set wl1_channel=100 " followed by " nvram commit " + reboot.

    No offense intended by this at all, as everyone's at different levels of experience and learning. But I must say be very careful arbitrarily setting and commiting nvram variables until you understand the overall concept of how they work, plus how to properly set them. There are zero safeguards when altering the nvram settings manually, and it can have serious negative consequences for your router.
     
    Last edited: Jan 11, 2017
  35. koitsu

    koitsu Network Guru Member

    Sean touched base on this, but I'll touch base on it a little more sternly and clearly: this command is bogus (i.e. completely wrong). You don't "nvram set" shell commands (wl is a command/utility, just like nvram is a command/utility). What's important to know is that despite this command looking like it did something, it actually did nothing.

    nvram up until very recently would not emit usage syntax/errors properly; it would just exit normally when given wrong/bogus syntax. The commit for that fix is here, which is only available in very new Toastman ARM firmwares (ones released roughly at the start of 2017):

    http://repo.or.cz/tomato.git/commit/198bcc0665d00eba9da9f46e882943e6a19089ab
    http://repo.or.cz/tomato.git/blobdi...lease/src-rt-6.x.4708/router/nvram_arm/main.c

    In other words: nvram set wl -i eth2 channel 100 did absolutely nothing (it wrote nothing to NVRAM).

    Protip, Tim: do not fool around with the nvram command or the wl command. (The former is actually the more dangerous of the two, for most things, but you can surely botch something temporarily with wl). If you aren't sure how to use either command, ask here first. For those two commands, you can get a usage syntax by just running the commands without any arguments (e.g. nvram and wl).

    P.S. -- @Toastman You botched my Email address on that commit. ;-)
     
    Tim Sudall and RichtigFalsch like this.
  36. RichtigFalsch

    RichtigFalsch Networkin' Nut Member

    Strange:
    On my R7000 channel_in_country won't work for 5GHz:
    It same for every other region I have tried.
    Yet, I am using 5GHz right now.


    It's working for b band, though:
     
  37. Tim Sudall

    Tim Sudall Connected Client Member

    I had that problem its because you need to specify an interface with the -i variable. So whatever interface you have for 5ghz (eg wl1 or in my case eth2)

    As my command above:

    Code:
    wl -i eth2 channels_in_country GB a
    and replace eth2 with your interface instead
     
    RichtigFalsch likes this.
  38. Tim Sudall

    Tim Sudall Connected Client Member

    Thanks guys, I really appreciate the help. Its interesting to learn these commands and I do understand the risks.

    So I tried
    Code:
    nvram get wl1_channel
    and it returns 0 whilst
    Code:
    nvram get wl0_channel
    returns 6.

    Does 0 dictate automatic?

    Am I right guessing this is correct as my current 2.4ghz channel is 6 and my 5ghz channel is auto (GB has no other option)

    If I wanted simply to set a script on startup to specify my channel with wl or nvram commands would this be possible? Would it also be possible by the same means to specify channel width and transmit power so I can manually set to a channel and make sure I am still complying with local radio laws?

    To start with the wl command i've tried:
    Code:
    root@R7000:/tmp/home/root# wl -i eth2 channel 100
    but when I run:
    Code:
    root@R7000:/tmp/home/root# nvram get wl1_channel
    I receive:
    Code:
    0
    
    Ater trying to set the channel I also tried this command
    Code:
    root@R7000:/tmp/home/root# wl -i eth2 channel
    But it gives me the UK channel that is always set by default on auto

    Code:
    No scan in progress.
    current mac channel     36
    target channel  36
    Don't really understand why the nvram get wl1_channel command doesn't seem to work for 5ghz but the wl -i eth2 channel does when the nvram get wl0_channel command works fine for 2.4ghz.
     
  39. Grimson

    Grimson Networkin' Nut Member

    Commands issued via command line will usually not be reflected in NVRAM, so you won't see a change in NVRAM variables when you use the WL command.

    Think of the NVRAM as a kind of config file that is being used by Tomato to configure the whole router when it is turned on. That "config" is simply stored in flash and only modified by using the GUI, in some small parts by the Tomato system during runtime or the NVRAM command line utility.

    Manually changing stuff with system utilities like "wl", "ifconfig", "iptables" and so on will have no effect on NVRAM. This is actually good, as you can try changes (especially when it comes to custom iptables rules) without changing the permant config, so in the worst case a hard reboot will return you to a configuration that was working before.
     
    Tim Sudall likes this.
  40. Tim Sudall

    Tim Sudall Connected Client Member

    Thanks, I understand now. That makes sense. But still :(
    Code:
    root@R7000:/tmp/home/root# wl -i eth2 channel 100
    root@R7000:/tmp/home/root# wl -i eth2 channel
    No scan in progress.
    current mac channel     36
    target channel  36
    
    I don't understand because:
    Code:
    root@R7000:/tmp/home/root# wl -i eth2 channels_in_country GB a
    36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140
    
    and

    Code:
    root@R7000:/tmp/home/root# wl -i eth2 country
    GB (GB/0) UNITED KINGDOM
    
     
  41. lubmar

    lubmar Network Newbie Member

    (newbie here) just started last night with advance tomato (latest ver.) on the R6300v2 , looks great ... thanks to all involved

    and of course I have a question - how to change speed displayed in "real time traffic monitor" from Kbps to Mbps ?
    thanks
     
  42. Grimson

    Grimson Networkin' Nut Member

    On MIPS you need to turn the radio off and back on to actually change the channel, I don't have an ARM device but you can try:
    Code:
    wl -i eth2 radio off
    wl -i eth2 radio on
    
    For Advanced Tomato ask here: http://www.linksysinfo.org/index.ph...-material-designed-web-gui-shibby-base.70254/
     
    lubmar and Tim Sudall like this.
  43. kacheng

    kacheng LI Guru Member

    I am experiencing issues with AdvancedTomato138 (Shibby 138) on an ASUS RTN-16 for:
    1. Route Modem IP doesn't work
    2. QOS Inbound classifies everything as Default class

    I tried reflashing and clearing nvram completely.
    The only choices seem to be:
    A. go back to 132 (and give up adblocker) or
    B. go without QOS and without route modem access

    Anyone have experience with this and can confirm?
     
  44. Tim Sudall

    Tim Sudall Connected Client Member

    Great thanks!

    So far I've worked out how to set channel and transmit power using wl but how do I set channel width with the wl command?

    I have also tried changing the nvram to set channel and width permanently and although I have changed it successfully as reported in the terminal it doesn't seem to work after restarting the wireless.

    Code:
    nvram set "wl1_chanspec=140/80"
    nvram commit
    service restart wireless
     
  45. RichtigFalsch

    RichtigFalsch Networkin' Nut Member

    Hello!
    From what I have seen, there's the argument -b that should show current bandwidth setting and be able for changing same:
    -b, --bandwidth : transmit bandwidth MHz; 20, 40, 80
    -b, --bandwidth : transmit bandwidth MHz; 20, 40, 80
    -b, --bandwidth : transmit bandwidth MHz; 20, 40, 80
    -b, --bandwidth : transmit bandwidth MHz; 20, 40, 80
    bw_cap Get/set the per-band bandwidth.
    -w bandwidth, 20, 40 or 80
    bandwidth, 20, 40, or 80, default 20
    -w bandwidth 20 or 40
    bandwidth, n=10, non for 20 & 40
    1: optimize bandwidth
    bandwidth, 20, 40, or 80, default 20
    usage: wl phytable table_id offset width_of_table_element [table_element]
    Note that table width supplied should be 8 or 16 or 32
    e.g. Configure traffic management and specify local ip addr. and bandwidth data:
    trf_mgmt_bandwidth
    Sets/gets traffic management bandwidth configuration.
    Usage: wl trf_mgmt_bandwidth
    downlink : downlink bandwidth (kbps)
    uplink : uplink bandwidth (kbps)
    min_tx_bk : min. guaranteed tx bandwidth percentage for BK (kbps)
    min_tx_be : min. guaranteed tx bandwidth percentage for BE (kbps)
    min_tx_vi : min. guaranteed tx bandwidth percentage for VI (kbps)
    min_rx_bk : min. guaranteed rx bandwidth percentage for BK (kbps)
    min_rx_be : min. guaranteed rx bandwidth percentage for BE (kbps)
    min_rx_vi : min. guaranteed rx bandwidth percentage for VI (kbps)
    If no rx gandwidth arguments are entered, tx bandwidth is used for rx.
    If no arguments are entered, the current bandwidth configuration is displayed.
    -i: 40MHz intolerate bit; -w: 20MHz width Req bit;
    root@tomato:/tmp/home/root#

    But when I try so, I just get:
    Code:
    wl -i eth2 -b
    wl: Unsupported
    
    Maybe you have more luck?
     
    Tim Sudall likes this.
  46. Tim Sudall

    Tim Sudall Connected Client Member

    Same message here, when I try to set bw_cap I also get "bad band"

    Also tried:

    Code:
    root@R7000:/tmp/home/root# wl -i eth2 chanspec -c 140 -b 5 -w 80 -s 0
    wl: Bad Channel
    
     
    Last edited: Jan 12, 2017
  47. vr33595

    vr33595 New Member Member

    Is it possible to configure backup of certain directories from the attached USB to the cloud? Asus stock firmware has integration with Asus own webstorage, but there are many other providers, such as Degoo offering 100GB for free.
     
  48. koitsu

    koitsu Network Guru Member

    Sounds solvable via a cronjob (cru), installation of Entware-ng (rsync package), and a subscription at rsync.net.
     
  49. Tim Sudall

    Tim Sudall Connected Client Member

    Thanks for posting this, finally what I was looking for.

    I set this and thought you may like to know you can use the txpwr1 command (rather than txpwr) to set power within UK regs for my channel sources. I added the following working lines to my init.d script

    Code:
    wl -i eth2 txpwr1 -o -m 1000
    wl -i eth1 txpwr1 -o -m 100
    Where -o removes regulations
    And -m sets power in mw

    My temps are cooler on my R7000 too.

    eth1: 2.4G - 46°C eth2: 5G - 51°C

    Finally I have tomato the way I want it. If only there could be a way to fix it in the firmware/wlan driver
     
  50. AndreDVJ

    AndreDVJ Addicted to LI Member

    Try dropbox-uploader from Entware. Check out also the Wiki from https://github.com/andreafabrizi/Dropbox-Uploader

    I backup stuff into a tar archive using the sample script (with some modifications) and upload to Dropbox. It works well for me.
     
  51. tcsoft

    tcsoft LI Guru Member

    Hi,

    is there JFS support in this firmware? If not, any chance to get it into (donation?)?
    Thx.
     
  52. koitsu

    koitsu Network Guru Member

    Do you mean JFFS, or did you truly mean IBM's journalling filesystem (JFS)? Nobody really uses the latter (most everyone uses ext4, which I believe Shibby does support).
     
  53. RichtigFalsch

    RichtigFalsch Networkin' Nut Member

    For everyone wondering about Shibby's well-being: There's a sign of life from him since today, on his own Polish web portal

    I used google translate, for seeing what he wrote, but it reads like he is alright and just too busy with his job atm.

    :)


     
    Techie007, wistlo, lepa71 and 21 others like this.
  54. Rangaistus

    Rangaistus Network Newbie Member

    regarding PPPoE & BWM:

    i have BW stats for Daily, Weekly & Monthly after changing the configuration to "Save History Location" to "RAM (Temporary)", and a reboot.

    also WAN1(ppp0) interface now shows up under Last 24H.

    attempting to figure out why :p
     
    RichtigFalsch, ambiance and Malakai like this.
  55. Mr9v9

    Mr9v9 Reformed Router Member

    I save my stats using CIFS also PPPoE and working fine for me.
     
  56. Rangaistus

    Rangaistus Network Newbie Member

    i figured out what happened.

    here's the write-up for anyone experiencing the Bandwidth Monitoring (BWM) issue with PPPoE.

    --- Symptom ---
    BWM does not record/display Daily, Weekly, Monthly Data.
    WAN1(ppp#) interface shows up in Real-Time, but not in Last 24 Hours.

    --- Cause ---
    BWM, aka rstats service keeps track of only 10 interfaces. this is hard-coded in
    router/rstats/rstats.c:
    Code:
    #define MAX_SPEED_IF    10
    if you have too many interfaces, vlans, etc. the ppp# interface could become the 11th+ interface. so while the real-time data is displayed, no history is recorded for the WAN interface.

    --- Check ---
    let's check the WAN interface.
    access the CLI via SSH or telnet, OR go to Tools > System Commands.

    execute:
    nvram get wan_iface

    that is the WAN interface. make a note. i'll use ppp0 in this example.

    the BW data is gathered from a file /proc/net/dev.

    execute:
    tail -n +3 /proc/net/dev | grep -v 'lo:' | grep -n ''

    the output should list the interfaces and data-bytes received/transmitted per line.
    Code:
    1:  eth0:689448064 798217252    0    0    0     0          0         0 1660642497 797512622    0    0    0     0       0          0
    2:  eth1:66087983  715962    0    0    0 8806189          0         0 2709764127 2218940    0    0    0     0       0          0
    3:  eth2:       0       0    0    0    0     0          0         0        0       0    0    0    0     0       0          0
    4: vlan1:1543226874 516928659    0    0    0     0          0      7778 2200528965 281319168    0    0    0     0       0          0
    5: vlan2:1958179838 281288593    0    0    0     0          0         0 3648745405 515982473    0    0    0     0       0          0
    6: vlan3:       0       0    0    0    0     0          0         0 106335423  210981    0    0    0     0       0          0
    7: vlan4:       0       0    0    0    0     0          0         0        0       0    0    0    0     0       0          0
    8:   br0:3304789727 517031431    0    0    0     0          0    165763 3114784591 282540182    0    0    0     0       0          0
    9: wl0.1:   21321     142    0    0    0 8806189          0         0 14554387   28729    0    0    0     0       0          0
    10:   br1:   20130     149    0    0    0     0          0        29 105517519  211071    0    0    0     0       0          0
    11:  ppp0:2856565096 281269222    0    0    0     0          0         0 3091885579 515881657    0    0    0     0       0          0
    12:  imq0:       0       0    0    0    0     0          0         0        0       0    0    0    0     0       0          0
    13:  imq1:       0       0    0    0    0     0          0         0        0       0    0    0    0     0       0          0
    14: tun21:       0       0    0    0    0     0          0         0        0       0    0    0    0     0       0          0
    
    if the WAN/ppp0 interface is not in the top10 list, then no history data will be kept.

    --- Solution ---
    to get around this, we need to exclude some interfaces from the top 10 list. you need to make that choice. good candidates are interfaces with 0 byte across all fields. in the above example: eth2 & vlan4.
    if all interfaces have data transfers, then choose between a VLAN or its physical interface.

    navigate to Administration > Bandwidth Monitoring
    enter your chosen interfaces in "Excluded Interfaces". in this example: eth2,vlan4
    then Save.

    --- Verify ---
    Navigate to Bandwidth > Daily. You should see the current Date, and numbers for Download, Upload and Total.
    the data updates every 2 minutes.
     
  57. koitsu

    koitsu Network Guru Member

    I quickly reviewed the rstats.c code with regards to MAX_SPEED_IF. What @Rangaistus said is 100% correct -- I verified the functions that do /proc/net/dev parsing, file loading, as well as the array declaration itself (all are important). The proper fix for this is remarkably easy. I'll work on getting commits in later today (I don't work on Shibby branches, only Toastman, but the fixes can be cherry-picked very easily between the two).

    Edit: fixes posted here: http://www.linksysinfo.org/index.php?threads/tomato-toastmans-releases.36106/page-41#post-284129
     
    Last edited: Jan 19, 2017
  58. ambiance

    ambiance Serious Server Member

  59. ambiance

    ambiance Serious Server Member

    @koitsu I see your fix doesn't have to exclude any interfaces. Excellent!

    [​IMG]
     
  60. koitsu

    koitsu Network Guru Member

    The interface exclusion described by Rangaistus is a workaround. The actual solution is what I committed. :)
     
  61. RichtigFalsch

    RichtigFalsch Networkin' Nut Member

    Now all we need to do is to compile our own build for this to work without the workaround?
    Doesn't anyone have a ready to go (where you just have to download current code, modify and enter 'make') Tomato build environment as an VortualBox or KVM appliance available? :)
     
    The Master likes this.
  62. BigRich

    BigRich Network Newbie Member

    Hi,


    I have two devices on my network that are not working properly. They are multi function HP printer, Sonos speaker,
    and Ecobee 3 thermostat. All are connected via wifi. My router is a Netgear Nighthawk with Tomato Shibby Tomato Firmware 1.28.0000 -129 K26ARM USB AIO-64K.

    I can see all three devices on the device list page of Tomato however when I try to access them from my iPhone or iPad their apps say they're disconnected. Then if I go to in Tomato advanced, wireless, and change the multicast rate from auto to 54 Mbps, and save, all of the devices immediately connect and are able to be controlled from their respective apps. At some point later they become disconnected again. Also when I go back in Tomato the multicast rate change I made doesn't actually save.
     
  63. ClearD

    ClearD Reformed Router Member

    I may or may not be able to help. I've got a Nighthawk, running shibby, and also have an ecobee3. Are you actually running version 129? Or?
     
  64. BigRich

    BigRich Network Newbie Member

  65. ClearD

    ClearD Reformed Router Member

    I'm on 138 myself, and everything is running well on my end. Between 129 and 138, there are loads of bug fixes, so I'd start there first. :)
     
  66. AaronCompNetSys

    AaronCompNetSys LI Guru Member

    Can some one (@shibby20 ?) comment on if inbound traffic will ever be added back into QoS? I am stuck on old versions because I require inbound QoS and bandwith limiting.

    As a side note, my Asus RT-AC66U running 132 Shibby is not capable of QoS of the full bandwidth of my 118Mb/12Mb line, QoS disabled it is fine. It can only support 68Mbps/8Mbps with QoS on, running about 15 rules and still only 5% CPU load, monitored via TOP. Any suggestions on more powerful hardware that will work with an old version of Shibby Tomato, or should I switch to another similar firmware?
     
    Techie007 likes this.
  67. BigRich

    BigRich Network Newbie Member

    I had to update shibby from version 129 to 131. Now everything is working normally. Thanks for your help.
     
    ClearD likes this.
  68. ClearD

    ClearD Reformed Router Member

    Curiosity, why not the latest version?
     
  69. ambiance

    ambiance Serious Server Member

    Some have stopped at 132 as it was the last version before MultiWAN was introduced.
     
  70. ClearD

    ClearD Reformed Router Member

    I suppose I could understand that, but 132 worked better than 131 for me. Seems somewhat arbitrary I suppose?
     
  71. apvmtan

    apvmtan Reformed Router Member

    Is Shibby retired?
     
  72. theirongiant

    theirongiant Serious Server Member

  73. pomidor1

    pomidor1 Reformed Router Member

    Shibby is busy but proposes try out fork kille72 (collaborator Shibbi) improves VLAN are currently two versions of the normal and the skin adwanced toamto
     
    Last edited: Feb 7, 2017
  74. apvmtan

    apvmtan Reformed Router Member

    Thanks, planning to pick up a used R8000 and flash it with Tomato, as long as he is not retired, I'll be fine. His Tomato build is best for Netgear stuff imo.
     
  75. peyton

    peyton LI Guru Member

    Where to find that fork pls ?
     
  76. PetervdM

    PetervdM Network Guru Member

  77. peyton

    peyton LI Guru Member

    Thanks for your reply but it is not fork repo. 2016-08. Already got that build.
     
  78. pomidor1

    pomidor1 Reformed Router Member

  79. Cloud

    Cloud Reformed Router Member

    @Shibby,
    @All,

    I have an old router and i'm not sure if this is supported on tomato.
    Belkin Wireless N+
    F5D8235-4 v1000
    Would you be able confirm if this supported? If yes please let me know which firmware version I can use for this.

    As always thanks for your hard work and support. Cheers!
     
  80. pomidor1

    pomidor1 Reformed Router Member

  81. sac7000

    sac7000 Reformed Router Member

  82. Elfew

    Elfew LI Guru Member

    Good, so shibby will release a new build v139 next week :) the changelog will be huge as he said, so we will see :)

    Here is more ino from shibby (thx to @pomidor1 :) )

     
  83. Annita

    Annita Serious Server Member

    Thank you for sharing the news!!! It's great to know that ;)
    Will be checking next week for the new release :D
     
    RichtigFalsch likes this.
  84. Jeffry

    Jeffry Networkin' Nut Member

    I hope that Shibby found a way to add in support for C1/E1 versions of the AC68U in his upcomming release. Not holding my breath, but that would be great if he did. =) If not, I wouldn't mind donating to a pool to get him a C1/E1 model for him or one of the other Tomato developers.
     
  85. Jose C

    Jose C Connected Client Member

    Great to hear shibby is working on tomato again.


    Sent from my iPhone using Tapatalk
     
  86. peyton

    peyton LI Guru Member

    Great news ! :)
     
  87. somms

    somms Network Guru Member

    [​IMG] [​IMG]

    I can only hope that Shibby's next tomato build will be as extremely stable as his last was on my gateway R7000!;)

    I could probably continue running v138 w/o requiring any reboot for another year but i do suppose it will be time to also update my remote clients up to OpenVPN 2.4 in preparation for his next build...
     
  88. pomidor1

    pomidor1 Reformed Router Member

    kille72 added openvpn 2.4 on your fork so you can already test, if someone is interested
     
  89. Elfew

    Elfew LI Guru Member

    I think it is more difficult than we think. You have to update sdk
     
  90. Annita

    Annita Serious Server Member

    Impressed!!!! Have the same router and it gets pretty warm and WiFi does not work properly and have to reset it around once a week (sometimes more)...
    Would you be so kind to share your WiFi network settings and Advanced Wireless Settings?
     
  91. Enig123

    Enig123 New Member Member

    Obviously I am new here.

    My first question is, if all the features I want to have with Tomato is VLAN and UPnP port forwarding, is VPN version (smaller) enough to feature that?

    What exactly is the difference between VPN and AIO? I just couldn't find an obvious link to the answer.
     
  92. pomidor1

    pomidor1 Reformed Router Member

    vpn = aio-trasnssmison and - (I think) dlna, I always used a aio- can be installed with entware / opetware- transsimiosion etc.

    it is rather the older routers was supposed importance, the new arm has a huge nand and nvram and there is no problem with the aio maybe except for Linksys EA6900 EA6700 etc. and dir868l among them is the problem of overcoming 32kb nvram (like to crash and reset, etc.) and a smaller version is better because they always less can occupy nvram
     
  93. Enig123

    Enig123 New Member Member

    Nvram and nand not be a problem for me neither. It's better minimize services to get better security right? So what I am wondering is whether the VPN build is enough for regular features.
     
  94. pomidor1

    pomidor1 Reformed Router Member

    it seems to me that it does not matter, they are different but actually gui trannsmision, but rather will not matter as to safety, and whether transsmision is a basic function for some so hehe you not so whether this version you will have whether this is a itself
     
  95. Solace50

    Solace50 New Member Member

    I came across the same issue with trying to setup a router for my parents so I could remotely admin the ports if needed. I'm on build 132 from shibby on a EA6900/6500v2, feel free to experiment with additional builds to see if the problem persists. It is most likely the setting is not routing the request locally to the port and forwarding it the DMZ IP.
     
  96. frudda

    frudda New Member Member

    Simple question.

    Does WNR3500L (v1) support version build5x-137 by Shibby?
    Could not find USB version.

    I want to upgrade from 36 because wget SSL was not working in earlier version.
    I heard it was getting updated. Can someone confirm this?
     
  97. alf5683

    alf5683 Connected Client Member

    Hi all.
    I know it's not a priority but if Shibby can upgrade the "Tinc server" in his new release :)
     
  98. VNGXR1337

    VNGXR1337 New Member Member

  99. pomidor1

    pomidor1 Reformed Router Member

  100. cerberii

    cerberii Network Newbie Member

    Hi, Would like to get some help. Can anyone tell me if the WDR3600 will run tomatos shibby K26 for MIPS v2? Its running an AR9343 which is using a MIPS32 74K . Is this considered a R2? I think shibbys is the best out there and I have already ran openwrt and dd-wrt/tomato on many routers, but prefer shibbys tomato.
    https://wikidevi.com/wiki/TP-LINK_TL-WDR3600
     

Share This Page