1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Shibby's Releases

Discussion in 'Tomato Firmware' started by shibby20, Feb 26, 2011.

  1. misuercarriere

    misuercarriere New Member Member

    I'm currently using AIO AT-138 and have the option. Perhaps it's only for AIO? Maybe some other builds too?
     
  2. tomato

    tomato New Member Member

    The asus router only has 4mb flash, So AIO is not an option. Maybe other can share their finding?

    I can only install Mini or mini IPV6 version.

    Sent from my SM-N910H using Tapatalk
     
  3. gary201

    gary201 New Member Member

    I have a Linksys E4200 v1 (2.5 and 5ghz radios). I've been running v1.32 for quite a while and yesterday updated to 1.4 (tomato-E4200USB-NVRAM60K-1.28.RT-N5x-MIPSR2-140-Mega-VPN.bin). I always do the full 15 second reset/power off/power on/release reset process, then manually reconfigure everything. What I have discovered is the 5ghz radio goes offline after a period of time, then after usually no more than a full minute, comes back up. Obviously everything using that looses its connection (phones, Linksys wumc710, etc.) Has anyone else observed radio disconnections similar to this? If it persists, I may just have to go back to v1.32 that I had been using for years.
     
  4. tomato

    tomato New Member Member

    Sorry, this is obviously unrelated. But can you check if there is dns-crypt menu under network->basic, on you 140 version? Thanks

    Sent from my SM-N910H using Tapatalk
     
  5. gary201

    gary201 New Member Member

    I can't check that because I got fed up w/the radio outages on the 5ghz band and dropped back to v1.38 (which is still higher than what I was at, which was 1.32). The problem has not reoccurred since. There isn't a menu entry "dns-crypt", however, on the basic > network menu a checkbox for "Use dnscrypt-proxy", which isn't checked by default and not enabled, either on the versions I have been using nor when I was running v1.4.
     
  6. tomato

    tomato New Member Member

    This is exactly what i was looking for. So you do have that option, mine doesn't have that. maybe because we run different package version. you were running Mega version and i'm running Mini version. can anyone else confirm that mini version doesn't include the dnscrypt-proxy package?
     
  7. imran khalid

    imran khalid Connected Client Member

    no such issue seen here, rock solid on E4200 v1, you must check your hardware mate if issue persists, 1.40 is non issue for sure
     
  8. imran khalid

    imran khalid Connected Client Member

    @shibby20
    Thanks for super build 1.40, its rock solid on my old baby E4200 v1.
    i'm missing your support for ASUS RT-AC88U, any chance you support it? please
     
  9. eahm

    eahm LI Guru Member

    Not trying to push, any news/eta on AC1900P? Thanks.
     
  10. krux01

    krux01 LI Guru Member

    My iOS devices do not connect to wifi for a few minutes after waking them up. They connect almost immediately on firmware 1.32 and prior. I updated to 1.40 and the issue remains. I have cleared nvram and set all setting back up. But like I said this problem has been there in every release since 1.32. I am running AIO build on a RT-N66R (RT-N66U). Has anyone else seen this issue? If so is there a fix?
     
  11. maurer

    maurer LI Guru Member

  12. AndreDVJ

    AndreDVJ Addicted to LI Member

  13. Edrikk

    Edrikk Network Guru Member

    @AndreDVJ -- Since Tomato doesn't use patch files, I wonder if it makes sense to add a common word (maybe "TOMATO PATCH") to items like this (which I assume is a tomato specific change) to allow for third party components to become more "drop-in"-able. That way new devs can search for that string to know where they have do some merging when updating.

    The other option would be to do something similar to what I did with miniupnp (as much as possible), and wrap Tomato specific code in ifdefs, and submit upstream to allow for drop-in updates.

    For example:

    Code:
    #ifdef TOMATO
      #define XAUTH_COMMAND "/opt/X11R6/X11/xauth -q"
    #else  
       #define XAUTH_COMMAND "/usr/bin/X11/xauth -q"
    #endif
    

    They may not accept such items upstream (as you could argue that every project would then have ifdefs), but if they do, it'll make life cleaner/easier for Tomato maintenance.
     
    M_ars and AndreDVJ like this.
  14. maurer

    maurer LI Guru Member

  15. mugs07

    mugs07 New Member Member

    Is anybody using this @eibgrad script on something newer than 1.32 or possibly have all traffic go through ISP except selective IP's, which go through VPN?

    When I tried using it, I was unable to get any traffic to go through VPN or outside VPN. There may be issues with newer Multi-WAN firmware and the script (not sure what other alternatives there are for solutions for this scenario.)
     
  16. Cl00ny

    Cl00ny New Member Member

    Upgraded from 132 to 140 and now Miniupnpd isnt working anymore...
    Erased nvram several times and configured by hand.

    RT-N16 MIPSR2-140 K26 USB Mega-VPN

    edit: flashed 140 AIO but same result...
    does miniupnpd work for you guys ?
     
    Last edited: Jun 2, 2017
  17. bjlockie

    bjlockie LI Guru Member

    I would like to see the transfer stats use appropriate units (KB, MiB, GiB).
    2,583,395.00 KB is not as useful as it could be.
    Is it really KB or KiB? :)

    I would also like the TomatoAnon to highlight which record is your router.
    I suspect there is a parsing error with my record.
     
  18. Cl00ny

    Cl00ny New Member Member

    MINIUPNPD still not working for me in 140!

    Would be nice to get some help or a possible fix for my problem but no one seems to care, i guess u dont rely on upnp as much as me...
    Should i open my own thread about this ? - Im pretty sure that im not the only one with this problem ?!
     
  19. bjlockie

    bjlockie LI Guru Member

  20. Cl00ny

    Cl00ny New Member Member

    I need upnp for my gaming devices / gaming consoles to open ports automaticly for certain games and services.
    There must be a problem with miniupnpd in 140, cause it worked with no problem in 132... i dont even know how to debug this, im really relying on ur help guys.
     
  21. reimer

    reimer Networkin' Nut Member

    I updated to v140 on a N66U using the AC build. I am using OpenVPN and have it set to the AES-128-CBC cipher.

    Previously, when I connected with any client, I can check the logs and it tells me it was connected with AES-128-CBC. Now after updating to v140, the logs are showing that it is connecting at AES-256-CBC. I have made no other changes to the VPN configuration. Both the settings in Tomato and my clients are still set to AES-128-CBC.

    I'm not familiar with the new security improvements in OpenVPN so I was curious if this was normal. Thanks.
     
  22. gary201

    gary201 New Member Member

    For my E4200 v1, my iPhone periodically will drop the 5ghz band connection and refuse to reconnect until the router is rebooted. I didn't have this issue with 1.32, but with 1.4 the 5ghz radio that stops working (everything looses the connection on that band). So I dropped back to 1.38 and now just the iPhone will stop connecting. I'll probably drop back to 1.32 this weekend, which is where I was and never had any issues.
     
  23. cloneman

    cloneman Networkin' Nut Member

    I tried Shibby 1.40 on MIPS today. I've noticed the QoS bandwidth calculation on the right side is still missing (qos-settings.asp), ever since MultiWAN releases started. Last one to have them was v1.32.

    Will this be corrected?
     
    Elfew and Cl00ny like this.
  24. tapasr_56d18fd83b51b

    tapasr_56d18fd83b51b New Member Member

    Has someone tested the RT-N66U firmware on a DSL-N66U. Because the DSL version of this router has both an Ethernet wan and DSL wan connection, I am curious if this could work. I am planning to buy this router, but I would love to use the shibby's firmware.
     
  25. maurer

    maurer LI Guru Member

    no, RT-N66U fw it's not working for DSL-N66U (you won't see - probably never - tomato on this device)
    if you really want FOSS software for DSL-N66U you could try openwrt/LEDE but the DSL part is not working...
     
    tapasr_56d18fd83b51b likes this.
  26. bjlockie

    bjlockie LI Guru Member

    Is there a process for asking the web interface be changed?

    I really think the web interface should use appropriate units (eg. 9,473.02 MB should be 9.47302 GB).
     
  27. JustinChase

    JustinChase Serious Server Member

    You're the 3rd or 4th to request this since I did a couple weeks ago. I hope it gets changed soon also.

    Sent from my HTC6545LVW using Tapatalk
     
  28. Cl00ny

    Cl00ny New Member Member

    Please fix miniupnpd... was so happpy to test 140 but i cant live without a working upnp.
     
  29. Elfew

    Elfew LI Guru Member

  30. JustinChase

    JustinChase Serious Server Member

    Are the kille72 builds the same source as shibby, just built more frequently, or is it something rather different? I read he's probably got the reporting fixed already, but I don't even know how or where to find his builds.

    Sent from my HTC6545LVW using Tapatalk
     
  31. Elfew

    Elfew LI Guru Member

  32. iv7777

    iv7777 Connected Client Member

    Hey everyone, I've found the ARM build has a problem restoring all NVRAM variables back to the router from a configuration file saved before. For example, the following are not restored:

    qos_inuse
    rrule1
    rrule2
    Then I traced the problem back to nvram_arm/main.c in the source code in line 216:

    if (issyspara(p))
    nvram_set(p, v);

    What it does is to perform a variable name check, if it either contains "wl", "wan", "lan", or it's in the list of "shared/defaults.c", the variable will be restored using nvram set equivalent command. If not found, then they are ignored. This missing varaiables could potentially cause lots of problem after restoring a settings from a configutaton file. The solution is to either add all variables to "shared/defaults.c" or just disable the check. For simplicity, just comment it out, recompile and problem solved:

    // if (issyspara(p))
    nvram_set(p, v);

    I found out this problem may potentially exists in all ARM builds and I have attached the original and the fixed main.c file for your review. Hope someone could commit this in the git.
     
  33. kille72

    kille72 Addicted to LI Member

    Thanks! Can any programmer review this change please?

    /nvram_arm/main.c, line 216:

    Code:
            v = strchr(p, '=');
    
            if (v != NULL)
            {
                *v++ = '\0';
    
    -            if (issyspara(p))
    +        //  if (issyspara(p))
                    nvram_set(p, v);
    
                p = v + strlen(v) + 1;
            }
            else
            {
                nvram_unset(p);
                p = p + 1;
            }
        }
        return 0;
    }
     
    Last edited: Jun 6, 2017
  34. tothjsz

    tothjsz Connected Client Member

    Hi!

    I have an Asus RT N18U router with Tomato Shibby v140 on it. I found an interesting "error":

    I have a home and a guest lan:

    01 internal - guest lan.png

    2 different wireless interfaces (+SSID) were created and assigned to these lans.

    02 virtual wireless interfaces.png

    The mac filter was/is switched on:

    03 mac filter is on.png

    Previously, if mac filter was switched on, then only known devices could connect to these wireless networks.

    Now, any device can connect to the 2nd wireless network, but only known devices can connect to the 1st.

    04 device list.png


    So, it looks like, the mac filter is valid for the 1st wireless network only. Is it ok? I think not, because the macmode is "allow" for both wifi network.

    05 macmode.png
     
  35. kille72

    kille72 Addicted to LI Member

    In what version does it work correctly?
     
  36. tothjsz

    tothjsz Connected Client Member

  37. kille72

    kille72 Addicted to LI Member

    Ok, I immediately suspect MultiWAN as the culprit...
     
  38. tothjsz

    tothjsz Connected Client Member

    Ok. Of course it doesn't disturb me, because it is much easier to configure the guest wireless network with version 140 (I don't have to switch off manually the mac filter for guest wifi).
     
  39. JustinChase

    JustinChase Serious Server Member

  40. kille72

    kille72 Addicted to LI Member

    I compile only ARM versions...
     
  41. Edrikk

    Edrikk Network Guru Member


    @kille72
    The correct solution is generally not to by-pass checks (which in this case was likely put in to avoid unwanted nvram vars from being saved across routers I would think), but rather to add the missing ones to the "shared/defaults.c" list.

    For example, rrule0 is already there in the file, so others should be added below it.
     
    tsynik, Elfew, kille72 and 1 other person like this.
  42. kw_broadens

    kw_broadens Network Newbie Member

    Agreed. The general principle is that any data coming from "outside" should be validated.
    Ken.
     
    boardlord and kille72 like this.
  43. Elfew

    Elfew LI Guru Member

    Did you try to reset NVRAM and configure everything from scratch? No backups etc?

    EDIT: I am sorry, I saw your first post. Did you enable UPnP for your interface? You can find the settings in Port Forwarding -> UPnP/NAT-PNP -> enable UPnP + select at least one LAN (enabled on)
     
  44. JustinChase

    JustinChase Serious Server Member

    Thanks for clarifying

    Sent from my HTC6545LVW using Tapatalk
     
  45. tothjsz

    tothjsz Connected Client Member

    Hm, it looks like I found the reason. Anybody can realize what the problem is, if she/he compare the macmode settings of version 132 and 140.

    This is the settings of version 132:
    macmode v132.png

    And this is the settings of version 140:

    macmode v140.png

    Yes, wl0.1_macmode is missing.......
     
    Elfew likes this.
  46. Elfew

    Elfew LI Guru Member

    Thx for debugging
     
  47. iv7777

    iv7777 Connected Client Member

    Agreed, the best solution would be adding all variables to "shared/defaults.c" list. However, it might not to be very practical due to the following issues:
    • All variables used in all packages incorporated into the firmware need to be included in the list. This goal could be a little challenge, considering they all come from different developers and require a highly orchestrated team effort to make a complete list. Before this is done, at any given moment, the NVRAM restoration process will always has a flaw of potentially "missing" variables
    • Even though it will finally be done, it's still very tedious to add some variables such as "rrule1, rrule2, rrule20...etc." These variables are for Access Restriction rules, which could be many and who knows when this number would have to end. Just don't feel good to see adding from rrule1 to rrule99
    • What about some custom variables created by custom script ? If they are not restored it's simply an inconvenience for the user
    • The current variable name check is not very strict anyway. Any corrupted names with "wl" "wan", "lan" in it may still be imported. For example, adfnsadfawl878*(*& will be accepted because it contains "wl".
    I guess under the current circumstances, a more feasible solution is to work around it by having a CRC check during both saving and restoration process. The chance of corrupted variables is pretty much eliminated. However, this is just my thought and it is beyond my capability. It would be nice to see if someone have a better solution.
     
    kille72 likes this.
  48. aDarkness

    aDarkness Connected Client Member

    Hello Everyone! I was wondering if Shibby planned on/ has released a tomato version for the R7000P? Thanks!
     
  49. Lorenceo

    Lorenceo Networkin' Nut Member

    I've set up a different LAN subnet on my R7000 running v140 Multiwan for use as a guest network, on its own VLAN. It seems that there's a few bugs with it though.

    Firstly, on the guest network an IPv6 DNS server is announced. It's the router's IPv6 address. This in itself is fine, but while it will reply to pings, it won't answer DNS queries. This means any device connected on the br1 subnet is very sluggish to browse the web as the devices try to send DNS queries to the IPv6 DNS server, but don't get any responses.
    I do have it set to request a separate /64 for br1.

    Secondly, while connected to this subnet some websites do not work as reliably. A notable example of this is www.speedtest.net - it can't complete its upload tests due to a socket error:
    upload_2017-6-10_7-57-11.png

    I suspect this problem may be related to having two WAN connections, as when I tried to reproduce this on another router (an RT-N16 also running v140) with a single WAN connection, there were no such socket errors.

    Does anyone have suggestions as to what the best way around this would be? Happy to provide any debug information that may be required.


    Edit: After a fair bit of setting tweaking it seems QoS is related to the socket errors. When QoS is disabled, devices on the second subnet do not run into the socket error. Turning QoS back on results in the error again.
     
    Last edited: Jun 12, 2017
  50. RBoy1

    RBoy1 Connected Client Member

    Yes I reported this issue sometime ago it was in v138 of the firmware. It was linked to a specific client. Everytime my one my portable WiFi bridge client connected to the network it cause the WiFi to go offline after a minute and then come back online but only then my WiFi client would no longer connect to it. Unfortunately I'm back to 132 as the most stable version. This was a WNR3500Lv2
     
  51. apreslin

    apreslin New Member Member

    I have the exact same behavior on version 140 on an Asus RT-AC3200. Happens about once a day or so, 5GHz goes offline for about a minute. All devices get disconnected then reconnect within a minute or so.
     
  52. James Bond

    James Bond Reformed Router Member

    Shibby 140 MIPSR1-140 K26 Max.
    Sometimes specific DNScrypt server fails to work as expected and I switch to another DNSCrypt server.
    After that Adblock behaves weirdly: log shows blocklist was loaded, but blocked addresses are resolved.
    The only solution so far is to reboot router.
     
  53. morebytes

    morebytes New Member Member

    Does anyone notice any bugs for DUAL WAN setting? Esp on Netgear WNDR4500V2 hardware?
     
  54. rs232

    rs232 Network Guru Member

    Last edited: Jun 16, 2017
  55. somms

    somms Network Guru Member

    [​IMG]

    Possible minor v140 bug for Shibby's attention:

    Running v140 since Shibby released, there have only been 2 instances where the tomato WINS using Samba file sharing service has seemed to stopped working (Network shares no longer auto populate on client computers connected to the network using WINS).

    Each time I noticeds WINS no longer responding, it is very easy to restart this service just by stopping selecting No to enable file sharing and then back to Yes, no authentication to re-enable again.

    Never had this issue under the previous v138 with the same gateway R7000 router and upgraded from v138 to v140 by clearing out the full NVRAM and then configuring the router exactly the same settings as the previous v138 so I don't believe this is an issue of previous NVRAM setting.

    Anyways, just wanted to pass on this very minor WINS service seeming to intermittently getting stuck and otherwise this v140 firmware has been just as rock-steady stable as the previous v138 on my R7000. Thanks Shibby!:)

    BTW: Anyone know what command I could enter under telnet in order to monitor if this samba file sharing service is still working on my R7000? This may aid me in troubleshooting next time I notice the client computers no longer auto populating network shares using WINS. Thanks!
     
  56. Kisch

    Kisch LI Guru Member

    Hi, I have upgraded my R7000 to Shibby v140 from v132 and have problem with Color Scheme. I have USB stick with Color Scheme attached to R7000. Same settings as I had with v132. I use this string in USB Support/Run after mounting:

    cp -r /tmp/mnt/FLASH_1GB/stornur_v1/* /var/wwwext/

    and cant make it work. With v132 it worked nicely.
     
  57. bax345

    bax345 New Member Member

    Hi I have a question on the CRC-32 in tomato firmware. I want to edit the .config file to disable all the crc components in it. I tried going through make menuconfig, and ran make after changing all the settings and saving it to .config. However, I kept getting /bin/sh: 1: mipsel-linux-gcc not found. How would I go about this process

    Thanks for taking the time out to help.
     
    Last edited: Jun 20, 2017
  58. redshibby

    redshibby Reformed Router Member

    disregard
     
    Last edited: Jun 26, 2017 at 5:37 AM
  59. BrandonS

    BrandonS Reformed Router Member

    I just updated to 140 and noticed while my TincVPN is connected and pingable, I can't actually get across the tunnel. This worked with multiple sites prior to upgrading to 140. I am using one site that is 1.1pre11 (132) and the other site with 1.1pre14 (140). I'm currently set to use compression of 10 (fast lzo) which may be the culprit. I did find a post on the tinc mailing list that sounds like the issue:
    https://www.tinc-vpn.org/pipermail/tinc/2017-January/004737.html

    Is anyone else using 1.1pre11 and 1.1pre14 together and if so with what compression? I am trying to narrow down whether this is the shibby 140 build or the tinc 1.1pre14 build so I can get a bug report to the proper group.

    EDIT: I just noticed no matter which compression value I use, in the Nodes Status menu the 140 build always shows "compression 0". It looks like the compression dropdown isn't setting the value. I need to confirm it is working with no compression once I can change one of the other nodes.

    EDIT for the EDIT: The compression was only showing 0 for the local host which appears to be normal behavior.
     
    Last edited: Jun 28, 2017 at 6:04 AM
  60. AndreDVJ

    AndreDVJ Addicted to LI Member

    If I recall correctly, both ends must use the exact same Tinc version.
     
    Sean B. likes this.
  61. Sean B.

    Sean B. Addicted to LI Member

    I agree with AndreDVJ, they must be the same.
     
  62. Malakai

    Malakai Networkin' Nut Member

    Don't know if that is true for the connection of 2 Tomato routers but I have one Tomato by Shibby v136 router with Tinc1.1pre11 and 2 Debian Jessie servers with tinc 1.0.24-2.1+b1, everything working as expected (at least from a communication between the hosts point of view).

    PS : no compression used in my case.
     
  63. BrandonS

    BrandonS Reformed Router Member

    I am able to confirm tinc 1.1pre11 and 1.1pre14 have been working together today after re-configuring my hosts not to use compression. I could get some of the 11's to use it together but once I introduced 14 everything went to hell. I had daemons start crashing and hanging up. I also had to add some manual port forwarding even though the script is set to firewall automatic. The only thing I noticed between the version mismatch which appears new is that I am geting a lot of errors on the older version:
    Jun 28 00:47:16 RT-10C37B417818 daemon.err tinc[24598]: Received late or replayed packet, seqno 0, last received 17578

    At this point I suspect it is a tinc issue and not a shibby issue.
     
  64. BrandonS

    BrandonS Reformed Router Member

    I am liking the adblock integration in the newer shibby builds. Does anyone know how to get to the user.sh console or if that exists? I am seeing some inconsistencies with adblocking like it stops after turning off debug. I also haven't found pixelserv so I am hoping to dig into it a bit more.
     

Share This Page