1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Toastman + ipv6 via TWC Road Runner Windows Issue

Discussion in 'Tomato Firmware' started by SaulMalone, Jan 14, 2014.

  1. SaulMalone

    SaulMalone Reformed Router Member

    Hi, TWC in my area (West Los Angeles) has had ipv6 deployed for quite some time.
    I have an old WRT54G v2.2 and being a poor college student I opted to update the firmware (tomato-K26-1.28.7821MIPSR1-Toastman-ND-MiniIPv6.trx) instead of buying a new router atm.

    I had trouble getting ipv6 working, a google search led me to this thread about issues with ipv6 and comcast, http://www.linksysinfo.org/index.php?threads/ipv6-and-comcast.38006/

    I got everything working using koitsu's instructions to enable ipv6 with prefix delegation + his wan up script:
    echo 0 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/accept_ra
    ip -6 route flush default dev `nvram get wan_iface`
    echo 2 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/accept_ra

    The router has ipv6 access (TWC gives me a /64) and can ping out, I booted a laptop with knoppix and I get an ipv6 address and everything works 100%. My windows 8.1 machine get an ipv6 address but I cannot ping out and I am now stumped as to what to do. Booting my windows pc with knoppix instead results in obtaining the same ipv6 address/gateway and connectivity. Plugging my windows machine directly into the model of course works. I google searched and have not found a solution so hopefully someone here can guide me as to what to do next.

    EDIT: wrong firmware filename included
    Last edited: Jan 15, 2014
  2. koitsu

    koitsu Network Guru Member

    1. I don't believe that firmware is Toastman, but instead Shibby. The filename doesn't resemble a Toastman firmware, yet your Subject says "Tomato Toastman".

    Toastman firmwares for MIPSR1 running Linux 2.6 are here: http://www.4shared.com/dir/v1BuINP3/#dir=eu5PT-EQ -- yes they are very old, as users are more or less being expected to get newer routers (with more flash space, i.e. 8MBytes or more. There isn't enough room on 4MByte routers to provide all these features people want).

    2. The aforementioned fix/workaround (echo/ip -6/echo) isn't needed on newer firmwares (meaning within the past 6 months), meaning fixes should already in place. Be aware however there have been massive changes to the IPv6 support, mainly radvd being deprecated in exchange of dnsmasq (yes you read that correctly), and there are still oddities to be worked out.
  3. SaulMalone

    SaulMalone Reformed Router Member

    Sorry I copy and pasted the wrong file name :/
    I am indeed using tomato-K26-1.28.7821MIPSR1-Toastman-ND-MiniIPv6.bin and still have to implement your aforementioned fix
  4. koitsu

    koitsu Network Guru Member

    You will have to implement said fix because as I described:

    The firmware in question is from 2011. The fact LAN RA advertisement works on Knoppix but not Windows 8.1 means you're going to have to get extremely familiar with how IPv6 works (it's a complete mess compared to IPv4) and start digging around to see if you can find some Windows registry entry or other tweak that makes things work.

    I wouldn't be surprised if this turns out to be somehow caused by this idiocy (which is actually the result of RFC 3041, which should just go to show how much of a mess IPv6 is).

    You might also try the firmware listed at the link I provided in my previous post, but ending in MiniIPv6 (2). I'm not sure what all got changed between that version and the non-(2) version (ChangeLog doesn't reflect the situation).
  5. SaulMalone

    SaulMalone Reformed Router Member

    I have tried the windows auto-assignment fix and tried various other settings with netsh with no results :(
    Manually configing it in windows dosnt help either, all in all ipv6 support on windows is pretty shitty
    My only experience with ipv6 is setting it up on my debian/bsd servers with minimal issue.

    I will test out the other firmware version now and report back my results thanks
  6. SaulMalone

    SaulMalone Reformed Router Member

    MiniIPv6 (2) has the same md5 hash as the non numbered firmware and is indeed just a copy
  7. SaulMalone

    SaulMalone Reformed Router Member

    Well this fix is defiantly needed + disabling terado to get an EIU-64 ipv6 address
    The auto ipv6 config windows receives mirrors my knoppix live settings, just no ipv6 internet access?
    I can ping the ipv6 gateway fine but beyond that nothing else works...
    I hope something else can be suggested to me next, tearing my hair out searching google

Share This Page