1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

** Tomato Toastman's Releases **

Discussion in 'Tomato Firmware' started by Toastman, Dec 18, 2011.

  1. Jacques

    Jacques Addicted to LI Member

    500.3 is ready for nvram 64KB for RT-N66U ?
  2. wappy

    wappy Serious Server Member

    @toastman, E3200 build have downgraded the nvram from 60k to 32k? also 5Ghz not working with this build.
  3. kthaddock

    kthaddock Network Guru Member

    You can test with this from jyavenard:

  4. kthaddock

    kthaddock Network Guru Member

    Thank you Toastman.

    I have just loaded 0500.2 and it's working just fine.
    Tested wifi speed to my laptop, downloaded file from Nividia and reached ~1.1 - 1.2 MB/sek. (8.8 - 9.6 mbps) on a 10/10 fiber.

    I gone tests 0500.3 with new driver later.

  5. hawkmat

    hawkmat Networkin' Nut Member

    Hi Toastman! I updated my E4200v1 with (tomato-E4200USB-NVRAM60K-1.28.0500.3MIPSR2Toastman-RT-N-Ext.bin) and the NVRAM shows up as 32K. It's suppose to be 60K.
    I tried other versions of 500.3 and they display 32K also. I did a erase NVRAM when I flased and two additional times.
  6. wappy

    wappy Serious Server Member

    Same on E3200(tomato-E3200USB-NVRAM60K-1.28.0500.3MIPSR2Toastman-RT-N-Ext) nvram changed from 60K to 32K :(
  7. Toastman

    Toastman Super Moderator Staff Member Member

    Okay, I'll check it.

    EDIT ... everything *looks* ok to me.
  8. mrg666

    mrg666 Networkin' Nut Member

    Using 500.3 RT-N on E2000, the new driver resets all of the MAC addresses. I have two E2000's and they are now colliding on the network due to same LAN and WLAN MAC addresses. Is this something happening with the new driver in 500.3?

    I have reverted one of the routers back to RT series and they can coexist now.


    Following is the firmware I have used
    The same set of MAC addresses used by the new driver is the following
    00:01:36:22:7f:1d -> LAN
    00:01:36:22:7f:1f -> WLAN
    00:01:36:22:7f:1e -> WAN
    To solve the problem, I have used the advanced/mac address menu to change the WAN and WLAN addresses. The LAN address changed with the following commands change xx values as shown at the bottom of your router.
    nvram set et0macaddr=xx:xx:xx:xx:xx:xx
    nvram set lan_hwaddr=xx:xx:xx:xx:xx:xx
  9. pharma

    pharma Network Guru Member

    Flashed tomato-E4200USB-NVRAM60K-1.28.0500.2MIPSR2Toastman-RT-N-VPN with no issues. NVRAM appears normal registering 60.00 kb.

  10. WildFireSG

    WildFireSG Serious Server Member

    This also occurred for me. What made me really notice a problem is that my WAN IP changed, which it usually doesn't. Then I noticed the build had completely given each interface a new MAC address that doesn't match my hardware!! Went back to 0500.2, restored my saved config, and all is good.
  11. jyavenard

    jyavenard Network Guru Member

    This is likely a side effect of fixing the MAC address override bug (fixed in commit: http://repo.or.cz/w/tomato.git/commit/3ad19f208c1079754a8560996259a995a3c0546e)

    Previously, and following the introduction of the VLAN/Multi-SSID feature, the WLAN mac address was always reset to NULL after each reboot. Forcing the firmware to set the mac address to the hardware default.

    What you are seeing is an issue with the default mac address not properly set in your nvram.
    There are two ways to fix it:
    Do a factory reset and manually reconfigure your router (do not do a restore)
    Advanced -> MAC Address
    For each interface, click on "Default".

    This will properly set the value rather that use a random crap set improperly in earlier version
  12. Toastman

    Toastman Super Moderator Staff Member Member

  13. WildFireSG

    WildFireSG Serious Server Member

    I would tend to agree with you (since you coded the update); however, the only change listed for Toastman's build 0500.3 vs. 0500.2 is an updated wireless driver. Everything works fine in 0500.2. On 0500.3, doing a full erase of the NVRAM still shows as 32K on the E4200 and the MAC addresses are messed up. But on 0500.2, *NOT* broken.
  14. Toastman

    Toastman Super Moderator Staff Member Member

    I'm getting a lot of people asking about my re-introducing the TCP Vegas settings into the GUI.

    The answer is a resounding "NO."

    TCP Vegas has absolutely no effect on traffic passing thought the router. This subject has been beaten to death already, any beneficial effect you do notice is likely due to your own imagination.

    Monk E. Boy, kthaddock and Gitsum like this.
  15. jyavenard

    jyavenard Network Guru Member

    Have you tried the instructions I've given?

    Selecting default for the MAC address ?
    what does it do?

    As for the NVRAM issue, that's something else entirely and most likely a build issue. No changes have been made to that part of the code
  16. WildFireSG

    WildFireSG Serious Server Member

    What about TCP Atlantic City? :)
  17. WildFireSG

    WildFireSG Serious Server Member

    I'm running back on 0500.2, so I haven't gotten to try your suggestions. I'll wait for 0500.4 (or whatever the next release # is) to see if the MACs are still messed up or not. If so, then I will use the "set default" option as you suggested. Thanks for all the prompt responses!
  18. LanceMoreland

    LanceMoreland Network Guru Member

    Had to revert back to 0500.2 on my E4200's. nvram size goes to 30k and causes problems.
  19. wappy

    wappy Serious Server Member

    Here is MAC not changed after update so on the e3200 is not changed back to default driver mac.
  20. jyavenard

    jyavenard Network Guru Member

    What you are seeing is more certainly a coincidence and nowhere related to the new drivers...
    There won't be any changes in Toastman that could change what you are seeing, simply because there's nothing to change.

    You have a corruption in your nvram, fix it: simple
  21. lilstone87

    lilstone87 Serious Server Member

  22. Evgenus

    Evgenus Serious Server Member

    Hi Toastman. Bandwidth limiter works only fo LAN(br0) networks, and does not for others - LAN1(br1), LAN2(br2) ... etc - it says that ip address outside the LAN.
    Is it possible to fix it?
    Model Netgear WNR3500L/U/v2
    Current Version: 1.28.7500 MIPSR2Toastman-VLAN-RT K26 USB VPN-NOCAT
  23. Cynamiter

    Cynamiter Networkin' Nut Member

    I flashed .500.3 on my E4200 and now it won't boot up, no Wi-Fi signal or ethernet connection is found. I've never had problems upgrading a firmware from you.
    Are there any simple solutions I can try besides resets? I can't find any specific topics. Please help me getting this router to work again.

    Edit: 30/30/30 Reset solved my problem and I reverted back to .499.4 and everything is fine now.
  24. shibby20

    shibby20 Network Guru Member

  25. kthaddock

    kthaddock Network Guru Member


    I have now tested 0500.3-nocat and can confirm that Virutal wireless don't set right MAC-address for WL0.1 (00:00:00:00:00:00)
    Have tested with set default MAC-address and alot of others tryings to get default MAC to show up. On RT-N16.

    Have tested wireless speed and it's excellent, my 10/10 fiber is to slooow. Get 1.1 - 1.2 MB/s


    Attached Files:

  26. mrg666

    mrg666 Networkin' Nut Member

    jyavenard, thanks for the help. I tried the default setting in Advanced > MAC Addresses. I had already set the default MAC addresses manually and clicking default didn't change them back. So it works as you recommended.

    Toastman, the new wireless drivers seems to be working slightly better than the old drivers in RT series with my both E2000 routers. Thank you.
  27. jyavenard

    jyavenard Network Guru Member

    It does seem that multiple-SSID is broken right now.
    In both the Toastman image running the newer 138.20 driver, and the shibby-RT-N one...

    Trying to track down the actual culprit...

    Edit: It's definitely driver update that broke multiple-SSID. Now need to find out if it's the drivers that are broken, or the way tomato uses them
  28. Toastman

    Toastman Super Moderator Staff Member Member

    Okay, the following situation exists with 1.28.0500.3

    1) People are reporting the new wireless driver gives better speeds, as found by Shibby
    2) The update has broken some other features, Jean-Yves is looking at it now (see above)
    3) The 60K NVRAM versions may well be broken and only result in 32K.

    I will pull this build and upload new build as soon as it's ready.

    Be patient!
  29. jyavenard

    jyavenard Network Guru Member

    Actually, with the previous drivers, something is borked too... but not as bad.
    If you set the virtual wireless, set a security method: it works.
    Change the security method to something else, save. mac address is now 00:00:00:00:00 and new wireless network doesn't work until you reboot.

    Looks like something has been broken for quite a while... Or did it ever work properly?

    Looking closer into this virtual wireless business... the UI is seriously broken... wonder how someone ever managed to use it
    Ok.. I'm now convinced this feature just never worked properly
  30. tvlz

    tvlz Addicted to LI Member

    The E3200, E2500 & Asus rt-n53 have 5Ghz USB radios, so a different drivers and code("usbap" in asus & linksys source code) need to be added for 5Ghz support.
  31. wappy

    wappy Serious Server Member

    It will be nice if it they added it to those E3200, E2500 and Asus rt-n53 builds so we can test it.

    For those that have the nvram bug (60 to 32k) you can fix it by installing the 095 shibby build, than upgrade to 500.2 build till it is fixed.

    On my E3200 it changed the nvram back to original 60K whene installed shibby build.
  32. mrg666

    mrg666 Networkin' Nut Member

    I can also confirm the 60K bug on E2000
    Total / Free NVRAM:
    32.00 KB / 17.09 KB (53.39%)
    The MAC address problem I reported for 500.3 build could also be related to this.
    But I am enjoying the new wireless drivers and the bugs don't affect my simple setup. I hope the new drivers won't be reverted.
  33. Toastman

    Toastman Super Moderator Staff Member Member

    Just to dispel any misunderstanding about this "upgrade to 64K" in the ASUS RT-N66U - it is not a "permanent" change.

    Please not that it isn't a cfe update, and it will only work while firmware using this code is being run. It will revert to only using 32K if any other firmware is used. If you want to experiment, please back up all your settings first using the nvram export --set method here:


    There is a possibility that this method could also be used for other routers, but it would require some additional changes. At the moment only the RT-N66U has it.
  34. Nitro

    Nitro Networkin' Nut Member

    Has anyone been watching this weeks episode of "Security Now" Steve Gibson is such a GABBER! damn his lips can blab! LOL... anyways he was talking about a new interesting development on the "Buffer Bloat" issue, someone manage to make a small piece of code that can work practically on any device (doesn't take much resources) and works for all types of bandwidth, even dynamically changing bandwidth rates such as WIFI or 3g, this tech has been named "CODL" and is looking to get ratified and hopefully router venders will pick it up from there. it sounds great, just wanted to know other peoples opinions on the matter.

    I think it sound great if your manage multiple devices wireless and need something that can easily adapter to the dynamic changes in bandwidth usage, and apparently it helps to increase throughput more efficiently.
  35. jyavenard

    jyavenard Network Guru Member

    Gibson believes he knows heaps when he doesn't as his security tools are just as useless...

    So whatever he says or write usually is automatically classified as junk and ignored..
  36. Toastman

    Toastman Super Moderator Staff Member Member

  37. ddotmada

    ddotmada Networkin' Nut Member

  38. Nitro

    Nitro Networkin' Nut Member

    Toastman, I am not asking you to watch all of it, I am asking for peoples opinions of the technology around fixing the "buffer bloat" problem. steve gibson didn't write the solution, he is merely highlighting it and discussing how it works.

    I actually think it would be very beneficial to someone like yourself who has over 250 wireless clients sharing a single adsl line. but people here seem content with never knowing or discussing it simply because steve gibson has talked about it.

    whatever, I guess I'll wait and see if cisco/linksys themselves add it to firmware, then switch to them to try it for myself.

    for those wishing to read up on codel and how it works here is the wiki: http://www.bufferbloat.net/projects/codel/wiki/Wiki

  39. BikeHelmet

    BikeHelmet Networkin' Nut Member

    Any chance someone could patch the IP traffic pages to start in GB rather than KB? I keep having to reset it. ;)
  40. thevdr

    thevdr Networkin' Nut Member

    I would like to second Nitro on this "codel" subject. It sounds interesting. I have been using the Toastman builds for satellite internet links and I guess this would be a great feature - both for a normal link at home and for links with bigger delayes or losts of users.

    Personally I am a newbie when it comes to building my own Tomato firmware - so I have to rely on a capable guys like Toastman ;-)

    So please, please, please.... Being a fellow engineer I know your time is limited. This is why I havent made my own build. But "codel" sounds like worth the effort.....
  41. maurer

    maurer LI Guru Member

    codel is written for kernel > 3.3
    tomato is still on - required by broadcom wireless drivers
    i did an openwrt build with george's patches (adds support for RT-N16 in openwrt trunk) if anyone's interested:
    it seems codel is already included in the qos-scripts (also in my build) and kernel.

    Attention! Untested build !
  42. Lorenceo

    Lorenceo Networkin' Nut Member

    Any news on getting radvd working properly with a user specified MTU? Currently have to execute it manually at router boot with a .conf file on a usb flash drive. It seems very crash happy, often exiting with Exiting, sigterm or sigint received. This happens between every 24 and 36 hours, killing IPv6 connectivity.
  43. thevdr

    thevdr Networkin' Nut Member

    Arg - I did'nt think of the kernel version. So openwrt seems to have implemented this?? Hm. I will stick to Tomato. Better QOS and I guess SFQ does a good job. Codel would have been nice to scale the buffer sizes to the actual connection bandwidth/delay though (or am I misunderstanding something) instead of just using tail-drop (which is what SFQ does now when the buckets are overflowing). Buffer sizes set correct to the corresponding bandwidth/delay of our connection would be nice to minimize latency - but this is set at compile time only?? Could SFQ buffer size be set as parameter in the GUI in a future build (maybe as a "number of packets") with a good guide to calculate a good value??

  44. D R

    D R Serious Server Member

    why is it when i turn on authentication username, password for samba file share, my network does not see the drive. but when it is turned off i can see folders, etc?
  45. RonV

    RonV Network Guru Member

    Wow it's really quite in this forum lately...does this mean that all the gremlins are gone in the latest release of Toastman! :)
  46. Solace

    Solace Networkin' Nut Member

    or just being patient with the upcoming release that addresses the known issues which is rare.
  47. gazsiazasz

    gazsiazasz Addicted to LI Member

  48. VanillaXtract

    VanillaXtract Serious Server Member

    How can I tell if I am running 7500 or 7500.2? I am sure it is .2 but in the syslog and web interface it just says 7500.
  49. thepoch

    thepoch Serious Server Member

    Go to the "About" page. Near the bottom you should see the timestamp it was built on. For my 7500.2 it says this:

    Built on Mon, 25 Jun 2012 12:05:20 +0700

    Any earlier and it's probably not 7500.2.
  50. lilstone87

    lilstone87 Serious Server Member

    Is there a reason I see no file system support for NTFS on toastman's firmware? I see Ext2 / Ext3, FAT, HFS, and HFS+ support. But my USB is formated with the NTFS file system, so is there any way of getting my drive to work?
  51. Toastman

    Toastman Super Moderator Staff Member Member

    What version are you running? It shows here as the second box in the filesystem support, as usual.
  52. lilstone87

    lilstone87 Serious Server Member

  53. Toastman

    Toastman Super Moderator Staff Member Member

    Yes, I see! The makefile has been changed by a merge, perhaps. I'll fix it when I have time. In the meantime, use an older version.
  54. lilstone87

    lilstone87 Serious Server Member

    Ok cool, thanks for taking the time to look, and see it wasn't a error on my end :). Because I made sure to do a erase all data from nvram, and redid all my settings. It will be nice once you, and Shibby release a 64k tomato firmware for the RT-N66U.
  55. igoreshka

    igoreshka Networkin' Nut Member

    hey Toastman
    can you tell me of what should i use for wrt610n v2 router
  56. dc361

    dc361 LI Guru Member

    @Igoreshka.. obviously I'm not Toastman but I did find this link on his FAQ: http://tomatousb.org/forum/t-386946/steps-to-update-linksys-wrt610n-r2-to-a-toastman-tomato-buil
    (yes the link has no 'd' on build)

    If you are really adventurous, you could follow BarryWare's instructions on the dd-wrt forum to update your WRT610v2 to an E3000 by changing the CFE (see: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=137565) I've updated two of my routers and they're now very happy as E3000s with one running dd-wrt and another TomatoUSB.

    Good luck!
  57. ghoffman

    ghoffman Addicted to LI Member

    i too would recommend the e3000 conversion. be very careful when you do it, and you'll never look back.
  58. subz3ro

    subz3ro Networkin' Nut Member

    toastman can you suggest me a way to solve the voip registration problem over vpn ? I am using openvpn & i can reach all tunnels but yet i cant register. I restart the voicebox & it registers otherwise not. Note this only happens after a router reboot. I have tried several methods like changing the UDP timeout value to 10 300 and various combinations. Interesting part is the voip works fine if I add another router in the LAN port of my Asus RTn-16. I am running tomato-K26USB-1.28.0500.2MIPSR2Toastman-VLAN-RT-N-VPN-NOCAT version.

    I can see in qos details only data being sent from my router to destination vpn register server but no incoming bytes. What is the reason behind this ?

  59. igoreshka

    igoreshka Networkin' Nut Member

    thanks guys,let still wait for Toastman himself to answer my question,very interesting of what he would say
    I still confused what s/w i need for wrt610n v.2 router
  60. the_bhagwan

    the_bhagwan Network Guru Member

    You are awesome!!
    Sorry to take up a post on this already bloated thread with 43 pages.
    But you're awesome!!!
    Thanks for what you do and sharing it with the world!!!
  61. Tordenflesk

    Tordenflesk Addicted to LI Member

    Yesterday, I put v1.28.7500 MIPSR2Toastman-RT K26 USB Ext on my Netgear WNR3500L which had previously run TomatoUSB. I did a full reset, cleared nvram and soforth. I redid all my usual settings and everything was just peachy. Now, 24 hours later, I'm having trouble doing much more that light web traffic before my connection dies. I can see that the router is hard at work doing pretty much nothing

    CPU Load (1 / 5 / 15 mins) 3.30 / 3.05 / 2.11
    CPU Usage 100.00%

    What TOP says:

    Mem: 23132K used, 38416K free, 0K shrd, 3172K buff, 8644K cached
    CPU:  0% usr  0% sys  0% nic  0% idle  0% io  0% irq  99% sirq
    Load average: 4.45 3.49 2.35 1/34 1549
    1470  1462 root    R    1720  3%  23% top
        3    2 root    SW<      0  0%  19% [ksoftirqd/0]
        4    2 root    SW<      0  0%  6% [events/0]
      518    1 root    S    1712  3%  5% telnetd -p 23
      386    1 root    S      744  1%  2% sd-idle
      321    1 root    S    1324  2%  1% buttons
      526    1 root    S    1192  2%  1% nas
      523    1 root    S    1012  2%  1% eapd
      564    1 root    S    2512  4%  0% nmbd -D
      565  564 root    S    2464  4%  0% nmbd -D
      538    1 root    S    1724  3%  0% crond -l 9
    1038    1 root    S    1724  3%  0% udhcpc -i vlan2 -b -s dhcpc-event -H t
    1462  518 root    S    1720  3%  0% -sh
      323  322 root    S    1716  3%  0% /bin/sh
      328    1 root    S    1708  3%  0% syslogd -L -s 50 -b 1
      330    1 root    S    1708  3%  0% klogd
    1037    1 root    S    1372  2%  0% httpd
        1    0 root    S    1340  2%  0% /sbin/init noinitrd
      322    1 root    S    1292  2%  0% console
      568    1 nobody  S    1104  2%  0% dnsmasq -c 1500 --log-async
    1034    1 root    S      900  1%  0% miniupnpd -f /etc/upnp/config
      283    1 root    S      752  1%  0% hotplug2 --persistent --no-coldplug
      43    2 root    SW      0  0%  0% [pdflush]
      87    2 root    SW<      0  0%  0% [mtdblockd]
        5    2 root    SW<      0  0%  0% [khelper]
      42    2 root    SW      0  0%  0% [pdflush]
      45    2 root    SW<      0  0%  0% [aio/0]
        2    0 root    SW<      0  0%  0% [kthreadd]
      44    2 root    SW<      0  0%  0% [kswapd0]
      433    2 root    SW<      0  0%  0% [kjournald]
      341    2 root    SW<      0  0%  0% [khubd]
      18    2 root    SW<      0  0%  0% [kblockd/0]
      408    2 root    SW<      0  0%  0% [scsi_eh_0]
      409    2 root    SW<      0  0%  0% [usb-storage]
    I see sirq is at a constant 99%. What is this?
  62. Elfew

    Elfew Addicted to LI Member

    I like the window with ports on the right picture... is that possible? I like it

    rs232 and n66666611 like this.
  63. jyavenard

    jyavenard Network Guru Member

    I ported tomato web interface to Linux Debian a few years back (more exactly, Linux voyage)... Was only a 2-3 days job... That included the http server, all the web asp pages and all the rc folder.
    Nvram lib was rewritten to use litesql so all the tomato code was usable as-is after that.
  64. The Doctor

    The Doctor LI Guru Member

    jyavenard, Tomato on Intel x86 hardware is something I've dreamed of, but never had the courage to even mention. A PC with a fairly cheap dual-core CPU & 2 network cards would make a router with awesome throughput, even if it was all going through a VPN. Any chance of you releasing your work on this? Perhaps we could have Tomato x86 soon?

  65. kthaddock

    kthaddock Network Guru Member

    If you wan't you can play wiyh DD-WRT X86 software.
  66. kmg90

    kmg90 Networkin' Nut Member

    Has anyone else had wireless issues with 7500.2? My WNR3500L WiFi barely works and by that I mean I can connect to it, I can establish somewhat of a link to the internet, but any web browsing typically amounts to:

    DNS request -> DNS resolved -> Connecting to Web site -> Connected to website -> ............. Nothing

    This occurs on all the wireless devices I have typically connected to the router all have this problem. (only wireless, wired clients have no issues)

    I've tried clearing NVRAM, I've tried re-downloading and re-flashing the firmware nothing seemed to work.

    So for now I'm on 7499.1 for now.
  67. n66666611

    n66666611 Serious Server Member

    I second that.Icons could be smaller but that's a nice interface feature.
  68. Mercjoe

    Mercjoe Network Guru Member

    I am just the opposite. I would say that the 7500.2 have had the best signal strength and throughput of all the recent versions.

    What version of the 3500l do you have ? Version 1 or 2? I am using a Version 1 myself.

    Which version of the firmware are you using??
  69. micro23

    micro23 Serious Server Member

    Hey guys. Thanks so much for updating tomato. I switched from tomato to dd-wrt when I get a wrt320 but I recently noticed you guys got it working with tomato!

    So here are my quetsions. I'm already running
    DD-WRT v24-sp2 (08/07/10) mega

    So can I upgrade directly to tomato? Here are the "instructions"
    1. The first time, before using Tomato, you must flash your router with a modified version of the Cisco firmware (CFE of 32K) : HERE
    2. Then you need to load a DD-WRT mini for the WRT320N (dd-wrt.v24-1xxxx_NEWD-2_K2.6_mini_wrt320n) for ex. HERE
    3. Then you should be able to directly load any Tomato-K26-MIPSR2-NoUSB Std , (standards or specials mod builds > 46): HERE or HERE
      (don't forget to reset the router and nvram , just after each flash)
    Next question.

    I see that there are 100 different firmwares but I dont see one specifically for the wrt320n. But I do see it's "WRT320N = E2000" Does that mean I can just use any e2000 firmware? I'm worried about this "you must flash your router with a modified version of the Cisco firmware (CFE of 32K) " part and noticed when I downloaded the latest e2000 firmware it said "tomato-E2000-NVRAM60K-1.28.0500.2MIPSR2Toastman-RT-N-Std" which is 60k.

    Long story short. I have a linksys wrt320n currently running DD-WRT v24-sp2 (08/07/10) mega What do I have to do to install this delicious new tomato ? THANKS!!!!!
  70. Pioneer

    Pioneer LI Guru Member

    As I've written here you can convert your WRT320N to an E2000 (same hardware).

    Only then you can flash an E2000 firmware.
  71. micro23

    micro23 Serious Server Member

    I found that thread right when you posted it ;) Thanks a bunch. I'm going to leave it on the wrt320 firmware for now then. I think that means I'm installing tomato-K26-1.28.7500.2MIPSR2Toastman-RT-VPN.trx today when I get home from work. Thanks for your help.

    I see that also posted in the versions instructions file in the root that if you want dual band you need the N version. Is that still the case? If so would tomato-K26USB-1.28.0500.2MIPSR2Toastman-RT-N-VPN.trx then be the correct file? Unfortunately then I guess I would have to ask is there any functional differences between those two files? I see it's for different routers but I cant seem to find the differences between them otherwise. The bulid notes on the changelogs are different so I assume they are different.

    June 14 2012- 1.28.0499.1

    June 14 2012- 1.28.7499.1

    Sure would love a recommendation ;)
  72. Pioneer

    Pioneer LI Guru Member

    The WRT320N/E2000 doesn't have simultaneous dual band. So get the normal RT-version (without the N).

    BTW nice decision to switch from dd-wrt to tomato ;)
  73. micro23

    micro23 Serious Server Member

    I miss tomato like you have no idea. I used to run it since it's inception on WRT54G back in the day. Cant wait to be home ;) Thanks again man I really appreciate it. Flashing my wrt320n directly from dd-wrt to tomato-K26-1.28.7500.2MIPSR2Toastman-RT-VPN.trx when I get home. Have a great day guys!
  74. micro23

    micro23 Serious Server Member

    I'm an addict so I flashed remotely ;) God how the heck did I ever live without Tomato. Thanks a bunch. Running great! The independent ip monitoring is incredible.

    I will say that the wireless is definitely borked on this release for me on a wrt320n. I also have an airport extreme as well and tested using that too. I simply cannot get over 25Mbps on a speedtest and thats only for a second most of the time it's in the 8-25 range. The wireless is very slow and wonky. Yet when I switch to my airport extreme it's rock solid every time. This also didnt happen with dd-wrt. Only wireless is affected. Wired works great.

    I can switch back and forth between routers and replicate the same thing every time. The airport is wired into the wrt320n.

    Let me know if you want or I can help troubleshoot in any way. I tried changing literally every single setting (security, modes, bands, everything) and it has the same results. Very very slow wireless and you can even see it going all the way up to 300 and as low as 12 on the status page under rate. Also tried resetting the router to factory defaults and full wipe the nvram in the settings for restore.
  75. gs44

    gs44 Networkin' Nut Member

    HI Toastman!! I haven't been as active here lately but I am still around :)

    I Just updated both of my E2000 and E3000 routers from NVRAM60K-1.28.7496MIPSR2-RT-Toastman (that has been running great since you released it) to the newest NVRAM60K-1.28.7500.2MIPSR2Toastman-RT version and so far everything seems great!! IPV6 support seems to function well and wireless speeds seem normal or even a little better :)

    Once again a BIG THANKS!! To you and all those involved that keep Tomato alive and going strong!!!!
  76. Toastman

    Toastman Super Moderator Staff Member Member

    Thanks for the feedback!
  77. jet8300

    jet8300 Serious Server Member

    This thread is confusing me. My router has Tomato Firmware v1.28.7633 .3-Toastman-IPT-ND ND Std on it currently and I decided to check for an update but you guys are talking recently about 1.28.0500.

    The version numbers are confusing me. Is there like a build log or a revision history or something somewhere so I can see what the most current stable build is? And also which routers are currently supported by this version of Tomato?
  78. Pioneer

    Pioneer LI Guru Member

    Which router do you have? It's an older MIPSR1 device (e.g. WRT54GL), isn't it?
    So version 1.28.7633.3 should be the most recent for you.

    1.28.0500.2 (RT-N) and 1.28.7500.2 (RT) are the most recent versions for newer MIPSR2 routers.

    There is more information in the Versions.txt file on Toastman's Download site.
  79. jet8300

    jet8300 Serious Server Member

    Yeah, it's a WRT54G v2. There's nothing wrong with the firmware on it, just wondered if there were any new features or updates. Thanks for the info! :D
  80. jet8300

    jet8300 Serious Server Member

    I still can't find a very good list of compatible routers. I'm looking for a new router for my mother's house and I find references here in the forums to routers that are running Toastman builds, but none of the lists I've found have these routers on them. A specific example being the Belkin Share Max N300 F7D7301.

    I've been looking here - http://en.wikibooks.org/wiki/Tomato_Firmware/Supported_Devices
    and here - http://tomatousb.org/doc:build-types

    I don't want to be a pain, but I appreciate anyone's help.
  81. Pioneer

    Pioneer LI Guru Member

    I don't know if there's such a list from Toastman, but Shibby has it on his website.

    I'd say, if a specific router isn't on that list, it doesn't support tomato.
  82. Nitro

    Nitro Networkin' Nut Member

    If you plan on running tomato then for simplicity and great quality I would recommend the Asus RT-N16 router which is nice and fast and has plenty of flash and ram for future updates and I also believe it was recommended by toastman as that was how i came to buy it :)
  83. _NemO_

    _NemO_ Networkin' Nut Member

  84. n66666611

    n66666611 Serious Server Member

  85. Mangix

    Mangix Networkin' Nut Member

    these are the changes:
    Build 23 (3-Jul-2012)
        (*) HTTP response lines are now separated by CRLF (not just LF), as per RFC2616;
        (*) SO_REUSEPORT used (where available) to allow more that one client
            to subscribe to the same channel on BSD-derived systems;
        (*) optimization patches by Alexey Suhinin integrated (tcp_nodelay, pause_timeout, mstream_type);
        (*) sloop.c uses syscall.h & -DUSE_SELECT to alternate between select(2)- and pselect(2)-based implementations of server loop
        (*) FIXED: idle timeout displayed incorrectly in select(2)-based version;
        (*) HTTP response includes 'Server:' clause;
  86. hawkmat

    hawkmat Networkin' Nut Member

    Just recieved a ASUS RT-AC66U. I looked though the log and noticed that they use new Broadcom drivers. Tomato drivers start with a 5 but these new ones in the ASUS firmware start with a 6.
    Jan 1 00:00:08 kernel: eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller (r338244)
    Jan 1 00:00:08 kernel: PCI: Enabling device 0000:01:01.0 (0000 -> 0002)
    Jan 1 00:00:08 kernel: eth1: Broadcom BCM4331 802.11 Wireless Controller (r338244)
    Jan 1 00:00:08 kernel: PCI: Enabling device 0000:02:01.0 (0000 -> 0002)
    Jan 1 00:00:08 kernel: eth2: Broadcom BCM4360 802.11 Wireless Controller (r338244)
  87. Dark_Shadow

    Dark_Shadow Addicted to LI Member

    Can you get a cfe dump and/or serial bootlog?
  88. coldmantis

    coldmantis Serious Server Member

    Hi there toastman, I love your firmware. Was about to pack up this E4200 until i tried your firmware, I was wondering where I can dl your newest versions. 4share says the folder is deleted and there is no files in mediafire for version 500.2 right now I'm using
    tomato-E4200USB-NVRAM60K-1.28.0497.1MIPSR2-Toastman-RT-N-Ext.bin but I have trouble with my ipad2 not connecting to the 5ghz band.
  89. Toastman

    Toastman Super Moderator Staff Member Member

    4shared have a problem. The files are actually stuck in the "recycle bin" and althought that actually says the bin is "empty" my free space is only showing 2.548 GB left. Therefore all the files *are* still there, intact, somewhere, and I expect (hope) they will be restored soon.

    I tried uploading to mediafire last night and that obviously failed as you can't see the files either. I'll try again later.
  90. ryzhov_al

    ryzhov_al Networkin' Nut Member

    Just tried to get access to 4shared via WebDAV right from router. "Recycle bin" is inaccessible.:(
  91. Toastman

    Toastman Super Moderator Staff Member Member

    Yeah, they've a problem with server. They will usually do a restore from a backup I think, but it'll likely take a few days.

    Uploaded to mediafire tonight.
  92. _NemO_

    _NemO_ Networkin' Nut Member


    I can give you ~10 Gb on my ftp if you wish.
  93. Mangix

    Mangix Networkin' Nut Member

    I can upload to BitCasa. Free for all.
  94. BikeHelmet

    BikeHelmet Networkin' Nut Member

    There should really be torrents available - that way one service or another going down won't ever limit access. Bandwidth and disk space wouldn't be a concern. The only problem would be "pulling down" versions that have issues. The tracker would be public, but someone would have to have control of it, to stop buggy versions and mis-compiles from spreading.
  95. Edrikk

    Edrikk Network Guru Member

    I think that's what this ddwrt patch is setting up for:
  96. Mangix

    Mangix Networkin' Nut Member

  97. coldmantis

    coldmantis Serious Server Member

    I have a WRT54G-TM, I believe it has 32mb of ram. It currently has tomatoe mlppp, I want to update this old firmware to toastman because since I setup my E4200 and used my WRT as a wireless client bridge I noticed that my dl speeds won't max out in real world test not speed test. I assuming I can use any firmware no matter the lable WRT54G, gs, L etc...?
  98. Toastman

    Toastman Super Moderator Staff Member Member

    That router is essentially similar to a GL.
  99. peyton

    peyton LI Guru Member

    It's just a stronger GL version as said
  100. Kiasu

    Kiasu Serious Server Member

    Hi Toastman,

    The folder still empty and no file. Any idea when will it be restored or any other location? Thx.

Share This Page