1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Toastman's Releases

Discussion in 'Tomato Firmware' started by Toastman, Dec 18, 2011.

  1. Nitro

    Nitro Networkin' Nut Member

    check toastmans signature out: it has an alternative link for when the first link fails.
  2. Lorenceo

    Lorenceo Networkin' Nut Member

    Any news on the IPv6 + radvd MTU problems?
  3. Monk E. Boy

    Monk E. Boy Network Guru Member

    The G-TM is a WRT54G v2 (which is basically the same hardware as a WRT54GL) with double the RAM & Flash.

    Any build intended for a GL will work on the G-TM, but builds for newer routers (MIPSR2) won't work on it.
  4. coldmantis

    coldmantis Serious Server Member

    any eta on when RTN files will be updated on mediaFire and if MIPSR1 K2.6 folder will be uploaded? thank you to everyone for clearing up the WRT54G-tm.
  5. Nitro

    Nitro Networkin' Nut Member

    Attached Files:

  6. Toastman

    Toastman Super Moderator Staff Member Member

    No. Because as time goes on we've been having trouble fitting new builds into the available space, we've all removed many themes already to make the binaries smaller.
  7. lucafolin

    lucafolin Serious Server Member

    Hi Toastman I need tomato-E2000-NVRAM60K-1.28.
    0498.1MIPSR2-Toastman-VLAN-RT-N-VPN with built in VPN PPTP server but 4shared files server was down....have you an alternative download site where I can find this firmware ?
    BR, L.
  8. Toastman

    Toastman Super Moderator Staff Member Member

    I'll try to upload it to mediafire for you. Look later.
  9. lucafolin

    lucafolin Serious Server Member

    Just downloaded, thank you so much.
  10. vancer32

    vancer32 Networkin' Nut Member

    Hi toastman. First of all thank you for the amazing firmware! I have flash tomato-E1500-NVRAM64K-1.28.0500.2MIPSR2Toastman-RT-N-STD.bin but I have some few problems encountered regarding my Linksys e1500 router. I am having a hard time connecting to PPPoE. Sometimes it instantly connects but most of the time it can't. I need to power cycle the router a few times. I did not encountered this problem on OEM firmware. Also when enabling Bandwidth Limiter after a few minutes it made my router unusable. No internet and can't login to config. Again Power cycling revives my router. I tried 30-30-30, resetting default default settings, clearing NVRAM, reflashing tomato firmware but problem still persists. I guess it's a bug in tomato. Please fix it I'd like sticking to tomato firmware I'd definitely not gonna flashback to stock firmware nor DD-WRT. THANK YOU.
  11. lucafolin

    lucafolin Serious Server Member

    Hi Toastman, I have installed tomato-E2000-NVRAM60K-1.28.0498-Toastman-RT-N-VPN on E2000 linksys but I havent't found GUI VPN PPTP server on it. Which is wrong? Which is The right version for E2000 pptp server embedded ?
    BR, L.
  12. Nitro

    Nitro Networkin' Nut Member

    ok no worries, you made me go back and look at the theme and I managed to reduce its size by 75% also if you are struggling for space for smaller builds then have you considered removing things like the overclocking feature? that is easily set via 2 commands in the system console and doesnt really justify the need for a GUI, it would also prevent newbies from mistakenly setting the wrong parameter. Just a suggestion (you probably already have done this :p )
  13. Kiasu

    Kiasu Serious Server Member

    Hi Toastman, I'm looking to flash my E4200 v1 with 5G and USB. So, I check your 4share and you have up to 1.28.0500.2VLAN and is that the stable version? Can you upload that version or a recommend stable version to that to mediafire pls? Thank you.
  14. unagisan

    unagisan LI Guru Member

    Toastman - thanks for the great firmware! I am running v1.28.7500.2 MIPSR2Toastman-RT K26 USB VPN on an Asus RT-N16 and loving the performance. Just a couple of questions:

    1) I have a 6to4 static tunnel up with Hurricane Electric and wondering if this build has ipv6 support in the firewall so my internal ipv6 clients are not out and exposed. I noticed there are ipv6 forwards so I can only assume so?

    2) I noticed that my 6to4 tunnel does not seem to automatically come up after rebooting. I must go in an manually update it before it comes up. Will this be resolved in future builds or can you suggest a 'fix'?

    Many thanks again for everything!

  15. tutorialbs

    tutorialbs Serious Server Member

    I have a complaint/question about QoS on my WRT54GL running: Tomato Firmware v1.28.7633 .3-Toastman-IPT-ND ND Mini-NOCAT build. This is likely more a problem with either Tomato or the WRT54GL, and I feel like Toastman needs his own team to help him answer all these questions, but I'll throw mine in with the rest anyway, sorry... LOL. But please, if anyone knows the answer, I'd love to hear it!

    No matter what I do to my classifications list, there is always (a lot of) traffic that ends up getting by as "Unclassified". Assuming QoS controls inbound traffic the same way it controls outbound traffic, at least by communicating with the sender to wait until higher local priority traffic has taken place (right??), I'm pretty sure that this traffic is simply untouchable by QoS, and therefore it's not controlled.
    Our favorite game here is a flash-based game that is run out of a browser window. I need my game to go faster than the others who play it, but I want their games to go faster than everyone else basically. So, i need rule(s) to accommodate port 80 connections that will have BOTH constant inbound/outbound traffic 1kb or less and/or, at times, up to 15mb per connection! There are always multiple servers, with multiple (very) different IPs, and 8 ports total are used (I think... it's weird, they use random but similar ports... makes QoS such a pain). That amount of data is GIANT for any multiplayer game! That is another huge part of why this is is such a pain. These annoyances render just about any pre-made QoS list worse than just not using QoS.
    I've tried every variation of "highest/high/medium/etc..." with my IP being the same or above what I set the "default class" for, but NOTHING works! Here are my settings (made sure my MACs & IPs weren't there, some of them in the 2nd list are subnets/gateway i didn't know whether those mattered or not). Note that the graph of 'show details' below actually does make sense in this case, because my first few classifications are set to: Disabled, however, even when I have no rules set to: Disabled, and I have rules that account for ALL possible bandwidth, there are still unclassified rules that screw up my game! Thanks!!
    IP | IP Range | MAC Address DLRate DLCeil ULRate ULCeil Priority TCP Limit UDP Limit​ 2500kbps 10750kbps 2500kbps 6250kbps Low nolimit nolimit​ 250kbps 6250kbps 250kbps 2250kbps Lowest 250 25/s​ 250kbps 3750kbps 250kbps 2750kbps Lowest 90 9/s​ 1250kbps 3250kbps 1250kbps 2250kbps Low nolimit nolimit​ 250kbps 7250kbps 250kbps 3250kbps Low nolimit nolimit​
    Enable QoS​
    Prioritize small packets with these control flags ACK SYN FIN RST
    Prioritize ICMP
    Reset class when changing settings​
    Default class Medium
    Qdisc Scheduler sfq
    "QoS - CLASSIFICATION" (Outbound Direction)
    Match Rule Class Description #​
    From ********************* Disabled 1MAC 1​
    From Disabled 1-2b 2​
    To Disabled 1-2a 3​
    From************************* Disabled 2MAC 4​
    From Low 3-7a 5​
    To Low 3-7b 6​
    From Lowest 8-51a 7​
    To Lowest 8-51b 8​
    (Unclassified connections selected.)
    Proto Source S Port Destination D Port Class Rule Bytes Out Bytes In​
    UDP 23453 ************* 23453 Unclassified 116 0
    TCP 2751 80 Unclassified 1801 5241
    TCP 43279 ************* 5228 Unclassified 1309 2303
    UDP 1024 ************* 1900 Unclassified 3994 0
    TCP 2756 80 Unclassified 1620 1082
    TCP 2752 80 Unclassified 1801 5281
    UDP ************* 68 ************* 67 Unclassified 0 1384
    TCP 2750 80 Unclassified 1835 9509
    TCP 2753 80 Unclassified 1801 5241
    TCP 2757 80 Unclassified 1787 128
    TCP 50719 ************* 443 Unclassified 1240 361
    TCP 50718 ************* 5223 Unclassified 2273 3267
    TCP 2754 80 Unclassified 1675 2198
    TCP 2755 80 Unclassified 1921 13.12 KB

  16. Porter

    Porter LI Guru Member

    1. You are posting in the wrong thread. This is the right one: http://linksysinfo.org/index.php?threads/using-qos-tutorial-and-discussion.28349/ .

    2. Don't use the bandwidth limiter. The BW limiter and the other QoS-system don't work together. Only enable QoS unter "Basic Settings".

    3. The unclassified traffic you are seeing is only happening in your LAN between you and your router. This doesn't influence internet speed and therefore doesn't need to be classified.

    4. Please post some screenshots of your whole QoS configuration the next time. Just parts of it are not that useful.

    I'm not even sure what you mean by that, but QoS doesn't communicate with other servers. It delays and drops packets. This is happening locally in your router.

    6. From here it looks like your only option is to give port 80 priority, since there is no way to know other ports or IPs.

    7. Cheating on friends is morally questionable.
  17. Toastman

    Toastman Super Moderator Staff Member Member

    Also, don't prioritize ACKS.
  18. AlexJoda

    AlexJoda Serious Server Member

    I tried the same and desperatly searched halve a day to find this PPTP Server for the E2000. The PPTP Server is not included in the non USB Toastman E2000 VPN Versions as one would think (the Linksys E2000 has no USB ports), but it is included in the USB VPN Versions for E2000. I downloaded tomato-E2000USB-NVRAM60K-1.28.7497.1MIPSR2-Toastman-RT-VPN.bin and the PPTP Server was in the VPN tunnel menue...
  19. dupondje

    dupondje Serious Server Member

    Just flashed the RT-N version on my E3000 and E2000.
    Using both routers to make a WDS connection to each other (wireless bridge).

    With RT I got a max speed of like 14mbit/seconds.
    With RT-N I max out my internet connection with 30mbit!

    RT-N seems to work way better on E3000 (5GHZ) then normal RT version.

    Thanks for this great firmware :)
    Just would like to flash the VLAN version (for Multi SSID), but stupid 4shared :(
  20. _NemO_

    _NemO_ Networkin' Nut Member

    Can you add to IPv6 "default gateway" setting? My IPS doesn't support Router Advertisements and without "default gateway" I can not use IPv6.
    Does "Router Advertisements" is necessary according to specification?
  21. dupondje

    dupondje Serious Server Member

    Then you need a DHCPv6 server also :)
  22. _NemO_

    _NemO_ Networkin' Nut Member

    No, I don't. My IPS give me only the following settings:
    IP: 2a03:7380:300:8000::/64
    GW: 2a03:7380:300:8000::fffe
    DNS: 2a03:7380:1fc:1::fffc
  23. gs44

    gs44 Networkin' Nut Member

    Hmm, Strange I to am running v1.28.7500.2 MIPSR2Toastman-RT K26 and have no issues at all with 6to4 static tunnel with Hurricane Electric on my E2000 or E3000 and it has been solid in the last 20 builds or so. My ISP also has its own 6to4 service and it functions perfectly as well. Maybe a router specific bug with only Asus RT-N16
  24. gs44

    gs44 Networkin' Nut Member

    Also, not sure but an after thought, is your ISP changing your Ipv4 address (your end point Ipv4 setting with HE) each time you reboot your router/network? if so this is the issue and has nothing to do with the router or firmware
  25. zorkmta

    zorkmta LI Guru Member

    Are there any version of RT-N66U of Toastman with 64k oficial?
  26. tutorialbs

    tutorialbs Serious Server Member

    I'll go respond to these in the other thread, I just have one or two more questions... thanks much for the quick responses!
  27. unagisan

    unagisan LI Guru Member

    No, the IP address is not changing. I am on a DHCP cable provider, and while it is a dynamic IP, the only way I can change it is to change the MAC address of my WAN device, so it stays 'static' for very long periods of time.

    I also use the DDNS updater with the HE TunnelBroker service configured should the link go down and my ipv4 WAN IP change.
  28. Mangix

    Mangix Networkin' Nut Member

    4shared is back up. just fyi.

    have to ask, how it is possible for the tailed E1000v2 MiniIPv6 firmware to exceed 4 megabytes? The flash chip itself is only 4...
  29. jyavenard

    jyavenard Network Guru Member

    MiniIPv6 is around 3.6MB at present
  30. kthaddock

    kthaddock Network Guru Member

    Maby you can imlement this. tempsensor:
    wl -i eth1 phy_tempsense
    wl -i eth2 phy_tempsense
    78 (0x4e)
    wl: wl driver adapter not found 
  31. Toastman

    Toastman Super Moderator Staff Member Member

    Temp sensor - what would it actually achieve?
  32. kthaddock

    kthaddock Network Guru Member

    Yes I know but I thought it was a fancy thing :)
  33. Toastman

    Toastman Super Moderator Staff Member Member


    I do know it would result in hundreds of new complaints in the forums about "overheating problems" !!!!
  34. Mangix

    Mangix Networkin' Nut Member

    the RT-N version is bigger.
  35. dupondje

    dupondje Serious Server Member

    Just upgraded my E3000 to last VLAN RT-N build. Just works perfect!
    But still missing some small things

    1) aiccu client by default (having it installed with optware now, so not such a big deal)
    2) Port Forwarding on IPv6 is weird. Does it now just forward ports? Or just open the ports in iptables (because all IPv6 clients have public IP)
    3) Something I would really really like is IPv6 support for IP Traffic. Now the IP Traffic stats are quite useless, as they only monitor IPv4 traffic.

    Anyway! Thanks for the good work on this firmware :)
  36. Nitro

    Nitro Networkin' Nut Member

    LOL! if you did do something like this you could colour code the output so that green = normal yellow= abnormal red=HOT! :D
  37. PJON

    PJON Networkin' Nut Member

    My DNS provider DNSMadeEasy isn't listed in the dynamic DNS provider list. They provide info on what's needed here


    Four parameters are needed, the last of which (IP address) is variable. Is there a way it can be referenced symbolically? Or is there an alternative solution?
  38. Sunspark

    Sunspark LI Guru Member

    Might be known info already, but the 2.4 VPN Client feature is really glitchy.. I have it working with both PPTP and OpenVPN but the PPTP (I use this more than OpenVPN as it seems more consistent and easier to work with) module has a lot of issues.. pressing start now warns me unsaved changes will be lost even on a clean reboot, start now doesn't always start.. likewise stop now doesn't always stop.. often requires stop now button twice.. sometimes starting it just doesn't do anything, and have to reboot it again before trying again to start it, have hard-locked the router requiring a hard power-off while fiddling with PPTP and OpenVPN client modules, etc.

    Reason I was fiddling with it through the router rather than a computer is because of devices like the PS3 that don't have VPN support.
  39. Mangix

    Mangix Networkin' Nut Member

    one thing to be known about using PPTP is that its security is broken. if you go to https://www.cloudcracker.com, you can submit a captured authentication request and crack it in less than 23 hours. Just saying...

    edit: I failed at the address. fixed.
  40. Sunspark

    Sunspark LI Guru Member

    True.. not really that much of an issue for the use it's used for atm.. streaming video from region locked areas to another region.

    I could fiddle with OpenVPN again, but it was glitchy a touch as well.. I wonder if those are meant for kernel 2.6 or makes no difference.
  41. Jacques

    Jacques Addicted to LI Member

  42. Sunspark

    Sunspark LI Guru Member

    Another thing that I am finding which is offputting, is that domain name redirection magic doesn't work well in Tomato.. if I set the DNS server to be static on the router including having use received dns turned off in dnsmaq, it's there and all that, but going through the web page tells me it is not set up properly.. setting DNS server on the device has it work properly.. does not through device told to get dns from the router which has the DNS server hardcoded as static.. I would see this as a bug. Rebooting devices and router does not do any good to resolve that. I need to dig out my spare router and experiment later and see if there is any difference between firmwares or if it is consistent behavior for all.
  43. jyavenard

    jyavenard Network Guru Member

    I didn't understand a word of you were trying to say...
  44. Nitro

    Nitro Networkin' Nut Member

    I also didn't understand fully what sunspark was saying but I think what he is trying to do requires the option

    to be activated (checked) in order to prevent a client connected to the router from providing their own DNS server addresses.
  45. Sunspark

    Sunspark LI Guru Member

    Geesh.. I re-read what I wrote.. it really does sound like gibberish doesn't it? Sorry guys.

    Intercept doesn't work.

    I'll re-write what I said clearer and more detailed this time around.

    Services like Netflix, BBC, etc. lock themselves to different regions: USA, CANADA, UK, etc. for licensing reasons, etc. What this means is that if you're in Canada for example and wish to watch content on Netflix stored in another region, you can do it two ways. You can use VPN or you can use DNS redirection. VPN works but is a pain because as mentioned, glitchy, and lowers your bandwidth. Sometimes you have to use VPN because the device you may be using does not (i.e. PS3) support a more recent flash version in its internal browser meaning you can't stream video in the PS3's web browser, but there may be a PS3 app that will allow you to use DNS redirection. For DNS redirection, there are servers like unotelly, unblock-us, tunlr, etc. that have you use their DNS server and if correctly communicating, they will fix the DNS so you get the content you want streamed directly to you from the other region without having to go through a middleman like VPN so you have full speed. So, on both the PS3 and the computer behind the router, if you set unotelly's (decent) DNS IP your device's network settings, as a static IP the page will tell you everything is set up correctly and you can watch Netflix-US in Canada, etc. If you have the PS3 and/or the computer set to use the router as DNS, and have the router use Unotelly's DNS server as a static DNS server IP, nothing breaks, but the Unotelly setup page when viewing it on the computer says it is not setup correctly, and you don't see the content from the other region.

    And that is the part that is confusing me.. why shouldn't it work? If the router is connected to the WAN, and the WAN is what is registered with the DNS redirection service, then shouldn't all devices behind the router automatically be set-up correctly, rather than requiring the devices to use a specific DNS server on their own network settings page?

    By the way, this DNS redirection stuff really works fantastically if you've set it up on the device viewing the content and I encourage you to take a look if you have a subscription already.
  46. randyoo

    randyoo Addicted to LI Member

    It's working perfectly well for me, but I'm not using intercept. (not at home, for this purpose, at least) I'm using unblock-us, and have their DNS servers entered in the Basic Network settings, which are then passed to all the clients via DHCP. I've even got the following script in WAN-up so the router auto-updates on ip address changes (I think you need the optware version of wget for this to work):

    /opt/bin/wget --post-data 'validated=1&email=my.unblockus.email.account%40gmail.com&rid=0' http://realcheck2.unblock-us.com/ -O /dev/null
    And yes, you're right, the DNS redirection is far superior to encapsulating the entire WAN connection in a VPN tunnel. More bandwidth, lower latency.

    Final note: I'm using Toastman's latest build on another router using DNS intercept, and it's working fine.
  47. Sunspark

    Sunspark LI Guru Member

    randyoo: Just now I switched my laptop from statically assigned IPs to DHCP to test, and the problem is resolved by this method. Thanks for the tip!

    I don't have an understanding as to why it works fine if I connect to the router with DHCP, but if I connect via statically assigned IPs instead I then need to use the external DNS IP on the device, rather than the router IP which has the external DNS IP in it.

    Do you have any ideas as to what DHCP does differently?
  48. Sunspark

    Sunspark LI Guru Member

    I don't get it.. it stopped working with DHCP and once again requires the devices to have the DNS IP that is not the router hardcoded into the settings.
  49. Sunspark

    Sunspark LI Guru Member

    I think I may have solved it.. but I have to test more tomorrow, and back to static as well maybe.

    In dnsmasq, I have to type server=#.#.#.#

    Useless in the LAN static IP settings area.

    This has got to be a bug of some sort.
  50. zorkmta

    zorkmta LI Guru Member



    Which are the difference between these two build, both said 64k and work for RT-N66U?

    Att the moment working with 499.3 VLAN version.

    Thanks for help
  51. Monk E. Boy

    Monk E. Boy Network Guru Member

    One supports arbitrary (e.g. beyond built-in) VLAN tagging, the other doesn't.

    VPN means Virtual Private Networking support, NOCAT is some form of guest networking where you present each client with a contract (via a web page on the router) they have to agree to before they're allowed to use the internet (or at least I think that's what it is), and VLAN is virtual LAN support allowing you to have a number of logical networks inside the router.
  52. bugalugs

    bugalugs Serious Server Member

    Yep no idea either, its very confusing but I can confirm that tomato-K26USB-1.28.7497.1MIPSR2-Toastman-RT-VPN.trx is working on this router but you need to load dd-wrt.v24-15396_NEWD-2_K2.6_mini_f7d3301.bin via the rotuers CFE prior to installing the toastman build for some reason.
  53. thunderforce

    thunderforce Networkin' Nut Member

    A couple of questions for those with E3000 routers using standard (non-VLAN) toastman firmwares:

    1) Which 2.6 firmwares best support dual-band [2.4/5 GHz]? RT or RT-N?

    2) Can the above firmwares support simultaneous dual-band connections well? I was reading on the forums that it's still relatively new to these firmwares.

    3) Also, of the firmwares in 1 and 2, only the EXT USB and non-USB versions have ipv6?
  54. jyavenard

    jyavenard Network Guru Member

    depend on your router, I'd go with the RT-N, it has newer driver

    They all do.


    USB/non-USB has nothing to do with having IPv6 or not, IPv6 is a separate option, could have USB with no IPv6 and non-USB with IPv6 and vice versa
  55. thunderforce

    thunderforce Networkin' Nut Member

    I was only asking about the EXT because there was a thread here saying that on the STD versions of Toastman's firmwares, that the ipv6 tab wasn't in the router config menu. I know USB has nothing to do with ipv6; I was asking about STD vs EXT specifically and if ipv6 were only in the EXT versions or not.
  56. though

    though Network Guru Member

    hey toastman-

    is the ASUS RT-AC66U supported yet by chance? thanks again for all your excellent work.
  57. jet8300

    jet8300 Serious Server Member

    I'm having some trouble with my WRT54G v2.2 locking up after flashing a VPN version and I have a stupid question. I was looking at going back and sorting through the download page for the right version and wonder what is the difference between the "tomato-WRT54G_WRT54GL" version and the plain "tomato-ND" version? Which one should I be using? I've been using the plain version.
  58. Solace

    Solace Networkin' Nut Member

    any progress on the last few discovered issues which caused the last build to be pulled?
  59. Andy_113

    Andy_113 Networkin' Nut Member

    not sure if this has been answered before but can i use this build - tomato-k26usb-nvram64k-1.28.0500.2-MIPSR2Toastman-RT-N-EXT - on the Asus RT-N66U? as i'm currently using the normal 32k build and running out of nvram space.

    Thanks devs for your hard work
  60. jyavenard

    jyavenard Network Guru Member

    You can, but you will have to perform a full reset. You will not be able to restore from a backup.
  61. jyavenard

    jyavenard Network Guru Member

    One has the original wrt54 drivers as provided by link says back in the day, the other has newer drivers (still quite old). The ND will work on the WRT54GL provided you stick to 2.4 kernels
    pharma likes this.
  62. Andy_113

    Andy_113 Networkin' Nut Member

    Thanks for clearing that up, was getting rather confusing.
  63. Tom Parkison

    Tom Parkison Networkin' Nut Member

    I'm getting an E3200 router tomorrow because my older E3000 router crapped out on me. Don't know why, but it did. I can't find an E3000 at all for a decent price. Oh sure, I could buy an E3000 but the best price is on Amazon.com for $200. Yep, you read right... $200!

    Anyways, I couldn't help but to notice that there are version differences for the two routers. The E3000 has version 1.28.7500.2 and the E3200 has version 1.28.0500.2 as their latest versions. Why the two versions? Is one older than the other?

    Also, how do you install the firmware. I'm not new to this firmware, I used this firmware on my E3000 but with the new E3200 I'm assuming that some things changed. Do I just load the router, go to the firmware upgrade page, and then flash away? Or do I have to do something different from the routine that's used on the E3000?

    Also, is there any real difference between the 3200 and the 3000?
  64. eahm

    eahm LI Guru Member

  65. FlyingHorse

    FlyingHorse Networkin' Nut Member

    You might also try going to the Linksys Outlet. I got my 4200v1 from them and am very pleased with my purchase. :D
  66. Toastman

    Toastman Super Moderator Staff Member Member

    August 15 2012 - 1.28.7500.4 and variants

    Maintenance update with bugfixes and improvements
    Thanks to JYAvenard and contributors

    - Add support for RT-N66 64K nvram (RT-N)
    - Fix nvram size for router with more than 32kB of nvram (not only 32/64kB)
    - Several fixes virtual wireless (MultiSSID)
    - Add "wireless" and "wl" optional services:
    • wireless: stop/start the wireless service, re-initialising the interfaces
    • wl: load/unload the wl drivers and re-initalise the various wireless interfaces
    - Rework virtual wireless configuration page, this commit fixes several issues:
    • Couldn't delete an entry once it had been created
    • Any changes made to an existing entry would never survive a
    • reboot (nvram commit wasn't run after clicking on save)
    • Twice as fast to save and reconfigure (20s vs 10s using new wireless restart service)
    - Restore static dhcp users = 250 (This got set back to 140 somehow)
    - IPP2P update to 0.99.16

    Vitaliy69 likes this.
  67. Cyberian75

    Cyberian75 Network Guru Member

    Does your firmware have IPv6?
  68. DanielCoffey

    DanielCoffey Networkin' Nut Member

    Thanks Toastman - my E3000 is loving your firmware. Sure I am only a basic user with one Mac Pro and a couple of mixed speed wireless devices but it loves it!
  69. Solace

    Solace Networkin' Nut Member

    bw monitor seems to be causing reboots again. was fine in previous builds and shibbys. attempted on tomato-E4200USB-NVRAM60K-1.28.0500.4MIPSR2Toastman-RT-N-VLAN-VPN-NOCAT with e4200v1

    other then that great build and a much more snappy interface/load times.

    guess ill stick to shibbys build since it has the appropriate fixes and a functional BW monitor for the time being.
  70. Toastman

    Toastman Super Moderator Staff Member Member

    BW Monitor?

    Provide symptoms? All appears to be working fine here as far as I can see.
  71. Ryan Goldstein

    Ryan Goldstein Serious Server Member

    koitsu wrote a WAN UP script to get IPv6 working on Comcast and other ISPs; it would be great if you could implement it into your build so this additional script isn't required. Here is his WAN UP script and associated comments:

    # Workaround for TomatoUSB bug where a spurious default IPv6 route is
    # added for no justified reason, resulting in packets getting forwarded
    # effectively to /dev/null.
    # 1. Temporarily disable accepting IPv6 RAs on the WAN interface.  This
    #    will stop the kernel from automatically adding a default IPv6 route
    #    when such an RA is received via the WAN.
    # 2. Delete ALL default IPv6 routes.  In effect this deletes the spurious
    #    IPv6 default route, as well as any default IPv6 routes received via RA.
    #    Sadly the "ip" command does not give you a way to differentiate between
    #    the two, since the one we truly want to delete lacks "proto kernel".
    # 3. Restore honouring IPv6 RAs via the WAN.  Within 60-120 seconds (often
    #    within seconds on Comcast) a default IPv6 route should be added by the
    #    kernel.  You can use "ip -6 route show default dev `nvram get wan_iface`"
    #    to verify; you should have only one route ("default via fe80::xxx ...").
    # http://www.dslreports.com/forum/r27234575-TomatoUSB-and-Comcast-IPv6-bugs-found
    echo 0 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/accept_ra
    ip -6 route flush default dev `nvram get wan_iface`
    echo 2 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/accept_ra
    Thanks for all your great work, Toastman!
  72. Tom Parkison

    Tom Parkison Networkin' Nut Member

    One thing that I noticed is that the the firmware for the E3200 doesn't seem to have the 5 GHz WiFi option. I remember reading somewhere that the drivers for the USB-based BCM43236 WiFi card isn't available, or rather, wasn't available at the time. But... according to this page, drivers are available, they just need to be patched into the source.
  73. Tom Parkison

    Tom Parkison Networkin' Nut Member

  74. guardian

    guardian Serious Server Member

    Latest build (1.28.7500.4, tomato-K26USB-1.28.0500.4MIPSR2Toastman-RT-N-VLAN-VPN-NOCAT.trx) on Asus RT-N66 leaks memory insanely under load, then the linux OOM killer starts to kill processes and router hangs. It seems that the leak is in kernel, not in processes. Build 1.2800.7500.2 is ok, no leak.

    After that, the build by Y. Avendard (tomato-K26USB-1.28.0501.2MIPSR2-jya-RT-N-VLAN-VPN-NOCAT.trx) leaks too, same way. Probably, the problem with that build is the same.
    Dent likes this.
  75. koitsu

    koitsu Network Guru Member

    For Toastman mainly -- I've done as much low-level work as I can to figure out the root cause:


    My guess is still Web Usage and/or IP Traffic features being enabled in people's configs/routers, since the statistics for these are tracked/stored purely in slab space (kernel memory) and not userland.

    I run tomato-K26USB-1.28.0500.2MIPSR2Toastman-RT-N-VPN.trx and do not have memory exhaustion problems as described by others, but I also disable Web Usage and IP Traffic.
  76. pharma

    pharma Network Guru Member

    I've been running tomato-E4200USB-NVRAM60K-1.28.0500.2MIPSR2Toastman-RT-N-VPN.bin since it first came out with no problems. Not one reboot with 6 wireless clients and heavy torrent usage, and definitely no memory leakage. I also have Web Usage and IP traffic enabled.

    Time Thu, 16 Aug 2012 18:26:47 -0400
    Uptime 5 days, 01:03:53
    CPU Load (1 / 5 / 15 mins) 0.00 / 0.00 / 0.00
    CPU Usage 2.61%
    Total / Free Memory 60.31 MB / 48.83 MB (80.96%)

    Sounds like you might have a config issue, or used the config file created from Shibby's mod.

    When I upgrade to the latest 1.28.0500.4 version I'll update this post on the results.

    Download a 3.3 gig torrent at 1.4 MB/s, download the latest Nvidia driver and surfed the web with no problems. Below are snapshots of CPU and memory usage:

    At Start of Downloading

    Thu, 16 Aug 2012 19:33:40 -0400
    CPU Load (1 / 5 / 15 mins)
    0.00 / 0.02 / 0.00
    CPU Usage
    Total / Free Memory
    60.04 MB / 47.60 MB(79.28%)

    10 minutes later, 2/3 torrent complete:

    Thu, 16 Aug 2012 19:43:49 -0400
    CPU Load (1 / 5 / 15 mins)
    0.05 / 0.02 / 0.00
    CPU Usage
    Total / Free Memory
    60.04 MB / 47.54 MB(79.19%)

    Torrent complete, surfing ...
    Thu, 16 Aug 2012 19:58:24 -0400
    CPU Load (1 / 5 / 15 mins)
    0.01 / 0.13 / 0.08
    CPU Usage
    Total / Free Memory
    60.04 MB / 47.70 MB(79.44%)

    No reboots or signs of memory leaks. I did notice a variation in wireless strength with some clients - prior version seems to have stronger wireless signal using same settings, but will observe for now.

  77. Toastman

    Toastman Super Moderator Staff Member Member

    thanks Koitsu!

    The latest release 7500.4 and 0500.4 is merged with JYAvenard's code too, I expect they would behave similarly. So was 7500.2/0500.2.

    TBH, apart from simple tests, I do not use the (experimental) VLAN builds here on any of my installations as I have no need of VLAN or Multi-SSID. Fact is, at the moment I have almost no time to devote to the project due to workload. Jean-Yves - any comments? Apart from the occasional weekend I'm still out here in never-never land!
  78. Solace

    Solace Networkin' Nut Member

    you may be correct, i did clear nvram when flashing though. maybe ill try again in the future with a 30/30/30 as well either way shibby is working without issues so ill just leave that on for now.
  79. tenskwatawa

    tenskwatawa Networkin' Nut Member

    Recent Web Searches​
    It is something wrong with Recent Web Searches - I thing it doesnd work from v1.28.7500 on my rt-n16.​
    My version is Tomato Firmware v1.28.7500.4 MIPSR2Toastman-RT K26 USB VPN​
  80. phykris

    phykris Addicted to LI Member

    Hi Toastman.

    Thanks for the great new build. Could you push it to git? Or is it too early for that?

    I would like to see in the source code what changed and I would like to use it as a start point for fixing an old bug (iptraffic monitor only works after a reboot for certain subnets, e.g.
  81. Toastman

    Toastman Super Moderator Staff Member Member

    tenskwatawa: it's working normally here on RT-N16

    phykris: I'll push it later, I just forgot to do it the other day :)
  82. pharma

    pharma Network Guru Member

    I've gone back to the previous version, tomato-E4200USB-NVRAM60K-1.28.0500.2MIPSR2Toastman-RT-N-VPN.bin.
    The wireless signal strength is stronger for my devices. No detailed analysis but primarily comparing signal strength of the wireless printer 5 inches away from the router - with 0500.2 the RSSI value is between -3 and +2, and the Quality is between -95 and +102. With 0500.4 the numbers are slightly worse -- RSSI is about -9 and Quality stays around 88.

    While the numbers are still good with 0500.4, my current priorities are to maximize wireless signal strength. So for now have gone back to 0500.2.

    Thanks to the developers for your continued efforts! :)
  83. kthaddock

    kthaddock Network Guru Member


    I think your signal from printer is TO strong 5 inches away. Rx is probably over loaded, move that away and test.
  84. pharma

    pharma Network Guru Member

    Hi kthaddock,

    With everything being the same (wireless settings), there should not be any variation in signal strength between firmware versions. However, I also noticed signal strength is less for clients 100 feet away downstairs. The strong signal returned for all wireless clients with 0500.2 using the exact same settings.
  85. Dent

    Dent LI Guru Member

    I also experience a similar problem with the 1.28.0500.4 RT-N version firmware for my E4200. I never examined the memory stats. I only know that the router hangs frequently necessitating a disconnection of power from the router in order to reboot it. I find the same problem with Shibby's version 100 firmware. Moving back to Toastman's 1.28.0500.2 firmware and all is well again. The only extras I have on are the IPv6 using the Hurricane tunnel and DDNS for the Hurricane Tunnel and OpenDNS.
  86. pharma

    pharma Network Guru Member


    I did not encounter that problem with 0500.4, but I am not using IPv6 or DDNS. It will be interesting if Guardian is using the same extras you are.
  87. pzlmg

    pzlmg LI Guru Member

    I also experience the same problem with "tomato-K26USB-NVRAM64K-1.28.0500.4MIPSR2Toastman-RT-N-VLAN-VPN-NOCAT.trx" on RT-N66U. I upgrade from 1.28.0500.2 and erase NVRAM. After about 4 hours, I noticed the free ram reduced to about 190MB. With Build 1.2800.0500.2, I got 25 days uptime, and the free ram was always about 220MB, no leak. Like Dent, I am using the IPv6 with the Hurricane tunnel and DDNS for the Hurricane Tunnel and I am using upnp, dnsmasq, optware, python, too.Moving back to Toastman's 1.28.0500.2 firmware and all is well again.
    Name RT-N66U
    Model Asus RT-N66U
    Chipset Broadcom BCM5300 chip rev 1 pkg 0
    CPU Freq 600 MHz
    Flash Size 32 MB

    Time Sat, 18 Aug 2012 10:24:08 +0800
    Uptime 12:06:06
    CPU Load (1 / 5 / 15 mins) 0.00 / 0.00 / 0.00
    CPU Usage 6.86%
    Total / Free Memory 250.00 MB / 228.33 MB (91.33%)
    Total / Free Swap 488.27 MB / 488.27 MB (100.00%)
  88. maple.chick

    maple.chick Networkin' Nut Member

    Toastman, any chance you will be adding PPTP server to WRT54G or K24 builds?
  89. Toastman

    Toastman Super Moderator Staff Member Member

    Probably not - too much hassle to keep that up to date.
  90. guardian

    guardian Serious Server Member

    Guys, the problem with the memory leak is identified and it is with 6in4 tunnel. It would be nice if it will be fixed in the next build. I've heard that Shibby is fixing it in his build.
  91. Solace

    Solace Networkin' Nut Member

    sorry i meant to say BW limiter not monitor. it was doing the same thing as i once reported in the past. it would consistently reboot of which you have to either 30/30/30 or wait for a bleak opporunity for it to kick it for a brief second to disable the BW limiter. of which i decided to try shibbys again after. i had no other real special features enabled other then the web monitor enabled. before it was the Default Class for unlisted causing the reboots, now it was just enabling the BW limiter after configuring some other settings. ill trouble shoot it some more another time since i need the router running for now.
  92. vancer32

    vancer32 Networkin' Nut Member

    I am also facing a problem on my E1500. When I enable B/W Limiter and configure it after a few minutes the router would lock-up. QoS works great though. Shibby's B/W Limiter doesn't have this problem. I am sticking to toastman build for the QoS. Please fix this problem toastman. thanks.
  93. Toink

    Toink Network Guru Member

    Update method: 30-30-30 + clear NVRAM from configuration menu.

    Flashed tomato-E3000USB-NVRAM60K-1.28.7500.4MIPSR2Toastman-RT-VLAN-VPN-NOCAT.bin to my E3000, and I also experienced lock-ups and 100% CPU usage when I enable Samba Share - although no sharing activity, whatsoever is happenning in the background. As soon as I enable and save the Samba Sharing settings the CPU usage will shoot up to 100% and the router would lock-up.

    Disabling the setting solves the issue.
  94. latinhawk

    latinhawk Serious Server Member

    I hope I am in the right place to ask my question. I have two routers an E2000 and an E2500
    that I need to flash. I like Toastman's builds as I have tried the before but with a router that previously had DD-WRT. The router I want to flash have original firmware and I need to know it I can flash them directly or if I need some other firmware first. Any help will be greatly appreciated.
  95. Toink

    Toink Network Guru Member


    You can definitely flash Tomato Firmware from the stock Linksys firmware. Just make sure BEFORE you flash your router, YOU MUST SET A STATIC IP ON YOUR PC. Toastman's builds has DHCP disabled by default.

    Don't forget to do the 30-30-30 clearing of NVRAM after flashing. Goodluck!
  96. Mangix

    Mangix Networkin' Nut Member

    trailed build is needed when flashing from the stock firmware. so flash a build that has E2000 and E2500 in the file name.

    i personally flash to dd-wrt first and then tomato since the toastman trailed builds have issues when flashing with serial but are otherwise fine from the web interface.
  97. JugsteR

    JugsteR Serious Server Member

    Not to worry, setting static IP after flash works equally good.

    Signature? Signature!
  98. Dr Strangelove

    Dr Strangelove Networkin' Nut Member

    Linksys E4200v1 running Tomato Firmware v1.28.0500.4 MIPSR2Toastman-RT-N K26 USB VLAN-VPN

    Haven't really noticed any problems myself. Run OpenVPN and PPTP servers and DDNS. No IPV6, monitoring, QoS or USB services.

    WiFi seems to be much the same as it's always been at 15metres with a noise floor of -85dB and signal strength of -63dBm(As seen on router interface), with other neighborhood WiFi operating in the same 2.4GHz frequency.
    Never had to reboot my E4200 and my Alienware M11x never seems to drop the WiFi connection and maintains approx 48 - 72Mbps throughput to NAS.
    My Olde Worlde XPERIA X10i 802.11g phone can maintain a working connection at 15metres, with only the odd dropped connection due to lack of signal strength at the phone.

    Thanks to those maintaining and supporting the firmware.
  99. xyn19

    xyn19 Addicted to LI Member

    Thank you for a great piece of firmware.

    But I cannot download the following particular firmware file:

    After clicking on Download and wait 20 seconds, it says "The file link that you requested is not valid."

    I have no problems downloading other files in the same folder.

    Could you please take a look?

    UPDATE: Aug 23, 2012
    Was able to download the firmware today, thanks a million!!!
  100. Toastman

    Toastman Super Moderator Staff Member Member

    Aha I did find a problem, try again, it should be OK now.

Share This Page