1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Toastman's Releases

Discussion in 'Tomato Firmware' started by Toastman, Dec 18, 2011.

  1. latinhawk

    latinhawk Serious Server Member

    I have been looking for the firmware for the E2500 but I don't see a build for it. Can some one tell me if there is one?
  2. latinhawk

    latinhawk Serious Server Member

    Forget it guys. It must be my age creeping on me. Found it.
  3. latinhawk

    latinhawk Serious Server Member

    Can anyone tell me if Toastman's build 1.28 RT-N activates the dual band on the E2500? I just installed it and I cant find the 5ghz portion in the GUI
  4. ppnndd

    ppnndd Serious Server Member

    5ghz is not yet supported for e2500/e3200
  5. latinhawk

    latinhawk Serious Server Member

    Thanks. I guess I'll have to live with the stock firmware.
  6. xyn19

    xyn19 Addicted to LI Member

    Yes, it works now, thanks a million!!!
  7. demstats

    demstats Serious Server Member

    Any reason why you removed ssh from the 7500.4 MISPR2 miniIPV6 build?
    I take great care to read the changelog before upgrading and nowhere it mention ssh removal, yet it is not present in 7500.4...
  8. Toastman

    Toastman Super Moderator Staff Member Member

    It was removed to make the build smaller after complaints from users that it was too large to flash.
  9. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I've lost track a bit so wanted to ask. Is there a version which incorporates Shibby's memory leak fix available?
  10. kthaddock

    kthaddock Network Guru Member

  11. Mangix

    Mangix Networkin' Nut Member

    isn't the memory leak only present in 1.28.7500.4? previous versions should be good.
  12. Toastman

    Toastman Super Moderator Staff Member Member

    Probably 0500.3 and 0500.4 are affected. 0500.3 is no longer in the repository anyway.

    It is beginning to look like the newer wireless driver is the cause, as I suspected. In the meantime these builds are marked as "BETA - "unstable"
  13. apoc

    apoc Serious Server Member

    Hi, I have 2 F7D3302 v1 routers, I updated the firmware on 1 of them to tomato-F7D3302-1.28.7500.2MIPSR2Toastman-RT-Mini however the device fails to respond. Did I mess it up by doing the firmware update via the router web interface or have I selected the wrong firmware ? it did advise the flash was sucessfull however even trying to ping the device after a reset it does not respond.
  14. kthaddock

    kthaddock Network Guru Member

    Try to set static IP, DHCP server is off by deffault.
    apoc likes this.
  15. apoc

    apoc Serious Server Member

    Brilliant, thank you. for some reason I have 2.1 in my head all night :)
  16. apoc

    apoc Serious Server Member

    would I be right or wrong in thinking a firmware such as tomato-K26USB-1.28.7498.1MIPSR2-Toastman-RT-Lite.trx is generic and can be used on the f7d3302 to give usb support, flashing using tftp ?
  17. ccbadd

    ccbadd Network Guru Member

    I have been having a problem with getting Asterisk working via optware. I have installed it and outgoing calls are fine, just not incoming. I have a F7D3301 running 7500.4 behind another router running DD-WRT with port 5222 forwarded. The problem is the port appears to be blocked. I have replace the main router with a stock Netgear 3800 with the same results. I have also disabled the firewall completed via firewall script to see if that is what is blocking it. Any ideas why this port is blocked?
  18. koitsu

    koitsu Network Guru Member

    Assuming this is the Asterisk "VoIP thing", and assuming it's running on the router itself, you should be permitting (not forwarding, but permitting/accepting) the following port numbers for inbound traffic from the WAN:

    * Incoming SIP -- UDP port 5060
    * IAX2 protocol -- UDP port 4569
    * IAX protocol -- UDP port 5036
    * RTP (data/payload) -- UDP ports 10000 to 20000
    * MGCP protocol -- UDP port 2727

    You might not need MGCP or IAX, but the rest are needed. What doesn't make me thrilled is the large range of UDP ports there you have to permit for RTP traffic to flow; unless you can force the port range within the Asterisk RTP configuration to be smaller (and I would strongly recommend that). That's all I can provide. Good luck.
  19. ccbadd

    ccbadd Network Guru Member

    I am using Asterisk 1.8 with Google Voice which uses port 5222. My only sip connections are inside the lan(phone to Asterisk), so I should not have to forward any of those ports. Is this correct?
  20. Toastman

    Toastman Super Moderator Staff Member Member


    I just posted 1.28.0500.5 - these RT-N builds have the fix for memory leak from jyavenard. No other changes.

    Thanks JY
  21. guardian

    guardian Serious Server Member

    Toastman: Could you please add the build with nvram 64k extender for RT-N66? It's now supported thanks to JYAvenard. Have no chance to squeeze my TLS keys into 32kb nvram...
  22. Edrikk

    Edrikk Network Guru Member

    Sorry to bug, but any chance of updating the MIPSR1 builds as well (e.g. WRT54GL, etc)? :)
  23. Morac

    Morac Network Guru Member

  24. though

    though Network Guru Member

    thanks toast. much appreciated!
  25. Morac

    Morac Network Guru Member

    Is there no 1.28.0500.5 for the RT builds?
  26. though

    though Network Guru Member

    pretty sure it's just for the RT-N builds since it uses a different wireless driver.
  27. hOrnizuka

    hOrnizuka Network Guru Member

  28. Morac

    Morac Network Guru Member

    Makes sense. Do the RT-N builds work on the E3000?
    The 4shared site states that RT is for E3000 and RT-N is for E4200, but I think I've seen people say they've ran the RT-N builds on the E3000 and there are E3000 versions under RT-N.
  29. Toastman

    Toastman Super Moderator Staff Member Member

    Both will run on the E3000 but the RT driver appeared to be better for most people, though a few said the opposite. Try them both and see.

    Some routers absolutely NEED the RT-N driver.

    Morac: The IPTraffic fix you mention is already included.
  30. dupondje

    dupondje Serious Server Member

    I use the RT-N version on my E3000 and E2000, and I get better wireless speeds :)
    Try out and see :)
  31. DanielCoffey

    DanielCoffey Networkin' Nut Member

    It is working fine here... plus Toastman has listed mirrors, remember.
  32. pharma

    pharma Network Guru Member

    Thanks. I keep getting html error when I click on the 4 shared link in his signature (worked a few weeks ago). The mediafire link only has files for the RT-N branch for version .0497.1

    4shared error:

  33. Toink

    Toink Network Guru Member

  34. pharma

    pharma Network Guru Member

    Thanks Toink! :)
  35. CredoS

    CredoS Networkin' Nut Member

    I (Asus n16) and thousands of Russian users like your firmware, but unfortunately L2TP protocol can not work on your own and Shubbi firmware, although the official Asus (http://dlcdnet.asus.com/pub/ASUS/wireless/RT-N66U_B1 / GPL_RT_N66U_B1_3003162.zip) and, based on Oleg (http://code.google.com/p/wl500g/source/list) and Merlin (https://github.com/RMerl/asuswrt-merlin/downloads) work fine at speeds up to 100,000 kbps. The mistake is that the speed of a process 30000kBit [kl2tpd / 0] loading the CPU to 100%. After this connection is lost, often losing USB Flash.
    You could not watch or fix it?
    Can help these fixes (http://code.google.com/p/rt-n56u/downloads/list) but this is for N56
  36. guardian

    guardian Serious Server Member

    Let me confirm and second this :) Tomato's L2TP is much slower than with original firmware or merlin's build and starts to take 100% CPU at around 60mbps.

    After that, the latest Toastman's build (500.5) has another L2TP-related problem -- the router which has L2TP connected hangs after saving settings in Basic submenus (power reset required to get it back to operation). Disconnect L2TP - and settings could be saved without problem. This behaviour effectively prohibits remote configuration of L2TP-connected routers. Latest Toastman's, Shibby's, JYAvenard builds have this bug, both 32k-nvram and 64k-nvram-extended. Toastman's 500.2 seems to be free from this bug.
  37. jsmiddleton4

    jsmiddleton4 Network Guru Member

    1.28.0500.5 on my E3000 here. Works great, seems a bit snappier. Was having trouble prior to updating to 1.28.0500.5 with my external USB drive. It was formatted EXT3. After updating to 1.28.0500.5 I moved the drive's files to another location, reformatted as NTFS, restored the files. Works faster than before. And I noticed the more standard naming of the device as sda1. I don't recall seeing that in previous versions. Might have been that way, just don't recall.

    Transfer speeds are faster, no stalling, etc.

    I did want to mention that I thought I had snarfed my E3000 with the 1.28.0500.5 update. Normal m.o. is to do hard reset of the router after firmware update. After updated headed for the router and led's were flashing in the same way I've seen them flash before with a corrupt firmware update. Also not something I recall seeing with previous version. Did hard reset anyway and to my relief router was fine. Was an anxious moment however.

    1.28.0500.5 seems great. Thanks for all the hard work involved and to Toastman for keeping us current.

    Now if I could upload a firmware to my brain to stop its memory leak.........
  38. GameDog

    GameDog Network Guru Member

    I am not sure if this has been reported before (at least I couldn't find it via search), but Internet Explorer 9 seems to corrupt entries made into the "Port Forwarding" table. I noticed this because I added a new entry, clicked on Save and all my other entries were gone. I could repeat this multiple times on IE. I switched to Chrome and it doesn't happen on that browser.

    I have the latest version of the firmware: Tomato Firmware v1.28.7500 MIPSR2Toastman-RT K26 USB VLAN-VPN-NOCAT

    Anybody else see this?
  39. though

    though Network Guru Member

    IE9 worked perfect for me with port forwarding entries. i flashed the lastest 1.28.0500.5 STD on my N66 last night...
  40. thunderforce

    thunderforce Networkin' Nut Member

    Dunno if this has already been answered, but has the ipv6 spurious default-route bug been squashed, yet?
  41. GameDog

    GameDog Network Guru Member

    You're right, its not just that though. I realized that I was doing something different. I was accessing that page on IE9 via an alias. Normally, I login to the router via its address, such as, but that time I had used the dns name I'd setup (router.home.ad). That triggers this particular bug. You can very easily tell because the editable entry starts out at the first row, instead of the last row. Again, this only seems to happen on IE9 and not on Chrome.

    Edit: Attached pix to show what I'm talking about


  42. koitsu

    koitsu Network Guru Member

    Looks like a CSS or Javascript-related bug or may be done intentionally. You would need to compare the HTML output (e.g. View Source) from the router when on Chrome vs. when on IE9, as it's very possible that TomatoUSB pays attention to the User-Agent HTTP header submit by the client (too much server-side software these days does this; proper HTML/XHTML conformance and proper QA on the part of the web developer is required to guarantee compatibility).

    FWIW, I get the same rendered results using Firefox as I do IE8 (cannot go to IE9 because I use XP) -- they look identical to your Chrome output. Behaviour does not change if I visit or http://gw.home.lan/ (latter is what I commonly use).

    The biggest problem is that the Port Forwarding menu source is very heavy in Javascript, so folks who are familiar with JS will probably need to work out what's going on.
  43. kthaddock

    kthaddock Network Guru Member

    Thank you for new build !

    Did you upgrade RADVD and Libdemon as well ?
  44. jyavenard

    jyavenard Network Guru Member

  45. kthaddock

    kthaddock Network Guru Member

  46. gs44

    gs44 Networkin' Nut Member

    Hi Toastman!!
    I flashed my E3000 with newest RT-N build 1.28.0500.5 Just for testing purposes as both my E3000 and E2000 seem to prefer the old stable RT branch for best wireless results...

    IPV6 seems to function well and no issues useing the 6in4 tunnels.. Memory usage does seem to be up 10% over older RT build v1.28.7500.2.. Not sure thats a real issue but I did note it.

    Wired speeds are just as fast as normal and wirless transfer speeds and speed tests seem about the same...

    However The "ping" speeds/times have went up by more than double on wireless tests.. useing RT build v1.28.7500.2 average ping time was at worst 20ms and now with newer RT-N build 1.28.0500.5 I see on average 40-50 ms ping times which could lead to me being killed while gameing online...lol

    I will say that through all my testing and dif versions of Toastman tomato this is the best RT-N version that I have tested and only looses the "ping" test (wireless) when compared to RT versions

    So back to normal RT build v1.28.7500.2 which has the best wireless speed and ping times for me on both my E3000 and E2000.

    Thanks to Toastman and the on going list of contributers that keep this project alive and kicking :)
  47. whatsinaname

    whatsinaname Networkin' Nut Member

    Is there any way to list my settings? (or export/import them) I am running an older version (v1.28.0494 MIPSR2-Toastman-VLAN-RT-N K26 USB VPN) on my e4200v1 and want to update to the newest 1.28.0500.5 build. I know you cant just "flash over the top" I guess I am just lazy and don't want to write down, or take screenshots of all my settings :) Thanks and keep up the excellent work!
  48. whatsinaname

    whatsinaname Networkin' Nut Member

  49. Dr Strangelove

    Dr Strangelove Networkin' Nut Member

    Running newest RT-N build 1.28.0500.5 on my Linksys E4200v1 and haven't noticed any problems.
    I don't have a very complex setup, but would notice if basics indicated problems.
    Still get ~63dBm at 15m in my environment and data throughput is much the same at 52 - 72Mbits to my NAS.

    Thanks to Toastman and those supporting the firmware.
  50. Mangix

    Mangix Networkin' Nut Member

    Open up telnet or ssh and type 'nvram show' without the quotes. Running this from the web interface also works.
  51. mito

    mito LI Guru Member

    @ hOrnizuka, you are ok with that firmware for your RT-N16. For me is running fine.
  52. ArCan

    ArCan Networkin' Nut Member

    Administration > Debugging > Download NVRAM Dump
    you will have nvram.txt file
  53. Beast

    Beast Network Guru Member

    A bit confused of late, maybe my age. Wich is the recommended firmware for an Asus RT-N16 ? The 500 series or the 7500 series...
    I have been using the 7500.4 are the wireless drivers in the 500's newer ?
  54. mikeownage

    mikeownage Networkin' Nut Member

    Toastman, I am running Tomato Firmware v1.28.7500 MIPSR2Toastman-RT K26 USB VPN-NOCAT along with dyncrypt and can't for the life of me figure out why my router is reaching 50% cpu usage. I only have 250 current connections and nothing else really going on any way to see what is using the cpu?
  55. Toastman

    Toastman Super Moderator Staff Member Member

    Beast - I'd use the 7500 build for the RT-N16. The RT-N builds will also work though.

    mikeownage - sounds pretty normal to me ... sirq is probably taking most cpu time, it's quite normal.

    you can telnet to the router and issue the command "top" to see what is happening
    zavar likes this.
  56. Credo

    Credo Addicted to LI Member

    Please look into this firmware fix all the work L2TP
    from the description of the developer: "2. Nuclear patched xl2tpd (at a rate of 30M for simulation load torrents over 90% of the channel loading percent - less than 10%), not flies, with cliffs - automatically restores the connection."
    Xl2tpd package for OpenWRT Backfire, environment - TP-Link 1043nd. Patched for:
    1. Using the module pppol2tp default. Excellent work!
    2. 'Gethostbyname' (cessation of attempts to connect after a count of attempts, if it can not resolve the DNS-name L2TP-server).
    3. Proper handling (transfer pppd) ipparam.
    Patches - standard, current at 10/04/2012, with of.site xl2tpd.
    MD5: 689abc22e9928af17451df9b20dc1033
    Important: Before installing do not forget to correct MD5 in / var / opkg / packages.
    OpenWRT firmware for TP-Link WR-1043ND
  57. mikeownage

    mikeownage Networkin' Nut Member

    Thanks, wasn't sure if that was normal.
  58. pharma

    pharma Network Guru Member

    Flashed tomato-K26USB-NVRAM64K-1.28.0500.5MIPSR2Toastman-RT-N-VPN.trx on a RT-N66U. No issues and excellent signal strength for all wireless clients.
  59. Chad Burks

    Chad Burks Networkin' Nut Member

    Thanks Toastman for all you do...just an observation:
    I have an e3000. It runs well on tomato-E3000USB-NVRAM60K-1.28.0500.5MIPSR2Toastman-RT-N-VPN-NOCAT, but tomato-E3000USB-NVRAM60K-1.28.0500.2MIPSR2Toastman-RT-N-VPN-NOCAT seems to allow for much more throughput. I also have an e4200v1 and its the same. My setup is simple, but my neighbor keeps asking me how I get my wireless signal so strong. He sees my SSID everywhere in his house, but can't find his own even with a range extender. So again I thank you!
  60. kaabob

    kaabob Addicted to LI Member

    +1 on a E4200
    OpenVPN and PPTP working great,

    Solid so far with no hiccups.

    Sent from my HTC Ruby using Tapatalk 2
  61. Solid-State

    Solid-State Network Guru Member

    Hi Toastman!

    Thanks for the fantastic tomatoUSB build and QoS!

    I am currently using tomato-K26USB-1.28.7500.2MIPSR2Toastman-RT-VPN-NOCAT.trx because I can't download the latest 7500.4 build. The download link at 4share doesn't seem to work and it errors out. I have an Asus RT-N16. I have noticed other .4 revisions download no problem.


    Doesn't work for me.
  62. Morac

    Morac Network Guru Member

    I'm using tomato-E3000USB-NVRAM60K-1.28.7500.4MIPSR2Toastman-RT-VPN.bin on my Linksys E3000 and I'm noticing that when downloading from the Internet the CPU usage jumps dramatically. It seems to range in the 30 to 60% range, but I've seen it spike to 95% during a speed test which doesn't seem right. Yet streaming video on my LAN over WiFi doesn't go about 10%.

    There's something about going from WAN to LAN. I have QoS and B/W Limiter off.
    I don't remember having this problem on the last build I used which was tomato-E3000USB-NVRAM60K-1.28.7498.1MIPSR2-Toastman-RT-VPN.bin.

    Any idea what's going on here?


    I logged into my router and did a "top" and during a download speed test there were two processes using 30% CPU each:

    2661 2653 root S 764 1% 32% /usr/sbin/bcrelay -i ppp[4-9].* -o br0
    2655 2653 root S 764 1% 30% /usr/sbin/bcrelay -i br0 -o ppp[4-9].*

    It looks like the VPN processing is doing this, which makes no sense since I'm not using the VPN at the moment.

    Edit 2:

    I disabled the PPTP server, but the status page still listed the CPU usage as 60%, despite "top" now showing no process using more than 1% of the cpu. I'm very confused.

    I will say that the bcrelay shouldn't be using any CPU if there are no PPTP clients connected.

    Edit 3:

    I re-enabled PPTP server, but disable broadcast relay. That prevents bcrelay from running so it doesn't use CPU. What's weird is I'm still see the CPU percentage spike on the overlay page, despite the fact that top shows no processing running with high CPU and the CPU load only goes up to about 0.08.

    I have a 50 Mbps down, 10 Mpbs up connection.
  63. Eddie55

    Eddie55 Serious Server Member

    Recently bought a RT-16 and would like to know what is the MOST stable build for Toastman
    I dont care about the latest and greatest i just want the MOST stable please
    Thanks in advance
  64. kthaddock

    kthaddock Network Guru Member

  65. mvsgeek

    mvsgeek Addicted to LI Member

    If you need WDS but no USB, I heartily recommend tomato-K26-1.28.7483.2MIPSR2-Toastman-RT-Std.trx. 217 days without an unscheduled reboot.
  66. Morac

    Morac Network Guru Member

    Has anyone who has an iOS device running iOS 6 had an issue where the Wifi connection remains up, but tcp/ip and UDP packets start dropping periodically?

    With my Linksys E3000 running the latest Toastman RT load, I've had this happen twice: once on my iPhone 4S and once on my iPad 2, but not at the same time. Rebooting the iOS device fixes this. So far I've only seen it at home, that could be coincidence since it has only been 3 days since I upgraded. Prior to that I had been running iOS 5.1.1 with the latest Toastman RT for about 2 weeks with no issue.
  67. jpe30

    jpe30 Networkin' Nut Member

    Do the RT-N firmwares not include support for NTFS USB drives? I just went from the latest Toastman RT build to the latest RT-N, and now my external HDD won't mount. Any ideas?
  68. kthaddock

    kthaddock Network Guru Member

    Did you do a NVRAM resett before and after build update? Don't use backup config file, reconfig by hand.
    RT-N 0500.5 include support for NTFS USB drives
  69. Bill_S

    Bill_S Network Guru Member

    Can anyone tell me why I can't set the WAN port to 1000Mb on my ASUS RT-N16? The only options are 10 and 100Mb full and half duplex and Auto. My cable modem has a 1000Mb port and I have a Cat6 cable running from the router to modems 1000Mb port but I still don't see 1000Mb in the listing in Advanced - Miscellaneous - WAN Port Speed.
    I am running Tomato Firmware v1.28.7500 MIPSR2Toastman-RT K26 USB Ext.
  70. shibby20

    shibby20 Network Guru Member

    this option does not works on RT-N16.
  71. Bill_S

    Bill_S Network Guru Member

    Does that mean I won't get 1000Mb only 100Mb using Toastman? Asus says the port is a 1000Mb port.
  72. lefty

    lefty Networkin' Nut Member

    If the feature doesn't work for the RT-N16, i would assume that it would then only be able to do 100 instead of 1000, which unless your cable ISP is faster than 100, it shouldn't matter.
  73. Bill_S

    Bill_S Network Guru Member

    Ok, but is this a limitation based on the Toastman firmware or the Asus hardware? If I want 1000Mb do I need to use another firmware like DD-WRT?
  74. lefty

    lefty Networkin' Nut Member

    Its not a limitation of the hardware as in everything i have ever read about the RT-N16 has noted that it has all 10-100-1000 ports (WAN included). And i'm not 100% sure if its a limitation of the toastman tomato builds (thats something toastman or shibby would have to clarify as i am no build maker, just a mere power user), as i do not even use my RT-N16 anymore to be able to tell you, it sits in a closet now because i found that there are many other units that outperform it for my needs. So its been quite a while since i have even used it.

    Also, i only recommend dd-wrt to people for certain things, in general i prefer tomato better, it seems to work better for me than dd-wrt does, atleast the features part of it does, the QoS and USB works properly in tomato, can't say the same for dd-wrt. I mean you could try dd-wrt but i am unsure if it would be your answer for the WAN port being 1000.
  75. Toastman

    Toastman Super Moderator Staff Member Member

    RT-N16 ports work at 1000 by auto-negotiation with whatever is plugged into it. There are reasons why there is no capability to "force" the speed to 1000, which have been discussed many times on the forum. It's rather a dangerous thing to do if the auto-negotiation fails. 1000 is rather a special case - google for further information.

    I can confirm that all firmwares from the different modders do successfully negotiate 1000. If yours doesn't - suspect faulty cable, patch lead meant only for 100Mbps, or the device plugged into it.
  76. jpe30

    jpe30 Networkin' Nut Member

    Yea, just reflashed with an NVRAM clear and still got the same thing. Here is what I'm seeing on my USB support page:

  77. jakey

    jakey Networkin' Nut Member

    1000 Mbps is not manually selectable on my RT-N66 either but if I check my cable modem status page it shows they are actually connected at 1000 Mbps with setting at auto..
  78. kthaddock

    kthaddock Network Guru Member

    Strange, your NTFS square is missing but it should be there in 0500.5 build.
    Are you shure you don't use your backup file to restore ? ;)
    I can se your drive is formatted as ntfs file system. What router do you use ?
    Have you tried to clear your browser cash and cookies ?

    What is output of this commands:
  79. jpe30

    jpe30 Networkin' Nut Member

    Just cleared my cache n' cookies, but that didn't change anything. I just reflashed and didn't use a backup file to restore.

    The router is an Asus RT-N16.
  80. Bill_S

    Bill_S Network Guru Member

    Understood and thanks.
  81. kthaddock

    kthaddock Network Guru Member

    Okey, just to be shure, are you using in configuration => Restore Default Configuration=> "Erase all data in NVRAM memmory (thouogh" drop down meny to erase NVRAM ?

    What is output of this commands:
    Put in Execute System Commands box
  82. Toastman

    Toastman Super Moderator Staff Member Member

    scarey and others: It took me less than a minute to create a 4shared account with a false email address, and then less than a minute to download a file.

    Please remember, you only have to do this once. I have to upload many hundreds of files regularly, and 4 shared is the only free worldwide server that I have found that allows me to do that with minimum hassle and without jumping though hoops, with 16GB of disk space and an easy to use bulk uploader. And no, guys, thanks for the offers of hosting on your sites, but I am not interested in using another server at this time.

    Thanks to the 130,000+ people who have managed somehow to download files without complaining about it.

    Good luck.
  83. Solid-State

    Solid-State Network Guru Member

    Hi Toastman,

    I am currently using tomato-K26USB-1.28.7500.2MIPSR2Toastman-RT-VPN-NOCAT.trx because I can't download the latest 7500.4 build. The download link at 4share doesn't seem to work and it errors out. I have an Asus RT-N16. I have noticed other .4 revisions download no problem.


    Doesn't work for me.
  84. koitsu

    koitsu Network Guru Member

    That's because there isn't a generic (e.g. for RT-N16 which doesn't have 60K of NVRAM) 7500.4 build that's for RT-VPN-NOCAT. There is one for RT-VPN but not RT-VPN-NOCAT. Screenshot showing that fact is below.

    The RT-N build directory does have what you're effectively looking for though.

    Attached Files:

  85. jpe30

    jpe30 Networkin' Nut Member

    The first line doesn't output anything, and the second line outputs this:

    nvram set usb_ntfs_opt=""
    That mean anything?
  86. Lorenceo

    Lorenceo Networkin' Nut Member

    Still having problems with radvd crashing, causing IPv6 connectivity to disappear.
    Can't set the radvd MTU through the GUI. Have to do it with a custom config on a flash drive, and that process doesn't stay running for long (~40 hours).
  87. kthaddock

    kthaddock Network Guru Member

    Okey, NTFS doen't seem to be in there. Do you erase NVRAM like this:?
    Then I don't have any more suggestions.
  88. koitsu

    koitsu Network Guru Member

    I have a suggestion: run a firmware/build that has NTFS support! The lack of NTFS support is clearly evident in the very first screenshot he provided, and that his WD15EARS model disk is using NTFS: http://www.linksysinfo.org/index.php?threads/toastman-releases.36106/page-13#post-192988

    Only ext2/ext3, FAT/FAT32, HFS, and HFS+ are shown. The "missing square" (missing checkbox), combined with the mount failure, is pretty damning evidence that there isn't NTFS support. So why is it a surprise that he can't mount an NTFS filesystem? I don't get it.

    Furthermore, the OP didn't list off what exact firmware he's using. Don't tell me "the latest", don't tell me "0500.5", provide the full filename of the firmware/build. Without that everyone is just grasping at straws.

    Attached is a screenshot of my RT-N16 running tomato-K26USB-1.28.0500.5MIPSR2Toastman-RT-N-Ext.trx. You can clearly see the NTFS checkbox.

    I don't think there's anything else for me to say. The user is running a firmware/build that lacks NTFS support. Period.

    Attached Files:

  89. kthaddock

    kthaddock Network Guru Member

    This builds include NTFS support:
  90. bripab007

    bripab007 Network Guru Member

    Hmm, ya know, I'll have to look into this. I recently thought my 2.4GHz radio on my E3000 was going out, as I was unable to connect with iOS devices, so I put up a different 2.4GHz AP to temporarily resolve it.

    How were you determining it was dropped connections and not radio problems?
  91. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I'm back to the old standby 7483.2. Even though I'm not doing WDS any more, wired whole house some time ago, I find it is the most stable version. Tried several of the new ones, the RT-N ones, etc., and had intermittent wireless connection issues, momentary lags, etc. Not sure if its CPU usage, memory leaks, or what. Just that the newer versions for me on the E3000 are not consistently stable.

    7483.2 always is rock solid.

    I don't need all the fancy graphs, QOS, etc. Just need stable.
  92. gs44

    gs44 Networkin' Nut Member

    I agree with you that 7483.2 is Rock solid and I ran it for a long amount of time, uprgadeing to newer versions only to switch back until E3000USB-NVRAM60K-1.28.7500.2MIPSR2Toastman-RT-Ext.bin came along.. It runs By far the best for wired and Wireless connections for me on my E3000 and E2000 I suggest you try it if you haven't already
  93. mito

    mito LI Guru Member

    Not always the firm is unstable, If you have Intel wifi cards take a look a it once in a while, they often go to sleep and reboots itself and then seems the firm failed.
  94. jsmiddleton4

    jsmiddleton4 Network Guru Member

    "I suggest you try it if you haven't already"

    It is indeed quite stable. Working very well!
  95. zavar

    zavar Networkin' Nut Member

    So for an RT-N16, the recommended build is 7500.2? Are there issues with 7500.4?

    Anyone know what the "shared folder" symbol on the 4shared directories mean? (ie the 7500.2 build shows the shared symbol, the 7500.4 doesn't).
  96. koitsu

    koitsu Network Guru Member

    For the Asus RT-N16 using classic wifi drivers, a.k.a. Toastman RT builds, 7500.4 is (AFAIK) what should be used as of this writing. Without full technical/verbose details from people about problems they might be having with 7500.4, there's really no way to ascertain or troubleshoot such problems. I don't have familiarity with the RT builds because I run RT-N (keep reading).

    For the Asus RT-N16 using newer ("new technology") wifi drivers, a.k.a. Toastman RT-N builds, 0500.5 is what should be used as of this writing. Do not use 0500.4 (it was removed from Toastman's site anyway), as it contained numerous memory leak bugs which have since been fixed.

    Some people get better throughput and overall stability using the RT builds rather than the RT-N builds, while others find the opposite. YMMV.
    zavar likes this.
  97. Elfew

    Elfew Addicted to LI Member

    Please tell me - I have noticed better transfer speeds over wifi wirh Shibby build. Is it related to tweaked driver in Shibby builds? I have asus rt-16n...

  98. lefty

    lefty Networkin' Nut Member

    @ Elfew there is no 'tweaked' driver, broadcom drivers are fixed binaries with closed source.. the code you can build around these fixed binaries can differ, and most times does, but the driver doesn't change nor will it unless broadcom changes it..

    @ Toastman if not much to ask, please add E1550 support to your next build so i can test tomato toastman builds on this unit. Thanks!
    Elfew likes this.
  99. zavar

    zavar Networkin' Nut Member

    Thanks Koitsu, much appreciated!
    koitsu and (deleted member) like this.
  100. pektong

    pektong Networkin' Nut Member

    Good Day Toastman! Do you support RT-n12 c1 router? I cannot find links saying that you support this router thanks!

Share This Page