1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

** Tomato Toastman's Releases **

Discussion in 'Tomato Firmware' started by Toastman, Dec 18, 2011.

  1. leandroong

    leandroong Addicted to LI Member

    Good Day Toastman! Do you support RT-n12 c1 router? I cannot find links saying that you support this router thanks! 
    Yes, it does on Shibby build, look here, http://tomato.groov.pl/?page_id=69
  2. Dutch87

    Dutch87 Serious Server Member

    Well, after a long time of stability, the following resulted in a crash of the tomato webinterface with tomato-K26USB-1.28.7500.4MIPSR2Toastman-RT-VPN on my Asus RT-N16.
    So the internet and network was still working but the page was only visible after a hard reboot.

    I use a https interface with a certificate using aes256 encryption on a custom port to view the web interface of the router. http is disabled.
    After adding an MAC adress to the following the bug resulted

    1. DHCP
    2. Acces restriction on allowd devices for internet
    3. Wireless MAC filter

    After saving the Wireless MAC filter it happened. This bug i reproduced 2 more times.
    Deleting an MAC does not result in this crash.

    In tomato-K26USB-1.28.7486MIPSR2-Toastman-RT-VPN-NOCAT I did not have this problem.

    Maybe this info helps ;)
  3. pektong

    pektong Networkin' Nut Member

  4. Toastman

    Toastman Super Moderator Staff Member Member

    pektong - As far as I know the C1 is identical to the B1, so it is already supported. Looks pretty much like the only difference is the plastic housing, anyone?
    pektong likes this.
  5. Lorenceo

    Lorenceo Networkin' Nut Member

    I've just come across a problem, in addition to radvd crashing on my RT-N16.

    This seems to affect both v1.28.7500 MIPSR2Toastman-RT K26 USB VLAN Ext and v1.28.7500 MIPSR2Toastman-RT K26 USB Ext.
    When connecting with PPPoE set to a tagged VLAN, whenever data is passing both downstream and upstream at the same time, the connection slows to a crawl, with very high pings.

    I've put up with the symptoms for a while now, assuming it was my modem being overloaded. Today however while downloading through HTTP with 16 threads, and uploading through FTP with a single thread, the router's bandwidth page was less responsive than usual.
    I tried pinging the router, and found that it had gone form the usual <1ms to between 200 and 1000ms.
    CPU and ram usage were both normal, the router was just not particularly responsive, and all traffic to and through it was suffering from a vast ping increase.

    I tried testing between two computers directly, uploading and downloading at the same time, but in DHCP mode. In this configuration it ran fine, with no slowdowns or vast ping increases, so I do not believe it to be a hardware fault.

    Hopefully this can be looked into and resolved, can provide more details/perform more tests if required.
  6. lefty

    lefty Networkin' Nut Member

    @ Toastman - sent you a little something to show thanks for the builds, i know its not much, but i will send more as time permits, please keep up the great work. Thank you!
  7. Toastman

    Toastman Super Moderator Staff Member Member

    Appeciated! Thank you!
  8. pektong

    pektong Networkin' Nut Member

    Thanks toastman I've flash your build on rt-n12 c1 and it's working fine up until now..
  9. lefty

    lefty Networkin' Nut Member

    Anyway you could provide more info in which this could possibly be further looked into? saying its working fine until now doesn't give much of a clue about what your problems with it are...
    koitsu likes this.
  10. LanceMoreland

    LanceMoreland Network Guru Member

    I am not noticing IPv6 connectivity issues, which doesn't mean it is not happening but I am seeing this occasionally in the logs:

    Oct 4 14:06:13 Tomato-1 daemon.warn radvd[4548]: Exiting, sigterm or sigint received.
    Oct 4 14:06:13 Tomato-1 daemon.info radvd[4906]: version 1.8.1 started
  11. stefanct

    stefanct Serious Server Member

    i have set up dnsmasq to serve tftp to be able to boot via pxe. this works great for e.g. memtest86+. now i would like to do the same with different bigger stuff like sysrescuecd or linux live cds. i know that this is possible on normal PCs, but on tomatousb my problem is the missing isofs.ko kernel module. i am not able to loop mount the .iso files (which are stored on an usb stick). on other firmwares there are kernel module archives for ipkg/opkg, but these do not exist for tomatousb afaics? Toastman: could you please include it in the builds? or is there another way (other than (cross)compiling it myself?
  12. koitsu

    koitsu Network Guru Member

    SIGTERM or SIGINT means something on the system **intentionally** restarted radvd. I imagine this happens if you go into the router GUI and make certain changes (clicking "Save", etc.). Many services/daemons get restarted in this situation. The log messages shown aren't indicative of a daemon crash (there would be no log entries if that were the case).

    No offence intended (honest! Just providing this to help show that other people make the same mistake), but here are some other examples of people who when experiencing some problem start digging through logs / pasting stuff that isn't relevant to the problem. And that's for Asus's stock firmware too.

    I think once users who aren't familiar with the underlying daemons/services and what is considered "normal" (meaning what happens under normal operation / internal to the router code itself), they start getting OCD over things. :(
  13. lefty

    lefty Networkin' Nut Member

    So which is it? in the post i replied to you are saying this:

    "Thanks toastman I've flash your build on rt-n12 c1 and it's working fine up until now.."

    And now you are saying what you did above? Its sorta contradictory that now you are saying you flashed shibby build, but previous you flashed toastman build, and now you are asking if there is a toastman build? If you already flashed the toastman build, which according to the post i quoted and replied to, you did, then you would know your answer already... you may want to back up and think about what you are doing and what you posting here and get your 'story' straight, because so far its nothing but confusing.
  14. pektong

    pektong Networkin' Nut Member

    Okay, I flashed my less than a week old rt-n12c1 to a Shibby build. What I want is a build that Toastman made that's why I'm asking if toastman has support on this router. Since Toastman said that b1 and c1 are just the same (hardware), I can flash on one of the build that he has. The problem is that there are so many versions and I don't know the version that is compatible on my router. I posted here to thank Toastman for his answer OK?

    Does my post a big deal on you?
  15. lefty

    lefty Networkin' Nut Member

    OK, sure i think i get it now, you are waiting for a personalized answer from toastman, sorry i wasted my time to inquire on trying to help you, i won't ever do that again..
  16. pektong

    pektong Networkin' Nut Member

    I'm sorry also if I misunderstood you. Your post is somewhat rude on my part. Also, I'm sorry if my english is not that good..
    Toxic likes this.
  17. dc361

    dc361 LI Guru Member

    English is not the first (or second...) language of a number of people who post. Sometime we forget that. Glad to hear that the toastman build is working well so far.
    mito and mvsgeek like this.
  18. MaX PL

    MaX PL Networkin' Nut Member

    is there any work being done with tomato on the AC routers? i may update to one but only once tomato support is available
  19. DJarvis1

    DJarvis1 Networkin' Nut Member

    Hi. I've currently got a e2000 router & i think it gas the 1.28 version of tomato from the polarcloud website.
    I wanna setup some Q.O.S. & didnt know if that is the latest fw avaliable?

    Whats the latest stable release for the e2000 ? Also in Toastmans QOS thread he mention he has classes that can be renamed etc.... Is that normal now ?


    Sent from my Galaxy S II using tapatalk
  20. Toastman

    Toastman Super Moderator Staff Member Member

    The version you are using is quite old now, I would recommend you change to 1.28.7500.4, look for builds with E2000 in the title. Be aware that my builds disable DHCP by default, so set a fixed IP address on your PC before you flash or you won't be able to access the router afterwards. If you need DHCP remember to enable it in the GUI.

    Make sure you erase NVRAM and reconfigure the router after you flash new firmware. This is easier using this method:


    The QOS in Toastman builds has the ability to name the QOS classes for a long time. Also, the incoming side of the QOS system has also changed, it now is a proper IMQ based ingress system and is a vast improvement over that which you are using.
    DJarvis1 likes this.
  21. DJarvis1

    DJarvis1 Networkin' Nut Member

    Ok, cheers cheers I've just been reading through the 1st page of ur Q. O. S thread.... I've read the 1st page.... I've gotta make a note of all my static I. P s /port-forwards etc I got set up @ the moment..... I've got a small handful of things to juggle around..

    Couple of ps3s, home server (media-server), htpcs, a few desktops & other mobile stuff...

    Sent from my Galaxy S II using tapatalk
  22. pmd

    pmd Networkin' Nut Member

    You don't say exactly how you're connected via IPv6, but that behaviour is normal if you're using Prefix Delegation. radvd is intentionally restarted to get it to read any changes that may have been written to its config file by the periodic refresh of your IPv6 prefix value (which comes from your ISP). I think it's restarted even if there's no actual change in the value as it's simpler to do that.
  23. kradflyer

    kradflyer Serious Server Member

    Hi toastman,
    i want to ask something about tomato that i use
    i used tomato-K26USB-1.28.0500.5MIPSR2Toastman-RT-N-VPN-NOCAT.trx with ASUS RT-N16

    i have problem about bandwith limiter.
    i used PPPOE as WAN Connection
    i have 1 access restriction rules that only allow certain IP than can use internet.

    my speed internet is 8Mbps (DL) and 3Mbps (UL)
    the problem starts here
    when i try to set the Max Download Bandwith more than 2500 kbit/s,my router just restart.
    after it restarted, wait for the pppoe to connect again..after pppoe connected, the router just restart again.
    same happen if i set 2 rules in bandwith limiter
    Max Download Bandwith 2500 kbits
    MaX Upload Bandwith 2000 kbits

    IP :
    DLrate : 1200kbps
    DLCeil : 1200kbps
    ULRate : 512kbps
    ULCeil : 512kbps
    Priority : Normal
    TCP Limit : nolimit
    UDP Limit : nolimit
    (this one works fine, and i try to add one more IP)

    IP :
    DLrate : 1200kbps
    DLCeil : 1200kbps
    ULRate : 512kbps
    ULCeil : 512kbps
    Priority : Normal
    TCP Limit : nolimit
    UDP Limit : nolimit

    after i add 2nd IP. the router just restart again.
    same thing when i set the max download bandwith .
    please help me with this problem. thank you

    ps: i only enable the limiter. not enable the QoS
  24. DJarvis1

    DJarvis1 Networkin' Nut Member

    Hi I been sear hing through the tread you linked & is looking for 1.28.7500.4 I think its the 1 in post 1167, but not sure if that for the e2000?.... Tries looking on the 4shared site. I could t seem to find that version for the e2000...

    Sent from my Galaxy S II using tapatalk
  25. DJarvis1

    DJarvis1 Networkin' Nut Member

    Cheers m8, OK assuming ext means extras.. What are those extras?. Also nocat?

    Also I've got another router upstairs (just used as a wifi range-extender)
    LINKSYS Wrt 54GL V1.1

    What's the latest version of for that router, if even there is a Toastman build for it....?


    Sent from my Galaxy S II using tapatalk
  26. romanz

    romanz Networkin' Nut Member

    Hello Toastman. Does the Linksys EA4500 has still no support and it's still impossible to flash it with your firmware? :(
  27. DJarvis1

    DJarvis1 Networkin' Nut Member

    hi, have looking around for latest (stable) version for WRT54GL v1.1 without any luck, ??
  28. spike095

    spike095 Serious Server Member

    Wondering if anyone's seen this issue before:

    Connected to Cable Modem: RT-N16 [1.28.7500 RT K26 USB Std]
    Wireless Ethernet Bridge: RT-N12B1 [1.28.0500.5 RT-N K26 Tiny]
    NVRAM was reset on upgrade and settings manually configured afterwards.
    Wireless is running in AUTO, WPA2+AES security -- 40MHz width, Channel 1 (least crowded according to InSSIDer).

    Wireless stats on the bridge are roughly hovering around:
    RSSI -47 dBm
    Noise -82 dBm (yes, the noise is fairly high)
    Signal Quality 35

    Every once in a while, the wireless rate (normally hovering around 270mbps to 300mbps) on my RT-N16 will drop down to 11mbps and just get stuck there. Going to Basic->Save or doing a disable/enable of wireless will pop the rate right back up to normal. I've tried with smaller width (20MHz), different channel (11), WDS instead of Bridge mode, and turning Interference Mitigation on/off, but this happens pretty regularly (about once a night) and seemingly at random (I don't notice it until my game pings start skyrocketing and downloads slow to a crawl). Anybody know why this type of behavior would occur?
  29. Toink

    Toink Network Guru Member

    Read Versions HERE

    For your WRT54GL the latest Toastman Build is 1.28.7633.3

    DJarvis1 likes this.
  30. lissny

    lissny Networkin' Nut Member

    any body there plz help me..
    I have created login system for Captive portal...
    it contains files..
    1-Cap-Port-users.asp (To. add, remove, edit, user- Accounts) (destinition: /root/www/)
    2-Cap-Port-Log.asp ( To view each login from user.. either successful OR unsuccssful) (destinition: /root/www/)
    3-Cap-Port-Splas.asp(user login page ) (destinition: /root/www/)
    4- user-records.txt (contain-- user login DB - encrypted text) (destinition: /root/tmp/)
    5- user-logs.txt (contain-- users Each login attempt) (destinition: /root/tmp/)

    user login page requests for.. user name and Pasword..and Captures PC-name, PC-User Name, MAC using Java script.
    and finally 5 things.. username password PC-Name and PC-Mac will be cheked with DataBase txt file.

    Problem is I can not put .asp files in "/root/www/" It says .. Error "Read only file system" for direcotry
    i have user putty and WinScp.... with root:admin but it gives erro above.
    plz help me.​
  31. lefty

    lefty Networkin' Nut Member

    last i knew, you had to have either JFFS space, or USB storage or some other means of storage in order to use captive portal, otherwise, everytime your router reboots, it'll erase the files.
    koitsu likes this.
  32. Monk E. Boy

    Monk E. Boy Network Guru Member

    Lefty is correct, even if the filesystem is writeable, if it's not in /jffs/ or USB storage (typically mounted in /tmp/mnt/sda1/, /tmp/mnt/sdb1/, or /tmp/mnt/volumenamegoeshere/) then the filesystem is going to either be read-only or temporary, in that when the router is rebooted it will get erased. There is a third option, which is to use SMB/CIFS storage, which mounts a directory on the router to a share on a PC on your network.

    Personally I like using SMB/CIFS for file transfers but don't like to rely on them actually being there for normal operation because any number of things can happen to a PC. I try to make routers as self-contained as possible. Maybe if I get to the point where I can have the share on a server that's relatively locked down then I'll trust it a bit more.
  33. Monk E. Boy

    Monk E. Boy Network Guru Member

    I know this is just a pointless quibble Toastman, but could you do anything about Administration -> Scripts -> Firewall? It looks like a Windows-to-Unix (or vice versa) translation where <CR>s exist when it expects <LF>s so the everything ends up on a single line.

    A long, long time ago, in a Tomato far away, they were separate lines.
  34. blackwind

    blackwind Serious Server Member

    I'm experiencing the following issue with v1.28.7497:

    When I make a Google Voice call, I can hear the other side clearly, but I'm receiving complaints that my voice is very, very choppy, to the point where I can't be understood. When I disable QoS, this no longer occurs. Prioritizing GV traffic (UDP 19295-19305) doesn't help, even when classified as "Service" and moved to the top of my rules list. "View Details" confirms that the rule in question is, indeed, functioning. Switching to pfifo had no effect.

    Is there anything I can do to resolve this short of disabling QoS for good?
  35. koitsu

    koitsu Network Guru Member

    I've been wondering about this myself. The NVRAM variable which stores the Firewall script is called "script_fire".

    You can see if you look at present-day Toastman code, script_fire is empty:


    However what's very, VERY confusing is if you use the search feature there to grep for the string script_fire for release 1.28.0500.5, guess what you find?


    Look at the entry referring to line 787, which refers to release/src/router/nvram/defaults.c. That clearly shows the commented-out rules/text in question.

    Yet if you click on the source file, script_fire is empty. And there appears to be no way to tell the web interface "show me all commits that affected this file". (This is something cvsweb has had since, oh, its original creation...)

    Crap like this is why I hate git, or at least the "web interfaces" for git. I don't know what to believe, and I sure as hell aren't going to install git on my FreeBSD machine (too many dependencies on other software) to find out the truth.

    EDIT: Ah ha, I see what the problem is. Yes, it's a problem with the web interface to git (IMO). The problem is that when doing a grep/search within a specific tag/branch, it searches only that tag/branch (which is correct), HOWEVER, the resulting link to the file **does not** contain the necessary tag/branch HTTP GET argument, so it ends up looking at HEAD. Note the URL does not contain anything like "h=refs/tags/Toastman..." in it:


    Meaning, from what I can tell, the problem has been fixed sometime after 1.28.0500.5 -- the fix being that they chose to empty the script_fire variable. I don't know of a way using the web interface to git to say "show me all commits that affect release/src/router/nvram/defaults.c, across all tags". Like I said -- cvsweb has had this since its creation. Git, sigh...

    Those of us who have this problem should simply delete the lines in Script -> Firewall and save. However, it'll come back again if we do an NVRAM reset, at least with 1.28.0500.5 (and possibly earlier).
  36. Monk E. Boy

    Monk E. Boy Network Guru Member

    Thanks. I suppose I shouldn't care all that much, since I can copy configs from existing routers, but I liked those default iptables per-connection rules.

    Maybe next Friday I'll have some free time to back up all the relevant info - I have an export config shell script, that exports all nvram variables to a text file on the USB device, but that does me no good if the router itself wanders off. Up on the whiteboard you go...

    I'm still on the RT branch for all my hardware, so no 7500.5 for me.
  37. goliath5

    goliath5 Serious Server Member

    Hello Toastman,

    I´m looking for a way to start pptp client on router startup. In my setup, WAN is not connected. I also tried to
    check "use wan port for lan" but it doesn't start pptpclient after reboot.

    Could you please tell me a way to start the pptp client in the script section?

    Thanks in advance!
  38. goliath5

    goliath5 Serious Server Member

    Maybe I´ve found a solution.
    I added "service pptpclient start" to the init script section.
  39. USNetboy

    USNetboy Networkin' Nut Member

    Incorrect. You are looking at the first commit of script_fire in late 2008. The present-day Toastman code (Branch RT-N, HEAD) is here:
    and as you can see in line 787 it is completely populated.

    Yes there is: Click on the link above, at the top of the page, click on "history". You will get a list of all the commits that touched defaults.c. You can now click on each "commitdiff" to see the actual change.

    It is unfortunate that you hold such resentment to git. It is the de-facto version control system these days and is considered by many coders to be superior to any of its counterparts. As much as GitWeb is capable, the git command line tool is where git really shines! Just as a quick demo, the following little magic will print the total change history of the script_fire line in defaults.c across all commits in the Toastman RT-N branch (there is no meaning for searching "across all tags" as tags are just labels within the branch):

    git log --reverse -G script_fire --oneline --pretty="%h %cd %s" --date=short defaults.c |
    while read a b; do echo "*****" $a $b; git show $a | grep '{ "script_fire' | cut -c -50; done
    Which results in:
    ***** d219bcc 2008-12-01 Tomato 1.21
    +{ "script_fire",V_TEXT(0, 8192)},
    +{ "script_fire",""},
    ***** 7d22983 2011-02-22 changed some defaults, limiter cosmetics, about page
    -{ "script_fire",""},
    +{ "script_fire"," Restrict number of TCP conne
    ***** ee28dee 2011-04-09 changed some nvram defaults
    -{ "script_fire"," Restrict number of TCP conne
    +{ "script_fire","#Restrict number of TCP conne
    So, to get back to our script_fire discussion, as you can see above, it was introduced in the initial Tomato 1.21 commit on December 2008 and was an empty NVRAM option. on February 2011 the empty option was populated but the submitter forgot the "#" at the beginning of the line. This was corrected on April 2011 and was never changed since then. Why was this posted as a single line, I'm not sure.
  40. koitsu

    koitsu Network Guru Member

    Thank you for the link and description of how to use the web interface to git there -- that is exactly what I was looking for. Can you explain to me how via the GUI you managed to find this link?


    If I go to:


    I find absolutely no link that takes me to /blob/refs/heads/... of any kind.

    Instead, if I go to that link and I navigate as follows:

    * "Heads" section, clicking "Tree" on Toastman-RT-N
    * Navigating to release/src/router/nvram
    * Clicking "blob" on defaults.c

    ...I'm taken to this URL:


    Which isn't the same. So I'm trying to figure out how you managed to find that URL you gave me?

    And whether or not git is the "de-factor VCS today" is purely opinion. For example, all of FreeBSD has used CVS up until last year (switching to Subversion for committers working on source; ports were still CVS), and this year has begin the final stages of removing the public-facing CVS bits forcing people to go to Subversion (for ports and src). There was a very long (almost a year long) extensive test of VCS systems all simultaneously in place (cvs, svn, p4, and git -- yes all simultaneous!) to try and find what the developers found to be most reliable and most effective, and they went with Subversion. I also had a co-lo customer of mine who used svn solely for all of their web and underlying platform code (Linux-based). So I think quite honestly it just varies.

    From an end-user perspective, you have to understand, this is what I'm used to (for getting full commit history/explanation):


    And a more concise/awesome interface for "following commits":


    So yes, I'm biased because this is what I've been used to for the past 15 years. That's the bottom line -- it's pure bias on my part.
  41. USNetboy

    USNetboy Networkin' Nut Member

    * "Heads" section, clicking on Toastman-RT-N
    * Click on "tree" at the top of the page
    * Navigating to release/src/router/nvram
    * Clicking "blob" on defaults.c

    Though the URL is different, both will land you on the same commit (8aa0bf0e - just click on the "Fix 6in4 memory leak").

    I agree that "the best VCS" is a highly subjective topic and apologize if I came through as a missionary. I've been using a variety of them through the years and two years ago started working on Android (and obviously git) and thought I "saw the light".
    koitsu likes this.
  42. blackwind

    blackwind Serious Server Member

    Because my post was approved (I'm a new member) after several others followed it, I figured I'd repost so it doesn't get lost in the shuffle (as it apparently has):
  43. Monk E. Boy

    Monk E. Boy Network Guru Member

    This is pure conjecture on my part, but bringing the file over to an OS where EOL is implemented as <CR> and then uploading it to a Linux-based project, where EOL is <LF>, would introduce this behavior. Since Windows uses <CR><LF> as EOL my initial suggestion in this thread would be false, because it'd just have an extra <CR> padding before EOL. Classic MacOS used <CR> for EOL, but no way anyone's going to be editing uploading code from OS9 to git in 2011. It's a riddle.
  44. koitsu

    koitsu Network Guru Member

    It looks to me like it wasn't an issue of CR+LF vs. CR. If you look at the other examples in the source, you can see that there are some which are multi-line and explicitly contain \n (not literal newlines, but the printf()-esque \n). So whoever added the examples for script_fire probably didn't think about it before committing. Human mistake/error is the most likely here. :)
  45. Toastman

    Toastman Super Moderator Staff Member Member

    If you are talking about the examples in my builds to limit numbers of connections, I seem to recall that I entered them into the text box and saved them. At that time they were all on seperate lines.

    After that I probably listed the nvram variables and just copied what I saw into defaults.c by cut and paste.

    However, I don't remember now. But the formatting was lost somewhere. It's probably as Koitsu says, human error.
  46. Monk E. Boy

    Monk E. Boy Network Guru Member

    Cool beans, its really no big deal and I didn't mean to turn it into a real discussion. But on the plus side koitsu got some good info on using git! So we got that going for us, which is nice...
    koitsu likes this.
  47. lancethepants

    lancethepants Network Guru Member

    Hey Toastman, dying to run your build on my e1550's with tlvz's fix when you get a free moment.
  48. Toastman

    Toastman Super Moderator Staff Member Member

    I'll try to do it soon ... rather busy at the moment ..
  49. Arghtastic

    Arghtastic Networkin' Nut Member

    Okay Gang, I am now very confused. I am upgrading to a Netgear 3500L (v1 it appears) from a LinkSys WRT54GL and I see there's a NVRAM60K version now. Does that work for the WRN3500L v1? I can't find anyway to figure out how much NVRAM I have with the stock firmware.

    I intend to continue using the WRT54GL (two of them actually) as an extra access point(s.) Can someone clarify for me?
  50. lefty

    lefty Networkin' Nut Member

    Your unit has 32k nvram.
  51. Arghtastic

    Arghtastic Networkin' Nut Member

    Thank you, lefty! Much appreciated.
  52. Toastman

    Toastman Super Moderator Staff Member Member

  53. eugene28

    eugene28 Serious Server Member

  54. Jacques

    Jacques Addicted to LI Member

    Hi Toastman,
    tomato-K26USB-NVRAM64K-1.28.0500.5MIPSR2Toastman-RT-N-VPN.trx on RT-N66U
    when i click on Real-Time in IP Traffic then nothing happens, after 12 seconds is all ok.
  55. kyphos

    kyphos Serious Server Member

    I've been using Jon's original 1.28 Tomato on my WRT54GL for a long time. Recently, I decided to modernize, and see if I could master Toastman's wonderful QOS enhancements, so I installed 1.28.7633.3 VLAN-IPT-ND STD (as per the recommendation from Toink). It installed and runs fine EXCEPT no wireless connectivity to the family iPhones. We have an iPhone 4 and a 4S, both with iOS5. Neither will connect to the WRT54GL. They see the SSID being broadcast from the WRT, but will not associate with it. All other clients in the house will connect, including an iPod Touch (w/iOS3), a couple of Macbooks (running OSX 10.6 and 10.8), an iPad w/iOS5, an old Thinkpad with WinXP. A neighbor's HTC Android phone will connect. Only the two iPhones are problematic.

    The iPhones connected just fine to the same WRT54GL when it had classic Tomato. They connect to both my Apple Airport Extreme, and Airport Express. They connect to a Netgear WNR3500L V2, as well as to numerous hots spots and APs when we're out and about.

    Troubleshooting so far: I disabled WiFi security, to eliminate any hinky encryption issues. I set the radio to 802.11G instead of Auto B/G. I fiddled a few of the Advanced/Wireless settings, judiciously changing them from the defaults. It's not channel interference - the Linky is on Channel 1, the Airport Express is on Ch 6, the Netgear on Ch 11, and the Airport Extreme on 5 GHz. The various units are scattered all over the house, not side by side.

    The About page indicates that 1.28.7633.3 uses the Broadcom wireless driver Should I be looking for another version of Tomato with the newer Broadcom 5.xxx driver?? If so, which one is best suited for the WRT54GL (and is known to work with the WiFi driver in iOS5)?

  56. kyphos

    kyphos Serious Server Member

    Update from OP:
    Problem Solved!!

    The root cause of my iPhone connectivity problem to Toastman Tomato WRT54GL appears to be a nasty bug deep in the bowels of the iOS WiFi driver. I've discovered two workarounds:

    1) Rename the SSID. Out of the box (more accurately, out of Toastman's trx archive file), the default name for the Tomato access point is "wireless". I renamed it to "wwireless". Problem solved - our iPhones can associate with the WRT54GL upon command. Seems odd that iOS firmware would be sensitive to the name of the AP.

    2) Forget existing wireless networks. Like most mobile devices, iOS caches information about known radios with which it has recently associated (the SSID and its access credentials). In my home environment, I already have two other Access Points in service: "big red" and "express-g". Both have been cached in an internal list of APs known to the iOS device, so that it can reconnect later without having to reenter the WiFi password manually on the iPhone. I discovered that after deleting both existing networks from the iOS cache (by tapping Forget this Network), the iPhones would associate with the "wireless" SSID created by Tomato.

    What I think is happening is that when I tapped on "wireless" to manually select that AP instead of one of the other two in range, the iOS software erroneously attempts to auto-connect to one of the saved (cached) radios, as well as to "wireless". It finds and associates with one of the others before it locked on to "wireless", even though I had manually specified the latter. Once I deleted the two cached networks from the iOS table, it couldn't auto-connect anymore, so it then did what I had told it to do (and associated with "wireless").

    To add more mystery to the madness, if I kept my two existing APs in the iOS table but renamed the WRT54GL AP from "wireless" to "awireless", it worked fine and did not auto-connect to one of the others. I surmise that the iOS code is using the alphabetical sort order of the SSIDs to prioritize which radio to choose when several are available, even if the user has manually specified the desired AP. But that doesn't explain why iOS would treat "wireless" differently from "wwireless".

    Having solved this problem, now I can get back to my original objective which is to figure out how to use VLANs and QoS.
  57. bripab007

    bripab007 Network Guru Member

    Kyphos, are you sure they're not running iOS 6? That's when a bunch of iOS wi-fi related problems cropped up (tons of posts at Apple support forums, Macrumors, etc.) for iPhones and iPads.

    So, the same thing happened to me with my E3000 running Toastman running v.1.28.7500.4 RT VPN. And at first, it was affecting my iPhone 4S, my iPad 2 and my wife's iPhone 5. After going through all the usual troubleshooting steps (various levels of wi-fi security, rebooting of iDevices and router, etc.), I found that the iPad and iPhone, had absolutely no problems whatsoever when connecting to the E3000's 5GHz accesspoint. The minute they connected to the 2.4GHz AP, however, they'd stop working or not be able to connect at all. Unfortunately, that's not an option for the iPhone 4S.

    As a test, I set up an old WRT320N running Toastman 1.28.7493 Std., and --lo and behold-- it allowed the iPhone 4S to connect to its 2.4GHz AP without issue! Unfortunately, that's about as far as I've had the time to get on the homefront.

    At work, what I found was that a couple of EA4500s running stock firmware also seemed to exhibit this issue initially. So I sort of replicated what I did at home and set up an alternate AP, an old WRT54G running stock firmware, as a temporary measure. Strangely enough, after several weeks, sometime after all the other users of the EA4500s had upgraded their devices to iOS 6, I've been able to connect to the EA4500s again without issue.
  58. kyphos

    kyphos Serious Server Member

    I'm absolutely certain my iPhones are on iOS5. I've quite deliberately not upgraded them until the dust settles on iOS6. I've seen some of the WiFi problem reports and there are too many bugs and mysteries for my liking. I also have a 3G (not 3GS) that is still running iOS3!

    My home environment (multiple APs, each of whose info is stored in the iPhone's list of known networks) is a somewhat unusual use case, and I think it is exacerbating one or more defects in the iOS5 WiFi driver firmware.
  59. bripab007

    bripab007 Network Guru Member

    Well, that is intriguing, but I never had a single wi-fi problem (that I'm aware of) at work or at home with multiple APs on iOS 5, so I'm not sure I can be much help in that case.
  60. bripab007

    bripab007 Network Guru Member

    I just wanted to follow up on what I did to fix my problem. I decided to flash my E3000 to a DD-WRT firmware to see if the results were any different over there, and what I found was that it fixed my 802.11n 2.4GHz problem with the iPhone 4S, but it broke the 5GHz AP that had been working just fine with the iPhone 5 and iPad!!

    So, after playing with it for a while to no avail, I decided to flash back to Tomato, restored settings from my config file to get back to square one, and lo and behold, both 2.4GHz and 5GHz are now working fine again with all devices!

    It's odd because when I first encountered this problem, I'd reset NVRAM (I literally always do this when moving between firmwares) to try default settings as well as upgraded to a newer Tomato than what I had been running, all no no avail.
  61. koitsu

    koitsu Network Guru Member

    bripab007, with all this "firmware dancing" you're doing, you don't seem to be keeping something in mind:

    The actual wifi driver used in these firmwares (TomatoUSB, DD-WRT, etc.) quite often changes between firmware versions (e.g. Toasmtan 1.28.7493 vs. Toastman 1.28.7500.4), and especially changes/is different between firmware types (e.g. DD-WRT vs. TomatoUSB).

    It's even more complex with Toastman, where there is the "RT" build and the "RT-N" build, where the major difference between the two is the wireless driver blob used. RT-N is the "new wifi driver" which some people have better success with, while others find it spotty/broken and find "RT" more reliable. YMMV!

    The wifi drivers used on these routers is a binary blob provided by Broadcom -- meaning nobody has the source code but them. If Broadcom messes with it and it causes problems for you, and rolling back to an old release solves your issue, great. But at the same time, some other random user might find that the driver changes actually fix/improve things for him. Welcome to why wireless sucks in general. :p

    My point here is this: every single time you change firmwares or go from version X to version Y, you need to look at the ChangeLog to see if the wireless driver has been changed/updated. You can see what wireless version is in use by using wl ver command (either via telnet, SSH, or via Tools -> System). You should make note what versions work for you and what versions don't work for you.

    And this is completely 100% separate from any reliability issues (driver-level or hardware-level) that the client device (iPhone, laptop, etc.) might have!

    Finally, you need to do extensive testing every single time you change firmwares or change versions. Extensive means literally 5 days of use, although 2-3 weeks would be better. I cannot tell you how many times I have seen people ranting and raving on this forum about how "firmware X works but firmware Y doesn't" (where the wireless driver didn't change), only to find out that what's actually happening is that their area (apartment complex, area of town, etc.) is filled with hundreds of wifi hotspots and thus there is too much interference from all the wifi traffic to get a good/stable signal at all times. There's little one can do about this other than change to a different (less-used) channel or deploy wifi-blocking paint or wallpaper to keep other people's signals out. Troubleshooting wireless problems is an extremely difficult and complex thing.
    menses likes this.
  62. PJON

    PJON Networkin' Nut Member

    My Asus RT-N16 is connected to a Huawei 3G B260a router on the WAN port. The B260a worked ok for a year but has become increasingly unreliable and needs to be reset frequently. I have a Huawei E1820 router as well which I know can be used to provide a 3G failover with some routers. Any advice on whether this can work ok (instead of the B260a) with the latest Toastman release and if so how to set up? Thanks
  63. bripab007

    bripab007 Network Guru Member

    Thank you for the info, but I really didn't do any firmware dancing. I was on 7005.4, reset NVRAM and set up from scratch > problem still existed. I flashed to DD-WRT > problem still existed. I flashed back to 7005.4 and reloaded saved config > PROBLEM SOLVED!

    I find that bizarre, don't you?

    (And yes, a different access point running 7493 worked fine throughout all of this)

    And yes, I read the changelogs before deciding to upgrade Tomato FW, as I usually like to stick with a version that's stable for my environment and has the features I most want/use (which is why I'd been happy with 7005.4).
  64. koitsu

    koitsu Network Guru Member

    Nope, I don't find it bizarre at all. What that indicates to me is that there's either a wireless binary blog bug that you were bit by that "went away" by total chance after reloading TomatoUSB the 2nd time (because a saved config restore completely overwrites/replaces and adds NVRAM variables). This is what I meant when I said "firmware dancing" -- you're jumpin' around doing backflips and cartwheels changing between firmwares and then rolling back to the previous version and "suddenly everything works!!! Flashing to DD-WRT then rolling back solved everything!". Trust me, the problem is elsewhere, and I'm sure you'll have the problem happen again in the future.
  65. bripab007

    bripab007 Network Guru Member

    What do you mean "the problem is elsewhere"? I can only surmise there must've been a problem with the initial flashing of Tomato 7005.4, the DD-WRT issue was slightly different (and I'm not sure what Broadcom drive it used) so I didn't take much stock in it, but then the second flashing of 7005.4 must've been successful.

    I'd hardly call flashing two different firmwares jumping around doing backflips. And again, because no one has access to Broadcom source code, what alternative do we as end-users have when faced with a wi-fi client problem such as this? We play around with wi-fi settings and/or go to a different FW that uses different wi-fi chipset drivers, right?
  66. koitsu

    koitsu Network Guru Member

    I can assure you the first time you flashed 7500.4, it worked. There's no way "the flash didn't work" and a failure would manifest itself as "wifi oddities". It just doesn't work like that. The flashing process will actually bail/abort if the flash fails, if my memory serves me right. So I can assure you all the correct bits got flashed.

    When I say "the problem is elsewhere", I'm referring to things like those listed in my last paragraph here. Wireless is a real pain in the butt when it comes to troubleshooting; what may work fantastic one day may stop working or start experiencing serious issues the next. For all you know this could be caused by some nearby person turning up a new access point themselves, with its power level cranked too high up, thus destroying the signal for everyone else. This really does happen -- I'm sure Toastman could tell us some of his horror stories with wifi debugging in the field.

    Regarding what choices consumers have: you're correct, we have very little choice. Generally speaking wireless is a very unreliable medium, and as I said, troubleshooting it is very difficult. But my point is that changing firmwares isn't helpful unless you start logging/taking notes about the things that matter, like wireless driver version. Firmware X vs. Firmware Y (i.e. Tomato vs. TomatoUSB Toastman RT vs. TomatoUSB Toastman RT-N vs. TomatoUSB Shibby vs. DD-WRT vs. OpenWRT) doesn't really help -- you gotta be more granular. Wireless driver matters, as do every one of your wireless settings. You don't just start changing random options/values ("play around with wifi settings") in the GUI and "see what fixes things" because 95% of the time adjusting those settings resets the entire wireless chip, which quite often solves whatever the problem was. Yes really! In fact, some wireless drivers and their chips (I can think of a few Atheros models) do this on their own when there's too much interference! I happen to communicate with a guy who works for Atheros and works on their wireless drivers on FreeBSD, which is how I'm familiar with some of this from a somewhat "abstract" POV.

    If you do go the "play around with settings" route, you have to take very meticulous notes, and as I said, let things sit for days, if not weeks, at a time because a simple 10 minute test is not long enough. Wireless... what a nightmare.
  67. w4rh4wk

    w4rh4wk Networkin' Nut Member

    Hey Everyone & Toastman,
    Is it possible to increase the max PPTP server connections on the GUI PPTP from 6 to a larger number?
  68. Toastman

    Toastman Super Moderator Staff Member Member

    w4rh4wk - What would u call a reasonable number?
  69. bripab007

    bripab007 Network Guru Member

    Yes, I agree there's probably no way in which the FW flash could've been botched in such a way that the wi-fi chipset was borked only for 2.4GHz and not 5GHz. Besides, it would've contradicted my initial finding which was that 7500.4 worked flawlessly for months until iOS 6 came out, at which point iOS 6 devices only worked on 7500.4's 5GHz AP. So I knew it wasn't really a flaw in the flashing of the 7500.4 FW, however, it has since resolved itself after flashing to DD-WRT and then back to 7500.4.

    That process was carried out over the course of a few hours, so that, coupled with the fact the problem first arose when iOS 6 came out and that I set up a 2nd 2.4GHz AP running 7493 which worked fine, invalidates the possibility of a neighbor's wi-fi AP interfering.

    So, what else can you make of the scenario?
  70. w4rh4wk

    w4rh4wk Networkin' Nut Member

    Lol oh man putting me on the spot here... 15-20 .. Is that possible?
  71. maurer

    maurer LI Guru Member

  72. w4rh4wk

    w4rh4wk Networkin' Nut Member

    Oh nice thanks very much Maurer. I'll give that a try on one of my test routers. Hey Toastman is it possible to increase the limit in the future releases?
  73. Zodler

    Zodler Serious Server Member

    Today I bought a Linksys E4200v2 and when I try to upgrade the firmware through the original firmware menus to

    I get an error that the image is not correct. What should I do?
  74. w4rh4wk

    w4rh4wk Networkin' Nut Member

    so i was able to find "pptpd_remoteip" via "nvram find pptpd" command and force a higher IP range greater than six IPs. I tested 7 PPTP VPN connections. On the 7th connection the client failed. Once it failed on the 7th connection no other new connections would work regardless if there was less than 6 users connected to the VPN. Definitely a hard limit somewhere else. :(
  75. Monk E. Boy

    Monk E. Boy Network Guru Member

    Just thought I'd note, since others are discussing problems connecting from iOS 6 devices, that iOS 6.0.1 was released and that one of the highlighted fixes is trouble connecting to WPA2 networks after upgrading to iOS 6.

    With the iOS devices I've upgraded, I had to delete all known networks (settings.app -> general -> reset -> reset network settings) after updating to 6.0.1, but YMMV.
  76. gfunkdave

    gfunkdave LI Guru Member

    The E4200 v2 is not compatible with third party firmwares because it uses a Marvell chipset. Only the E4200 v1 is compatible. Sorry.
  77. Zodler

    Zodler Serious Server Member

    Thanks. Wow, I wish people had mentioned it clearly! I was careful before buying and looked and everywhere I looked in the firmware files I saw E4200 and no mention of E4200v1 in the names so I was pretty sure it would be safe to buy it.

    So now I am considering Asus RT-N66U. Please let me know if there is a bad surprise with versions like E4200. Am I 100% sure if I buy RT-N66U, tomato will work on it?

    Also I have another question. I just visited Asus site and I saw they have traffic monitoring graph. My needs are simple and all I need is a graph to see the traffic and a kind of a decent QOS. Will I still benefit from replacing it with tomato? How is ASUS's network graphs? Does it show per IP? Because what I love about toastman tomato is the real time graph per IP. Thank You.
  78. koitsu

    koitsu Network Guru Member

    Absolutely nothing, because iOS is locked down and nobody is familiar with the operational code of the wireless driver there except Apple, and because Broadcom provides a binary blob driver for wifi on routers. There is nothing else I can say or do about it, which is the same boat you're in, and the same boat we're all in. This doesn't mandate "fiddling around" with wireless settings. Instead, it mandates other solutions, like: "well crap, I'm out of options, I guess I'd better get something that's known to work with my iOS devices. Maybe I can get an Apple router and use that for wireless, while using my normal router for non-wifi things?"

    Furthermore, "over the course of a few hours" is not enough time (I don't know why I keep having to state this) -- when I have seen actual engineers debugging wireless coverage + driver issues (and I have seen this in person), it takes them multiple weeks of 6-8 hours of surveying every day with tools and being actively engaged. I watched this happen at Microsoft (previous place of employment) where there were coverage issues within our corporate office and other "strange anomalies" where people's laptops would disconnect and refuse to reconnect. The problems there turned out to be apparently 5 or 6 different things simultaneously -- there were coverage gaps between the repeaters, some people were using confirmed-as-broken Intel wifi drivers (Intel's changelogs indicated an issue that had been fixed which matches up perfectly with their problem), and there were 3 or 4 settings on most (but not all!) repeaters which had to be adjusted (engineers thought they had set things up correctly when the repeaters were deployed but was obviously not the case). Like I said: multiple things wrong, all of which when combined caused problems, and it took weeks to figure out.

    Otherwise, for data to track, please start with what I said, and expect the troubleshooting to take weeks. Really.
  79. gfunkdave

    gfunkdave LI Guru Member

    FWIW, we have several iDevices in our house (as do my parents in theirs) and Tomato routers in both locations have never given a problem.
    beatnik likes this.
  80. bripab007

    bripab007 Network Guru Member

    Look, I appreciate the input, but either I didn't state things clearly in previous posts, or you're just not comprehending them. I ran 1.28.7500 for months on iOS 5 without issue. Then over the course of probably six weeks, troubleshot the problem through various means (fiddling with iOS 6 devices, trying different wi-fi settings/encryption, testing other wi-fi APs and routers, etc.), one of which was to reset NVRAM on router, to no avail. Then just this past weekend, over the course of a couple hours (in addition to the hours and hours spent over the course of the previous ~six weeks), I flashed to DD-WRT, flashed back to 1.28.7500, restored from saved config, and it's all of a sudden working.

    My troubleshooting was over the course of weeks, not hours. My flashing the firmware twice and then confirming the problem was resolved, was over the course of a couple hours this past weekend.

    I understand wi-fi is complex, and we don't need to continue this conversation anymore because we'll never determine the answer. But please don't assume I only troubleshot this problem for a few hours.
  81. koitsu

    koitsu Network Guru Member

    Sorry, my indication of how much time you let things sit/settle for was based on this statement ("... over the course of a few hours ..."). If I misunderstood or misinterpreted, yep, that's absolutely 100% my fault and I apologise for that.
  82. Solid-State

    Solid-State Network Guru Member

    Hey koitsu, for a business environment what build to you recommend RT or RT-N. If I don't need the VLAN function might as well just install STD ehh?

    Recently with a brand new Asus N56-VZ notebook with Atheros wireless in it I had strange DNS issues. I'm using three static DNS entries with 0500.5 STD and when I had DNS issues on the Asus notebook I checked the DNS and it had very strange HEX values in there. I've never seen that before!
  83. koitsu

    koitsu Network Guru Member

    For a business environment, I recommend getting a business-class router, because the term "business environment" means very little to me unless you give me actual numbers. If we're talking about an office filled with 50 people, I'm already laughing at the idea of someone using a residential router to drive that reliably (I worked at an ISP which had 7 employees and it didn't take much to overwhelm the crappy Portmaster they had as their router; packet loss madness, rebooting, blah blah. Good thing I put a Cisco 2510 to use). In that case, get yourself a Cisco router (I'm not talking about Linksys/Cisco, I'm talking about a real Cisco router), or a low-end Juniper router; spend a few thousand + get a support contract and go with that. It's a business, treat it like one.

    I should also be clear: I'm not talking about those wonky SMC routers or some other "SoHo Business"-class router -- those things are usually junk, with IP stacks written from the ground up by folks in Taiwan (I trust BSD and Linux IP stacks because I know they work). There are lots and lots of "business-class routers" for US$300-400 (including some from Cisco) that are just absolute garbage. So don't be fooled necessarily; don't think that paying 2x the amount of a consumer router is going to get you "something more robust", because it doesn't work like that. However, in the case of Cisco and Juniper equipment, oh yes, I can assure you you will get what you pay for (and a support contract ensures you can hold someone liable for bugs/issues you encounter).

    If by "business environment" you meant "I'm a residential customer who pays for business-class service because I use lots of bandwidth", then that's not "business environment" at all. :) So if you could help define exactly what you needs are, how many people there are, your average bandwidth usage, etc. then I can probably recommend something for you.
  84. bripab007

    bripab007 Network Guru Member

    No problem. You're absolutely 100% correct that wi-fi is a strange and mysterious beast, quite difficult to tame. It's quite likely if I'd been keeping a log of everything I tried and when, I'd have a better idea of what finally solved it.
  85. Monk E. Boy

    Monk E. Boy Network Guru Member

    This morning my newly-issued work iPad refused to connect to my RT-N16 at home, and my iPhone refused to connect as well, so I ended up trying my usual (reset network settings on the iDevice) with no luck. When I connected up to the router from a wired system I noticed that the "Interference level" was listed as "Severe." Changing the wireless channel moved that to "Acceptable" and then my iPhone (which I had purposely avoided resetting, I just reset the iPad) could connect... which held true for the iPad as well.

    Since I was literally doing this as brushing my teeth and getting dressed before charging out the door I didn't have time to fire up a sniffer and see what was causing the interference, but my guess is a neighbor decided to install a new router this morning, set it up on my channel, which promptly tromped all over the RT-N16. Or their existing wireless router automagically changed its channel in the couple minutes of wireless silence after 6am when my router rebooted.

    Anyway, my point here is basically the same as Koitsu's - before blaming the device (even if the device is the router), it pays to do a more thorough investigation of what's actually happening in the environment (it may even save you from having to set up all your &*(@#&*$( workplace wireless networks all over again :) ). Now if only Apple would let some damn wireless stumbling apps back into the app store...
  86. koitsu

    koitsu Network Guru Member

    Monk E. Boy's story is a good example of what I was trying to explain. I guess I'll have to go into some abstract details about wireless to really get my point across (specifically for his situation):

    There are known nuances with a lot of wireless chips or drivers (Atheros comes to mind, but I'm 100% certain the same issue applies to any vendor), where when the chip (or driver -- there's sort of a symbiotic relationship between the two) begins to experience/witness what it considers to be excessive wireless interference (usually caused by too much traffic across a single frequency (that's why there are multiple channels available to choose from)), the driver and/or chip can sometimes get wedged in an operational mode where it tries its best to deal with the interference but usually fails (packet loss at layer 1 or layer 2; hard for me to tell). In the end, the chip (or driver -- again, not sure due to the symbiotic relationship) gets "stuck" operating like this, and the only way to get it to un-wedge is to reset the chip or reset the driver in some way.

    When you change the channel frequency associated with your AP, I can assure you that the wireless driver and/or chip in some way/shape/form is reset. This is difficult to analyse because in the case of Broadcom chips, the driver is a binary blob (but even if it was open-source, that doesn't help unless you have someone looking at the driver who understands its code + how it operates).

    So what am I trying to say here? I'm trying to say that Monk E. Boy could have stuck with the same channel # he was already using and instead rebooted his RT-N16 (and I bet you the interference indicator would have dropped to Acceptable), or toggled a setting that caused the wifi chip/driver to reset itself, thus un-wedging.

    Starting to understand why so many people report things like "yeah man when I change from channel X to channel Y the problem was gone!", despite that probably not being (accurately) the case? :)

    Where's my evidence come from about this driver/chip behaviour? Experience and long Email threads. I've seen this behaviour with Atheros-based wifi chips on PCI cards. I tried to migrate from my RT-N16 (as my router) to using my FreeBSD box instead with a PCI-based 802.11g card in it. Initially things worked great, no issues. But aftersome time, I began experiencing bizarre behaviour -- either from the chip or the driver -- which caused issues. The only workaround was to reset the Atheros chip, which in FreeBSD you could not do (only solution: reboot the machine). You can see from my post that this is not a FreeBSD issue -- Linux has an entire Wiki page dedicated to this problem. Changing channels didn't matter, and changing some of those tunables also didn't matter. Because of that issue, along with some other unrelated things, back to the RT-N16 I went.

    The maintainer of the Atheros wifi driver on FreeBSD responded, and this individual also happens to work for Atheros. What he says is extremely low-level (I do not understand about 60% of it); do not even for a minute think wireless is a "simple" thing. I urge anyone who questions the legitimacy of what I'm saying to read what Adrian wrote -- you will begin to truly understand just how utterly buggered wireless is as a technology (that's how I see it anyway), why it's unreliable, and most importantly, why sometimes just "fiddling with settings" causes things to improve (because the chip and/or driver itself gets reset back into a state where it's usable).

    This is one of the maybe 20+ reasons I use wired connections for nearly everything. I know that's not pragmatic/practical for everyone (duh). But respectfully: I am in no way shape or form a good engineer when it comes to 802.11 protocols (IP, Ethernet, T1/T3, SONET, etc. are a different story), but please try and understand I'm not talking out my ass here; I've been down this road before, and though I cannot easily debug some of these problems, I can assure you there are environmental situations that can cause a wireless chip and/or its driver to get into a "weird logic state" where resetting the chip and/or resetting the driver magically causes things to work again. That is why it's very important for troubleshooting that people take meticulous notes and really give things multiple days (if not weeks) of testing. An hour (or even multi-hour) test is not enough.
  87. Monk E. Boy

    Monk E. Boy Network Guru Member

    For what it's worth, when I got home at night the AP on channel 1 had vanished (forgot to mention I did hit the scan button, which is how I chose the new channel). The really annoying thing with WiFi is you like to think the signals end at your walls but they go a long, long way, into other peoples homes and property. Its really become a tragedy of the commons in multi-home domiciles like apartment complexes, townhomes, etc.

    Another complication is that you can do all the WiFi sniffing/scanning/stumbling you want and it won't show you 2.4Ghz/5Ghz interference from non-WiFi sources. You need a dedicated piece of hardware (WiSpy seems to be the cheapest way I've found, short of building something yourself or re-purposing non-WiFi RF hardware) to actually receive all RF signals coming in and display an analysis. Even something as simple as a microwave or a cordless phone can cause 2.4Ghz interference. Oh god, cordless phones are the worst, especially the ones that apparently choose a particular frequency at random - ostensibly to avoid interference - for each damn phone call.

    Ultimately problems at homes come and go on their own rather mysteriously, in no small part due to the "Auto" behavior of consumer equipment that randomly stumbles across channels until it finds the worst possible channel to use and then plops itself down there until it's thoroughly pissed off everyone within range, at which point it'll move on. But unless you take the time to sit down and figure out what is going on, especially since really figuring it out requires additional hardware, you're effectively stumbling around in the dark... sometimes what you're feeling isn't pigs brains, it's just some lukewarm spaghetti noodles.
  88. Toastman

    Toastman Super Moderator Staff Member Member

    Koitsu / Monk E Boy - couldn't agree more. Wifi is just about the worst engineered RF solution I ever saw in my life. I've spent thousand of hours messing with wifi, and am no closer to understanding than before. Having source code probably wouldn't help in the slightest, as Koitsu said.

    The use of auto channel selection has also contributed to the mess.

    Personally I use nothing but hardwired stuff, but I have to use wifi to deliver internet to apartments. "G" just about works ok, but since "N" was foisted on us on 2.4GHz, all hell has broken loose.
  89. Mangix

    Mangix Networkin' Nut Member

    has all hell broken loose because of the 40MHz stuff or what?
  90. lyrebird

    lyrebird Networkin' Nut Member

    Asking for a help. I am using the latest vpn no usb build in my RT-N16. I noticed that when the qos is turned on, i will see a lot of warnings (shown below) when I use the openvpn. and the speed is seriously degraded. Any suggestions? Thanks!

    Authenticate/Decrypt packet error: bad packet ID
  91. koitsu

    koitsu Network Guru Member

    Outside my skill set, but this seems to indicate 802.11n isn't really helping things at all. Quoting part that caught my eye:

    The entire article is very useful, but leaves me with one taste in my mouth: what an absolute, awful mess. This picture doesn't impress me either. 2.4GHz is way too overused/crammed/full at this point. I'm starting to see how/why interference is such a problem now, especially given how everyone and their dog has an AP, or multiple APs, or (in the case of medium or large businesses) 40 APs. Ugh.
  92. Mangix

    Mangix Networkin' Nut Member

    It's too bad that this problem has no good solutions. Everyone says 5GHz but besides the lack of those(although it is getting better with newer devices), the range is horrible.

    There's just not enough bandwidth anywhere.

    One possibility is to get a router than is "SuperChannel" compatible, meaning able to use frequencies not allocated for Wi-Fi but not only is that illegal in most places, device support is inexistent.

    So yeah. No good solutions.
  93. koitsu

    koitsu Network Guru Member

    I get the impression the original idea behind 802.11 was that it would be adopted in a different fashion by the market/vendors, and that not every person on the planet (so-to-speak) would have their own wifi AP... but look what happened. ;-)

    Then again, anything wireless-oriented I've seen, not just 802.11 protocols, have these kinds of interference issues. Mobile phones are a great example, Bluetooth also comes to mind, and we can even go back further to things like CB radio causing massive interference across AM/FM radio channels and so on. I imagine in today's wireless world, the most common crap seen flying around the air probably consists of 802.11 and mobile/cellular traffic. I would hate to be on any committee having to deal with this kind of thing. :)
  94. Mangix

    Mangix Networkin' Nut Member

    I'm curious if software-defined radio will mitigate some of the problems to an extent. But then again that's years off.
  95. Dr Strangelove

    Dr Strangelove Networkin' Nut Member

    WiFi is going to [a bad place] in a handcart.

    Wait until Miracast(WiFi-direct+) gets going and half the devices in your home are using it. It use 2.4GHz for connection setup and 5GHz for data.
    And if one thought you could escape to 5GHz land, look out here comes 802.11ac

    On the upside, having a Linksys E4200v1 with Toastman TomatoUSB firmware and the neighbors out of spitting distance I have a relatively stable 2.4GHz WiFi environment. But I'm sure I'm the black sheep in the paddock.

    I haven't thought this through, but would TomatoUSB support Miracast some time in the future?
  96. Monk E. Boy

    Monk E. Boy Network Guru Member

    BTW, in the 5Ghz band there's a big frequency jump between the low channels and the high channels. In the US we have a huge range of channels in the middle that are basically locked out, but if you're lucky enough to have a low channel free of interference, that signal can actually go a decent distance. Not as far as 2.4, but much farther than the higher channels.

    My only issue with home use and sniffing over long periods of time to uncover the cause is the fact that signals tend to come and go on their own due to neighbors having no clue about what it is they're doing. In the course of a couple weeks you may have neighbors pop up with one AP, demolish your connection for a couple days, then disappear, only to reappear with a different make/model AP a couple days later and do the same thing all over again. Now imagine multiple neighbors doing this. The patterns are hard enough to discern when they're stable, but throw people living in close proximity to each other in the mix and it's frustrating. To the lay people WiFi is either "bad" or "good" based on the device they purchased, they don't understand channels, much less RF.

    When you're in a business environment where you own the entire building and you have control of everything it's one thing, that you can sit down and figure out logically and reasonably, but when you've got too many cooks in the kitchen and some of the cooks are apparently 4 years old and have never seen hot surfaces before... it's... annoying.
  97. digiblur

    digiblur Networkin' Nut Member

    I know the Ubiquiti products have the Airview piece built into them. I've used it a few times and it seems to work pretty well.
  98. Toastman

    Toastman Super Moderator Staff Member Member

    haha - take one look at the 2.4GHz band using an HP Spectrum Analyzer, and you'll basically just give up ... the whole band occupancy is constantly changing, routers are hopping from channel to channel, video cameras, phones, bluetooth, radar, you name it - it's there.

    Over here we have 3 telecoms ISP's set up thousands of free wifi AP's all over the city - and their AP's are on top of high rise buildings. There's one a kilometer from here that's just as strong as the AP next to my own apartment. And yes - some of them are "N" .... and stomp over everyone and each other. The ISP's clearly have no idea, or couldn't care less, how much trouble they are causing.

    Wifi is not supposed to be used like this.

    As far as apartment blocks are concerned, nowadays people need signals strong enough to use by their mobile phones, which are, to put it mildly, as deaf as a post. So we have to provide quite strong signals to all rooms through concrete rebar walls. That means a LOT of AP's (most hotels don't have enough). I always aim to have an AP within 15 meters of every room.

    The one saving grace is that the whole lot are also encased in a rebar concrete shell so most of the signals don't escape from the buildings...
  99. koitsu

    koitsu Network Guru Member

    Interesting timing -- Slashdot just posted this today:


    Some of the comments are worth reading too (not too often can I say that about Slashdot). I'm not sure what to think about the technology itself, but it's still interesting.

    Footnote: It's starting to creep me out how much stuff I participate chatting about which ends up showing up 24-48 hours later on Slashdot. I'm really starting to think human beings have some sort of collective intelligence, like ants or something. :p
  100. Mangix

    Mangix Networkin' Nut Member

    congestion control for Wi-Fi....hope it actually works magic.

    Not too far off from the truth. When you have multiple people having the same exact problems...

Share This Page