1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Toastman's Releases

Discussion in 'Tomato Firmware' started by Toastman, Dec 18, 2011.

  1. Morac

    Morac Network Guru Member

    My 2.4 GHz channel frequently toggles between "severe" and "normal" when I log in and watch my router (it's still usable usually unless I power up my Microwave). My 5 GHz channel stays "normal", but the speed drops off unless I'm fairly close to the router. There are literally dozens of APs listed when I do a scan and no free channels, which is boggling considering there is open space behind my house and my two immediate neighbors don't have WiFi (or didn't originally). So I'm picking up dozens of WiFi signals (a number of them quite strong) from across the street and down the block.

    So I agree that WiFi signals go a "long, long way".
  2. Monk E. Boy

    Monk E. Boy Network Guru Member

    Not too long ago I lived in a townhouse complex and the number of APs showing up on scans were mind-boggling, quite literally in the 50s. Half of them were completely unsecured. I'd occasionally get bored and install updates on routers if there was a known bug with the version they were running.

    And then I discovered powerline networking... which also served me well up until a couple years ago (in my current residence I'm down to a single AP, with a single room of ethernet-connected equipment).
  3. koitsu

    koitsu Network Guru Member

  4. Toastman

    Toastman Super Moderator Staff Member Member

    Wifox ... wonderful, that's just what we need - a war.

    Koitsu - thanks for posting that interesting article from Intel. I see many USB3 hard disks with what looks like absolutely no shielding at all. Made in China ...

  5. Mangix

    Mangix Networkin' Nut Member

    for fast Wi-Fi, don't use USB 3.0 is what it sounds like. I'm curious about the power level a USB3 device transmits at. I know the spec says 600mW but wow.
  6. _NemO_

    _NemO_ Networkin' Nut Member

    Aha! That's why my Microsoft Arc Touch mouse freezes when I connect USB3.0 flash drive near the mouse transceiver.
  7. RonV

    RonV Network Guru Member

  8. M0g13r

    M0g13r LI Guru Member

    Switched from latest shibby to latest toastman on RT-N66U

    Now I have fullspeed on 50/10 mbit line with qos enabled !!!

    Toastman i love U :p *G*
  9. Mangix

    Mangix Networkin' Nut Member

    different default settings for example.

    do 'nvram show | grep wl0_' on both shibby and toastman defaults. your answer should lie there. somewhere...
  10. PBandJ

    PBandJ Networkin' Nut Member

    I only have experience with Toastman's, didn't know different defaults are used. Would be interesting to see the differences.
  11. callous

    callous Network Guru Member

  12. gs44

    gs44 Networkin' Nut Member


    Just as an update I have been running tomato-NVRAM60K-1.28.7500.2MIPSR2Toastman-RT version specific on my E3000 and E2000 since you released it back in June. It has been Rock solid and by far the best/fastest version thus far for both of my routers. This is compared to your newest version and tons of older versions. Keep up the GREAT work. Tomato RULES!! lol
  13. RKGraves

    RKGraves Serious Server Member

    Recently installed a TomatoUSB-Toastman build of firmware on my Asus RT-N16. It is running very well and I want to make a Paypal donation but can't find a link specific to Toastman.
    - Is there such a link?
    - Would someone please point me to it?
    Thank You
  14. Toastman

    Toastman Super Moderator Staff Member Member

    Look at the "About" Page or visit the website in my signature :)

    And ... thank you!
  15. Zodler

    Zodler Serious Server Member

    Guys I don't understand why there is E2000 in RT-N branch? What's the difference with the E2000 RT branch?
  16. lefty

    lefty Networkin' Nut Member

    Because, the RT-N branch has the newer broadcom wireless N driver where the RT branch has the older wireless driver. Some people like using RT-N builds for their E2000, some like using the RT builds. Claims differ performance wise for which one you should use, so its then up to you to test either and decide for yourself which you want to use.
    koitsu likes this.
  17. koitsu

    koitsu Network Guru Member

    "Currently PayPal accounts in Thailand are only able to send payments. This recipient is not eligible to receive funds." :( Koitsu sad panda...
  18. koitsu

    koitsu Network Guru Member

  19. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Don't know why but the longer I run 7500.4 version the slower it gets and it starts dropping some of the wireless clients.

    Back to 7483.2 and it is solid and fast and stays that way.
  20. Mangix

    Mangix Networkin' Nut Member

    upgrade to 7500.5. 7500.4 has a memory leak issue with the RT-N branch.
  21. jsmiddleton4

    jsmiddleton4 Network Guru Member

    There isn't a 7500.5.

    There is an 0500.5.

    The 7500.4 doesn't use the RT-N driver.
  22. Mangix

    Mangix Networkin' Nut Member

    Ah yes that's accurate. Although there was an RT-N build ending in .4 before it got pulled.
  23. coldmantis

    coldmantis Serious Server Member

    Will there be support for 3TB Hd's on E4200 in the near future.
  24. Zodler

    Zodler Serious Server Member

    Please at least tell us the router you are using it on.
  25. jsmiddleton4

    jsmiddleton4 Network Guru Member

  26. Drutten2

    Drutten2 Serious Server Member

    Are there any updates for the E4200 ? Latest greatest?
    I'm currently using: Tomato Firmware v1.28.0500 MIPSR2Toastman-RT-N K26 USB Ext
  27. dorimon5

    dorimon5 Serious Server Member

    hi toastman! I need your help. I have Linksys WAG200G. What firmware version I would like to use? Thanks!
  28. thevdr

    thevdr Networkin' Nut Member

    Hi - just a brief question regarding the ingress QOS which i think adds an extra dimension to QOS and works great:

    I have noticed that the prioritized packages for SYN, FIN and RST are send using the highest priority class and I see the traffic on the QOS graphs as a result (traffic without any active connections). But I can not see any inbound traffic in this class? I can see some inbound traffic without active connections on my default priority class - is this the traffic from these SYN, FIN and RST packages inbound??

    Regards - and forgive me for yet another QOS question ;-)
  29. lissny

    lissny Networkin' Nut Member

    is it possible in BW limiter ...there will be a collumn of.....B.W data
    it means bw limiter will active on that amout of Data is reached. eg. 1gb ....2gb
    then the speed will effect that IP/mac
    plz reply
  30. SirZ

    SirZ Serious Server Member

    Hey Toastman, can you add to your firmware build launch flag to udpxy -M and option to webGUI where we can change this flag value?
  31. Tom Parkison

    Tom Parkison Networkin' Nut Member

    I don't have a problem with USB 3.0 and WiFi, however USB 3.0 spreads royal havoc with my Logitech wireless keyboard and mouse set which as you probably have guessed, it works in the 2.4 GHz range. Also, I had to change my wireless channel to something lower (channel 1) to get it play nice with the Logitech wireless set because that too caused issues. Too much 2.4 GHz stuff in my house all in very close proximity.
  32. Tom Parkison

    Tom Parkison Networkin' Nut Member

    Have you dropped support for the e3200?
  33. mito

    mito LI Guru Member

    Hei guys, undestand the modders, they do their best and free for us, don't ask for personal needs, it is imposible to build a firm for each user! that is the reason that there are a lot of "tomato flavors" to choose from, pls read this link: http://toastmanfirmware.yolasite.com/
  34. JohnO

    JohnO Serious Server Member

    Which SNMP OID for memory info?

    I've been using MRTG to graph my interface stats with Toastman (and DD-WRT before that) for a number of years. I'd now like to add graphs for CPU utilization and memory utilization.

    I'm using Tomato Firmware v1.28.7496 MIPSR2-Toastman-RT K26 USB Ext on a Linksys e3000.

    From the GUI, I see:

    Name OshPool
    Model Linksys E3000
    Chipset Broadcom BCM4716 chip rev 1 pkg 10
    CPU Freq 480 MHz
    Flash RAM Size 8 MB

    Time Sun, 16 Dec 2012 18:52:37 -0600
    Uptime 286 days, 13:07:41
    CPU Load (1 / 5 / 15 mins) 0.00 / 0.01 / 0.00
    CPU Usage 1.64%
    Total / Free Memory 60.08 MB / 48.98 MB

    I found the correct OIDs for CPU:


    1 minute Load: .
    5 minute Load: .
    15 minute Load: .

    But when I try the recommended OIDs for memory utilization, I get items returned that dont' seem correct:
    [root@cardinal mrtg]# snmpget -c public -v 1 myrouter .
    UCD-SNMP-MIB::memTotalReal.0 = INTEGER: 60 kB
    [root@cardinal mrtg]# snmpget -c public -v 1 myrouter .
    UCD-SNMP-MIB::memAvailReal.0 = INTEGER: 0 kB
    [root@cardinal mrtg]# snmpget -c public -v 1 myrouter .
    UCD-SNMP-MIB::memTotalFree.0 = INTEGER: 0 kB

    I've also tried:

    [root@cardinal mrtg]# snmpget -c public -v 1 myrouter
    HOST-RESOURCES-MIB::hrStorageSize.101 = INTEGER: 0
    [root@cardinal mrtg]# snmpget -c public -v 1 myrouter
    HOST-RESOURCES-MIB::hrStorageUsed.101 = INTEGER: 0

    Any suggestions?


  35. Toastman

    Toastman Super Moderator Staff Member Member

    December 20 2012 - 1.28.7501
    • some changes to nvram defaults
    • fixed 6in4 memory leak
    • 120 secs reboot timer
    • rc: fix for E4200 MAC address
    • IPTraffic bugfix
    • Remove 22 bit netmask limitation
    • ntfs-3g release 20121.1.15
    • 3G support for Huawei E3131s-2
    • Switchable QOS pie chart
    • Default for WMM is now "enabled"
    • Asus WL330GE support
    • Fix for excessive VPN logging "vpn client already running"
    Thanks to Shibby, Koitsu, Dinnn, TVLZ, Ollopa ...

    though likes this.
  36. Werner

    Werner Serious Server Member

    Also a E3200 version?
  37. Arghtastic

    Arghtastic Networkin' Nut Member

    Thanks to all for the hard work. I seem to have hit a sip related problem in v1.28.7500 MIPSR2Toastman-RT K26 USB VPN. I was wondering if anyone had time to take a look? I am happy to do any additional debug needed. Could someone take a look at my post here: http://www.linksysinfo.org/index.ph...sr2toastman-rt-k26-usb-vpn-and-sipgate.54151/

  38. callous

    callous Network Guru Member

    Is there any support for the E3200 5ghz band for this release by any chance :D
  39. solentcentaur

    solentcentaur Serious Server Member

    Despite trawling the various forums/wikis I've not found an answer to my issue and am hoping someone will help!

    I've been running a WRT54G with DD-WRT to act as a VPN(PPTP) router on my home network. I've some devices connected to the VPN gateway and others to the normal ADSL router/modem. This way some appear in spain, others in the UK. The problem I had was VPN throughput on the WRT54 (around 1.5Mbs on a 6.5Mbps ADSL connection (both speedtest figures).

    I've just moved to a ASUS RT N66U and initially tried a shibby build but the 5G wifi didn't seem to work after a NVRAM reset. DDWRT loaded but the GUI wouldn't configure (always stuck on .../apply.cgi) and eventually found the toastman tomato-K26USB-1.28.0501MIPSR2Toastman-RT-N-VLAN-VPN build, installed, working on 2.4G and 5G wireless and VPN configured and running at 6Mbps download.

    So to my question - if the router reboots the VPN requires restarting manually (also if it drops I believe). I'm not a linux expert and am hoping someone can offer me a basic script to auto-start the pptp service as if clicking on "Start" as if on the PPTP client GUI page, and if possible to restart it if the connection drops.

    Many thanks.
  40. kthaddock

    kthaddock Network Guru Member

  41. lefty

    lefty Networkin' Nut Member

    0501 RT-N working great on my E1550 and E900 with comcast cable ISP, flashed my E2000 with RT 7501 but haven't used it in any kind of production, but the flash to it is fine.

    Thanks for the great tomato builds Toastman, and happy holidays!

    PS: i tried to donate via paypal, but it is saying that you are not eligible for receive?
  42. Urko

    Urko Network Guru Member


    I must thank Toastman for the firmware and great work. I don't know where to report bug, so I'll do it here. In firmware Tomato Firmware v1.28.7500 MIPSR2Toastman-RT K26 Std on asus rt-n12 I notcet bug. Wireless is set to G only, and if you enable after burner device freezes. I could only resore it with ddwrt firmware, then factory defaults and back to toastman firmware.
  43. Toastman

    Toastman Super Moderator Staff Member Member

    lefty - I guess this is something to do with Paypal's latest way to screw people. I have no idea why it doesn't work now.

    If anyone knows why, I'd be glad to know, because Paypal are not forthcoming with any explanation.
  44. lefty

    lefty Networkin' Nut Member

    Something to do with the country you are in, says that country is currently not able to receive, i will continue to try.
  45. pharma

    pharma Network Guru Member

    Thanks Toastman! Your efforts are greatly appreciated!
    No issues ...
  46. Tom Parkison

    Tom Parkison Networkin' Nut Member

    Why isn't there any e3200 builds? I've not seen a new version since v1.28.0500.

    I asked before in a previous post but it seems that that question was ignored. Have you dropped support for it?

    EDIT: Nevermind, 4Shared seems to be screwing up in my browser and won't show all files in the folder. I had to open the site in another browser for 4Shared to function properly.
  47. lefty

    lefty Networkin' Nut Member

    You must not be looking close enough or looking in the right place, the E3200 builds are there for the latest RT-N 1.28.0501
  48. Tom Parkison

    Tom Parkison Networkin' Nut Member

    4Shared seems to be screwing up in my browser and won't show all files in the folder. I had to open the site in another browser for 4Shared to function properly.
  49. Python46

    Python46 Networkin' Nut Member

    Shibby also has an E3200 version in build 104, his newest release.
  50. callous

    callous Network Guru Member

    E3200 support! Thank you toastman
  51. callous

    callous Network Guru Member

    I see

    and one tomato-E3200USB-NVRAM60K-1.28.0501MIPSR2Toastman-RT-N-VLAN-VPN and

    What is the difference between NOCAT one doesnt say NOCAT and the one that says -EXT?
  52. callous

    callous Network Guru Member

    I found the shibby 104 for E3200 to be unstable for this version. After several weeks the router will just freeze up multiple times in a day. The firmware does say it is a test firmware.

    This is not a complaint at all as everyone is appreciative of the time and effort spent on this by shibby, tvlz, toastman and likely soon fractal (thanks guys!), but rather to tell the others to test with caution.
  53. callous

    callous Network Guru Member

  54. El Maestro

    El Maestro Serious Server Member

    Oops, was expecting support for 5Ghz with my E2500 and sadly found that only 2.4 is supported in last Toastman's... Going back to Tvlz 0001.1...
  55. callous

    callous Network Guru Member

    Yep, confirmed:

    has no 5ghz support for the E3200 in latest Toastman build 1.28.0501 :(((

    I did a 30-30-30 and also reboot, and restore default settings but no joy
  56. alfred

    alfred Networkin' Nut Member

    I have a WL-330gE, but I don't know which is the correct 1.28.7501 file for 330gE?

    Should it be named by ND, MIPSR1?
  57. kyrios

    kyrios Serious Server Member

    Quick question.
    I own E4200 and RT-N16 and both loaded with latest Toastman.
    At RT-N16 (Advanced => Miscellaneous => CPU Freq) is there.

    At E4200, I can't find the menu.
    Is it safe for E4200, to NVRAM set clkfreq 453,226,113 ?
    Default is 480,240,120.
    I mean can we downlock E4200? Just like RT-N16?
  58. RonV

    RonV Network Guru Member

    Anyone know how to get the v6in4 to graph on the 24 hour chart? It shows up just fine in the real-time chart but all I see in the 24 hour chart is my v4 interfaces: WAN (vlan2), WL (eth1), br0, eth0, imq0, tun21, vlan1

  59. iamhacked

    iamhacked Serious Server Member

    I almost bricked my RT-N16 trying to flash tomato-K26USB-1.28.7501MIPSR2Toastman-RT-Ext.trx with the Firmware Restoration utility (from your 4shared links). The automatic recovery hanged at 33% and told me it's not in recovery mode. After that, I couldn't even get it into recovery mode. Luckily, I reverted back to stock using this guide http://www.shcherbyna.com/?p=1403

    What did I do wrong to almost brick it?
  60. Riddlah

    Riddlah Networkin' Nut Member

    If you are using Recovery Tool, it will always hang at 33 or 35% (I can't recall). It will also give that error message after a couple minutes once the application timeouts. However, the flash usually goes through even if it doesn't show it. If you are using this version, I would suggest pinging the router to see when the reboot finishes.

    Version of the Recovery Tool does show the complete process.

    I did flash both 1.28.7501 and 1.28.0501 and both go through without any issues.
  61. iamhacked

    iamhacked Serious Server Member

    I couldn't ping the router either, but Windows Firewall wasn't disabled when I was trying to flash Tomato. That might be what caused the trouble. I'll try again using the stock - DD-WRT - Tomato method.
  62. kyrios

    kyrios Serious Server Member

    Confirmed with Riddlah.
    use Rescue
  63. tvlz

    tvlz Addicted to LI Member

    You did use the reset button on the bottom of the router,
    they both use the same code so it should be working
  64. callous

    callous Network Guru Member

    I did use the reset button on the bottom of the router. I dont know why it is working for 2500 but not 3200.
  65. iamhacked

    iamhacked Serious Server Member

    Hmm.. I don't know why my printer (HP Laserjet 1010) and external HD isn't showing up [​IMG]
  66. alexlau

    alexlau LI Guru Member

    Not sure whether this is the appropriate place for this question: is anyone using Toastman's build experiencing the same problem as described here: http://tomatousb.org/forum/t-452707/e4200-unstable-crashing-with-bw-limiter-enabled-toastman ?

    My E3000 is having the same problem: Turned on the IP bandwidth limiter and the IP bandwidth monitoring, after a few hours, the router will drop connection and the only thing I can do is to switch off/on the router. There are about 9-10 wireless connection and 2 wired connection. It happens to the recent 3 builds and I didn't try older ones...

    Is there any particular setting I have to do for the IP bandwidth monitoring?

    Thank you Toastman & everyone for the help~
  67. the_bhagwan

    the_bhagwan Network Guru Member

    what happened to page 16 of this thread? 10 days missing.
  68. ghostdance

    ghostdance Serious Server Member

    I can enable and disable "Core USB Support" option through web-interface. What command in telnet I can write for same effect?
  69. shibby20

    shibby20 Network Guru Member

    nvram set usb_enable=0
    nvram commit
    service usb restart

    usb_enable=1 will enable usb support.
  70. lissny

    lissny Networkin' Nut Member

    shibby can u reply me...​
  71. frojnd

    frojnd Networkin' Nut Member

  72. frojnd

    frojnd Networkin' Nut Member

    I would love to give a like to a person who suggested me to read this article: http://code.google.com/p/tomato-sdhc-vlan/wiki/MultiSSIDHOWTOForWRT54GL but unfortunately some posts are missing ?!

    After following it I was able to see and connect to wirtual ssid. So thank you person who suggested me this article!

    Furthermore can someone suggest me how can I configure NAT so people who are on virtual ssid can't reach primary wlan/lan?
  73. Toastman

    Toastman Super Moderator Staff Member Member

    Apologies all, it seems like the site host has had a problem and restored from a backup...
  74. Tom Parkison

    Tom Parkison Networkin' Nut Member

    OK, so Linksys has a Zero-Day Exploit on their hands. Apparently several Linksys routers are vulnerable to attack.

    Is your firmware vulnerable? Or am I safe?
  75. Monk E. Boy

    Monk E. Boy Network Guru Member

    Any chance you could repost the details for changes in 7501.2/0501.2? Between vacation and the hectic first week back on the job I managed to miss out on that release.
  76. gs44

    gs44 Networkin' Nut Member

    since page 16 is gone I shall repost...lol

    possible bug:

    every new build since 7500.2 has introduced lag all around with IPV6 6in4 static tunnel on my E3000
  77. gs44

    gs44 Networkin' Nut Member


    Nevermind, I think it is my tunnel broker haveing issues, not sure though...
  78. Mangix

    Mangix Networkin' Nut Member

    not a 0day. and also not dangerous.
  79. Crumb1910

    Crumb1910 Serious Server Member

    User gone, post gone, I think I have to ask again:

    I bought myself two Asus RT66U and put Tomato on it, build tomato-K26USB-NVRAM64K-1.28.0501MIPSR2Toastman-RT-N-VLAN-Ext.
    It's working perfect, thanks Toastman.

    I'm using the multi-SSID feature together with VLAN's to separate the traffic from my normal WLAN from that one of my guest WLAN. I would like to use the MAC address filtering and the AP isolation feature as well. Actual both features are available on interface level, not SSID level. This would mean I have use the same MAC address filter on my guest WLAN, what not make sense for a guest WLAN. Other way around with AP isolation, this would make sense for a guest WLAN, but not so much for my normal WLAN.

    Is it planned for a future release to implement this features on a per-SSID-level (virtual-interface-level), so it would be possible to filter only on one SSID and not on the other one ?

  80. JugsteR

    JugsteR Serious Server Member

    Sounds like a neat thing to have.

    Signature? Signature!
  81. Toastman

    Toastman Super Moderator Staff Member Member

    January 10 2013 - 1.28.7501.1 and variants

    replaced by

    January 11 2013 - 1.28.7501.2 (fixes a few errors)

    - Add new L7 filter for Youtube - thanks to Porter
    - Revised QOS Classification rules - mainly changed the order
    - Added TC-ATM overhead calculation for DSL - thanks tvlz for the patch!
    - Cosmetics - Bandwidth Pie selector

  82. vlads

    vlads Serious Server Member


    SSH doesn't work in tomato-K26-1.28.7501.2MIPSR2Toastman-RT-MiniIPv6. The dropbearmulti executable and the associated symbolic links are missing from the build.
  83. Toastman

    Toastman Super Moderator Staff Member Member


    I am not at home and not able to do much. However, no changes have been made that should affect SSH in any way. I just used SSH to access my router there, and as far as I can see it's working normally - that uses the EXT build. I forget now if SSH is disabled from the miniIPv6 build.... ???

    EDIT - I managed to access git repository - and yes, SSH is not enabled in that build.
  84. heebo1974

    heebo1974 Serious Server Member

    Any possibilities to get these upgrades to older releases ? Like tomato-ND-1.28.7633.3-Toastman-IPT-ND-Std.trx.
  85. rhdcheme

    rhdcheme Addicted to LI Member

    Just wanted to report that I have a E4200 V1 running very nicely (fast wireless speeds, no problems with DLNA, and no problems with online gaming) on v1.28.0501 MIPSR2Toastman-RT-N K26 USB VLAN-Ext.
  86. slowspeed3

    slowspeed3 Serious Server Member

    im using a Asus RT-N16 and was on Tomato Firmware v1.28.0500 MIPSR2Toastman-RT K26 USB VPN and upraded to the newest build but my config wont restore, says invalid hardware - can someone repost 1.28.0500 or 1.28.0501 if not 0500 for me so i can go back? things were working fine , please help ( its not in repo)
  87. adlerfra

    adlerfra LI Guru Member

    Toastman. Your latest version is running great on my RT-N16.
  88. Morac

    Morac Network Guru Member

    I upgraded my E3000 from Tomato Firmware v1.28.7500.4 MIPSR2Toastman-RT K26 USB VPN to Tomato Firmware v1.28.7501.2 MIPSR2Toastman-RT K26 USB VPN and am seeing instances where I'm getting random long periods of packet loss on my iPhone and iPad (one running 2.4 and other 5). Not sure why. I've found rebooting the devices helps for a bit.
  89. the_bhagwan

    the_bhagwan Network Guru Member

    This new one was giving me QOS problems:
    When the kids were on YouTube and Netflix I noticed significant lag with web surfing.

    could be some random problems with my ISP and not the build I suppose?

    For now I've reverted back to:

    Model Belkin Share Max N300 (F7D3301/F7D7301) v1
    Chipset Broadcom BCM4716 chip rev 1 pkg 10
  90. pharma

    pharma Network Guru Member

    Not sure if you checked and compared the Classification rules order, but since this changed in 7501.2, specifically "Revised QOS Classification rules - mainly changed the order", the lag you notice is IMO expected/normal unless you changed the order of your Classification rules back to match what you had in 7500.4. Changing Classification rules order is normally done individually as a QOS fine-tuning tweak.

    Everything is going great with version 7501.2 ... no issues to report.
  91. the_bhagwan

    the_bhagwan Network Guru Member

    I think you are right. For some reason my classification rules didn't get changed. A left over from the older build in the NVRAM. going to try 7501.2 again, Thanks!
  92. the_bhagwan

    the_bhagwan Network Guru Member

    Duplicate post, sorry
  93. Bill_S

    Bill_S Network Guru Member

    Help, I am confused. I have two WRT54GS's, one is version 1.1 the other is version 4 and I would like to install Toastman on them. What confuses me is the issue of which Kernel to use. Should I use Kernel 2.4 or 2.6? Can someone clear up my confusion with a recommendation on the correct Kernel?
  94. Toastman

    Toastman Super Moderator Staff Member Member

    Do take a good look at the rules before you change them back, to see why they were changed ... LOL

    Remember too, these are example rules, and they are deliberately split into many rules to make diagnosing problems easier. They are slanted towards making internet access reliable in a large apartment block with users outside of the control of any admin. So the QOS rules have to be strict, and we don't necessarily allow or tolerate any infringements - we simply don't guarantee VOIP/Skype Video/P2P etc. will work.

    Example - You will see some Skype video gets classified as "crawl" as it is UDP. If you need to allow it, set incoming and outgoing "Crawl" class bandwidth to, say, rate 5% and limit 60% or whatever you feel is needed. For HD video, set to allow 1.2Mbps in both directions. Remember this will then allow ONE connection - if say 3 users need to run HD video at the same time, you would need 3.6Mbps in both directions. Note that P2P will then also be increased and will hog the class, unless you create a different rule only for skype.
  95. Toastman

    Toastman Super Moderator Staff Member Member

    Bill_S - use the 2.4 kernel for this router. A 2.6 version specifically compiled for MIPSR1 will also work but in my experience is slower and rather prone to crashes. So I don't make them now.
  96. Bill_S

    Bill_S Network Guru Member

    Thanks Toastman, one final question. I wanted to have IPv6 but I don't see it in the 2.4 kernel, is it available in the 2.4 kernel build?
  97. Bill_S

    Bill_S Network Guru Member

    I can't find MiniIPV6 - no USB, no CIFS, no Zebra + IPv6, is it not available in the latest build for Kernel 2.4?
  98. Monk E. Boy

    Monk E. Boy Network Guru Member

    As far as I know, to get IPv6 you need a 2.6 kernel.

    I may be wrong, but that's how its been for ages.
  99. Bill_S

    Bill_S Network Guru Member

    Bummer, here is what Toastman posted about 2.6 kernel.
    It would seem that since he is no longer making 2.6 kernels and they are slower and prone to crashes IPv6 is out for me.
  100. Mercjoe

    Mercjoe Network Guru Member

    He is not making the 2.6 kernel versions for the older routers that use MIPSR1 coding. There is just not enough room in the flash for the coding required. Thus too many compromises have to be made in order to make it fit. Not to mention the processors tend to be slow further slowing down the whole apparatus.

    ALL the firmware that he makes for the MIPSR2 routers use the 2.6 kernel.

Share This Page