Tomato Toastman's Releases

Discussion in 'Tomato Firmware' started by Toastman, Dec 18, 2011.

  1. Victek

    Victek Network Guru Member

    Due to changes from the dnsmasq author, he expect that you used other OS ... problem is solved, git pushed in Tomato RAF

    Jan  1 01:00:53 RT-N16 init[1]: Asus RT-N16: Tomato 1.28.9013 MIPSR2-RAF-V1.2d K26 USB
    Jan  1 01:00:53 RT-N16 user.debug init[1]: 182: pptp peerdns disabled
    Jan  1 01:00:53 RT-N16 dnsmasq[545]: exiting on receipt of SIGTERM
    Jan  1 01:00:53 RT-N16 dnsmasq[571]: started, version 2.67test14 cachesize 1500
    @koitsu I'm sorry to read it.. keep health first ..
    Last edited: Sep 19, 2013
  2. Lorenceo

    Lorenceo Networkin' Nut Member

    Which build will work on an Asus N66u HW revision B1?
    I just tried RAF tomato-K26USB-1.28.9013MIPSR2-64K-RAF-V1.2e, and native IPv6 via DHCP-PD does not work still. :(
  3. Toastman

    Toastman Super Moderator Staff Member Member

    Victek sorted the dhcp-quiet issue, The code was in fact still in the build but due to the way that dnsmasq has been updated by the author, some conflict occurred. Vic has added dhcp quiet checkbox for both dhcpv4 and dhcpv6 so that no manual entry will be required in the custom box :)

    Thanks Vic, nice work!

    @Beast - no idea why ftp permissions would change, no change was made that I am aware of. Any idea what was the last version that worked ok?
  4. Beast

    Beast Network Guru Member

    Toastman (just a reminder, I HAVE NOT YET TESTED THIS VERSION) for the 550 permission error. But I went back in posts and found this...

    So for me the version was ( tomato-K26USB-1.28.0501.3MIPSR2Toastman-RT-N-VPN.trx)
    POST by alfred

    About FTP "550 Permission denied" issue:

    I have tested:
    both got "550 Permission denied" issue.

    After reverting back to
    then it works fine.
  5. Toastman

    Toastman Super Moderator Staff Member Member

    ok thanks, I'll take a look at it
  6. tvcat

    tvcat Networkin' Nut Member

    hi toastman,
    can you include the full range vlan tagging by teaman? thanks.
  7. Toastman

    Toastman Super Moderator Staff Member Member

    All of Teamans code is already included.
  8. tvcat

    tvcat Networkin' Nut Member

    Ok thanks.
    Router: ASUS RT-N12C1
    Firmware: v1.28.0500 MIPSR2Toastman-RT-N K26 VLAN-Std

    The problem is i cant get any connection from the tagged port 4. It is working if i deselect the tagged checkbox.

    There is some problem with this router:
    1. The indicator light of the wifi and internet is reversed.
    2. the port number is different with the vlan gui.\
    port wan on router = port 4 in vlan gui
    port 1 on router = port 3 in vlan gui
    port 2 on router = port 2 in vlan gui
    port 3 on router = port 1 in vlan gui
    port 4 on router = port wan in vlan gui


  9. Victek

    Victek Network Guru Member

  10. kthaddock

    kthaddock Network Guru Member

    If you "tagged" port 4 you must meet with tagged device. If it's last before PC you don't have to tagg that one.
  11. tvcat

    tvcat Networkin' Nut Member

    Oh sorry i missed your reply, i will upload tomorrow.

    so what you mean is that i can only use tagged port with tagged device?
  12. kthaddock

    kthaddock Network Guru Member

  13. Mercjoe

    Mercjoe Network Guru Member

    The latest version--> Tomato Firmware v1.28.7503 MIPSR2Toastman-RT K26 USB VLAN-VPN-NOCAT , causes WDS issues after approx. 24 hours. The WDS link is lost and it drops off the device list.

    Resetting it is as simple as going on the Basic -> Network page and clicking save. The link is then restored for another 24 hours.

    I never had the link drop out on the previous version.

    The remote router uses Tomato Firmware v1.28.7634 Toastman-IPT-ND ND Std
  14. illumilore

    illumilore Networkin' Nut Member seems to no longer consider the automated IP address update that this firmware can do as updating your account, and wants the user to log in in a more manual way. Is there a way to update the dyndns client in this to fix this problem?
  15. tvcat

    tvcat Networkin' Nut Member

    I suggest use other ddns service. I changed to freedns since they need manual login to keep the account alive.

    Sent from my Nexus 4 using Tapatalk 4
  16. Zre.3000

    Zre.3000 Reformed Router Member

    Just installed tomato-E3000USB-NVRAM60K-1.28.7502.1MIPSR2Toastman-RT-VPN.bin on my Linksys E3000.
    Everything I tried so far works fine except reporting memory in SNMP. Can this be fixed somehow by editing /tmp/etc/snmpd.conf or ...?
  17. nurofen

    nurofen Serious Server Member

    IPTV + VLAN everything works fine!
    Last edited: Oct 3, 2013
  18. RMerlin

    RMerlin Network Guru Member

    Policy change from DYnDNS> They require you to actually log into your account through the website at least once a month. Not something that could be trivially automated.
  19. lancethepants

    lancethepants Network Guru Member

    Time try a new place I think. Too much of a hassle.
    My favorites are and dnsexit. Both allow the use of any domain you own, and are free!
    Also worth mentioning. StartSSL for free unlimited SSL certificates that are browser trusted.
  20. AlexF

    AlexF Serious Server Member

  21. RMerlin

    RMerlin Network Guru Member

    I agree. This is clearly to drive more free users into paying. Personally I have a problem with coercion. If I end up paying, chances I'll pay a different provider because of this.

    If you want more free SSL goodies, I use Comodo's free DigitalID for email encryption (Free for personal use; valid for a year).
  22. lefty

    lefty Networkin' Nut Member

    Seems to be a growing trend with dynamic DNS providers.
  23. nurofen

    nurofen Serious Server Member

    Thanks for the firmware!
    Last edited: Oct 3, 2013
  24. Morac

    Morac Network Guru Member

    I'm running tomato-E3000USB-NVRAM60K-1.28.7502.8MIPSR2Toastman-RT-VPN.bin on my Linksys E3000, so it's not the latest, but it's been running fine with the exception of an issue I had yesterday, which isn't in the list of fixes for the new version.

    I went to add a new device to the wireless filter list, so I turned off the filter, added the new device and went to turn the filter back on it said saving changes and restarted services and then WEB server appeared to die. Connections to it would time out. I SSHed into the router, but couldn't figure out how to get the server back up and running (I didn't try killing httpd and restarting though), so I rebooted it.

    When it came back up, the web server was fine, but the filter hadn't been enabled. I enabled it and it appears to be fine so I don't know why the web server died.
  25. though

    though Network Guru Member

    hey toast-

    do you plan on making this available on the RT-AC68U which should be available in a couple weeks?

    thanks in advance!
  26. Toastman

    Toastman Super Moderator Staff Member Member

    @AlexF - Thanks!

    @though - I don't have any free time to do so at the moment, and I don't have one of those routers. The others are working on it, maybe later. Victek mentioned it recently, perhaps he will reply.
  27. RMerlin

    RMerlin Network Guru Member

    The RT-AC68U is a radically different architecture - totally different CPU platform (ARM). Supporting it will definitely involve a lot of work.
  28. kyrios

    kyrios Networkin' Nut Member

    But it shall be lesser work once beta AC-56U is ready, right?
  29. RMerlin

    RMerlin Network Guru Member

    That should help, yes, but there's still a lot of work involved to get to that first step.
  30. nurofen

    nurofen Serious Server Member

    Correct the time zone in the city of Moscow ;)
  31. korenisko

    korenisko Networkin' Nut Member

    Hi all,
    actually Im using Toastman build STD from 19.9.2013 on asus rt-n16. It worked very well configured to use 3G usb modem as WAN. But after 5-8 days router lost connection to internet. I rebooted router via web gui, but no connection to internet. Changed wan settings to DHCP, saved and rebooted. Then again configured wan to use 3G modem. But it couldnt connect. I checked modem and it was connected to internet, only router hadnt connection. So I phisically unplugged it from usb port and replugged. In one or two moments - internet worked via router.
    3G modem is Huawei E367.

    This oddy behaviour I had seen on other tomato builds from other devs. Is there some solution or any more stabble build to use it as 3G router?
    Thanks for advice
  32. kyrios

    kyrios Networkin' Nut Member

    See the log whether the USB device has switched to modem or not.
    If yes, try to longer Redial period to 30s or longer. 10s is too short
  33. korenisko

    korenisko Networkin' Nut Member

    Kyrios, thank You for help me out! I checked and there was 30s, so I changed it to 40s and router connected to internet smoothly. I had this problem in every build of tomatousb. Finally, I do not need to flash again to another :)
    I have one more problem with ftp service. I have enabled lan and wan acess but Im getting 550 (permission dennied error. So, cant copy to hdd via ftp. Is there any solution for this?
  34. Toink

    Toink Network Guru Member

    Is your FTP connected to your USB/Wireless Plan? Do you have a STATIC IP on your wireless plan? AFAIK, wireless plans have Dynamic IP's and are usually behind a proxy. Incoming FTP connections from outside IP's is impossible.
    Last edited: Oct 4, 2013
  35. korenisko

    korenisko Networkin' Nut Member

    I have dynamic public IP and with that ip I havnt any proxy. I have router connected to service and it working well. I can connect to ftp via internet and ftp client can list folders, but I cant write to it.

    I tried now to transfer some files, it comes with 550 - Permission denied.
    Last edited: Oct 4, 2013
  36. kthaddock

    kthaddock Network Guru Member

    Have you set permission under: USB and NAS => FTP server => User Accounts => Read/write ?
  37. korenisko

    korenisko Networkin' Nut Member

    Yes, I have it enabled to write and added account to ftp, not admin one.
  38. kthaddock

    kthaddock Network Guru Member

    Try to set Read/write and test again. Have you specified a directory also? ex /mnt/sda1/
    Last edited: Oct 4, 2013
  39. Beast

    Beast Network Guru Member

  40. korenisko

    korenisko Networkin' Nut Member

    Thanks guys, Ill check and do changes when I arrive home, because for some reason, router is not acessible via internet now :O

    so, after comming home my router lost internet connection again (probably because ISP dyn IP change?) So, I tried to reboot via web gui, not connected, tried un-re-plugging usb modem and then it connected sucessfully. Morning I increased reconnect interval to 40s, now I changed it to 60s. I dont know, where is problem. Sometimes internet is working, router gets new ip (probably), sometimes it lost connection. But one weired thing is, that 3G dongle is connected to internet (blue led is lighting)

    I did changes on ftp and finally write is working.
    Last edited: Oct 4, 2013
  41. korenisko

    korenisko Networkin' Nut Member

    Last problem remains :-( Nobody knows?
  42. nurofen

    nurofen Serious Server Member

    When a new version to test the ? :)
  43. xtacydima

    xtacydima LI Guru Member

    Think we will ever see more than 50 rules possible for port forwarding?
    For those of us whom run servers and NAS devices the forward spots go fast.
  44. Toastman

    Toastman Super Moderator Staff Member Member

    How many do you think is reasonable?
  45. eahm

    eahm LI Guru Member

    I'd say 25 million.
  46. RMerlin

    RMerlin Network Guru Member

    Personally I went for 2^7. If someone were to come to me asking for more, I'd tell him he seriously needs to rethink his network topology :)
  47. Toastman

    Toastman Super Moderator Staff Member Member


    Hmm. I port forward from the gateway router to each of the access points so I can reach them for maintenance, that accounts for around 30 or so usually. 50 seems reasonable to me

  48. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Seriously though, if Tomato is successfully ported to ARM then more people will be trying to use SOHO routers in these ways, and with existing hardware and heavy loads, some people may prefer to use manual port forwarding rather than plug n play methods.
  49. RMerlin

    RMerlin Network Guru Member

    The main worry there would be how big would the vts_* nvram setting potentially reach. Since Tomato already deals with really large entries (3000-ish characters for large certificates for OpenVPN), 128 should be a nice round number, without introducing any new issue that doesn't already exist (the RT-AC56U CFE doesn't like nvram values larger than a certain size, it causes the CFE to either skip some settings at boot time, or hang when doing an nvram dump from CFE).
  50. Beast

    Beast Network Guru Member


    Any news why we need to add the write permissions manually to the FTP server. ????
  51. Toastman

    Toastman Super Moderator Staff Member Member

    No, I have not had time to look at it yet.

    EDIT - I see the problem, it was an error introduced by a commit a while back. I will fix it soon.

    @ rMerlin - 128 port forwards coming up soon. Remember, guys, all these large numbers of rules for various features come at a price - you do need enough NVRAM space. Be careful and keep your eye on it!
  52. internalaudit

    internalaudit Reformed Router Member

    A question on which Toastman firmware to use for my Linksys WRT310N V2 routers (
    nvram Size = 32kb)

    Because this webpage says my router is K26

    Does this mean this is the right folder I should be getting my firmware from?

    RT (MIPSR2 - newer, like RT-N16, E3000,WNR3500Lv1 etc) - NORMAL BRANCH > 1.28.7503 STD - BETA >

    Because it doesn't come with USB and the NVRAM is 32kb,
    I should be choosing the first file, correct?


    3.7 MB 09-19-2013


    4.1 MB 09-19-2013


    5.2 MB 09-19-2013

    Thanks so much
    Last edited: Oct 10, 2013
  53. eahm

    eahm LI Guru Member

    Toastman, your VLAN build still doesn't have br1-2-3 limiter? I remember you did integrate it few months ago? Sorry, I just noticed because I normally use the STD Std.
  54. though

    though Network Guru Member

    hey toast (or anyone else that may know)-

    i am going to my grandpa's this weekend and want to upgrade the toast build on his BUFFALO WHR-G125 which is 5 yrs old. it currently has 1.27.1798.

    do i use ND 2.4 or ND 2.6 !??!?!? thanks!

  55. Toastman

    Toastman Super Moderator Staff Member Member

    @internalaudit - the first should be ok

    @eahm, no, I didn't. I wasn't happy with the result, I found it unstable :eek:

    @though - use a 2.4 build ..
    internalaudit, eahm and though like this.
  56. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    toastman, sometime around sept i tried your latest firmware for my linksys e4200v1 router but the wifi n was not good.

    So i used your stable build "Tomato Firmware v1.28.0502 MIPSR2Toastman-RT-N K26 USB VLAN-VPN-NOCAT" which works fine no issues.

    My question is, has the newer firmwares fixed the wifi issue ?

    PS: i tested Victeks TomatoRAF new firmware which too had the same issue as yours concerning the wifi.
  57. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    What was the WiFi problem you experienced?
  58. Toastman

    Toastman Super Moderator Staff Member Member

    I never saw a problem with wifi on later builds, so I think nothing has changed.
  59. eahm

    eahm LI Guru Member

    My god, I've tested Victek's VLAN 1.2k for one day, awful awful awful. The WiFi, especially 5GHz, keeps disconnecting, not all the time but it's not stable at all. The BW Limiter was ON on br1.

    Went back to Toastman's VLAN Std, I have to keep a VLAN for few months. Seems all good for now.

    I will try the new Shibby with new 6.x drivers when released.
  60. Solace

    Solace Networkin' Nut Member

    did you use

    Default Class for unlisted MAC / IP's in LAN (br0)

    or any of the other options? i noticed that enabling that feature will cause instability within the router causing fluctuating pings and loss of connectivity for some odd reason but the normal bw limiter works plenty fine standalone. i reported this months ago and then i believe the feature was removed.
  61. CardinS2U

    CardinS2U LI Guru Member

    hi toastman!

    was wondering does your distro support Asus RT-AC66U???
  62. Toastman

    Toastman Super Moderator Staff Member Member

    @CardinS2U - no, I will not add support for it until I am happy that it seems stable as I don't have one of those routers here.
  63. eahm

    eahm LI Guru Member

    No, just br1 limiter.
  64. Victek

    Victek Network Guru Member

    Please give concrete details, settings and configuration. The wireless driver are the same for both firmwares. Wireless 6.x drivers still shows low power performance, but more stable than 5.x
  65. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    well the behaviour i noticed...

    login wifi works. but after a while it would sort of disconnect. the internet won't work unless manually reconnecting the wireless, but it would still be the same problem again after a while.

    Also probably slightly laggier/unresponsive.

    i tested both 2ghz and 5ghz modes, but same thing. This is for wireless N. I didn't test other modes than that.

    But the older firmware just works no issue :/ so was a big difference in stability for me.

    Of course, everytime i upgraded the firmware, i cleared/flush nvram as usual. And i manually entered settings, not load from old settings. So that probably wasn't why :/
  66. phgghy

    phgghy Reformed Router Member

    I have noticed this ftp write problem since 1.28.7501. And I've been doing the same workaround that people have mentioned above by manually setting write enable. It works for a little while and then the ftp write problem persists after that. Hopefully it will get fixed in the next build.

    I also like to mention that ftp support did work very well on tomato-K26USB-1.28.7497 which was the first toastman tomato I used.
  67. Toastman

    Toastman Super Moderator Staff Member Member

    The ftp permissions will be fixed in a new release, wait a day or two.
  68. korenisko

    korenisko Networkin' Nut Member

    And 3g issue?
  69. Toastman

    Toastman Super Moderator Staff Member Member

    If you can give information as to what exactly is wrong with it, maybe that would give someone an incentive! None of the developers live in Moscow ...
  70. eahm

    eahm LI Guru Member

    Sorry Victek, I was talking about the BW Limiter, nothing personal against your mod or the wireless drivers but I was just confirming what Toastman was saying for months, that the BW Limiter needs to be redesigned from scratch.
  71. Ezrem

    Ezrem LI Guru Member

    Hi, I have a RT-N66U running Tomato Firmware v1.28.0494 MIPSR2-Toastman-RT-N K26 USB VPN. I am planning to update to tomato-K26USB-NVRAM64K-1.28.0503MIPSR2Toastman-RT-N-VPN.trx. I think that is the right version to go to to get updates as well as 64K NVRAM support?

    What's the best procedure to update? Should I just do a GUI flash with After flashing, erase all data in NVRAM memory checked, or is there something more involved I need to do?
  72. Victek

    Victek Network Guru Member

    Ah, sorry, yes, it was redesigned again, it works now...

    @Ezrem upgrade ticking erase nvram and then enter all settings manually again, it's the safe method.
  73. Ezrem

    Ezrem LI Guru Member

    @Victek - thanks, I thought so, just wanted a sanity check.

    Hopefully the NVRAM64K part is okay too!
  74. Victek

    Victek Network Guru Member

    If you had 32KB version or B2 hardware version take care, might be necessary to erase nvram again once you upgrade it.. safest.
  75. Ezrem

    Ezrem LI Guru Member

    Yes, I'm currently on a 32KB version firmware, as well as this being one of the original run RT-N66U's when they were first released and nearly impossible to find. Still safe to load the 64K image?

    Thanks so much for your help!
  76. Victek

    Victek Network Guru Member

    I think yes, better wait Toastman confirmation, nevertheless if the upgrade fail you can revert easily using Asus restoration utility.
  77. Toastman

    Toastman Super Moderator Staff Member Member

    I can't confirm myself as I don't have one of those routers, but other people have reported it works OK. But as Vic says, the ASUS recovery tool makes it easy to revert or try another build.
  78. eahm

    eahm LI Guru Member

    The one I've tested was 1.2k, it didn't work very well for br1/2/3.
  79. nurofen

    nurofen Serious Server Member

    Hi! Toastman, Come for a visit! You have beautiful themes control panel! I use Asus N66u. Installed firmware tomato-K26USB-NVRAM64K-1.28.0503MIPSR2Toastman-RT-N-VLAN-Ext.trx. 1) Not correctly shows time. Correctly as in the picture:


    2) On your firmware is not working wifi, the default settings. Can not get ip address LAN.

    (on firmware RAF wifi works well)

    thank you.

    It is unfortunate that Victek does not collect firmware Ext :)
    Last edited: Oct 16, 2013
  80. Elfew

    Elfew Network Guru Member

    Ext - what is extra in this build? What victek build doesnt contain? Thank
  81. nurofen

    nurofen Serious Server Member

    @Elfew, Victek there is no time to assemble Ext. Close the topic. I do not want you angry:D

    thank you.
  82. Elfew

    Elfew Network Guru Member

    Ok, live long and prosper :)
  83. Toastman

    Toastman Super Moderator Staff Member Member

    I believe Moscow time should be +04:00, next build will correct that

    I don't find anything wrong with wifi. Works ok here!
  84. nurofen

    nurofen Serious Server Member

    I do not know why, but I have wifi does not work HTC sensation. Does not give the address of the DHCP.

    Firmware RAF wifi works fine! Tomato RAF Firmware v1.28.9013 MIPSR2-RAF-V1.2n K26 USB
    - Linux kernel and Broadcom Wireless Driver updates

    Picture settings firmware RAF:

    Toastman, thank you :)
    Last edited: Oct 17, 2013
  85. kthaddock

    kthaddock Network Guru Member

    Try to use fix channel instead of auto. Use channel 1-6-11.
    Delete your wireless config in HTC and reconnect again.
    nurofen likes this.
  86. nurofen

    nurofen Serious Server Member

    @kthaddock, Why not work on automatic settings? Thank you, do not have time to check :)
  87. kthaddock

    kthaddock Network Guru Member

    Can be problem if your surroundings contain alot of other wifi users.
    Maby you can obtain better function if you turn on "Interference Mitigation" mode 4

    To save battery in your HTC you may turn on: APSD mode"on" and DTIM interval to "3-4".
    But test to change channel to fix channel first.
  88. nurofen

    nurofen Serious Server Member

  89. Toastman

    Toastman Super Moderator Staff Member Member

    October 14 2013 - 1.28.7503.1 and variants (uploading now)

    (This release fixes a few bugs and adds some changes requested by posters)

    - fixed typo in access restrictions
    - netfilter: nf_conntrack: fix event flooding in GRE protocol tracker (victek)
    - added ethernet state to overview page - text only (based on Asus sources)
    - fixed ftp permissions bug
    - increase number of possible portforwards to 128
    - some small bugfixes

  90. Toastman

    Toastman Super Moderator Staff Member Member

    @nurofen - if "auto" is used your router will constantly be hopping from channel to channel, causing interference to others and receiving it from them. In other words, it's totally unpredictable, and is the cause of many people having good throughput one minute and bad the next. I personally think it is one of the stupidest additions to Tomato, and I keep meaning to remove it. :D

    A note about - they annoyed me so much I changed to minidns, which works very well and seems very reliable. It is supported in the Tomato GUI.
  91. nurofen

    nurofen Serious Server Member

    @Toastman,Well, I will install a new version ext asus rt-n66u and put the channel manually 1-6-11 :)

    thank you
  92. eahm

    eahm LI Guru Member

    Good choice about DynDNS, I first switched to No-IP years ago then to Never looked back.
  93. SlorNet

    SlorNet Reformed Router Member

    @Toastman - I gotta say, your releases are excellent work. Yesterday actually marked the very beginning of my Tomato usage, after a couple days of frustration trying to use the current DD-WRT mess (things sure have changed over the years since I flashed my WRT54G back in 2006) for my E4200 that I want to get a little better use out of now. A little web searching led me to find and grab your 0502.1 build with USB, VLAN, and VPN to upgrade the E4200. That's probably the best decision I'd made this week! Everything I've done on it has worked well, including the VLAN support that I have read might still be a bit experimental. I just needed a simple 2-VLAN separation in place, and it was easy as can be to get that configured in Toastman Tomato (I tried with DD-WRT about 8 times, having to do a hard reset after each unsuccessful try). From what I've seen, the build is solid, and it seems to support every feature I need and then some.

    Last edited: Oct 18, 2013
  94. Mercjoe

    Mercjoe Network Guru Member

    Flashed v1.28.7503.1 MIPSR2Toastman-RT K26 USB VLAN-VPN-NOCAT onto a WNR3500l.


    WDS seems to work fine now. Last build it was unstable and dropped after a few hours and had to be manually re-established periodically.

    IP traffic is inoperative. The graphs come up, but no data is displayed. No IP addressed on the top or any data. I cleared the data file and still nothing.

    YES; I re-flashed, cleared NVRAM and did a total manual reconfiguration each time and came up with the same results each time.

    As a side note, swapping menu to menus is slow as heck now with this version.
  95. SlorNet

    SlorNet Reformed Router Member

    @Toastman - One question about the 0502.1 build... I've noticed that, while I'm certainly getting plenty of network traffic through my E4200, the yellow activity lights never light up on any of the ports, LAN or WAN. They go nuts when the router is first turned on or reset, but it seems that something disables them at a point during the boot process. Is there any known issue regarding that? It's certainly not a big deal for typical use, but occasionally I do like to be able to look at the back of the unit and get a blinkety-blink feel for the network traffic. Any pointers would be appreciated.

  96. malakai1911

    malakai1911 Networkin' Nut Member

    Your firmware has been really awesome on my RT-N66U.

    I picked up an RT-N53, thinking it would be a good router for my mother (cheapish, basic, dual band and tomato), but I can't seem to find a Toastman build that supports the 5GHz band on it. Is there a particular variant that should be used on the N53? (I tried searching, but couldn't find a specific answer to that, I know Shibby builds a specific variant for the N53.)

    Thank you!
  97. Toastman

    Toastman Super Moderator Staff Member Member

    @Mercjoe - Everything works normally on all routers I have access to, GUI is extremely fast and responsive on LAN. Don't know what to suggest.

    @SlorNet - Thanks! Re the LAN sockets, the port lights aren't supported.

    @malakai1911 - I'll take a look at that later

    I added text based LAN port indicator as people seemed to want it and it does perform a useful function when used remotely. But I see it is showing some ports as 1Gbps when they are in fact 100Mbps. I tried other mods and as far as I can see the detection is not reliable. I may revert that feature later.
  98. RMerlin

    RMerlin Network Guru Member

    Do you have one of these routers to test things on, Toastman? If so I can provide you with two robowr commands that might allow you to enable the port LEDs (assuming they use the same registers as Asus's routers with similar Broadcom switches).
  99. Toastman

    Toastman Super Moderator Staff Member Member

    No, I don't have one, but we could try it anyway, and see if it works (with Slornet's help) ... thanks!
  100. RMerlin

    RMerlin Network Guru Member

    Try these two commands (in that order):

    et robowr 0x00 0x18 0x01ff
    et robowr 0x00 0x1a 0x01ff
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice