1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Toastman's Releases

Discussion in 'Tomato Firmware' started by Toastman, Dec 18, 2011.

  1. SlorNet

    SlorNet Reformed Router Member

    @RMerlin, @Toastman - Sure thing, I'll try them when I get home today. For about a half second, I thought I could try it out remotely, but then I realized it's hard to see LEDs from here... :)
    Python46 likes this.
  2. Toastman

    Toastman Super Moderator Staff Member Member

  3. JohnnyG76

    JohnnyG76 Addicted to LI Member

    (I posted this message on another forum, thought I'd come to the source for more help! :)

    I have the recent toastman firmware with vpn support running on my Linksys WRT310N (Tomato Firmware v1.28.7503 MIPSR2Toastman-RT K26 VLAN-Mini)

    Internet is working fine using this firmware once I've set my vlans. 33,34,35 (tagged 802.1q 32).

    I'm using this setup to hopefully completely replace my Actiontec router from FibreOP (Bell Aliant)

    Anyhow, my question is: How do I (if possible) set my VLAN 34 with pcp bit set to 4 (802.1p video tag) for Video?
    Do I have to add any other routes manually for any of this to work? (IPTV)
    Is there an alternative?

    Love this firmware!

    VPN setup screenshot
  4. SlorNet

    SlorNet Reformed Router Member

    @RMerlin, @Toastman - Unfortunately, those commands didn't produce any change in the LEDs. Still nothing from the yellows.
  5. RMerlin

    RMerlin Network Guru Member

    I guess they aren't wired to the usual 53115 registers then. Oh well, was worth a try.

    Someone would have to dig up the GPL for that model and see what they are doing to initialize those LEDs.
  6. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    U mentioned 1.28.7503.1 is the latest, however when i checked for the firmware for my router LinksysE4200 V1, it showed the latest for it was 1.28.0503.1

    But the time stamp for last updated was this or last week. So which exactly is latest, i'm confused :/
  7. Malitiacurt

    Malitiacurt Networkin' Nut Member

    In case anyone wants to dig it up, I believe Lightsword got firmware source for most Linksys models and uploaded it to sourceforge.

    eahm likes this.
  8. CTXSi

    CTXSi Network Guru Member

    The RT and RT-N builds have different numbers. The RT builds are 1.28.75XX while the RT-N builds are 1.28.05XX. Its the "XX" part that indicates they are the same.
  9. a_spider

    a_spider Reformed Router Member

    *is glad he bought DNS forwarding in 2002 from dyndns*... still have that account, and it never goes inactive because i'm a VIP ;) for my $30 one time payment, I've gotten 11 years of DNS forwarding so far. XD
  10. RMerlin

    RMerlin Network Guru Member

    Then it's because of you that they are trying to squeeze as much money as possible from us free users :)

    (just teasing ;) )
  11. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    ah i see.

    so seeing as i need 5ghz, so the RT-N is for me. The RT is the older 2.4ghz wireless only.
  12. lancethepants

    lancethepants Network Guru Member

    IPTraffic seems to be working alright for me.

    There is however a noticeable lag for the Status -> Overview page to load. (Maybe something to do with the ethernet port state).
  13. Toastman

    Toastman Super Moderator Staff Member Member

    Yes, it is the ports state that causes lag. It gets removed next build....
  14. SlorNet

    SlorNet Reformed Router Member

    Nice. I happened to have a paid/donation account (one-time, $15) with EveryDNS before Dyn took them over a few years ago. That got me a conversion to Dyn VIP with 50 nonexpiring Standard DNS services. If only for that reason, it's tough for me to dislike much about DynDNS. Though I wish they would support vanity NS records...
  15. SlorNet

    SlorNet Reformed Router Member

    Is this something we ("we" meaning someone who, unlike me, would know what to look for) could glean from the DD-WRT source code? My recollection is the traffic LEDs was one of the few things that worked properly when I tried a late-model DD-WRT build on it.
  16. Toastman

    Toastman Super Moderator Staff Member Member

    There will be a new version later, updated dnsmasq (thanks Simon) - with some fixes that we hope will improve the ipv6 experience. Thanks to Kevin Darbyshire-Bryant for the updates!

    I have reverted the ethernet ports state indicator.

    @SlorNet - nice service! I never had any complaint with dyndns free service. However, I do not like it when a "free forever" service suddenly turns bad and start deleting things that cause people tremendous problems. Seems to me I had several "free forever" mail services that did that to me already, and now it really makes me see red.

    I recommend freedns.afraid.org and minidns.net as being free and reliable. Josh, my thanks to you for what you did for the community all these years!
  17. Toastman

    Toastman Super Moderator Staff Member Member

    October 26 2013 - 1.28.7503.2 and variants

    - Revert "Ethernet State Report - text only"
    - update to dnsmasq 2.67rc4
    includes fix in tomato helper for non dhcpv6 compiles (thanks Shibby)
    includes an accept 'Wide Prefix' patch from Vlad
    @ http://wl500g.googlecode.com/svn/trunk/dnsmasq/020-relax-prefix.patch
    This allows constructed ranges to have forced larger prefixes
    on a smaller prefix interface - eg allow /64 on an interface that is
    a /48 - This patch is probably the holy grail we've been looking for
    and both Vlad & myself are hoping Simon accepts it. - Kevin
    - Fix dhcpv4 logging - was always in quiet mode
    - Dnsmasq 2.67rc4+24Oct13 patches + wrap the wide prefix patch into
    HAVE_TOMATO compilation blocks for ease of update
    - Dnsmasq v2.67 final release + Tomato tweaks ---->> up to date

    Thanks to Kevin Darbyshire-Bryant

    Padre and Elfew like this.
  18. gg_99

    gg_99 Reformed Router Member

    Has the "RT" section on 4shared disappeared? I was looking to apply my first toastman build to an e3000 this afternoon and noticed the section disappear while I was actively investigating which firmware I needed. Figured that maybe an update was coming but the section has not yet reappeared. Tried a couple of different browsers and my phone without luck.

    When it is available, would you consider 1.28.7503.2 a good place to start (as opposed to an older, perhaps more proven alternative)? I'm assuming that without the "beta" tag that the expectation is that it's stable.

    Looking forward to giving it a shot. And already enjoying how active this community is. Thanks for all you guys do.
  19. LanceMoreland

    LanceMoreland Network Guru Member


    I am anxious to try this version but I don't see any new versions or anything uploading.
  20. gg_99

    gg_99 Reformed Router Member

    Looks like patience is a virtue, and it's all back in place. I've downloaded "tomato-E3000USB-NVRAM60K-1.28.7503.2MIPSR2Toastman-RT-VPN.bin" and so will be watching for feedback on how this is working for everyone. Feel free, though, to suggest an older version that is known stable and might be a better place to start.

    Thanks all.
  21. gfunkdave

    gfunkdave LI Guru Member

    Hi Toastman -

    I have been using your firmware for the last couple years, and I've always been impressed. Just (finally) sent a small donation.

    Thanks again.

  22. Toastman

    Toastman Super Moderator Staff Member Member

  23. gs44

    gs44 Networkin' Nut Member

    Hi Toastman,

    Flashed me E3000 with latest RT Build and everything seems great, IPV6 via HE Tunnel functions as always.

    One side note to others: If you are using a windows 8.1 machine to flash your router DO NOT use the new IE11 included with Win 8.1....It will crash in the middle of the router flash. There was a update for IE11 issues, not sure if this fixed it or not, but not gonna try again as I almost bricked my router... I had to resort to google chrome to get a successful flash..lol
  24. Elfew

    Elfew Addicted to LI Member

    IE? Tell me who uses this browser... the worst browser for windows
  25. Toastman

    Toastman Super Moderator Staff Member Member

    @gs44 - Thanks!
  26. gg_99

    gg_99 Reformed Router Member

    @gs44 - thanks from me too. Installed nearly 24 hours ago on my e3000 and so far (basic config/use) so good. Glad to be on tomato now. And thanks, of course, to toastman as well.
  27. RonV

    RonV Network Guru Member

    I use it, best browser for windows!
    Last edited: Oct 27, 2013
  28. RonV

    RonV Network Guru Member

    I have been using the IE in Windows 8.1 to flash my routers since 8.1 preview. Sorry to hear that you are having issues but I have found IE 11 to be but a really solid browser. I am glad you found a way to flash from your system using another browser.
  29. eahm

    eahm LI Guru Member

  30. Elfew

    Elfew Addicted to LI Member

    @Toastman - any chance to get QOS working with IPv6?
  31. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

  32. DavidJ

    DavidJ Reformed Router Member

    Anyone else encountering problems with the Openvpn client in the 7503.2 build?

    I have an RT-N16 at home and one in the office. The office RT-N16 runs the Openvpn server and is on build 7503.1. Never a problem up till now. I updated the home router to 7503.2 and when I click on the Start Now button on the Openvpn client page nothing happens (not even an entry in the logs on either the home or office routers). I tried connecting using the Openvpn client on my PC and that worked fine so I don't think there's any problem at the office end. I've just reverted the home router to 7503.1 and the Openvpn client is working again. Problem with the openvpn client in 7503.2?

  33. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    Toastman, just wondering, since the original tomato creator stopped being active, the branches of tomato have been maintained.

    How come the other tomato developers don't come together and work on a unified firmware ? Or is there some diverse approach to the tomato development that prevents you guys from doing so :/

    I ask because it's confusing which firmware to use because there is so much being added to the different variants out there x_x;
  34. jerrm

    jerrm Network Guru Member

    I personally believe we'd be worse off with a unified approach. Each individual dev is free to pursue his interests, and the best bits generally get adopted by all. Any unified or committee approach would just slow things down.
  35. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    well i mean, why not add all the generally adopted code and make that the new tomato, and take it from there :X or is it still too early for that ?
  36. jerrm

    jerrm Network Guru Member

    Who decides what goes into this "unified tomato?" It would just be another mod and confuse things further.

    The maintainer would probably just it consider busy-work, and rarely update. Right or wrong, most folks want the latest and greatest and would skip over it for the latest Toastman/Shibby/Victek/WhoEversNext build.
  37. lancethepants

    lancethepants Network Guru Member

    Not all the developer do or would agree on what should or shouldn't be included.
    Toastman believes routers were meant to route (lol) and doesn't add a whole lot more than doesn't support that.
    Shibby/Victek add a lot of bells and whistiles, like torrent client, tor, webserver, dnscrypt.

    Really their goals are different.
    Toastman's motivation is to make reliable stable firmware with good effective QoS for use in apartments he admins.
    Shibby/Victek add lots of new and experimental features, and try to push the routers to their absolute limits.

    I like the diversity. They borrow code from each other all the time anyway, so most shared features will get upgraded in all firmwares.
  38. gs44

    gs44 Networkin' Nut Member

    my 2 cents... If its not broke, don't change it..lol
    The way it is now is basically they all have a "base tomato" that they all work/develop from and then each adds there own tweaks/bells/whistles as each sees fit giving us 3 flavors to choose from. Much better than a single flavor....

    A side note: This thread is for Toastman related stuff so if any feel the need to keep this going maybe starting a new thread would be the correct way to address this and let others chime in without takeing over Toast's thread with off subject discussions.
  39. Elfew

    Elfew Addicted to LI Member

    Yes, but QoS is useles with IPv6 and high speed connections.... It needs to be fixed
  40. gs44

    gs44 Networkin' Nut Member

    Considering one of Toatman's main focus is QOS I would have to assume once all the IPV6 basics are ironed out he will or others will help him with getting QOS and IPV6 to play together. IPV6 is basically new to most and not required as of yet in most locations, It will be of course in the future but for now why bug QOS with IPV6 Bugs in tomato until the IPV6 bugs themselves in tomato are fixed.
  41. Elfew

    Elfew Addicted to LI Member

    Ok, IPv6 is fully working with GUI interface (tested with my connection and fw from Victek).

    I can reach 194mbit with my rt-16n but when I enable QoS speed is under 90mbits..... :( and it doesnt work with IPv6. IPv6 is sound of future, must have feature in Tomato... QoS is usefull for many users with slow connection but for ipv6 users and users with high speed connections cannot be used....
  42. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    so basically neither victek or toastman have yet to have anything substantial in qos in regard to ipv6 :/ ? I heard it's related to coding in nftables in order to get the qos working right for ipv6 implementations.

    What about shibby? did he started yet on nftables :X
  43. Elfew

    Elfew Addicted to LI Member

    Victek wrote that he will maintain only his features - BW limiter, Web server, (VoIP server), Captive portal -> all of them all working with IPv6... QoS will not be maintain by Victek because he didnt code it and dont you it.

    There is problem with code and nftables... QoS is coded by Toastman so contact him, maybe he could maintain it and solve these issues - IPv6 compatibility and throughputs problems...

    Personally I dont you QoS, I use BW limiter with priority settings for my clients and it works without problem and it doesnt limit my throughput... but there are many users who need QoS
  44. Victek

    Victek Network Guru Member

    nftables is not implemented in tomato.. just to fix last posts. Each contributor to tomato have his own idea about what it's better for his flavour, in any case the base is common and can be checked in the git.
  45. Elfew

    Elfew Addicted to LI Member

    I agree, every dev should maintain a feature which released and coded...then share code and changes with others...
  46. bagu

    bagu Network Guru Member

    In a world of dream, we just have to check boxes and the website provide us the tomato build just for us (according to boxes checked)...But...Its a real world with many difficulties ;)
  47. Orwell

    Orwell Serious Server Member

    Is anyone else having issues downloading off of 4shared.com ?

    I've allowed all cookies and scripts in Firefox 24 and yet the 4shared.com free download wait timer is stuck on 20 seconds when attempting to download toastman's images.

    I've gone so far to try jdownloader, unsuccessfully. Jdownloader states that toastman images are only available to premium (paid) account holders. I assume this is unrelated and an issue with jdownloader.
    Last edited: Nov 4, 2013
  48. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    is there a guide to decipher the git. I try to look for changelogs for each new change.

    I even tried to sort by developer but it's like a maze x_x;

    So far i rely on the toastman shared changelog txt, victeks changelog, and shibbys changelog on the main site :/

    But gits a bit confusing to keep track of x_x;
  49. NitSuA

    NitSuA Reformed Router Member

    Hi, I have now idea if this is the right topic, but here it goes:

    I'm using the latest Toastman firmware for my WNR3500Lv1, with great success.
    I'm using the router as a printserver as well, only thing which is not working, is importing a scanned image from my PC/MAC. With the Apple airport this is working fine. Is there any fix for this, so I can import a scan from my PC/MAC? Kind regards!!!
  50. Daneve Mateo

    Daneve Mateo Reformed Router Member


    Don't use any download accelerator, just save the file using the built-in browser downloader.
  51. Porter

    Porter LI Guru Member

  52. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    You need to create an account and log in to download, but last time I checked there was no charge.
  53. xtacydima

    xtacydima LI Guru Member

    Thx, the extra port forwards will help a lot - it is greatly appreciated!!!!!
  54. Orwell

    Orwell Serious Server Member

    No download accelerator was used with Firefox.

    On the old 4shared site I don't believe authentication was necessary to download single files, but it may be necessary to register with them now.

    I'll try registering, thanks
    Last edited: Nov 4, 2013
  55. Orwell

    Orwell Serious Server Member

    Maybe someone can help to clarify and or verify what I'm observing.

    Checksum verifiers (MD5, SHA-1, SHA-256, SHA-512) are not posted along with Toastman's images. I believe 4shared used to store MD5 values for each image, but this is no longer present. For 1.28.7635 WRT54G builds (MIPSR1, 2.4 Kern), Toastman did post a build log (fpkg-7635Toastman-IPT-ND.log), which appears to include crc32 of generated images. I compared build crc32 values to crc32 calculated from downloaded images, none match.

    # TXT

    Last edited: Nov 4, 2013
  56. maleadt

    maleadt Networkin' Nut Member

    Is anybody else using DHCPv6 with Prefix Delegation, and a prefix length <64? I get a /56 LAN prefix from my ISP, but Tomato only routes the /64 subnet (as seen in the WebUI). Isn't this wrong?
    Last edited: Nov 5, 2013
  57. koitsu

    koitsu Network Guru Member

    Have you seen this post (it's further up in this thread)? It really helps when people don't make blanket statements and instead provide something minimal, like for example, the exact filename of the firmware you're using (not version, but filename). :)
  58. maleadt

    maleadt Networkin' Nut Member

    Guilty as charged. Since I didn't know whether this is a bug or a misunderstanding on my side, I opted for a quick message rather than something more concrete.

    Anyway, here goes: I have native IPv6 from my ISP, and I get handed out the static /56 LAN prefix cafe:babe:1337:100:: through DHCPv6. I'm using Tomato v1.28.0502 MIPSR2Toastman-RT-N K26 USB VPN, which I know isn't the latest version but it seems to work properly, and I didn't immediately spot any changelog entry related to this (minor) issue. I've configured Tomato to use DHCPv6 PD with a /56 prefix, and added a custom configuration entry for dnsmasq to enable SLAAC on the first /64 (with ra-names so I can reach dual-stack hosts through dnsmasq's DNS server -- pretty neat!).

    However, when I have a look at the routing tables (or the Advanced: Routing page in the WebUI), I see only cafe:babe:1337:100::/64 is routed to br0! I ran into this when giving a host a second, static IP outside the SLAAC zone (cafe:babe:1337:101::1), and this host turned out to be unreachable from other clients. By manually routing the full /56 subnet on br0, which I *think* should have been the case from the start, the situation is resolved (I do this by manually "ip -6 route add"-ing the entire /56 to br0 when the WAN interface comes up).

    Is this a bug -- should DHCPv6 with a /56 LAN prefix imply that the entire /56 is routed to br0 (I think it should), or am I misunderstanding something?

    EDIT: I should probably update first instead of complaining here, since it seems like a lot of IPv6-related changes have gone into Tomato lately.
  59. jerrm

    jerrm Network Guru Member

    Victek is probably the most pro-active IPv6 dev right now. I don't think his build would necessarily resolve this issue, but he has been pretty active with IPv6 updates. Hate to say it, but I'm not interested enough in IPv6 at the moment to keep up with the details.

    Try loading TomatoRAF and offering feedback/testing to Victek.
  60. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I'm back. Been trying RMerlin's ASUS based firmware. See he's here too. He has worked very hard. I was missing the features of Toastman's and was having issues with 5 ghz, newest firmware, and connecting via WPA2 from my laptop's dual band broadcom NIC.

    Back to Toastman's and everything is fine.....

    Glad to be back.
  61. Orwell

    Orwell Serious Server Member

    Anyone able to replicate data from my previous post re: checksum mismatch? Or is anyone able to clarify on where official checksum for build images can be obtained?
  62. Orwell

    Orwell Serious Server Member

    Toastman I think I've found a bug relating to bandwidth graphs in build 1.28.7634; possibly 1.28.7635 (untested). A user can select a time zone and configure tomato to use a ntp time server. After saving this information, a refresh of the status page correctly reflects the selected time zone. However, bandwidth graphs (and possibly all stats) display UTC time and do not appear to reflect the selected time zone.
  63. bagu

    bagu Network Guru Member

    Is there a way to make tomatoUSB support 802.3ad ? (link aggregation)
  64. Chad Burks

    Chad Burks Networkin' Nut Member

    Hi Toastman,
    I tried your nocat 0503.2 build on my E4200v1 and found IPv6 unreliable using a HE tunnel. It worked for awhile, but became unresponsive. Reverted back to 0502.8 and have no problems...just an FYI and THANKS!

    Sent from my iPad using Tapatalk
  65. eahm

    eahm LI Guru Member


    There was a N66U with ~450 days, I had to restart it 12 days ago.
    Last edited: Nov 19, 2013
  66. gs44

    gs44 Networkin' Nut Member

    Strange, wonder if there is some issue with just RT-N versions although only diff I am aware of is wireless driver between builds. My E3000 has an uptime of 23 days and IPV6 works flawlessly with HE Tunnel.. 7503.2
  67. arigosh

    arigosh Network Guru Member

    I think I found a bug. It seems recent versions of Toastman (for example tomato-WRT54GS-1.28.7635Toastman-IPT-ND-Std) on WRT54GS / WRT54G WRT54GL have a problem with the wireless filter. If you add more then 34 mac addresses in the "wireless filter" section, it simply stops working.

    I tested with 50 mac addresses on the old "original" Tomato 1.28 and it works fine.

    When I open a terminal and start adding manually addresses using the "wl mac" command I get an error "wl: Not In Range" after I add 34 addresses.
  68. vivithemage

    vivithemage Serious Server Member

    I am still running: 1.28.0500 MIPSR2Toastman-RT-N K26 USB VLAN-VP

    Any reason to upgrade? I would love to see a change log list! I currently have no issues with the router (outside of USB stops working after 30~ days usually), so just curious what's changed!
  69. Merlyn_3D

    Merlyn_3D Network Guru Member

    I seem to be having problems with the latest 503.2 build. After about a day, my wifi (5GHz particularly) becomes super unreliable. This wasn't an issue with 503.1.

    I'm using an N66u.
  70. Toastman

    Toastman Super Moderator Staff Member Member

    There will be a new build soon, nothing new except for the ipv6 and dnsmasq updates.

    For those who are interested, the replacement of radvd with the equivalent in dnsmasq
    is an ongoing process. Simon Kelley, who is the main dnsmasq developer, is committed to
    development of ipv6. That is why I have changed to it, the old system never worked
    100% but was stuck in development. dnsmasq will be our best way to improve tomato.

    I am sticking to the dnsmasq updates from Kevin Darbyshire-Bryant's development
    branch, which is posted to git on a regular basis.
  71. Toastman

    Toastman Super Moderator Staff Member Member

    arigosh, I've used the filter with 180+ entries here. I think maybe you don't have enough nvram space.
  72. Toastman

    Toastman Super Moderator Staff Member Member

    November 21 2013 - 1.28.7503.3 and variants

    - dnsmasq2.68test2 + 17Nov13 - fix advertising depracated prefixes

    Thanks to Kevin Darbyshire-Bryant & Simon Kelley

    • further improvements from Simon Kelley to ipv6 etc..
    • dnsmasq updated with all commits up to and including 17 Nov 2013

  73. Toastman

    Toastman Super Moderator Staff Member Member


    Aaarrrgghhhh ....

    There has just been another update to dnsmasq bringing it to 2.68 rc1 - I will post again in the next few days when Kevin updates his branch. You might want to hold off on the 7503.3 :eek:
  74. arigosh

    arigosh Network Guru Member

    Other than a filter list of 50 mac addresses there is literally nothing on this router. Tomato reports Total / Free NVRAM: 32.00 KB / 10.82 KB (33.81%).

    This problem is easily reproducible on my two routers (WRT54GV2 & WRT54GSV1.1). I load tomato-WRT54G_WRT54GL-1.28.7635Toastman-IPT-ND-Std and WRT54GS-1.28.7635Toastman-IPT-ND-Std respectively, and do an "Erase all data in NVRAM memory (Thorough)". Then I add 35 mac addresses to the Wireless Client Filter list and set it to "Permit only the following clients". I save and reboot. Then I try to connect from one of the laptops and fail. Then I open Telnet and log in, I type "wl mac" and verify that the list is indeed empty. I then proceed to add manually the 35 mac address by repeatedly issuing the command “wl mac xx:xx:xx:xx:xx:xx” for each mac address which works for the first 32 times and then fails with "wl: Not In Range" on the 33rd, 34th and 35th try.

    I tested the same with Jonathan Zarate's original Tomato 1.28 (not ND) with 150 addresses and it worked fine.

    I tested it with TomatoUSB build 54 (tomato-ND-1.28.8754-Std), and again it fails at 32 addresses.

    I tested Asus RT-N16 running tomato-K26USB-1.28.0503.3MIPSR2Toastman-RT-N-VPN-NOCAT and it will only accept 64 addresses before failing.

    Since this fails at the “wl mac” level, I think it may have to do with the choice of drivers.
  75. arigosh

    arigosh Network Guru Member

    Interestingly enough, Asus RT-N16 running tomato-K26USB-1.28.7503.3MIPSR2Toastman-RT-VPN-NOCAT will accept only 32 addresses, yet when running tomato-K26USB-1.28.0503.3MIPSR2Toastman-RT-N-VPN-NOCAT will accept 64.
  76. Toastman

    Toastman Super Moderator Staff Member Member

    My apologies, somehow I read your mail wrong, I was thinking of access restrictions, not the wireless filter.

    I'll take a look at it, it's probable that the parameter has gotten changed sometime by a merge.

    EDIT - no, there is still provision for 250 clients in the wireless filter. So it's probably something specific to your useage.
  77. arigosh

    arigosh Network Guru Member

    Toastman, Do you have any specific version you recommend, one that you consider "stable"? Specifically I am talking about WRT54GSv1/V1.1 and RT-N16. I am not sure if the most recent are to be considered "experimantal", and if so, which of the older ones to choose.
  78. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Almost any of the builds from the past year will be stable. I haven't tried his last 2-3 builds, but they are likely equally solid and more stable than stock.

    (edited out my comments about IPv6 - I find it frustrating that the new "standard" has so many different implementations)
    Last edited: Nov 23, 2013
  79. motocrossmann

    motocrossmann Network Guru Member

    Looking for some advice on how to troubleshoot a problem I am having with Toastman on my WRT610Nv2. I have a hardware SIP type device called a Biscotti that I use for teleconferencing with my parents. When I use the device with the latest builds (tomato-K26USB-1.28.7503.3MIPSR2Toastman-RT-Ext), the connection will get poor and/or the call will just end. If I use my older WRT610Nv1 with DDWRT, everything works fine. So I am stuck trying to troubleshoot why it dies on Tomato. I have tried setting up port forwards, based on the Biscotti vendor website, but to no avail. Any ideas on how I can nail this down??? My Biscotti device really don't have much in the way of logs to speak of, so I am stuck with poking around on my router. The DDWRT install just works with no configuration at all, but I'd really rather be using Tomato. Thanks in advance!

    Edit- I think this has to do with the Tomato Broadcom drivers. While they work great in most cases, something about my device causes problems. DDWRT works flawlessly, unfortunately. I'd prefer Tomato, but all builds I've tried have the same problem.
    Last edited: Nov 28, 2013
  80. madmalkav

    madmalkav Networkin' Nut Member

    I just updated from an oooold tomato usb release to toastman's latest on my WNR3500L . Everything is working ok sans IP Traffic monitoring, I have activated it but it always shows blank. I have changed from saving to ram to jffs without success, what else can I try?

    EDIT: forget it, after changing back to RAM saving it started working.
  81. LanceMoreland

    LanceMoreland Network Guru Member

    Even though Toastman has not announced it in this thread he has uploaded 1.28.7503.4 and variants. I have it installed and all is well.
  82. Python46

    Python46 Networkin' Nut Member

    I am running 0503.4 at the moment and it seems to be working OK.

    I do note that not all versions have been uploaded. Some of the VLAN 0503.4 versions are not there. I would guess that something happened to stop the uploads.
  83. Solid-State

    Solid-State Network Guru Member

    Thanks for all the great work on your builds throughout the years Toastman.

    Hey I'm in need of a decent production stability level router for a SMB and have been using RT-N16s but have found the wireless range poor.

    I'm going to be buying a new router and require 4G fallback as the software I'm "deploying" will be SAAS.

    I'm curious if you consider your builds more mature/stable for the RT-N66U vs. the RT-AC66U as I don't really need the AC wireless throughput.

    I intend to use a Telus "Huawei E3276 4G LTE Mobile Internet Key" for fallback on DOCIS network failure.

    I have had nothing but smooth sailing with your firmware on RT-N16 for some years and use UBNT wireless gear to compliment the poor N16 wireless performance.

    Moving to new router hardware for SOHO/SMB would you purchase RT-N66U or RT-AC66U considering driver/build maturity including consideration for USB 3/4G fallback?
  84. Toastman

    Toastman Super Moderator Staff Member Member

    Yes Indeed, uploading stopped as it reached 16GB 4shared limit, but I was away from home so can't do anything.

    Should be there now

    7503.4 and variants

    only dnsmasq updates - nothing else !
  85. kthaddock

    kthaddock Network Guru Member

    Still missing in this:
    RT-N (MIPSR2 - latest, like E4200, RT-N10U, RT-N12B1, RT-N66U, WNR3500Lv2, RT-N15U , also RT-N16
    1.28.0503.4 VLAN 351.7 MB 11-27-2013 STD is 464.6MB

    EDIT: se it uploading now. :rolleyes:

    Last edited: Nov 30, 2013
  86. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I did not figure out why RMerlin's stopped the wireless client stalling, etc., that was happening with your 7503.3. I did go back to the version of RMerlin's that has the "older" sdk5 drivers.

    Still on RMerlin's and have not had any more throughput issues.
  87. bagu

    bagu Network Guru Member

    Does the nocat version contain ipv6 ?

  88. Lorenceo

    Lorenceo Networkin' Nut Member

    I've just tried 7503.4 and while IPv6 is there, using PPPoE to authenticate and DHCPv6-PD for IPv6 does not seem to work correctly. All IPv6 connections will show that the destination is unreachable unless you boot the router first, and then connect the WAN cable after it has fully booted. Trying to get IPv6 working with QoS enabled will also result in IPv6 not working. If you enable QoS after IPv6 is working it seems to work fine.
    Disabling the wireless seems to resolve the IPv6 issues, but a wireless router with its wireless interface(s) disabled is rather disappointing.
    If you do get IPv6 to work and your MTU is something other than 1500 you'll run into issues with some websites. The MTU announced in the router advertisements is stuck at 1500 regardless of what the WAN MTU is set at.
    I've had these problems with Victek and Shibby versions as well.
  89. Toastman

    Toastman Super Moderator Staff Member Member

    ok, Thanks for the feedback.
  90. Beast

    Beast Network Guru Member

    ok, I updated to (Tomato Firmware v1.28.7503.4 MIPSR2Toastman-RT K26 USB VLAN-VPN) and I have had my wireless turned off. Well I turned it back on and now almost no URL's will reslove. With wireless turned on I could not even get here. First noticed this on the wireless connected PC, then checked my wired connect PC and found same problem. Google took forever to pop up. And most everything else just said server could not be found. Using Firefox. Turned wireless back off, rebooted router. Now all is normal ?????

    Router (RT-N16). Using Adblock script 3.9e with pixelserv 3.2 or 3.4
    Did NOT clear NVRAM after this update.

    Update: Reinstalled 7503.4 and cleared nvram. Configured router manually. With wireless enabled router stops working after a few minutes (can't reach any URL).

    Checked marked (Intercept DNS port UDP 53). Testing to see if routers stays working.
    Last edited: Dec 1, 2013
  91. Beast

    Beast Network Guru Member

    A snip it from my log after restarting with intercept port 53 and Adblock script and wireless running.

    Dec 1 11:00:54 BeastNet daemon.info dnsmasq[1090]: started, version 2.68test2+17Nov13 cachesize 8192
    Dec 1 11:00:54 BeastNet daemon.info dnsmasq[1090]: compile time options: IPv6 GNU-getopt no-RTC
    Dec 1 11:00:54 BeastNet daemon.info dnsmasq[1090]: asynchronous logging enabled, queue limit is 25 messages
    Dec 1 11:00:54 BeastNet daemon.info dnsmasq-dhcp[1090]: DHCP, IP range --
    Dec 1 11:00:54 BeastNet daemon.info dnsmasq[1090]: using nameserver for unqualified names
    Dec 1 11:00:54 BeastNet daemon.info dnsmasq[1090]: using nameserver for unqualified names
    Dec 1 11:00:54 BeastNet daemon.info dnsmasq[1090]: reading /etc/resolv.dnsmasq
    Dec 1 11:00:54 BeastNet daemon.info dnsmasq[1090]: using nameserver
    Dec 1 11:00:54 BeastNet daemon.info dnsmasq[1090]: using nameserver
    Dec 1 11:00:54 BeastNet daemon.info dnsmasq[1090]: using nameserver
    Dec 1 11:00:54 BeastNet daemon.info dnsmasq[1090]: using nameserver for unqualified names
    Dec 1 11:00:55 BeastNet daemon.info dnsmasq[1090]: using nameserver for unqualified names
    Dec 1 11:00:55 BeastNet daemon.info dnsmasq[1090]: read /etc/hosts - 2 addresses
    Dec 1 11:00:55 BeastNet daemon.info dnsmasq[1090]: read /etc/dnsmasq/hosts/hosts - 3 addresses
    Dec 1 11:00:55 BeastNet daemon.info dnsmasq-dhcp[1090]: read /etc/dnsmasq/dhcp/dhcp-hosts
    Dec 1 11:00:55 BeastNet user.notice root: ADBLOCK: dnsmasq is running

    Still running for 2 hours now, with port 53 intercepted. And again it breaks.
    Its got to be dnsmasq dieing, because as soon as I make a change in the router that
    restarts it, all is well for a while.
    Last edited: Dec 1, 2013
  92. Solid-State

    Solid-State Network Guru Member

    Using tomato-K26USB-1.28.0503.4MIPSR2Toastman-RT-N-VPN-NOCAT on RT-N16.

    I'm also having DNS lookup issues with dnsmasq. I'm not using pixelserv or anything fancy like that as I just use a browser plug for ABP.

    It seems random and it's quickly resolved by clearing the local DNS cache on Win7x64 clients. On the second lookup it will resolve properly. I'm not sure when this started but has been an issue with 0503.3 and 0503.4 I haven't experienced the problem with 0501.3 using RT-N builds.

    I am using boxed defaults on DHCP/DNS with DHCP turned on using static DHCP on three machines and two manually entered DNS servers. The static DHCP address are outside of the address space of the dynamic DHCP IP range.

    All the rest are boxed defaults.

    Just performed a 30/30/30 on the unit reflashed to tomato-K26USB-1.28.0503.4MIPSR2Toastman-RT-N-VPN-NOCAT and another 30/30/30. Let the unit settle... Performed HTTP UI NVRAM clear thorough and manually entered the static DHCP MACs.

    I'll see what happens.

    PS where is the dnsmasq log file stored?
  93. Solid-State

    Solid-State Network Guru Member

    Not sure if this matters but I have "Prevent DNS-rebind attacks" enabled as per boxed defaults. I also notice no option "Use Internal Caching DNS Forwarder:" to turn on DNS caching on the router and considering the lookup failure works after a workstation dns cache flush suggests it's not caching DNS at all unless it doesn't cache 404s.
  94. Lorenceo

    Lorenceo Networkin' Nut Member

    I've been doing some more IPv6 + QoS testing and have found that QoS doesn't seem to be limiting IPv6 connections.

    Here are some examples:
    Qos graphs. Note how there is a lot of default class traffic and minimal P2P traffic. Most of the traffic showing up as default on the graphs should be being classified as P2P and set to low priority, since it is bulk download traffic.

    Clicking the default class shows the following connections, which all appears to be correct. None of the connections shown here are moving much data.

    The P2P class shows the IPv6 download connections that should be being limited.

    IPv4 connections are all being classified and limited correctly, but it seems that IPv6 connections are only classified. They all seem to pass through the router as the default traffic class, without any prioritisation over other classes.
  95. Beast

    Beast Network Guru Member

    Still having problems with no internet access after another pc connects wireless. Shut down wireless pc and reboot router everything is fine again.
    And the lose of internet access was immediately upon the wireless pc connecting to the router. The wireless pc is the same one that I've used to connect without problems in the past.

    Router=Asus RT-N16 and FW Toastman's v1.28.7503.4 MIPSR2Toastman-RT K26 USB VLAN-VPN.
    Running Adbock 3.9e with pixelserv 3.4

    I just recently turned my wireless back on, I had it turned off some months ago since I was not using it. All hard wired stuff works fine and has been.

    Reverted back to 7502.8 and wireless working again. For a while that is. Stopped working again after a couple of hours.

    Some one please tell me some commands to run, so I can figure out whats dying and when.
    Last edited: Dec 7, 2013
  96. bobyang

    bobyang Serious Server Member

    I have NetGear WNR3500L and everything works perfectly with Toastman's firmware till I upgrade to 100Mb/30Mb connection. If I have Qos on, I can only go all the way to 62Mb for downloading. I checked the CPU at around 45Mb download, it reaches about 98% of CPU usage. Therefore, I decided to buy a faster router.
    I got RT-AC56U, I just wonder if the new firmware works now without wireless which I don't use. thanks!

  97. Porter

    Porter LI Guru Member

    That's a known problem. If you feel up to the task, please contribute. I haven't looked into this matter because I don't have IPv6 here anyway. But I guess there will be a time when there is. I can't imagine that it would be that difficult, since you probably just need an IPv6 enabled kernel (which you oviously have) and the rest probably just is some GUI tweaking and iptables stuff in the background.
  98. mstombs

    mstombs Network Guru Member

    If it doesn't specifically say it is for new Broadcom dual-core ARM devices then it isn't! Too expensive to brick those nice new routers with old Broadcom MIPS firmware!
  99. bobyang

    bobyang Serious Server Member

    thank you!

    could someone told me where do some people get the tomato ARM firmware from? I saw someone post about their device is running tomato. thanks!
  100. bobyang

    bobyang Serious Server Member

    For anyone wants to know the info. I just found this https://github.com/Victek/Tomato-RAF it seems like ARM is supported by RAF. :) I hope to see it shortly in Toastman's release, I love Toastman's Qos!


Share This Page