1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Toastman's Releases

Discussion in 'Tomato Firmware' started by Toastman, Dec 18, 2011.

  1. Elfew

    Elfew Addicted to LI Member

    Be patient is the asnwer ;)
  2. mstombs

    mstombs Network Guru Member

    One reason we all love Toastman firmware is that is 'fast follows' developments by others in git - but only when they are considered stable and at least out of experimental stage for 'betas'. I know Victek is merging in support for New Asus Broadcom/ARM - but don't think it is ready for general use yet - see for example


    There's an historic link from Tomatousb to Asus, so it will be possible to add the new CPUs/toolchains back into tomatousb git - and clearly Victek has started - but perhaps Shibby will be first to announce release? ARM is the future (80%+ of smartphones already?) Rmerlin already has working versions of his great additions to the Asus firmware on these new routers, and you will also see developments in dd-wrt and OpenWrt etc.

    Would be nice for EasyTomato to be able to jump from Toastman base code on RT-N16 to a high end router option too!
  3. Victek

    Victek Network Guru Member

    @mstombs , I answer by reference in your post.
    Many people (also shibby with AC68) are working in ARM porting, it's the ONLY option for Tomato to remain as 'third firmware option'.
    About tomato flavor... well, any of the versions you know splits tomato to different needs and people, toastman to access point to many subscribers and QoS and others to different needs, dd-wrt follows the wide line of integrate any model in it's framework, asus included tomato and teddybear contribution in his mainline, changed httpd server to lighttpd and create their framework for first models, now they are refining the code and adapting for their product portfolio, but yes, it's a tomato in the ground. Oleg's firmware team, a real developer and helpful people same as Openwrt team are the ONLY true sources for third party firmware by far.
    Tomato don't have 'team' .. just contributors and cherry-pick people....
    Toastman likes this.
  4. RMerlin

    RMerlin Network Guru Member

    They didn't. They still use the old mini httpd code that goes back to the Linksys days, but with a lot of changes of their own. lighttpd is strictly used for AiCloud.
  5. Beast

    Beast Network Guru Member

    Go ahead and try it. I did a 30/30/30 clear and nvram clear. And reinstalled. This time all is working ok.

    Not sure why I had all that trouble. Also I turned of WMM in wireless settings. Im not going to change anything
    else for the moment. Since it is working. Also updated to the newer 4.5 adblock script which also seems to be
    working well at the moment.
  6. Victek

    Victek Network Guru Member

    I thought httpd was tomato original, thanks for the correction.
  7. RMerlin

    RMerlin Network Guru Member

    Tomato and Asuswrt both use the same old httpd that originally came from Linksys from what I recall. Asus did quite a few change to the socket part of the httpd tho, so it's currently quite different from Tomato's.
  8. bripab007

    bripab007 Network Guru Member

    Oh, my mistake. I thought when I had read your posts that once you enabled wireless it would freeze the router after a period of time, and I could've sworn you said it was still happening after an NVRAM reset.
  9. Toastman

    Toastman Super Moderator Staff Member Member

    December 13 2013 - 1.28.7503.5 and variants

    - dnsmasq updated to 2.68 release
    - fixed tools ping/trace for hostnames with . - :

    Thanks to Victek, Kevin Darbyshire-Bryant & Simon Kelley

  10. bobyang

    bobyang Serious Server Member

  11. jerrm

    jerrm Network Guru Member

  12. Beast

    Beast Network Guru Member

    Sorry I should of updated sooner, my router did freez when anything connected wireless, that is untill i did the 30/30/30 and several nvram clears.

    I was just so darn happy it was working again, I forgot to update my post. Not sure what caused the problem in the first place.
  13. bagu

    bagu Network Guru Member

  14. gs44

    gs44 Networkin' Nut Member


    Hello!! Just installed 1.28.7503.5 usb.ext on my E3000 and so far so good, IPV6 via HE tunnel functions properly and everything else functions rock solid. As Always THANKS for your continued support of Tomato!!!
  15. motocrossmann

    motocrossmann Network Guru Member

    Wooo Hooo!!! So happy to be back on Tomato! I had to switch to DDWRT to get a legacy device to play ball with my wrt610nv2. I then converted it to an e3000 on DDWRT and then realized that Toastman RT-N builds support the e3000. I'm back baby!!!
  16. motocrossmann

    motocrossmann Network Guru Member

    So how do i get input-core.ko loaded on Tomato? I downloaded it from extras-K26-MIPSR2-from-TomatoUSB.tar.gz, (on the 4shared toastman site), but I can't seem to get it loaded. When I run insmod input.core.ko, I get "insmod: can't insert 'input-core.ko': unknown symbol in module, or unknown parameter". What am I missing here? (I'm working on getting my UPS going)

    Shibby to the rescue! I found ko modules over on his site that are more current and seem to load properly. Now I just need to get apcupsd working...
    Last edited: Dec 14, 2013
  17. Toastman

    Toastman Super Moderator Staff Member Member

    Just to get in early, Happy Christmas and New Year, everybody!
    though, JugsteR and elduderino like this.
  18. Beast

    Beast Network Guru Member

    Probably a dumb question, but what is ( input-core.ko ) and what can you do with it??????
  19. elduderino

    elduderino Reformed Router Member

    I thought RT-N didn't support e3000. Sorry, I haven't looked to upgrade my Toastman's build in a long time until now. It's always ran great on my E3000, despite not having 5ghz band (but I knew that going in). I take it RT-N is obviously 802.11n support?

    And while I'm asking stupid ass questions, can someone point me to the place that explains why any TomatoUSB Mods, like Toastman's, can't utilize 5ghz? I've always wondered.

    Nvm. My lazy ass did some searching in this thread ;)
    Last edited: Dec 15, 2013
  20. gutsman7

    gutsman7 Networkin' Nut Member

    same to you to Toastman, and everyone else.
    JugsteR likes this.
  21. bobyang

    bobyang Serious Server Member

    Toastman, thanks a lot all the time and keeping on good works! happy holidays to you too!!

    I got 100mb/40mb fiber now. I found my NetGear WNR3500L can only go up to 63mb with QOS, even I give it 100%, 100% in qos. I am still working on it for few days already, please let me know if you know anything I can change to make it works with full speed. (I did a test from modem, I can get about 98mb/39mb.) could be the cpu is too high? i got ac56u arm. if it is CPU issue, hope new router will help in the future.
  22. motocrossmann

    motocrossmann Network Guru Member

    I use input-core.ko, hid.ko, and usb-hid.ko to add support for detecting my attached UPS device. The apcupsd will notify me by email of powerfailures / etc. It also allows for shutting down optware tools elegantly, if you happen to use them. Basically I nerded out on a science project, lol. It was far from necessary.

    As for RT-N on my e3000 elduderino, it allowed me to get 56Mbps down over both wireless radios. That was another unnecessary project, but getting 26Mbps on the RT build just wasn't good enough. ;)

    Happy Holidays Boys.
  23. RonV

    RonV Network Guru Member

    Merry Christmas to you Toastman and everyone else. Thank you so much for the hard work you put into this project.
  24. RMerlin

    RMerlin Network Guru Member

    This is probably CPU limited, tho I would expect that router to get maybe closer to 80 Mbps. Disabling QoS would help by reducing complexity at the firewall level.

    The RT-AC56U would be more than capable of hitting 100 Mbps, however Tomato isn't ready for prime time on this model yet.
  25. gg_99

    gg_99 Reformed Router Member

    I'm having some trouble with a brand new Asus RT-N16 that I bought specifically for Tomato compatibility. I'm having random reboots that I've not been able to solve. I've tried a couple of recent builds and am current running tomato-K26USB-1.28.7503.5MIPSR2Toastman-RT-VPN. I've been through a thorough NVRAM reset a couple of times and have manually reconfigured the router after each. I have a very basic config, where I've currently disabled wireless (I have a Linksys e3000 also running Toastman tomato I use for a WAP that's running rock solid), USB, and most other features. I'm using this essentially for just wired connections, DHCP (with 3 reservations) and little else.

    Each time I check the logs I'm seeing only information since the reboot, which is not a surprise, but it's obviously not all that helpful. The reboots seem to happen at random; since I've been checking it's happened at 2am, 4am and 2pm and does not appear to be related to traffic load (no torrents, downloads or the like). I've not seen uptime longer than about a day and a half. After my last full reset/reconfig I made it only about 6 hours before a reboot, although about a day seems more common.

    Any thoughts on additional troubleshooting? Anything to try or other builds to flash? This isn't a huge issue for me as it appears to recover quickly on its own, but I bought this for bandwidth reporting and eventually VPN, but I'll need it to be more stable. Am I already looking at an RMA for a 3 week old router (I cut the UPC for a rebate, so return to Newegg is unfortunately not possible).

    Thanks all! Really appreciate the assistance. And happy holidays to you all. Thanks again for the builds, Toastman!
  26. Beast

    Beast Network Guru Member

    Use USB stick, and use custom path in the system logging to preserve your messages during reboot. Also set logging level up to record more events.
  27. gg_99

    gg_99 Reformed Router Member

    Thanks. I'll start doing some reading on how to implement that log redirection to USB. I know it's in the tomato UI, but I suspect it'll take a little effort on my side to get it working. Thanks for the suggestion.
  28. Beast

    Beast Network Guru Member

    Its under Admin\logging. I use ( /tmp/mnt/USBDRIVE/messages ) as the custom path. Since that is the default under USB/NAS once you plug your USB stick in the back.
  29. gg_99

    gg_99 Reformed Router Member

    Cool. This was easier than I thought, and I must have been literally configuring this as you replied (thanks again, btw). My path ended up being /tmp/mnt/USBDISK/log/messages, and I can see a few lines logged there through the UI and telnet. I assume these log entries should survive a restart now? And per your earlier suggestion, how do I go about elevating the logging level? Do you mean checking some of the Events Logged or Connection Logging options? If so, any in particular you think might be helpful?

    Thanks again.
  30. Beast

    Beast Network Guru Member

    Under Admin/Debugging there is (console log level ) box that can be set from 1-8.

    Not sure what additional things get logged, i have never elevated mine before.
  31. omgsy

    omgsy Reformed Router Member

    Hello, I am new to this forum and I recently found that there are custom firmwares for my E4200.

    My question is what are the differences between Toastman and Tomato versions?

    I can't decide which is good for E4200. I know both are good and works with E4200 but I am just using it for my home use. Nothing fancy stuff.

    Thank you.
    Last edited: Dec 17, 2013
  32. johnsonn55

    johnsonn55 Reformed Router Member

    If you don't need inbound QOS (in most case outbound QOS should be sufficient), you can turn off inbound QOS by executing the following commands in Tools->System page:
    nvram set qos_irates="0-100,0-100,0-100,0-100,0-100,0-100,0-100,0-100,0-100,0-100"
    nvram commit

    Then reboot the router, the inbound QOS should be turned off. And you should get full download speed after the modification. Please note that if you change other QOS settings by GUI, the qos_irates setting you did will be overwritten by GUI. You will need to execute the commands again after that.

    I remember in 7501.2 version there is "No Limit" option in Inbound Rates/Limits. Set all category to No Limit will turn off the inbound QOS. But in later version, you can only input 1% ~ 100%. So the only way to turn off inbound QOS is execute commands. Maybe there is some better way for turning off inbound QOS?
  33. bobyang

    bobyang Serious Server Member

    Thanks Johnson!

    I think it could be cpu issue now.. even I turn everything to 100% but I only get 60% of speed and I see the CPU is high. :(

  34. Edrikk

    Edrikk Network Guru Member

    Just turn off QoS. setting it to 100% doesn't do the same thing as disabling.
    In a "controlled" environment (i.e. your house) you're much better off limiting things at the source (e.g. use uTorrent's scheduler) than dropping packets via QoS.
    Toastman and Marcel Tunks like this.
  35. JohnO

    JohnO Serious Server Member

    Early indeed! It seems I don't get into the Christmas spirit until the 24th. Thanks so much for a stable and very useful firmware!
  36. bobyang

    bobyang Serious Server Member

    we use netflex, live stream, qvod, xbox, gaming, voip, and web. It is almost impossible without Qos. For example, if my brothers are watching netflex and qvod, and a VOIP call get in, I have no time to run to each room and ask them to stop watching. Another situation, without qos, gaming will be terribly lagging when someone just turn on steam without asking "anyone is playing game or VOIP, I am going to do streamming...".....That's the reason we need tomato badly because tomato handles Qos and traffic sharping beautifully.
    Toastman likes this.
  37. motocrossmann

    motocrossmann Network Guru Member

    Anyone using Entware? I've been messing about with Optware on Tomato cause of my DDWRT experience. It appears Entware is more up to date. Should I switch?
  38. jerrm

    jerrm Network Guru Member

    Yes and yes.
  39. motocrossmann

    motocrossmann Network Guru Member

    Cool. Any asiablock like scripts I should be aware of on Entware? Other gems? I see apcuspd - which I already use on optware...
  40. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Entware is actively maintained and seems to have fewer bugs.
  41. motocrossmann

    motocrossmann Network Guru Member

    Last edited: Dec 21, 2013
  42. koitsu

    koitsu Network Guru Member

    You could simply follow the official instructions... :)

    If you're going to be installing Entware on something which previously had Optware installed on it, you should ensure that your /opt directory is completely empty of files (especially dotfiles (files that begin with dot/period)). There have been many cases of people "migrating" from Optware to Entware only to find that packages/commands/etc. broke bizarrely because they did not fully delete all of the crapfiles Optware puts in place.
  43. bobyang

    bobyang Serious Server Member

    I may find a bug in the firmware.

    1. I issued following in, Firewall:

    iptables -I FORWARD -p tcp -m iprange --src-range -m connlimit --connlimit-above 150 -j REJECT

    2. "save'

    3. reboot

    then the router will keep on rebooting about every 3 minutes...

    so I need to get into router within 3 minutes to remove the line, and reboot then it stops rebooting.

  44. RyanJ

    RyanJ Reformed Router Member

    I just bought a RT-N66U - Is the download I need tomato-K26USB-1.28.0503.5MIPSR2Toastman-RT-N-VLAN-Ext.trx for standard plus extra utilities and NTFS support?
  45. gutsman7

    gutsman7 Networkin' Nut Member

    You have to put your connlimit rule in the prerouting chain.
    iptables -t nat -I PREROUTING -p tcp -m iprange --src-range -m connlimit --connlimit-above 150 -j REJECT
  46. motocrossmann

    motocrossmann Network Guru Member

    Is NAT Loopback working for you guys? I'm on the latest build (1.28.0503.5) and can't get it to work regardless of what settings I choose.

    Got it going!! You need a "Force Next Update" under Basic-> DDNS, even if your IP has NOT changed since installing Tomato. Not sure why this is the case, but it solved my problem. Now loopback works perfectly. Thanks for the awesome work Toastman.
    Last edited: Jan 3, 2014
  47. BearMarch

    BearMarch Reformed Router Member

    Installed tomato-K26-1.28.7503.5MIPSR2Toastman-RT-Mini (since Std didn’t fit on 4 MB of flash) on a Linksys E1000v1. I was not able to enable sshd. I compared to what was installed on my E3000 and I couldn’t find /usr/bin/dropbear* on the E1000.

    How do I start sshd on the mini firmware? Thanks!
  48. koitsu

    koitsu Network Guru Member

    You cannot -- the router does not have enough flash (only 4MBytes as you stated) to include support for this, due to SSL dependencies (extremely large). The E1000v1 also lacks a USB port, so your only option is to use a CIFS/SMB or NFS mount (of another machine on your network (ex. a wired Windows machine)) for /opt and then use something like Entware to install either dropbear or openssh packages, along with using mount.autorun to properly start the daemon(s) as desired. All of this is outside the subject matter of this thread.
  49. Runkle

    Runkle Networkin' Nut Member

    Hi all - I'm having an issue with vsftpd and SSL. I'm a relative newbie, so it could be something simple.

    500 OOPS: SSL: ssl_enable is set but SSL support not compiled in

    I'm currently running v1.28.7503 MIPSR2Toastman-RT K26 USB VLAN-VPN-NOCAT on an RT-N16. I compiled the SSL certs from the router via the openssl binary, so I'm quite confused. Maybe vsftpd is looking for it at the wrong path?
  50. tbalon

    tbalon Reformed Router Member

    Current Version: 1.28.7502 MIPSR2Toastman-RT K26 USB VLAN-VPN
    running on 9 month old RT-N16 hardware.

    The unit has been stable for months. I recently purchased a Roku 3 ( wireless N ).
    and I changed the operating mode from B/G Only to Auto. In auto mode, the unit
    would spontaneously reboot. I use syslog, but no entries are found in syslog. This
    happens about 1/day. Syslog simply shows boot up messages. Feels like a random
    panic followed by reboot.

    The only thing I've tried so far is to disable WMM on the wireless screen. This did
    not have any impact on the issue.

    Please Advise ...
    Last edited: Dec 26, 2013
  51. mikalai

    mikalai Reformed Router Member


    I installed toastman recently which is nice. But I'm missing some features in the mini builds. I suggest we omit the logo on the about page to make space for missing features such as dnscrypt. Or adding IPv6 in the Regular build would be nice too.

    Yes the logo is nice, but less important than some features. At the very least could we remove some artifacts? It is obvious that it used to be a jpeg converted to png. By removing the leftover artifacts I could remove 3KB from the picture (Without a degradation of the picture). By adjusting the shadings of the wings and so on we could probably shave another 3KB.

    Cleaned picture Left, original right:

  52. Beast

    Beast Network Guru Member

    If you need room, I would think deleting more themes would get your way more than 6k. Next time I enable ssh I will take a look at how much space is taken up by them. On Toastmans builds looks like there are 12 themes total.
    This may not be true for all variants of the build.
  53. Toastman

    Toastman Super Moderator Staff Member Member

    Feel free to delete anything you like, you will be able to save several k.

    Most of the original themes are merely colour changes, not so much space can be changed there. Deleting the themes which were "additional" to Jon's original releases would do the trick.
  54. tbalon

    tbalon Reformed Router Member

    Still getting random panic reboots with Version: 1.28.7502 MIPSR2Toastman-RT K26 USB VLAN-VPN
    running on 9 month old RT-N16 hardware. ... Anyone ? Is this a known problem with the release ?
    Should I simply update to tomato-K26USB-1.28.7503.5MIPSR2Toastman-RT-VPN.trx ?

    The unit was stable for months and now panics when running in Auto rather than b/g
    only mode.

    Assuming I need to update, can I just select this trx and use the upgrade feature with the "erase NVRAM after flash" option ?
    Last edited: Dec 28, 2013
  55. koitsu

    koitsu Network Guru Member

    I have not experienced a single "random panic reboot" when using a Toastman firmware on my RT-N16 (and I've had two models over time) ever.

    Secondly, is it a kernel panic you're experiencing, or a sporadic reboot? I'm aware a panic will induce a reboot, but there is a very substantial difference between a kernel panic+reboot and just a simple reboot. The latter could induced by hardware malfunction or overheating or some other issue, while the former is indicative (usually) of a software issue. The only way you'd know if it was an actual kernel panic, by the way, is if you had serial console wired up. So please explain what it is you're seeing exactly.

    Finally, you've given absolutely zero details regarding all the Configuration settings you adjust/change, features you're using, etc.. There are known problems when using things like QoS + certain other features combined, where occasionally the router will kernel panic + reboot. I cannot be bothered to dig up all the threads talking about it. The workaround/solution is to stop using all those features combined and instead use only the bare minimal amount of stuff you need. If you don't have serial console, then start by ceasing use of QoS (if you're using it) and see if the problem goes away (you will need to test this for a few weeks -- not hours, not a day, not 2 days, but weeks), or disabling use of all these other features. Apply KISS principle as much as possible. These routers are not "workhorses" in the same sense a PC is.
    JugsteR and Goggy like this.
  56. RixNox

    RixNox Serious Server Member

    Cheers mate, keep it going!
  57. tbalon

    tbalon Reformed Router Member

    Sorry, the post you read was one that followed my original post ( a few posts back ) that had more information.

    The post was a follow-up to my previous post which explained the issue. In that post I mentioned that I have
    been running the unit's wireless configured for B/G only for several months without any issues. I had purchased
    a ROKU 3. The Roku was N capable and so I changed the RT-N16 to run in AUTO mode instead of B/G Only. I
    don't use IPV6, No QOS, No VLAN, No VPN tunnels, No USB or NAS connected. Just a few ports forwarded that's
    pretty much it. I don't even use any encryption... Just switched from B/G to AUTO.

    This is when the trouble began. No other changes were made. No QOS. Basically no advance features at all.
    No encryption, just wireless filter with my local MAC's for devices. I do use SYSLOG to capture system events
    to a linux box. The log shows NO entries when the unit reboots. The only thing I've done so far is to disable
    WMM after reading a similar post.

    What I'm seeing is the following. Under normal use, one or two devices connected to the unit in AP mode, things
    stop for about 1-2 minutes and then resume. When I examine the unit, the up time is reset, the unit has rebooted
    and there are no entries in the syslog other than boot up messages.

    Regarding the "panic" issue. I view this as a kernel panic since I'd assume if the "software" was able to cope with whatever happened it would have done so, logged a message, restarted a service etc etc. If it wasn't a panic,
    then it should have logged a message and restarted itself as this would help debug the issue.
  58. gg_99

    gg_99 Reformed Router Member

    I don't have much in the way of help to offer you, but I have a two month old RT-N16 running K26USB-1.28.7503.5MIPSR2Toastman-RT-VPN and am also experiencing random reboots. I used to see them about once a day and then went 10 days before the next reboot. You can see some of my info above in this thread, but I also have a very simple configuration - I'm not even using wireless as I leave that to my e3000 in a WAP config, which is also running a recent Toastman build (no reboots there at all, very stable). I've got logging set to use my USB drive for persistent storage of logs, and the only thing really being captured is regular DHCP activity (requests, acks, etc.). The only logging I see when it reboots is some of the startup info, and I've got Debugging set to level 6. No hints as to what caused a crash or restart. For what it's worth, I also have a Roku (a 2 XD in my case), but haven't seen anything so far that'd make me think one of my clients is causing the issues, although I've been similarly suspicious (Roku, several Dish Network devices, etc.).

    Keep us/me posted if you make any progress, as I'm very interested.
  59. koitsu

    koitsu Network Guru Member

    If this is a software issue at the kernel level: there will be no "logging" that gives you any information. The kernel or a device driver has crashed; there can be no "log" of this sent anywhere or written anywhere (because only very specific/limited capabilities within the kernel can be trusted when there is a kernel panic -- syslog, etc. cannot be done), other than serial console output -- and even that is somewhat pointless (symbol-to-function-name translation is not enabled as to keep the kernel extremely small in size due to limited flash on routers), but it will at least provide proof that something within the kernel is crashing (but not knowledge of what driver/code in the kernel crashed). The router will then reboot.

    If this is a hardware issue: there will be no "logging" that gives you any information. There is absolutely nothing that can be used to troubleshoot this at the software level. This most commonly manifests itself as the device acting "flaky", and reboots are common. However, hardware-level problems can also manifest themselves as kernel panics, such as when RAM goes bad or similar.

    TL;DR -- Distinguishing the difference between the two circumstances is extremely difficult on embedded hardware and usually requires serial console.

    To @gg_99 -- please do not correlate your issue with someone else's issue just because you happen to be experiencing "random reboots" too. "Me too" threads do not help troubleshooting when there is lack of concrete data/details that can help troubleshoot. Feel free to look around the forums over the past 7-8 years, especially with regards to Linksys Exxxx series routers experiencing problems with the hardware overheating. Some people have done things like "fan mods" to the router to keep them stable. Discerning the difference between that situation (overheating) and a software-level issue is difficult, other than through pure trial-and-error.
  60. gg_99

    gg_99 Reformed Router Member

    While I appreciate the reply, it seems reasonable to me to report that I'm having random reboots with *exactly* the same hardware and at one recent point the same software (we're both using RT-N16's, and I'm having no problems with my e3000, which I mentioned only as a point of reference for not using the wifi on my RT-N16).

    I've tried my darndest to come up with those concrete data/details with any available console logging, but to your point there's very little that I can provide in this scenario where they're simply not created. Given that we're both having random reboots in very similar circumstances with the same hardware, what else is there other than "me too"? Perhaps it's not helpful, but it continues a dialogue where we might be able to help one another with some commonality. I'm sorry if you disagree.
  61. mw333

    mw333 Serious Server Member

    Just a dumb question - have you been conducting wireless surveys?
  62. gg_99

    gg_99 Reformed Router Member

    If this is in regards to the RT-N16 issue, I have not. Wireless is disabled. Although to an earlier point, my random reboots may be fully unrelated to the other user's, as his may be related to a recent wifi configuration change. I'll exit the conversation until I have something more to report or contribute.
  63. mw333

    mw333 Serious Server Member

    The reason I asked is because my RT-N16 is very stable unless I click on Tools --> Wireless Survey --> Refresh a couple of times. It might take a couple of days but there is a correlation - it seems to reduce stability. The wireless on this gateway is not enabled but it will still listen. So I resist the urge. When I have to survey the area I usually reboot after, at a convenient time.
  64. koitsu

    koitsu Network Guru Member

    @gg_99 -- read what @tbalon said. No, here, let me quote both of your conversations:

    My point: as someone who has been part of open-source projects since the early 90s, proper troubleshooting is accomplished by treating every single problem case uniquely. Correlation between issues can be accomplished after-the-fact by that approach, not jumping on a bandwagon and then having to prove issues are unrelated. It's more effective to treat each situation uniquely from a developer POV.

    Your two situations to me are completely unrelated, barring hardware flakiness.
  65. motocrossmann

    motocrossmann Network Guru Member

    Bump... Just trying to figure out if this is something with my specific config, or a bug...
  66. lefty

    lefty Networkin' Nut Member

    Perhaps providing more info on your part may yield better results. It may help in knowing how you are trying to check to see if its working instead just stating you "can't get it to work no matter what settings you choose", btw what settings are you choosing? Just seems pretty vague to me..
  67. gg_99

    gg_99 Reformed Router Member

    @koitsu In a post two above yours you'll see that I understand the two issues are separate, and I apologize for having connected the two or caused any undue confusion of the previous poster's issue.

    Perhaps it is just flaky hardware, but my random reboots continue unabated and I'll continue troubleshooting that on my own as a separate issue.

    Happy New Year all.

    Edited: Is there any reason to give EasyTomato for the RT-N16 a try to see if it solves the reboot issue? My understanding is that it is still based on Toastman's builds, but I don't know if there's any specific tweaking done for their builds that are specific to the RT-N16. Any insights? Thanks again.
    Last edited: Jan 1, 2014
  68. motocrossmann

    motocrossmann Network Guru Member

    Under Advanced-> Firewall-> NAT

    NAT Loopback- I tried both "All" and "Forwarded Only". Either choice should cause my DDNS name to forward to my local IP address, when I'm on the LAN/WLAN. Neither choice works though.

    NAT Target- not clear on what effect it has. Regardless, choosing either SNAT or MASQUERADE doesn't change things for me.

    Am I not understanding how this should be working? I know this worked for me on DDWRT, but maybe I'm not playing with the right options.
    Last edited: Jan 1, 2014
  69. sunwind

    sunwind Reformed Router Member

    Which version for an Asus RT-AC66U AC1750?
  70. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Shibby or Victek.
  71. lefty

    lefty Networkin' Nut Member

    So lets be clear about this, because your DDNS settings aren't working 'correctly' in your mind loopback isn't working? I don't think that problem has anything to do with loopback.
  72. motocrossmann

    motocrossmann Network Guru Member

    Not at all. DDNS works as it should.
  73. gfunkdave

    gfunkdave LI Guru Member

    I've noticed this issue in every version of Toastman that I have used over the last few years. When I back up my settings by doing the "nvram export --set" method, it has an issue with nvram keys whose GUI inputs are multi-line text boxes.

    For example, I have a few lines of config in my Advanced -> DNS box but it only catches the first line - and forgets to put in the trailing quotation mark. This not only makes it miss some settings, but also causes an error on each such line when trying to re-import the settings.

    Anyway, here's an example:

    nvram set dnsmasq_custom="bogus-nxdomain= 
    Toastman, seems like this should be relatively easy to fix - just don't break the export at the first newline character or something to that effect.

    Thanks! Thoughts?
  74. jerrm

    jerrm Network Guru Member

    Long standing issue. nvram --set works fine.

    It's probably grep mucking things up - either use "nvram export --quote" or properly capture --set output. See http://www.linksysinfo.org/index.php?threads/nvram-export-can-not-handle-wrap-text.68478/.
    gfunkdave likes this.
  75. tbalon

    tbalon Reformed Router Member

    Yes. There is one other wireless AP ( my neighbors ) which is a faint signal on a different channel. So,
    yes there is one other AP about 300 ft away on a different channel. Note I am not saying there is no
    interference, only that there are no other AP's or wireless devices physically withing 300 ft of my AP.
    No, microwave ovens, no 2.4Ghz phones, no hidden peer-to-peer wireless networks.

    Stable to me is the unit running with out issue. My other toastman builds on Linksys are running
    several months and never reboot. The Toastman build on my RT-N16 runs months with no reboots etc. in
    B/G only mode. Good wireless throughput, very few errors or packet loss, etc. This is what I call stable.

    While it's nice to argue about what is or is not a kernel panic, or what is or is not a known problem or if
    my issue is the same as another persons similar problem running the same release on the same hardware etc.
    It's not getting me or the other folks having similar issues anywhere. What is or is not a panic or a reboot
    is semantics. I appreciate the efforts of those involved with the support and development of this fine
    code base, but the fact remains that without a defect tracking system and folks collecting, analyzing
    and determining if reported issues are indeed "duplicates" or "known issues", we are left to this forum
    to exchange what info we have.

    I've noticed over the past week or so the unit is stable if I disconnect the Roku and hardwired it and don't have
    any wireless nodes connected using N.

    The unit runs fine and is stable in A/B only.
    The unit runs fine and is stable in AUTO if and only if all devices are connected B/G
    The unit randomly crashes and reboots if a devices or devices are connected in N mode.

    Am I saying it's a wireless N problem, NO.
    I'm saying the unit reboots with no warning or logging if there are wireless N devices.

    I thought this might be a known issue ( hence my original post )
    Someone else has also had a random reboot issue. < gg_99 >

    For now, I will run in B/G mode since the unit is not stable in N mode.
  76. mw333

    mw333 Serious Server Member

    It's possible that the act of taking wireless surveys with your tomato router is reducing your time between reboots. I am not sure why. Here's a scenario - the wireless drivers support taking the survey and the information is captured and displayed on the GUI. It works. But did it clean up after itself?

    Much testing went into the image you are utilizing. Some things get tested more than others. Similar to your observation, operate sans N and it lasts longer - this may or may not increase the time between your reboots - I have found not taking surveys makes my router last longer. But it's hard to leave it alone. ;)
  77. tbalon

    tbalon Reformed Router Member

    Thanks ! ... I ran the survey using my laptop, not the AP. I did run a survey using my old AP ( linksys WRT54G )
    running v1.28.7632 -Toastman-IPT-ND ND VPN before updating to the new RT-N16 hardware. When I have
    had issues with wireless in the past, I always run a survey to see if there are other AP's on the same channel
    close by.
  78. mw333

    mw333 Serious Server Member

    What are your wireless settings? 20 MHz mode? Are you leaving everything else in the default?
  79. tbalon

    tbalon Reformed Router Member

    Yes, 20 Mhz Mode. I've attached screen shots. The only thing I changed from default was to turn off WMM in
    the wireless settings.

    Attached Files:

  80. mw333

    mw333 Serious Server Member

    Noted 3 things: Connected for 13 days (this is good). What country are you in? WMM should be turned on.

    Recommend you set your router and clients for your country to be in compliance. If devices follow the wireless-N spec you need WMM for > 54Mbps. It appears that different wireless-N devices behave differently. For example, the 20/40 coexistence thing is really wild. It could be that way with WMM.

    The only settings I've changed: country=US and transmit power=0. The wireless is very stable (unless I do surveys). Laptop performance (20Mhz mode): With mimo 1x1 (built in) --> 72. With mimo 2x2 (adapter) --> 144.

    How's your total/free memory? Do you have "Count cache memory and buffers as free memory" unchecked? After you boot up does your free memory decrease and decrease, or decrease and stabilize after a while? Use of USB will utilize memory and CPU. Is your CPU load excessive? With/without wireless clients connected?

    Have you added any custom firewall rules or other (Admin) scripts? Are you using USB? QOS? IP Traffic? Bandwidth? All these nice extras can load things up. L7 filters?

    I have seen one spurious reboot - son was doing this thing and I just happened to be tuning QOS (for netflix). Son's thing opened at least a 1000 connections in a very short period of time. I only saw a piece of it before no more gui updates and it rebooted.
  81. though

    though Network Guru Member

    Wireless upload a video to youtube and my entire network goes to hell?!?!?

    i use the RT-N66U and have the latest toastman standard USB build installed. i noticed if i upload a video that i take on my phone and send it to youtube, the network, both wired and wirless goes to hell. crazy packet loss, about 100%, and the packets that aren't lost are crazy high. the internet becomes totally unuseable. i have both 2.4ghz and 5gz enabled and it effects both the same and also wired devices as well. web pages are not accessible, etc.

    my network provider is TWC 30/5. is this common behavior??
  82. koitsu

    koitsu Network Guru Member

    @though -- Try disabling WMM under Advanced / Wireless. If that fixes it for you, then I can point you to another thread that has some stuff you add to your Scripts / Firewall section that should alleviate the problem after re-enabling WMM.
    though likes this.
  83. tbalon

    tbalon Reformed Router Member

    Thanks .. The default for country was Singapore, which, if I recall, simply allows for channels beyond 1 to 11
    normal 802.11b/g. Anyway, I will set to to my country.

    Transmit power is also at default.

    Total / free is displayed on the one uploaded pic. Total is ~ 124 MB and Free is ~ 113 MB

    No custom firewall rules, just a few port forwards ( very basic ) , no USB, no QOS ... All default / stock.

    The unit has been stable because I have connected the ROKU direct (hardwire) and the iMac is connects connects N or G ( it varies ).
  84. mw333

    mw333 Serious Server Member


    In general, wired is best. However, I am really curious why roku does not play well. Could be a firmware issue. You would think that by 2014 the wireless-N standard would be standard. ;)

    So far I've been lucky. Phones (androids and apple), latops and dvr (b/g/n) play well together including older laptops that can't do n.
  85. tbalon

    tbalon Reformed Router Member

    The Roku played just fine ... what would happen is that in the middle of a film / program it would stop. Then
    after about 1 - 2 minutes we could restart. When I looked at the RT-N16 AP, I could see that it had rebooted
    itself. It would also reboot when we would use PLEX from the iMac ( also on N ). Once I connected the ROKU
    directly, the frequency of reboots diminished. The iMac only connects via N a small portion of the time. It usually
    connects G. I think this is why my stability has improved recently.
  86. though

    though Network Guru Member

    @koitsu that definitely seemed to help. no more packet loss with my tests! now what??

    see below
    Last edited: Jan 6, 2014
  87. koitsu

    koitsu Network Guru Member

    @though -- glad to hear it. Your choices are the following:

    1. Keep WMM disabled (this won't hurt you and is the easiest solution), or,
    2. Re-enable WMM and follow the instructions in this thread instead. Do not let the fact that it talks about Comcast dissuade you; the issue may apply to your ISP as well.

    Regarding #2: because the thread is long/hard to follow, the commands you would place in Scripts / WAN Up would be the following (copy paste this, because the ` marks you see are backticks, not apostrophes):

    modprobe xt_DSCP
    iptables -t mangle -A PREROUTING -i `nvram get wan_iface` -j DSCP --set-dscp 0
    These will take effect automatically every time the router is rebooted. To save yourself a reboot, you can enter the two commands into the CLI or Tools / System. You should not get any output back from the commands.

    You can verify the rule is in place by running iptables -t mangle -L -n -v --line-numbers and should see an entry in the PREROUTING chain with a target of DSCP. Example:

    Chain PREROUTING (policy ACCEPT 136M packets, 45G bytes) 
    num pkts bytes target prot opt in out source destination 
    1 68M 26G DSCP all -- vlan2 * DSCP set 0x00 
    If this does not fix the issue for you, then undo the changes, disable WMM, and reboot the router and just leave it at that.
    though likes this.
  88. though

    though Network Guru Member


    i take that back. whether i have WMM enabled or disabled makes no difference. any other ideas to try??
  89. koitsu

    koitsu Network Guru Member

    Nope. But welcome to why thorough testing matters before immediately saying "that fixed it". "Thorough testing", to me, when it comes to wireless, means literally 1-2 weeks of testing. I'm not exaggerating in the least when I say that either.

    It sounds more like to me that you have some kind of wireless issue that is going on which I cannot debug/assist with. I say that because clicking "Save" in the Advanced / Wireless section reinitialises the wireless driver, which can temporarily relieved problems for people with interference problems or other anomalies. Interference problems usually cannot be solved, especially when things like baby monitors, microwaves, USB 3.0, or other things that you have no control over (i.e. neighbours) impact your wireless connectivity.

    One thing I do know is to use "G Only" or "B Only" or "B/G Mixed" mode and not "Auto", in addition to picking a channel that has a very low number of APs seen on it (rather than using "Auto"). And unlike some, I have found most stability using the geographic region setting of "UNITED STATES" and not "SINGAPORE" (the Tomato default), but I also live in the US. But I use wireless very very VERY little and use Ethernet cables instead -- something that works. :) Some other people have found the internal wireless antennas in their routers to be faulty or hooked up shoddily.

    I myself only have familiarity with the WRTSL54GS and RT-N16. The behaviour varies per model of router, and I have no experience with the RT-N66U.

    TL;DR -- I do not help with wireless troubleshooting, because wireless is an awful protocol that is completely unreliable in its nature and design. 80% of the time wireless troubleshooting requires someone who is physically present and knows how to use very low-level tools correctly (including tcpdump if the issue is deemed to be purely packet-related and not wireless-related). Most people on the Internet are just "forum warriors" and don't actually understand how any of these technologies actually work, so finding a real engineer is a big task. However there are some great folks here on this forum who have good amounts of familiarity with basic wireless troubleshooting, so hopefully one of them can help you. Sorry I can't be of more assistance -- I'm also just very jaded about 802.11 anything.
    Last edited: Jan 6, 2014
    though likes this.
  90. bobyang

    bobyang Serious Server Member

    thanks. yeah. I did "-t nat" it in tomato firmware afterwards, but I thought if it doesn't take it, it should not reboot.

    FYI, I try in IPtables 4.x (Asus wrt) and it doens't work anymore, I must put without "-t nat", it said I should to do filter in -t nat. that's the reason, I want to see if I can do the same command in tomatoUSB. (I tried to keep both the same)

  91. though

    though Network Guru Member

    @Toastman do you have any ideas here??
  92. Porter

    Porter LI Guru Member


    I hope I didn't overlook it in your recent posts but did you enable QoS?
  93. though

    though Network Guru Member

    i did try that but uploads to youtube take FOREVER with Qos enabled.
  94. Porter

    Porter LI Guru Member


    Is it just internet connectivity that is failing or can't you access your router's GUI as well?

    QoS probably needs to be configured correctly.
  95. though

    though Network Guru Member

    @Porter Lan and router GUI is perfectly ok. just pings to wan and web pages become unusable.
  96. Porter

    Porter LI Guru Member


    Seems like network congestion on your WAN interface. If that's the case, QoS is your best bet.

    0. I hope you do have a recent Shibby/Toastman/Victek firmware flashed.

    1. Find some speedtesting website in your area and measure upstream and downstream at different times of the day.

    2. Enable QoS (not B/W-Limiter!). Deduct 15-30% safety-margin from your measured bandwidths and enter those values. Click save.

    3. Try uploading again. Go to QoS/View Graphs and try to figure out in which Class your youtube-upload ends up. The class it should end up in is FileXfer.
    though likes this.
  97. DownSouth

    DownSouth Reformed Router Member

    Hello Toastman,
    First thanks for the incredible amount of info and the wonderful builds.
    tomato-WRT54G_WRT54GL-1.28.7635Toastman-IPT-ND-VPN.bin installed on a WRT54GL v1.1 and with the QOS setup properly allows everything including P2P to work together on a 4096/384 ADSL connection.

    Now the other shoe drops. I flashed it on a WRT54G v1.1. OOPS.
    Had to TFTP the original Tomato 1.28 to recover it which using Router Tools only took a few minutes.
    Almost painless.
    After many fun hours I finally discovered this:

    Seems someone discovered that the WRT54G v1.1 won't load ND bins. OOPS

    Config below
    2Wire 2701 HG-T ADSL 4 port router in Bridge LLC mode ATM offset 32, w Wi-Fi disabled, LAN ->
    WAN [WRT54GL w Wi-Fi, -> LAN1 Magicjack VOIP] LAN4 ->
    WAN{Grandstream HT-486 ATA}LAN -> WAN(WRT54G w Wi-Fi -> LAN ports PC, Media server, Smart TV)

    I will use the GL in the main house with the VPN client, QOS and BW limiting to split between the tenants who like to stream HD video and take all the bandwidth and the G (running Tomato 1.28) in the casita running P2P, which I can limit on my torrent client to 11PM-8AM but prefer not to since I pay the phone/ISP bill.

    Question is do I need to move P2P to a higher class (all my P2P are on specific ports excluded from all other classes and QOS details shows all torrents in the P2P class) or will the BW limiting split things evenly and limit the streaming speed and give more to the casita WRT54G AP.

    I'll try it both ways and report back if you aren't sure.

    Casita WRT54G gets highest priority in BW limit with static IP from the WRT54GL.
    House has all other IP addresses.
    Casita router is on a different subnet so 1 IP is all the house router sees.

    Might be a nice idea to add a note in your Versions.txt file (yep I actually read it) that WRT54G v1.0 & 1.1 won't work with ND builds, yours, Shibby's or anyone else's.

    I learned a lot, and being retired had the time to play with the routers, but don't have the time or more honestly inclination, to build my own non ND bin from the gits http://repo.or.cz/w/tomato.git

    Guess I'll have to have a friend buy and bring down an ASUS RT-12/D1 for me to play with if this doesn't work.
    As that has 8MB of flash and will pass 90Mb/sec it should fill my forseeable needs including IPv6, QOS, VPN.
    Thanks a lot.
  98. Porter

    Porter LI Guru Member


    QoS and B/W limiter don't work together. You will have to choose one.

    Please google or use the search in this forum to find out whether the ASUS RT-12/D1 can cope with QoS and your high bandwidth. From what I have seen, it most likely won't. I can't recommend a router that will.
  99. DownSouth

    DownSouth Reformed Router Member

    Thanks Porter,

    Strange, but I've been using QOS with the BW limiter with success for several weeks now splitting
    between the main PC and all wireless devices.
    I'll try it, since I can't damage anything and if they won't coexist I'll drop the streaming class below the torrenting class, or just BW limit.

    I guess I could use Tomato 1.28 for QOS in the casita and BW limit on the router which everything passes
    through though the QOS in Toastman's release is much more effective.
    What I really want is effective QOS in the casita router and VPN and BW limiting in the house route.

    Do you know of any NON ND Tomato release which has effective QOS? Victek or RAF?

    My bandwidth figures are in kb/s not mb/s so the RT-12/D1 will easily handle it and
    Toastman's release will load on it.
    Measured speeds using ookla are 3.6 Megabytes/sec down, well within the limit of even my old WRT54G.
  100. Grimson

    Grimson Networkin' Nut Member

    Hi, I updated my RT-N16 from an old Teddy Bear build to the current "Tomato Firmware v1.28.7503.5 MIPSR2Toastman-RT K26 USB VPN" build, I did erase the NVRAM and reconfigured the whole unit by hand.

    It's working fine except IPv6. I'm using 6to4 anycast, and while the router gets an IPv6 address, and can communicate over IPv6, the clients don't get an IPv6 address.

    I noticed you removed RADVD in favour of DNSMASQ, seems like 6to4 anycast has been bugged in the process.

Share This Page