1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

** Tomato Toastman's Releases **

Discussion in 'Tomato Firmware' started by Toastman, Dec 18, 2011.

  1. HunterZ

    HunterZ LI Guru Member

    ...and that's why I mentioned that it's not really possible for Tomato. Someone would need to dive into the source code and figure out how to implement support for something like that, assuming it's even possible.
    koitsu likes this.
  2. itsjr

    itsjr LI Guru Member

    I have an IPv6 6rd Relay set up on the latest Toastman and connectivity-wise, everything is working great. I get a 10/10 on test-ipv6.com

    However, I'm noticing that Tomato isn't displaying hostnames for local IPv6 on the QoS: View Details page. My devices get 3 IPv6 addresses, and one of them displays in the Device List. But any connectivity to the outside world does not use this DHCP address and uses one of the other IPv6 addresses that the device gets.

    Should I be able to see host names for each of these IPv6 addresses? Without them, it's hard to make sense of the details page. Also, the IP Traffic section doesn't show any IPv6 traffic at all. Should it show or is this a limitation of the traffic and bandwidth monitoring components?
  3. though

    though Network Guru Member

    I am not a coding master but figure it can be done since default (non-tomato) routers have it, Windows, etc.
  4. Toastman

    Toastman Super Moderator Staff Member Member

    yes ....

    You know, if you consider that perhaps 60% of the users in these apartment blocks use android phones nowadays, and in this country (SE Asia) everyone uploads crap to Youtube every day, it would have been blindingly obvious if the whole internet stopped working. In total, across several apartment blocks, there are maybe 1200 clients or so, if we had such a problem, we would have severe problems many times a day.

    So, when I say, I can't reproduce the problem, I mean, both that I can't reproduce the problem, nobody else ever saw a problem, and we never had any time when the internet stopped working due to mobile phones using wifi. The only time the internet stops working here is when the UPS battery dies following a power outage.
  5. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Toastman is running Jelly Bean. What about the people having problems?
    (with the Android YouTube upload causing timeouts on other devices, just to clarify)

    Reminds me of the old Broadcom Linux WiFi client device driver bug where no other devices could connect at the same time with certain device and AP combinations. It seems to be not a Tomato problem, but a Tomato + specific Android version + specific YouTube app version interaction.
    Last edited: Sep 1, 2014
  6. Toastman

    Toastman Super Moderator Staff Member Member

    @itsjr - at the moment ipv6 isn't fully supported by other sections of tomato. The original developers of those sections stopped working on tomato and are not expected to return (anyone want to guess why?).

    We need someone to take over that work, anyone with comprehensive ipv6 knowledge able to assist ... ?

    Talking about mobile phones and Android in particular, there are many anomalies that crop up. For instance, they ignore instructions by DHCP to use an alternative gateway. I have a lot of mobile phones, but I do view them very much as toys. I always carry a "real" old Nokia with me, the battery of which lasts for weeks and which has never failed to connect to a network. I began to do this after losing a good friend after my "smart" phone consistently failed to ring at an important time.
  7. though

    though Network Guru Member

    Problem confirmed with both Jelly Bean and Kitkat devices.
  8. though

    though Network Guru Member

    *I recommend all users of tomato firmware to apply this until a dynamic solution is implemented by default*

    I fixed the problem by:

    1. start a ping to google (ping www.google.com -t)
    2. open the bandwidth monitor in tomato
    3. open the qos page in tomato and enable it. i max out the inbound (999999) and then proceed to #4.
    4 start a large video (>100mb) upload via the youtube app on an android device and monitor the bandwidth monitor and ping times. if you are getting an upload rate at 6000 kbit/s for example, i suggest taking 90% of that and putting it in the outbound bandwidth limit box which would be 5400 kbit/s then hit save at the bottom of the qos page.

    my tests reveal if you leave ~10% of the outbound pipe free, ping times will not be effected much (if at all) and will allow your network to cruise right along even with the youtube uploads going. this is not a perfect fix, unfortunately. if you isp raises your upload speeds (or decreases it), you will need to go back here and change the value. hopefully a dynamic solution is implemented in a future build.
    Last edited: Sep 2, 2014
  9. cbgbz

    cbgbz Network Newbie Member

    Sorry if I'm hijacking a thread, but I didn't see a place to start a new one. I also couldn't find a search function.

    Does one of the Toastman mods support WPA security in client mode?

    I'm running Tomato 1.28 and it only supports WPA an AP mode.
  10. though

    though Network Guru Member

    yes i am 90% sure client mode supports WPA2.
  11. cbgbz

    cbgbz Network Newbie Member

    Thanks. A couple of more questions.
    1) Since I'm already running Tomato, do I use the upgrade tool on the Admin GUI to load the new version?
    2) Can anyone recommend a version? I have a WRT54GL V1.1 router and the only thing I want to do is set up the router in client mode. Tomato 1.28 works fine as long as I don't need WPA.
  12. though

    though Network Guru Member

    1. yes you can use the upgrade tool. i would do a thorough nvram clear after you flash the new version.

    2. i would suggest: tomato-WRT54G_WRT54GL-1.28.7635Toastman-IPT-ND-Mini.bin
  13. motocrossmann

    motocrossmann Network Guru Member

    I had been able to send magic packets through my router from the internet to my media center to wake it up, but it has stopped working for sometime. I was using this firewall scirpt:

    arp -i br0 -s FF:FF:FF:FF:FF:FF

    Along with a couple of port forwarding rules, but it doesn't seem to work anymore. I'm on 1.28.0505.2

    Any advice?
  14. Monk E. Boy

    Monk E. Boy Network Guru Member

    How exactly would this dynamic QoS solution work? Do you expect Tomato to script an upload to YouTube? Don't you think Google would be a little upset about all those random people uploading videos multiple times an hour?

    These other automatic QoS methods you speak of are consumer solutions that have all kinds of corner cases. Every decent commercial QoS system I've seen is implemented similar to how Tomato handles it (though, admittedly, with a lot more flexibility). Instead of taking a functioning QoS system and replacing it with a barely-functioning QoS system, perhaps we should just ignore all the people who throw their computers out once they get overloaded with malware. You can't fix stupid.

    Why Android? Wouldn't a wired client be the best option for testing? Wireless connectivity is not reliable.
  15. Morac

    Morac Network Guru Member

    I don't know how hard this would be to do, but one method would be to keep track of the total upload speed of WAN traffic (which is done for the bandwidth meter) and store the maximum value and set the QoS to a percentage of that.

    Of course once QoS gets set, that wouldn't work anymore since the upload speeds would then be capped, but there could be a reset button or something to cause the router to re-measure.

    An alternative, which is used by some torrent programs, is to periodically ping a well known stable low latency WAN side address like Google.com (or configurable by the user) and if the ping times get too high throttle back on the uploads.
    though likes this.
  16. though

    though Network Guru Member

    please read the posts and then you can edit or repost...
  17. though

    though Network Guru Member

    ^^^^^^^^^^^^ ok this guy gets it. the ping idea is actually probably going to be the best solution. it would be best for the qos to then throttle the culprit device like 10 or 15% of it's bandwidth to keep the network (and low pings) flowing like it's supposed to.
  18. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    I suggest starting a thread on developing your QoS plan. This thread is for Toastman's firmware.
  19. Blade3609

    Blade3609 Reformed Router Member

    I noticed a bug in 1.28.0506.3 VLAN and STD. I have a RT-N16 and just be sure I did a fresh install (cleared NVRAM after update). The problem is that it router randomly reboots every day, I tried to catch what happens but before it can write it in the logs the router already reboots. I went back to 1.28.0505 VLAN and no problems.
  20. Toastman

    Toastman Super Moderator Staff Member Member

    RT-N16? anyone else? It is stable here.

    Adaptive QOS sounds really nice. But every solution I have seen have disadvantages that I personally think outweigh any benefits. For anyone that wants to try it, I recommend taking a look at Gargoyle.

    Pings? I disagree totally with this one. Using adaptive QOS and similarly anything based on pings, make your QOS dependant on someone elses' problem that you cannot control or fix. It would mean your router severely throttling back your connections if google's remote server gets hit by heavy traffic, if the ISP's gateway becomes overloaded, if any route changes take place in the internet, and so on.

    There are many routers that come in nice shiny boxes trumpeting such amazingly efficient QOS systems. All you have to do is click the button labelled "Fix everything how I want it" and it all works. [Not.]

    That is presumably why there have been around a million downloads of Tomato over the years.
  21. cbgbz

    cbgbz Network Newbie Member

    What's the difference between a .trx file and and a .bin file? Will the upgrade tool use either?
  22. cbgbz

    cbgbz Network Newbie Member

    When I can't get a wifi signal, I use Verizon tethering for connectivity. According to the Verizon usage stats, over 90% of my usage is the result of isolated events that use up several hundred MB of data.

    I think they are the result of some process or app syncing, updating, or something else I didn't explicitly ask it to do.

    Can Tomato help me figure out what's causing me to use up so much data when tethered? What other tools would anyone recommend?

    I used to use a usb dongle that used the Sprint network for connectivity. I didn't have this problem then. The problem started when I started using my cell phone for wifi connectivity.

    I'm starting to smell a rat whose name starts with a V.

    If this is not an appropriate topic for the forum, I'll be happy to take it off line the anyone who is interested.
  23. HunterZ

    HunterZ LI Guru Member

    He said in his post that it is an RT-N16.
  24. though

    though Network Guru Member

    yes and this issue will effect every person that uses's toastman's tomato firmware. with more and more people getting smartphones and uploading videos with resolutions getting higher, storage capacity increasing, 4K coming, this is only going to grow & expand. i only use toastman in my installs, so figure it would be a good place to start here. he can choose to implement something or refer to someone that can (@shibby20 )
  25. Grimson

    Grimson Networkin' Nut Member

    I'd say that most people that go for Toastmans firmware are doing it because they want to configure QoS in more detail than they can with stock. So it's not an issue for most users, in fact it would be a waste of time for Toastman to develop something most user will turn off in an instant.
  26. HunterZ

    HunterZ LI Guru Member

    It would be better to start a new thread because Toastman's is only one of 3 or so major Tomato forks (Toastman, Shibby, Victek, ???). If someone implements your idea independently of a fork then it could potentially be added to all of them.
  27. though

    though Network Guru Member

    i understand that, however if a simple dynamic solution was enabled by default i think it would provide a better end-user experience for everyone. remember, it could easily be turned on or off.
  28. Monk E. Boy

    Monk E. Boy Network Guru Member

    You're still over-simplifying a very complex system. So what happens to your automatic measurements when servers being accessed are themselves overloaded, incapable of saturating your network connection? So now instead of getting your 10-15% less than ideal bandwidth you could easly be looking at 50% or less of your ideal bandwidth. Not because your connection is the problem but because the source of your traffic is. Servers get saturated regularly, and it doesn't take a DDoS to do it (though it could cause similar issues).

    I read through the entire thread, if you would take a minute to read and comprehend what I wrote you could start to understand how complex the problem is that you're facing. The entities whose bandwidth you'll be using are likely to take action (read: block traffic) unless you come to an agreement with them ahead of time - and I say this because it's already happened. NTP is tiny amounts of traffic, just likes pings, but in aggregate it can turn into massive amounts of traffic. Bandwidth is not free.

    If you want to write a new QoS system from scratch, I don't think anyone here is going to get in your way. If it ends up working better, hey, I'll be the first to congratulate you. But you've got a long, hard road ahead of you. No time like the present to roll up your sleeves and start coding.
  29. Vlzinho

    Vlzinho Network Newbie Member

    Hi everyone, sorry if I am asking in the wrong thread, but I was wondering if someone here could answer this.

    What is the correct way to set DNSMASQ to listen on 5353 instead of the standard DNS port 53? Is it server=IP:port or server=IP#port? I am using a DNS service that is able to respond on port 5353.

    Edit: the cute emoji there stands for : followed by a P.
  30. pharma

    pharma Network Guru Member

    Can a MODERATOR please clean last few pages of this thread and move QOS discussions to QOS thread. :)
  31. PBandJ

    PBandJ Networkin' Nut Member

    I think you are

    Is it that difficult to open the man page for dnsmasq and search for the word port?
    koitsu likes this.
  32. koitsu

    koitsu Network Guru Member

  33. gs44

    gs44 Networkin' Nut Member

    WTH... after a few months of happy ipv6 support, TWC went backwards and has shut off ipv6 (Comcast style) and reverted to a 6to4.... I get better results with HE 6to4 then there (TWC) own 6to4.. been this way for 2 weeks now..:(:(
  34. Grimson

    Grimson Networkin' Nut Member

    How is this related to Toastmans Tomato releases?
    koitsu likes this.
  35. gs44

    gs44 Networkin' Nut Member

    Well... Toastman himself has privately messaged me through the past asking about ipv6 support and ect.... So even though I am pretty sure this is not related to his latest version... I figured I would report... Welcome and thankyou..:)
    pharma likes this.
  36. symp_

    symp_ Network Newbie Member

    I am having a problem setting up ipv6. The router obtains an ipv6 address with prefix 64.
    But i need an /120 address according to my isp to get a access my network from outside my LAN.
    Tomato wont let me set prefix higher than 64. How do i get a /120 address?
    Last edited: Sep 23, 2014
  37. Matt Wilson

    Matt Wilson Reformed Router Member

    You say that your router obtains an IPv6 address. Where is that address coming from? Is it coming from your ISP, a tunnel provider such as Hurricane Electric, or some other source.

    In general, any public IP address, be it IPv4 or IPv6 has to be assigned by an outside body of some sort. Unless you happen to represent a large organization that has acquired a block of addresses directly assigned to it, you would generally to public IP addresses from your ISP. If coming from them ask for all the technical details from them you need to set it up. If you share them with us we might be able to figure out what to do with them.

    If you are getting your public IPv6 addresses from a non-ISP organization, such as a tunnel broker like Hurricane Electric you will need to follow their directions for the setup. I can't tell you in advance what those directions would be since I don't know what service, if any, you are using.
  38. symp_

    symp_ Network Newbie Member

    It's coming from a university research network.

    The instructions i got is:
    Each apartment has its own VLAN, where we run dual stack with both v4 and v6. As research network only awards very few v4 IPs for us, these are RFC1918 IPs, while we have been given a larger block v6 addresses.
    Each has a subnet as such. 2001:878:ZZZ:XXX:/64 where XXX is your apartment. Outside-in is opened for all traffic to 2001:878:ZZZ:XXX::100/120 - so if you put your IPv6 IP to be in the range, so you can access it from the outside. Please note we make no filtering at 2001:878:ZZZ:XXX::100/120 so you need your own firewall.

    (ZZZ removed by me)
  39. Matt Wilson

    Matt Wilson Reformed Router Member

    The information you have from them seems to be poorly written and explained, not to mention they seem to be using IPv6 nomenclature in some non-standard or incorrect ways.

    To me it sounds 2001:878:ZZZ:XXX:/64 is the /64 block that is assigned to you, where you have full control of the entirety of XXX. This is what you would be plugging in to your router in the link you provided earlier, only using 64 instead of 120.

    2001:878:ZZZ:XXX::100/120 (again, this looks like work nomenclature to me) is a specific address within the block assigned to you that is unfiltered, ie it is what you would use for incoming traffic if you were hosting a server. You could make it the IPv6 address of your router/firewall and then forward incoming traffic by port to the appropriate destination. You could also assign a different address to your router and then forward all traffic to that address to wherever you want it to go. It all depends on how you set things.

    If you won't be hosting any servers you could skip that address entirely since it would be needed only for inbound traffic.

    I'm making some big assumptions here, but feel free to take this back to whoever provided this information and see if they can verify it or find out where I'm wrong. That said, I'm about 95% percent that I'm accurate in what I said.
  40. symp_

    symp_ Network Newbie Member

    I will be hosting a server.

    How do i configure Tomato to use 2001:878:ZZZ:XXX::100/120?
  41. Matt Wilson

    Matt Wilson Reformed Router Member

    I'm not 100% certain, since this is a thread for toastman, not Tomato. But Toastman is built on Tomato, so much of it is the same.

    Assuming that what I wrote is how they actually intend to use things you don't use the /120. I'm not sure why they wrote it that way, but it seems to done using incorrect notation. Something seems of aside from including the /120, but I'm not sure what is bothering me about it. You use everything before it as the router's IPv6 address. In that same page or another page you would put in all of the /64 information.

    Then you have to forward everything that arrives at that address, to the address of the server that is inside the network.
  42. shadowken

    shadowken Networkin' Nut Member

    Since QOS doesn't classify Layer7 patterns for IPv6 , is there any plans to develop Layer7 for IPv6 soon ?
  43. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    The L7 project ended a while ago. Making new IPv4 filters can be done with some effort, as Porter did for YouTube, but creating an IPv6 version of L7 would be a much bigger undertaking. Last time I checked there didn't seem to be anyone working on it.

    Sent from my HTC One_M8 using Tapatalk
  44. shadowken

    shadowken Networkin' Nut Member

    As for the filters I believe they are the same and checked that with wireshark except the header difference but I mean that the IPv6 libraries code for layer7 aren't included to make it work ...
  45. Elbart

    Elbart LI Guru Member

    Is it to be expected that a E3000 running Toastman's RT-N 0506.3 is being maxed out by a WAN-to-LAN-throughput of around 70Mbits caused by one HTTP-download?
    When having a ssh-session open with top -d 1, the screen-refresh starts to lag when the download-speed comes close to 70Mbit/s, and sirq goes over 90%.

    QoS disabled, around 30 port-forwardings, IP-Traffic- and Web-Usage-Logging disabled.

    EDIT: Tried with reset NVRAM, made no difference.
    Last edited: Oct 2, 2014
  46. gs44

    gs44 Networkin' Nut Member

    Seems about right, My E3000 is Overclocked to 532mhz and at download speeds around 35Mbits/s I see 40% cpu load
  47. Solid-State

    Solid-State Network Guru Member

    I have an Asus RT-N66U running tomato-K26USB-NVRAM64K-1.28.0505.2MIPSR2Toastman-RT-N-VPN-NOCAT and have seen high CPU utilization.

    When I run a torrent and have another PC streaming on my 25/3 docsis service I see CPU usage as high as 30%. I have never see such high utilization in the past and am curious if anyone else has experienced this.

    BTW I have no QoS or logging going on with no VLANs or VPN.


    tomato-K26USB-NVRAM64K-1.28.0506.3MIPSR2Toastman-RT-N-VPN-NOCAT though after first install showing high CPU usage has leveled out and is not showing such high utilization carrying out the same network operations/traffic.
  48. Solid-State

    Solid-State Network Guru Member

    What is sirq listed in top process list?

    Software IRQ?

    I never never seen it this high before using older hardware as my RT-N66U is new.
    Last edited: Oct 8, 2014
  49. Solid-State

    Solid-State Network Guru Member

    I have been using Tomato and DD-WRT for over a decade and recently switched from an RT-N16U to an RT-N66U and up until these two recent builds I never noticed such high software IRQ utilization and this is on slower hardware.

    Something isn't right here!
  50. Morac

    Morac Network Guru Member

    I normally see CPU usage as high as 80% when running speed tests on my E3000. My ISP download speeds are 100 Mbps.

    That said try unchecking the Comcast DSCP fix option and see if that makes a difference.
  51. RMerlin

    RMerlin Network Guru Member

    SIRQ load is usually caused by traffic going through the router.
  52. sunfire7

    sunfire7 Network Newbie Member

    I have an E3000 as well and had to downgrade to 7505.2 because with 7506.3 have the problem of slow browsing, most of the time the pages were stuck in the middle of the load without showing anything, I had to refresh the page to be able to load it. (Erased Nvram everytime and setup from scratch). 7505.2 seems fine. With my 20mbps conection I have aprox 90% cpu load, I only have a dnsmasq script and B/W limiter on, wireless disabled. Overclocked to 532mhz. I don't know if I have a defective unit or something is wrong with the build (because I recall not seeing such high cpu load before), or I simply need a better router.

    Last edited: Oct 9, 2014
  53. PBandJ

    PBandJ Networkin' Nut Member

    I'm experiencing the same thing on my RT-N16, albeit with shibby's mod (see sig for details). Maybe it's caused by some change done recently on both firmwares?
  54. JohnO

    JohnO Serious Server Member

    As a counter example, I have an E3000 that is running well, with low CPU utilization, unless I'm downloading a large file, when the CPU will be in the high 80% range, which seems fine. Granted, I'm not regularly slamming it with large downloads, but on my Comcast 25/5, the 5 computers here have not noticed any change with 7506.3.

    I'm not running any QoS or bandwidth limiter. I do run with wireless on both frequencies.
  55. Morac

    Morac Network Guru Member

    My E3000 is also running normally. I don't overclock. I also don't have QOS or the bandwidth meter turned on. I have a 100/10 connection.
  56. motocrossmann

    motocrossmann Network Guru Member

    I'm editing this post to benefit whoever might find it looking for similar info. I run 2 e3000 routers on Toastman tomato-E3000USB-NVRAM60K-1.28.0506.3MIPSR2Toastman-RT-N-Ext. My goal was to enable the 5GHz radios and create a "premium" network with minimal clients solely dedicated to maximum bandwidth. So, on the 5GHz channels, I setup the two routers on their own channels, with 40MHz width, N-only, WPA2 AES. Both yeilded about 55Mbps, without much work (my WAN supports 120Mbps). To get the speeds higher, I made the following changes: Preamable=short, 802.11n Preamable=greenfield. Overclocking the main router to 533 added about 5% bandwidth, and on the secondary router I moved the LAN connection to the switch (off the WAN port, and disabled the "Use WAN port for LAN" option). Right now I'm getting about 80Mbps on the main router and 90Mbps on the secondary router. Any suggestions on getting more performance are welcome, but I'm pretty happy to get this much out of such old hardware!!! Thanks for the great work Toastman!!!
    Last edited: Oct 24, 2014
  57. sunfire7

    sunfire7 Network Newbie Member

    Regarding my high CPU usage from last post (80% cpu load with a 20/5 mbps conection) I disabled "Broadcast Relay Mode" under VPN PPTP Server settings and now under the same scenario CPU is about 35%. I will keep it disabled if my vpn keeps working good
  58. Toastman

    Toastman Super Moderator Staff Member Member

    Just something that people might find useful to know... i.e. don't always blame routers for slow performance.

    Recently I've been getting so many people complaining about "the internet is slow", I decided to pay them a visit and find out what they actually meant, as I don't see any problem on my PC. Apart from the usual people with virus-ridden machines or laptops with 50 bytes of memory running 30 virus checkers and embedded crap from Baidu, the answer was that the web pages they complain about have so many redirections that the browser is stuck waiting for "googlesyndication.com" or the like. A test on one guy's PC with one site gave 23 seconds load time versus 1 second on mine. Another never actually loaded because it was waiting for some site that never answered. And almost every page is being slowed to a crawl by google's stuff, they are pretty much the worst culprit.

    To get around this, use adblock plus, and ghostery.


    Example - one site was so full of crap that the client died while waiting for it to load. We just found the body next to a burnt-out laptop.

    so many spys on web pages now.PNG
  59. Grimson

    Grimson Networkin' Nut Member

    Well the only pages here that sometimes are slow or get stuck loading, are the ones from the tomato interface. But this has been around for quite some time, I even had it with my RT-N16 and Teddys builds.
  60. PBandJ

    PBandJ Networkin' Nut Member

    I'm experiencing what Grimson describes as well, albeit with the Shibby mod.
    I don't recall having this issue in the past (I flashed tomato-K26USB-1.28.7495MIPSR2-Toastman-RT-Ext after purchasing but never updated till my bad cap issue). Or maybe it was very infrequent.

    A page refresh sorts it out, so it's not a big deal. More of an annoyance.
    FWIW, I'm using Firefox (beta channel) with Adblock Plus, DoNotTrackMe and Flashblock as well as a few other essentials.
  61. RonV

    RonV Network Guru Member

    If you are running internet explorer 9, 10 or 11 you can easily install the adblock plus tracking protection list.

  62. Toastman

    Toastman Super Moderator Staff Member Member

    @Grimson ... Strange you have delays on http pages from the router. I have used tomato from the very early days of Jon's original releases right up to the present time, with Shibby, Victek, and my own versions, and all of them load so fast you can say they have little discernible delay. Excepting perhaps pages such as IP Traffic statistics which take some time for the router to compile and send, but even they are only a few seconds. I have used many different brands of router, none have had a problem with this.

    In a large residential block, some residents actually want or need the advertisements. I have no idea why ... :eek: Thanks Ron for that link.

    As I admin for more than 1200 clients using our routers, I see an awful lot of PC's and Laptops. I have never seen a single one in a resident's possession that compares with the speed of my own PC while browsing the web. There's nothing remarkable about it, granted it is a fast PC using W7 64bit and sufficient memory, but so are many of them.

    When they complain about how slow the internet has become, I sometimes drag them down to my own apartment to see that the problem is most certainly not our router. Most of them have their jaws drop open when they see the majority of web pages open in about a second.

    "Why is mine so slow?" they complain.

    Well, running a toy laptop with pitifully slow 5400 rpm disk drive, 500MB of memory, half a dozen virus checkers, several dozen toolbars, super pc-go-faster (sic), baidu bloat and NOD32, free USB virus checkers (with absolutely free viruses) and other added garbage from every website they ever visited that asked them to click on some dancing teddy bear ... WTF do they expect? And then, the pages they visit are loaded with garbage too.

    Run adblock and ghostery on your web browsers, and delete all of the garbage on your pc. You'll find that most of the problems go away. And for God's sake use a free virus checker that works and not one that costs a fortune and slows your PC to a crawl.

    Running router-based adblock is an option - if everyone needs a solution, and if your router has enough resources to run it on today's increasingly faster internet connections. If not, let the PC do it, it's easier and faster and hassle free.

    My own opinion is that the internet has been taken over by big business, and everything we do is being monitored, spied on, and sold ... and nowhere does that apply more than on Android, where almost every application asks for (and gets) our permission to examine, use, and potentially copy almost everything on the device (including your explicit permission to turn on your microphone and webcam at any time!). Thanks, Google! :D

    My observations are that pretty well every website on the internet is now infested with these tracking cookies and other spyware crap ripping off and sending your private data to someone's server. And the hundreds of people who complain every week about slow internet simply are not aware that their web browser is actually waiting for a site to respond before continuing to the next cookie. Each one that is slow to reply adds several seconds more to the page load time.

    It is no use getting faster internet speeds if big business and our own browsers are now limiting our throughput to the same speed it was 10 years ago. Just look at the source of a typical single web page, it takes up the bandwidth that we used to send several hundred emails in, not so many years ago.
  63. HunterZ

    HunterZ LI Guru Member

    You could run the router based adblocking solution that we maintain on this forum. If you don't use port interception then people can still choose their own DNS servers in the case that they don't want it.
    pharma likes this.
  64. VoYaGeRTM

    VoYaGeRTM Reformed Router Member

    There is just one problem with that HunterZ.
    Mobile phones and tablets :p
    There is no standard way to change the DNS servers in there unfortunately.
    And most users of those devices don't even know how to change them.
  65. HunterZ

    HunterZ LI Guru Member

    Doh you're right. How lame. I suppose they could use a VPN but that's too much to expect.
  66. Grimson

    Grimson Networkin' Nut Member

    It's not delay, most of the times the pages load as fast as lightning. But here and there a page gets stuck loading and it's really stuck then, because no matter how long you wait it won't show up. You then have to abort the browser request and reload the page for it to work again.
    Sometimes you can also notice it when you have something like the Overview page with auto refresh open. It will refresh fine for maybe 5 minutes to 2 or 3 hours and suddenly it doesn't refresh anymore and you have to reload the whole page to get it going again. This is independent from the type of browser you use, I've had it happen with Firefox, IE, Opera and Chrome alike, even with AOSP browser on my phone.

    My personal guess, without checking the source code, is that it's probably some kind of race condition in the httpd used by tomato. I also found it happens more frequently when there is less or no load on the router instead of when there is high load on it.

    Though in the end it's not really a big problem as it happens very infrequently and is just a minor nuisance that doesn't cause any damage or further problems. It just means that sometimes I have to request a page twice, or reload it when I'm monitoring things using the auto refresh option.
  67. mikalai

    mikalai Reformed Router Member

    I noticed jffs2 was removed from the E1200-VPN firmware. There is 8MB flash on the router and the firmware is 4MB, so there is plenty space. Any particular reason why it is removed? It is available on both normal build and the much larger USB build (but funny enough the remaining space isn't big enough for jffs to actually mount :p). BTW there is no USB port on the E1200, not on mine anyway.

    Is there a way to enable jffs through the command line? I tried setting jffs2_format=1 + jffs2_on=1 + commit + reboot and after reboot jffs2_format is back to 0 but I am unable to mount any of the /dev/mtd*

  68. Toastman

    Toastman Super Moderator Staff Member Member

    November 5 2014 - 1.28.7636 (MIPSR1 K24)

    - mininiupnpd 1.8
    - ComcastComcast Fixes: DSCP and buffer overflow. (Thanks Shibby)
    - Add gui for Comcast DSCP fix. (thanks LanceThePants)
    - prevent heartbeat vulnerability, updating openssl will be too large for K24
    - allow usernames (thanks Shadowken)
    - RSA Keylength to 1024


    I don't have any WRT's set up as routers nowadays, so this build has not been thoroughly tested.
    Joe A, HitheLightz and The Master like this.
  69. vajonam

    vajonam Addicted to LI Member

    I am not able to save Bandwidth settings. I am able to write to the CIFS1 folder, creating a new file works. the only thing in the file is RS01. The rstats daemon is running.

    I am running on RT16N with 1.28.0506.3. IP Traffic seems to save fine, not sure whats going to with rstats. any ideas as to where to look?

    Tomato v1.28.0506 MIPSR2Toastman-RT-N K26 USB VLAN-VPN
    here is a listing of my folder.

    ----------+  1 tomato   other      58770 Nov  5 12:00 tomato_cstats_bcaec5c4f69d.gz
    ----------+  1 tomato   other         40 Nov  5 12:32 tomato_rstats_bcaec5c4f69d.gz
    ----------+  1 tomato   other         40 Nov  5 12:32 tomato_rstats_bcaec5c4f69d_1.bak
    ----------+  1 tomato   other         40 Nov  5 12:25 tomato_rstats_bcaec5c4f69d_2.bak
    Every file is only 40k big..
  70. HunterZ

    HunterZ LI Guru Member

  71. vajonam

    vajonam Addicted to LI Member

    No I don't see anything, when I restart rstats, it show rstats stopped/started and nothing more.
  72. Solid-State

    Solid-State Network Guru Member

    Where do I find that option? I don't have IPv6.
  73. Solid-State

    Solid-State Network Guru Member

    Hey Toastman I'm curious if you know where the ARM builds are these days in terms of stability etc. Have you tested/compiled any ARM versions with the RT-AC68U?
    Last edited: Nov 6, 2014
  74. Joe A

    Joe A Connected Client Member

    Thanks Toastman. Looking forward to trying this out.
  75. Eri

    Eri Serious Server Member

    dear sir, just want you to know.
    Since i flash my WRT54GL with your mod: 1.28.7635 std (MIPSR1 K24), i'm unable to delete rule(s) of access restriction page. But i'm able to add, modify/save the rule(s). Then i upgraded to your latest build: 1.28.7636 std (MIPSR1 K24), the problem still occur.
    and another question if you don't mind, is it possible to have more than 50 lines of QOS Classification of your K24 Mod?
  76. Joe A

    Joe A Connected Client Member

    Was the heartbleed bug fixed like this:
    Last edited: Nov 11, 2014
  77. lancethepants

    lancethepants Network Guru Member

    Joe A likes this.
  78. Joe A

    Joe A Connected Client Member

  79. comet.berkeley

    comet.berkeley Addicted to LI Member

    Thanks Toastman!

    I put it on an old WRT54G V3 and it works fine.
    My testing was light. i set up the router as a wireless access point and connected to it from a linux machine in another room.

    I mostly use the old WRT54G as a client for machines with good ethernet but no wireless.
    Joe A likes this.
  80. Toink

    Toink Network Guru Member

    Hi, @Toastman what is your equivalent Shibby firmware for the Tenda W1800R?

    If there's anyone out here who knows, kindly chime in. Much appreciated Thanks! :)
  81. geextux

    geextux Network Newbie Member

    I flashed my WRT54GL with tomato-WRT54G_WRT54GL-1.28.7636Toastman-IPT-ND-VPN.bin. It work just fine. And then setup OpenVPN using this http://dev.mensfeld.pl/2014/07/setting-up-a-vpn-server-on-a-tomato-router-wrt54gl/. Even if "Client address pool - DHCP" is UNCHECK and provide IP range manually, in dnsmasq.conf allways add "interface=tapXX" setting. This is normal or bug?

    I found the source that cause this (release/src/router/vpn.c, line 1176):
    vpnlog(VPN_LOG_EXTRA, "Adding server %d interface to dns config", cur);
    snprintf(&nv[0], sizeof(nv), "vpn_server%d_if", cur);
    fprintf(f, "interface=%s%d\n", nvram_safe_get(&nv[0]), SERVER_IF_START+cur);
    It should check vpn_serverX_dhcp NVRAM before, if 0 (UNCHECK) then skip it. But I'm not sure how to patch it, long time not coding in C/C++ and not familiar with Tomato source code. Hope there are members this forum would write a simple patch for it. Thanks...
    Last edited: Nov 22, 2014
  82. Noodle

    Noodle Addicted to LI Member

    Forgive me, but download link is out of date? (7506.3)

    Where can I download latest version?
  83. Monk E. Boy

    Monk E. Boy Network Guru Member

  84. buffoon55

    buffoon55 Network Newbie Member

    Does Toastman support 5ghz for E3200?
  85. JohnO

    JohnO Serious Server Member

    Depending on your router, 7506.3 may be the most recent release. The recent notes above about the WRT54G release version follows a different numbering scheme than for newer routers.
  86. gg_99

    gg_99 Reformed Router Member

    Do I understand correctly that in the newest release (tomato-K26USB-1.28.0506.3MIPSR2Toastman-RT-N-VPN) for my RT-N16 that OpenSSL / VPN are patched and "safe" against known vulnerabilities? Thanks in advance!
  87. rolfp

    rolfp Serious Server Member

    I've been running a WRT54GL v1.1 for a lot of years, mostly with Tomato Version 1.28, which has been a very solid experience.
    I'm on Comcast HSI, with an eye on getting compliant with their native, dual-stack ipv6 implementation.
    I wonder if there might be screenies of the Toastman firmware that might help me prepare switching my LAN over, which includes a little webserver and DDNS on an ipv4 thin client.
    I gave my backup WRT54GL to my brother and, maybe, I should just pick up another one for the dry run(s). Thanks.
  88. rolfp

    rolfp Serious Server Member

    Got second WRT54GL, will work with that.
    Last edited: Dec 15, 2014
  89. though

    though Network Guru Member

    anyone having issues with their Anroid 5.0 Lollipop devices falling offline using Toastman's release and 5Ghz?

    I am using Tomato Firmware v1.28.0503 MIPSR2Toastman-RT-N K26 USB Std

    both my wife and my Nexus 6 will just drop offline and then connect to LTE when it's in perfect range. it will do this randomly. Never had this issue before when on 4.4.4 (pre-lollipop).
  90. HunterZ

    HunterZ LI Guru Member

    Dunno, my only lollipop device doesn't have 5ghz.
  91. Monk E. Boy

    Monk E. Boy Network Guru Member

    It would help to note the router being used, as the problem may not be universal across all routers.
  92. sunwind

    sunwind Reformed Router Member

    Is there a changelog for the changes in v1.28.7636? Looked around but can't find one anywhere

    Edit: Nevermind. It's a few posts up.
    Last edited: Dec 17, 2014
  93. kudos67

    kudos67 Network Newbie Member

    just a quick thank you

    I tried unsuccessfully for longer than I'd care to mention to install various versions of DD-WRT ( that place is a minefield )

    a quick look at alternatives online brought me here and with little or no problems i had

    tomato-ND-1.28.7633.3-Toastman-IPT-ND-VPN installed and my VPN running perfectly on my old WRT54G V2

    thank you
  94. Toastman

    Toastman Super Moderator Staff Member Member

    December 25 2014 - 1.28.7506.4 and variants

    dnsmasq updated to 2.72+ up to December 9 2014


    It is uploading now, please be patient, it takes awhile...
    though, The Master, Joe A and 2 others like this.
  95. Grimson

    Grimson Networkin' Nut Member

    Thank you.

    If you got the time, after the holidays, could you update OpenVPN too? The currently used version is AFAIK open to an denial of service exploit.
  96. Joe A

    Joe A Connected Client Member

    Thanks Toastman! Happy Holidays!
    Last edited: Dec 26, 2014
  97. Toastman

    Toastman Super Moderator Staff Member Member

    December 31 2014 - 1.28.7507 and variants

    - Dnsmasq 2.72+ up to December 9 2014
    - OpenSSL 1.0.1j
    - OpenVPN 2.3.6
    - Increase no. of QOS rules to 128 (subject to available NVRAM


    ottoemezzo, gs44, Goggy and 5 others like this.
  98. Grimson

    Grimson Networkin' Nut Member

    Thank you, and a happy new year too!
  99. vajonam

    vajonam Addicted to LI Member

    I am looking for support for RT-AC66U Routers, is this planned?
  100. alfred

    alfred Networkin' Nut Member

    I want
    for my RT-N16.

    but, just can not find.

Share This Page