1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

** Tomato Toastman's Releases **

Discussion in 'Tomato Firmware' started by Toastman, Dec 18, 2011.

  1. SNR

    SNR Networkin' Nut Member

    Here's an example of what I'm seeing regarding QoS classification. I'm using the default match rule set from WRT54GS-1.28.7633.2-Toastman-IPT-ND-Std.bin plus four additional rules as listed below:

    magicJack PLUS:
    Src MAC: 6C:33:A9:XX:XX:XX
    Protocol: TCP/UDP
    Class: VOIP/Game

    Apple Push Notification Service (APNS):
    Dst IP:
    Protocol: TCP
    Class: Messenger

    CrashPlan Central:
    Dst IP:
    Protocol: TCP
    Class: Download

    SiliconDust Channel Lineup (for HDHomeRun device):
    Dst IP:
    Protocol: TCP
    Class: P2P/Bulk

    These additional rules are placed within the default set between the group of "Media" rules ending at #21 and the group of "VOIP/Game" rules beginning (by default) at #22. Placing in this location in necessary to prevent the L7-based VOIP rules from mis-classifying some of this traffic.

    Traffic for the magicJack PLUS and HDHomeRun devices is being classified correctly. These are autonomous devices wired directly to my network via D-Link switches.

    Traffic to APNS and CrashPlan Central is being classified correctly for some of the PCs on my network, but for others this traffic is sometimes being classified as P2P/Bulk with rule #255 (i.e. the default class). See below for an example of this problem with traffic to CrashPlan Central. I've also attached a copy of the iptables log.

    It seems that CrashPlan Central traffic that is classified correctly is usually the first traffic for that destination that the router sees. Another (possibly more significant) datum is that correctly classified traffic originates from devices wired directly to the network, while the incorrectly classified traffic is all from wireless connections to the router.

    Hope someone can figure this out. Thanks.

    P.S. Still looking for a proper donation channel for this mod...


    Attached Files:

    BikeHelmet likes this.
  2. BikeHelmet

    BikeHelmet Networkin' Nut Member

    Have you tried setting it to a domain name rather than an IP range? I'm curious how that behaves.

    (So set the QOS rule to central.crashplan.com rather than an IP range)
  3. SNR

    SNR Networkin' Nut Member

    I wanted and tried to do that initially but unfortunately central.crashplan.com resolves to a set of addresses in the 173.225.132.xxx range. For whatever reason, all CrashPlan Central connections on my network are to addresses in the range 209.208.241.xxx (which reverse resolves to the same hostname). So when I specified central.crashplan.com in the rule the traffic would forward resolve to a different range and not get classified correctly.
  4. Rising68

    Rising68 Networkin' Nut Member

    I found the solution, which is maybe also interesting for other Tomato newbies, too. You need to flash the E2000USB firmware to get all these extra features. This is kind of confusing, because the E2000 does not have an USB port. Additionally, I only found instructions talking about only using the non-usb firmwares ...
  5. Toastman

    Toastman Super Moderator Staff Member Member

    Apologies, it's a compile error that meant it was missing from those builds. I'll fix it. Keep an eye on 4shared.
  6. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Still checking but I think I figured out the "see folders and not files" issue. Windows 8 was tested on a couple of laptops and looks like there were some residual corrupt files for network configurations. Like having clients still in a homegroup but they never joined a home group. Had to delete a config file in peernetworking folder. Will check it as I can but I think that was the problem.
  7. lancethepants

    lancethepants Network Guru Member

    Thanks for the awesome work Toastman, looking forward to seeing the latest in the repo too.
  8. Aeon512

    Aeon512 Networkin' Nut Member

    Thanks for the new update. I just installed .7.1 and it works so far perfectly.

    Tested the PPTP server and it works very nice using Mac OS X as a client.
    However, from iOS 5.1 on an iPhone I don't get any connections... On dd-wrt they write a lot about different configuration changes that need to be done to get iOS working, but no success on my side so far.

    Anyone has PPTP with iOS up and running and is willing to share his configuration file, so we can figure out what is missing?
  9. kthaddock

    kthaddock Network Guru Member

  10. asloane

    asloane LI Guru Member

    Since flashing Buffalo WHR-G54S with tomato-ND-1.28.7633.2-Toastman-IPT-ND-Mini.trx the router red light is permanently on. The router had been running Tomato 1.28 without issue. "erase all data in NVRAM memory" was run from the GUI after flashing and the configuration was manually rebuilt.

    Could a bad setting has caused the red light? Several years ago the same router showed a continuous red light because of an issue with a QoS rule in an earlier version of Tomato. Only one simple QoS rule has been added to the many QoS rules in Toastman's build. I am wondering if the router can cope?

    On the QoS page, the error "iptables-restore: line <nnn> failed" is seen - where <nnn> is a number which varies.

    Are there too many QoS rules? Is IPT monitoring the cause of the error?

    I have disabled QoS and the red light is gone, after a reboot.
    Can anyone suggest a fix?
  11. asloane

    asloane LI Guru Member

    The red light has gone off after playing with QoS and other settings. Will report back if the red light returns.

    The error "iptables-restore: line <nnn> failed" is no longer appearing on the GUI Page
    but I have been seeing "unresolved symbol kzalloc" in the message log

    "dhcpc-event[nnnn]: Error while loading rules. See /etc/iptables.error file" is no longer appearing in the message log
  12. asloane

    asloane LI Guru Member

    router red light is back and error messages have returned

    init[1]: Error while loading rules. See /etc/iptables.error file.
    syslog: unresolved symbol kzalloc
  13. Nitro

    Nitro Networkin' Nut Member

    This works only if the teamspeak server has the default port. unfortunately many teamspeak servers are hosted/rented out cheap and usually have a non standard, custom port.

    so this rule only catches some teamspeak sessions.
  14. Nitro

    Nitro Networkin' Nut Member

    @ toastman, could you please watch this episode of "security now" as it talks about "buffer bloat" regarding routers, it would be great to hear your thoughts on the subject.

    Episode #345: http://twit.tv/show/security-now/345

    there is also another group already working on a openWRT version that will fix this issue. I ran the test suggested by Steve Gibson and it resulted in a buffer time of 1300ms for uploads (pretty poor compared to the 100ms result i have for downloads)

    Apparantly linux version 3.3 has some sort of fix for this, and the group over at ceroWRT are implementing v3.3 into openWRT.

    more info on this matter can be found here:


  15. BikeHelmet

    BikeHelmet Networkin' Nut Member

    That is one long webcast. I gave up on watching it after 40 minutes of them talking about Coffee and iPad3's.
  16. SNR

    SNR Networkin' Nut Member

    Short story: Go here and run the The ICSI Netalyzr:


    I've got over 1700ms upload buffering (U-Verse), which is probably a big contributor to our poor VoIP performance at home. And that's how I ended up here, using Tomato to compensate for most of it.
  17. Toastman

    Toastman Super Moderator Staff Member Member

    nitro -

    I couldn't watch this crap all the way through, I get this urge to strangle those idiots. Especially that Gibson guy.

    The original articles were somewhat better presented, and didn't mention coffee or ipads at all. This one is full of the usual self-praising alarmist garbage that we have come to expect from this gentleman.

    However, the subject has been mentioned before in this forum and others with regard to Tomato, tried and tested by several tomato developers and rejected as it did not help at all. If anything it made things far worse. Tomato is already capable of extremely fast pings and site response under full load if set up well. Use the search facility and try to find the posts here and on tomatousb.org.

    If you use online tools to measure things, make sure you understand how they work, there have been many alarmist posts recently

  18. lancethepants

    lancethepants Network Guru Member

    I've given it a listen. There may have something there about router buffers, but I don't think that's really the whole story. The router buffers are in use because the link (either up or down) is becoming saturated, and so packets are being temporarily stored because the line can't handle them. They're talking about a new technology that would arbitrarily start to drop packets before the router gets to the point of filling the buffer. So the people that are using the most bandwidth (connections), it is most likely their connections will be dropped. To me this sounds like a weak form of QoS. If you don't allow your line to become saturated, and you're using some form of packet prioritization, then I think you're fine.

    I just ran the test, and it said I also had 1700-1800ms on the upload. Well right now I'm playing a game, so I think my priority first is going to that. I imagine also most likely their traffic is http/s or is being sent to bulk. To truly run the test, I think you need to disable QoS, and also make sure there is virtually nothing else on the line. I personally think QoS is sufficient, and should eliminate any "buffer bloat" issues that might exist.
  19. BikeHelmet

    BikeHelmet Networkin' Nut Member

    The true solution is to not cap our speeds so arbitrarily low.

    Big buffers are fine. Korea has proved that. They work great when everyone is on 100mbit or 1gbit. There is no bottleneck when emptying the buffer to your PC.

    What we have now is a sink being filled up with a firehose and draining through a regular drain. Many sites would be happy to send you 10MB/sec (saturating a 100mbit line), but they can't. Most (like Youtube) actually do throttling to avoid lagging all of us out. For the technically inclined we can setup QOS, but for most people there is no solution unless their ISP or the other end implements it.
    Mine says 2200ms. That's with QOS on and nothing using my connection. I turned QOS off and got 400ms instead... maybe it's deprioritizing the connection, and thus is taking longer to fill my ISP's buffers?
  20. TheBigTomato

    TheBigTomato Networkin' Nut Member

    Still very much enjoying the had work Toast-man and the other devs have put into keep thing going. Appreciate the hard work very much!
  21. BikeHelmet

    BikeHelmet Networkin' Nut Member

    I have two feature ideas - maybe someone can comment on whether they are possible or useful?

    1) On the Device List page, add a "WAN" column with tickboxes.

    Reasoning: I have two laser printers. I don't want them ever talking to the internet. Also, when I want to run a speedtest without any interference, currently I have to run downstairs and disconnect all the cables manually. It'd be far more convenient if I could just untick some boxes, save the settings, and then all the packets from those particular IPs are dropped.

    Thoughts: Maybe that isn't the correct page for it to be on, since there's no save button. Either way, it'd be useful/convenient to have somewhere. Maybe it's time for the Firewall page to be expanded?

    2) Fairness OFF tickbox (QOS / Basic Settings)

    Reasoning: I don't know if it's even possible to implement this - but I have some traffic that I want to always go first. My VOIP ATA is assigned a static IP by MAC. I then classify its traffic to the highest priority. But that doesn't guarantee other stuff won't go first (even if it's just an ack or something), and ping times when my connection is in use show this. It would be handy to prioritize some traffic above all others, so that every other connection takes a back seat to those prioritized in a Fairness OFF class.

    Thoughts: Probably not easy to implement. Might require changes to the kernel? Ick. :/ You'd also need to warn people to only use it for bandwidth light stuff like VOIP. If you used it for HTTP downloads or something that uses a higher percentage of your connection, it would instantly create massive ping spikes.
  22. Spyros

    Spyros LI Guru Member

    Is there a bug with daylight savings? Time changed in Greece on Sunday (last Sunday of March as always) and still the clock is one hour back, rebooted, played with some settings (tick/untick daylight savings) but problem remains.
  23. streetwolf

    streetwolf Networkin' Nut Member

    Trying to flash with tomato-K26USB-1.28.7497.1MIPSR2-Toastman-RT-Ext.trx After a few seconds my connection is reset and the upgrade stops. Any thoughts on why this is happening?
  24. Planiwa

    Planiwa LI Guru Member

    Perhaps the "QOS Basic Settings" page is functionally overloaded. It might be called "QOS Rate & Limits", since everything else is really "classification" and could be moved to the "Classification" page.

    Then it might be clear: The matter of "priorize this or that" is really a matter of *classification*.

    Somone will say "but those other priorizations may apply to "unclassified" connections". That may be so, but it is still a matter of classification, even if we call it a "unclassified".

    Then those who want to can do what is suggested here -- put a device or host in a class, regardless of what type of packet runs on it. (And, when the VOIP devices start doing HD video conference calls, maybe someone will have to rethink "VOIP above all else. :))

    Actually, they can do it now. Just "priorize" nothing, make the device the "highest" class and lower each of the remaining classes, coalescing two of them. No?
  25. axiom

    axiom Networkin' Nut Member

    Thank you Toastmam/Teaman for your great work on implemeting PPTP server!

    With the new PPTP GUI, how do I go about setting up the firewall/port fowarding to allow port 1723 through?

    Do I have to still create and edit the file /opt/etc/config/vpn.fire and put the following code in it?
    iptables -A INPUT -p gre -j ACCEPT
    iptables -A INPUT -p tcp --dport 1723 -j ACCEPT
    iptables -A INPUT -i ppp+ -j ACCEPT
    iptables -A FORWARD -i ppp+ -j ACCEPT
    iptables -A FORWARD -o ppp+ -j ACCEPT

    I was able to configure the PPTP server and verify that I can connect to it when I am inside my LAN, but wasn't successful on the outside.

  26. Elbart

    Elbart LI Guru Member

    Toastman's 0493 (and probably later) is also affected by the busybox-DST-change-bug, version 1.18.5 (June 2011), bugfix was announced in October 2011, latest stable is 1.19.4 (February 2012).
  27. jsmiddleton4

    jsmiddleton4 Network Guru Member

    So new version with Busybox 1.19.4 coming?
  28. M_ars

    M_ars LI Guru Member

    @toastman: can you make a K26-version for the WRT54GL with vpn + pptp server + multi-ssid in the next release? that would be perfect :)
  29. axiom

    axiom Networkin' Nut Member

    After some digging around I was able to make it work outside of my LAN by adding the following to my firewall script. Is this considered best practice to open up port 1723 and GRE for the PPTP VPN server?
  30. mstombs

    mstombs Network Guru Member

    Its not a specific bug to BusyBox, its anything using the uClibc library on the router - can be fixed by apply a patch to the tomatousb toolchain and rebuilding see http://tomatousb.org/forum/t-456075/auto-dst-not-working-for-england-utc-0000-time-zone for details and a work-around if needed this week, not sure when it will be needed in future!
  31. though

    though Network Guru Member

    hi all,

    maybe toastman or others can answer this simple question...

    what is the largest NTFS formatted drive that i plug into the RT-N16 and have tomato see it and mount it?

  32. streetwolf

    streetwolf Networkin' Nut Member

    I need HELP guys. I was having some issues with my router or firmware, so I decided to do the 30/30/30 reset. To make a long story short my router will not allow me to connect at all. Hoping I didn't brick it what is the method to get it working again?
  33. though

    though Network Guru Member

    did you set a static ip on your pc (like then try to connect to ?

    dhcp is not enabled by default...
  34. streetwolf

    streetwolf Networkin' Nut Member

    Genius, pure genius. Worked perfectly! Thanks a million.
  35. Toastman

    Toastman Super Moderator Staff Member Member

    though, I've seen several people using 3TB drives.
  36. though

    though Network Guru Member

    well i have 2 different 3TB drives and it won't work. it detects it in the GUI but won't let me mount it :\
  37. Toastman

    Toastman Super Moderator Staff Member Member

    Hmm. I added GPT support for HDD sometime ago - patch by Yaniv Hamo. Many people tried it and said it worked for them, mostly of course they were 2TB drives. I don't have USB HDD or docking station to try it myself. Perhaps others will comment if it still works OK.
  38. though

    though Network Guru Member

    i will check which version i have on that particular router tomorrow and reply. attached is what i see when i try to mount it...
  39. Nitro

    Nitro Networkin' Nut Member

    looking at that picture, i dont think you are using the latest version, I just checked my options and there is other format options.

    what firmware version are you using?
  40. pzlmg

    pzlmg LI Guru Member

    3TB HDD works with Tomato Firmware v1.28.0497 MIPSR2-Toastman-VLAN-RT-N K26 USB VPN-NOCAT.
    BTW. I'm using RT-N66U.
  41. fubdap

    fubdap Addicted to LI Member

    Question - I see you have 3 devices attached to the router. I thought the router has 2 usb port. How did you do that?
  42. Toastman

    Toastman Super Moderator Staff Member Member

    Version for Netgear WNR3500L v2 added to last build today.
  43. dkirk

    dkirk Network Guru Member

    Try formatting the drives under EXT3 and I'll bet they mount then. They'll run faster as well.
  44. though

    though Network Guru Member

    i need to be able to plug then in win7 machines too.
  45. psyubl

    psyubl Networkin' Nut Member

    Can someone tell me MD5 sum or SHA1 sum of tomato-K26USB-1.28.7497.1MIPSR2-Toastman-VLAN-RT-VPN-NOCAT.trx?
  46. jsmiddleton4

    jsmiddleton4 Network Guru Member

    "formatting the drives under EXT3"

    Is there an easy way to do this to the attached drive?
  47. dkirk

    dkirk Network Guru Member

  48. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I'll d/l it. You did while it was attached to the router?

    Edit: Looks like the external drive has to be plugged into a PC or Laptop.
  49. pzlmg

    pzlmg LI Guru Member

    i insert a MicroSD card into the internal MicroSD slot.
  50. though

    though Network Guru Member

    well crap... i updated to your latest release and it still won't mount the drive. it sees it but won't mount it :\
  51. Elfew

    Elfew Addicted to LI Member

    My 2TB HDD works great on RT-16N with the latest Toastman build...
  52. chocsoup

    chocsoup Networkin' Nut Member

    Plug in a USB hub. I have two hubs, one that works and another which doesn't.
  53. chocsoup

    chocsoup Networkin' Nut Member

    I use Ext2Fsd to access ext partitions on Win 7 machines.
  54. jsmiddleton4

    jsmiddleton4 Network Guru Member

    In looking for a way to format EXT3 to a router attached device I've seen comments about a Windows driver that enables EXT3 access.
  55. Gitsum

    Gitsum LI Guru Member

    When using this software on my ASUS RT-N66U and I max out my 100mbit download speed, I see CPU usage of around 90%. Is this normal? I would think this router could handle much more speed than that.
  56. CredoS

    CredoS Networkin' Nut Member

    N-16, tomato-K26USB-1.28.7497.1MIPSR2-Toastman-RT-Ext.trx
    The latest firmware. All is lost as USB flash and the same process kltdp / 0 from 70 to 98%

    Mem: 60360K used, 66672K free, 0K shrd, 4164K buff, 26004K cached
    CPU: 0% usr 14% sys 0% nic 4% idle 0% io 2% irq 78% sirq
    Load average: 3.37 4.41 5.90 2/64 21713
    21231 2 root SW< 0 0% 84% [kl2tpd/0]
    19512 19508 root R 1720 1% 1% top
    21229 1 root S 876 1% 0% xl2tpd
    3 2 root SW< 0 0% 0% [ksoftirqd/0]
    21230 1 root S 1316 1% 0% redial
    Error after which disappears USB
    29-03-2012 (debug|daemon|xl2tpd) xl2tpd[22445]: check_control: Received out of order control packet on tunnel 39870 (got 4, expected 5)
    13:01:46 29-03-2012 (debug|daemon|xl2tpd) xl2tpd[22445]: handle_packet: bad control packet!
    13:02:59 29-03-2012 (debug|daemon|xl2tpd) xl2tpd[22445]: check_control: Received out of order control packet on tunnel 39870 (got 5, expected 6)
    13:02:59 29-03-2012 (debug|daemon|xl2tpd) xl2tpd[22445]: handle_packet: bad control packet!
    13:03:03 29-03-2012 (info|kern|kernel) usb 1-1: reset high speed USB device using ehci_hcd and address 2
    13:02:59 29-03-2012 (debug|daemon|xl2tpd) xl2tpd[22445]: check_control: Received out of order control packet on tunnel 39870 (got 5, expected 6)
    13:03:11 29-03-2012 (debug|daemon|xl2tpd) xl2tpd[22445]: handle_packet: bad control packet!
    13:03:11 29-03-2012 (debug|daemon|xl2tpd) xl2tpd[22445]: check_control: Received out of order control packet on tunnel 39870 (got 5, expected 6)
    13:03:11 29-03-2012 (debug|daemon|xl2tpd) xl2tpd[22445]: handle_packet: bad control packet!
  57. Toastman

    Toastman Super Moderator Staff Member Member

    credos, we have no l2tp connections here so we can't test. I have no idea what is causing your problem, sorry. Eventually, someone in E. Europe will probably find the cure and post it.
  58. CredoS

    CredoS Networkin' Nut Member

    Ready to provide the private message or email Root access to the router.
    There is access to DynDNS and NO-IP
    Withso TedyBearsolvedone problem.It may look simplesolution may be?
    Go to a different firmware do not want to considerimperfect
  59. BikeHelmet

    BikeHelmet Networkin' Nut Member

    Many 3TB drives are MBR formatted.

    The traditional MBR limit is 2.2TB - but that's actually a sector limit... and since many 3TB externals now have 4KiB sectors, the limit would be ~16TB for them...

    Hence, many external 3TB+ drives are actually MBR/NTFS formatted.
  60. mstombs

    mstombs Network Guru Member

    Broadcom provide non-GPL binary module code to perform 'CTF - cut through forwarding' and 'fast nat' to bypass a lot of CPU spent doing transfers via the Linux kernel, so you may well find original Asus firmware can go faster with lower CPU load. See some details of Linksys firmware on E4200 in here


    Since Broadcom provide the wireless and switch chipset drivers they are in a unique position to do this in ways which will never feed back into the standard GPL Linux core. Unfortunately this breaks a number of Tomato features such as QOS and stats reporting so attempts to include this in Tomato mods have been unsatisfactory. I think Oleg firmware manages to keep it by sticking closer to Asus firmware.
  61. zorkmta

    zorkmta LI Guru Member

    Hi all, after read differente firmware for Rt- n66u 32k and 60k, but i´m not sure and don´t want to made a mistake and brick ruoter.

    Can someone help me which is a good version stable for RT-N66U? Thanks
  62. nick ant0ny

    nick ant0ny Networkin' Nut Member

    Hi, Between RT and RT-N (both on shibby and toastman) versions what is the only difference? the 5ghz channel only or is there anything better to prefer one from another?
  63. Toastman

    Toastman Super Moderator Staff Member Member

  64. bucher

    bucher Networkin' Nut Member

    Minitool Partition Wizard is free, you can format HDD with it then hook it up to the router.
  65. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Thanks. I found Easus as well. It requires hard drive to be attached to the host computer. I converted mine and played with EXT3 a bit. Because I'm using Win 7 and will be sticking with Windows seems easier to keep the ext drive as NTFS format.
  66. zorkmta

    zorkmta LI Guru Member

  67. BikeHelmet

    BikeHelmet Networkin' Nut Member

    Heh. I just found out that my computer has a 37 second drift in a single day.

    I'm thinking of setting all my computers to poll the NTP servers every 30-60 minutes. Good idea?
  68. Toastman

    Toastman Super Moderator Staff Member Member

    Usually mine have been much better than that, but still, that's good enough for most purposes. The OS usually polls several times a day.
  69. Ensign_Redshirt

    Ensign_Redshirt Serious Server Member

    Hi guys,

    Having some issues getting the pptp server to work with iOS devices. Was hoping someone might be able to take a look at my configuration and give a second opinion. Thanks.

    - Router is a Linksys E4200 with 1.28.0497.1 (nvram erased/thourough). iOS devices are iPhone 4 and iPad 2 with 5.1.
    - PPTP server settings:
    -- Enabled (duh)
    -- Local IP: Matches my routers internal IP/Gateway
    -- Remote IP range: .150-.154 (outside of my dhcp pool)
    -- Broadcast: Both
    -- Encryption: MPPE-128
    -- No DNS or WINS settings (all set elsewhere)
    -- MTU/MRU: 1450
    -- VPN account: testuser : password1234
    - iOS PPTP client settings:
    -- Server: my ddns host name (verified that it's pinging the correct IP)
    -- Account: testuser
    -- RSA: Off
    -- Pass: password1234
    -- Encryption: auto
    -- Send Traffic: All
    -- Proxy: None
    - Added port 1723 to the internal router address
    - Added the ppp/gre firewall script that's been floating around the forums for good measure.

    The error I receive is on the client saying that the server is not responding. I've tried turning up the logging level on the router and searching for things like pptpd, but I'm not seeing much. I should note that this connection seems to work when I'm on local wifi, but as soon as I switch over to 3G it doesn't like me anymore.

    Even if this doesn't end up working, I still want toastman to know how much I appreciate his work. These builds have made my home network fun to play with again, and the updated dlna server in this version seems to be much more stable than what I upgraded from. Has he ever said if there's a place to donate, or maybe a group of developers or charities he likes if there's no direct channel to him?

    EDIT: So I just tried this exact same configuration after letting the router sit for a few hours and it seems to be working now. Strange, as I tried multiple restarts last night with no success. I guess I'm good to go for now (and hopefully this helps someone else with their setup).

    Also, I found a donate button at toastman's yolasite. I'm assuming this is the best place to donate, but please let me know if that's not right.
  70. Toastman

    Toastman Super Moderator Staff Member Member

    I'm glad it began to work for you. The info you gave will I'm sure also help a few people.
  71. chocsoup

    chocsoup Networkin' Nut Member

    Try enabling USB 1.1 support as well as USB 2.0 support, I've read it is required for many USB 2.0 devices.

    Also, did you take that screen shot with a camera?
  72. teaman

    teaman LI Guru Member

    Are you using some sort of dynamic DNS on your router (Basic -> DDNS)? Well, if you do /and/ if, by any chance, your WAN IP address got changed at some point, then I'd suggest you might want to consider the possibility of some sort of DNS cache being related to some of those 'server not responding' errors you got on your earlier attempts (that is, until your router had a chance to update any of those DDNS records and/or any cached info on your client's end would be expired and refreshed with an up-to-date IP address).

    Thanks for bringing that up - cheers!
  73. Nitro

    Nitro Networkin' Nut Member

    no, clearly they put their monitor into their scanner, its good quality scanner too!!
  74. bendiss

    bendiss Serious Server Member

    Hi @all,
    I have following problem with ASUS RT-N66U and Firmware 1.28.0496 MIPSR2-Toastman-VLAN-RT-N K26 USB VPN.
    When I disable my 5GHz wireless network then I can not get any access to my guest wlan wl0.1. This happens with DHCP and static IP. When I turn on the eth2(wl1) again everthing is working fine.

    Is this a known problem?

    Help would be appreciated.

  75. M_ars

    M_ars LI Guru Member

    hi toastman,
    i am not able to set a static dhcp ip for the second ip-range (guest dhcp lan area). My laptop alwasy gets an ip within the dhcp-range instead of desired static ip. Looks like it only works for the primary (default) lan? Does Port Forward also only work for the default/primary lan? I couldnt get it to work. Any ideas?

    My settings with your latest vlan-build: (default home network with dhcp on) (guest network with dhcp on)
  76. lissny

    lissny Networkin' Nut Member

    Does Tomato support User IP/MAC Bandwidth QUOTA??
  77. Ensign_Redshirt

    Ensign_Redshirt Serious Server Member

    You know, I hadn't even thought about DNS caching as an issue, especially on the client (since it is ios and there's no clear way to verify that the cache has been flushed). I guess I was going off the fact that the DDNS service had successfully updated and assumed it was good to go. My modem had been unplugged the entire day so its very likely that it pulled a new IP around the time I began testing. Excellent point, sir.
  78. BikeHelmet

    BikeHelmet Networkin' Nut Member

    I had another idea for a useful feature, if anyone is in the mood to tackle it.

    Bandwidth graphs - Tomato already has 24 hour bandwidth graphs... but what about a way to save them automatically? I have Tomato storing Bandwidth stats and IP Traffic stats to my NAS. It'd be handy if there were a way to get it to save Bandwidth and IP Traffic 24 hour graphs to dated files every day at midnight.

    Just like my past ideas, I have no idea how much work is involved. But I do think it'd be useful. That's the kind of thing that pfsense has. Really useful for determining peak usage times.
  79. Armand1234

    Armand1234 Addicted to LI Member

    Ola sir Toastman :)

    One quick question... is any of your build based on old kernel 2.4.20 ( not ND) ?
  80. BikeHelmet

    BikeHelmet Networkin' Nut Member

  81. Gitsum

    Gitsum LI Guru Member

    So what your saying is that Tomato will never have the proper drivers and will always be "slower" so to speak as when using ASUS firmware? Because I am mainly interested in quick packet forwarding for online gaming. So if Tomato's QOS doesn't work as efficiently as the stock firmware, I guess I'll have to give up some of Tomato's extra features for the better performing ASUS firmware.
    That's a bummer.
  82. Elfew

    Elfew Addicted to LI Member

    OK, is ASUS firmware really so bad? Because on ASUS firmware I have better speed on wifi than on Toastman... stability is not bad... I think the latest version is pretty stable...

    Toastman - why stock firmware has better speed over wifi (on Toastman - about 19Mb/s; on ASUS 29Mb/s)

    (same channel, same place, same hardware and antennas orientation...)
  83. mstombs

    mstombs Network Guru Member

    You shouldn't need high throughput for gaming - you need low latency. Most of us don't get near the upper limits of download speed when the CPU becomes a bottleneck - but saturating the upload channel is a real issue. You should find Tomato QOS much more effective way to prioritize important packets ahead of background traffic - but it does need care to setup.
  84. kaabob

    kaabob Addicted to LI Member

    Is there a way to make incoming OpenVPN connections on UDP 53 be redirected to UDP 1194?
    Read a how-to, but this old code does not seem to work. thanks

  85. lancethepants

    lancethepants Network Guru Member

    Give this a try.

    First, place the following in 'Init' script: This loads a necessary module to redirect incoming ports.
    insmod ipt_REDIRECT

    Then in 'Firewall' scripts:
    iptables -A INPUT -p udp --dport 53 -j ACCEPT
    iptables -A PREROUTING -t nat -p udp --dport 53 -j REDIRECT --to-port 1194

    Then reboot.

    edit: Not sure what issues may arise from DNS using that port, but I have gotten this to work with other ports.
  86. Nitro

    Nitro Networkin' Nut Member

    toastman: I wanted to ask if you had any plans on implementing something like OpenDns Crypt into the routers firmware for those that use openDNS as this could be a great security feature to have.

    openDNS Crypt is already available as a desktop client for mac but the source code is available on github:

  87. FameWolf

    FameWolf Serious Server Member

    I have a Belkin N300 router. I installed tomato-K26USB-1.28.7497.1MIPSR2-Toastman-RT-Ext.trx without a problem however I'm wondering where I can find compatible versions of the mii, usbnet, cdc_ether, rndis_host kernel modules as I wish to tether my android phone to the router. These would normally come in the "extras" package but I can't find that. If there is a newer version even beta that has those I'd appreciate being pointed in the right direction. I attempted to find them on my own...tried to install tomato-K26USB-1.28.9054MIPSR2-beta-Ext.trx which does have the extras file in the same dir and promptly bricked my router. I see it didn't have the RT in the filename so now I'd rather ask before having to do the 30/30/30 to reinstall again.
  88. Elfew

    Elfew Addicted to LI Member

  89. FameWolf

    FameWolf Serious Server Member

    My router gets it's internet from another pc on the lan and shares with rest of house/devices ( the pc tethers to a cell phone and I haven't figured out how to connect the phone directly to the router). Is enabling QOS even worthwhile? I'd like to classify bittorrent traffic as low priority but to prevent internal traffic from being throttled you'd have to specify the speed as either 100megabit or 1 gigabit depending on the speed of your wired connections....or am I missing something?
  90. Elfew

    Elfew Addicted to LI Member

  91. lancethepants

    lancethepants Network Guru Member

  92. maple.chick

    maple.chick Networkin' Nut Member

    I hope WRT54G builds get this feature as well.
  93. Gitsum

    Gitsum LI Guru Member

    I see Shibby's new build, 092, has a checkbox to enable "CTF", cut through forwarding, which makes me think perhaps some new drivers have been introduced???
  94. John Bäckstrand

    John Bäckstrand Serious Server Member

    I upgraded my wnr3500l tonight after getting tired of the DHCP-renew disconnects. I am on a 100Mbps connection and before the router was unable to attain that, I got somewhere between 75 and 85Mbps. Sadly, the version I installed only gets 50Mbps!

    Can I run a K24 build on this router without problems? Or is there a likely culprit as to why the performance would be this much lower compared to a version 6-12 months back? Also thinking about trying stock firmware...
  95. Dutch87

    Dutch87 Serious Server Member

    Thanks Toastman for keeping improving Tomato!

    Because of recent news I have a question / request.

    Is it possible to patch the Samba server in your next build for the purpose of keeping a secure build?

    Samba 3.0.x to 3.6.3 are affected by a vulnerability that allows remote code execution as the "root" user.
    More info https://www.samba.org/samba/security/CVE-2012-1182
    Elbart and Armand1234 like this.
  96. FameWolf

    FameWolf Serious Server Member

    Can anyone point me to any documentation that 1) shows how to compile toastman's git repo and 2) lists the steps to compile additional kernel modules such as mii, usbnet, cdc_ether, rndis_host? This would allow tethering any android phone to the router.

    Additionally, with the difference in upload/download speeds of Edge (2g) vs 3g and 4g....how do you configure your QOS settings? If you configure them for 2g don't you slow your fastest traffic down etc?

    If I have the internet being provided by a pc on the same lan ie router is, internet comes from and other pc's use how could I best configure QOS to make bittorrent and other P2P protocols low priority but not mess with internal lan speed? The actual internet connection is 1 speed (much slower than internet lan traffic which is 300mb per second on wifi and 1 gigabit via wired connections but they are all on the same lan.
  97. Nitro

    Nitro Networkin' Nut Member

    I see 1.28.7498 is now uploaded - where does the changes get listed? :)
  98. eviltone

    eviltone Network Guru Member

    i would think in the change log text thing that he has ---- i forget what it is called.... but if he updated it, the changes will be there!
  99. Nitro

    Nitro Networkin' Nut Member

    I cant find it? is it on 4shared? i had a look before posting but could not see any changelog.txt
  100. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Probably me missing something but devices are not showing up in master or wireless bridge slave with xx98.

    Routers seem to be working, clients working, etc. Just no device listing.

Share This Page