1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomato Toastman's Releases

Discussion in 'Tomato Firmware' started by Toastman, Dec 18, 2011.

  1. jsmiddleton4

    jsmiddleton4 Network Guru Member

    98.2 takes long time to load the device page. Loads eventually but not the usual pop right up once click on Devices.

    The EXT version snaps right to the Device page. The STD version is the one that is slow.
  2. zavar

    zavar Networkin' Nut Member

    Hi Toastman,

    Does 98.2 include Teaman's fix for IPTraffic stqts backup/restore and the larger log file sizes?

    Speaking of filesizes, is there anyway to view and save more than 30 days of the daily traffic logs?
  3. teaman

    teaman LI Guru Member

    If you mean the bugfix mentioned on this post (http://www.linksysinfo.org/index.ph...iped-out-on-setting-change.37440/#post-182742), then... I don't think so: this code has been committed to my local git repo and hasn't been pushed to the public git repo just yet (soon!).

    About the 30 days thingie: cstats is a rstats knock-off. So, basically, it has the same kind of design/limits (except that rstats will store stats for only one WAN interface, whereas cstats has been written to keep track of as many thingies/IPs as it can/memory). In short: no, it's not possible unless there's some major rework in cstats code.

  4. zavar

    zavar Networkin' Nut Member

    That's the update that I meant. Thanks for the explanation Teaman and the very quick reply!
  5. kthaddock

    kthaddock Network Guru Member

    @ Toastman, Teaman

    I have tested 0498.2-nocat and there is some issues.
    On Device list, lease doesn't showing value but dnsmasq seems to working.
    Client dissaper after disconnect doesn't wait out relese time. Slow loading of device list page.

    I can't get port forwarding to work, not sure if problem is here. Can someone else test that ??
    UpnP portforwarding working !

    Saw some deamon warn from PPTP server also.
  6. Toastman

    Toastman Super Moderator Staff Member Member

    Interesting. Will take a look. Device page seems OK here, jsmiddleton also noticed some hiccups.
  7. kthaddock

    kthaddock Network Guru Member

  8. Jacques

    Jacques Addicted to LI Member

    Hi Toastman,
    GUI become slow in tomato-K26USB-1.28.0498.2MIPSR2Toastman-RT-N-VPN.trx i'm back to
    tomato-K26USB-1.28.0498.1MIPSR2-Toastman-RT-N-VPN.trx on RT-N66U
  9. FoxD

    FoxD Networkin' Nut Member

    Hello Toastman, GUI become very slow too on tomato-K26USB-1.28.7498.2MIPSR2-Toastman-VLAN-RT-VPN, Asus RT-N16
  10. Dutch87

    Dutch87 Serious Server Member

    Well, I succesfully updated to Tomato Firmware v1.28.7498 MIPSR2-Toastman-RT K26 USB VPN-NOCAT on my Asus RT-N16

    All woks fine, althoug I experienced one for me personally annoying bug:
    -After a reboot the custom MAC addresses I assigned to the Wireless and WAN are gone, this bug was also present in earlyer version, but not as early as tomato-K26USB-1.28.7493MIPSR2-Toastman-RT-VPN-NOCAT. (and Yes, I always clear the NVram and make all the settings from scratch again by hand...)

    Can this be fixed?

    The reboot now also is much faster at 72 seconds on my Asus RT-N16 instead of 3 minutes, althoug it still takes 3 minutes for all (like wireless internet) to be functional

    Also GUI is not slow here.... :)

    Also bout the discussion on the bandwidht limiter.
    I have an agument for you all that I did not see in the discussion:
    -In many contries it's still normal to NOT have a fair use policy. So people ar bound to an amount af several GB's a month they can use their ADSL line. After that amount they have to pay per several MB over limit, wich can be very costfull.

    Now, if I understand correct. The value of the BW limiter was that you could assign an amount of traffic to a user to give everyone a fair share. Like if you have 5GB per month, you can give each of the 4 users 1GB traffic that month after which their internet speed will be like 5kb/s as penalty, keeping you as internet service provider in the clear of high data costs.

    So for that sake I find it a great loss that the BW limiter is gone and I don't see this functionality in the QoS, which only looks at quality and not a Quantity as far as I understand....

    Will an Acces Restriction Whitelist option added to the GUI? Now you can only blacklist webpages...
    In a medical setting like the one I work, you don't want people to go watch websites which are not essential for their work. This gives the wrong idea to patients, makes work more effective and the systems containing patient data more secure (if they can only watch te hand full of medical database sites and online declaration systems this poses less of a security threat)
  11. Toastman

    Toastman Super Moderator Staff Member Member

    Interesting comments - it behaves as normal in every way (std and extra/VPN) for the things I use it for. All pages are normal here and fast. No messages in logs, I have it running on 4 busy gateways.

    But - I think I will pull the plug on that release if we get any more adverse reports. I had suspected it may have some problems, which is why I have not announced it. Good test, thanks for the feedback folks.

    Dutch87, no, it never had a "quota" system. It was only a realtime bandwidth limiter. At the moment there isn't a Tomato with a quota system.

    No whitelist at the moment, although you could do something with iptables.
  12. kthaddock

    kthaddock Network Guru Member

    YES. agree with that !
    (wifi always takes time to come up especially when you have 2:nd wifi configured, thats normal and alwas been so)
  13. Toastman

    Toastman Super Moderator Staff Member Member

    I'm shortly uploading 2 test versions based on 7498.2 - RT version only

    1) with only the PPOE status progress indicator removed 1.28.0009​
    2) with only dnsmasq 2.6 reverted 1.28.0010​

    TEST BUILD directory​

    Can anyone try these please?

    7498.2 has been deleted.
  14. Rocky Grim

    Rocky Grim Networkin' Nut Member

    No build for the WNR3500Lv2 yet right? Whats the PPOE status progress indicator?

    Toastman, I don't know if this has been reported to you yet or not. I'm using build 1.28.0498. I'm having a problem with the naming of my devices. Under Static DHCP/ARP I have assigned my pc's a name and IP address. However, on the IP traffic monitor sometimes it just shows a couple of there IP address's instead. Other times it will not show the full name.
  15. braindedd

    braindedd Networkin' Nut Member

    Would test for you but I'm getting the slowdowns on the Tiny build.
    Had to do a TFTP recovery when I flashed too, but that was just me not erasing NVRAM I suspect.
  16. FoxD

    FoxD Networkin' Nut Member

    1) With 1.28.0009 problem exist, Web Interface slow and hangs, no lease time in device tab
    2) 1.28.0010 seems to be OK
  17. Andy_113

    Andy_113 Networkin' Nut Member

    I also have the bug with device page taking ages to display details, when it does appear it doesn't display lease times, tried erasing nvram etc with no change. I'm using the 0498.2 usb ext on Asus RT-N66U. Have reverted back to 0498.1.
  18. pharma

    pharma Network Guru Member

    No problems with tomato-E4200USB-NVRAM60K-1.28.0498.2MIPSR2Toastman-RT-N-VPN other than the Device List page opens a few seconds slower than normal.
    Edit: Other notables
    1. Lease is not working in Device List page.

  19. lancethepants

    lancethepants Network Guru Member

    Perhaps only those that use PPPoE are affected.
  20. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Trying test versions now.

    These versions ok for the E3000?
  21. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Not on PPOE here. Just cable. The ext version works just fine. STD is slow for me.
  22. Toastman

    Toastman Super Moderator Staff Member Member

    jsmiddleton, these weren't specifically for the E3000, no. I didn't have time to do one b4 I went to sleep. I'll make one now and upload it. [done] ...
  23. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Getting it now.
  24. jsmiddleton4

    jsmiddleton4 Network Guru Member

    STD version contains USB/EXT stuff. Not a problem and with the quick compile its ok. Device mode still slow. In fact everything slow. After reboot takes long time to assign DHCP addresses, etc., with DHCP server "On". Had to do power off and back on one time to get router back. Seems unstable when setting up, etc. But once up it seems fine.
  25. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Tested the old standby xx83.2. Snappy, device mode snappy, no issues.
  26. Toastman

    Toastman Super Moderator Staff Member Member

    was that 0009 or 0010 ?

    0010 should be better.

    In fact they're all OK here, fast, nothing to say really. LOL
  27. Dutch87

    Dutch87 Serious Server Member

    Thanks for your fast response!

    Sorry for my misinterpretation on quota!! Then I agree with you! QoS is really working well here, especially made easy by your pre-config. I just had to modify it, add a few rules like Steam download services and Quake III Arena, and it works like a charm. Maybe Quota will be an option some day in the future...

    I know iptables is very powerfull. But then I will just cross my thumbs and hope on the whitlisting option to get into the GUI.

    Any idea on why after a reboot it forgets the assigned MAC adresses to the Wifi and WAN port?
  28. Toastman

    Toastman Super Moderator Staff Member Member

    not at the moment, no. I'll have a think about it...
  29. Planiwa

    Planiwa LI Guru Member

    If you are serious about answering that question, I may be able to assist you.
    Q1: does the nvram command find the MAC addresses after you make the change?
    Q5: does the nvram command find the MAC addresses after you reboot?
  30. jsmiddleton4

    jsmiddleton4 Network Guru Member

    xxxx.10 versions.
  31. jsmiddleton4

    jsmiddleton4 Network Guru Member


    Glad to try the test version again. Did you get a chance to change the E3000 STD version so it doesn't have th USB stuff?
  32. Toastman

    Toastman Super Moderator Staff Member Member

    No, I'm out again at another site, no chance to do ...
  33. jsmiddleton4

    jsmiddleton4 Network Guru Member

    No problem. Went back to xx83.2. Was fine. So I tried the test version again. Works fine. Device mode no problem. Did not reset anything. Weird.
  34. Edrikk

    Edrikk Network Guru Member

  35. tenskwatawa

    tenskwatawa Networkin' Nut Member

    Thank you Toastman for you very good job!!!
    I will only add little bug on v1.28.7498 MIPSR2Toastman-RT K26 USB VPN. My router it is - RT-N16.
    I don’t see Lease time on Status – Device List.
  36. Damarr

    Damarr Addicted to LI Member

    Hello Toastman, I have an issue with your builds that I can't figure out and was wondering if you'd encountered it elsewhere.

    When I use the RT MIPSR2 branch, my E4200 works absolutely perfectly. It's stable and I get the full line speed both up and down. When using the RT-N MIPSR2 branch, the router is similarly stable and I get full up speeds, but the down speed never exceeds 5Mbps. I have had this issue with the all of the RT-N builds.

    This happens regardless of how the router is configured (both radios on, one radio on, different frequences, everything on default after a NVRAM wipe, etc). I'm convinced it isn't a settings issue, and the 5GHz radio hasn't blown out or anything similar as when I revert to Cisco's firmware both radios work simultaneously at full speed.

    It's a real pain, as I love your firmware but can't use both radios on my router with it. Any ideas?
  37. Toastman

    Toastman Super Moderator Staff Member Member

    I don't have an E4200 so don't get this problem. There are many people using it though. Anyone else care to comment?
  38. hawkmat

    hawkmat Networkin' Nut Member

    Hi Damarr and Toastman! I have no trouble running Tomato RT-N on the E4200v1
    I have seven E4200v1 in operation around our office complex with one unit being the router and six units acting as AP's.
    I have Tomato Firmware "tomato-E4200USB-NVRAM60K-1.28.0498.1MIPSR2-Toastman-RT-N-Ext.bin" on all seven units.
    I have users on both 2.4 and 5 GHz bands and they all run at the same speed as the factory firmware.
    I'm not sure why the factory firmware works correctly on your unit but a fresh install of Tomato RT-N does not.
    I have a couple spare's units sitting on the shelf so I'll try to duplicate your problem.
  39. LanceMoreland

    LanceMoreland Network Guru Member

    I am running the RT-N MIPSR2 branch on my E4200 without any issues what so ever. If you have an Intel card in your computer, make sure WMM is enabled in Tomato's Advanced Wireless settings or you will be limited to 54G speeds.

  40. cjason

    cjason Networkin' Nut Member


    Installed "tomato-K26USB-1.28.7498.1MIPSR2-Toastman-RT-VPN" on my N16 and I'm very pleased about wireless signal which shows a big improvement over version 7493.

    I have one problem though, VPN server doesn't start. In logs I have this:

    All VPN params are saved in some text files and copied for every installation. They are good because they worked until this version.

    Any thoughts?

  41. Toastman

    Toastman Super Moderator Staff Member Member

    In that version I think I had used Shibby's update to openvpn. It appeared to work OK when I tested it, though. I didn't see anyone else comment on it so far, you are the first. Perhaps we'll get some more feedback from others who have been using it. I'm not an expert on VPN as I never used it in earnest.
  42. M_ars

    M_ars LI Guru Member

    I am using OpenVPN 2.2.2 and everything is working fine (latest shibby/toastman build). In my case all keys and files are stored at/in JFFS (RT-N16 Asus).

    @cjason: maybe there is something wrong with your file... i get no errors at all from openvpn. According to your post - you are still using the "old" version 2.1.1 - dont you?
  43. cjason

    cjason Networkin' Nut Member


    It seems that now all the keys must be copied including BEGIN and END lines, which I never did because it use to work without them . All is working fine now.

    @M_ars: I'm using the latest stable build, 7498.1 that is, along with openvpn binaries included with it. The file is "tomato-K26USB-1.28.7498.1MIPSR2-Toastman-RT-VPN.trx", downloaded form 4shared Toastman's repository. Are you using a different version of firmware?
  44. M_ars

    M_ars LI Guru Member

    @cjason: right now i am using 092V, but i change it from time to time. I like both, toastman and shibby :)
  45. Kila

    Kila Serious Server Member

    I'm trying to use this firmware on my E2500, but it keeps failing when I try to update the firmware.

    Using: tomato-E2000-NVRAM60K-1.28.7497.1MIPSR2-Toastman-RT-Std.bin

    Any ideas why it won't accept it?
  46. M_ars

    M_ars LI Guru Member

    E2500 is not supported!
  47. the_bhagwan

    the_bhagwan Network Guru Member

    I would have tried this and reported back except my situation requires VLAN.
    Love your builds, the awesome QOS + the VLAN I need.
    Just cant try test builds without VLAN
  48. lancethepants

    lancethepants Network Guru Member

    Hey Toastman, I know MIPSR1 2.6 kernel builds aren't that commonly used, but I was wondering if you could update them with your latest QOS.
  49. Toink

    Toink Network Guru Member

    +1 to this please (for Kernel, 2.4 as well)

    I'm currently using tomato-NDUSB-1.28.7633.3-Toastman-VLAN-IPT-ND-VPNNOCAT.trx on my WRT54GS v1.1

    Toast, does 7633.3 have your latest QOS? I'm sorry I'm not so sure it's stated in your changelog...

    Changelog says:

    Graci! :)
  50. Toastman

    Toastman Super Moderator Staff Member Member

    7633.1/2/3 have latest QOS with improved ingress, a real maximum bandwidth limit, and class priorities.

    I am not going to do anything more with MIPSR1 K2.6 versions. Too big, too slow, and too buggy on these old routers.
  51. Dutch87

    Dutch87 Serious Server Member

    Please, although i'm not as skilled as most of you are.
    I think it's a nice feature to circumvent Assisted-GPS databases.

    Q1: Yes, it's changed (seen in inSSIDer) after setting it right in de GUI
    Q5: No, it's reverted to the real MAC adress again
    If this is not the answer you were looking for, please let me know how to obtain that kind of information

    This problem was not present in the earlyer version that I mentioned. No one else having this problem then?
  52. lancethepants

    lancethepants Network Guru Member

    Maybe you could just tell me which branch and which profile I could compile 2.6 for WRT54GL.

    Also for 2.4 too, I checked out the latest tag for 2.4, but but sure how to do the make command.
  53. paladin252

    paladin252 Networkin' Nut Member

    toastman, since you are on the fence about dnscrypt, id like to add my voice to the "please" group. thanks for all of your great work!
  54. Wolfd

    Wolfd Serious Server Member

    hi, everyone.
    I'm using Tomato Firmware v1.28.7489 MIPSR2-Toastman-RT K26 Mini on my Netgear WNR3500
    and can't find ebtables utility.

    I want to use ebtables in order to completly block wifi ip-tv multicast traffic.
    How can i install ebtables ?
    or what firmware should i use ?
  55. lancethepants

    lancethepants Network Guru Member

    I'd like to see a 2.4 kernel for WRT54GL with ebtables, or a hint of how to compile 2.4 branch, I've done 2.6 before for my own purposes.

    How do you compile the K2.4 builds Toastman?
  56. fenhuan

    fenhuan Serious Server Member

    Hi Toastman!

    Thank you for the great firmware for LinkSys E4200 v1. I've found an issue regarding Country code on Wireless Advanced settings screen. Each time router reboots this field returns to its original value. Is there any trick to workaround this?

    I am driving tomato-E4200USB-NVRAM60K-1.28.0498.1MIPSR2-Toastman-RT-N-Ext.bin
  57. rs232

    rs232 Network Guru Member

    Hi Toastman,
    are you planning to all to add a configuration gui for the dnsmasq/TFTP?

  58. Toastman

    Toastman Super Moderator Staff Member Member

    fenhuan, That's strange. I don't have an E4200 but I'll recheck it on the routers I do have.

    EDIT - unable to reproduce this here.

    rs232, not at the moment
  59. Magyosha

    Magyosha Networkin' Nut Member

    I’m using tomato-K26USB-1.28.7498.1MIPSR2-Toastman-VLAN-RT-VPN-NOCATon an asus rt n-16 router.

    Now onto what I am trying to accomplish.

    I’m on a housing estate where certain houses are to have access to this wifi and others are not. My initial setup is standard just using wpa2. However its not ideal as people share passwords. So here we go

    I want to set the wl0 with wpa2 and mac filter to only allow clients who have the password and also have had the mac address listed as permitted.

    I then want to set wl1 (the virtual wifi) with only wpa2 which I will change the password for frequently. The idea being when a new resident wants access I give them the password to this then once they are on I can see there mac and add it to the approved list for wl0

    I think this will work as my understanding (and from testing) is that wireless filter rules are not applied to virtual interfaces, something to do with it being classed as a guest ? which works in my favour for the way I am trying to do it.

    So will this work or is there a easier more correct way of accomplishing this. I ruled out just asking people initially for their mac address when the 1st person replied ‘no I don’t have a mac it’s a pc’

    I wonder if I could bribe toastman with a few beers on walking street to come and help me set it up as he lives not so far away lol
  60. fubdap

    fubdap Addicted to LI Member

    @Magyosha - if you assign static ip to all authorized devices on your network, you can use the feature on the attached screenshot to prevent any unauthorized devices to use your network. The feature is called "ignore DHCP requests from unknown devices" It will not grant network access to anyone that is not on the static ip list even if they know the password.

  61. Magyosha

    Magyosha Networkin' Nut Member

    i thought about using that also. but would just setting a static ip on the computer thus avoiding the need for dhcp not bypass this ?
  62. fenhuan

    fenhuan Serious Server Member

    Just checked again thoroughly. And Country returns to United States (origin of this device) each time router reboots or power failure.
    Probably I can extract some logs and post it here?

  63. the_bhagwan

    the_bhagwan Network Guru Member

    maybe this link will be helpful?

    So maybe try this:

    nvram set wl_country_code="US"
    nvram set wl_country="US"
    nvram set wl0_country_code="YourCountry"
    nvram set wl0_country="YourCountry"
    sleep 4
    nvram commit
    sleep 4

    If that doesn't work, maybe as a work-around, enter this in Administration/Scripts/init
  64. fenhuan

    fenhuan Serious Server Member


    Unfortunately, the sequence above doesn't help. Moreover, variables wl_country, wl0_country, wl1_country were empty. And wl_country_code, wl0_country_code, wl1_country_code always set to US after reboot.

    I've added below script into init section and now it works for me.

    nvram set wl_country_code=DE
    nvram set wl0_country_code=DE
    nvram set wl1_country_code=DE
    sleep 4
    nvram commit
    sleep 4
  65. celaur

    celaur Serious Server Member

    Hi Toastman, I've been using your Tomato mod on my Netgear 3500L since 2 years now, pretty stable and very intuitive on the bdw mangement side, thanks.

    I'm posting now because of the removal of the Bdw Limiter. I must say I never had a problem because of it, so I was not aware it was a source of problems.
    I've been using it a lot in my family as a temporary way to limit my children when they take all of our small (1024 kbps) inbound bdw, or our even smaller (256 kbps) outbound bdw, and we (mom or dad .. :) ) need urgent access.

    I's very convenient because:
    1) very fast to set up and effective immediately, without fiddling with the long classification list (or with ugly scripts as I saw it earlier in the forum).
    2) it amounts to applying a second classification rule to a traffic using different criteria, which can't be done with the normal QOS classifier. Indeed, with the classifier, I understand that only one rule can be matched for a particular "traffic". So I do not see a way to achieve the same thing with only the QOS classifier.

    Illustration by a small example:
    - Using the QOS classifications, I prioritize WOW3 for my elder son and Skype traffics for all, which are small but require low latency, as High in my list. Therefore, they go in front of others.
    - However, in some occasions, I don't want that the total traffic of one of my children (including his/her WOW3 and Skype) exceed 50% of the inbound and 50% of the outbound bdw, when for example he/she is in parallel downloading something and hogging the inbound part, or sharing and filling the outbound part.
    - In those occasions, I still want to prioritize his/her WOW3 and Skype over the other outbound traffics, to keep the general QoS.
    - For that purpose, I use the Bdw Limiter. And since it's very quick to set up, I can react in a matter of seconds if needed, without having to think or find about all I would like to prioritize over him/her which would take hours = "the culprit is quickly identified, let's act, I have other things burning or urgent if for example I am working from home .. :-D".

    So in summary, it allows me to have two matches for each individual traffic of my to-be-limited child: one for prioritizing over or below outbound others, and one on total of all his/her traffics, on both inbound and outbound sides.

    I couldn't find a way to do the same with the QOS since one traffic can only be matched with one rule. Or am I missing something ? If not, I do wish that you will put the bdw limiter back. For now I will stick I guess to 7497.1 which I believe is the latest one having it.
    Sorry for this long first post, and I am all hears if you or somebody else has another suggestion.
  66. Toastman

    Toastman Super Moderator Staff Member Member

    I am putting it back, but without the "default settings for nonlisted IP's"

    That was the cause of most of the complaints.
  67. celaur

    celaur Serious Server Member

    That's good to know, thanks much. I understand then why I never had trouble, I am only using a simple per ip setting.
  68. wilsonhlacerda

    wilsonhlacerda Networkin' Nut Member

  69. lancethepants

    lancethepants Network Guru Member

    While on topic of the K2.4 builds, I would love to see the inclusion of ebtables in K2.4 builds, also for VPN reasons (bridging). I know teddy_b tried this at one point with some glitches, but it would be nice if we had another stab at it. I know it's a little more involved with patching the kernel and all. Just simply a request if possible.
  70. Cumulonimbus

    Cumulonimbus Networkin' Nut Member


    i can conform this. Same Issue on my both E4200v1. My E4200 has Europe als Origin Country-Code. It i set up my 5GHZ-Band to use Channel 157 (only available in US Country) Code, the Original Country-Code is set back to Default, if i changee Setting in Advanced Wireless.
  71. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I've gone back to 7483.2. Was having a problem with a laptop that has Broadcom Dual Band WLAN and the xx98.1 version. Having connection issues. With 7483.2 data throughput and connection are both rock solid. Older broadcom driver in xx83.2?
  72. lissny

    lissny Networkin' Nut Member

  73. anpak

    anpak Networkin' Nut Member

  74. illumilore

    illumilore Networkin' Nut Member

    In logging configuration, whenever I have Custom Log File Path disabled, the logs work fine, but when I have it enabled with "/tmp/mnt/usb_router_4gb/syslog/", the path of a folder in the mount location of my usb flash drive, the logging stops working; no files are created in that location and nothing is shown when I try to view the logs. I assume that it doesn't have to be group or world writable, as other services such as bandwidth monitoring are written by root and log to the usb stick just fine. Am I doing something wrong in my configuration?

    Tomato Firmware v1.28.7497 MIPSR2-Toastman-RT K26 USB VPN

    # ls /tmp/mnt/usb_router_4gb/ -l | grep sys
    drwxr-xr-x 2 root root 4096 Dec 31 1969 syslog
  75. Hackerivs

    Hackerivs Networkin' Nut Member

    on my asus rt n-16 i have firmware 1.28.7497 MIPSR2-Toastman-VLAN-RT K26 USB VPN and the current Uptime is 73 days, 23:50:44
    that is the stablest release i ever had. thank you toastman for your great work!!!

    the only thing that i hate is that my 3g usb modem does not work properly on tomato releases :(
  76. hjf288

    hjf288 LI Guru Member

    So I heard Shibby build 92+ Supports CTF.. any plans to integrate it into your version Toastman? :)
  77. jsmiddleton4

    jsmiddleton4 Network Guru Member

    What is CTF?
  78. Python46

    Python46 Networkin' Nut Member

    Cut Through Forwarding
  79. BikeHelmet

    BikeHelmet Networkin' Nut Member

    Is the Bandwidth monitor broken in 7498.1?

    I just finished upgrading my Asus RT-N16 to: tomato-K26USB-1.28.7498.1MIPSR2-Toastman-VLAN-RT-VPN-NOCAT

    Before that I was running: tomato-K26USB-1.28.7495MIPSR2-Toastman-VLAN-RT-BETA-VPN-NOCAT

    I was hoping that by upgrading I would finally get multiple SSIDs working, but they still aren't working. Also, the bandwidth monitor broke. It stopped recording any changes a few days ago, when I flashed. I reset it, and now it sits with the page completely blank. I checked all share permissions (CIFS share), and there's nothing wrong there. Also, the IP Traffic monitor is working fine, and is saving stats to a different folder on the same share.

    As a last ditch attempt I cleared the NVRAM and re-flashed 7498.1, then reconfigured from scratch - no change, still completely broken. Any suggestions?

    Edit: I also noticed 7498.1 takes a long time to start? With 7495 booting my RT-N16 took about 35 seconds, then at around 40 seconds PPPoE login was complete. With 7498.1 it takes 75+ seconds for the web interface to be accessible, then another ~5 for PPPoE login to complete.
  80. HunterZ

    HunterZ LI Guru Member

    Just upgraded from my trusty old WRT54G to an Asus RT-N16, and installed v1.28.7498 MIPSR2-Toastman-RT K26 USB Ext on it. I noticed that wifi channels 1-4 are missing from the channel dropdown when channel width is set to 40MHz. Is this normal?

    If so, then it seems strange that I can use channel 11 in the US at 40MHz. It also seems strange that it still picks channel 1 when channel is set to "Auto".

    Edit: Okay, I see that the available channel range is controlled by the sideband setting. It still seems strange that "Auto" picks channel 1 when sideband is set to Upper though!
  81. PJON

    PJON Networkin' Nut Member

    I updated last night to tomato-K26USB-1.28.7498.1MIPSR2-Toastman-RT-VPN-NOCAT on my RT-N16 after a few months running tomato-K26USB-1.28.7486.1MIPSR2-Toastman-RT-Ext with no problems

    Today my wife couldn't get online on her laptop even though I carefully set everything up as it was before (captured all the screens and saved them; cleared NVRAM, reflashed and reconfigured). Turns out that the WPA / WPA2 Personal option doesn't work any more with Windows 7 (64 bit). Forcing it to WPA2 resolved.

    FWIW: I don't spend enough time doing admin on the router to know instantly where everything is and had to spend quite a bit of time looking for things -- in all the wrong places all too often. If I wasn't sympathetic to Ubuntu's Unity interface, which permits searching of all menus and string matching on the fly, I am now. This is not a complaint at all. I realize it's complex. A way of dumping a text file with all the config info in human readable form would be good! (not sure if I should trust reloading configurations across release versions). I did notice that the wireless SSID was not reset despite clearing NVRAM.
  82. BikeHelmet

    BikeHelmet Networkin' Nut Member

    Hey, does anyone think multicast port forwarding would be useful? Right now you can port forward to a single IP, but not to a subnet. It seems that there would be select cases where you want to forward packets from a port to all IPs within a range.

    Anyone know how easy it is to implement something like that? I'm guessing GUI-based is out of the question. Near as I can tell iptables doesn't have the capability, so I have to rely on IGMPproxy or Udpxy - but the packets have to be marked multicast? I'm not quite clear on how relay unicast traffic as multicast to a bunch of internal IPs.

    Anyone got a link to a good tutorial or something that I can use to learn more about Udpxy/etc.?

    Edit: Added info to my post 3 posts up.
  83. the_bhagwan

    the_bhagwan Network Guru Member

  84. Toastman

    Toastman Super Moderator Staff Member Member

    June 9 2012 - 1.28.7499 and variants

    NB - until these are properly tested consider them as BETA builds !!

    • IP Traffic: Fix JS error causing initial load delay when default nvram 'tomato' skin
    • ash: fix execution of shell scripts without shebang
    • PPPoE Status Progress - overview page
    • add PPTPD to ext builds
    • dropbear: 2012.55 update
    • dnsmasq: 2.61 update
    • reinstate BW Limiter, but presently with no default limits for unlisted clients.
    • add SNMP configuration options for custom port and remote access
    • fixed "ug" bug (Thanks JYAvenard)
    • Support for Asus RT-N53 (Thanks Shibby)
    • Support for new Linksys E-series routers (Thanks to @tvlz and to Shibby)
    - E1000v2/2.1​
    - Cisco M10v2​
    - E900​
    - E1200v1​
    - E1200v2​
    - E1500​
    - E1550​
    - E2500​
    - E3200​


  85. stefanct

    stefanct Serious Server Member

    hehe bad timing: my old wrt54gv2 died a few days ago and i flashed my "new" e3000 yesterday with tomato-E3000USB-NVRAM60K-1.28.0498.1MIPSR2-Toastman-VLAN-RT-N-VPN.bin.
    i tried to setup a multissid configuration by following http://code.google.com/p/tomato-sdhc-vlan/wiki/MultiSSIDHOWTOForE3000.
    it failed at step 3: the unchecked port of br0 always reappeared to be part of the original interface.

    i have now successfully installed tomato-E3000USB-NVRAM60K-1.28.0499MIPSR2Toastman-VLAN-RT-N-VPN.bin but (the content part of) the Advanced/VLAN page is completely empty.

    PS: do you push to any public git repo besides http://repo.or.cz/w/tomato.git? the latter seems to be not up to date.
    PPS: thx! ;-)

    edit: also, on the Virtual Wireless page it is no longer possible to delete any entries. if i click delete the currently selected entry/line is just deselected.
  86. Riddlah

    Riddlah Networkin' Nut Member

    hey toastman,

    just loaded tomato-K26USB-1.28.0499MIPSR2Toastman-VLAN-RT-N-VPN-NOCAT and there doesn't seem to be any content on the VLAN page. Going to finish configuring and then reflash again to confirm.

    Edit: Erased and reflashed and same bug.
  87. pzlmg

    pzlmg LI Guru Member

    The same here with Tomato Firmware v1.28.0499 MIPSR2Toastman-VLAN-RT-N K26 USB VPN-NOCAT 1.28-0499.png
  88. Toastman

    Toastman Super Moderator Staff Member Member

    Hmmmm yuk. Looking .... you're right. VLAN build is screwed. Where the hell did it go? LOL

    I'll see if I can fix it later this weekend. The normal build seems OK so far, unless I missed something.
  89. stefanct

    stefanct Serious Server Member

    another minor bug i noticed in 0499: the model name in the status overview is mangled: it shows the normal "Linksys E3000" string but followed by a space (0x20) and another weird/unprintable character (0x18). i have not looked at the source that generates the string, so no idea what's the exact cause.
  90. Jacques

    Jacques Addicted to LI Member

  91. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member


    Please can you have a look at including Netgear WNR3500lv2 again in .499 as well.

    Many thanks,

    PS: Thanks for all your hard work on Tomato - I've just retired my WRT54G v3.1 for the above router - currently running Shibby's latest build which really is good... I just don't like the QOS as much, so I'd like to go back to Toastman. I really should donate to both of you!
  92. Pioneer

    Pioneer LI Guru Member

    Is it on purpose that the 1.28.7499 Folder is empty?
  93. kthaddock

    kthaddock Network Guru Member

    Yes, Trouble with VLAN builds.

  94. Nitro

    Nitro Networkin' Nut Member

    I am hoping Toastman has had time to look at dnscrypt to see if he thinks its worth adding, I personally use it, but would like to make the rest of my families computers a bit more safer with this feature built into the router, that way they don't need to do anything or even understand it, they don't even need to know its there, I just need to know they are better off :)

    I am not an expert but I am assuming since shibby managed to integrate it into his version of the firmware, it should be simple enough for toast man since, he has managed in the past to implement other features that shibby has added in the past also.

    anyways hopefully we'll maybe see it in a future version.
  95. stefanct

    stefanct Serious Server Member

    dnscrypt is an opendns marketing gag (most polite wording i could come up regarding this). http://blog.trendmicro.com/dnscrypt-–-not-fundamental-enough/ explains it very well.
    opendns on the whole is very fishy (redirecting to spam instead of replying NXDOMAIN etc). just because something has "open" in it, it does not really need to be without commercial interest or good-hearted.
  96. Seal

    Seal Network Guru Member

    E1000 MiniIPV6: File too big to fit in MTD
    E1000 Mini: No wired access..router only reachable wirelessly
    Both versions Std.
  97. braindedd

    braindedd Networkin' Nut Member

    Netgear WNR3500v2 (4mb) - File too big to fit in MTD :-/
  98. Toastman

    Toastman Super Moderator Staff Member Member

    I'll try to do something about the file sizes over the next few days...

    OpenDNS / DNScrypt stuff is not something I really want to incorporate. Too many business concerns controlling what we do already.
  99. kthaddock

    kthaddock Network Guru Member

    Hello all you.

    I have loaded 099-nocat (11 juni) and it's working very well :) Only thing I have discovered is some garbage in STATUS => OVERWIEW => "Model =>Asus RT-N16 mq1 parent 1: classid 1:1 htb rate %skbit"

    Showing page is extremely fast now, faster that earlier builds :D
    WLAN is working now.

  100. Cumulonimbus

    Cumulonimbus Networkin' Nut Member


    have flushed the new 0499 to my E4200v1, but Router won't boot up after Flash. The white LED flashed two times, then the LED goes OFF. I see, the Router boot's two times. If i plugged in my LAN-Cable in LAN1 - LAN4, the green LAN-LEDs are permanently on. Also the WAN-LED is green if i connect a cable. Any Reason, what's going wrong?

    Yes, i have done a 30-30-30 Reset.

    File that i flashed:

Share This Page