1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tomato upgrade E4200 "File contains an invalid header"

Discussion in 'Tomato Firmware' started by cirrius51, Dec 27, 2011.

  1. cirrius51

    cirrius51 Networkin' Nut Member

    I'm french and I'm really sorry in advance for my English.

    Can you help me?

    here is my problem: I upgraded my firmware on my Linksys E4200 with an incompatible versionof http://www.polarcloud.com/tomato file found -> tomato-K26USB-1.28.9054MIPSR2-beta-vpn3.6. trx

    Now I is accessible only by Wireless in my web interface and not so local cable more opportunities to connect to internet.

    I try many things without success
    - With a firmware upgrade E4200 - error "File contains an invalid header"
    - Several reset and still the same problem.

    I've read in other site that the problem comes from the header of the firmware that has the wrongversion of the router. (for the latter insert my router is not the right)

    I am at my knowledge in this area
    I hope many of you

    I thank you in advance.
  2. Toink

    Toink Network Guru Member

    1. Dowload the tftp.exe utility

    2. Download the latest version of Linksys E4200 firmware from Linksys. Hardware v1

    3. Set a Static IP Address to your laptop/PC.
    Ex. IP Address:
    Subnet Mask:
    Default Gateway:

    4. Now run the tftp.exe utility you have downloaded.
    Set the server IP to
    Password is admin (default)
    Browse for the folder where you downloaded the Linksys E4200 folder
    Set to retry fot 10 times and then hit the Upgrade button

    If in any case the upgrade fails, try to ping the router (in windows open cmd, then type ping -t While the ping is on going in the background, redo step number 4.

    If the upgrade succeeds, wait for a couple of minutes. Then do a hard reset (press the reset button at the back of the E4200). Then flash with the correct Tomato Build.

  3. pharma

    pharma Network Guru Member

    The correct firmware for your E 42oo will contain "E4200" in the firmware name, like "tomato-E4200USB-NVRAM60K-1.28.0493MIPSR2-Toastman-RT-N-VPN.bin". Just to get you started go to http://www.4shared.com/dir/v1BuINP3/Toastman_Builds.html and get the correct firmware. Once you are running Tomato there are other Tomato Mods that offer different functionality that you can use.

  4. cirrius51

    cirrius51 Networkin' Nut Member

  5. cirrius51

    cirrius51 Networkin' Nut Member

    Hello TOING,

    Thank you for your reponce and sorry I could not answer before.

    I made several test with the instructions you give me and here are the results:
    can not connect to the router by cable with static IP (limited connection) but I did still point number 3 as you asked me.

    when I run tftp.exe nothing happens, but when I switch off the router and turn on it starts withtftp.exe UPGRADE (blue bars ahead but stops) but it does not go until the end and ERASEblocks.
    the router will flash (LED CISCO) and when I pass the port cable connects automatic DHCP itlocally but the web interface is blocked, no access.

    I do not know if I have used thee, for I notice is not well understood point number 4 "Set to retry10 times fot and then hit the Upgrade button"

    reset the router after I returned to the same state (tomato firmware with bad names router)

    I thank you again for all this help.
  6. cirrius51

    cirrius51 Networkin' Nut Member

    Hello PHARMA,

    I really took into account the address you give me and I will take this firmware preferably, for the moment I try always to return with an original firmware.

    thank you very much for your help.
  7. cirrius51

    cirrius51 Networkin' Nut Member

    Hello all,

    I always work on my problem (see first post) I am still trying many things.

    I trying to transfer via TFTP Client Windows like interface and TFTP linksys I have the samedefault "server error: transfer canceled" at the launch, the update starts but it stops abruptly.

    I saw the opportunity to put the router in factory mode by causing a shunt (short circuit followingtutorial I've found) is my last possibilities.

    Do you have other less radical solution.

    Thank you again for your help
  8. Toink

    Toink Network Guru Member


    Try this:

    1. Makes sure you do STEP 3 on my first instruction.
    2. Connect directly to the router (using a LAN cable)
    3. Keep the router off.
    4. Start ping (-ing) your router.
    5. Do step number 4 in my previous post. This time set the 'retry' to 99.
    6. Now power up your router and as soon as you did, hit the upgrade button immediately.

    PS. Here's a trick if you can't set a static IP to your PC's LAN. Try to directly connect your LAN to your modem first, and set up your PC's static IP from there. As soon as the static IP is set, connect your PC to your router. and do the instructions above.
  9. cirrius51

    cirrius51 Networkin' Nut Member

    Hello toink,

    really thank you for your help, it helped me find the solution.

    to finish this job, I managed to unlock my situation.

    I explain that everyone can enjoy this experience, I took the file. "bin" that I install I opened with aneditor hexadicimal, it give me the file header I installed in my router, I downloaded the correctfirmware "E4200.bin" and I opened it with the same hex editor and I deleted (for me) line (4200) Irecord and then I use the interface upgrade that tomato this time does not give me the error "Filecontains an invalid header".

    really thank you to all for those who wish can I make copies of the software screen hex ​​file withbefore and after.

    thank you to all

    Good luck .......................................

Share This Page