1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TomatoVPN can connnect to router but can not reach reach to PC connted to the router

Discussion in 'Tomato Firmware' started by ddy, Jul 31, 2011.

  1. ddy

    ddy Networkin' Nut Member

    Please help.

    router : motorola wr850g, tomatoVPN 1.25
    VPN setting:
    Interface Type: TAP
    Protocol: UDP
    Firewall: Automatic
    Authorization Mode:Static Key

    Configuration file
    dev tap
    secret key.txt
    proto udp
    remote XXX.dyndns.org 1194
    cipher BF-CBC

    VPN client (work on WinXP PRO SP3) can connected to the router, and the device list in router show a IP was distributed to the client PC through the virtual network card. but the client PC can not open the web page of the router and can not see/reach the PC behind the router, the PC behind the router can not see/reach the client PC.(When connect the client PC with other PC with same router directly, they can see/reach each other.

    Thanks !
  2. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    Have you tried disabling the firewall on the client PC?
  3. ddy

    ddy Networkin' Nut Member

    Thank you very much for the reply.

    Yes, I disabled the firewall all the time.

    I tried to ping the client from router, can not get through.

    I tried tomatoVPN 1.28, the problem is the same.

    I tried set to default and clear NVRAM, then setup again.

    I tried the tomato dualwan 1.25, try to get PPTP by direct external IP or DDNS, all get error 800, it seems the VPN in toamto DualWan is not working. (the VPN server working in tomatoVPN)

    one thing I 'm not sure will be the cause of problem. My router's MAC address is 00:11:22:33:44:55, it was changed to this after a hard reset.

    Do you have any suggestion, I can try.
  4. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    First, the subnet of the LAN where the client is connecting from is different that the server's LAN, right? If not, it has to be.
  5. ddy

    ddy Networkin' Nut Member

    The problem is exactly what you said, both server and client use the same subnet. It works now.

    Thank you !

Share This Page