1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tomatoVPN firewall problem?

Discussion in 'Tomato Firmware' started by rs232, Aug 25, 2010.

  1. rs232

    rs232 Network Guru Member

    Hello, I have 2 tomatovpn 1.27 running on Buffalo HW.
    A is set as VPN server
    B is set as VPN client
    A-LAN routes are in the B routing table and all the way around pointing to the local P2P TUN interface in output


    Code:
    LAN---B-------------A---LAN
    hosts connected on the B-LAN can access hosts on the A-LAN network, but if I try to connect all the way around it fails. The further I can get from A site (including the A-TUN interface) is the B-LAN IP address of the router which responds to pings only, no https admin interface or ssh despite these are enabled. B-TUN interface is instead fully reachable.

    I`m not quite sure what the problem, the network is actually larger as A is itself the VPN client to another site (C) and the communication between A and C is perfect instead.

    Any tip?
     
  2. SgtPepperKSU

    SgtPepperKSU Network Guru Member

  3. rs232

    rs232 Network Guru Member

    NAT is disabled.
    But bloody window$! Guess what, the main problem was the vista firewall on the target machine as by default allows only LAN connections inbound :-(
    As per the ping only working on the B-LAN interface now also ssh works but for some strange reason the https admin interface via the B-TUN IP address only.
    Not a huge deal, but I'm just trying to understand why:
    Using the browser on the A-LAN
    https://B-TUN:8080 works
    https://B-LAN:8080 doesn't

    I still refer to my other sites where both socket work equally

    Thanks
     

Share This Page